gifts2017

Максимум изменений в стандартной конфигурации при их минимуме с использованием formex.dll

Опубликовал Аркадий Кучер (Abadonna) в раздел Программирование - Практика программирования

Восстанавливаю ранее опубликованную статью. Может кому пригодится...
Иногда очень хочется что-нибудь добавить в стандартную конфигурацию, но потом возникают проблемы, связанные с "затиранием" кода при обновлении. Каждый раз помнить где и что - напряжно.
При данном подходе в Глобальный Модуль добавляется всего одна (!) строчка

В Глобальный Модуль добавляем всего одну строчку:

Процедура ПриНачалеРаботыСистемы()
   
//....................................
   
ОткрытьФорму("Отчет",Контекст,КаталогИБ()+"СтартСистемы.ert");
КонецПроцедуры
// ПриНачалеРаботыСистемы()

Запускаемая при старте системы обработка  "СтартСистемы.ert":

Перем Путь,Имя;
Перем
лСервис; // местная
Процедура Сформировать()
   
// здесь процедуры, ктр. необходимо выполнить при входе ВСЕХ пользователей
   
РасположениеФайла(Путь,Имя);
    ФС.
УстТекКаталог(Путь);
   
лСервис.ДобавитьГлобальныйМодуль("#ЗагрузитьИзФайла ДопГМ.txt");
КонецПроцедуры

Процедура
СформироватьАвтопилот()
   
//-- тут можно написать что-то для режима автозапуска программы
    //-- например, стартануть обработку восстановления последовательности
КонецПроцедуры

Процедура
ПриОткрытии()
    ЗагрузитьВнешнююКомпоненту(КаталогПрограммы()+
"FormEx.dll");
   
// лСервис - локальный контекст, только для загрузки дополнительного Глобального Модуля
   
лСервис = СоздатьОбъект("Сервис");
   
Сформировать();
    Если ВРЕГ(ИмяПользователя())=
"AUTOPILOT" Тогда
       
СформироватьАвтопилот();
    КонецЕсли;
    СтатусВозврата(
0);
КонецПроцедуры


Примерный текст дополнительного Глобального модуля уже подгруженного formex

Перем Сервис Экспорт;
Перем
L Экспорт;
//-- любые другие глобальные переменные
Процедура ПослеОткрытия(Конт)
   
ФормаРасш = СоздатьОбъект("РасширениеФормы");
   
//-- да! забыл... тут лучше поставить блок попытка-исключение,
    //--а то ругается на список Констант
   
Попытка
       
ФормаРасш.УстановитьФорму(Конт.Форма);
    Исключение
        Возврат;
    КонецПопытки;
   
Тип=ФормаРасш.ТипОбъекта();
   
ПолныйТип=ФормаРасш.ПолныйТипОбъекта();
   
// -- далее полный простор для творчества
КонецПроцедуры

//------------------------------------------------------------------------------------------------
//-- в теле модуля - это фактически продолжение ПриНачалеРаботыСистемы()
Сервис= СоздатьОбъект("Сервис"); // это уже глобальная для всей системы
//-- грузим любые необходимые нам DLL
//-- или выполняем другие действия при старте системы
ЗагрузитьВнешнююКомпоненту(КаталогПрограммы()+"MiracleV8.dll");
L=СоздатьОбъект("AddIn.MiracleClass");
L.RUS();
ТекстОкна=" Мой текст";
L.SetMainText(ТекстОкна);
L.SetMainIcon(КаталогИБ()+"Main.ico");


Преимущества подхода:

1. Всего одну строчку добавить в ГМ после обновления.

2. СтартСистемы.ert, и ДопГМ правятся "на лету", никого выгонять из базы не надо.

Изменения станут доступными пользователю после его перезахода в 1С

Недостаток:

При синтаксис-контроле система, естественно, не видит глобальные процедуры, функции и

переменные (например, при их вызове в отчете), объявленные в ДопГМ, и ругается.

 

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Руслан Харисов (fAngel) 15.08.10 12:08
а что мешает свой код в глобальники оставлять выделенным комментариями в конце глобальника тогда и искать процедуру ПриНачалеРаботыСистемы не придется и синтаксические ошибки можно проверить и никаких сюрпризов с ЗагрузитьИзФайла
2. Аркадий Кучер (Abadonna) 15.08.10 12:12
(1) Ничего не мешает, но:
1. Надо искать различия в тексте :(
2. Надо народ выгонять, ежели надумаешь что-нибудь поменять (не обновление, а текущее изменение). А кто работал с толпой отмороженных юзверей числом в 50 человек знает как это не всегда просто.
А проигнорировать якобы ошибку, связанную с ДопГМ, какие проблемы?
Плюс к тому: знаю кучу народа, который активно уже пользует ДопГМ, и даже не один
3. Аркадий Кучер (Abadonna) 15.08.10 12:18
Кстати, я очень активно использовал ЗагрузитьИзФайла и для модулей форм и проведения для особо часто меняемых документов/справочников. И никаких сюрпризов эдак лет за пять не наблюдал. Зато удобств - целая куча.
Пример из жизни: запретил запись Контрагента с пустым ИНН. Заплакали бухи мат. группы, им приходит накладная на материалы, приходовать надо, а в накладной ИНН нема... Будет только через несколько дней в Счет-фактуре. Модуль элемента Контрагенты у меня во внешнем файле, легкое движение руки - и мат. группа снова счастлива.
И никаких воплей остальных: "у меня там... а вы...!"
4. Александр Венгер (venger) 15.08.10 15:06
5. Аркадий Кучер (Abadonna) 15.08.10 15:07
6. Александр Венгер (venger) 15.08.10 15:09
(5) С разукрашкой - это отсилы минута, со вставкой уже в публикацию и т.д.;-) Эт я так поворчать;-)
7. Аркадий Кучер (Abadonna) 15.08.10 15:11
(6) Надо ж еще с разукрашкой разобраться... Я по сей день толком понять не могу, как картинку в статью вставить :( Требует URL, на файлообменник что ли закидывать?
8. Александр Венгер (venger) 15.08.10 15:37
(7) Я в профиль в фотки кидаю, а в урле дописываю www, перед infostart....
9. Аркадий Кучер (Abadonna) 15.08.10 15:39
(8) Почему было не сделать нормально, как обычное прикрепление файла - со своего HDD? :(
10. Аркадий Кучер (Abadonna) 15.08.10 19:24
(4) Сань, я исправился :D
Пойду гляну, если не ставил плюс за разукрашку - поставлю.
Однако, ставил: "Вы уже голосовали..."
11. Александр Венгер (venger) 15.08.10 19:56
(10) О, как красивее стало;-) Да и как потом другим объяснять, что мол раскрасте, если сам Abadonna не раскрашивает;-)
12. Аркадий Кучер (Abadonna) 15.08.10 19:58
13. Епрст (Ёпрст) 16.08.10 07:59
....а для всего остального.. есть turbomd.dll
14. Victor Nespyatin (victuan) 16.08.10 08:15
(3) У меня для таких случаев давно ПодключаемыйМодуль 1с++ трудится.
15. Епрст (Ёпрст) 16.08.10 08:17
+13 ибо при #ЗагрузитьИзФайла нет возможности поправить форму и моксель..
А это - не комильфо..
16. Аркадий Кучер (Abadonna) 16.08.10 08:18
(14) Можно и так, только когда я начинал "ЗагрузитьИзФайла" 1с++ еще и в помине не было
17. Епрст (Ёпрст) 16.08.10 08:22
(16) да, но turbomd.dll появилась очень давно..
18. Аркадий Кучер (Abadonna) 16.08.10 08:24
(15) Справедливо. Но мне обычно в 90% случаев хватает обработки ПослеОткрытия()
Че-нить там на форме прикрыть, сделать так чтобы у разных юзверей с одинаковым набором прав они были все-таки чуть разные, не плодя лишних прав в Конфе и т.д.
19. Епрст (Ёпрст) 16.08.10 08:24
+17 году так..в 2004 ..
а ВыполняемыйМодуль - так вообще совсем недавно..максимум год-два..
20. Аркадий Кучер (Abadonna) 16.08.10 08:25
(17)
но turbomd.dll появилась очень давно..

Если честно, я её вообще просохатил :D
21. Епрст (Ёпрст) 16.08.10 08:26
(18) форму чего-либо часто приходится править, особо, если это не типовая конфа..или есть новые объекты - форму журналов/списков..
Да и встроенные отчеты приходится править.. тот-же моксель в нём...
22. Аркадий Кучер (Abadonna) 16.08.10 08:30
(4) Сань, я не только исправился, но и перевыполнил план ;)
Вот тут результат:
http://infostart.ru/public/73902/
23. Алексей Константинов (alexk-is) 16.08.10 08:40
(0) Картинки для главной страницы не хватает
24. Аркадий Кучер (Abadonna) 16.08.10 08:45
(23) Дык а что туда сунуть? От фонаря, или кода кусок?
Заценил мою доработочку "Разукрашки" под Дельфю? ;)
25. Александр Рытов (Арчибальд) 16.08.10 08:59
(24) Ну, раз ты к конфе кое-что прикрутить позволяешь...
Прикрепленные файлы:
26. Алексей Константинов (alexk-is) 16.08.10 09:03
(24) Да. Заценил. Для внешнего набора ключевых слов оставлял версию "Разукрашка (2.1.0.2)"
Теперь подумываю как прикрутить подобный механизм к (3.1.0.2). При работе с запросами теперь ведь используется не один, а два набора ключевых слов. Соответственно старые методы уже не подходят.

По поводу картинки. Когда не знаю что нарисовать, ставлю коробку с ракетой :)
27. Аркадий Кучер (Abadonna) 16.08.10 09:14
(25) Приболчено, насяльника ;)
28. Аркадий Кучер (Abadonna) 16.08.10 09:21
(26)
Теперь подумываю как прикрутить подобный механизм к (3.1.0.2)

Самое прикольное, что я скачал сразу версию 3.1.0.2, но и наборы слов XML, и долго недоумевал какого лешего у меня ничего не меняется после изменения XML ;)
Пока не догадался в модуль глянуть
29. MIK В (mikukrnet) 16.08.10 17:19
Для полноты картины надо еще меню заменить на динамическое http://infostart.ru/public/66085/
30. Аркадий Кучер (Abadonna) 16.08.10 17:42
(29) Ну я примерно это и подразумевал, когда писал
//-- грузим любые необходимые нам DLL
//-- или выполняем другие действия при старте системы

;)
31. MIK В (mikukrnet) 17.08.10 12:34
А нельзя ли по аналогии с turbomd сделать скрипт для OpenConf который подгружает дополнительный глобальный модуль в основной глобальник, а при закрытии конфигуратора - выгружает обратно.

Решился бы вопрос с синтаксическим контролем. Иначе дополнительный глоб. модуль фактически нежизнеспособен, ведь правильно было б взять его и почти целиком выгрузить во внешний, чтоб потом на лету менять все что понадобится
32. Аркадий Кучер (Abadonna) 17.08.10 14:39
(31) А попроси умельцев по OpenConf, может приделают.
Но я как-то обходился и с кривым синтаксис-контролем...
Как минимум два года особых напрягов не возникало
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа