Оповещения пользователям об изменении конфигурации

Опубликовал Павел Опарин (opx) в раздел Программирование - Работа с интерфейсом

Как сообщить всем пользователям, что добавлен новый, очень нужный и полезный механизм в 1С: Предприятие 8.1 или 8.2? В этой статье я расскажу как это сделать с минимальным исправлением конфигурации поставщика.

Как сообщить всем пользователям, что добавлен новый, очень нужный и полезный механизм в 1С: Предприятие 8.1 или 8.2? В этой статье я расскажу как это сделать с минимальным исправлением конфигурации поставщика.

1. Создаем регистр сведений "ОповещениеПользователей" непериодический, независимый с измерениями: Пользователь (СправочникСсылка.Пользователи), Дата (Дата), Владелец (СправочникСсылка.Пользователи); Ресурсы: Просмотрено (Булево), Оповещение (СправочникСсылка.ВнешниеОбработки, Строка)

2. Создаем общий модуль, напр.: опМодуль (глобальный, Клиент (обычное приложение)

Этот модуль имеет следующий текст:

Функция ВывестиОповещение(ИмяОтчета);
    ИмяФайла = ПолучитьИмяВременногоФайла();
    Отчет = Справочники.ВнешниеОбработки.НайтиПоНаименованию(ИмяОтчета);
    ДвоичныеДанные = Отчет.ХранилищеВнешнейОбработки.Получить();
    ДвоичныеДанные.Записать(ИмяФайла);
    опФорма = ВнешниеОбработки.ПолучитьФорму(ИмяФайла);
    опФорма.Открыть();
    УдалитьФайлы(ИмяФайла);   
КонецФункции

Процедура ПроверкаНовыхОповещений() Экспорт
   
    ОтборПользователей = Новый Структура("Пользователь");
    ОтборПользователей.Пользователь = ПараметрыСеанса.ТекущийПользователь;
    Оповещения = РегистрыСведений.ОповещениеПользователей.Выбрать(ОтборПользователей);
    КолОп = 0;
    Пока Оповещения.Следующий() Цикл
        Если Оповещения.Просмотрено Тогда
            Продолжить;
        КонецЕсли;
        КолОп = КолОп + 1;
    КонецЦикла;
    Если (КолОп>0) Тогда
    ВывестиОповещение("Оповещения пользователя");
    КонецЕсли;
КонецПроцедуры

Процедура ЗадатьИнтервал(Интервал) Экспорт
    ПодключитьОбработчикОжидания("ПроверкаНовыхОповещений",Интервал,Ложь);
КонецПроцедуры

Процедура ОчиститьИнтервал() Экспорт
    ОтключитьОбработчикОжидания("ПроверкаНовыхОповещений");
КонецПроцедуры

3. Исправляем процедуру ПриНачалеРаботыСистемы() - добавим строку в конец процедуры:

ЗадатьИнтервал(60);

На этом исправления конфигурации поставщика заканчивается

4. Качаем приложенные обработки

5. Добавляем как внешние обработки и обзываем их следующим образом:

ОповещенияПользователя.epf - "Оповещения пользователя"

Оповестить.epf - "Оповестить"

ДобавленОтчет.epf - "Добавлен отчет" (это для примера)

6. Редактируем макет обработки ДобавленОтчет.epf под свои нужды (вставляем картинки, таблицы, пишем текст). Кто не знает как редактировать макет - пишите мне лично, может быть подскажу.

7. Запускаем обработку "Оповестить", выбираем в ней обработку "Добавлен отчет" и пользователей, которые должны получить это оповещение.

8. Принимаем звонки с вопросами типа: "А что это там у меня вылезло?" :)

Скачать файлы

Наименование Файл Версия Размер
Комплект Обработок Для 1С 8.1
.zip 17,99Kb
21.02.13
206
.zip 17,99Kb 206 Скачать
Комплект Обработок Для 1С 8.2
.zip 36,02Kb
21.02.13
87
.zip 36,02Kb 87 Скачать

См. также

Комментарии
1. marat_n q (marat_n) 103 20.08.10 14:07 Сейчас в теме
А механизм "ЗадачиПользователей" в типовых для чего?
2. Павел Опарин (opx) 426 20.08.10 17:15 Сейчас в теме
ЗадачиПользователя для задач, а оповещения для оповещений
3. Александр Зубцов (iov) 359 21.08.10 12:21 Сейчас в теме
(2) Согласен с marat_n если есть механизм типовой то зачем создавать фактически аналогичный ? Либо тогда добавляй обязательное прочтение с согласием , разделение по группам пользователей (например менеджерам не нужен новый механизм автоматического проведения счетов фактур - это бухгалтерские дела) и показывать только выбранным. Установить отчет по ознакомлению + возможность скачать документацию для прочтения вне конфигурации. Раздели режимы( срочно-важно - открывается принудительно и монопольно, обязательно к прочтению-открывается не монопольно , уведомление- открывается пользователем ).
4. Павел Опарин (opx) 426 22.08.10 19:20 Сейчас в теме
Интересно. Кто-то смотрел эти обработки?
1. Возможность передать в оповещениях внешнюю обработку
2. Постоянное напоминание, пока оповещение не будет прочитано.
3. При отправке оповещения возможность выбора нескольких пользователей.
4. Просмотр уже просмотренных оповещений.
Как мне показалось задачипользователя несколько не расчитаны для вышеизложеных задач.
Никого ставить это не заставляю. Выложил здесь для того, что "а вдруг кому нужно" :)
5. Валерий Дубовой (Valerich) 1616 26.08.10 12:09 Сейчас в теме
интересная идея,

а использовать запрос в проверке новых оповещений по каким причинам нельзя?
6. Павел Опарин (opx) 426 26.08.10 15:13 Сейчас в теме
Не знаю... огорчу я Вас или обрадую, г-н Valerich, но таких причин нет. По мне так каждый разработчик выбирает сам как это делать. А считать микросекунды (скорость выполнения) из-за максимум 1000 записей - неинтересно.
7. OBEH (OBEH) 26.08.10 15:38 Сейчас в теме
Ох и любят 1-эсниги булево. Неужели, нельзя вместо Просмотрено (Булево), ставить Просмотрено (Дата, время)? Информативность гораздо выше в такого рода событиях.
8. Павел Опарин (opx) 426 27.08.10 13:09 Сейчас в теме
Возьму на заметку. Хорошая мысль ОВЕН, хоть со своими плюсами и минусами, но в контексте данной задачи это было бы кстати ;)
9. OBEH (OBEH) 27.08.10 13:56 Сейчас в теме
А это, по моему, практически в любом контексте правильнее. Дату использовать, как булево. Заодно, видно время события, если приспичит узнать
10. OBEH (OBEH) 27.08.10 14:00 Сейчас в теме
Вот меня сейчас просто бесит, что приходится из конфы на 7.7 к себе в 8.2 таскать целый справочник. А там уже более 96 тыс. позиций. Предлагаю, при любом изменении, ставить дополнительном поле дату. Делов то, на 1 минуту. И конфа самописная. Но москалям лень этим заниматься. Так бы брал только измененные после определенной даты записи
11. Clere (Clere) 02.09.10 15:51 Сейчас в теме
мне понравилось! просто и со вкусом:) плюсую
12. Павел Опарин (opx) 426 07.09.10 14:53 Сейчас в теме
Один хороший человек подсказал, что в 8.1 не работает и то, что он не может более одного файла скачать. Быстренько переделал. И теперь это можно скачать одним файлом и для различных платформ :)
13. isn Игнатьев (isn) 12 27.10.10 18:45 Сейчас в теме
Обнаружил не большую ошибку в регистре сведений реквизит "Пользователи", а в обработке оповестить ЗаписьРС.Пользователь = Стр.Пользователь;
в целом мне понравилось. ставлю +
14. isn Игнатьев (isn) 12 29.10.10 11:21 Сейчас в теме
Думаю для новичков надо подготовить конфигурацию с реализацией данного оповещения на двух платформах: на 8.1 и на 8.2. Для просмотра примера реализации
15. isn Игнатьев (isn) 12 29.10.10 12:30 Сейчас в теме
в виде дополнения к выше описанному заданию. при создании в регистре сведений "ОповещениеПользователей" Пользователи (СправочникСсылка.Пользователи) необходимо установить "Индексировать". Иначе поле выбора работать не будет
16. Пуд (Пуд) 09.11.11 12:29 Сейчас в теме
Единственное, что расстраивает - необходимость исправления ПриНачалеРаботыСистемы(), когда конфигурация на поддержке незаметно число таких изменений растет и растет...
17. MOHAX (MOHAX1905) 20.01.12 14:10 Сейчас в теме
19. Sergey Ponomarev (SPonomareff) 38 08.06.12 10:38 Сейчас в теме
Добрый день.

Решил посмотреть как работает данная доработка, но у меня вылезает вот такая вот ошибка:

{ОбщийМодуль.опМодуль.Модуль(15)}: Ошибка при вызове метода контекста (Выбрать)
Оповещения = РегистрыСведений.ОповещениеПользователей.Выбрать(ОтборПользователей);
20. Sergey Ponomarev (SPonomareff) 38 08.06.12 11:00 Сейчас в теме
Совсем забыл, у меня сервер 1С:Предприятие 8.2 (8.2.14.540) УПП 1.3 (1.3.11.1)
21. Andrey (Varp) 12.03.13 21:24 Сейчас в теме
Подскажите. А можно ли выводить звуковое сопровождение. То есть звуковое напоминание, что есть не прочитанные сообщения?
22. Юлия Пухова (luchyk007) 30.04.13 07:56 Сейчас в теме
было бы супер объединить эту обработку с выгонялкой пользователей, получилась бы универсальный механизм для манипуляций сотрудниками.
Татьяна_69; +1 Ответить
23. Алексей Седых (sedalex) 10.02.15 10:55 Сейчас в теме
[QUOTE=v_vitalik;296139]Материальный отчет с ценами http://infostart.ru/public/172369/
Дебиторская задолженность по срокам долга http://infostart.ru/public/172371/
Задолженность поставщикам по срокам долга (УПП 1.3/БП 2.0) http://infostart.ru/public/172119/
Спасибо[/IS-QUOTE]

http://rghost.ru/43587722
http://rghost.ru/43587734
http://rghost.ru/43587746
24. Марат Хафизов (Painted) 16 10.02.15 11:09 Сейчас в теме
(23) sedalex,
Материальный отчет с ценами http://infostart.ru/public/172369/
Дебиторская задолженность по срокам долга http://infostart.ru/public/172371/
Задолженность поставщикам по срокам долга (УПП 1.3/БП 2.0) http://infostart.ru/public/172119/
Спасибо
http://rghost.ru/43587722
http://rghost.ru/43587734
http://rghost.ru/43587746

Попробую угадать. Перепутал форумы, ткнул не в то окно браузера?