gifts2017

Доступ к Секретной Информации с КЛЮЧА

Опубликовал Mihail D (dmv78) в раздел Администрирование - Защита, права, пароли

Установить доступ к данным, либо обработке с ключа (например флеш-USB).
Вот Вам реальный пример как это сделать!
Для реализации необходима "флешка" и немного терпения!

Жизненная ситуация:

Вам необходимо хоть как то обезопасить несанкционированное использование своей обработки.  

Сделать выгрузку обработки или отчета с закрытой кодовой частью это пол дела, потому как использование все равно возможно даже если код закрыт, но отрабатывается.

1. Качаем последний файл: 

* Определение ID Диска (НОВЫЙ). 

* Открываем обработку в 1С.

* Вставляем в USB разъем флешку, любую рабочую. Ждем когда система определит ее как устройство. 

* Жмем "выполнить".

* Получаем вот такой ответ обработки: 

Список

 * Из полученного списка выбираем нужный нам ID Код флешки, в моем случае это Диск: Н, с кодом "F24FEA74".

 * Далее открываем в конфигураторе наш объект который хотим защитить: 

    - Открываем Модуль объекта

    - В модуле объекта создаем процедуру со следующим кодом: 

    Процедура КлючЗащиты() Экспорт

    Попытка

ScrptCtrl = Новый COMОбъект("MSScriptControl.ScriptControl");
ScrptCtrl.Language = "vbscript";
ScrptCtrl.addcode("
|Function GetComputers()
| Set objWMIService = GetObject(""winmgmts:{impersonationLevel=impersonate}!\\.\root\cimv2"")
| Set colDisks = objWMIService.ExecQuery (""Select * from Win32_LogicalDisk"")
| For Each objDisk in colDisks
| disk = disk & objDisk.DeviceId & "";"" & objDisk.DriveType& "";"" & objDisk.VolumeSerialNumber& "";""
| Next
| GetComputers = disk
|End Function
|"
);
Текст = СокрЛП(ScrptCtrl.Run("GetComputers"));
ScrptCtrl = Неопределено;
Исключение
Сообщить(ОписаниеОшибки());
КонецПопытки;

Если
Найти(Текст,"2") > 0 Тогда
//Далее создаю таблицу для дисков
//и разбираю полученную информацию
ТаблицаДисков = Новый ТаблицаЗначений;
ТаблицаДисков.Колонки.Добавить("ИДДиска");
Пока
СтрДлина (Текст) > 0 Цикл
СтрокаТаб = ТаблицаДисков.Добавить();
Если
Сред(Текст,4,1) = "2" Тогда
Если
Сред(Текст,6,8) = "F24FEA74" Тогда
КлючДоступа = Истина;
Прервать
Иначе
КлючДоступа = Ложь;
КонецЕсли;
КонецЕсли;

Если
Сред(Текст,6,1) = ";" Тогда
СтрокаТаб.ИДДиска = "";
Иначе
СтрокаТаб.ИДДиска = Сред(Текст,6,8);
КонецЕсли;
Если
СтрокаТаб.ИДДиска = "" Тогда
Текст = Сред(Текст,7,СтрДлина (Текст)-6);
Иначе
Текст = Сред(Текст,15,СтрДлина (Текст)-14);
КонецЕсли;
КонецЦикла;
КонецЕсли;

Если
КлючДоступа = Истина Тогда
Сообщить("Работа разрешена");
Иначе
Сообщить("Доступ запрещен, НЕОБХОДИМО ВСТАВИТЬ КЛЮЧ");
ЭтотОбъект.ПолучитьФорму("Форма").Закрыть();
КонецЕсли;

КонецПроцедуры

* В модуле формы в процедуре

Процедура ПриОткрытии()

  КлючЗащиты();

КонецПроцедуры

* Сохраняем конфигурацию, создаем файл поставки без выгрузки текста модулей.

* Создаем новую конфигурацию, заливаем туда только что созданный файл поставки.

* Сохраняем закодированный отчет/обработку как внешнюю.

ПЕРЕДАЕМ ПОЛУЕННЫЙ РЕЗУЛЬТАТ ВМЕСТЕ С ФЛЕШКОЙ ЗАКАЗЧИКУ.

Теперь отчет будет работать только в том случае, если флешка вставлена в систему. Флешки нет, отчет не откроется...

РЕЗЮМЕ: Данный метод придаст небольшого шарма вашей разработке, а для того что бы ее скомпилировать все равно необходимо время, зато работать 100% будет только одна копия вашего отчета. 

При этом приведен самый тривиальный пример, но уверен что каждый из вас может найти более изощренные методы использования данного метода. 

Так же возможна привязка к другому оборудованию системы, посредствам 1С. 

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Определение ID Диска (НОВЫЙ)
.epf 8,24Kb
20.02.13
19
.epf 8,24Kb 19 Скачать
Отчет для проверки на УТ + 2 текстовых файла с кодом модуля! (старый файл).
.rar 47,87Kb
20.02.13
48
.rar 47,87Kb 48 Скачать
Определение ID - (старый файл)
.epf 7,60Kb
20.02.13
98
.epf 7,60Kb 98 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. noprogrammer (noprogrammer) 29.09.10 22:23
Если уж у пользователя есть "СуперПрава" то встроенный в конфигурацию "СуперОтчет" ему может и не понадобится для просмотра "секретной" информации т.к. на инфостарте есть отчеты которые по возможностям перекроют любой "СуперОтчет" встроенный в конфу + пользователь может запустить консоль отчетов + много чего еще.

Сам подход мне понравился (потому +), он очень эффектный и легко позволяет успокоить руководителей-параноиков (которые начинают думать, что их инфа реально защищена)

Так же флешка может на разных компьютерах определятся по разному, не как диск G, а например F или D

Как у себя решили эту проблему? или флешку дали только руководителю и попросили запускать отчет только на его компе? ;)
2. Mihail D (dmv78) 29.09.10 23:06
Всё верно! По поводу первого - можно получить отчетом конечно если есть данные, всё можно программисту! Только вот если человек не знает как это работает изнутри, даже если он-семь пядей во лбу, то что он тут на Инфостарте найдет? Ну найдет 1 отчет, другой... Но эти отчеты не будут давать полноценной картины. Там ведь отчет - вся управленка. При том это на самом деле просто некое усложнение процесса получения доступа без дополнительного ключа. А так можно получить любую информацию, если есть из чего!
Вопрос решили с флешками просто:
Документ = Новый Файл("D:\модуль.txt");
Документ1 = Новый Файл ("G:\модуль.txt");
Документ2 = Новый Файл ("F:\модуль.txt");
Если (Документ.Существует()) Тогда
ФайлСТекстом = "D:\модуль.txt";
ИначеЕсли Документ1.Существует() Тогда
ФайлСТекстом = "G:\модуль.txt";
ИначеЕсли Документ2.Существует() Тогда
ФайлСТекстом = "F:\модуль.txt";
КонецЕсли;
Док = Новый ЧтениеТекста(ФайлСТекстом);
ВыбФайл = Док.Прочитать();
Выполнить(ВыбФайл);
3. Mihail D (dmv78) 29.09.10 23:16
Ну и правильно было замечено - психологически, заказчику проще - он уверен что у него всё под контролем и он один имеет такую флешку. И если кто то получит информацию или захочет её получить - тогда это 100 пудов "попытка хищения"!

На пользователя можно сделать дополнительный доступ, т.е. в базу войти не возможно если не вставлена флешка с Авторизацией на конкретного пользователя. С таким подходом можно конфигурацию так закрыть, что потом и войти нельзя будет без специальной флешки пользователя, даже зная реальный пароль Юзера. И создать одну флешку Супер КЛЮЧ, которая откроет Вам конфигурацию, при любом раскладе под Root.
4. Аркадий Кучер (Abadonna) 30.09.10 06:27
(0)
Документ = Новый Файл("D:\модуль.txt");
Документ1 = Новый Файл ("G:\модуль.txt");

Нюансик только один:
А если терминал? Тогда флеху надо расшаривать (хотя бы для терминала) и путь уже другой будет.
А руководитель, сующий флеху в терминальный сервер, мне только в кошмарном сне присниться может ;)
5. Валерий Гайдабура (director04) 30.09.10 08:37
А может проще было создать обработку или общий модуль с закрытым кодом и в ней (нем) требовать ввода какогото суперпароля, без которого не будет крутиться отчет? Можно рассмотреть и создание внешних компонент с аналогичной функциональностью.
Лично мне, паранойя с флешкой не очень нравится.
Хотя, если вопрос стоит не об защите данных, а об оргазме клиента - тогда конечно "клиент всегда прав". Да и готов платить за паранойю, как правило, хорошо.
DimaP; dabu-dabu; zuza; w-divin; +4 Ответить
6. fadeyson (1cspecialist) 30.09.10 16:50
А теперь делаем флешку с вредоносным кодом, который, ну скажем перетрет пару справочников и регистров, вставляем флешку и вперед... Интересно, что после этого клиент скажет?

Текст кода выносить на сторону нельзя. Флешка должна быть ключом с паролем, который просто так прочитать нельзя. Перед выполнением какого-либо кода нужно прочитать пароль с флешки и если он соответствует - выполнить код. Ну или просто - проверить наличие флешки с определенным ID, который просто так подменить нельзя.
YAN; DimaP; V_V_V; +3 Ответить 1
7. VVV (V_V_V) 30.09.10 18:13
А мне понравилась идея с входом через флешку, озвученная в (3). Дешево и сердито. :D
Ежу понятно, что для вменяемого программиста ведущего данную конфу (или имеющего на руках ее копию) такие ограничения что рыбе зонтик. Но как еще один уровень секьюрности идея в целом имеет право на жизнь. За что и плюс...
8. script Мальчинко (script) 01.10.10 00:33
Я тоже за то что бы модуль оствался в конфигурации а не на флешке.
Лучше "Общий иодуль" - в нем весь алгоритм отчета, а в алгоритме уже можно проверить флешку на наличии на ней файла с паролем. Если на флешке есть нужный файл, а в нем пароль - работаем, иначе - ругаемся и не работаем.
А вообще за мысль +
9. red 80 (red80) 01.10.10 08:48
Если у Администратора базы данных за определенную мотивацию нервы сдадут, то он скопирует секретный файл на любой носитель в сети без проблем, когда параноик вставит флешку. Защита на сейчас. Работает пока не пришел параноик.
10. Сергей (seermak) 01.10.10 10:29
вот примерная функция определения флешки и файла на ней
Функция СъемныйДиск() Экспорт
СъемныйДиск = "";
Попытка
ScrptCtrl = Новый COMОбъект("MSScriptControl.ScriptControl");
ScrptCtrl.Language = "vbscript";
ScrptCtrl.addcode("
|Function GetComputers()
| Set objWMIService = GetObject(""winmgmts:{impersonationLevel=impersonate}!\\.\root\cimv2"")
| Set colDisks = objWMIService.ExecQuery (""Select * from Win32_LogicalDisk"")
| For Each objDisk in colDisks
| disk = disk & objDisk.DeviceID & "";"" & objDisk.DriveType& "";""
| Next
| GetComputers = disk
|End Function
|");
Текст = СокрЛП(ScrptCtrl.Run("GetComputers"));
ScrptCtrl = Неопределено;
Исключение
Сообщить(ОписаниеОшибки());
Возврат СъемныйДиск;
КонецПопытки;

Если Найти(Текст,"2") > 0 Тогда
//Далее создаю таблицу для дисков
ТабДисков = Новый ТаблицаЗначений;
ТабДисков.Колонки.Добавить("Диск");
ТабДисков.Колонки.Добавить("Описание");
//Разбираю полученную информацию
Пока СтрДлина (Текст) > 0 Цикл
Строка = ТабДисков.Добавить();
Строка.Диск = Лев(Текст,2);
Строка.Описание = Сред(Текст,4,1);
Текст = Сред(Текст,6,СтрДлина (Текст)-5);
КонецЦикла;

Для Каждого Элемента Из ТабДисков Цикл
Если Элемента.Описание = "2" Тогда // Это и есть сменный носитель
СъемныйДиск = Элемента.Диск; //"F:"
//Если сменных носителей несколько а нужно выбрать определенный то как вариант на нужном диске хранить файл с определенным именем к примеру .
МасивФ = НайтиФайлы(Элемента.Диск,"Transfer.fls");
Если МасивФ.Количество() > 0 Тогда
СъемныйДиск = Элемента.Диск;
КонецЕсли;
МасивФ = Неопределено;
КонецЕсли;
КонецЦикла;
ТабДисков = Неопределено;
КонецЕсли;
Возврат СъемныйДиск;
КонецФункции // СъемныйДиск()
Yury1001; dmv78; +2 Ответить 1
11. Mihail D (dmv78) 01.10.10 13:05
Я считаю так - все правы, всем спасибо за комментарии. Реально очень хорошие идеи генерировать одному сложно, но когда каждый по чуть-чуть добавить своего, затем это объединить в единое целое - получается очень мощно и универсально.

Я согласен что код выносить "стремно", но Вы тоже поймите - если отчет разрабатывался индивидуально, и открытый код отчета остался только в .cf, а для использования используется флешка - мне кажется хороший метод. При том что если код отсутвует в конфигурации впринципе, тогда есть только один вариант "злоумышленнику" - разработать свой код! Но чем больше будет ссылок на "флешку", тем гемморойней будет везеде прописать, что бы правильно работало.
Здесь каждый сам для себя должен определится как и кому будет лучше, кому по паролю, кому нет! Ведь вариантов масса здесь.
12. Mihail D (dmv78) 01.10.10 13:29
(6) Вообще то есть именоо тут масса обработок позволяющих делать автосохранение БД. И если вредоносный код перетрет пару справочников или ещё чего там - ну тогда молодец что написал такой код, хотелось бы его тоже тут увидеть. Но в нашем случае восстанавливаем последнюю копию и продолжаем работать как работали.

Если имеется ввиду что можно создать такой же текстовый файл, с таким же названием и туда "забить" что то типа очистки значениий, тогда СООБЩУ, текст с флешки не читается при отсутсвии ещё одного файла, который определяет что за флешка пытается передать тексты кода! Это и есть ситема защиты! Кстати кто то знает как получить ID устройства? ;)
13. fadeyson (1cspecialist) 01.10.10 17:24
(12) "Но в нашем случае восстанавливаем последнюю копию и продолжаем работать как работали..."

Поздно. Уже нечего восстанавливать. Диски C: отформатированы. Работа всех пользователей парализована. Клиент в шоке, когда очухается - выставит вам счет на недополученную за время простоя прибыль. Начальника службы безопасности завтра увольняют. Конкуренты торжествуют. :D

Мораль: Код выносить на сторону нельзя! Все остальные идеи - здорово и есть куда развивать.
14. Mihail D (dmv78) 01.10.10 17:49
:D (13) Ок. Придется написать как исключить возможность написание "псевдокода", хотя в ответе (10) Вам можно легко увидеть ответ.
К тому же - если отформатируют ДИСК :С - это бредятина - тогда вообще хоть код прошит, хоть не прошит - пользователь получил доступ к Диску С:, не вижу смысла в Вашем ответе. Или это банальная демогогия? К Вашему сведению - нормальный сис. админ делает образы Дисков, а выгрузки ИБ - сохраняются не на 1 диск, а иногда сразу на несколько. Но это уже зависит от того как вы обеспечиваете целостность и сохранность информации! :D Покажите мне код, который отформатирует Диск :С на серваке при помощи 1С- Предприятие.
15. Yura Prokofev (Yura_ylt) 02.10.10 12:20
А если куски кода на флешке хранить в зашифрованном виде и ключ для их расшифровки, а в 1с их перед загрузкой с помощью того-же ключа расшифровывать и после этого выполнять, тогда придется реализовать системы шифрования для разработчика, который с помощью того-же ключа их зашифровывает и передает клиенту
16. Сергей (seermak) 02.10.10 13:01
да можно сделать еще проще = если нужная флешка в дупле - выполняем код из закрытого модуля, если нет - отправляем программу другим путем.
17. Андрей Лещанов (Nuuq) 03.10.10 11:00
А вот еще идея:
если купить токен (параноидальный защитофил пойдет на этот дорогостоящий шаг или же он у него уже есть для клиент-банка например), получить с него ID и прописать в общем модуле условие на наличие в системе этого устройства, таким образом можно убить двух зайцев:
1. весь код исполняется только в пределах базы
2. нет заморочки с буквой диска флэшки на разных компах
(это и в правду у некоторых флэха бывает и C: :) а где и F и т.д...)
18. Аркадий Кучер (Abadonna) 03.10.10 13:34
В 7.7 испокон веков существует #ЗагрузитьИзФайла, но никто еще не додумался его с флехи или CD грузить ;)
19. Mihail D (dmv78) 03.10.10 14:08
Так мы тут про 8х, говорим. Насколько мне известно, 7.7 открыть проще простого! Там как не шифруйся - защищеность очень низка! В 8 - всё не так! При том - здесь тоже можно использовать те же #загрузитьизфайла. В этом примере рассматривается возможность доступа к той или иной иформации, и в качестве примера приведен простой код, вы можете на своё усмотрение, использовать хоть ЗагрузитьизФайла, хоть из Строки, хоть из Узла. Если здесь расписывать где и как можно применить, можно книгу написать, при том с неопределенным количесвом редакций!
20. Аркадий Кучер (Abadonna) 03.10.10 16:58
Насколько мне известно, 7.7 открыть проще простого!

В восьмерке мне открыть - как раз проще простого, а вот 7.7, закрытую КЗК-2, хрен сломаешь.
21. AdApter (adapter) 04.10.10 13:34
O, ya, ya!
Еще пара дополнений:
1. файл с вынесенным кодом запаковать с паролем, записать на закриптованную флешку, флешку положить в сейф;
2. Сервер 1С8 вынести на влаго-пыле-долбоебо-вандало защищенный нетбук, работающий по Линуксом с закриптованным системным разделом.
3. Программиста и сисадмина, которые всё это настроят - напишут, посадить в камеры одиночки с толщиной свинцовой стены 3м, при отсутствии - в конфортабельные палаты ближайшей психушки
22. Mihail D (dmv78) 04.10.10 14:04
(21) Похоже ты мало знаешь про специфику бизнеса и УК РФ! Если что, люди иногда в серверной садят охранника - который закрыт изнутри - и видит в камеру всю территорию, перед ним инструкция - в случае "боевых действий", извлечь все жесткие диски с сервера, после чего взять ударный инструмент - "киянку" - точными ударами разбить все диски, аккуратно разбитые диски сложить в корзину для мусора! Данную инструкцию пропустить через Шредер! :) В наше время люди готовы не только в сейф запихать базу данных... А вот какую информацию они там оберегают - только им известно. Хотя по большому счету, большинство из них просто так думают что там важная информация, но вот остальные - знают что там за информация, и что им за это будет! Потому средства защиты, дополнительные никогда лишними не бывают, это я из личного опыта знаю!
Программист - это зачастую человек отвечающий только за правильную работоспособность БД, ответственность за то что он написал неправильный код - он несет не перед государством, а перед Юридическим лицом, а вот Юридическое лицо несет всю ответственность перед государством!
Программист только по пьяни за дебош может попасть в обезъянник, а руководитель организации, бухгалтер, финансовый директор - может попасть в любой момент, не в обезъянник, а в СИЗО. Разница ощутима. Хотя если ты не был ни там ни там, тебе это ничего не скажет - просто лишний раз посмеешься, и сам себе скажешь - какие все вокруг "параноики". Так вот последние - готовы платить не только за сохранность коммерческой информации, но и за безопасность содержащейся информации! Бизнес всегда имеет Светлую и Серую сторону, а те кто пытается быть только Светлым - их включают в реестр специальный, и все их грузы проходят усиленный контроль. Почему так? Не знаю! Наверное потому что МЫ РУССКИЕ, и когда что то получаем - очень жалко отдавать назад кому то!
23. Александр Синцов (Sintson) 05.10.10 01:57
Бред, по моему! Исходные данные в базе остаются, при наличии желания и мозгов всегда можно их проанализировать. Пусть и не так как специализированным отчетом, универсальный подойдет.
Вообще сложность защиты должна быть прямо пропорциональна полезности программы (информации).
24. Mihail D (dmv78) 05.10.10 09:51
Конечно можно! Только иногда можно выиграть время пока твои мозги получают информацию! Для чего нужно время я тут расписывать не собираюсь! Но те кто знает понимает!
25. AdApter (adapter) 06.10.10 17:03
та, не кипятись. я просто пошутил :)
26. Александр Зубцов (iov) 09.10.10 01:43
хм вы бы еще предложили шифровать данные непосредственно в базе а на флешке держать ключи расшифровки...
а для безопасности просто надо "крышу" из гос структур. остальное только ради душевного спокойствия и лишней копеечки.
27. Denis Lookin (lookindenis) 09.10.10 16:14
Решение простое - Часть модуля просто выносим в текстовый файл, переносим этот файл на флешку...

а поч не весь модуль? =)
28. Александр Цегельников (markers) 11.10.10 06:28
ИМХО использование метода "Выполнить" есть оооочень большая дыра, даже в рамках конфигурации!!!! Где данные лежат тут-же... Лучше придумать алгоритм аля серийного номера на основании серийника флешки (а на флешке держать текстовый файл (который и читать как текст) в котором находится ответный ключ от серийника) А модуль с алгоритмом можно закрыть! А генерилку ответного ключа держать в внешней обработке и её в сейфе или ещё где.
ЗЫ: Самый простой метод получения ключа из серийника, это делать сдвиг например идём по буквенно (кроме знака "-") и к номеру символа добавляем позицию символа и ставим в ключ символ с получившимся числом это первая половина серийника, вторую например отнимаем позицию с конца.. Вот вам и генерилка и проверялка.
Желательно следить что получившиеся символы были "безопасными", чтоб потом считались из текстового файла
ЗЫ2: Тогда даже подсмотрят какой номер на вашей флешке и если поменяют серийный номер своего устройства на ваш номер (а это возможно) но не скопируют ключевой файл, то проверка не пройдёт!
Кстати лучше текстовый файл создавать скрытым, как защита от дурака.
ll13; ASMIR.ru; +2 Ответить
29. Антон Рощин (wolfsoft) 27.10.10 16:21
А не проще что-нибудь вроде "Secret Disk Server NG" (система защиты корпоративных баз и конфиденциальных данных на серверах от несанкционированного доступа, копирования, повреждения, кражи или неправомерного изъятия) приобрести? Цена не бог весть какая даже для средней конторы.

Но в целом, за идею и творческий порыв плюсну :)
30. Vitaliy (idef) 27.10.10 22:23
А если флеха погибла?
Нужен супер-пупер админ с мастер-флехой для восстановления?
В общем идея имеет право на жизнь, но как показывает практика - недостатков больше чем преимуществ. :(
31. Ярослав Радкевич (WKBAPKA) 29.10.10 09:56
не думаю, что в России более стремные условия ведения бизнеса, чем скажем в Белоруссии. Подход через флешку - оригинальный, но абсолютно бесполезный. Имея исходную базу данных - проанализировать ее безо всяких проблем. Что это за супер такой отчет должен быть? да и когда уже наезжают, время уже не является принципиальным. В защите информации главное правильно подойти к вопросу, что защищать нужно. Всю базу не защитишь никогда. Даже из государственных военных организаций бывает утечка... а тут открытое предприятие!
32. Ярослав Радкевич (WKBAPKA) 29.10.10 09:59
2(2): зачем быть семь пядей во лбу... или на предприятии особая секретная технология ведения учета ? ;)
33. Николай (provnick) 29.10.10 12:43
ИМХО, а что если по определенному ID диску и находящемуся на флешке файлу с паролем вообще запретить запуск конфигурации, разве не защита? Ну не для мастеров, но во всяком случае от несанкционированного входа неких любопытных, а "Имея исходную базу данных" дак её нужно иметь
34. Константин Семичев (konstantin-semichev) 13.11.10 16:17
а у администратора баз данных нету возможности унести базу с конфой домой и поправить код ? ИМХО, защита от нечистых на руку юзеров, от админа она не спасет, если админа промотивировать, то даже отсутствие кода отчета не поможет, если он реально админ. отчеты это не данные, можно другой написать и вставить куда надо. главная проблема утечек это сами данные, мелкие фирмы чаще страдают от слива контрагентов, а утечка фин информации реализуется сливом стандартной бухгалтерской оборотки
35. Denis Lookin (lookindenis) 13.11.10 16:48
ну что вы так набросились на автора?
о_О
он же написал, что это для заказчиков типа - "злостный параноик"
=)
36. Роман Хусяинов (rom-x) 15.10.11 17:06
Определение ID - USB диска... выводит пустое поле, флешка подключена, что не так делаю?
37. Mihail D (dmv78) 18.10.11 10:22
Всё работает нормально!
Вставьте флешку в разъем, затем проверьте определилась ли она системой, т.е. просто откройте её через "Мой Компьютер", если всё нормально, тогда откройте обработку "Poluchit id USB" из программы 1С предприятие, в режиме Предприятие, затем нажмите кнопку "Выполнить". :( Ну для контрольной убедительности вставьте другую флешку и проверьте её, вдруг у Вашего экземпляра флешки нет ИД :))))))...
38. Роман Хусяинов (rom-x) 18.10.11 19:56
(37) dmv78, спасибо за инструкцию, все делаю так же, пробовал на 2-х флешках, не работает.
Все скриншеты могу приложить, вот скрин основного окна:
39. Александр Омельянов (proger1c81) 27.02.13 02:53
кто-то знает, как взломать защиту РАРУС 1С Ресторан? Защита интересно организована через внешнюю компоненту V8Restoran.dll. Написана на Делфи, запускает форму проверки ключа защиты. Если нет ключа, то и не дает дальше использовать все функции и прелести, заложенные в этой компоненте. Очень хочется взломать ДЛЛ-ку, прописать, где надо, что ключ защиты и есть и использовать все функции этой компоненты. Их так просто не переписать, свои не придумаешь :(
А насчет поставки конфы без текста модуля или запароленного текста модуля - это очень легко решается Декомпилятором 1С. 1минута и все пароли сняты и тексты возобновлены ;) Жаль нет такого простого и удобного декомпилятора для DLL файлов.
40. Александр Орефков (orefkov) 23.07.13 14:00
Это что, такая шутка юмора?
Защита, рассчитанная на семиклассника?
Это даже не серийник диска, это виндовый идентификатор тома, который вообще никак с железом не связан, присваивается при форматировании и может быть установлен для любого диска в любое значение (утилит полно в сети).
Для флешек хотя бы брали ее железный серийник, чуть понадежнее бы было.
Хотя и это обходится перепрошивкой флешки.
41. Lubov Filippova (laf) 10.12.13 04:57
Да оригинально, молодец автор. Можно брать за основу.
42. Владислав Огурцов (ogursoft) 10.12.13 08:01
Неужели в 1С не подумали над этим вопросом и не ввели поддержку авторизации на основе внешних считывателей/рутокенов и т.д.?
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа