gifts2017

Дни рождения с переходом на следующий год

Опубликовал dferty (dferty) в раздел Отчеты - Разное

Скачать файлы

Наименование Файл Версия Размер
Дни рождения 41
.ert 315,00Kb
29.09.10
41
.ert 315,00Kb Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Алексей (buhinfo) 30.09.10 11:50
А "мертвые души" (неработающие сотрудники) по прежнему печатаются вместе со всеми?
2. dferty (dferty) 30.09.10 12:31
а их нужно перенести в папку (например 2010 год мертвые души) и если они там не отбирать их :)
3. Аркадий Кучер (Abadonna) 30.09.10 15:53
Дни рождения с переходом на следующий год

Это, типа, Большой Запой? :D
hogik; Kapitan911; Alraune; +3 Ответить
4. Алексей (buhinfo) 01.10.10 18:27
ответ на (2) а почему нельзя отсекать мертвые души обработкой?
5. Юрий (Kurt) 27.10.10 16:46
(2) а отбор по СостояниеФизлица хотя бы на дату начала фомирования отчета... типа того религия не позволяет?

Вот, дарю, например так ... аж с перестраховкой :D
в функцию передается сотрудник, возвращается "0" если он в данном отчёте не нужен

//******************************************************************************
// Неработает и не попадает в период
//
Функция Неработает(Чел)
	Г=ДатаГод(ДатаНачала);	
	ДР=Чел.ФизЛицо.ДатаРождения;
	М=ДатаМесяц(ДР);
	Ч=ДатаЧисло(ДР);
	//Предполагаемый текущий День рождения
	ДР1=Дата(Г,М,Ч);
	
	// Отсеиваем у кого День рождения не в периоде
	Если ДР1<ДатаНачала Тогда
		ДР1=ДобавитьМесяц(ДР1,12);
		Если ДР1>ДатаКонца Тогда
			Возврат 0;
		КонецЕсли;
	КонецЕсли;
	
	// Отсеиваем уволенных и неработающих в периоде
	Нач=0+ПустаяСтрока(Чел.СостояниеФизлица.Получить(ДатаНачала));
	Кон=0+ПустаяСтрока(Чел.СостояниеФизлица.Получить(ДатаКонца));
	ДР2=0+ПустаяСтрока(Чел.СостояниеФизлица.Получить(ДР1));
	Если (Нач+Кон+ДР2)=3 Тогда
		Возврат 0;
	КонецЕсли;
	Возврат 1;
КонецФункции //Неработает(Чел)
//******************************************************************************
...Показать Скрыть


Ну конечно исходим из того, что отчёт за год (не более), а то два дня рождения в одном отчёте это уже слишком :D
6. Юрий (Kurt) 27.10.10 16:54
(5) добавочка... :) а то вдруг не совсем понятно..
"ДатаНачала" и "ДатаКонца" - это соответственно начало и конец периода за который формируем отчёт.
7. Инна **** (karp12) 10.11.10 14:41
Не дает выбирать подразделение,что нужно сделать?
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа