gifts2017

Сравнение оборотов по бухгалтерскому учету между двумя базами по COM соединению

Опубликовал ediks (ediks) в раздел Отчеты - Бухгалтерские

Обработка для сравнения оборотов по регистру бухгалтерии "Хозрасчетный" двух баз в разрезе регистраторов по COM соединению.

Целью создания этой обработки является получение списка номеров регистраторов, по которым имеются расхождения в оборотах двух баз. Регистраторы ищутся в базах по UUID.

Обработка позволяет использовать отборы по реквизитам проводки и по типу регистратора.

В качестве бонуса в комплекте предлагается слегка измененная типовая обработка "Универсальный обмен данными в формате XML". В нее добавлена возможность заполнения отбора по документам или справочникам списком значений, полученным из обработки "Сравнение оборотов по БУ" и "Сравнение элементов справочников" через буфер обмена.

Типичный сценарий действий :

1) Выбирается период сравнения.

2) Выбирается фильтр по типу регистратора (можно не выбирать). Флажок "Не учитывать" определяет условие "Не Регистратор Ссылка Документ.ХХХ".

3) Заполняется отбор. Тоже можно не заполнять, но очень желательно для сокращения времени выборки.

4) Нажимается кнопка "Заполнить". Если выявились расхождения, то стандартными средствами "Вывести список" можно вывести номера и даты документов в табличный документ.

5) Список номеров и дат документов (кодов справочника) можно скопировать в отбор универсального обмена как показано на рис. 2 и выгрузить в приемник, используя разработанные Вами правила обмена.

Частично код заимствован (функции поиска COM объектов) из аналогичной публикации http://infostart.ru/public/21382/ , за что автору еще раз огромное спасибо. По сравнению с этой публикацией данная обработка позволяет использовать отборы по счетам, субконто и типам регистраторов.

Скачать файлы

Наименование Файл Версия Размер
Сравнение регистраторов 192
.epf 29,29Kb
13.12.10
192
.epf 29,29Kb Скачать
Универсальная выгрузка 41
.epf 153,05Kb
13.12.10
41
.epf 153,05Kb Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Александр Медведев (anig99) 13.12.10 23:22
А можно как-то придумать, чтобы тип документа перенести в общий отбор со всеми вытекающими возможностями гибкого отбора?
2. Александр Медведев (anig99) 13.12.10 23:23
да и расширить проверку до всех возможных регистров тоже было бы неплохо.
3. ediks (ediks) 13.12.10 23:37
(1) В обработке использован стандартный отбор построителя. Как добавить в отбор тип документа, я не знаю.
(2) По идее можно добавить проверку по налоговому учету, здесь сложного ничего нет. Если руки дойдут, то сделаю. Для регистров накопления эта обработка не предназначалась, в отличие от Вашей.
4. Яков Коган (Yashazz) 16.12.10 16:55
Упс, промахнулся и плюсанул комментарий... Тогда уж выскажусь: использовать надо СКД, тогда и тип документа легко добавить, как пользовательское поле.
А вообще, опять же, кто-нибудь пробовал СКД на внешних наборах из нескольких баз?
5. София (pantera190) 23.09.11 13:49
7. Олег Никоноров (nikolega) 12.07.12 16:01
Отличная робработка !

Несколько идей доработки:

1. Полезно было бы добавить отбор по организации:
Построитель.Отбор.Добавить("Организация",, "Организация");
(предварительно в инициализации в запросе прописать организацию)

2. Версию платформы 8.2

3. Для удобства анализа таблицы
в конце процедуры добавить :
Процедура ФормированиеИтоговойТаблицы() Экспорт
....
Расхождения.Сортировать("ГУИД,Свертка,Регистратор");
КонецПроцедуры

4. Для визуального контроля добавить на табличное поле обработчик на событие ПриВыводеСтроки:
Процедура РасхожденияПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
Если ДанныеСтроки.Свертка = -1 Тогда
ОформлениеСтроки.ЦветФона = Новый Цвет(153,204,255);
КонецЕсли;
КонецПроцедуры

5. Перенести кнопку "Заполнить" на место кнопки "Выполнить".

Вроде все ))) Плюс однозначно тебе !
8. ediks (ediks) 12.07.12 20:31
(7) Спасибо за оценку моей разработки. Все предложения принимаются, но, к сожалению, неизвестно когда я их реализую. Если только подвернется задача.
9. Олег Никоноров (nikolega) 12.07.12 21:07
(8) Я уже сделал это ) Если надо - пришлю обработочку
10. Андрей Акулов (DrAku1a) 13.03.13 04:45
Плюс однозначно. И за сопоставление COM-объектов - тоже!
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа