gifts2017

Посылка сообщения пользователям

Опубликовал Alexander Veselov (alves) в раздел Обработки - Универсальные обработки

Предназначена для рассылки по сети всем, или избранным активным пользователям базы данных сообщения. Работает только для Windows XP - в Windows 7 или Vista - бесполезна.

Предназначена для рассылки по сети всем, или избранным активным пользователям базы данных сообщения. Работает только для Windows XP - в Windows 7 или Vista - бесполезна.

Обработка использует механизм посылки сообщений через команду "net send"

Проверена в работе на одноранговой сети, в многоранговой сети с доменом и управляемой Windows Server 2008R2, при использовании файл-серверного варианта 1С УТ, при использовании клиент-сервера 1С УПП.

Необходимо:

1. Чтобы на компьютере пользователя была включена "Служба сообщений"

Механизм включения "Службы сообщений" можно описать, но вряд ли это надо делать в данной теме. На сайте этот механизм уже описывался.

Спасибо за замечания. Приветствуются предложения.Smile

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
АктивныеПользователи.epf
.epf 18,28Kb
01.02.11
275
.epf 18,28Kb 275 Скачать

См. также

PowerTools от 1 000
Подписаться Добавить вознаграждение

Комментарии

1. Иван Дижа (IDija) 01.02.11 10:12
Стоит подробнее описать. У меня например сходу и не заработала
2. Василий Демидов (Душелов) 01.02.11 11:02
3. sound sound (sound) 02.02.11 14:37
Для пользователей в терминале:
http://infostart.ru/public/76919/,
также http://www.robvanderwoude.com/termserv.php

у меня это примерно так (кусок выдран как есть):


Процедура ОтправитьСообщениеПоФайлу(ФайлРассылки, Пользователь) Экспорт
	ТекстСообщения = "" + Пользователь + ", ";
	Если ВвестиСтроку(ТекстСообщения, "Сообщение для " + Пользователь, 0, Истина) Тогда
		врФайл = ПолучитьИмяВременногоФайла("bat");
		ЗапТекст = Новый ЗаписьТекста(врФайл, КодировкаТекста.OEM);
		Для каждого ТермСерв Из МассивТермСерверов Цикл
			ЗапТекст.ЗаписатьСтроку("MSG.EXE @" + ФайлРассылки + " /SERVER:" + ТермСерв + " " + ТекстСообщения);
		КонецЦикла;
		ЗапТекст.Закрыть();
	КонецЕсли;
	ЗапуститьПриложение(врФайл, , Ложь);
КонецПроцедуры // ОтправитьСообщениеПоФайлу()


...Показать Скрыть
4. Лёша Авто (Lesha1C) 03.02.11 16:05
да, сходу точно не работает...
5. Сабир Абдурахманов (Nigelist) 03.07.11 10:19
Есть ли возможность посылать пользователям 1С служебные сообщения, штатными средствами? Без всяких "net send"?
6. Михаил Ражиков (tango) 03.07.11 11:19
7. Кудряшова Майя (mayak15) 28.09.11 10:13
Я так понимаю требуются настройки через панель управления
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа