gifts2017

Ошибка формирования свода проводок ЗИК 306 - в январе 2011 не формируются проводки по кт 97 счета

Опубликовал Елена Мocкаленко (melenaspb) в раздел Программирование - Практика программирования

Ошибка формирования свода проводок ЗИК 306 -  в январе 2011 не формируются проводки по кт 97 счета

Если в  2010 году были переходящие на 2011 год отпуска, то все что 1С "смогла сделать" для их отображения в своде проводок это добавить вот такой комментарий :
// списание из РБП по правилам 2010 года
дальше этого дело не пошло :(


  • Предлагаю свой вариант исправления:
    Исправляем  ГМ -> Функция глПроводкиЗаПериод2011

    1. Закомментируем строки 74365 - 74371  -  мы будем исправлять вариант 2011 года
    // Если НачалоМесяца_РБП < ДатаРасширенияПеречняЛьготныхТарифовСтраховыхВзносов Тогда
    // списание из РБП по правилам 2010 года
    // Иначе // правила с 2011 года
     
    и так же комментируем строку 75066 - конец этого условия
    //КонецЕсли

    2. Исправляем строку  74426
    вместо
    ЗаполнитьДанныеДляПроводок2011(ДоходыВычетыНалогиСотрудников, Сотрудник, Месяц, КоэффициентСотрудника,СкидкаМатпомощь, ДатаАктуальности,
    ИсчисленоПФРНак,ИсчисленоПФРСтрах,ИсчисленоФСС,ИсчисленоТФОМС,ИсчисленоФФОМС,ИсчисленоДопТариф,ИсчисленоФСС_НС,
    БазаДопТариф,БазаФСС_НС,ОблагаемаяБазаПФР,ОблагаемаяБазаФСС,ОблагаемаяБазаФОМС,КоэфПФР_ПоПределу,КоэфФОМС_ПоПределу,КоэфФСС_ПоПределу);
    пишем
    ЗаполнитьДанныеДляПроводок2011(?(ДатаГод(КонецПериода_РБП) < ТекущийГод,ДоходыВычетыНалогиСотрудниковПрошлогоГода,ДоходыВычетыНалогиСотрудников), Сотрудник, ДатаМесяц(КонецПериода_РБП), КоэффициентСотрудника,СкидкаМатпомощь, ДатаАктуальности,
    ИсчисленоПФРНак,ИсчисленоПФРСтрах,ИсчисленоФСС,ИсчисленоТФОМС,ИсчисленоФФОМС,ИсчисленоДопТариф,ИсчисленоФСС_НС,
    БазаДопТариф,БазаФСС_НС,ОблагаемаяБазаПФР,ОблагаемаяБазаФСС,ОблагаемаяБазаФОМС,КоэфПФР_ПоПределу,КоэфФОМС_ПоПределу,КоэфФСС_ПоПределу);

    3.
    Меняем строку 74980
    ТаблицаКорреспонденций.Сумма = СуммаПроводкиНалоги;
    на
    ТаблицаКорреспонденций.Сумма = СуммаПроводкиПоВзносам;

    4.
    И после строки 74920 вставляем кусок из процедуры для 2010 года , тут конечно можно бы вынести кое что за цикл, но не до красоты:
        // Рассчитаем ФСС_НС для 2010 года
                                    СписокНалогов = СоздатьОбъект("СписокЗначений");
                                    СпрДопПроводок = СоздатьОбъект("Справочник.ДополнительныеПроводки");
                                    СпрДопПроводок.ВыбратьЭлементы();
                                    Пока СпрДопПроводок.ПолучитьЭлемент() = 1 Цикл         
                                       
                                        Если (СпрДопПроводок.Код = "ФСС_БЛ") или (СпрДопПроводок.Код = "АВИА") Тогда
                                            Продолжить;   
                                        КонецЕсли;
                                       
                                        Если СпрДопПроводок.ПроцентОтРасчетнойБазы > 0 Тогда
                                            СписокНалогов.ДобавитьЗначение(СпрДопПроводок.ТекущийЭлемент(),СпрДопПроводок.Код);
                                            СпособыОтраженияНалогов.Установить("СпособДляФСС_НС",СпрДопПроводок.ПорядокОтраженияВНУ);
                                        КонецЕсли;
                                       
                                    КонецЦикла;
                                    Если (СуммаПроводкиНалоги = 0) И (НачалоМесяца_РБП < ДатаРасширенияПеречняЛьготныхТарифовСтраховыхВзносов) Тогда
                                        КоэффициентФСС_НС_Сотрудника = 1;
                                        //в некоторых случаях применяется понижающий коэффициент
                                        РазделятьФССНС = ?((Константа.ОрганизацияИнвалидов.Получить(ДатаМесяц(КонецПериода_РБП))=0),1,0);
                                        Если РазделятьФССНС=1 Тогда
                                            Категория=ЗапросПоЖР_РБП.КатегорияПлательщикаПФР;
                                            Если (Категория=Перечисление.КатегорияПлательщикаПФ.НРИВ)
                                            или (Категория=Перечисление.КатегорияПлательщикаПФ.СХИВ)
                                            или (Категория=Перечисление.КатегорияПлательщикаПФ.АДИВ)
                                            или (Категория=Перечисление.КатегорияПлательщикаПФ.ИПИВ)
                                            или (Категория=Перечисление.КатегорияПлательщикаПФ.ФХИВ) Тогда
                                                КоэффициентФСС_НС_Сотрудника = 0.6;
                                            КонецЕсли;
                                        Иначе
                                            КоэффициентФСС_НС_Сотрудника = 0.6;
                                        КонецЕсли;
                                        ДополнительноеОтчисление = СписокНалогов.Получить("ФСС_НС");
                                        КоэфУчетаВФСС_НС = 0;//1 или 0   
                                        ПроцентОтРасчетнойБазы = 0;   
                                        Если ТипЗначения(ДополнительноеОтчисление) = 11 Тогда
                                            //есть в списке налогов ФСС_НС
                                            ПроцентОтРасчетнойБазы = ДополнительноеОтчисление.ПроцентОтРасчетнойБазы;
                                           
                                            Если глВходитВБазуПроводки(ВР,ДополнительноеОтчисление) = 0 Тогда
                                                //ВР не входит в базу для расчета ФСС_НС, однако мы можем явно указать оплату в документе
                                                //для некотрых видов расчета
                                                Если (ВР = ВидРасчета.ОплатаПоДоговору) или (ВР = ВидРасчета.ОплатаПоДоговоруСПредпринимателем) или (ВР = ВидРасчета.Авторские) или (ВР = ВидРасчета.ЛицензионныеВыплаты) Тогда
                                                    Если ДокументВР.Вид() = "ДоговорГраждПравХаракт" Тогда
                                                        Если ДокументВР.УплачиватьВФСС = 1  Тогда
                                                            КоэфУчетаВФСС_НС = 1; //в документе указано, что платим ФСС_НС
                                                        КонецЕсли;
                                                    КонецЕсли;                       
                                                КонецЕсли; 
                                            Иначе //ВР входит в базу ФСС_НС
                                                КоэфУчетаВФСС_НС=1;   
                                            КонецЕсли;
                                        КонецЕсли;
                                       
                                        ШаблонДополнительногоОтчисления = ДополнительноеОтчисление.ШаблонПроводки;
                                        СуммаПроводкиНалоги_ФСС_НС = Окр(СуммаПроводки*КоэфУчетаВФСС_НС*КоэффициентФСС_НС_Сотрудника * ДополнительноеОтчисление.ПроцентОтРасчетнойБазы / 100,10);
                                        Если ШаблонДополнительногоОтчисления.СчетДебета.Выбран()=1 Тогда 
                                           
                                           
                                            Если (Найти(СтрокаСправочников,","+СокрЛП(ШаблонДополнительногоОтчисления.СчетДебета.Субконто1.Идентификатор)+",")>0) и (СокрЛП(ШаблонДополнительногоОтчисления.СчетДебета.Субконто1.Идентификатор)<>"Справочник.ПрямыеЗатраты") Тогда
                                                Субконто1ДебетаВзносовДП=ШаблонДополнительногоОтчисления.Субконто5Дебета;
                                            Иначе
                                                Субконто1ДебетаВзносовДП=ШаблонДополнительногоОтчисления.Субконто1Дебета;
                                            КонецЕсли;
                                            Если (Найти(СтрокаСправочников,","+СокрЛП(ШаблонДополнительногоОтчисления.СчетДебета.Субконто2.Идентификатор)+",")>0) Тогда
                                                Если СокрЛП(ШаблонДополнительногоОтчисления.СчетДебета.Субконто2.Идентификатор)<>"Справочник.ПрямыеЗатраты" Тогда
                                                    Субконто2ДебетаВзносовДП=ШаблонДополнительногоОтчисления.Субконто5Дебета;
                                                Иначе  // это для "производства"
                                                   
                                                    Если ПустоеЗначение(ШаблонДополнительногоОтчисления.Субконто2Дебета)=0 Тогда
                                                        Если СокрЛП(ШаблонДополнительногоОтчисления.Субконто2Дебета.Код) = "ПрочиеЗатратыПоЗпл" Тогда
                                                            Если Конфигурация = "ПроизводствоСАналитикой" Тогда
                                                                Субконто2ДебетаВзносовДП=ПрочиеЗатратыПоВзносам_ДляПУБ_сАналитикой;
                                                            Иначе
                                                                Субконто2ДебетаВзносовДП=ПрочиеЗатратыПоВзносам;
                                                            КонецЕсли;
                                                        Иначе
                                                            Если Конфигурация = "ПроизводствоСАналитикой" Тогда                                           
                                                                Субконто2ДебетаВзносовДП=ПрочиеЗатратыПоВзносам_ДляПУБ_сАналитикой;
                                                            Иначе
                                                                Субконто2ДебетаВзносовДП=ПустоеСубконто;
                                                            КонецЕсли;
                                                        КонецЕсли;
                                                    Иначе
                                                        Если Конфигурация = "ПроизводствоСАналитикой" Тогда                                           
                                                            Субконто2ДебетаВзносовДП=ПрочиеЗатратыПоВзносам_ДляПУБ_сАналитикой;
                                                        Иначе
                                                            Субконто2ДебетаВзносовДП=ПустоеСубконто;
                                                        КонецЕсли;
                                                    КонецЕсли;
                                                   
                                                КонецЕсли;
                                               
                                            Иначе   
                                                Субконто2ДебетаВзносовДП=ШаблонДополнительногоОтчисления.Субконто2Дебета;
                                            КонецЕсли;
                                            Если (Найти(СтрокаСправочников,","+СокрЛП(ШаблонДополнительногоОтчисления.СчетДебета.Субконто3.Идентификатор)+",")>0) и (СокрЛП(ШаблонДополнительногоОтчисления.СчетДебета.Субконто3.Идентификатор)<>"Справочник.ПрямыеЗатраты") Тогда
                                                Субконто3ДебетаВзносовДП=ШаблонДополнительногоОтчисления.Субконто5Дебета;
                                            Иначе
                                                Субконто3ДебетаВзносовДП=ШаблонДополнительногоОтчисления.Субконто3Дебета;
                                            КонецЕсли;
                                           
                                            Если (КонстантаКонфигурация=Перечисление.БухгалтерскиеПрограммы.Бухгалтерия80)
                                            или (КонстантаКонфигурация=Перечисление.БухгалтерскиеПрограммы.Бухгалтерия16)
                                            или (КонстантаКонфигурация=Перечисление.БухгалтерскиеПрограммы.БПКОРП) Тогда
                                                ШаблонПроводки = глПодобратьШаблонПроводки("Дт "+ШаблонДополнительногоОтчисления.СчетДебета.Код+" Кт "+СчетБудущихПериодов.Код+" (зарплата)",
                                                ШаблонДополнительногоОтчисления.СчетДебета, ШаблонДополнительногоОтчисления.Субконто1Дебета,ШаблонДополнительногоОтчисления.Субконто2Дебета,ШаблонДополнительногоОтчисления.Субконто3Дебета,ШаблонДополнительногоОтчисления.Субконто4Дебета,ШаблонДополнительногоОтчисления.Субконто5Дебета,ШаблонДополнительногоОтчисления.Субконто6Дебета,ШаблонДополнительногоОтчисления.Субконто7Дебета,
                                                СчетБудущихПериодов, СубконтоСтатьяРБПФСС_НС,ПустоеСубконто,ПустоеСубконто,ПустоеСубконто,
                                                ШаблонПроводки.ПодпадаетПодЕНВД,ШаблонПроводки.Балансодержатель);   
                                            Иначе
                                                ШаблонПроводки = глПодобратьШаблонПроводки("Дт "+ШаблонДополнительногоОтчисления.СчетДебета.Код+" Кт "+СчетБудущихПериодов.Код+" (отчисления в фонды)",
                                                ШаблонДополнительногоОтчисления.СчетДебета, Субконто1ДебетаВзносовДП,Субконто2ДебетаВзносовДП,Субконто3ДебетаВзносовДП,ШаблонДополнительногоОтчисления.Субконто4Дебета,ШаблонДополнительногоОтчисления.Субконто5Дебета,ШаблонДополнительногоОтчисления.Субконто6Дебета,ШаблонДополнительногоОтчисления.Субконто7Дебета,
                                                СчетБудущихПериодов, ПустоеСубконто,ПустоеСубконто,ПустоеСубконто,ПустоеСубконто,
                                                ШаблонПроводки.ПодпадаетПодЕНВД,ШаблонПроводки.Балансодержатель);
                                            КонецЕсли;
                                           
                                        Иначе
                                           
                                            Если (Найти(СтрокаСправочников,","+СокрЛП(СчетДебета.Субконто1.Идентификатор)+",")>0) и (СокрЛП(СчетДебета.Субконто1.Идентификатор)<>"Справочник.ПрямыеЗатраты") Тогда
                                                Субконто1ДебетаВзносов=Субконто5Дебета;
                                            КонецЕсли;
                                            Если (Найти(СтрокаСправочников,","+СокрЛП(СчетДебета.Субконто2.Идентификатор)+",")>0) Тогда
                                                Если СокрЛП(СчетДебета.Субконто2.Идентификатор)<>"Справочник.ПрямыеЗатраты" Тогда
                                                    Субконто2ДебетаВзносов=Субконто5Дебета;
                                                Иначе  // это для "производства"
                                                   
                                                    Если ПустоеЗначение(Субконто2Дебета)=0 Тогда
                                                        Если СокрЛП(Субконто2Дебета.Код) = "ПрочиеЗатратыПоЗпл" Тогда
                                                            Если Конфигурация = "ПроизводствоСАналитикой" Тогда
                                                                Субконто2ДебетаВзносов=ПрочиеЗатратыПоВзносам_ДляПУБ_сАналитикой;
                                                            Иначе
                                                                Субконто2ДебетаВзносов=ПрочиеЗатратыПоВзносам;
                                                            КонецЕсли;
                                                        Иначе
                                                            Если Конфигурация = "ПроизводствоСАналитикой" Тогда                                           
                                                                Субконто2ДебетаВзносов=ПрочиеЗатратыПоВзносам_ДляПУБ_сАналитикой;
                                                            Иначе
                                                                Субконто2ДебетаВзносов=ПустоеСубконто;
                                                            КонецЕсли;
                                                        КонецЕсли;
                                                    Иначе
                                                        Если Конфигурация = "ПроизводствоСАналитикой" Тогда                                           
                                                            Субконто2ДебетаВзносов=ПрочиеЗатратыПоВзносам_ДляПУБ_сАналитикой;
                                                        Иначе
                                                            Субконто2ДебетаВзносов=ПустоеСубконто;
                                                        КонецЕсли;
                                                    КонецЕсли;
                                                   
                                                КонецЕсли;
                                            КонецЕсли;
                                            Если (Найти(СтрокаСправочников,","+СокрЛП(СчетДебета.Субконто3.Идентификатор)+",")>0) и (СокрЛП(СчетДебета.Субконто3.Идентификатор)<>"Справочник.ПрямыеЗатраты") Тогда
                                                Субконто3ДебетаВзносов=Субконто5Дебета;
                                            КонецЕсли;
                                           
                                            Если (КонстантаКонфигурация=Перечисление.БухгалтерскиеПрограммы.Бухгалтерия80)
                                            или (КонстантаКонфигурация=Перечисление.БухгалтерскиеПрограммы.Бухгалтерия16)
                                            или (КонстантаКонфигурация=Перечисление.БухгалтерскиеПрограммы.БПКОРП) Тогда
                                                ШаблонПроводки = глПодобратьШаблонПроводки("Дт "+СчетДебета.Код+" Кт "+СчетБудущихПериодов.Код+" (зарплата)",
                                                СчетДебета, Субконто1Дебета,Субконто2Дебета,Субконто3Дебета,Субконто4Дебета,Субконто5Дебета,Субконто6Дебета,Субконто7Дебета,
                                                СчетБудущихПериодов, СубконтоСтатьяРБПФСС_НС,ПустоеСубконто,ПустоеСубконто,ПустоеСубконто,
                                                ШаблонПроводки.ПодпадаетПодЕНВД,ШаблонПроводки.Балансодержатель);   
                                            Иначе
                                                ШаблонПроводки = глПодобратьШаблонПроводки("Дт "+СчетДебета.Код+" Кт "+СчетБудущихПериодов.Код+" (отчисления в фонды)",
                                                СчетДебета, Субконто1ДебетаВзносов,Субконто2ДебетаВзносов,Субконто3ДебетаВзносов,Субконто4ДебетаВзносов,Субконто5ДебетаВзносов,Субконто6Дебета,Субконто7Дебета,
                                                СчетБудущихПериодов, ПустоеСубконто,ПустоеСубконто,ПустоеСубконто,ПустоеСубконто,
                                                ШаблонПроводки.ПодпадаетПодЕНВД,ШаблонПроводки.Балансодержатель);
                                            КонецЕсли;
                                           
                                        КонецЕсли;
                                       
                                        ТаблицаКорреспонденций.НоваяСтрока();
                                        ТаблицаКорреспонденций.Сотрудник = Сотрудник.ОсновнойЭлемент;
                                        ТаблицаКорреспонденций.ВидРасчета = ВР;
                                        ТаблицаКорреспонденций.Шаблон = ШаблонПроводки;
                                        ТаблицаКорреспонденций.Сумма = СуммаПроводкиНалоги_ФСС_НС;
                                       
                                        Если КонстантаКонфигурация=Перечисление.БухгалтерскиеПрограммы.БПКОРП Тогда
                                            Если ТаблицаКорреспонденций.Шаблон.СчетДебета.УчетПоПодразделениям=1 Тогда
                                                ТаблицаКорреспонденций.ПодразделениеДт = ПодразделениеСотрудникаНаКонецПериода;   
                                            КонецЕсли;
                                            Если ТаблицаКорреспонденций.Шаблон.СчетКредита.УчетПоПодразделениям=1 Тогда
                                                ТаблицаКорреспонденций.ПодразделениеКт = ПодразделениеСотрудникаНаКонецПериода;   
                                            КонецЕсли;
                                        КонецЕсли;
                                       
                                       
                                    КонецЕсли;

 

10.02.11 Добавила архив с md с моими изменениями.

Мои изменения помечены комментариями //***изм{  и  //***изм}

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
md -файл с изменениями
.rar 5,02Mb
27.06.13
467
.rar 5,02Mb 467 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Светлана Иванова (Cvetic) 09.02.11 10:59
2. niktas (niktas2009@yandex.ru) 09.02.11 11:26
Тоже наступили на эти грабли. Присоединяюсь к спасибо. Будем изменять недоработки студентов с 1С.
3. Андрей (Свой) 09.02.11 12:45
Срочно нужен тэг "Ошибки ЗиК 306" !!!
4. ПодОпытный (mihenius) 09.02.11 15:00
Для начала можно перенести в рубрику: Исправление ошибок в 1С
http://infostart.ru/public/?rubric=1646
5. MIM (3k-soft@bk.ru) 09.02.11 15:23
Подскажите, после описанных изменений в Гл.модуле, свод проводок выдаёт дополнительные ставки и плюсует их в итог.
ФСС в итоге вместо 11104.67 получаем 11238.77 и так далее ...
Что может быть не так?
Спс
Прикрепленные файлы:
bold13; gogofogo; +2 Ответить 2
6. vkr (vkr) 09.02.11 15:36
(0) Огромное спасибо! Напоролись на сей глюк,
подергались и решили подождать гуру...
И вот она сошла к нам !!! Питер рулеззз !!! :)
7. Елена Мocкаленко (melenaspb) 09.02.11 16:35
(5) А до изменений было нормально?
Просто судя по вашей картинке у вас может есть не рассчитанные записи в журнале расчетов, может не по всем взносы расчитаны. Надо проверить совпадает ли количество людей в документах Начисление зарплаты и Начисление страховых взносов. Перепровести все эти документы и повторить расчет
8. rdv (rdv) 09.02.11 17:02
Люди, кто сталкивался с начислением страховых взносх ФСС НС и ПЗ (0,2%) нерезидентам, в 306 релизе им ничего не начисляется, хотя должно.
9. MIM (3k-soft@bk.ru) 09.02.11 18:32
(7)Тень бросать на Вас не буду :)
разница гдето в Наших шаблонах похоже
на одни сформировалось норм все ставки и суммы, а на други все левые проценты
будем поискать
Спасибо
11. Света Зеленкова (cler_31) 10.02.11 11:52
MIM,
(5) Возможно, ваша ситуация свзяна вот с этой ошибкой ошибка 306 . Нормально у тех, у кого нет вычета в 4000 и не нормально у тех, у кого есть.
12. Griz (Griz) 10.02.11 13:44
13. Александр Нам (alxnam) 11.02.11 11:04
Подскажите пожалуйста как установить "Чайнику"
14. MariP Назарова (MariP) 17.02.11 21:09
Обратитесь к ГБ, в этом году другое отношение к БУ счета 97.
Многие совсем теперь подругому читают ПБУ!
Возможно это не ошибка...
15. Юлия Бойко (Yul_kat) 18.02.11 14:13
А остальные налоги не будем с 97 на затраты списывать?
16. Юлия Бойко (Yul_kat) 18.02.11 14:20
Я так поняла поправкаи в Положение по ведению бухучета (утв. приказом Минфина России от 29.07.98 № 34н) по поводу отмены 97 счёта так и не приняли?
18. baa50 (baa50) 21.02.11 19:34
А мне пришлось еще исправлять в 75209 строке (у меня такая вышла) чтобв 97 закрывался полностью
Если СуммаПроводкиПоВзносам <> 0 Тогда
Если (Найти(СтрокаСправочников,","+СокрЛП(СчетДебета.Субконто1.Идентификатор)+",")>0) и (СокрЛП(СчетДебета.Субконто1.Идентификатор)<>"Справочник.ПрямыеЗатраты") Тогда
Субконто1Дебета=Субконто4Дебета;
КонецЕсли;
Если Найти(СтрокаСправочников,","+СокрЛП(СчетДебета.Субконто2.Идентификатор)+",")>0 Тогда
Если СокрЛП(СчетДебета.Субконто2.Идентификатор)<>"Справочник.ПрямыеЗатраты" Тогда
Субконто2Дебета=Субконто4Дебета;
Иначе // это для "производства"

Если ПустоеЗначение(Субконто2Дебета)=0 Тогда
Если СокрЛП(Субконто2Дебета.Код) = "ПрочиеЗатратыПоЗпл" Тогда

Если Конфигурация = "ПроизводствоСАналитикой" Тогда
Субконто2Дебета=ПрочиеЗатратыПоСтрахВзносам_ДляПУБ_сАналитик­ой;
Иначе
Субконто2Дебета=ПрочиеЗатратыПоСтрахВзносам
КонецЕсли;
Иначе
Если Конфигурация = "ПроизводствоСАналитикой" Тогда
Субконто2Дебета=ПрочиеЗатратыПоСтрахВзносам_ДляПУБ_сАналитик­ой;
Иначе
Субконто2Дебета=ПустоеСубконто;
КонецЕсли;

КонецЕсли;

Иначе
Если Конфигурация = "ПроизводствоСАналитикой" Тогда
Субконто2Дебета=ПрочиеЗатратыПоЕСН_ДляПУБ_сАналитикой;
Иначе
Субконто2Дебета=ПустоеСубконто;
КонецЕсли;
КонецЕсли;

КонецЕсли;
КонецЕсли;
Если (Найти(СтрокаСправочников,","+СокрЛП(СчетДебета.Субконто3.Идентификатор)+",")>0) и (СокрЛП(СчетДебета.Субконто3.Идентификатор)<>"Справочник.ПрямыеЗатраты") Тогда
Субконто3Дебета=Субконто4Дебета;
КонецЕсли;

Если (КонстантаКонфигурация=Перечисление.БухгалтерскиеПрограммы.Бухгалтерия80)
или (КонстантаКонфигурация=Перечисление.БухгалтерскиеПрограммы.Бухгалтерия16)
или (КонстантаКонфигурация=Перечисление.БухгалтерскиеПрограммы.БПКОРП) Тогда
ШаблонПроводки = глПодобратьШаблонПроводки("Дт "+СчетДебета.Код+" Кт "+СчетБудущихПериодов.Код+" (зарплата)",
СчетДебета, Субконто1Дебета,Субконто2Дебета,Субконто3Дебета,Субконто4Дебета,Субконто5Дебета,Субконто6Дебета,Субконто7Дебета,
СчетБудущихПериодов, СубконтоСтатьяРБПСтраховыеВзносы,ПустоеСубконто,ПустоеСубконто,ПустоеСубконто,
ШаблонПроводки.ПодпадаетПодЕНВД,ШаблонПроводки.Балансодержатель);
Иначе
ШаблонПроводки = глПодобратьШаблонПроводки("Дт "+СчетДебета.Код+" Кт "+СчетБудущихПериодов.Код+" (отчисления в фонды)",
СчетДебета, Субконто1Дебета,Субконто2Дебета,Субконто3Дебета,Субконто4Дебета,Субконто5Дебета,Субконто6Дебета,Субконто7Дебета,
СчетБудущихПериодов, ПустоеСубконто,ПустоеСубконто,ПустоеСубконто,ПустоеСубконто,
ШаблонПроводки.ПодпадаетПодЕНВД,ШаблонПроводки.Балансодержатель);
КонецЕсли;


ТаблицаКорреспонденций.НоваяСтрока();
ТаблицаКорреспонденций.Сотрудник = Сотрудник.ОсновнойЭлемент;
ТаблицаКорреспонденций.ВидРасчета = ВР;
ТаблицаКорреспонденций.Шаблон = ШаблонПроводки;
//ТаблицаКорреспонденций.Сумма = СуммаПроводкиНалоги; ЭТО МЕСТО
ТаблицаКорреспонденций.Сумма = СуммаПроводкиПоВзносам;
19. Denis Lookin (lookindenis) 21.02.11 23:31
(16) а йа просто удалил фсе проводки по 97 =)
и сделал как и с НДФЛом (по периоду регистрации) в случае
расходов будущих периодов

какт так...
20. Федосеева Наталья (fng-kam) 22.02.11 01:14
Спасибо большое. Очень вовремя. :D
21. Светлана Иванова (Cvetic) 02.03.11 14:58
Теперь февраль неправильно закрывается :( Даже непонятно что за сумма берется по Кт 97. Она больше чем переходящие отпуска + налоги по этим отпускам. Никто не сталкивался?
22. Светлана Иванова (Cvetic) 02.03.11 15:05
Попробовала убрать настройки публикации - в Кт 97 ставит сумму отпускных без налогов. В 308 релизе тоже самое.
23. baa50 (baa50) 17.03.11 16:39
Cvetic пишет:

Теперь февраль неправильно закрывается Даже непонятно что за сумма берется по Кт 97. Она больше чем переходящие отпуска + налоги по этим отпускам. Никто не сталкивался?


я поступил проще в глобальнике
заменил //СуммаФСС_НС = ?(Сч = КолРасходовВНУ,БазаФСС_НСнеЕНВД - НакопилиФСС_НС, СуммаФСС_НС);
на
СуммаФСС_НС = ?(Сч = КолРасходовВНУ,БазаФССнеЕНВД - НакопилиФСС_НС, СуммаФСС_НС);
времени не было более детально искать, подозреваю что в 11 году используется расчеткоректирующихкоэфф2010.
lord-nick; +1 Ответить
24. Владимир Валерьевич (perkos) 15.04.11 09:51
тема актуальна для 309 релиза?
25. flaks Данилова (flaks) 20.09.11 22:20
Спасибо! в свое время очень помогло
26. Михаил Юргин (mihail_yurgin) 20.11.11 02:14
27. 1 s (sssvetl) 20.11.11 06:59
97 сейчас не используется для РБП
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа