Распределение больничного листа для ЗИК 7.7 релиз 308

Опубликовал Яков Кушпетюк (Jacob34) в раздел Программирование - Практика программирования

Решил проблема с распределением больничного листа по проводкам в ЗИКе для бюджетных организаций. С определенным знанием кода можно переделать  для хоз расчетников. Потребуется сделать небольшие модификации кода.

Проблема: распределить больничный лист по проводкам базовых начислений.

Решение: Реализация с использованием документа "Бух учет начислений"

1. Меняем состав документов , на основании которых вводится док "БухучетНачислений": входим в конфигуратор, открываем док и нажимаем кнопку "Ввод на основании". Затем ставим галочку в графе "Вводить на основании" у документа "Больничный лист".

2. Заходим в форму документа. Создаем на форме кнопку с вызовом процедуры (у меня она называется "ЗаполнитьБЛ()"). В модуле формы вставляем в любое место процедуру:

см Файл 1

 

3. В глобальнике в меняем функцию глПолучитьРаспределениеРезультата()   вставляем код

см файл 2

Для простоты вставил код всей функции. Можно ее брать и полностью заменять. Кому интересно смотрите комментарий "//здесь измения". Претендую только на код, заключенный в рамках данного комментария.

Кому непонятно, пишите. Если смогу помочь, сделаю это. И конечно плюсуйте, если понравилось.

 

Скачать файлы

Наименование Файл Версия Размер
Файл 1 и Файл 2 в одном архиве
.rar 12,39Kb
09.03.11
305
.rar 12,39Kb 305 Скачать

См. также

Комментарии
1. Виктор Селезнев (вик) 31 09.03.11 11:27 Сейчас в теме
А как насчет того, что часть начислений идет за счет работодателя, а часть за счет ФСС?
2. Vladimir (Boroda) 90 09.03.11 12:08 Сейчас в теме
3. Евгений (FreeXer) 63 09.03.11 12:30 Сейчас в теме
Один файл два раза загрузили. Куда не жмешь - первый файл загружается.
Просьба сделать Архив из двух файлов и закачать этот один Архив )
4. Оля Носова (Nataly_2012) 09.03.11 13:05 Сейчас в теме
Один файл два раза загрузили.
Функции глобального модуля глПолучитьРаспределениеРезультата() - нет.
5. Дима (dvdimka) 09.03.11 14:21 Сейчас в теме
В теории идея отличная -вытащить распределение по иФ через штатный документ, но много нюансов. Как, например, распределять при достижении предельной величины 415 тыс за год?
6. Яков Кушпетюк (Jacob34) 143 09.03.11 21:08 Сейчас в теме
Все исправил. Выложил один архив. Он без пароля и там два файла.
7. Яков Кушпетюк (Jacob34) 143 09.03.11 21:09 Сейчас в теме
На счет больничного за счет работодателя- все распределяется в соответствии с проводками. В этом плане все работает корректно.
8. Яков Кушпетюк (Jacob34) 143 09.03.11 21:15 Сейчас в теме
dvdimka пишет:
В теории идея отличная -вытащить распределение по иФ через штатный документ, но много нюансов. Как, например, распределять при достижении предельной величины 415 тыс за год

Суть в следующем: Мы достаем все начисления за 2 года которые входят в базу страховых взносов и берем распределение этой базы по проводкам. На мой взгляд суть распределения заключается в пропорциональном распределении больничного по начислениям. В принципе, если возникает ситуация с превышением 415 тыс руб, то данную ситуацию отрабатывает сам больничный, ограничивая размер начисления по больничному листу, при этом распределяем полученную сумму по базовым начислениям. Если есть идеи, то могу их реализовать ради собственного интереса. Пишите.
9. Татьяна Шавлак (Stety) 142 10.03.11 11:20 Сейчас в теме
Насчет превышения предельной величины облагаемой базы точка зрения правильная - не имеет смысла заморачиваться этим при определении пропорции распределения. Ведь превышение как правило происходит внутри какого-то периода, а внутри него начисления, образующие базу могут начисляться не только "с первого по тридцать первое". Пока законодательно нет требования углубляться в эти изыски, нет смысла мозг себе и бухам этими ужасами выносить. :D
10. Александр Верхотурцев (AlexW) 11.03.11 12:39 Сейчас в теме
За идею плюс. Попробовал. Документ "БухУчетНачислений" работает почти нормально, если не брать в расчет некоторые виды расчета, например "матпощь". Но вот свод проводок не распределяет проводки за счет ФСС, всё ставит на бюджет. Может я еще что-то не учел?
И ксати, почему у вас в процедуре глПолучитьРаспределениеРезультата() изменения только в ветке "Если СобиратьДанныедляЕСН"?
Разве не надо еще изменить "Если СобиратьДанныеБухУчета"?
11. ПодОпытный (mihenius) 86 14.03.11 11:14 Сейчас в теме
Может лучше перенести в "Исправление Ошибок 1С"?
http://infostart.ru/public/?rubric=1646
12. Олег Олег (Oliwer) 17.03.11 13:19 Сейчас в теме
Все сделал, но пишет сообщение что для В.Р. "Оплата больничного листа" проводка не корректна и сформирована не будет
в виде расчета Б/л в Дт 303.02/КБК/830/ФСС_НС/Расходы по страхованию в Кт 302.03/КБК/730/Сотрудники
В тип дохода для страховых взносов - Не является объектом налогообложения
И кстати, не смотря на это сообщение делает проводки но все на бюджет.

И еще. Я правильно понял последовательность?
Делаем Б/л, затем на основании его БухУчетНачислений, затем расчитать ЗП.
13. Юлия (Pulyalya) 4 17.03.11 17:09 Сейчас в теме
Если убрать :

Если (Режим = "Проверка") и (ДокРаспределение.шаблонпроводки.Выбран() = 1) Тогда
Если ПроверкаХозоперации(ШаблонУчета,ВР,ПроверятьСконфигурированныеУдержания)=0 Тогда
глСообщениеТрассировки(глСообщенияТрассировки, "Указанная в "+ДокРаспределение.НомерСтроки+" строке документа "+глПредставлениеДокумента(ДокРаспределение)+" для в.р. """+глПредставлениеВидаРасчета(ВР)+""" проводка некорректна и сформирована не будет.", -1,0,,,,,,,,,ДокРаспределение); Продолжить
КонецЕсли;
КонецЕсли;

в блоке "//здесь изменения" , то проводки выдает правильные.

Но не распределяет бл за прошлый расчетный период.К примеру, в марте сотрудник принес бл 27.02.11-05.03.11, та чать бл которая за февраль не распределяется(или падает на основной источник), а часть бл за март распределяется.
14. Яков Кушпетюк (Jacob34) 143 17.03.11 17:12 Сейчас в теме
Oliwer,. Могу ответить следующее: последовательность правильная, а по поводу ошибки не могу сказать однозначно, т.к. не встречал ее. У меня стоит уже примерно у 15 клиентов и они закрыли месяца. Пока все нормально. Поэтому могу помочь только если пришлете базу на мой ящик. Пока можно только мд, я его проверю. Если все правильно, тогда надо отлавливать ошибку на реальной базе.
15. Lika P (Lika-Kalika) 10 17.03.11 22:02 Сейчас в теме
Писала в поддержку 1с (месяц назад), мне ответили, что они собираются дописать распределение (по базе для страховых взносов).
16. Юлия (Pulyalya) 4 18.03.11 21:26 Сейчас в теме
Разобралась с переходящим бл (прошлый месяц плюс текущий) тогда надо вводить 2 док-та бухучет, один за прошлый месяц, второй за текущий.
17. Вера Одегова (vera4ka) 25.03.11 08:28 Сейчас в теме
идея и правда классная,только в глобальном модуле ошибка.я думаю надо добавить проверку "Если Документы.ДокОснование= Документ Тогда"... а иначе получается,что находится первый док,и все распределяется по нему.причем если ечть челы,у которых БЛ только по одному источнику,у них тоже все поделится...
18. andrue-t (andrue-t) 07.04.11 18:28 Сейчас в теме
не работает:

Если ДокОснование<<?>>.Вид() = "БольничныйЛист" Тогда
{Документ.БольничныйЛист.Форма.Модуль(7395)}: Переменная не определена (ДокОснование)
19. Вера Одегова (vera4ka) 07.04.11 18:50 Сейчас в теме
почему? добавляем эту проверку не в больничном листе,а в глобальном модуле
ИначеЕсли ВидДока = "БольничныйЛист" Тогда
Документы = СоздатьОбъект("Документ.БухучетНачислений");
ДокРаспределение = ПолучитьПустоеЗначение("Документ.БухучетНачислений");
ДатаВыборки = КонМесяца(ДатаОкончания);
Если Документы.ВыбратьДокументы(ДатаВыборки,ДатаВыборки) = 1 Тогда
Пока Документы.ПолучитьДокумент()=1 Цикл
Если Документы.ДокОснование=Документ ТОгда //вот здесь!!!!
Если (Документы.Проведен() = 0) Тогда
Продолжить;
КонецЕсли;
ДокРаспределение = Документы.ТекущийДокумент();
Прервать
КонецЕсли;
КонецЦикла
КонецЕсли;
20. Наталья Михеева (ЦБК) 12.04.11 11:34 Сейчас в теме
Как решить проблему с распределением больничного листа по проводкам в ЗИКе для бюджетных организаций на релизе 309???
21. Юлия (Pulyalya) 4 14.05.11 19:41 Сейчас в теме
Распределяет только начисление б\листа, при этом НДФЛ с б\л не распределяет по источникам и в док-тах выплата зп, накопленная задолженность тоже не видно этого распределения.
22. Антон Подольный (Hidden_Note) 18.05.11 14:38 Сейчас в теме
Автору спасибо за идею. Для распределения НДФЛ всё же добавил аналогичные изменения и в ветку Если СобиратьДанныеБухУчета = 1... Вот только если там тоже прописать Если ВидДока = "БольничныйЛист" (с учетом, что у новых больничных ПособияПоСреднемуНеРаспределять=1), она задвоит уже имеющиеся строки распределения по проводкам (при обходе начислений). В этом случае надо фильтровать добавление новой строки в ТаблицаРаспределения, если аналогичная строка уже есть.
23. Дима (dvdimka) 03.06.11 10:07 Сейчас в теме
А поподробней можно про распределение НДФЛ?
24. Игорь Гладкий (smooth) 173 23.08.11 14:29 Сейчас в теме
Автору спасибо за идею!
Только я перенес блок изменений глмодуля из раздела "Если СобиратьДанныеУчетаЕСН = 1 Тогда" в блок "Если СобиратьДанныеБухУчета = 1 Тогда" и вопрос распределения б/л, ндфл, и выплат решился (то (22) и контролировать дублирование строк не надо ;)).
Увеличил интервал выборки документов "БухучетНачислений" с КонМесяца(ДатаОкончания) по КонМесяца(ДобавитьМесяц(ДатаОкончания,3)) - это к вопросу переходящих б/л от Pulyalya (14),(16), ну, и поставил условие на ДокОснование (Если Документы.ДокОснование = Документ Тогда)
И вроде все работает ;)
25. Дима (dvdimka) 31.08.11 11:20 Сейчас в теме
в 309 релизе все работало, а в 313 распределяет, но в проводки БЛ не попадает..
26. Ирина Баранова (Ироида) 8 08.09.11 23:57 Сейчас в теме
27. Viktor (kurvik) 21.09.11 19:15 Сейчас в теме
Было бы отлично, если добавить еще автоматизированный контроль за теми суммами которые попали в расчет больничного за два года и теми, что включились в документ "Бух учет начислений" для распределения по источникам.Выдавать разницу.
28. Юлия (Pulyalya) 4 12.10.11 22:49 Сейчас в теме
Спасибо автору! Но надо убрать еще суммы мат.помощи (необлагаемой страх. взносами до 4т.р.)из суммы, попадающей в документ бух учет начислений.
29. Алиса Гудкайд (kainiss) 1 09.12.11 11:17 Сейчас в теме
Cпасибо,переделал для документа ПРиказ о работе в праздничные дни.
30. Александр (fast) 21.12.11 15:01 Сейчас в теме
Очень полезная информация, использовал как шаблон, немного переделывал под нужды клиента, с экономил уйму времени за что и спасибо.
31. Ершова Ольга (lushka) 8 28.12.11 07:18 Сейчас в теме
Автору спасибо, реально выручило в свое время, с кое-какими доработками "под себя"
32. Светлана Фоменко (safia-med) 13.03.14 10:10 Сейчас в теме
Как учитываются суммы материальной помощи не облагаемые налогами?
Оставьте свое сообщение