gifts2017

УнифицированнаяФорма Т-12 и Т-13

Опубликовал Денис Шевченко (denium) в раздел Печать - Печатные формы документов

УнифицированнаяФорма Т12 и Т13.
Возможность выбора формы в одном отчете.

УнифицированнаяФорма Т12 и Т13.

Один отчет для двух регламентированных форм Т-12 и Т-13.

Создан на основе типового, с возможностью переключения.

В Т-13 добавлены суммы по отработанному времени с рашифровкой по видам.

           
код вида оплаты кор-
респон- дирую- щий
счет
дни
(часы)
код вида оплаты кор-
респон- дирую- щий
счет
дни
(часы)
7 8 9 7 8 9
Я   127      
РВ   32      
           
           

26.03.2011

В Т-12 добавлено заполнение колонок по сверхурочным,ночным,празничным,выходным дням, а также итог по неявкам.

             
Итого отработано за месяц
Количе-ство неявок,
дней (часов)
дней часов        
  всего из них      
    сверхуроч-ных ноч-ных выходных, праздничных  
8 9 10 11 12 13 14
13 104         9
 
24 71
 

28.03.2011

Выявлена ошибка с итогами по сверхурочным, исправлено в Т-12,Т-13

27.04.2011

Выявлена ошибка использования типовых функций, которых уже нет в новых релизах.

20.10.2011

Переделал отчет, на основе типового ЗУП 2.5.40.3

В типовом появилась возможность при переводах внутри месяца видить табель отделно для каждой должности.

Исправлены некоторые ошибки.

Перезалил, доступно для скачивания как старая так и новая версия. Еcли нравится поставьте + Smile

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
УнифицированнаяФормаТ13 (новая версия)
.erf 79,10Kb
20.10.11
255
.erf 79,10Kb 255 Скачать
УнифицированнаяФормаТ13 (старая версия)
.erf 76,44Kb
20.10.11
199
.erf 76,44Kb 199 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. AlexaKot (AlexaKot) 23.03.11 14:30
Не считает ночные/сверхурочные/выходные часы :-( (в табеле-12)
2. Денис Шевченко (denium) 24.03.11 10:13
"Не считает ночные/сверхурочные/выходные часы (в табеле-12) "
Планирую исправить чуть позже ...
3. BigB (BigB) 25.03.11 08:34
Мне тоже нужны ночные/сверхурочные/выходные часы в Т-12.
С нетерпением буду ждать обновления отчета.
4. Денис Шевченко (denium) 26.03.11 13:25
Залил новую версию, пришлось обнулить счетчик скачиваний со 100 до 0 :D
5. BigB (BigB) 28.03.11 13:27
В новой версии бухи говорят, что ночные считаются, а сверхурочные нет. Сам не проверял.
6. Денис Шевченко (denium) 28.03.11 18:41
А ты проверь по табелю, сверхурочное должно отображаться у тебя в табеле что Т13 что Т12 буквой "С", я сам тестировал все состояния.
7. Денис Шевченко (denium) 28.03.11 18:49
Вот фрагмент кода
Иначе
ОбластьДанныхСтрока.Параметры.мНочных =мДанныеОбОтработанномВремени.Получить(Справочники.КлассификаторИспользованияРабочегоВремени.РаботаНочныеЧасы);
ОбластьДанныхСтрока.Параметры.мСверхурочных=мДанныеОбОтработанномВремени.Получить(Справочники.КлассификаторИспользованияРабочегоВремени.Сверхурочные);
Если мДанныеОбОтработанномВремени.Получить(Справочники.КлассификаторИспользованияРабочегоВремени.ВыходныеДни) <> Неопределено Тогда
мВыходныеДни = мДанныеОбОтработанномВремени.Получить(Справочники.КлассификаторИспользованияРабочегоВремени.ВыходныеДни);
Иначе
мВыходныеДни =0;
КонецЕсли;
Если мДанныеОбОтработанномВремени.Получить(Справочники.КлассификаторИспользованияРабочегоВремени.ДополнительныеВыходныеДниОплачиваемые) <> Неопределено Тогда
мДополнительныеВыходныеДниОплачиваемые = мДанныеОбОтработанномВремени.Получить(Справочники.КлассификаторИспользованияРабочегоВремени.ДополнительныеВыходныеДниОплачиваемые);
Иначе
мДополнительныеВыходныеДниОплачиваемые =0;
КонецЕсли;

ОбластьДанныхСтрока.Параметры.мВыходных = мВыходныеДни + мДополнительныеВыходныеДниОплачиваемые;

ОбластьДанныхСтрока.Параметры.мПраздничных =мДанныеОбОтработанномВремени.Получить(Справочники.КлассификаторИспользованияРабочегоВремени.Праздники);
КонецЕсли;

Как видишь тут определены все состояния из справочника КлассификаторИспользованияРабочегоВремени
8. Денис Шевченко (denium) 28.03.11 18:53
Возможно твои бухи путают сверхурочные с оплатой выходных дней, посмотри буквы по табелю и все поймешь.
Работа в выходные дни будет отображена как РВ, и ляжет в колонку Выходных дней.
9. Денис Шевченко (denium) 28.03.11 19:22
Извините, ввел в заблуждение косяк по сверхурочным дейсвтительно есть , это единсвенное состояние которое я не проверил.
Исправлю в ближайшее время. :(
10. Денис Шевченко (denium) 28.03.11 20:15
ИСПРАВИЛ,
Залил новый отчет ...
11. Владимир (a_vovan) 18.04.11 08:45
Отчет не скачивается - скачивается файл "копия" без расширения.

Добавление .epf не помогает.
12. Владимир (a_vovan) 18.04.11 09:10
Помогло добавление к имени файла .erf
13. гидрострой админ (gidrostroi) 22.04.11 13:52
Скажите, пожалуйста:
у нас 8.2 Зарплата 2.5.31.4
при попытке загрузки отчета ругается:
"{Справочник.ВнешниеОбработки.Форма.ФормаЭлемента(170)}: Ошибка при вызове метода контекста (Создать): Ошибка подключения внешних метаданных: Ошибка загрузки документа.
Внешний отчет не может быть прочитан текущей версией программы."

есть ли какой-то способ решить проблему?
очень нужен хороший Т-13

заранее спасибо!
14. Денис Шевченко (denium) 23.04.11 20:36
Откройте сначала мой отчет в конфигураторе, он предложит конвертировать его из весрии 1с 8.1 в версию 1с 8.2
После этого можно работать с ним в редакции 1с 8.2
15. гидрострой админ (gidrostroi) 25.04.11 14:34
(14)Спасибо Вам огромное! Бухгалтерия счастлива!
16. гидрострой админ (gidrostroi) 25.04.11 15:14
(14)Рано мы радовались.
При формировании отчета вылетала ошибка
{ВнешнийОтчет.УнифицированнаяФормаТ13.МодульОбъекта(1781)}: Метод объекта не обнаружен (ФамилияИнициалыОтветсвенногоЛица)
							ОбластьДанныхПодвал.Параметры.ФИООтветственного = УправлениеОтчетами.ФамилияИнициалыОтветсвенногоЛица(ВыборкаПоРаботнику.ФизЛицоОтветственного, ВыборкаПоРаботнику.ФамилияОтветственного, ВыборкаПоРаботнику.ИмяОтветственного, ВыборкаПоРаботнику.ОтчествоОтветственного);


После того как в модуле объекта закомментировала 6 строк со словами "ФамилияИнициалыОтветсвенногоЛица" (предварительно попробовав исправить ОтветСВенного на ОтветСТВенного - безрезультатно) - все заработало, но конечно же не проставляется Ответственное лицо (в то время как с Руководителем и Кадровиком все ок). Бухгалтерия была счастлива пока это не заметила :)

Возможно ли что-то с этим сделать?
Будем Вам очень благодарны, потому что в остальном все просто идеально (проблема с формированием табелей при гибком графике сотрудника решена на ура!)
17. Денис Шевченко (denium) 26.04.11 22:22
Данный отчет тестировался на Релизах 1с 8.1 редакция 2.5.26 и выше, в данный моменет успешно работает на
2.5.34.
Честно говоря после перехода я оставил старый модуль, скорее всего нужно заменить фрагмент на который ругаеться система
ОбластьДанныхПодвал.Параметры.ФИООтветственного = УправлениеОтчетами.ФамилияИнициалыОтветсвенногоЛица(ВыборкаПоРаботнику.ФизЛицоОтветственного,ВыборкаПоРаботнику.ФамилияОтветственного, ВыборкаПоРаботнику.ИмяОтветственного, ВыборкаПоРаботнику.ОтчествоОтветственного);

меняем на

ОбластьДанныхПодвал.Параметры.ФИООтветственного = УправлениеОтчетамиЗК.ФамилияИнициалыОтветсвенногоЛица(ВыборкаПоРаботнику.ФизЛицоОтветственного,ВыборкаПоРаботнику.ФамилияОтветственного, ВыборкаПоРаботнику.ИмяОтветственного, ВыборкаПоРаботнику.ОтчествоОтветственного);

Дело в том что несколько релизов назад 1с стала перемещать функции из УправлениеОтчетами в УправлениеОтчетамиЗК.
Я оставил и те и другие для соместимости, поэтому не заметил что на чисто типовом решении может выходить ошибка.

Перезалил новый отчет заменил все вызовы из модуля УправлениеОтчетами на УправлениеОтчетамиЗК.
18. гидрострой админ (gidrostroi) 27.04.11 13:21
Спасибо большое! Вы волшебник! Все работает точно как надо. спасибо
19. megabyte (megabyte) 28.04.11 09:53
неправильно считает в столбце "неявки по причинам" в форме т-13. т.е. в табеле стоит От - 12 штук! в итог идет 10, типо 2 дня выходных. что не верно!
20. Ирина хаб (Hiren110) 29.04.11 10:51
Добрый день, объясните особо умной..как я скачала файл мои дальнейшие действия..как его установить? спасибо.
21. Денис Шевченко (denium) 29.04.11 14:16
Я так понимаю вы далеки от программирования :D
В таком случае, если у вас платформа 1с 8.1 откройте этот отчет как внешний через файл открыть.
Если 1с 8.2 Откройте сначала мой отчет в конфигураторе, он предложит конвертировать его из весрии 1с 8.1 в версию 1с 8.2.
После конвертации тоже самое что для 1с 8.1.

Если вы программист, до можете заменить в конфигураторе отчет формы Т-13 на мой.
22. Юрий Щербинин (jesus007) 16.05.11 14:52
В ЗУП 2.5.33.4 не учитывает перенос праздника с 1 на второе мая почему-то. Перенос праздников вообще предусмотрен?
23. Lena Grig (GrigLena20) 02.06.11 09:10
Есть ошибка.
Например, если человек в отпуске с 30.04.11 по 15.05.11
В форме Т-13 должно же вывести что 1го и 9го мая "В" выходной, остальное отпуск, а у вас выводит только отпуск.
В стандартной же форме выводятся слишком много выходных 1,2,7,8,9го мая, тоже неправильно.
24. Виталий Барилко (Diversus) 07.06.11 16:40
(0) Да... Поддерживаю (23) не хватает такой штуки.
Хотя отчет хороший
25. wereson@mail.ru Мишустин (wereson) 10.06.11 11:13
У меня вопрос, ваш отчет поддерживает режи вывода сотрудников по заполняемым должностям в отдельных строках? ( если сотрудник в предеелах расчетного периода менял должность и график)
26. Ирина Иванова (I_r_a) 19.10.11 12:39
очень хороший отчет, только не работает отбор по документу "Табель ....", когда добавляю в параметрах отбора НОмер по документу
27. Денис Шевченко (denium) 21.10.11 14:54
(25) wereson,
Реализовано в новой версии.
28. Valery Kovalenko (v.kov945) 20.03.12 15:34
1c 8.1 конфигурация Зарплата и Управление Персоналом (базовая), редакция 2.5 (2.5.13.5)
После запуска внешнего файла выдает ошибки:
{ВнешнийОтчет.УнифицированнаяФормаТ13(119,10)}: Переменная не определена (ПроцедурыУправленияПерсоналомПереопределяемый)
Если Не <<?>>ПроцедурыУправленияПерсоналомПереопределяемый.РегламентированныйКалендарьЗаполнен(НачалоПериода, КонецПериода, Истина) Тогда
{ВнешнийОтчет.УнифицированнаяФормаТ13(1641,57)}: Переменная не определена (УправлениеОтчетамиЗК)
ОбластьДанныхПодвал.Параметры.ФИООтветственного = <<?>>УправлениеОтчетамиЗК.ФамилияИнициалыОтветсвенногоЛица(ВыборкаПоРаботнику.ФизЛицоОтветственного, ВыборкаПоРаботнику.ФамилияОтветственного, ВыборкаПоРаботнику.ИмяОтветственного, ВыборкаПоРаботнику.ОтчествоОтветственного);
{ВнешнийОтчет.УнифицированнаяФормаТ13(1642,57)}: Переменная не определена (УправлениеОтчетамиЗК)
ОбластьДанныхПодвал.Параметры.ФИОРуководителя = <<?>>УправлениеОтчетамиЗК.ФамилияИнициалыОтветсвенногоЛица(ВыборкаПоРаботнику.ФизЛицоРуководителя, ВыборкаПоРаботнику.ФамилияРуководителя, ВыборкаПоРаботнику.ИмяРуководителя, ВыборкаПоРаботнику.ОтчествоРуководителя);
{ВнешнийОтчет.УнифицированнаяФормаТ13(1643,57)}: Переменная не определена (УправлениеОтчетамиЗК)
ОбластьДанныхПодвал.Параметры.ФИОКадровика = <<?>>УправлениеОтчетамиЗК.ФамилияИнициалыОтветсвенногоЛица(ВыборкаПоРаботнику.ФизЛицоКадровика, ВыборкаПоРаботнику.ФамилияКадровика, ВыборкаПоРаботнику.ИмяКадровика, ВыборкаПоРаботнику.ОтчествоКадровика);
{ВнешнийОтчет.УнифицированнаяФормаТ13(2018,59)}: Переменная не определена (УправлениеОтчетамиЗК)
ОбластьДанныхПодвал.Параметры.ФИООтветственного = <<?>>УправлениеОтчетамиЗК.ФамилияИнициалыОтветсвенногоЛица(ВыборкаПоРаботнику.ФизЛицоОтветственного, ВыборкаПоРаботнику.ФамилияОтветственного, ВыборкаПоРаботнику.ИмяОтветственного, ВыборкаПоРаботнику.ОтчествоОтветственного);
{ВнешнийОтчет.УнифицированнаяФормаТ13(2019,59)}: Переменная не определена (УправлениеОтчетамиЗК)

Что нужно сделать для исправления?
29. kitt al;dskjf;ldasjkf (kitt) 29.05.12 08:43
30. Пуд (Пуд) 24.07.12 16:38
Здравствуйте!
Не объясните принцип работы вашей формы?Как я понял по выложенному коду
Иначе 
ОбластьДанныхСтрока.Параметры.мНочных	 =мДанныеОбОтработанномВремени.Получить(Справочники.КлассификаторИспользованияРабочегоВремени.РаботаНочныеЧасы);
ОбластьДанныхСтрока.Параметры.мСверхурочных=мДанныеОбОтработанномВремени.Получить(Справочники.КлассификаторИспользованияРабочегоВремени.Сверхурочные);
Если мДанныеОбОтработанномВремени.Получить(Справочники.КлассификаторИспользованияРабочегоВремени.ВыходныеДни) <> Неопределено Тогда 
мВыходныеДни = мДанныеОбОтработанномВремени.Получить(Справочники.КлассификаторИспользованияРабочегоВремени.ВыходныеДни); 
Иначе 
мВыходныеДни =0; 
КонецЕсли; 
Если мДанныеОбОтработанномВремени.Получить(Справочники.КлассификаторИспользованияРабочегоВремени.ДополнительныеВыходныеДниОплачиваемые) <> Неопределено Тогда 
мДополнительныеВыходныеДниОплачиваемые = мДанныеОбОтработанномВремени.Получить(Справочники.КлассификаторИспользованияРабочегоВремени.ДополнительныеВыходныеДниОплачиваемые); 
Иначе 
мДополнительныеВыходныеДниОплачиваемые =0; 
КонецЕсли; 
ОбластьДанныхСтрока.Параметры.мВыходных	= мВыходныеДни + мДополнительныеВыходныеДниОплачиваемые; 
ОбластьДанныхСтрока.Параметры.мПраздничных =мДанныеОбОтработанномВремени.Получить(Справочники.КлассификаторИспользованияРабочегоВремени.Праздники); 
КонецЕсли;
...Показать Скрыть
- показалось, что анализируется данные Т-13?То есть не в запросе получаются все суммы выходных и т.п.?
31. Пуд (Пуд) 24.07.12 16:46
Ну то есть данные получаются не одним запросом, а при обработке данных. Почему выбран такой способ? Просто хочется узнать,не сочтите за нахальство :)
32. Гульнара Р (Эсти) 11.08.14 04:28
Отчет формируется на основании каких данных? табеля или документов начислений?
AlexandraSerg; +1 Ответить
33. Александра Коробицина (AlexandraSerg) 01.12.15 16:00
Скачала новую версию. Формирую Табель Т-12, выводит неправильно, точнее совсем не считает ночные, сверхурочные и праздники с выходными. Заводим в программу табель учета рабочего времени, в котором указываем как работал сотрудник. Почему Табель не выводит данные?
34. Александра Коробицина (AlexandraSerg) 17.12.15 12:27
Разобралась с отчетом! Если завести все кадровые документы, табель при необходимости и сделать начисление зарплаты, то отчет формирует и заполняет все как надо.
Спасибо за отчет!
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа