gifts2017

Ввод норм расходов для продукции

Опубликовал Олег Валуйский (waol) в раздел Обработки - Обработка справочников

Упрощение процедуры ввода норм расходов продукции, полуфабрикатов для типовой конфигурации Бухгалтерский учет.

Обработка для редактирования/ввода норм расходов для продукции.
Задается группа продукции из справочника Номенклатура, группа материалов из справочника Материалы.
Задается дата показа существующих норм, дата записи новых.
Ввод осуществляется на форме отчета по нормам. Там же - сохранение.
Сохраняются только те позиции, по которым было редактирование.
Значение реквизита "Количество продукции" не изменяется. При создании новых позиций в справочнике норм расходов устанавливается равным 1 на 01.01.80.

Расшифровки на форме отчета работают пока открыта форма обработки.
Хотя, если в ГМ добавить описанные изменения, то будет работать в любом случае.

Можно работать как с внешним, можно встроить в конфигурацию в ветку Отчеты или Обработки с идентификатором "ВводНормРасходов"

Для использования необходима внешняя компонента 1cpp.dll. Релиз, думаю не принципиален, ссылка приведена на последний.


*************
изменения в ГМ:

// изменить
//Процедура ОбработкаЯчейкиТаблицы(Расшифровка, СтандартнаяОбработка, Таблица) Экспорт
//    Перем Отчет;
   
Процедура ОбработкаЯчейкиТаблицы(Расшифровка, СтандартнаяОбработка, Таблица, _Адрес) Экспорт
    Перем Отчет;

    // { ol
    Если ТипЗначенияСтр(Расшифровка) = "СписокЗначений" Тогда
        Если Расшифровка.Получить("ВидРасшифровки")="ВозвратОЯТВОтчет" тогда
            сз_параметр =СоздатьОбъект("СписокЗначений");
            сз_параметр.Установить("Расшифровка",Расшифровка);
            сз_параметр.Установить("Таблица",Таблица); 
            сз_параметр.Установить("Адрес",_Адрес);
            сз_параметр.Установить("РежимОткрытия","ОбработкаЯчейкиТаблицы");
            Отчет=Расшифровка.Получить("Отчет");
           
            Если ФС.СуществуетФайл(Отчет) = 1 Тогда
                ОткрытьФорму("Отчет#",сз_параметр, Отчет);
            ИначеЕсли Метаданные.Отчет(Отчет).Выбран() = 1 Тогда
                ОткрытьФорму("Отчет." + Отчет + "#",сз_параметр);
            ИначеЕсли Метаданные.Обработка(Отчет).Выбран() = 1 Тогда
                ОткрытьФорму("Обработка." + Отчет + "#",сз_параметр);
            КонецЕсли;
            Возврат;
        КонецЕсли;   
    КонецЕсли;   
// изменить

Скачать файлы

Наименование Файл Версия Размер
ВводНР.zip 36
.zip 14,13Kb
04.11.14
36
.zip 14,13Kb Скачать

См. также

Подписаться Добавить вознаграждение
В этой теме еще нет сообщений.