gifts2017

Обмен УТ-БП (не перезагружаемые документы)

Опубликовал Евгений Гущин (gusinea) в раздел Обработки - Обработка документов

При перезагрузке документов из УТ в БП иногда требуется не перегружать некоторые документы. Данная обработка позволяет указать такие документы.
!Создавалась и тестировалась для 1С Предприятие 8.2  (обмен УТ 10.3 -> <БП 2.0), но если подрихтовать я думаю подойдет и для 8.1

При перезагрузке документов из УТ в БП иногда требуется не перегружать некоторые документы. Данная обработка позволяет указать такие документы. Потребуются незначительные изменения конфигурации. Для того чтобы все заработало надо сделать следующее:

  1. Добавить из файла Конф.cf регистр сведений "НеЗамещаемыеДокументыПриОбмене".

  2. Добавить Следующий код в начало процедуры "ПередЗаписьюДокументаДляОбменаТорговляБухгалтерияКОРППередЗаписью", которая находится в общем модуле "ПроцедурыОбменаТорговляБухгалтерияКОРП"  :

	 Запрос1 = Новый Запрос;
Запрос1.Текст = "ВЫБРАТЬ
| НеЗамещаемыеДокументыПриОбменеСрезПоследних.Документ
|ИЗ
| РегистрСведений.НеЗамещаемыеДокументыПриОбмене.СрезПоследних КАК НеЗамещаемыеДокументыПриОбменеСрезПоследних
|ГДЕ
| НеЗамещаемыеДокументыПриОбменеСрезПоследних.НеЗамещать = ИСТИНА
| И НеЗамещаемыеДокументыПриОбменеСрезПоследних.Документ = &Документ";

Запрос1.УстановитьПараметр("Документ", Источник.Ссылка);
Кол=Запрос1.Выполнить().Выгрузить().Количество();
Если Кол <> 0 тогда
    Возврат;
КонецЕсли;
  1. Запускаем обработку НеЗамещаемыеДокументы.epf  и работаем с ней. Все документы, которые не будут выгружаться в БП, будут видны в таблице. Существует возможность просмотреть эти документы за произвольный период. Также существует возможность группового добавления таких документов.

При добавлении в список документа (если он был изменен, но ещё не был выгружен ), он уже не будет выгружаться при последующей выгрузке.

При удалении документа из списка, он будет принудительно перезагружен при следующей выгрузке.


Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Конф.cf
.cf 8,48Kb
29.08.14
79
.cf 8,48Kb 79 Скачать
НеЗамещаемыеДокументы.epf
.epf 15,63Kb
29.08.14
27
.epf 15,63Kb 27 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Сергей Ожерельев (Поручик) 08.04.11 17:00
Кол=Запрос1.Выполнить().Выгрузить().Количество();
Если кол<>0 тогда
Возврат;
КонецЕсли;

Поржало вхлам.

РезультатЗапроса = Запрос1.Выполнить();
Если Не РезультатЗапроса.Пустой() тогда
Возврат;
КонецЕсли;
2. Сергей Ожерельев (Поручик) 08.04.11 17:03
Это во первых.
А во вторых, чем не устроила регистрация изменений для обмена?
3. Евгений Гущин (gusinea) 10.04.11 16:24
(2)Ну и какая разница? Постебаться охота или несколько миллисекунд жизни жалко?
Стандартная, увы, не для всех пользователей подходит... А лично меня более чем устроила.
И вообще, выложил просто от нечего делать, посмотрю недельку, если никому не нужна будет - удалю нафиг
4. Elina Muhamedzyanova (Elina_Muhamedzyanova) 10.11.11 13:11
спасибо, в свое время скачала и воспользовалась, помогла.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа