Универсальная смотрелка DBF-файлов [обновлено!]

Опубликовал aximo в раздел Программирование - Практика программирования

Представляю Вам собственную универсальную смотрелку DBF-файлов. Собственно, для чего она нужна? Подробнее...

 

Представляю Вам собственную универсальную смотрелку DBF-файлов. Собственно, для чего она нужна?

Вообще-то я не ставил себе задачу - написать dbf-смотрелку, но у меня была необходимость написать некую универсальную функцию, которая "запихивала" бы содержание DBF-файла в табличную часть.

Т.е. написал функцию и "забыл" как она работает. Вот сама функция:


Функция DBFвТаблицу(ПутьКDBF, Кодировка)   //вер.1.5
   
ТаблицаДанных = Новый ТаблицаЗначений();
   
ФайлDBF=Новый XBase;
   
ФайлDBF.ОткрытьФайл(ПутьКDBF,,Истина);
    Если
Кодировка = "ANSI" Тогда
       
ФайлDBF.Кодировка = КодировкаXBase.ANSI;
    Иначе
       
ФайлDBF.Кодировка = КодировкаXBase.OEM;
    КонецЕсли;

    Для Каждого
ПолеDBF Из ФайлDBF.Поля Цикл
       
ТаблицаДанных.Колонки.Добавить(ПолеDBF.Имя,,ПолеDBF.Имя);
    КонецЦикла;
   
ФайлDBF.Первая();
    Пока НЕ
ФайлDBF.ВКонце() Цикл
       
ЗаполнитьЗначенияСвойств(ТаблицаДанных.Добавить(),ФайлDBF);
       
ФайлDBF.Следующая();
    КонецЦикла;
   
ФайлDBF.ЗакрытьФайл();
    Возврат
ТаблицаДанных;
КонецФункции

Как логическое продолжение (чтобы тупо не выкладывать эту функцию), решил написать программу, которая будет использовать эту функцию - получилась "смотрелка-dbf".

Для особых педантов сразу скажу - типизация пока не поддерживается, т.к. не было необходимости в этом.

Обработка сделана на Платформе 8.1, использовать ее можно в любой конфигурации или на "голой" платформе.

Кому будет полезна данная обработка:

1.Начинающим программистам 1с - вы можете посмотреть как загрузить dbf в память, автоматически создав необходимые колонки.

2.Простым пользователям - если вы грузите в 1с-ку какие-то dbf-файлы, с помощью этой программы - посмотрите, что грузите, перед записью в базу 1с.

 

Кому поможет, буду рад, если отблагодарите...

 

П.С. "Динозаврам 1с" эта программа будет малоинтересна...

 

Файлы

Наименование Файл Версия Размер Кол. Скачив.
УниверсальнаяЧиталкаDBF.epf
.epf 8,62Kb
05.09.11
109
.epf 8,62Kb 109 Скачать

См. также

Лучшие комментарии

8. alexk-is 06.09.2011 00:05
(6) Чуть быстрее будет так...
Функция DBFвТаблицу(ПутьКDBF, Кодировка)
   
ТаблицаДанных = Новый ТаблицаЗначений();
   
ФайлDBF = Новый XBase;
   
ФайлDBF.ОткрытьФайл(ПутьКDBF,, Истина);
    Если
Кодировка = "ANSI" Тогда
       
ФайлDBF.Кодировка = КодировкаXBase.ANSI;
    Иначе
       
ФайлDBF.Кодировка = КодировкаXBase.OEM;
    КонецЕсли;
    Для Каждого
ПолеDBF Из ФайлDBF.Поля Цикл
       
ТаблицаДанных.Колонки.Добавить(ПолеDBF.Имя,, ПолеDBF.Имя);
    КонецЦикла;
   
ФайлDBF.Первая();
    Пока Не
ФайлDBF.ВКонце() Цикл
       
ЗаполнитьЗначенияСвойств(ТаблицаДанных.Добавить(), ФайлDBF);
       
ФайлDBF.Следующая();
    КонецЦикла;
   
ФайлDBF.ЗакрытьФайл();
    Возврат
ТаблицаДанных;
КонецФункции


А ещё быстрее будет так :)
Ответили: (9)
+ 3 [ artbear; ExS42; aximo; ]
# Ответить
21. boriskud 19.10.2011 10:28
Спасибо! Функция пригодилась при написании процедуры загрузки в базу DBF файла.
+ 1 [ aximo; ]
# Ответить
23. xaker1C 20.12.2011 18:05
Прикольно
+ 1 [ aximo; ]
# Ответить

Комментарии

1. artbear 05.09.2011 15:56
(0) Вместо
Для Каждого ПолеDBF Из ФайлDBF.Поля Цикл
НомерКолонки=НомерКолонки+1;
НоваяСтрока[ПолеDBF.Имя]=ФайлDBF[ПолеDBF.Имя];
КонецЦикла;
Попробуй поюзать
ЗаполнитьЗначенияСвойств(НоваяСтрока, ФайлДБФ);
Ответили: (2)
# Ответить
2. aximo 05.09.2011 16:30
(1) согласен, но так как у меня - более "классически что-ли" и понятнее...
# Ответить
3. aximo 05.09.2011 16:31
(0) просьба, можешь подсказать как выделять цветом код... я не нашел с ходу тегов
Ответили: (4) (5)
# Ответить
5. artbear 05.09.2011 17:49
(3) Когда у тебя будет ДБФ из хотя одной/двух тысяч строк, разницу сразу ощутишь :)
ЗЫ ВСЕГДА юзай ЗаполнитьЗначенияСвойств, а не ручной перебор имен.
ИМХО Это признак опытного разработчика 1cv8
Ответили: (6)
+ 1 [ aximo; ]
# Ответить
6. aximo 05.09.2011 19:34
(5) спасибо. исправил, стало быстрее.
Ответили: (8)
# Ответить
7. anton.fly7 05.09.2011 20:04
а если будет колонка на 950 символов, как твоя обработина его покажет?
и еще, не проще ли смотреть DBF_ки в екселе?
# Ответить
8. alexk-is 06.09.2011 00:05
(6) Чуть быстрее будет так...
Функция DBFвТаблицу(ПутьКDBF, Кодировка)
   
ТаблицаДанных = Новый ТаблицаЗначений();
   
ФайлDBF = Новый XBase;
   
ФайлDBF.ОткрытьФайл(ПутьКDBF,, Истина);
    Если
Кодировка = "ANSI" Тогда
       
ФайлDBF.Кодировка = КодировкаXBase.ANSI;
    Иначе
       
ФайлDBF.Кодировка = КодировкаXBase.OEM;
    КонецЕсли;
    Для Каждого
ПолеDBF Из ФайлDBF.Поля Цикл
       
ТаблицаДанных.Колонки.Добавить(ПолеDBF.Имя,, ПолеDBF.Имя);
    КонецЦикла;
   
ФайлDBF.Первая();
    Пока Не
ФайлDBF.ВКонце() Цикл
       
ЗаполнитьЗначенияСвойств(ТаблицаДанных.Добавить(), ФайлDBF);
       
ФайлDBF.Следующая();
    КонецЦикла;
   
ФайлDBF.ЗакрытьФайл();
    Возврат
ТаблицаДанных;
КонецФункции


А ещё быстрее будет так :)
Ответили: (9)
+ 3 [ artbear; ExS42; aximo; ]
# Ответить
9. artbear 06.09.2011 10:03
(8) Да, ФайлDBF.Следующая(); очень быстро работает.
# Ответить
10. DionisioSPb 07.09.2011 15:50
А вот я столкнулся, что при выполнении такого кода:

//--------------------
ОбъектXBase = Новый XBase;
ОбъектXBase.Кодировка = КодировкаXBase.OEM;
ОбъектXBase.поля.Добавить("KEY", "S", 50, 0);
ОбъектXBase.поля.Добавить("STR", "S", 50, 0);
ОбъектXBase.СоздатьФайл("C:\test.dbf");

ОбъектXBase.АвтоСохранение = Истина;

Значения = новый Структура("KEY, STR", "Значение KEY", "Значение строка");
ОбъектXBase.Добавить();
ЗаполнитьЗначенияСвойств(ОбъектXBase, Значения);
ОбъектXBase.Записать();
ОбъектXBase.ЗакрытьФайл();
//--------------------

Поле "KEY" не будет заполнено. Пришлось переделывать на Для Каждого ИмяПоляDBF Из ПоляDBF Цикл
Грустно...
# Ответить
11. echo77 07.09.2011 18:31
Простым пользователям эта штука на хер не нужна, anton.fly7 правильно говорит - DBF проще смотреть с помощью excel/calc.
Куда сложнее обратное преобразование, у меня в публикациях была такая штука
# Ответить
12. defini 08.09.2011 10:20
echo77 пишет:
Простым пользователям эта штука на хер не нужна, anton.fly7 правильно говорит - DBF проще смотреть с помощью excel/calc.
правильно говорит - DBF проще смотреть с помощью excel/calc.


ИМХО смотреть дбф-ки удобнее дбф-навигатором и вьювером. Но никак не екселем.
# Ответить
13. jONES1979 08.09.2011 10:43
"Простым пользователем" ещё и похерить можно DBF-ку, открывая её Экселем и исправляя. А потом в нескажу-каком-банке её не примут, потому что убогие программисты этого банка толи "привязали" свою программу к какой-то устаревщей версии формата DBF, толи ещё чего.
# Ответить
14. djd.sf (файл скачал) 08.09.2011 11:04
"Простым пользователем" ещё и похерить можно DBF-ку, открывая её Экселем и исправляя. А потом в нескажу-каком-банке её не примут, потому что убогие программисты этого банка толи "привязали" свою программу к какой-то устаревщей версии формата DBF, толи ещё чего.
Это ты про что? Разъясни пожалуйста, я не понимаю.
# Ответить
15. jONES1979 08.09.2011 11:13
Это пример из жизни, вместо того чтобы сформировать DBF c корректными данными, бухгалтеры открыли Екселем и подправили цифры. Но в банке их программа "подавилась" DBF-кой, не смогла открыть.
# Ответить
16. sommid 12.09.2011 13:11
Типизация очень даже може пригодиться. Например, для использования полученной таблицы в качестве виртуальной в запросе.
в свое функции писал так:
//----------------------------------------
Для каждого ТекКолонка из мФайл.Поля Цикл
    
    ТипДБФ = ТекКолонка.Тип;
    //возможные типы из Синтаксис-помощника: Содержит тип поля: "S"- строка, "N" - число, "D" - дата,
    //    "L" - булево, "F" - число, "M" - мемо поле (не поддерживается)
    
    Если ТипДБФ = "S" Тогда
        ТекТип = "Строка";
	ТекКвалификатор = Новый КвалификаторыСтроки(ТекКолонка.Длина);
	ТекОписаниеТипов = Новый ОписаниеТипов(ТекТип, , ТекКвалификатор);
	тз.Колонки.Добавить(ТекКолонка.Имя, ТекОписаниеТипов);

    ИначеЕсли ТипДБФ = "N" ИЛИ ТипДБФ = "F" Тогда
        ТекТип = "Число";
	ТекКвалификатор = Новый КвалификаторыЧисла(ТекКолонка.Длина, ТекКолонка.Точность);
	ТекОписаниеТипов = Новый ОписаниеТипов(ТекТип, ТекКвалификатор);
	тз.Колонки.Добавить(ТекКолонка.Имя, ТекОписаниеТипов);

    ИначеЕсли ТипДБФ = "D" Тогда
        ТекТип = "Дата";
	ТекОписаниеТипов = Новый ОписаниеТипов(ТекТип);
	тз.Колонки.Добавить(ТекКолонка.Имя, ТекОписаниеТипов);

    ИначеЕсли ТипДБФ = "L" Тогда
        ТекТип = "Булево";
	ТекОписаниеТипов = Новый ОписаниеТипов(ТекТип);
	тз.Колонки.Добавить(ТекКолонка.Имя, ТекОписаниеТипов);

    Иначе
        ТекТип = "";
	тз.Колонки.Добавить(ТекКолонка.Имя);

    КонецЕсли;
		
КонецЦикла;
...Показать Скрыть

//------------------------------------
# Ответить
17. help1Ckr 13.09.2011 23:31
Читалка в дбф удобная функция - иногда не удобно между окнами переключатся. Еще бы для xmlфайлов нормальную смотрелку сделали :D
Ответили: (22)
# Ответить
18. help1Ckr 13.09.2011 23:40
Кстати, для большей пользы, не мешало бы добавить итоги по числовым полям.
# Ответить
19. Hamitova (файл скачал) 15.09.2011 07:50
На 1С я перешла с Fox Pro, и мне показалась очень интересной и простой эта обработка. Спасибо...
Ответили: (20)
# Ответить
20. aximo 15.09.2011 08:46
(19) да пожалуйста. это у меня капля в море и еще идей непаханное поле ...
# Ответить
21. boriskud 19.10.2011 10:28
Спасибо! Функция пригодилась при написании процедуры загрузки в базу DBF файла.
+ 1 [ aximo; ]
# Ответить
22. anig99 (файл скачал) 16.11.2011 13:05
(0) переделал под управляемые формы http://infostart.ru/public/98411/
(17) для xml вот есть - http://infostart.ru/public/84254/
# Ответить
23. xaker1C 20.12.2011 18:05
Прикольно
+ 1 [ aximo; ]
# Ответить
25. Waldor 29.01.2012 17:24
Спасибо. Оптимизировал свою дбф загрузку...
# Ответить
26. stormtg 13.02.2012 14:41
Спасибо, очень интересно
# Ответить
27. i132 16.02.2012 16:27
Получится немного быстрее если анализировать ответ ДБФ.Следующая();:

ЕстьЗаписи = ДбФ.Первая();
Пока ЕстьЗаписи Цикл
...
ЕстьЗаписи = ДБФ.Следующая();
КонецЦикла;

пример отчета на СКД по произвольному DBF файлу: http://infostart.ru/public/116645/
# Ответить
28. EfiopReal 14.03.2012 10:04
Спасибо. Думаю функция пригодится. Как раз планируем добить FoxPro. Остались последние секции, так что думаю можно будет перетащить остатки на 8.2 автоматом, а не заниматься этим вручную. Хотя от ручной работы полностью не избавиться (в foxpro по моему штрихкоды отсутствуют).
# Ответить
29. h_vitya 28.03.2012 14:00
Спасибо. Думаю функция пригодится. Как раз планируем добить FoxPro. Остались последние секции, так что думаю можно будет перетащить остатки на 8.2 автоматом, а не заниматься этим вручную. Хотя от ручной работы полностью не избавиться (в foxpro по моему штрихкоды отсутствуют).


Меня устраивает через Exel смотреть dbf
# Ответить
30. electronik 25.04.2012 16:21
Спасибо но хотелось узнать как предстоят дела с кодировками, ато при работе с ДБФ возникает кучу моментов кодировками ето здесь предусмотрено или нужно руками допиливать
Ответили: (31)
+ 1 [ aximo; ]
# Ответить
31. aximo 25.04.2012 17:01
(30) в моих задачах еще не случалось его допиливать под что-то... малая вероятность...
# Ответить
32. Alfer 16.01.2014 19:26
меня устраивает во всем - а некоторые моменты возьму на вооружение для дальнейшего использования
# Ответить
33. vvirus 21.05.2014 08:29
добавь определение типов данных DBF, при формировании таблицы - это поможет при загрузке ТЗ в запрос
пример есть тут http://infostart.ru/public/100001/
# Ответить
34. cheiser1982 15.12.2014 13:18
Адаптированно для управляемых форм платформы 8.3:
DBFViewer8_3 для управляемых форм
# Ответить
Внимание! За постинг в данном форуме $m не начисляются.
Внимание! Для написания сообщения необходимо авторизоваться
Текст сообщения*
Прикрепить файл