gifts2017

Универсальная смотрелка DBF-файлов [обновлено!]

Опубликовал Дмитрий Никс (aximo) в раздел Программирование - Практика программирования

Представляю Вам собственную универсальную смотрелку DBF-файлов. Собственно, для чего она нужна? Подробнее...

 

Представляю Вам собственную универсальную смотрелку DBF-файлов. Собственно, для чего она нужна?

Вообще-то я не ставил себе задачу - написать dbf-смотрелку, но у меня была необходимость написать некую универсальную функцию, которая "запихивала" бы содержание DBF-файла в табличную часть.

Т.е. написал функцию и "забыл" как она работает. Вот сама функция:


Функция DBFвТаблицу(ПутьКDBF, Кодировка)   //вер.1.5
   
ТаблицаДанных = Новый ТаблицаЗначений();
   
ФайлDBF=Новый XBase;
   
ФайлDBF.ОткрытьФайл(ПутьКDBF,,Истина);
    Если
Кодировка = "ANSI" Тогда
       
ФайлDBF.Кодировка = КодировкаXBase.ANSI;
    Иначе
       
ФайлDBF.Кодировка = КодировкаXBase.OEM;
    КонецЕсли;

    Для Каждого
ПолеDBF Из ФайлDBF.Поля Цикл
       
ТаблицаДанных.Колонки.Добавить(ПолеDBF.Имя,,ПолеDBF.Имя);
    КонецЦикла;
   
ФайлDBF.Первая();
    Пока НЕ
ФайлDBF.ВКонце() Цикл
       
ЗаполнитьЗначенияСвойств(ТаблицаДанных.Добавить(),ФайлDBF);
       
ФайлDBF.Следующая();
    КонецЦикла;
   
ФайлDBF.ЗакрытьФайл();
    Возврат
ТаблицаДанных;
КонецФункции

Как логическое продолжение (чтобы тупо не выкладывать эту функцию), решил написать программу, которая будет использовать эту функцию - получилась "смотрелка-dbf".

Для особых педантов сразу скажу - типизация пока не поддерживается, т.к. не было необходимости в этом.

Обработка сделана на Платформе 8.1, использовать ее можно в любой конфигурации или на "голой" платформе.

Кому будет полезна данная обработка:

1.Начинающим программистам 1с - вы можете посмотреть как загрузить dbf в память, автоматически создав необходимые колонки.

2.Простым пользователям - если вы грузите в 1с-ку какие-то dbf-файлы, с помощью этой программы - посмотрите, что грузите, перед записью в базу 1с.

 

Кому поможет, буду рад, если отблагодарите...

 

П.С. "Динозаврам 1с" эта программа будет малоинтересна...

 

Скачать файлы

Наименование Файл Версия Размер
УниверсальнаяЧиталкаDBF.epf 109
.epf 8,62Kb
05.09.11
109
.epf 8,62Kb Скачать

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Артур Аюханов (artbear) 05.09.11 15:56
(0) Вместо
Для Каждого ПолеDBF Из ФайлDBF.Поля Цикл
НомерКолонки=НомерКолонки+1;
НоваяСтрока[ПолеDBF.Имя]=ФайлDBF[ПолеDBF.Имя];
КонецЦикла;
Попробуй поюзать
ЗаполнитьЗначенияСвойств(НоваяСтрока, ФайлДБФ);
2. Дмитрий Никс (aximo) 05.09.11 16:30
(1) согласен, но так как у меня - более "классически что-ли" и понятнее...
3. Дмитрий Никс (aximo) 05.09.11 16:31
(0) просьба, можешь подсказать как выделять цветом код... я не нашел с ходу тегов
5. Артур Аюханов (artbear) 05.09.11 17:49
(3) Когда у тебя будет ДБФ из хотя одной/двух тысяч строк, разницу сразу ощутишь :)
ЗЫ ВСЕГДА юзай ЗаполнитьЗначенияСвойств, а не ручной перебор имен.
ИМХО Это признак опытного разработчика 1cv8
6. Дмитрий Никс (aximo) 05.09.11 19:34
(5) спасибо. исправил, стало быстрее.
7. Антон (anton.fly7) 05.09.11 20:04
а если будет колонка на 950 символов, как твоя обработина его покажет?
и еще, не проще ли смотреть DBF_ки в екселе?
8. Алексей Константинов (alexk-is) 06.09.11 00:05
(6) Чуть быстрее будет так...
Функция DBFвТаблицу(ПутьКDBF, Кодировка)
   
ТаблицаДанных = Новый ТаблицаЗначений();
   
ФайлDBF = Новый XBase;
   
ФайлDBF.ОткрытьФайл(ПутьКDBF,, Истина);
    Если
Кодировка = "ANSI" Тогда
       
ФайлDBF.Кодировка = КодировкаXBase.ANSI;
    Иначе
       
ФайлDBF.Кодировка = КодировкаXBase.OEM;
    КонецЕсли;
    Для Каждого
ПолеDBF Из ФайлDBF.Поля Цикл
       
ТаблицаДанных.Колонки.Добавить(ПолеDBF.Имя,, ПолеDBF.Имя);
    КонецЦикла;
   
ФайлDBF.Первая();
    Пока Не
ФайлDBF.ВКонце() Цикл
       
ЗаполнитьЗначенияСвойств(ТаблицаДанных.Добавить(), ФайлDBF);
       
ФайлDBF.Следующая();
    КонецЦикла;
   
ФайлDBF.ЗакрытьФайл();
    Возврат
ТаблицаДанных;
КонецФункции


А ещё быстрее будет так :)
artbear; ExS42; aximo; +3 Ответить 1
9. Артур Аюханов (artbear) 06.09.11 10:03
(8) Да, ФайлDBF.Следующая(); очень быстро работает.
10. Денис (DionisioSPb) 07.09.11 15:50
А вот я столкнулся, что при выполнении такого кода:

//--------------------
ОбъектXBase = Новый XBase;
ОбъектXBase.Кодировка = КодировкаXBase.OEM;
ОбъектXBase.поля.Добавить("KEY", "S", 50, 0);
ОбъектXBase.поля.Добавить("STR", "S", 50, 0);
ОбъектXBase.СоздатьФайл("C:\test.dbf");

ОбъектXBase.АвтоСохранение = Истина;

Значения = новый Структура("KEY, STR", "Значение KEY", "Значение строка");
ОбъектXBase.Добавить();
ЗаполнитьЗначенияСвойств(ОбъектXBase, Значения);
ОбъектXBase.Записать();
ОбъектXBase.ЗакрытьФайл();
//--------------------

Поле "KEY" не будет заполнено. Пришлось переделывать на Для Каждого ИмяПоляDBF Из ПоляDBF Цикл
Грустно...
11. Александр Крынецкий (echo77) 07.09.11 18:31
Простым пользователям эта штука на хер не нужна, anton.fly7 правильно говорит - DBF проще смотреть с помощью excel/calc.
Куда сложнее обратное преобразование, у меня в публикациях была такая штука
12. defini (defini) 08.09.11 10:20
echo77 пишет:
Простым пользователям эта штука на хер не нужна, anton.fly7 правильно говорит - DBF проще смотреть с помощью excel/calc.
правильно говорит - DBF проще смотреть с помощью excel/calc.


ИМХО смотреть дбф-ки удобнее дбф-навигатором и вьювером. Но никак не екселем.
13. Петр Петров (jONES1979) 08.09.11 10:43
"Простым пользователем" ещё и похерить можно DBF-ку, открывая её Экселем и исправляя. А потом в нескажу-каком-банке её не примут, потому что убогие программисты этого банка толи "привязали" свою программу к какой-то устаревщей версии формата DBF, толи ещё чего.
14. игорь ром (djd.sf) 08.09.11 11:04
"Простым пользователем" ещё и похерить можно DBF-ку, открывая её Экселем и исправляя. А потом в нескажу-каком-банке её не примут, потому что убогие программисты этого банка толи "привязали" свою программу к какой-то устаревщей версии формата DBF, толи ещё чего.
Это ты про что? Разъясни пожалуйста, я не понимаю.
15. Петр Петров (jONES1979) 08.09.11 11:13
Это пример из жизни, вместо того чтобы сформировать DBF c корректными данными, бухгалтеры открыли Екселем и подправили цифры. Но в банке их программа "подавилась" DBF-кой, не смогла открыть.
16. Дмитрий (sommid) 12.09.11 13:11
Типизация очень даже може пригодиться. Например, для использования полученной таблицы в качестве виртуальной в запросе.
в свое функции писал так:
//----------------------------------------
Для каждого ТекКолонка из мФайл.Поля Цикл
    
    ТипДБФ = ТекКолонка.Тип;
    //возможные типы из Синтаксис-помощника: Содержит тип поля: "S"- строка, "N" - число, "D" - дата,
    //    "L" - булево, "F" - число, "M" - мемо поле (не поддерживается)
    
    Если ТипДБФ = "S" Тогда
        ТекТип = "Строка";
	ТекКвалификатор = Новый КвалификаторыСтроки(ТекКолонка.Длина);
	ТекОписаниеТипов = Новый ОписаниеТипов(ТекТип, , ТекКвалификатор);
	тз.Колонки.Добавить(ТекКолонка.Имя, ТекОписаниеТипов);

    ИначеЕсли ТипДБФ = "N" ИЛИ ТипДБФ = "F" Тогда
        ТекТип = "Число";
	ТекКвалификатор = Новый КвалификаторыЧисла(ТекКолонка.Длина, ТекКолонка.Точность);
	ТекОписаниеТипов = Новый ОписаниеТипов(ТекТип, ТекКвалификатор);
	тз.Колонки.Добавить(ТекКолонка.Имя, ТекОписаниеТипов);

    ИначеЕсли ТипДБФ = "D" Тогда
        ТекТип = "Дата";
	ТекОписаниеТипов = Новый ОписаниеТипов(ТекТип);
	тз.Колонки.Добавить(ТекКолонка.Имя, ТекОписаниеТипов);

    ИначеЕсли ТипДБФ = "L" Тогда
        ТекТип = "Булево";
	ТекОписаниеТипов = Новый ОписаниеТипов(ТекТип);
	тз.Колонки.Добавить(ТекКолонка.Имя, ТекОписаниеТипов);

    Иначе
        ТекТип = "";
	тз.Колонки.Добавить(ТекКолонка.Имя);

    КонецЕсли;
		
КонецЦикла;
...Показать Скрыть

//------------------------------------
17. Саша Безымяный (help1Ckr) 13.09.11 23:31
Читалка в дбф удобная функция - иногда не удобно между окнами переключатся. Еще бы для xmlфайлов нормальную смотрелку сделали :D
18. Саша Безымяный (help1Ckr) 13.09.11 23:40
Кстати, для большей пользы, не мешало бы добавить итоги по числовым полям.
19. Райса Хамитова (Hamitova) 15.09.11 07:50
На 1С я перешла с Fox Pro, и мне показалась очень интересной и простой эта обработка. Спасибо...
20. Дмитрий Никс (aximo) 15.09.11 08:46
(19) да пожалуйста. это у меня капля в море и еще идей непаханное поле ...
21. Борис Кудрявцев (boriskud) 19.10.11 10:28
Спасибо! Функция пригодилась при написании процедуры загрузки в базу DBF файла.
22. Александр Медведев (anig99) 16.11.11 13:05
(0) переделал под управляемые формы http://infostart.ru/public/98411/
(17) для xml вот есть - http://infostart.ru/public/84254/
23. Харьков Харьков (xaker1C) 20.12.11 18:05
25. Waldor waal (Waldor) 29.01.12 17:24
Спасибо. Оптимизировал свою дбф загрузку...
26. stormtg stormtg (stormtg) 13.02.12 14:41
Спасибо, очень интересно
27. Илья (i132) 16.02.12 16:27
Получится немного быстрее если анализировать ответ ДБФ.Следующая();:

ЕстьЗаписи = ДбФ.Первая();
Пока ЕстьЗаписи Цикл
...
ЕстьЗаписи = ДБФ.Следующая();
КонецЦикла;

пример отчета на СКД по произвольному DBF файлу: http://infostart.ru/public/116645/
28. EfiopReal (Созинов) 14.03.12 10:04
Спасибо. Думаю функция пригодится. Как раз планируем добить FoxPro. Остались последние секции, так что думаю можно будет перетащить остатки на 8.2 автоматом, а не заниматься этим вручную. Хотя от ручной работы полностью не избавиться (в foxpro по моему штрихкоды отсутствуют).
29. Анатолий Кримчак (h_vitya) 28.03.12 14:00
Спасибо. Думаю функция пригодится. Как раз планируем добить FoxPro. Остались последние секции, так что думаю можно будет перетащить остатки на 8.2 автоматом, а не заниматься этим вручную. Хотя от ручной работы полностью не избавиться (в foxpro по моему штрихкоды отсутствуют).


Меня устраивает через Exel смотреть dbf
30. Andrey Dyak (electronik) 25.04.12 16:21
Спасибо но хотелось узнать как предстоят дела с кодировками, ато при работе с ДБФ возникает кучу моментов кодировками ето здесь предусмотрено или нужно руками допиливать
31. Дмитрий Никс (aximo) 25.04.12 17:01
(30) в моих задачах еще не случалось его допиливать под что-то... малая вероятность...
32. Андрей Штоколов (Alfer) 16.01.14 19:26
меня устраивает во всем - а некоторые моменты возьму на вооружение для дальнейшего использования
33. Виктор (vvirus) 21.05.14 08:29
добавь определение типов данных DBF, при формировании таблицы - это поможет при загрузке ТЗ в запрос
пример есть тут http://infostart.ru/public/100001/
34. Александр Честикин (cheiser1982) 15.12.14 13:18
Адаптированно для управляемых форм платформы 8.3:
DBFViewer8_3 для управляемых форм