gifts2017

Инвентаризация кассы ИНВ-15

Опубликовал юрий гулидов (gull22) в раздел Печать - Печатные формы документов

Обработка для формирования печатной формы Акта инвентаризации кассы по форме ИНВ-15

Обработка предназначена для формирования печатной формы акта инвентаризации наличных денежных средств по форме ИНВ-15. В форме обработки выбирается или устанавливаются вручную реквизиты для печатной формы.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
ИНВ_15
.epf 22,38Kb
31.05.13
153
.epf 22,38Kb 153 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Сергей Рудаков (fishca) 08.09.11 13:19
обработки выбирается или устанавливаются вручную ревизиты

ошибочку подправь. ;)
2. Tallis 10.12.12 18:50
В базе с несколькими организациями остаток по 50.01 посчитался без отбора по организации...(((
3. Дмитрий (gosizo) 04.02.13 15:05
4. Макас (makas) 05.02.13 11:34
А в БП 2.0 будет работать?
5. Макас (makas) 05.02.13 11:53
Замечания по работе в БП2.0 да и пожалуй в КА
Область.Параметры.ДолжностьРук = Справочники.ДолжностиОрганизаций.НайтиПоКоду("1");

Почему надо искать по коду 1, а не 0000000001 и не "должность руководителя организации"


Область.Параметры.Руководитель = ФамилияИО(Справочники.СотрудникиОрганизаций.НайтиПоКоду("0000000003"));

Почему надо искать по коду, а не брать Руководителя из справочника "Организации" или "Ответственных лиц"


В БП2.0 обработка все время ставит последний номер кассовых документов № 1 с префиксом "С"
Последний номер подставлять не желает :-/
Как изменить префикс документов?
6. Макас (makas) 05.02.13 12:04
Обработка работает в БП 2.0, однако если обработку отредактировать в БП 2,0 и сохранить, тогда она перестает работать.
7. Валерий Буданов (buval) 03.04.13 14:29
Спасибо за обработку. В КА использовал с небольшими изменениями: - "Процедура КнопкаВыполнитьНажатие(Кнопка)" заменил тест перебора из регистра на запрос. //%%%%%%%%%%%% Заменил на запрос %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
ЗапросПроверка = Новый Запрос;
ЗапросПроверка.Текст ="ВЫБРАТЬ
| ХозрасчетныйОстатки.Счет,
| ХозрасчетныйОстатки.СуммаОстатокДт
|ИЗ
| РегистрБухгалтерии.Хозрасчетный.Остатки(&Дата, Счет.КодБыстрогоВыбора = ""5001"", , ) КАК ХозрасчетныйОстатки";
ЗапросПроверка.УстановитьПараметр("Дата",Дата);

РезультатЗапросПроверка=ЗапросПроверка.Выполнить().Выбрать();
Если РезультатЗапросПроверка.Следующий() Тогда Остаток=РезультатЗапросПроверка.СуммаОстатокДт;Иначе Остаток=0;КонецЕсли;

//Приход = 0;
//Расход = 0;
//ВыборкаПриход = РегистрыБухгалтерии.Хозрасчетный.Выбрать();
//Пока ВыборкаПриход.Следующий() Цикл
// Если ВыборкаПриход.СчетДт.КодБыстрогоВыбора = "5001" Тогда
// Приход = Приход + ВыборкаПриход.Сумма;
// КонецЕсли;
//КонецЦикла;
//ВыборкаРасход = РегистрыБухгалтерии.Хозрасчетный.Выбрать();
//Пока ВыборкаРасход.Следующий() Цикл
// Если ВыборкаРасход.СчетКт.КодБыстрогоВыбора = "5001" Тогда
// Расход = Расход + ВыборкаРасход.Сумма;
// КонецЕсли;
//КонецЦикла;
//Остаток = Приход - Расход;
//%%%%%%%%%%%% Заменил на запрос %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%% -Процедура ОсновныеДействияФормыДействие(Кнопка) заменил чтение Руководителя из справочника на функцию //%%%%%%%%%%%% Заменил на процедуру %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
Руководители = РегламентированнаяОтчетность.ОтветственныеЛицаОрганизаций(Организация, КонецДня(Дата),);
Руководитель = Руководители.Руководитель;
РуководительДолжность = Руководители.РуководительДолжность;
Область.Параметры.ДолжностьРук = РуководительДолжность;
Область.Параметры.Руководитель = Руководитель;
//Область.Параметры.ДолжностьРук = Справочники.ДолжностиОрганизаций.НайтиПоКоду("1");
//Область.Параметры.Руководитель = ФамилияИО(Справочники.СотрудникиОрганизаций.НайтиПоКоду("0000000003"));
//%%%%%%%%%%%% Заменил на процедуру %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
Suulla Uola; +1 Ответить
8. Suulla Uola Maljjk (Suulla Uola) 22.05.13 11:28
Да, с изменениями внесенными buval быстрее работает :-)
9. Suulla Uola Maljjk (Suulla Uola) 23.05.13 03:52
У нас тут получается так, что параметр "Подразделение" в запросе не задействован и выборка независимо от установок этого параметра происходит по всем подразделениям.
Ищу способ задействовать "Подразделение", а то невозможно получить требуемый результат. Может кто уже сделал? :-)
10. Suulla Uola Maljjk (Suulla Uola) 23.05.13 04:23
Сделал.
ЗапросПроверка = Новый Запрос;
ЗапросПроверка.Текст ="ВЫБРАТЬ
| ХозрасчетныйОстатки.Счет,
| ХозрасчетныйОстатки.СуммаОстатокДт
|ИЗ
| РегистрБухгалтерии.Хозрасчетный.Остатки(
| &Дата,
| Счет.КодБыстрогоВыбора = ""5001"",
| ,
| Субконто1 = &Подразделение
| ИЛИ Субконто2 = &Подразделение
| ИЛИ Субконто3 = &Подразделение
| ИЛИ Субконто4 = &Подразделение) КАК ХозрасчетныйОстатки";

ЗапросПроверка.УстановитьПараметр("Дата",Дата);
ЗапросПроверка.УстановитьПараметр("Подразделение",Подразделение);
РезультатЗапросПроверка = ЗапросПроверка.Выполнить().Выбрать();
Если РезультатЗапросПроверка.Следующий() Тогда
Остаток = РезультатЗапросПроверка.СуммаОстатокДт;
Иначе
Остаток = 0;
КонецЕсли;
11. Suulla Uola Maljjk (Suulla Uola) 23.05.13 08:37
Осталось сделать в таком-же духе выборку по номерам ПКО, РКО.
12. Suulla Uola Maljjk (Suulla Uola) 23.05.13 10:22
Опять сделал.
Вместо:
ВыборкаПКО = Документы.ПриходныйКассовыйОрдер.Выбрать();
Пока ВыборкаПКО.Следующий() Цикл
НомПКО = ВыборкаПКО.Номер;
УбратьНули(НомПКО);
КонецЦикла;

ВыборкаРКО = Документы.РасходныйКассовыйОрдер.Выбрать();
Пока ВыборкаРКО.Следующий() Цикл
НомРКО = ВыборкаРКО.Номер;
УбратьНули(НомРКО);
КонецЦикла;

Вставляем:
ЗапросПКО = Новый Запрос;
ЗапросПКО.Текст ="ВЫБРАТЬ
| ПриходныйКассовыйОрдер.Номер,
| ПриходныйКассовыйОрдер.Дата КАК Дата
|ИЗ
| Документ.ПриходныйКассовыйОрдер КАК ПриходныйКассовыйОрдер
|ГДЕ
| ПриходныйКассовыйОрдер.Подразделение = &Подразделение
| И ПриходныйКассовыйОрдер.Дата < &Дата
|
|УПОРЯДОЧИТЬ ПО
| Дата УБЫВ";

ЗапросПКО.УстановитьПараметр("Дата",Дата);
ЗапросПКО.УстановитьПараметр("Подразделение",Подразделение);
РезультатЗапросПКО = ЗапросПКО.Выполнить().Выбрать();
Если РезультатЗапросПКО.Следующий() Тогда
НомПКО = РезультатЗапросПКО.Номер;
// УбратьНули(НомПКО);
КонецЕсли;

ЗапросРКО = Новый Запрос;
ЗапросРКО.Текст ="ВЫБРАТЬ
| РасходныйКассовыйОрдер.Номер,
| РасходныйКассовыйОрдер.Дата КАК Дата
|ИЗ
| Документ.РасходныйКассовыйОрдер КАК РасходныйКассовыйОрдер
|ГДЕ
| РасходныйКассовыйОрдер.Подразделение.Ссылка = &Подразделение
| И РасходныйКассовыйОрдер.Дата < &Дата
|
|УПОРЯДОЧИТЬ ПО
| Дата УБЫВ";

ЗапросРКО.УстановитьПараметр("Дата",Дата);
ЗапросРКО.УстановитьПараметр("Подразделение",Подразделение);
РезультатЗапросРКО = ЗапросРКО.Выполнить().Выбрать();
Если РезультатЗапросРКО.Следующий() Тогда
НомРКО = РезультатЗапросРКО.Номер;
//УбратьНули(НомРКО);
КонецЕсли;
13. Lena Kl (elenko1) 23.01.14 10:23
Нужная штука, спасибо автору и всем комментирующим!
14. frolo mail (frolo) 26.02.14 19:52
Пригодилось в БП 2.0, пришлось слегка допилить.
1. Не хватает фильтра по организации при определении остатков кассы и номеров последних пко/рко.
2. Желательно включить сохранение настроек, чтоб не забивать членов комиссии каждый раз.
3. Непонятно, откуда в макете пустые страницы после каждой заполненной.
15. Наталья Круц (Natalia7145) 05.02.16 14:23
Добрый день. А данная обработка подходит для Бухгалтерия 8.3?
16. юрий гулидов (gull22) 08.02.16 08:32
На сегодняшний день, нет.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа