gifts2017

Компенсация отпуска, оплата дней доноров и оплата льготных дней родителей в ЗиК

Опубликовал Максим (maxim305) в раздел Программирование - Практика программирования

"Компенсация отпуска"," Оплата дней доноров" и "Оплата льготных дней родителей" - эти виды расчетов должны облагаться страховыми взносами с 01.01.2011 года.

Поступила задача в конфигурации "1С: Зарплата и кадры" (релиз 7.70.314) настроить налогообложение этих расчетов таким образом, чтобы до 2011 года данные виды расчетов не облагались страховыми взносами, а с 2011 года облагались. Эта задача возникла в умах бухгалтеров после прочтения Письма Минздравсоцразвития от 15.03.2011 № 784-19 "О начислении страховых взносов в государственные внебюджетные фонды на выплаты в пользу работников".

Ознакомился с публикацией http://infostart.ru/public/86830/ и хочу предложить свой вариант решения задачи. Нужно внести изменения в функцию глСобратьДанныеДляСтраховыхВзносов глобального модуля конфигурации (релиз 7.70.314):

Между строк 12311 и 12312 нужно вставить следующий код:

Если (ВР = ВидРасчета.ОплатаДнейДоноров) или (ВР = ВидРасчета.ОплатаЛьготныхДнейРодителей) или
        (ВР = ВидРасчета.КомпенсацияОтпускаСверх28дней)  Тогда
         Если Год <= 2010 Тогда // не облагались страховыми взносами
                  СоответствиеВРкодамДоходов.УстановитьЗначение(НомерСтроки,2,"НеОблагаетсяЦеликом");
         Иначе // с 2011 стали облагаться страховыми взносами
                  СоответствиеВРкодамДоходов.УстановитьЗначение(НомерСтроки,2,"ОблагаетсяЦеликом");
         КонецЕсли;
КонецЕсли;

Надеюсь, вам пригодится это простое решение с минимальными правками в коде!

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Юрий (forurchik) 04.10.11 13:06
Не совем понял для чего это писалось. это уже было реализованно в новой версии
2. Максим (maxim305) 05.10.11 04:18
forurchik пишет:

Не совем понял для чего это писалось. это уже было реализованно в новой версии


Каким же образом?
3. d ryabov (ryabov_d) 06.10.11 10:18
Опробовано на комплексной 7.7 - все работает
4. Евгений Нямцу (Nev1C) 06.10.11 23:56
Спасибо все работает.Проводки формирует правильно.Хотя я до сих пор считаю это законодательным бредом.
5. Nicholas Mikuslas (Nicholas) 17.10.11 06:36
Конфигурация не типовая. Сориентируйте, где находятся строки 12311 и 12312?
6. Максим (maxim305) 18.10.11 07:47
Nicholas пишет:

Конфигурация не типовая. Сориентируйте, где находятся строки 12311 и 12312?


Код нужно вставить в следующий фрагмент:
Иначе // остались невходящие в налоговую базу в.р.; из них надо выделить объект налогообложения
Если СправочникВР.РасходыЗаСчетФСС = 1 Тогда
СоответствиеВРкодамДоходов.УстановитьЗначение(НомерСтроки,2,"РасходыЗаСчетФСС");
ИначеЕсли Найти(",4000,4600,3010,3020,2800,2900,2400,2640,",","+НомерДоходаПоНДФЛ+",") > 0 Тогда
СоответствиеВРкодамДоходов.УстановитьЗначение(НомерСтроки,2,"НеЯвляетсяОбъектом");
ИначеЕсли (Лев(НомерДоходаПоНДФЛ,2)="15") Тогда
СоответствиеВРкодамДоходов.УстановитьЗначение(НомерСтроки,2,"НеЯвляетсяОбъектом");
Иначе // остальное не облагается
СоответствиеВРкодамДоходов.УстановитьЗначение(НомерСтроки,2,"-1");
КонецЕсли;
КонецЕсли;

// сюда нужно вставить код

СоответствиеВРкодамДоходов.УстановитьЗначение(НомерСтроки,3,?(СправочникВР.Выбран()=1,Строка(СправочникВР.ДовольствиеВС),"1"));
7. Nicholas Mikuslas (Nicholas) 20.10.11 09:16
А разве до 2011 года они попадали не в "РасходыЗаСчетФСС"?
Можно, кстати, сделать вот так:
СоответствиеВРкодамДоходов.УстановитьЗначение(НомерСтроки,2,ПолучитьПредставлениеДоходаДляСтраховыхВзносов(СправочникВР.ТипДоходаДляСтраховыхВзносов));

Тогда не будет жесткой привязки, а способ обложения будет браться из вида расчета.

П.С. Желательно делать перерасчет в октябре, после сдачи отчетности за III квартал. Иначе данные за июль и август могут поменяться и придется подавать уточненные сведения, либо подправлять базу вручную.
8. Anna Babynina (orsprog) 20.10.11 09:25
(1) forurchik,
а у кого нет новой версии...очень пригодится
9. Nicholas Mikuslas (Nicholas) 21.10.11 09:09
(1) А в каком конкретно релизе это реализовано?
10. Dima Dima (dumal) 17.11.11 21:27
Спасибо, нужная информация. Наткнулся случайно, но буду знать
11. Viktor (kurvik) 23.11.11 18:14
Спасибо, нужная информация.Был свой вариант.Сравним-какой лучше.
12. Светлана Корнеева (kler) 03.02.12 13:27
Так в каком релизе реализовано?
13. Ершова Ольга (lushka) 12.02.12 08:09
а как сделать чтоб суммы по КТ 69-ых счетов по ОплатеЛьготныхДнейРодителей падпли не на Дт 69.1, а на 91.2?
14. Маратик Гайнутдинов (Черный Плащ) 20.04.12 09:50
а как реализовать все что выше сказенное в 323 или в 324 релизе?!
15. Руслан Валеев (ronval) 29.08.12 09:55
(14) Черный Плащ,
тоже не нашел в 326 релизе
16. Kapitan911 Юрий (Kapitan911) 30.12.12 11:12
Если Год >= 2012 Тогда

//Юрий ЦКБ --> установим что ОплатаЛьготныхДнейРодителей и с 2012 года облагается взносами
//Если пользователь не задал иное
НомерСтроки="";
Если СоответствиеВРкодамДоходов.НайтиЗначение(ВидРасчета.ОплатаЛьготныхДнейРодителей,НомерСтроки,1)=1 Тогда
Если СокрЛП(СоответствиеВРкодамДоходов.ПолучитьЗначение(НомерСтроки,2)) = "РасходыЗаСчетФСС" Тогда
СоответствиеВРкодамДоходов.УстановитьЗначение(НомерСтроки,2,"");
КонецЕсли;
КонецЕсли;
//Юрий ЦКБ <-- установим что ОплатаЛьготныхДнейРодителей и с 2012 года облагается взносами

ОбходСотрудниковДляСтраховыхВзносов2012(ВсегоСотров, Сотрудники, ЗапросПоВзносам, ЗапросПоВзносамКСправочникам, СобиратьРучныеКорректировки, МесяцРасшифровки, Форма, ДоходыВычетыНалогиСотрудников, СобиратьРасшифровку, ЖрнЗарплата, Год, ПервыйМесяц, ПоследнийМесяц, ИскатьВоенных, ТаблицаРаспределенияПоШаблПроводок, НеВыделятьИнвалидов,СобиратьТолькоВзносы,СобиратьДанныеДляРасчетаПособий,СобиратьДанныеДляОтчета,НеВыделятьЛьготныеТарифы,ЗапросПоДоходамКСправочникам);

ИначеЕсли Год = 2011 Тогда
ОбходСотрудниковДляСтраховыхВзносов2011(ВсегоСотров, Сотрудники, ЗапросПоВзносам, ЗапросПоВзносамКСправочникам, СобиратьРучныеКорректировки, МесяцРасшифровки, Форма, ДоходыВычетыНалогиСотрудников, СобиратьРасшифровку, ЖрнЗарплата, Год, ПервыйМесяц, ПоследнийМесяц, ИскатьВоенных, ТаблицаРаспределенияПоШаблПроводок, НеВыделятьИнвалидов,СобиратьТолькоВзносы,СобиратьДанныеДляРасчетаПособий,СобиратьДанныеДляОтчета);

Иначе
ОбходСотрудниковДляСтраховыхВзносов2010(ВсегоСотров, Сотрудники, ЗапросПоВзносам, ЗапросПоВзносамКСправочникам, СобиратьРучныеКорректировки, МесяцРасшифровки, Форма, ДоходыВычетыНалогиСотрудников, СобиратьРасшифровку, ЖрнЗарплата, Год, ПервыйМесяц, ПоследнийМесяц, ИскатьВоенных, ТаблицаРаспределенияПоШаблПроводок, ИскатьЕНВД, НеВыделятьИнвалидов,СобиратьТолькоВзносы,СобиратьДанныеДляРасчетаПособий);

КонецЕсли;

Возврат 1

КонецФункции // глСобратьДанныеДляСтраховыхВзносов()
17. Kapitan911 Юрий (Kapitan911) 30.12.12 11:15
Это настройка в конце функции глСобратьДанныеДляСтраховыхВзносов для включения ОплатаЛьготныхДнейРодителей в базу страховых взносов с 2012 года. Если нужно с 2011 такой же блок (выделенный комментариями нужно скопировать после "ИначеЕсли Год = 2011 Тогда")
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа