gifts2017

Выгрузка метаданных общих реквизитов для конвертации данных 2.1.5 (8.2) + обработка общих реквизитов

Опубликовал Илья (i132) в раздел Программирование - Практика программирования

Проверка, указан ли общий реквизит для заданного типа.
1. Добавление общих реквизитов (8.2.14+) в список МД для конфигурации Конвертация Данных
2. УниверсальныеПодборИОбработкаОбъектов.epf с учетом общих ревизитов

Описание общих реквизитов от 1С: http://downloads.v8.1c.ru/content/Platform/8_2_14_439/V8AddDoc.htm
 

Уже давно появились общие реквизиты - а в стандартных обработках они до сих пор не появились.

 

Пример для проверки общего ревизита в обработке выгрузки метаданных(MD82Exp.epf)

(вставить в конец процедуры ВыгрузитьСвойства()):

Если Метаданные.РежимСовместимости = Метаданные.СвойстваОбъектов.РежимСовместимости.НеИспользовать Тогда
 
Для каждого ОбщийРеквизит из Метаданные.ОбщиеРеквизиты Цикл
    Если
ОбщийРеквизит.РазделениеДанных = Метаданные.СвойстваОбъектов.РазделениеДанныхОбщегоРеквизита.Разделять Тогда
        Если
ОбщийРеквизит.ИспользованиеРазделяемыхДанных = Метаданные.СвойстваОбъектов.ИспользованиеРазделяемыхДанныхОбщегоРеквизита.Независимо Тогда
           
Продолжить; //не доступен в объектной модели
       
КонецЕсли;
    КонецЕсли;
   
СвойтваОбъектаВСоставе = ОбщийРеквизит.Состав.Найти(Объект);
    Если НЕ
СвойтваОбъектаВСоставе = Неопределено Тогда
        Если
СвойтваОбъектаВСоставе.Использование = Метаданные.СвойстваОбъектов.ИспользованиеОбщегоРеквизита.НеИспользовать Тогда
            Продолжить;
        ИначеЕсли (
СвойтваОбъектаВСоставе.Использование = Метаданные.СвойстваОбъектов.ИспользованиеОбщегоРеквизита.Авто)
            и (
ОбщийРеквизит.АвтоИспользование=Метаданные.СвойстваОбъектов.АвтоИспользованиеОбщегоРеквизита.НеИспользовать)
             Тогда
//не указанно явное использование
           
Продолжить;
        КонецЕсли;
       
//Использование=Использовать или (авто и АвтоИспользование)

       
ВыгрузитьСвойство(ОбщийРеквизит, "Реквизит", Родитель);
    КонецЕсли;
  КонецЦикла;
КонецЕсли;

2. Тоже самое можно проделать с другими обработками, например УниверсальныеПодборИОбработкаОбъектов.epf

 

Замечание: У общих реквизитов есть большой недостаток -их нельзя указать в качестве графы журнала документа, нельзя использовать как критерий отбора.

Еще про общие ревизиты: http://infostart.ru/public/91391/

Скачать файлы

Наименование Файл Версия Размер
MD82Exp_2_1_5.epf 112
.epf 20,59Kb
30.11.11
112
.epf 20,59Kb Скачать
УниверсальныеПодборИОбработкаОбъектов.epf 17
.epf 99,40Kb
30.11.11
17
.epf 99,40Kb Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Дмитрий Семенов (Sam13) 13.10.16 16:30
Просто спаситель.
Супер!
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа