gifts2017

Соответствие имен объектов SQL и 1С. С возможностью гибкого поиска.

Опубликовал Виталий (Vin_Tik) в раздел Администрирование - Поиск данных

Обработка с возможностью поиска объектов метаданных по имени 1С или по имени таблицы хранения SQL, с рядом дополнительных функций. Писал для удобства прямого доступа к базе и формирования SQL-запросов. Возможно дальнейшее развитие типа парсера запросов.

Писал под себя, так как работаем напрямую с данными 1С через SQL-запросы. Если кому понадобится, могу доработать функционал.

Также есть возможность проанализировать движения документов.

Скачать файлы

Наименование Файл Версия Размер
СоответствиеИменОбъектовSQL_И_1С.epf 177
.epf 15,48Kb
11.11.11
177
.epf 15,48Kb Скачать

См. также

Подписаться Добавить вознаграждение
Комментарии
0. Виталий (Vin_Tik) 28.10.11 16:33
Обработка с возможностью поиска объектов метаданных по имени 1С или по имени таблицы хранения SQL, с рядом дополнительных функций. Писал для удобства прямого доступа к базе и формирования SQL-запросов. Возможно дальнейшее развитие типа парсера запросов.


Перейти к публикации

1. psih12 28.10.11 16:33
При попытке открыть пишет, что обработка не для данной конфигурации. У меня это 8.2.14, УТ 10.3. Что это может быть?
2. Виталий (Vin_Tik) 29.10.11 08:06
(1) psih12, Попробуй открыть конфигуратором сначала
3. psih12 29.10.11 08:36
(2) Vin_Tik, В конфигураторе открывается нормально, конвертации под мою версию 1С не требует. А вот в режиме предприятия выдает ошибку.
4. Виталий (Vin_Tik) 29.10.11 08:52
(3) psih12, а в режиме отладки с остановкой на ошибках пробовал? Обработка универсал, пока не нашел где может спотыкаться, если тока в 8.2.14 что-то поменяли. Попробуй я сейчас 8.2.14 поставлю проверю
5. Виталий (Vin_Tik) 29.10.11 09:05
Открыл в 8.2.14.537 в локальной версии полет нормальный
6. psih12 10.11.11 22:49
(5) Vin_Tik, В какой конфигурации открыл? У меня в УТ 10.3 так и не открывается. Пишет, что данная обработка не предназначена для запуска в данной конфигурации
7. psih12 10.11.11 23:30
Запустил в режиме отладки. При открытии обработки выдало ошибку, что переменная не определена "Доп.МассивИзСтроки". Что это за переменная и что за метод такой?
8. psih12 10.11.11 23:58
Vin_Tik, я так понял, что "Доп.МассивИзСтроки" это функция разложения строки на подстроки, которая встроена у Вас в конфигурацию в каком-то модуле "Доп". Выложите ее, чтобы вставить ее в код самой обработки
9. Виталий (Vin_Tik) 11.11.11 15:54
Совершенно верно, проглядел это вот процедурка можете просто ее добавить и заменить вызов

Функция МассивИзСтроки(Строка,i=-1,Разд=";") Экспорт
Строка=СтрЗаменить(Строка,"""","""""");
Массив = "Массив = Новый Массив;Массив.Добавить("""+СтрЗаменить(Строка,Разд,""");Массив.Добавить(""")+""");";
Выполнить(Массив);

Если i>=0 Тогда // Получить значение по индексу
Если i<=Массив.Количество() Тогда
Возврат Массив[i];
Иначе
#Если КЛИЕНТ Тогда
Сообщить("В строке всего "+Массив.Количество()+" индексов, """+i+""" индекса нет!!!");
#КОНЕЦЕСЛИ
КонецЕсли;
КонецЕсли;

Возврат Массив;
КонецФункции
10. Виталий (Vin_Tik) 11.11.11 16:00
Исправил ошибку вызова функции МассивИзСтроки
11. psih12 16.11.11 15:46
Вот теперь вроде всё функционирует.
12. samir omarov (balabani) 20.11.11 03:30
Вот спасибо Очень нужна такая вещь в работе
13. Андрей Булатов (steklodom.1c) 24.11.11 09:26
Спасибо, действительно нужная вещь
14. Борис Моренко (BorisMor) 01.06.12 12:59
Хорошая обработка на будущее.
Пару раз надо было узнать в какой табличке лежит регистр т.к. на индексы ругались.
15. Олег Кабанов (cisOleg) 10.07.12 19:38
Обработка 1С платформа 2.2.
Для помощи формирования SQL запросов к информационной базе 1С
на сайте кис бюджетирование в разделе файлы и программы
логин oleg@cis2000.ru
пароль 123