gifts2017

Перенумератор справочников и документов

Опубликовал Георгий Худяков (vxm2365) в раздел Обработки - Обработка документов

Мастер перенумерации документов и справочников

за основу была взята обработка на этом сайте. Я бухгалтер, мне очень помогла

 

Мастер перенумерации справочников и документов (Обычная форма 8.2)

http://infostart.ru/public/79546/

 

Далее доработанная, чтобы можно было нумеровать документы с определенного номера. К сожалению, начальная обработка не позволяла перенумеровывать документы в кварталах, кроме первого. Т.е. если РКО в втором квартале нужно перенумеровать, это невозможно слелать, не повредив нумерацию первого, или нужно каждый квартал нумеровать с "1", что не соответствует нормативной базе.

Теперь этих проблем нет.

Скачать файлы

Наименование Файл Версия Размер
Мастер перенумерации документов и справочников Доработанный 262
.epf 12,05Kb
06.11.11
262
.epf 12,05Kb Скачать

См. также

Подписаться Добавить вознаграждение
Комментарии
0. Георгий Худяков (vxm2365) 20.11.11 03:22
Мастер перенумерации документов и справочников

Перейти к публикации

1. samir omarov (balabani) 20.11.11 03:22
Вот спасибо Очень нужна такая вещь в работе
2. 1 1 (girlochka) 25.11.11 03:10
3. Shade (Shade) 25.11.11 10:32
balabani пишет:

Вот спасибо Очень нужна такая вещь в работе



А скажите плиз:
в 8.1 есть версия или только в 8.2?
А то обратная конвертация не работает, а щас приспичило, найти не могу :((((
4. Владимир Б (antares_of) 02.12.11 14:45
давно хотел найти такую обработку, но все никак не мог, очень удобная штука, так как в бухгалтерии 2.0 этого нет, а в 1.6 было, вот и приходится вручную перенумеровывать, а это не очень удобно(
7. WarLex (WarLex) 02.12.11 20:19
Спасибо большое, обработка нужная и помогла сэкономить массу времени - вполне можно добавлять в свой повседневный арсенал.
9. Петр Петров (Adoms) 08.02.12 10:21
хорошая обработка, на захлебывается иногда, например № 25 надо изменить на 5 (по порядку) а номер пять уже есть в след. дате
10. Светлана Кончакова (Ariko-sv) 22.02.12 09:59
Чего-то не пойму что случилось, как нажала "выполнить", так даже из программы вылетела - это что?
11. Светлана Кончакова (Ariko-sv) 22.02.12 10:01
Кстати это 8.2 ред 2.0, а на 8.1 все отлично перенумеровало.
12. Светлана Кончакова (Ariko-sv) 22.02.12 10:04
Видимо потому, что там один документ был удален. Только его убрала, так все отлично пронумеровалось. Спасибо вам большое и прошу свои извенения.
13. Кирилл Панфилов (PanKir) 28.05.12 10:09
давно уже сбилась нумерация справочника контрагентов, а всё руки не доходили найти такую обработку
делал свою, но для документов, и то на уровне новичка-программиста 1С, через открытие формы :)
а тут недавно ещё и нумерация договоров сбилась, пришлось отключить автоматическое создание договора при новом контрагенте...

спасибо за обработку, буду тестировать...
14. Кирилл Панфилов (PanKir) 28.05.12 15:38
(0)
протестировал, немного сыровата...
дело в том, что когда число переводится в строку, то разделитель между группами становится пробелом, что не есть красиво и хорошо...
всё-таки номер (код) элемента состоит из 9 (или 11) цифр с лидирующими нулями (и префиксом, если надо):
"000004563" но не как не "00004 563" что и выходит в этой обработке...
15. Кирилл Панфилов (PanKir) 28.05.12 15:43
предлагаю вставить следующую функцию:
Функция УбратьВнутренниеПробелы(ЧислоСтрокой)
	
	ДлинаСтроки = СтрДлина(ЧислоСтрокой);
	едн = Прав(ЧислоСтрокой, 3);
	Если ДлинаСтроки > 8 Тогда 
		едн = Прав(ЧислоСтрокой, 3);
		ЧислоСтрокой = СокрЛП(Лев(ЧислоСтрокой, ДлинаСтроки-3));
		тыщ = Прав(ЧислоСтрокой, 3);
		млн = СокрЛП(Лев(ЧислоСтрокой, ДлинаСтроки-3));
		Возврат млн+тыщ+едн;
	ИначеЕсли ДлинаСтроки > 4 Тогда 
		едн = Прав(ЧислоСтрокой, 3);
		тыщ = СокрЛП(Лев(ЧислоСтрокой, ДлинаСтроки-3));
		Возврат тыщ+едн;
	Иначе 
		Возврат ЧислоСтрокой;
	КонецЕсли;
	
КонецФункции
...Показать Скрыть


и соответственно:
	тн = УбратьВнутренниеПробелы(тн);

между строками:
	тн = "" + нпп;
	ДлинаКоличестваЭлементов = СтрДлина(тн);

там, где таковые найдутся... (всего три вставки таких)
16. Кирилл Панфилов (PanKir) 28.05.12 16:11
(15) PanKir,
маленькое замечание - работал со справочником и забыл что в документах не 9 цифр в коде, а 11, то есть чтобы эта функция хорошо работала для больших баз, где количество документов реально доходит до 11-ти значных чисел надо добавить ещё одно условие на длину кода, а именно:
   Если ДлинаСтроки > 12 Тогда
      едн = Прав(ЧислоСтрокой, 3);
      ЧислоСтрокой = СокрЛП(Лев(ЧислоСтрокой, ДлинаСтроки-3));
      тыщ = Прав(ЧислоСтрокой, 3);
      ЧислоСтрокой = СокрЛП(Лев(ЧислоСтрокой, ДлинаСтроки-7));
      млн = Прав(ЧислоСтрокой, 3);
      млр = СокрЛП(Лев(ЧислоСтрокой, ДлинаСтроки-11));
      Возврат млр+млн+тыщ+едн;
   ИначеЕсли ДлинаСтроки > 8 Тогда 
      едн = Прав(ЧислоСтрокой, 3);
      ЧислоСтрокой = СокрЛП(Лев(ЧислоСтрокой, ДлинаСтроки-3));
      тыщ = Прав(ЧислоСтрокой, 3);
      млн = СокрЛП(Лев(ЧислоСтрокой, ДлинаСтроки-7));
      Возврат млн+тыщ+едн;
   ИначеЕсли ДлинаСтроки > 4 Тогда 
      едн = Прав(ЧислоСтрокой, 3);
      тыщ = СокрЛП(Лев(ЧислоСтрокой, ДлинаСтроки-3));
      Возврат тыщ+едн;
   Иначе 
      Возврат ЧислоСтрокой;
   КонецЕсли;
...Показать Скрыть


вот писал этот код и нашел у себя же опечатку - вычитал все время 3 из длины строки, а нужно ведь каждый раз на 4 больше...