gifts2017

Бухучет Украина.Начислении износа по полностью изношенному элементу

Опубликовал Дмитрий Литовченко (kompas-dm) в раздел Программирование - Ошибки в отраслевых решениях

Небольшая проблема при начислении износа по полностью изношенному элементу. В проводки идут рассчитанные суммы предыдущего элемента.

// ===============================
// рассчитывает износ по конкретному ОС, НМА, необоротному активу
// по установленному для него методу

Процедура РассчитатьИзносПоЭлементу(Элемент, ПервСтоимость, ПервКво, ОстСтоимость, СчИзноса, Сч, ПервСтоимостьНУ, ОстСтоимостьНУ, СчИзносаНУ, СчНУ)
    Элемент.ИспользоватьДату(НачМесяца(ДатаДок),1);
    Если Элемент.МетодРасчетаИзноса.Выбран() = 0 Тогда
        глКомментарий(Строка(Элемент)+": не задан метод расчета износа. Износ не начислен!",0,,"!");
        Возврат;
    КонецЕсли;
    Если ПервКво = 0 Тогда
        Если ОстСтоимость > 0 Тогда
            глКомментарий(Строка(Элемент)+": Первоначальное количество равно 0. Износ не начислен!",0,,"!");
        КонецЕсли; 
        СуммаИзноса = 0;   // нужно вставить
        СуммаИзносаНУ = 0;  // нужно вставить
       
        Возврат;
    КонецЕсли;

............................................  далее по тексту ............................................

Полный текст модуля документа - в файле вложения

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
МодульДокумента_НачислениеИзноса.rar
.rar 3,84Kb
09.11.11
1
.rar 3,84Kb 1 Скачать

См. также

Подписаться Добавить вознаграждение
В этой теме еще нет сообщений.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа