Чистильщик регистров 8.1/8.2

Опубликовал Осипов Сергей (fixin) в раздел Администрирование - Сервисные утилиты

Позволяет удалять или перезаписывать выбранные в списке записи регистров 1С (сведений, накоплений, бухгалтерии, расчетов).

Просто выбрать нужные записи и массово удалить или перезаписать.

Удобная утилита администрирования

Скачать файлы

Наименование Файл Версия Размер
ЧистильщикРегистров.epf
.epf 7,76Kb
09.11.11
18
.epf 7,76Kb 18 Скачать
ЧистильщикРегистров 82.epf
.epf 9,64Kb
09.11.11
118
.epf 9,64Kb 118 Скачать

См. также

Добавить вознаграждение
Комментарии
1. Vladimir (Boroda) 90 09.11.11 20:00 Сейчас в теме
Спасибо, вещь нужная и полезная. А "перезаписать" - в каком смысле? Отредактировать нужное значение и сохранить (перезаписать)? И "массово" - означает, что можно снести за один раз несколько регистров? (Просто, из скрина не совсем понятен принцип работы...)
2. motherf 09.11.11 20:52 Сейчас в теме
Перезаписать - это для РИБ, чтобы эти записи ушли сразу во все узлы РИБ. Просто для каждой записи вызывается метод "Записать".
А обрабатывается только один выбранный в данный момент регистр. Открывается его форма списка и множественным выделением можно выделять строки. Выбранные строки можно удалить или перезаписать.
Просто технический инструмент.
3. A (Kochevnic) 09.11.11 21:04 Сейчас в теме
Спасибо! Пригодится в хозяйстве
4. Валерий Дубовой (Valerich) 1603 16.11.11 03:45 Сейчас в теме
выбирать нужные записи вручную.... это как закат солнца тем же методом. для мелких баз сгодится, для серьезной работы нет
5. motherf 16.11.11 11:55 Сейчас в теме
(4) ну почему же. Делаете отбор нужных записей в форме списка через отборы, нажимаете Ctrl + A и вперед!
Порою это быстрее, чем писать код.
6. Анастасия Столбовская (StAsya_1C) 14 16.11.11 17:48 Сейчас в теме
Для распределенки самое то, спасибо!
7. motherf 17.11.11 06:54 Сейчас в теме
(6) ну так для этого и было задумано "Перезаписать", для РИБ.
8. Sergio Bargio (sergiobargio1) 112 15.02.13 12:02 Сейчас в теме
Спасибо, очень необходимая обработка. Пожалуйста, подскажите как ей воспользоваться?
;-(
Запустил обработку,
выбрал РегистрыБухгалтерии.Хозрасчетный,
в табличной части пусто ;-(
Как предварительно выбрать по условию необходимые записи?
9. Осипов Сергей (fixin) 3454 15.02.13 12:23 Сейчас в теме
(8) sergiobargio1, сделай ПКМ, выбери интервал записей. Возможно, интервал кривой стоит.
10. Sergio Bargio (sergiobargio1) 112 15.02.13 12:45 Сейчас в теме
(9) fixin, пардон за дилетантский вопрос, что такое ПКМ?
11. Осипов Сергей (fixin) 3454 15.02.13 12:55 Сейчас в теме
12. Sergio Bargio (sergiobargio1) 112 15.02.13 13:21 Сейчас в теме
(11) fixin, спасибо ;-) да это первое что я пробовал. все отборы отключены, интервалы без ограничений, увы ни чего не отображается, см. скрин
Прикрепленные файлы:
13. Осипов Сергей (fixin) 3454 15.02.13 13:28 Сейчас в теме
(12) sergiobargio1, скрин интервала не вижу. проблема в интервале скорее всего...
14. Sergio Bargio (sergiobargio1) 112 15.02.13 13:31 Сейчас в теме
15. Осипов Сергей (fixin) 3454 15.02.13 13:37 Сейчас в теме
счас гляну.
глянул, ситуация воспроизводится. почему - не знаю. ;-)
16. Sergio Bargio (sergiobargio1) 112 15.02.13 14:06 Сейчас в теме
(15) fixin, другие регистры открываются. обновить не помогает. возможно для класса регистра бухгалтерии какое-то появилось свойство, ограничивающее доступ к нему?
17. Осипов Сергей (fixin) 3454 15.02.13 14:40 Сейчас в теме
(16) поставил отбор по одной из колонок - все появилось (поле "Содержание" = ""). Снял отбор - и опять все пропало.
Видимо, без отбора не показывает.
Попробуйте повторить эту методику, если именно счас надо почистить чего-то.
18. Sergio Bargio (sergiobargio1) 112 15.02.13 15:18 Сейчас в теме
(17) fixin, это да, только при условии поле "Содержание" = "". Засада, что при любых других условиях поля "Содержание" уже ни чего в таблице значений не отражается. Перепробывал разные варианты с этим полем, кроме = "" - увы, не обходит баг. пытаюсь по другим реквизитам условия - тоже, увы пусто. Наверное не удастся воспользоваться обработкой: у Вас там условие, что для бухгалтерского регистра удаление только по одной строке. Закомментировал условие, но мне необходимо очень большой массив удалить по условию: если в проводке вид субконто является ссылкой на Справочники.ОбъектСтроительства и значение этого субконто Справочники.ОбъектСтроительства.ПустаСсылка(). Наспех наваял обработку
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
Движение.Отбор.Регистратор.Установить(ВыборкаДетальныеЗаписи.Ссылка);

Для каждого Запись Из Движение Цикл
Если Запись.СубконтоДт = Справочники.ОбъектыСтроительства.ПустаяСсылка() Тогда
Движение.Удалить(Запись);
КонецЕсли;
КонецЦикла;

Движение.Записать();
КонецЦикла;
КонецПроцедуры
Но увы, при выполнении платформа выдала "Не хватает памяти".
Пожалуйста, черканите текст запроса для выборки ВыборкаДетальныеЗаписи , плз.
Спасибо.
19. Осипов Сергей (fixin) 3454 15.02.13 15:58 Сейчас в теме
не, сорри, не ко мне... некогда
20. Sergio Bargio (sergiobargio1) 112 15.02.13 16:06 Сейчас в теме
(19) fixin, тогда извините, что побеспокоил. Ваша обработка подтолкнула к хорошей идее. Большое спасибо.