Проверка соответствия НДФЛ удержанного/перечисленного (ЗиК)

Опубликовал legioner в раздел Отчеты - Анализ учета

Отчет, позволяющий выявить ошибки при распределении сумм НДФЛ уплаченных (ЗиК)

1с не стала мудрить и сделала алгоритм распределения перечисленных сумм НДФЛ по аналогии с ПФР.

К тому же если сумма уплаты превышает сумму начисления - остаток от распределения прибавляется к сумме сотрудника у которого она наибольшая. И этот "хвостик" при следующем распределении  не учитывается вообще. К тому же если уплат за месяц было несколько и общая сумма не будет равна сумме удержанного НДФЛ - коэффициент распределения <> 1 и суммы не распределятся по сотрудникам так как надо.

Отчет призван облегчить жизнь расчетчиков и найти ошибки распределения.

 

Новая версия отчета.

Исправил выявленные недочеты (см. комментарии). 

Отличия:

1) Данные берутся не из журнала расчетов, а типовыми процедурами, что дает возможность учитывать корректировки НДФЛ в карточке

2) Возможность брать для анализа как начисленный, так и удержанный НДФЛ

3) Добавлено количество отчетов для анализа

 

Режимы:

Сравнить начислено/уплачено целиком - показывает суммы уплачено/перечислено по сотрудникам/списку в целом за период

Сравнить начислено/уплачено помесячно - показывает суммы уплачено/перечислено по сотрудникам/списку с разбивкой по месяцам

Итоги начислено/уплачено помесячно - показывает суммы уплачено/перечислено в целом (без разбивки по сотрудникам)
Количество выплат сотрудника в периоде - показываем сколько документов было по сотруднику в месяце (нужен если заполняли вручную по отпускникам: отпуксники)

Сравнить НДФЛ начис/удерж по сотрудникам - сравнивает начисленный/держанный НДФЛ по сотрудникам за указанный период

Сравнить НДФЛ начис/удерж по месяцам - сравнивает начисленный/держанный НДФЛ помесячно сводно

Сравнить НДФЛ начис/удерж (шахматка) - сравнивает начисленный/держанный НДФЛ помесячно в разрезе сотрудников 

 

Можно выбирать ставки и ОКАТО (подразделения)

Файлы

Наименование Файл Версия Размер Кол. Скачив.
проверка НДФЛ_ЗиК.ert
.ert 91,00Kb
12.03.12
372
.ert 91,00Kb 372 Скачать

См. также

Лучшие комментарии

69. andrewks (файл скачал) 10.03.2012 20:18
(65) вот что не так:

например, отчёт №2 (сравнить начислено/уплачено помесячно)
вот что творится в ТЗ: http://savepic.su/1521600.htm
видно что для каждого ключа "Сотрудник+Период" есть две строки - одна с пустым ОКАТО/КПП (начисления), вторая с указанным ОКАТО/КПП (уплаты)

соответственно, вот этот кусок кода:
				СуммаУдержана=0;
				СуммаПеречислена=0; 
				а=0;
				Если ТЗ.НайтиЗначение(ТЗ1.Сотрудник,а,"Сотрудник")=1 Тогда
					Для й=а По ТЗ.КоличествоСтрок() Цикл
						ТЗ.ПолучитьСтрокуПоНомеру(й);
						Если ТЗ.Сотрудник<>ТЗ1.Сотрудник Тогда
							Прервать;
						КонецЕсли;
						Если ДатаМесяц(ТЗ.Период)=к Тогда
							Если БратьНДФЛУдержанный=1 Тогда
								СуммаУдержана=ТЗ.СуммаУдержана; 
							Иначе
								СуммаУдержана=ТЗ.СуммаИсчислена; 
							КонецЕсли;          
							СуммаПеречислена=ТЗ.СуммаПеречислена; 
						КонецЕсли;
					КонецЦикла;
				КонецЕсли;

...Показать Скрыть


будет выводить хаотические данные
Ответили: (74)
+ 1 [ legioner; ]
# Ответить
72. sam41 (файл скачал) 11.03.2012 14:34
в строке 326 исправьте "СписокСтавок.ТекущаяСтрока()=1" на "СписокСтавок.ТекущаяСтрока()=2".
Ответили: (73)
+ 1 [ legioner; ]
# Ответить

Комментарии

1. log1 17.11.2011 08:47
Спасибо!!!! Очень актуально
# Ответить
2. TrinitronOTV (файл скачал) 17.11.2011 09:02
log1 пишет:

Спасибо!!!! Очень актуально

присоединяюсь, очень полезный отчет
Ответили: (17)
# Ответить
3. Boroda (файл скачал) 17.11.2011 09:04
Вот отлично - только с утра озадачили проблемой (не идёт НДФЛ), и вот помощь от legioner в её решении! Огромное спасибо, Олег, за обработку!
# Ответить
4. legioner 17.11.2011 09:36
Не за что.
Планирую к концу недели сделать подобный для бухгалтерии
# Ответить
5. ysb_ter (файл скачал) 17.11.2011 22:02
Эта обработка точно для "оперативного учёта", как сказано в описании, или всё-таки для "расчёта" ?
# Ответить
6. ninak (файл скачал) 18.11.2011 01:53
Тоже хочу знать - для ЗИК эта обработка?
# Ответить
7. legioner 18.11.2011 05:46
Извиняюсь "промазал" мышкой... конечно же расчет. Поправил.
Обработка для "Зарплата и Кадры"
# Ответить
8. kurvik 23.11.2011 10:08
Вовремя, отлично - только что бухгалтера озадачили проблемой (не идёт НДФЛ).И вот помощь от legioner в её решении! Огромное спасибо, Олег!Будем использовать.
# Ответить
9. Lyuba-Lyuba 23.11.2011 10:10
В точку, оч актуально!
# Ответить
10. legioner 23.11.2011 10:26
Для бухгалтерии тоже сделал.
Брать здесь http://infostart.ru/public/99279/
# Ответить
11. It-developer 24.11.2011 15:40
Такое же для УПП 1.3 надо :)
# Ответить
12. legioner 25.11.2011 14:29
Если на выходных хватит времени - сделаю)))))
# Ответить
13. legioner 26.11.2011 06:40
Исправлена ошибка - не учитывался налог начисленный если по человеку в этом месяце не было уплаты.
# Ответить
15. NPMar (файл скачал) 30.11.2011 10:02
Спасибо! Хотела сама писать такую обработку, но никак не хватало времени. Много было проблем, если в течении месяца были перечисления НДФЛ по сотрудникам несколько раз и вот эти "хвостики"... Почему-то это никак не могут учесть в поставляемых релизах. Суммы не распределятся по сотрудникам так как надо.
По крайней мере этот отчет может помочь как-то разобраться.
# Ответить
16. NPMar (файл скачал) 30.11.2011 10:47
Проверила обработку. Обнаружился некоторый недостаток. Не считается удержанный НДФЛ с сумм отпускных, начисленных в декабре прошлого года. Мы перечислили НДФЛ в декабре 2010г, я показала, что налог перечислен за январь в декабре. Он отлично посчитался. Но сумма удержаного налога не взялась. Хотя в реестре все идеально.
Наверное это не недостаток. Просто этот дебелизм с разбивкой сумм по периодам действия по НДФЛ везде вызывает недоумения. Очень хорошая обработка. Еще раз спасибо!
Ответили: (33)
# Ответить
17. 2011b11 (файл скачал) 30.11.2011 16:08
(2) TrinitronOTV, Я тоже присоединяюсь ко всем. Спасибо большое за соевременную обработку, очень понадобиться сейчас, после новых изменений в вычетах.
# Ответить
19. zharkov.ss 30.11.2011 22:56
Спасибо за обработку, будет полезный инструмент для бухгалтера, для выявления косяков по ндфл. А то все по старинке "крыжили"...
# Ответить
20. Big_Pavel (файл скачал) 01.12.2011 10:18
Не считались ИТОГИ Если Итого ПОМЕСЯЧНО
Вставте строки где !! знаки
ИначеЕсли РежимВыводаОтчета=3 Тогда

Таб.ИсходнаяТаблица("Таб_Итоги");

ТЗ.НоваяКолонка("Месяц");
ТЗ.ВыбратьСтроки();
Пока ТЗ.ПолучитьСтроку()=1 Цикл
ТЗ.Месяц=НачМесяца(ТЗ.МесяцРег);
КонецЦикла;

ТЗ.Свернуть("Месяц","НДФЛ_У,СуммаСумма");
ТЗ.Сортировать("Месяц");

//заголовок
Таб.ВывестиСекцию("Заг");
Таб.ВывестиСекцию("Месяц");
!!! Итог_НДФЛ_У=0;
!!! Итог_СуммаСумма=0;
//таблица
ТЗ.ВыбратьСтроки();
Пока ТЗ.ПолучитьСтроку()=1 Цикл
МесяцОтчета=МесяцПрописью(ДатаМесяц(ТЗ.Месяц))+" "+Год+"г.";
Таб.ВывестиСекцию("Стр");
!! Итог_НДФЛ_У=Итог_НДФЛ_У+ТЗ.НДФЛ_У;
!! Итог_СуммаСумма=Итог_СуммаСумма+ТЗ.СуммаСумма;
КонецЦикла;

//итоги
Таб.ВывестиСекцию("Итог");
Ответили: (29)
# Ответить
21. Big_Pavel (файл скачал) 01.12.2011 10:20
Очень странная расшифровка на колонке Сумма НДФЛ удержанно
Эта колонка затрагивает документы выплат .... а расшифровка только по уплате в бюджет ....
# Ответить
22. Полковник (файл скачал) 01.12.2011 11:01
Спасибо! Расчетчики обратились с проблемами по НДФЛ. О чудо! Уже есть нужная обработка. Жаль что 1-Сники вообще не хотят с этими проблемами разбираться, все идет к тому, что бы бросить 7-ку (ну, прямо заставляют это делать). А кто-нибудь знает, в 8-ке так же или получше?
Ответили: (25) (76)
# Ответить
23. Il 02.12.2011 09:25
Эх жалко чутка бы пораньше... - недавно сам мучался.
# Ответить
24. Il 02.12.2011 09:25
Но плюс однозначно!
# Ответить
25. Il 02.12.2011 09:30
(22) Полковник, в 8-ке эсники более грамотно подошли к этому вопросу.
# Ответить
26. Nikola178 (файл скачал) 07.12.2011 15:02
Присоединяюсь к предыдущим ораторам -Спасибо автору за ценную обработку!! весьма своевременно, особенно в преддверии закрытия года немного облегчит труд проверки
# Ответить
27. LN (файл скачал) 07.12.2011 15:10
Обработка полезная и умная, пригодится. А в последнем релизе Зарплата и кадры реализован расчет НДФЛ перечисленного с выбором : по НДФЛ удержанному или начисленному. Наконец-то...
# Ответить
28. Nikola178 (файл скачал) 08.12.2011 11:13
да, кстати, протестил обработку. При установке периода выборки не с начала года, а например с апреля и по декабрь и выбрав режим отчета "сравнить начислено/уплачено помесячно" выдается вот такое вот ругательство:

ТабИтог.ПолучитьСтрокуПоНомеру(к);
{G:\DISTRIB\ОБРАБОТКИ ДЛЯ 1С\ДЛЯ ЗИК\ПРОВЕРКА НДФЛ_ЗИК.ERT(398)}: Номер за пределами значения!

Подскажите, как можно исправить??
Ответили: (29)
# Ответить
29. legioner 10.12.2011 05:55
Выложил новую версию отчета.
Учтены замечания (20) и (28).
# Ответить
30. Nikola178 (файл скачал) 12.12.2011 11:41
Nikola178 пишет:

да, кстати, протестил обработку. При установке периода выборки не с начала года, а например с апреля и по декабрь и выбрав режим отчета "сравнить начислено/уплачено помесячно" выдается вот такое вот ругательство:



ТабИтог.ПолучитьСтрокуПоНомеру(к);

{G:\DISTRIB\ОБРАБОТКИ ДЛЯ 1С\ДЛЯ ЗИК\ПРОВЕРКА НДФЛ_ЗИК.ERT(398)}: Номер за пределами значения!

Подскажите, как можно исправить??


Большое спасибо автору за оперативность, теперь все рулит, как надо...!!!
# Ответить
31. legioner 12.12.2011 15:29
Не за что.
Проверьте правильность распределения уплат ПФР
с помощью вот этого отчета
http://infostart.ru/public/101402/
# Ответить
32. oleg_judin 14.12.2011 11:09
Интересный отчет. Рекомендую. Автору спасибо.
# Ответить
33. Boroda (файл скачал) 16.12.2011 19:20
(16) Да, этим НДФЛ отличается от СВ: в первом случае налог идёт ЗА период, к которому относятся начисления, а во втором взносы падают В период, в котором были начисления. Но, вроде бы, в этом году (а заставляли желать же и в прошлом) было распоряжение от налоговой запрещающее такое распределение НДФЛ в конце налогового периода, т.е. года. Иными словами, если переходящий отпуск был начислен в декабре этого года, то и НДФЛ за отпуск полностью должен остаться в этом же году. Видимо, они сами заколебались в этом учёте. Номер и дату документа не помню, давно видел, где-то по весне ещё.
Мечта: эх, если бы помимо кнопки вывода отчёта была бы и кнопка "Перезаполнить правильно НДФЛ"...
Ответили: (34) (35)
# Ответить
34. LN (файл скачал) 16.12.2011 20:22
(33) Boroda, такие документы надо где-то записывать, хотя обычно 1С старается соответствовать нормативной базе. Неужели сейчас 7-ку настолько забросили, что и на новые распоряжения не обращают внимания. Надо будет проверить как в 8-ке считается НДФЛ по переходящим отпускам.
# Ответить
35. legioner 17.12.2011 16:52
(33)
Есть бородатый анекдот:
3 кнопки:
- Заполнить по данным БД
- Заполнить как хочет ГНИ
- Заполнить правильно
Поэтому мечты остаются мечтами)))))))))
# Ответить
36. Гость 20.12.2011 12:26
очень интересная и полезная обработка,спасибо,очень кстати
# Ответить
37. andru_dv 23.12.2011 16:54
Спасибо. Актуальный отчет. Особенно в конце года.
# Ответить
38. prog-eg (файл скачал) 24.12.2011 23:02
Сформировала отчет. Затем выполнила ручную корректировку данных по НДФЛ: изменила сумму уплачено.
Сформировала отчет заново, но исправления не отражаются в отчете хотя в регистре налогового учета все отразилось.
Ответили: (42)
# Ответить
39. harutyunb 27.12.2011 16:18
актуальность высока перед отчетами.
# Ответить
40. higs (файл скачал) 30.01.2012 13:35
Большое спасибо! Вот и у меня начали базы подбираться к сдаче!! Обработка пригодилась. Единственное неудобство: в выборе вида отчета везде указано Начислено/Уплачено, а фактически собирается Удержано\Уплачено. Если бы были все три ресурса, было бы не хуже!
Ответили: (43)
# Ответить
42. legioner 08.02.2012 13:20
(38) данные берутся только непосредственно из ЖР. Это не коммерческая версия
Ответили: (45)
# Ответить
43. legioner 08.02.2012 13:21
(40) Хорошо. Думал об этом - поправлю
# Ответить
45. bb1962 (файл скачал) 09.02.2012 07:39
(42) legioner,
А следовало бы брать их из глСобратьДанныеДляНДФЛВыбор().
Ответили: (46)
# Ответить
46. legioner 29.02.2012 04:59
(45) Так и сделал... Выложил новую версию отчета.
Данные берутся не из ЖР, а типовыми процедурами + прикрутил еще 3 отчета дополнительно.
# Ответить
48. Cvetic 29.02.2012 11:17
Хорошо бы добавить еще одну колоноку "Сумма НДФЛ исчисленного".
# Ответить
49. legioner 29.02.2012 11:26
Реализовано... Выберите вариант НДФЛ
Ответили: (50)
# Ответить
50. ysb_ter (файл скачал) 29.02.2012 21:39
(49) Теперь, похоже, реализованы практически все высказанные пожелания.
Хоть и "нет предела для совершенства" :)
Спасибо за обработку.
Ответили: (51)
# Ответить
51. legioner 01.03.2012 02:02
(50)Есть еще задумка. Автоматически исправлять в карточке ситуацию с "переходящими" отпусками и больничными листами. Постараюсь реализовать в ближайшие дни.
# Ответить
52. Mitusinka 01.03.2012 10:51
Если все делаешь правильно, то с ндфл проблем не дожлно быть, рассчитываешь зарплату, выплачиваешь заработную плату, создаешь документ на перечисление ндфл в текущем месяце, делаешь рассчитать ндфл удержанный и спокойно переходишь на следующий месяц. и год закрывается без проблем
Ответили: (79)
# Ответить
53. legioner 01.03.2012 12:50
Это если правильно..... А если ЗП выплачивается не регулярно или частями? А переходящие отпуска/больничные? А головотяпство расчетчиков? А если начислено больше чем уплачено?

Вариантов пруд пруди.
Ответили: (100)
# Ответить
54. aimerlive 01.03.2012 12:52
отчет заставляет в очередной раз задуматься о периоде регистрации и периоде действия. Доходы беруться по периоду действия значит и налоги должны так же считаться .
Ответили: (56)
# Ответить
55. log22 01.03.2012 13:00
Спасибо огромнейшее!!! Отчет просто супер!
Ответили: (66) (75)
# Ответить
56. legioner 01.03.2012 13:02
(54)Не все так однозначно.... По логике 1С делает ВСЕ ПРАВИЛЬНО. Никто же не виноват что ГНИ считает по своему.
К тому же как быть тогда с перерасчетами за предыдущие месяца?
# Ответить
57. andrewks (файл скачал) 01.03.2012 17:25
в варианте "Сравнить начислено/уплачено помесячно" отчёт выводит неверные данные по суммам уплаты (суммы в разрезе месяц/сотрудник не соответствуют введённым документам уплаты, причём даже итог уплаты за м-ц тоже не соответствует)
Ответили: (58) (61)
# Ответить
58. andrewks (файл скачал) 01.03.2012 17:32
(57) дико извиняюсь, ложная тревога, оказывается, в базе была введена дополнительная оплата за январь в сентябре (не ошибка, а т.к. делали перерасчёт), а сразу я этого не заметил.

реально нужная обработочка, если бы не наткнулся, хотел уже сам писать что-то подобное, чтобы косяки вылавливать
Ответили: (65)
# Ответить
. ysb_ter (файл скачал) 02.03.2012 13:14
(58) а у меня не "ложная тревога", а именно как в сообщении 57
"дополнительных оплат" в базе нет, там всего-то 3 оплаты в апреле за январь и февраль
# Ответить
. ysb_ter (файл скачал) 02.03.2012 13:29
(49) На чём ещё споткнулся при просмотре обработок:

1. при выборе "Сравнить НДФЛ начисл/удерж по сотрудникам"
и при выборе "Сравнить НДФЛ начисл/удерж по месяцам"
не считает "Итого" по колнке "Разница"

2. "Количество выплат сотрудника в периоде"
если выплат больше чем 1 - то появляется список и можнов нём перейти к просмотру
если выплата одна - то список из одной этой выплаты не появляется (неудобство однако :) )

3. "Итоги начисл/уплач помесячно" и "Сравнить начисл/уплач помесячно"
если выбирать "Брать НДФЛ начисленный", то заголовок колонки всё-равно остаётся "Сумма НДФЛ удерж", хотя цифры берутся правильно.
Возникает путанница при просмотре сформированных отчётов.
# Ответить
61. andrewks (файл скачал) 03.03.2012 13:59
нет, всё-таки возвращаю (57). в ситуации, когда несколько ОКАТО/КПП, данные по уплате выводятся совершенно хаотические
Ответили: (62)
# Ответить
62. andrewks (файл скачал) 03.03.2012 14:01
+(61) и по исчисленному НДФЛ тоже
# Ответить
63. andrewks (файл скачал) 03.03.2012 14:10
что-то нумерация сообщений какая-то странная
Ответили: (64)
# Ответить
64. ysb_ter (файл скачал) 03.03.2012 22:06
(63) мало того, что нумерация странная, но ни 54 ни 55 сообщения (те, которые мои) никак не отразились в моей "статистике"
# Ответить
65. legioner 05.03.2012 02:26
(58)Данные об уплатах берутся типовой процедурой из ГМ... Смотрите внимательнее
Или приведите приме что не так у вас.
Ответили: (69)
# Ответить
66. legioner 05.03.2012 02:32
(55)
1) В каком именно режиме не считается? Подразделения выбирали или по всем? НДФЛ начисленный или удержанный?
Ставка налога?

2) Ну одна выплата и одна... На больших предприятиях он (список) будет тогда просто ОГРОМНЫЙ.
Вам нужно видеть какими документами получилась сумма по сотруднику за указанный период?
Хорошо - прикручу к отчету дополнительную расшифровуку

3) Да, заголовки забыл поменять - поправлю
# Ответить
67. berta (файл скачал) 09.03.2012 12:12
Вы спасли мне жизнь ,еще не разобралась но такая ситуация , суммы для перечисления брала со свода за месяц,и теперь вдруг всплывает что данные при выгрузке справок за 2011 год рвет на 5 тысяч с суммой если я складываю помесячно из сводов на предприятии работает 215 человек как их искать и с чем это связано ума не приложу очень надеюсь на вашу обработку
Ответили: (68)
# Ответить
68. legioner 10.03.2012 07:41
(67) Прочитайте вот эту статью. В ней описываются некоторые "тонкие" моменты НДФЛ
http://www.1c-pro.ru/topic40069.html
Может помоет вам разобраться.
Ответили: (87)
# Ответить
69. andrewks (файл скачал) 10.03.2012 20:18
(65) вот что не так:

например, отчёт №2 (сравнить начислено/уплачено помесячно)
вот что творится в ТЗ: http://savepic.su/1521600.htm
видно что для каждого ключа "Сотрудник+Период" есть две строки - одна с пустым ОКАТО/КПП (начисления), вторая с указанным ОКАТО/КПП (уплаты)

соответственно, вот этот кусок кода:
				СуммаУдержана=0;
				СуммаПеречислена=0; 
				а=0;
				Если ТЗ.НайтиЗначение(ТЗ1.Сотрудник,а,"Сотрудник")=1 Тогда
					Для й=а По ТЗ.КоличествоСтрок() Цикл
						ТЗ.ПолучитьСтрокуПоНомеру(й);
						Если ТЗ.Сотрудник<>ТЗ1.Сотрудник Тогда
							Прервать;
						КонецЕсли;
						Если ДатаМесяц(ТЗ.Период)=к Тогда
							Если БратьНДФЛУдержанный=1 Тогда
								СуммаУдержана=ТЗ.СуммаУдержана; 
							Иначе
								СуммаУдержана=ТЗ.СуммаИсчислена; 
							КонецЕсли;          
							СуммаПеречислена=ТЗ.СуммаПеречислена; 
						КонецЕсли;
					КонецЦикла;
				КонецЕсли;

...Показать Скрыть


будет выводить хаотические данные
Ответили: (74)
+ 1 [ legioner; ]
# Ответить
70. andrewks (файл скачал) 10.03.2012 20:21
как минимум нужно исправить так:

						Если ДатаМесяц(ТЗ.Период)=к Тогда
							Если БратьНДФЛУдержанный=1 Тогда
								СуммаУдержана=СуммаУдержана+ТЗ.СуммаУдержана; 
							Иначе
								СуммаУдержана=СуммаУдержана+ТЗ.СуммаИсчислена; 
							КонецЕсли;          
							СуммаПеречислена=СуммаПеречислена+ТЗ.СуммаПеречислена; 
						КонецЕсли;

...Показать Скрыть


так хотя бы выводятся правильные данные в итоговой колонке, и во многих колонках за месяц (но не во всех)
# Ответить
71. andrewks (файл скачал) 10.03.2012 20:38
расхождения возникают, когда смотришь по НДФЛ удержанному, когда по НДФЛ исчисленному - всё норм.

причём, в ТЗ сумма НДФЛ удерж. не совпадает с суммами по журналу зарплаты (причём "хаос" возникает именно по месяцам, в итоге за год совпадает)

непонятно
# Ответить
72. sam41 (файл скачал) 11.03.2012 14:34
в строке 326 исправьте "СписокСтавок.ТекущаяСтрока()=1" на "СписокСтавок.ТекущаяСтрока()=2".
Ответили: (73)
+ 1 [ legioner; ]
# Ответить
73. legioner 12.03.2012 03:30
(72)Спасибо за замечание. Исправил
# Ответить
74. legioner 12.03.2012 05:30
(69)Поправил недочет с режимом "по всем ОКАТО". Теперь таблица не расползается
# Ответить
75. legioner 12.03.2012 05:31
(55)Поправил заголовок в отчете. Спасибо за замечание
# Ответить
76. Gulak 13.03.2012 10:30
(22) Полковник, это точно! да еще бы дали гарантий, что на 8-ке будет лучше... а там похоже тоже самое...
# Ответить
77. harutyunb 13.03.2012 16:13
после проверки, предлагаю использовать обработку infostart.ru/public/120493/, думаю что будет полезна, в том плане что она исправит в документе перечисление НДФЛ суммы расхождения.
# Ответить
78. JER_MARK (файл скачал) 13.03.2012 16:29
Плюсую! Вещь нужная, пока нигде не встречалось аналога.
# Ответить
79. Полковник (файл скачал) 14.03.2012 02:35
(52) Mitusinka, Это вам так кажется, что не будет проблем! У нас на предприятии, например, в декабре 2011 начислили отпуск сотруднику с 25.12.2011 по 05.02.2012гг, выплатили, НДФЛ удержали и перечислили, так в справке 2-НДФЛ за 2011г. суммы, приходящиеся на январь и февраль 2012г. не отражаются! Они отражаются в справке на 2012г. Ну, а отсюда все вытекающие последствия! Приходится все вручную корректировать.
Ответили: (82)
# Ответить
80. serpent (файл скачал) 14.03.2012 10:48
в приложенных скриншотах , для наглядности надо было закрасить ФАМИЛИЮ а не цифры...
теряется наглядность и информативность обработки.
# Ответить
81. Rockman 14.03.2012 15:49
Спасибо за обработку. Хоть НДФЛ уже сдан, но все равно качну на будущее.
# Ответить
82. legioner 14.03.2012 17:35
(79)С переходящим НДФЛ - старая морока. 1с делает как надо, а не как хочет ГНИ... К тому же еще и вычеты пытается "накрутить". Год то новый.... Здесь или править сотрудников через карточку или корректировать ЖР.
# Ответить
84. shults69 16.03.2012 10:59
Очень актуально, цифры по НДФЛ плывут.
Ответили: (85)
# Ответить
85. legioner 16.03.2012 11:34
(84)Плывут цифры в отчете? В каком?
# Ответить
86. shults69 17.03.2012 11:57
Цифры плывут в стандартных отчетах и регистрах по НДФЛ, несовпадение НДФЛ начисленного и удержанного, с Вашим все нормально.
# Ответить
87. legioner 17.03.2012 16:02
Прочитайте статью указанную здесь (68)
Думаю будет полезно узнать почему у вас такая "свистопляска"
# Ответить
88. JER_MARK (файл скачал) 20.03.2012 08:09
Вчера на большом предприятии проверяла обработку. Есть несколько замечаний.
1. Если взять налоговый регистр по НДФЛ и обработку, то бывают расхождения между регистром и обработкой в том, в какой месяц относится НДФЛ удержанный. Из-за этого мне было трудно с помощью обработки анализировать правильно ли уплачен налог.
2. По некоторым сотрудникам заметила, что не учитывались корректировки из справочника "НКИтоги". Возможно дело в том, что в таблице полученной с помощью глСобратьДанныедляНДФЛ...() в колонках "_10" и "НУ1" хранится НДФЛ удержанный, но по каким-то причинам там не всегда одинаковые данные.
Ответили: (90) (94)
# Ответить
89. JER_MARK (файл скачал) 20.03.2012 08:10
Кстати, может где есть ответ на такой вопрос: сотрудник сменил статус нерезидента. И по 30% и по 13% было уплачено все. А в справке 2-НДФЛ отображается в графе "Перечислено" отображается только сумма оплаты по 13%
Ответили: (93)
# Ответить
90. bb1962 (файл скачал) 20.03.2012 08:20
(88) JER_MARK,
>в таблице полученной с помощью глСобратьДанныедляНДФЛ...()
нужно правильно параметры задавать.
Ответили: (91)
# Ответить
91. JER_MARK (файл скачал) 20.03.2012 09:12
(90) bb1962, Какие именно параметры ты имеешь ввиду? Собственно то, что можно указать на форме - указываю, а вот уж что подставляется в функцию - мне неизвестно.
Ответили: (92)
# Ответить
92. bb1962 (файл скачал) 20.03.2012 09:31
(91) JER_MARK,
Что на форме, я не знаю, а в функции есть параметр "Режим"
Если Режим = 1 Тогда
справочник "НКИтоги" используется.
# Ответить
93. ysb_ter (файл скачал) 20.03.2012 21:00
(89) вообще-то вопрос не по данной обработке.
ответ, например, был в "Главной книге" № 4-2012 стр.50-51
(она уже включена в КонсультантПлюс в базу "Бухгалтерская пресс и книги", статья "Как быстро заполнить и сдать справки 2-НДФЛ").
суть ответа - "статус работника надо указать по состоянию на конец года".
если нужен скан журнала - пиши.
# Ответить
94. legioner 21.03.2012 02:42
(88)
JER_MARK, ручные корректировки в текущей версии отчета учитываются (не учитывались в первой версии отчета - вы пользуетесь актуальным?) Что же касается расхождений по НДФЛ удержанному то вы похоже путаете месяц уплаты и за какой месяц уплачено. Сальдо по указанным вами сотрудникам случайно не "пляшет"?
# Ответить
95. OleGazz 22.03.2012 06:22
спасибо большое, было интересно почитать статью и коменты, узнал много нового...
# Ответить
96. aleksei_t 23.03.2012 09:47
Спасибо!!!! Очень актуально
# Ответить
97. NPMar (файл скачал) 23.03.2012 11:52
Еще раз, спасибо большое за обработку. Тем более, она сейчас доработана. Придется еще раз скачать!
Тем более, что сейчас учитываются ручные коррктировки.
# Ответить
98. berezin (файл скачал) 28.03.2012 15:26
Спасибо! Буду еще раз качать с исправлениями
# Ответить
99. ljolsen 23.08.2012 10:05
Спасибо за обработку!!! Вот пока только скачать не могу
# Ответить
100. ljolsen 23.08.2012 10:23
(53) legioner, Вот и у нас такая "фигня" - начислено больше чем уплачено, причем всем сотрудникам и почему-то в июле 2011 года. Зато в декабре им начислено меньше,чем пречислено.Получается в итогах так: СуммаИсчислено=СуммаУдержано=СуммаПеречислено!
# Ответить
101. NikaK 27.12.2012 09:16
legioner, если можно, скиньте на мыло nikak155@mail.ru, пожалуйста, последнюю версию отчета. Очень много доработок у вас, а у меня сейчас денюшек нет. Первую версию скачивала. Спасибо.
# Ответить
102. cleose 08.12.2013 00:21
Здравствуйте!
Если не трудно, пришли пожалуйста обработку на почту ir.maximum собачка yandex.ru.
Спасибо!
# Ответить
Внимание! За постинг в данном форуме $m не начисляются.
Внимание! Для написания сообщения необходимо авторизоваться
Текст сообщения*
Прикрепить файл