Перенос/копирование и установка отбора/периода при интерактивном переключении или смене варианта отчета/СКД в БСП 3.1 (1C ERP, УТ, БП, ...)

Публикация № 1362284

Разработка - Практика программирования

Пользователи ругаются - не хотят заново заполнять период, отборы при смене варианта отчета - в публикации с открытым кодом решим эту боль.

Все последние конфигурации 1С (БП 3.0, ЗУП, ERP, УТ 11, Розница, CRM, ...) используют в своей основе ту или иную версию Библиотеки Стандартных Подсистем (БСП, SSL). Это очень удобно и для разработчиков, и для 1С и для пользователей - везде плюс/минус одинаковый стандартный код, стандартное поведение системы. Мы тоже в 2019 году выпустили третью версию Кронос: WMS (интерфейс Такси, УФ, система управления складом), построенную на базе подсистем БСП. Однако, при её использовании наши пользователи заметили часть неудобств БСП, например - при переключении/смене между предопределенными вариантами отчетов (разный вид представления одной и той же информации) пользователю приходилось повторно указывать установленные им отборы или период. Логика 1С при разработке БСП нам понятна, но исходя из того, что для Кронос: WMS основной сценарий работы пользователя с программой другой - мы решили немного подкорректировать работу БСП и сделать приятное пользователям. 

Вот как в пользовательском режиме демонстрационной конфигурации БСП 3.1 это работает:

 

Итак,  приступим к реализации в Демонстрационной конфигурации "Библиотека стандартных подсистем", редакция 3.1 (3.1.4) , но описанное ниже будет верно и для БСП версий 2.4, 3.0.

При интерактивном нажатии на кнопку Ещё->Варианты отчета или кнопки: 

вызывается сначала процедура общей формы ФормаОтчета:

&НаКлиенте
Процедура Подключаемый_ЗагрузитьВариантОтчета(Команда)

а из неё уже процедура загрузки выбранного варианта:

ЗагрузитьВариант(ВариантФормы.КлючВарианта)

Вот собственно здесь и будем делать необходимые нам корректировки и правила.

 

Давайте, для начала в процедуру Подключаемый_ЗагрузитьВариантОтчета (БСП 3.1) встроим вопрос пользователю, хотел бы ли он, чтобы его настройки отчета (отбор или период, прочие параметры) перенеслись в выбранный вариант отчета:

	//заменим 
	//ЗагрузитьВариант(ВариантФормы.КлючВарианта);
	//на
	Оповещение = Новый ОписаниеОповещения("ЗакончитьЗагрузкуВарианта", ЭтотОбъект, ВариантФормы);		
	ПоказатьВопрос(Оповещение, "Перенести отбор/параметры в новый вариант отчета?", РежимДиалогаВопрос.ДаНет);

и напишем процедуру обработки оповещения:

&НаКлиенте
Процедура ЗакончитьЗагрузкуВарианта(Результат, ДополнительныеПараметры) экспорт
	
	ЗагрузитьВариант(ДополнительныеПараметры.КлючВарианта, (Результат=КодВозвратаДиалога.Да));
	
	КлючУникальности = ОтчетыКлиентСервер.КлючУникальности(НастройкиОтчета.ПолноеИмя, ДополнительныеПараметры.КлючВарианта);
	
	Если Элементы.ФормироватьСразу.Пометка Тогда
		ПодключитьОбработчикОжидания("Сформировать", 0.1, Истина);
	КонецЕсли;
	
КонецПроцедуры

После изменим объявление процедуры ЗагрузитьВариант(КлючВарианта, ПеренестиНастройки=Ложь) и запомним в её начале текущие настройки и пользовательские настройки компоновщика СКД: 

	ПредыдущиеНастройки = Отчет.КомпоновщикНастроек.Настройки;
	ПредыдущиеПользовательскиеНастройки = Отчет.КомпоновщикНастроек.ПользовательскиеНастройки;

 

А теперь самое интересное - нам необходимо перенести/скопировать/установить предыдущие настройки компоновщика СКД в новые установленные, после УстановитьТекущийВариант - сделаем мы это таким кодом:

	Если ПеренестиНастройки Тогда 
		
		ТекущиеНастройки = Отчет.КомпоновщикНастроек.Настройки;
		
		//перенесем отбор базовый	
		ПеренестиОтборДинамическогоСписка(ТекущиеНастройки.Отбор, ПредыдущиеНастройки.Отбор, Ложь);
		
		//перенесем отбор пользовательский
		Для Каждого Элемент Из ПредыдущиеПользовательскиеНастройки.Элементы Цикл
			
			ЭлементНастройки = Отчет.КомпоновщикНастроек.ПользовательскиеНастройки.Элементы.Найти(Элемент.ИдентификаторПользовательскойНастройки);
			
			Если ТипЗнч(ЭлементНастройки)=Тип("ЭлементОтбораКомпоновкиДанных") Тогда
				ЗаполнитьЗначенияСвойств(ЭлементНастройки, Элемент,, "ЛевоеЗначение, Представление, ПредставлениеПользовательскойНастройки, Родитель, Применение");					
			ИначеЕсли ТипЗнч(ЭлементНастройки)=Тип("ЗначениеПараметраНастроекКомпоновкиДанных") Тогда	
				ЗаполнитьЗначенияСвойств(ЭлементНастройки, Элемент,, "Параметр, ЗначенияВложенныхПараметров, ПредставлениеПользовательскойНастройки, Родитель");					
			КонецЕсли;
			
		КонецЦикла;	
		
		//обновим период на форме после загрузки предыдущих настроек
		ПараметрыОбновления = Новый Структура("ИмяСобытия", "ПриОбновленииСоставаПользовательскихНастроекНаСервере");
 		ОбновитьЭлементыФормыНастроекНаСервере(ПараметрыОбновления);

	КонецЕсли;

 

ПеренестиОтборДинамическогоСписка(ТекущиеНастройки.Отбор, ПредыдущиеНастройки.Отбор, Истина);

Если в сценарии работы Ваших отчетов НЕ требуется переносить/копировать отбор, который пользователь сам добавил в отчет (не включенные в пользовательские настройки), то вызвать процедуру ПеренестиОтборДинамическогоСписка нужно с Истина, если нужно все отборы переносить/копировать, то вызывать с Ложь.  Мы у себя используем Истина, т.к. те отборы, которые необходимо автоматически переносить/копировать, включены в пользовательские настройки, остальные мы автоматически не переносим/копируем даже при нажатии пользователем ДА: 

 

Сама процедура ПеренестиОтборДинамическогоСписка  достаточно простая - осуществляет перенос/копирование/установку отбора с Отбора-источник на Отбор-приемник, как в динамическом списке, так и в СКД. Причем, как было описано выше, бывает два варианта - либо только перенос (отбор устанавливается на уже существующие элементы отбора), либо полное копирование/установка отбора (добавляется в том, числе отбор, который отсутствует) в динамический список/СКД приемник. В нашей конфигурации Кронос: WMS мы много где используем копирование настроек, поэтому мы себе добавили процедуру в общий модуль:

&НаСервере
Процедура ПеренестиОтборДинамическогоСписка(ОтборПриемник, ОтборИсточник, ТолькоИзменение=Ложь) экспорт
	
	Для Каждого ЭлементИсточник Из ОтборИсточник.Элементы Цикл
		
		ИмяПоля = СокрЛП(ЭлементИсточник.ЛевоеЗначение);
		
		Если ПустаяСтрока(ИмяПоля) Тогда
			Продолжить;
		КонецЕсли;	
		
		Если ТолькоИзменение Тогда
			
			ОбщегоНазначенияКлиентСервер.ИзменитьЭлементыОтбора(
			ОтборПриемник,
			ИмяПоля, ЭлементИсточник.Представление,
			ЭлементИсточник.ПравоеЗначение,
			ЭлементИсточник.ВидСравнения,			
			ЭлементИсточник.Использование,
			ЭлементИсточник.РежимОтображения, ЭлементИсточник.ИдентификаторПользовательскойНастройки);
			
		Иначе
			
			ОбщегоНазначенияКлиентСервер.УстановитьЭлементОтбора(
			ОтборПриемник,
			ИмяПоля,
			ЭлементИсточник.ПравоеЗначение,
			ЭлементИсточник.ВидСравнения,
			ЭлементИсточник.Представление,
			ЭлементИсточник.Использование,
			ЭлементИсточник.РежимОтображения);
			
		КонецЕсли;

	КонецЦикла;	
	
КонецПроцедуры

 

Приведу целиком для БСП 3.1.4 получившуюся процедуру ЗагрузитьВариант с учетом корректировки:

&НаСервере
Процедура ЗагрузитьВариант(КлючВарианта, ПеренестиНастройки=Ложь)
	Если Не РежимРасшифровки И Не ВариантМодифицирован Тогда
		// Сохранение текущих пользовательских настроек.
		ОбщегоНазначения.ХранилищеСистемныхНастроекСохранить(
			НастройкиОтчета.ПолноеИмя + "/" + КлючТекущегоВарианта + "/ТекущиеПользовательскиеНастройки",
			"",
			Отчет.КомпоновщикНастроек.ПользовательскиеНастройки);
	КонецЕсли;
	
	//Добавлено: сохраним предыдущие настройки
	ПредыдущиеНастройки = Отчет.КомпоновщикНастроек.Настройки;
	ПредыдущиеПользовательскиеНастройки = Отчет.КомпоновщикНастроек.ПользовательскиеНастройки;
	//

	РежимРасшифровки = Ложь;
	ВариантМодифицирован = Ложь;
	ПользовательскиеНастройкиМодифицированы = Ложь;
	НастройкиОтчета.ПрочитатьФлажокФормироватьСразуИзПользовательскихНастроек = Истина;
	
	УстановитьТекущийВариант(КлючВарианта);

	//Добавлено: перенос настроек	
	Если ПеренестиНастройки Тогда 
		
		ТекущиеНастройки = Отчет.КомпоновщикНастроек.Настройки;
		
		//перенесем отбор базовый	
		ПеренестиОтборДинамическогоСписка(ТекущиеНастройки.Отбор, ПредыдущиеНастройки.Отбор, Ложь);
		
		//перенесем отбор пользовательский
		Для Каждого Элемент Из ПредыдущиеПользовательскиеНастройки.Элементы Цикл
			
			ЭлементНастройки = Отчет.КомпоновщикНастроек.ПользовательскиеНастройки.Элементы.Найти(Элемент.ИдентификаторПользовательскойНастройки);
			
			Если ТипЗнч(ЭлементНастройки)=Тип("ЭлементОтбораКомпоновкиДанных") Тогда
				ЗаполнитьЗначенияСвойств(ЭлементНастройки, Элемент,, "ЛевоеЗначение, Представление, ПредставлениеПользовательскойНастройки, Родитель, Применение");					
			ИначеЕсли ТипЗнч(ЭлементНастройки)=Тип("ЗначениеПараметраНастроекКомпоновкиДанных") Тогда	
				ЗаполнитьЗначенияСвойств(ЭлементНастройки, Элемент,, "Параметр, ЗначенияВложенныхПараметров, ПредставлениеПользовательскойНастройки, Родитель");					
			КонецЕсли;
			
		КонецЦикла;	
		
		//обновим период на форме после загрузки предыдущих настроек
		ПараметрыОбновления = Новый Структура("ИмяСобытия", "ПриОбновленииСоставаПользовательскихНастроекНаСервере");
 		ОбновитьЭлементыФормыНастроекНаСервере(ПараметрыОбновления);

	КонецЕсли;
    //

	ОтчетыКлиентСервер.ОтобразитьСостояниеОтчета(
		ЭтотОбъект,
		НСтр("ru = 'Выбран другой вариант отчета. Нажмите ""Сформировать"" для получения отчета.'"),
		БиблиотекаКартинок.Информация32);
КонецПроцедуры

 

Боль клиента решена, при смене варианта отчета в конфигурации на базе БСП задается вопрос о необходимости переноса отбора в выбранный вариант, отбор переносится, и пользователю не требуется вручную опять его устанавливать.  

 

Надеюсь, моя публикация была Вам полезна и сэкономит Ваше время, ссылка на все публикации SizovE

Подписывайтесь на мой канал (наверху), будет много интересного бесплатного контента :)

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Olenevod 26 31.01.21 15:36 Сейчас в теме
Полезная статья. Еще вот были случаи когда надо было формировать несколько вариантов отчетов сразу на разных вкладках с одинаковыми настройками. Эта статья облегчает процесс создания такого отчета.
2. SizovE 154 01.02.21 18:52 Сейчас в теме
(1) чтобы не ждать завершения формирования ? Кстати, да, хорошая мысль +
3. Olenevod 26 02.02.21 09:48 Сейчас в теме
(2) Не только. Просто например бухам нужно было анализировать данные в разных "проекциях". Их было пять и, например, пятый отчет уже использовал данные предыдущих отчетов, но с теми же отборами. Им проще переключаться по вкладкам по сформированным отчетам, чем каждый раз их формировать, да еще и настройки подкручивая на каждом.
4. SizovE 154 02.02.21 14:46 Сейчас в теме
(3) Т.е. им по сути нужно было, чтобы вариант отчета строился не в этой вкладке, а открывался в новой, иногда действительно удобно ) - хороший кейс.
Оставьте свое сообщение

См. также

Serverless (Faas) в 1С. Создание и вызов Yandex Cloud Functions Промо

Универсальные функции Практика программирования v8 Бесплатно (free)

"Я не могу просто взять и скопировать код с гитхаба", "у нас 1С микросервисами окружена", "возможностей мало" - частые фразы 1С разработчиков. которым не хватает возможностей платформы в современном мире. Faas, конечно, история не новая, но нас сдерживало 152ФЗ и задержки по пингам. Для того, чтобы действительно использовать в 1С код, к примеру, на Python, надо было приложить усилия. Теперь всё намного проще - берём и используем.

28.12.2020    4320    comol    22    

Базовые вещи БСП, которые облегчат жизнь программисту 1С

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Россия Бесплатно (free)

В данной публикации я опишу полезные процедуры и функции модуля общего назначения библиотеки стандартных подсистем, обязательные к использованию любым программистом 1С.

30.08.2020    10818    quazare    33    

Форма выбора (подбор) в управляемых формах

Практика программирования v8 v8::УФ 1cv8.cf Россия Бесплатно (free)

Разбор небольших примеров того, как правильно открывать форму выбора (подбора) в управляемых формах, не прибегая к модальным окнам.

08.05.2020    35325    user5300    16    

Полезные функции БСП (Часть 2)

БСП (Библиотека стандартных подсистем) v8 1cv8.cf Россия Бесплатно (free)

Список полезных функций из состава Библиотеки стандартных подсистем 3.1.

10.03.2020    14851    user5300    19    

Использование программных перечислений, ч.1: строковые константы Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Часто ли у вас возникает необходимость в коде выполнять сравнение на строку?

10.12.2016    38437    unichkin    74    

Программная работа с настройками СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Нюансы программной работы с настройками системы компоновки данных в отчетах и динамических списках. Обзор всех видов настроек компоновки. Что в каких случаях правильно применять. В качестве примера рассмотрена работа с отборами и группировками.

27.01.2020    38945    ids79    26    

[СКД] Программное создание схемы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Сделаем отчет на СКД полностью программно, без использования макета "схема компоновки данных".

15.01.2020    30435    John_d    22    

Последовательности событий при проведении документа 1С. Шпаргалка + про формы + про расширения

Практика программирования v8 Россия Бесплатно (free)

Собрал информацию о событиях/подписках/расширениях в одном месте.

30.12.2019    23156    kuzyara    38    

Вспомогательные инструкции в коде 1С Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    32034    tormozit    104    

30 задач. Странных и не очень

Практика программирования v8 Бесплатно (free)

30 задач на знание языка программирования 1С и некоторого поведения платформы. Маленьких. Странных и не очень.

02.12.2019    18788    YPermitin    60    

Как передать IP адрес, который вызвал HTTP запрос в 1C (для веб-сервера Apache)

Практика программирования v8 Бесплатно (free)

Столкнулся с задачей получения IP адреса, который вызывает http сервис 1С. Итак, решение:

22.11.2019    9827    Sibars    19    

Шпаргалка (БСП). Добавление в новый документ механизма печати дополнительных печатных форм

Печать БСП (Библиотека стандартных подсистем) v8 1cv8.cf Бесплатно (free)

Постоянно приходится вспоминать, как добавить механизм печати (БСП) в новый документ. Поэтому решил написать шпаргалку.

10.10.2019    21623    John_d    17    

Оформление и рефакторинг сложных логических выражений Промо

Практика программирования v8 Россия Бесплатно (free)

В сложных логических выражениях нередко самому автору спустя какое-то время тяжело разобраться, не говоря уже о других программистах. Предлагаемая методика позволяет повысить наглядность таких выражений путем оформления в виде И-ИЛИ дерева и одновременно выполнять их рефакторинг.

20.09.2012    79280    tormozit    131    

Полезные процедуры и функции для программиста

Практика программирования Универсальные функции v8 1cv8.cf Россия Бесплатно (free)

Все мы пишем программный код и часто используем процедуры, облегчающие его написание. Ниже приведена выборка таких полезных процедур и функций.

07.10.2019    33125    HostHost    41    

Таблица значений. Нюансы

Практика программирования v8 Бесплатно (free)

Обзор некоторых аспектов использования общеизвестного инструмента 1С.

01.10.2019    40063    Yashazz    50    

О программе Postman для тестирования API и для чего она нужна 1С-нику

Практика программирования Программное обеспечение (software) v8 Бесплатно (free)

Для чего нужна программа Postman для тестирования API и какая от него польза для 1С-программиста.

24.09.2019    14539    budidich    28    

Запись значения в поле ввода/формы со срабатыванием события ПриИзменении Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Иногда возникает необходимость после записи значения в какое либо поле ввода/формы вызвать для него обработчик события ПриИзменении, а о вызове самого события приходится только мечтать. В этой статье приводится программный способ вызова этого события.

11.07.2007    50036    tormozit    48    

[Шпаргалка] Программное создание элементов формы

Практика программирования Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Программное создание практически всех популярных элементов формы.

06.09.2019    66893    rpgshnik    68    

Агрегатные функции СКД, о которых мало кто знает

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    58101    ids79    55    

Регистры бухгалтерии. Общая информация

Практика программирования Математика и алгоритмы v8 v8::БУ БУ Бесплатно (free)

Общая информация о внутреннем устройстве регистров бухгалтерии.

05.09.2019    33158    YPermitin    24    

Как сделать из &НаКлиентеНаСервереБезКонтекста почти &НаКлиентеНаСервере Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Как сделать метод формы, доступный на клиенте и на сервере одновременно, и сохранить при этом удобство разработки

10.09.2017    46702    tormozit    74    

Три костыля. Сказ про фокусы в коде

Практика программирования v8 Бесплатно (free)

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    27037    YPermitin    80    

Отслеживание выполнения фонового задания

Практика программирования Универсальные функции Разработка v8 1cv8.cf Бесплатно (free)

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    35200    ids79    16    

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    106515    ids79    63    

Выгрузка документа по условию Промо

Практика программирования Разработка v8 Бесплатно (free)

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    16415    m-rv    2    

Фоновое выполнение кода в 1С - это просто

Практика программирования v8 1cv8.cf Бесплатно (free)

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    43837    avalakh    26    

Разбираемся с параметрами редактирования СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Связь по типу, Параметры выбора, Связи параметров выбора

31.07.2019    29098    json    15    

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    75661    ids79    14    

Как прикрутить ГУИД к регистру сведений Промо

Практика программирования Перенос данных из 1C8 в 1C8 Разработка v8 Бесплатно (free)

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    20946    m-rv    17    

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ

Инструментарий разработчика Практика программирования v8 v8::СКД Бесплатно (free)

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    39863    ids79    27    

Регистры сведений. За кулисами

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Небольшие заметки по внутреннему устройству регистров сведений.

09.07.2019    28309    YPermitin    14    

"Меньше копипаста!", или как Вася универсальную процедуру писал

Практика программирования Разработка v8 v8::СКД 1cv8.cf Бесплатно (free)

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    20399    SeiOkami    50    

Как сделать запрос на изменение данных Промо

Практика программирования v8 v8::Запросы 1cv8.cf Бесплатно (free)

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    32279    m-rv    21    

Работа с настройками системы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Варианты отчетов, работа с настройками вариантов: структура группировок, поля отчета, отборы, сортировка, условное оформление, другие настройки, настройки отображения диаграмм.

02.07.2019    58991    ids79    17    

Создание отчетов с помощью СКД - основные понятия и элементы

Практика программирования Математика и алгоритмы v8 v8::СКД Бесплатно (free)

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    60310    ids79    26    

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017

Практика программирования Производительность и оптимизация (HighLoad) v8 v8::Запросы Бесплатно (free)

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    27010    dmurk    146    

Метод формирования движений в типовых регистрах нетиповыми регистраторами Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    28836    itriot11    34    

Подсистема "Варианты отчетов". Используете ли Вы ее правильно?

Работа с интерфейсом БСП (Библиотека стандартных подсистем) v8 1cv8.cf Бесплатно (free)

Небольшая история про использование подсистемы "Варианты отчетов" из БСП. Используете ли Вы ее правильно?

04.06.2019    46719    YPermitin    52    

Подсистема БСП «Управление доступом», основные объекты и регистры

БСП (Библиотека стандартных подсистем) Роли и права v8 v8::УФ v8::Права 1cv8.cf Бесплатно (free)

Основные принципы работы подсистемы «Управление доступом» из состава БСП. Виды доступа, ограничение доступа на уровне записей. Описание основных объектов и регистров, используемых подсистемой.

23.05.2019    25400    ids79    9    

Регистры накопления. Структура хранения в базе данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    49547    YPermitin    30    

Использование классов .Net в 1С для новичков Промо

Практика программирования Разработка внешних компонент Универсальные функции v7.7 v8 Бесплатно (free)

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    78349    Serginio    113    

О расширениях замолвите слово...

Практика программирования Разработка v8 Бесплатно (free)

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    37810    ellavs    126    

Git-репозитории для 1С-кода (опыт использования при небольших проектах)

Практика программирования v8 Бесплатно (free)

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    28585    ellavs    90    

Трюки с внешними источниками данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    34446    YPermitin    53    

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С Промо

Математика и алгоритмы Практика программирования v8 v8::blocking 1cv8.cf Бесплатно (free)

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    37357    ids79    40    

Ошибки при работе с хранилищем конфигурации и способы их решения

Практика программирования v8 Бесплатно (free)

В статье собраны наиболее распространенные ошибки при работе с хранилищем конфигурации и способы их обхода и решения.

01.03.2019    48340    Смешной 1С    31    

Разработка и сценарное тестирование с Vanessa-ADD. Отчетность Allure. Автоматизация запуска сценариев

Практика программирования Vanessa Automation v8 Россия Бесплатно (free)

Формируем отчетность о результатах выполнения сценариев. Автоматизируем запуск.

26.02.2019    24112    Vladimir Litvinenko    28    

Тестер: частые вопросы Промо

Практика программирования v8 Бесплатно (free)

Ошибкам бой - тесты норма жизни!

25.07.2018    30121    grumagargler    31