Доначисление страховых взносов на обязательное страхование от НС и ПЗ в Бухгалтерии 7.7 и УСН 7.7 для Договора подряда

Публикация № 669684

Разработка - Практика программирования

подряд несчастный случай страховой взнос

Во всех источниках, которые мне встречались, написано, что Страховые взносы НС и ПФ нужно начислять, если это указано в Договоре подряда.

Во всех источниках , которые мне встречались, написано, что Страховые взносы НС и ПФ нужно начислять, если это указано в Договоре подряда. В конфигурациях 7.70.637 (бухгалтерия) и 7.70.279 (УСН) для договорников (Код НДФЛ 2010) эти взносы не начисляются. Но если все же нужно их начислить, то можно в конфигурации добавить новый документ. Экранная форма (на рисунке) достаточно простая.

В модуле формы нужно написать:


Перем ОбработчикСообщений;
Перем НачальнаяДатаДокумента;
Перем ДатаДокумента;
Перем Отказ;

//*****************************************************************************
// Проверка()
//
// Описание:
//  Проверяет является ли данный документ единственным документом НачислениеСтраховыхВзносовОтНСиПЗдляДоговоровПодряда
// в течение данного месяца.
//
Процедура Проверка(Отказ)
    
    Отказ=0;
    Если ДатаДокумента <> ДатаДок Тогда
        Дубликат = СоздатьОбъект("Документ.НачислениеСтраховыхВзносовОтНСиПЗдляДоговоровПодряда");
        Если (Дубликат.ВыбратьДокументы(НачМесяца(ДатаДок),КонМесяца(ДатаДок))=1) И (Дубликат<>ТекущийДокумент())Тогда
            Предупреждение("За "+Формат(ДатаДок,"Д ММММГГГГ")+" страховой взнос рассчитывался
            |документом """+Дубликат+" от "+ДатаДок+""";
            |Для расчета следует использовать этот документ.");
            Отказ=1;
        КонецЕсли;
        ДатаДокумента = ДатаДок;
    КонецЕсли;
    
КонецПроцедуры // Проверка()

////////////////////////////////////////////////////////////////////////////////
// ПРОЦЕДУРЫ И ФУНКЦИИ, ВЫЗЫВАЕМЫЕ ИЗ ФОРМУЛ ЭЛЕМЕНТОВ ДИАЛОГА
//

//*****************************************************************************
// ПриИзмененииДаты()
//
// Вызывается из формул элементов диалога:
//  Поле ввода ДатаДок.
//
Процедура ПриИзмененииДатаДок()
    
    ДатаДок = КонМесяца(ДатаДок);
    Проверка(Отказ);
    Если Отказ=1 Тогда
        Возврат;
    КонецЕсли;
    
КонецПроцедуры // ПриИзмененииДаты()

//******************************************************************************
// Заполнить()
Процедура Заполнить()  
    
    Если КоличествоСтрок()>0 Тогда
        Если Вопрос("Перед заполнением таблица документа будет очищена. Продолжить?","Да+Нет")="Нет" Тогда
            Возврат;
        КонецЕсли;
        
        УдалитьСтроки();
    КонецЕсли;

    Начисления=СоздатьОбъект("Документ.НачислениеЗП");
    Начисления.ВыбратьДокументы(НачМесяца(ДатаДок), КонМесяца(ДатаДок));
    Пока Начисления.ПолучитьДокумент()=1 Цикл
        Если (Начисления.Проведен()=1) И (Начисления.ВидНачисления.ВидДохода.Код="2010") Тогда
            Начисления.Выбратьстроки();
            Пока Начисления.ПолучитьСтроку()=1 Цикл
                НоваяСтрока();
                Сотрудник=Начисления.Сотрудник;
                Сумма=Начисления.Оклад;
                Документ=Начисления.ТекущийДокумент();
            КонецЦикла;
        КонецЕсли;
    КонецЦикла;
    
КонецПроцедуры 

//****************************************************************************** 
//Вызывается из формулы элемента диалога "Сотудник"

Процедура ПриВыбореСотрудника()
    
    Начисления=СоздатьОбъект("Документ.НачислениеЗП");
    Начисления.ВыбратьДокументы(НачМесяца(ДатаДок), КонМесяца(ДатаДок));
    Пока Начисления.ПолучитьДокумент()=1 Цикл
        Если (Начисления.Проведен()=1) И (Начисления.ВидНачисления.ВидДохода.Код="2010") Тогда
            Начисления.Выбратьстроки();
            Пока Начисления.ПолучитьСтроку()=1 Цикл
                Если Начисления.Сотрудник=Сотрудник Тогда
                    Сумма=Начисления.Оклад;
                    Документ=Начисления.ТекущийДокумент();
                КонецЕсли;
            КонецЦикла;
        КонецЕсли;
    КонецЦикла;
    
КонецПроцедуры

//******************************************************************************
//    ПровестиИзФормы(НажатаКнопкаОК=0)
//
//    Параметры:
//        НажатаКнопкаОК - число, 1 - нажали кнопку ОК, 0 - нажали кнопку провести
//
//    Вызывается из формул элементов диалога:
//        Провести, ОК
//
//    Описание:
//        Записывает и проводит документ
//
Процедура ПровестиИзФормы(НажатаКнопкаОК=0) 
    
    ПриЗаписиПерепроводить(0);
    Записать();
    ПриЗаписиПерепроводить(1);            
    Если Провести(,ОбработчикСообщений)=0 Тогда
        глДобавитьСообщение(ОбработчикСообщений, "Документ не проведен.",ТекущийДокумент());
    КонецЕсли;
    
КонецПроцедуры // ПровестиИзФормы()

//******************************************************************************
// Предопределенная процедура
//
Процедура ВводНового() 
    
    ДатаДок = КонМесяца(РабочаяДата());
    ДатаДокумента = Дата(0);
    Проверка(Отказ);

КонецПроцедуры

//******************************************************************************
//    Предопределенная процедура
//
Процедура ПриОткрытии()
    
       НачальнаяДатаДокумента = ДатаДок;
    
КонецПроцедуры    // ПриОткрытии 

 

а в модуле документа:

 

//******************************************************************************
//
Процедура ОбработкаПроведения(ОбработчикСообщений)
	
	Сч69_11     = СчетПоКоду("69.11");

//	Операция.Содержание = СодержаниеОперации;
	ФСС_НС = глПолучитьНалог("ФСС_НС");
	СчФСС_НС = ФСС_НС.Счет;
	СубФСС_НС_1 = ФСС_НС.Субконто1;
	СтФССотНС = ФСС_НС.Ставка.Получить(КонМесяца(ДатаДок));

	ВыбратьСтроки();
	Пока ПолучитьСтроку() = 1 Цикл
		
		Если (Документ.ДатаДок < НачМесяца(ДатаДок)) ИЛИ (Документ.ДатаДок > КонМесяца(ДатаДок)) Тогда
			
			Сообщить("В строке "+НомерСтроки+" документ начисления не входит в рассматриваемый период","!!!"); 
			Сообщить("Документ не проводится","!!!"); 
			Возврат;
			
		КонецЕсли;
		
		Если Документ.ИспользоватьСчетДокумента = 1 Тогда
			СчетДебета = Документ.СчетЗатрат;
		Иначе
		    СчетДебета = Сотрудник.СчетЗатрат.Получить(КонМесяца(ДатаДок));
		КонецЕсли;
		
        Если ПустоеЗначение(СчетДебета) = 1 Тогда
			Если Документ.ИспользоватьСчетДокумента = 1 Тогда
				ТекстСообщения = "Не выбран счет отнесения затрат";
				глСообщениеПроведения(ТекстСообщения, ТекущийДокумент(), 1);
				глНеПроводить(ТекущийДокумент());
				
			Иначе
				ТекстСообщения = "Не выбран счет отнесения затрат для сотрудника "+Сотрудник;
				глСообщениеПроведения(ТекстСообщения, ТекущийДокумент(), 1,, Сотрудник);
				глНеПроводить(ТекущийДокумент());
			КонецЕсли;
			Возврат;
		КонецЕсли;
		
 		// Дт <Счет учета затрат> Кт 69.11
		Если Сумма <> 0 Тогда
			Операция.НоваяПроводка();
			Операция.НомерЖурнала = "ЗП";
			Операция.СодержаниеПроводки = "Начислено НС и ПЗ";
			Операция.Дебет.Счет = СчетДебета;
			Если Документ.ИспользоватьСчетДокумента = 1 Тогда
				Операция.Дебет.Субконто(1, Документ.Субконто1);
				Операция.Дебет.Субконто(2, Документ.Субконто2);
				Операция.Дебет.Субконто(3, Документ.Субконто3);
			Иначе
				Операция.Дебет.Субконто(1, Сотрудник.Субконто1.Получить(КонМесяца(ДатаДок)));
				Операция.Дебет.Субконто(2, Сотрудник.Субконто2.Получить(КонМесяца(ДатаДок)));
				Операция.Дебет.Субконто(3, Сотрудник.Субконто3.Получить(КонМесяца(ДатаДок)));
			КонецЕсли;
			Операция.Кредит.Счет = Сч69_11;
			Операция.Кредит.Субконто(1, СубФСС_НС_1);
			Операция.Сумма = Окр(Сумма * СтФССотНС/100,2,1);
		КонецЕсли;
	КонецЦикла;
	
	Операция.Записать();
	
	ТекстСообщения = "Документ проведен.";
	глСообщениеПроведения(ТекстСообщения, ТекущийДокумент(), 0);
	глПриПроведении(ТекущийДокумент());

КонецПроцедуры // ОбработкаПроведения

Документ формируется не чаще, чем один раз в месяц. По кнопке Заполнить табличная часть заполняется всеми начислениями сотрудников за месяц, у которых код по НДФЛ равен 2010 (Выплаты по договорам гражданско-правового характера (за исключ. авторских)). Табличную часть можно отредактировать.

Результатом проведения документа будут сформированные проводки Дт <Счет затрат>  Кт  <Счет ФСС_НС>  <Сумма проводки>, где Счет затрат получается из соответствующего документа начисления, Счет ФСС_НС - счет Расчетов по обязательному социальному страхованию от несчастных случаев на производстве и профессиональных заболеваний, а Сумма проводки вычисляется, как начисленная сумма, умноженная на Ставку ФСС НС и ПЗ.                            

Специальные предложения

Оставьте свое сообщение

См. также

Использование классов .Net в 1С для новичков Промо

Практика программирования Разработка внешних компонент Универсальные функции v7.7 v8 Бесплатно (free)

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    77178    Serginio    110    

Маркировка лекарств - как передать код маркировки при продаже через ККТ Штрих-М

Практика программирования ККМ v7.7 Здравоохранение, медицина, стоматология Фармацевтика, аптеки Россия Бесплатно (free)

Пример программного кода для вывода чеков на ККМ Штрих-М с передачей информации о маркированных товарах (лекарства).

10.02.2020    8712    vovaapril    27    

[ПОЛЕЗНЯШКА, 7.7] Как посчитать итоги по документам черным запросом с изподвывертом?

Практика программирования v7.7 1cv7.md Бесплатно (free)

Мелкая полезняшка, считает запросом итоговую сумму документов и количество документов.

12.03.2016    19189    CheBurator    18    

.Net в 1С. На примере использования HTTPClient, AngleSharp. Удобный парсинг сайтов с помощью библиотеки AngleSharp, в том числе с авторизацией аля JQuery с использованием CSS селекторов. Динамическая компиляция

Практика программирования WEB v7.7 v8 Бесплатно (free)

Часто приходится парсить сайты, в том числе с авторизацией, перескакивая со страницы на страницу по ссылкам. Тот, кто занимался вэб программированием, знает, как удобно использовать JQuery и CSS селекторы. На .Net написана очень удобная библиотека AngleSharp. Я покажу, как с её помощью можно значительно облегчить себе труд.

10.03.2016    56134    Serginio    33    

1С:Предприятие 7.7. Оптимизация. Промо

Практика программирования v7.7 1cv7.md Россия Бесплатно (free)

Разгоняем 1С:Предприятие 7.7. Выжимаем последние соки.

31.01.2009    47053    alexk-is    110    

.Net в 1С. Асинхронные HTTP запросы, отправка Post нескольких файлов multipart/form-data, сжатие трафика с использованием gzip, deflate, удобный парсинг сайтов и т.д.

Разработка внешних компонент Практика программирования WEB v7.7 v8 Бесплатно (free)

Очень часто нужно при работе с HTTP сервисами или сайтами использовать Асинхронные HTTP запросы, отправку на сервер нескольких файлов, использование сжатия трафика. Эта статья про то, как этого легко добиться.

09.03.2016    31950    Serginio    22    

Пример HTTP запроса к УТМ ЕГАИС на платформе 1С 7.7

Внешние источники данных Практика программирования Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v7.7 1cv7.md Россия Бесплатно (free)

Запрос реализован на объекте ServerXMLHTTP из встроенной в Windows библиотеки MSXML, результатом запроса является XML объект DOMDocument из той же библиотеки MSXML со встроенным интерфейсом его обработки

16.12.2015    25492    Palmer1976    3    

Экспорт нескольких MXL таблиц в один XLS файл, на отдельные листы. Простой алгоритм

Загрузка и выгрузка в Excel Практика программирования v7.7 v8 Бесплатно (free)

Статья посвящена распространённому вопросу - как сохранить несколько таблиц (отчетов) в формате MXL, с которым работает 1С, на отдельные листы одного Excel файла. Освещается простой алгоритм решения проблемы штатными средствами, без использования внешних модулей и библиотек (не относящихся к 1С и Excel).

23.11.2015    17490    etmarket    14    

Как уменьшить количество заблокированных объектов Промо

Практика программирования v7.7 1cv7.md Россия Бесплатно (free)

История о том как я решил пересобрать форму справочника клиентов и чем это все закончилось...

12.01.2012    15610    ShEvOvIcH    18    

Процедура расшифровки ячейки таблицы в отчетах 1С 7.7

Практика программирования Универсальные функции v7.7 1cv7.md Бесплатно (free)

Хочу поделиться с вами универсальной процедурой для расшифровки ячеек печатной формы отчетов в 1С 7.7.

24.09.2015    17798    Anzhey    14    

Универсальный способ сравнения таблиц

Практика программирования v7.7 v8 Бесплатно (free)

На эту тему уже есть статьи, но этот способ нигде не описан. Хотя я его использую с тех пор, как занимаюсь программированием. Его преимущество в простоте и универсальности: можно применять на 1С, SQL, а также в любом другом языке программирования.

05.07.2015    19206    json    1    

Числа прописью в родительном падеже в 7.7? Легко!

Практика программирования v7.7 1cv7.md Бесплатно (free)

Вывод числительных прописью в родительном падеже штатными средствами в три строчки кода.

20.06.2015    12816    gimalaj    3    

Технология обновления нетиповых конфигураций 1С:Предприятия 7.7 Промо

Практика программирования Администрирование данных 1С v7.7 1cv7.md Россия Бесплатно (free)

Данная статья рассчитана на уже подготовленного пользователя, владеющего некоторыми навыками программирования и работы в конфигураторе. Статью можно использовать как поэтапное руководство к действию. Статья была написана для повышения качества работ выполняемых сотрудниками компании Информ Сервис при обновлении нетиповых конфигураций. Я надеюсь, что эта информация окажется полезной и для вас.

12.12.2008    63004    alexk-is    25    

Хитрости сохранения табличного документа в Excel для дальнейшей работы с ним

Загрузка и выгрузка в Excel Практика программирования v7.7 v8 1cv8.cf 1cv7.md Бесплатно (free)

Все пользователи 1С всех версий (начиная с 7-й) сталкиваются с проблемой нормальной работы с данными, сохраненными в Excel файл. Есть некоторые хитрости, которые позволяют облегчить работу с сохраненными данными из 1С в формат Excel.

16.01.2015    91408    shmellevich    38    

Записки на память. Зарплата и кадры 1С 7.7 (ЗиК 7.7 )

Бухгалтерский учет Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v77::Расчет 1С7:ЗиК Россия БУ НУ УУ Бесплатно (free)

ЗиК 7.7 постепенно сходит на нет. Но, возможно, кому-то из нас все-таки когда-либо еще не раз придется столкнуться с этой конфигурацией. Поскольку работы по ней и заказов всё меньше и меньше, знания о ней и опыт постепенно угасают. Мой опыт с ЗиК 7.7 длиной в 14 лет терять просто так неохота. В этой статье я запишу, чтобы не забыть, важные моменты об этой конфигурации, чтобы самому не забыть, и вдруг кто-то получит это в наследство на сопровождение и будет вынужден (иначе не скажешь) это обслуживать. Или еще можно рассматривать эту статью как модное нынче «Письмо самому себе в прошлое».

18.11.2014    40210    Lapitskiy    26    

ЗаполнитьЗначенияСвойств - заставляем работать в 7.7

Практика программирования v7.7 1cv7.md Бесплатно (free)

Если вы используете в работе 1С:Предприятие 8.х, то наверняка знакомы и с замечательной системной процедурой, как ЗаполнитьЗначенияСвойств(). Ее использование помогает значительно упростить написание программного кода в ряде случае, делает его (код) более наглядным и простым. Но что же делать тем, кто до сих пор использует (постоянно или иногда) 1С:Предприятие 7.7?

24.07.2014    22180    tomvlad    5    

Ошибка заполнения отчета о движении денежных средств за 2012г (RP12Q4 12q4004)

Практика программирования v77::БУ 1С7:Бух Россия Бесплатно (free)

Ошибка заполнения отчета движения денежных средств за 2012г (RP12Q4 12q4004)

13.03.2013    9360    Famza    5    

Конвертация данных 2.1 (2.1.3.1) 1С 7.7 - 1С 8.Х передача параметра ПКО

Практика программирования Перенос данных из 1С7.7 в 1C8.X v7.7 v8 КД Бесплатно (free)

Передача параметров по умолчанию доступна только для баз 1С 8.х -1С 8.х. Показан пример, как передать параметры из 1С 7.7 - 1С 8.х

10.12.2012    25507    serg_gres    6    

Скрытие помеченных на удаление в справочнике

Практика программирования v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free)

Корректно скрываем помеченных на удаление в справочнике, с иерархией и без. Вроде простая и нужная вещь, но почему-то нигде не встречалась

08.08.2012    13909    mikukrnet    7    

Исправление и проведение документов

Практика программирования v77::БУ 1С7:ПУБ Россия Бесплатно (free)

Исправление и проведение документов, например, счетов-фактур, введенных на основании документов реализации, можно организовать многими способами. Описан сравнительно простой подход, реализованный и работающий несколько лет в реальной бухгалтерии 1Cv7.7. Без внешних компонентов.

23.07.2012    13511    BorisBelov    11    

Динамическая фильтрация в справочнике при вводе наименования

Практика программирования v7.7 1cv7.md Россия Бесплатно (free)

Позволяет в открытой форме списка, выбора или подбора справочника производить динамическую фильтрацию по набранному наименованию.

02.07.2012    16424    maxpiter    62    

Ввод остатков по 76.ВА в 1С ПУБ

Практика программирования v77::ОУ v77::БУ 1С7:ПУБ Россия БУ Бесплатно (free)

Статья посвящена найденному мной недостатку в конфигурации 1С 7.7 "Производство-услуги-бухгалтерия", связанному с вводом начальных остатков по 76.ВА.

29.04.2012    10062    Пользователь 1С    0    

Обновление базы 1с 7.7. с помощью движка 1с 8.х

Практика программирования Администрирование данных 1С v7.7 1cv7.md Россия Бесплатно (free)

Если Вас угораздило в стандартную типовую конфу внести правки, причем в самый большой модуль, а именно глобальный. Если к тому же Вы внесли изменение в какую-то стандартную функцию, в которой 1с сама регулярно чего-то меняет, то любое обновление начинает доставать. Используя возможности движка платформы 1с 8.х можно существенно сэкономить себе время и нервы.

28.04.2012    18686    Valerich    31    

Ошибка при формировании отчета Авансы по налогу на имущество. В 1С:Предприятие 7.7. Регламентированная отчетность за I квартал 2012 года Обновление 12q1009 от 18.04.2012 г.

Практика программирования v77::ОУ v77::БУ 1cv7.md Россия Бесплатно (free)

При формировании отчета NIMAVP1.ERT Авансы по налогу на имущество (версия 5.03) в разделе № 1-3 не сохраняет номера Страниц при выборе, что ведет к не сохранению и выводу печати двухмерного кода.

24.04.2012    9383    leo072    7    

Ошибка при формировании отчета 4-ФСС для УСН 7,7 12q1007

Практика программирования v77::БУ 1С7:Бух Россия НУ Бесплатно (free)

При формировании таблицы 6,7 раздела 2 возникает ошибка ИтАн.ИспользоватьСубконто(ВидыСубконто.ВидыПлатежейВФонды, Перечисление.ВидыПлатежей.Штраф); {C:\PROGRAM FILES\1CV77\SSTDEMO\EXTFORMS\RP12Q1.GRP\FSS4_1212.ERT(2330)}: Поле агрегатного объекта не обнаружено (ВидыПлатежейВФонды)

11.04.2012    11363    *Zed*    1    

Запуск внешней обработки по расписанию v7.7

Практика программирования Администрирование данных 1С v7.7 1cv7.md Россия Бесплатно (free)

Неоднократно возникали задачи организовать, например ежедневную выгрузку и отправку отчетов по эл.почте, и вот…

20.03.2012    44424    Yury1001    17    

ЗиК 321, в отчетах пропадает проводка по ПФР_страховая

Практика программирования v77::ОУ v77::Расчет 1С7:ЗиК Россия ФОМС, ПФ, ФСС Бесплатно (free)

При формировании отчета "Свод проводок" с галкой "Учет начисления налогов с ФОТ, включаемых в состав расходов" в отчет не выходит ПФР_страх

10.02.2012    6892    filh    19    

Бухгалтерия 7.7. Релиз 535. Некорректности (ошибки) при вступлении в силу постановления 1137. Релиз 536 вышел

Практика программирования v77::БУ 1С7:Бух Россия БУ Бесплатно (free)

При обновлении на 535 релиз обнаружил некорректность в документах поступления.

06.02.2012    8872    Famza    19    

Ошибка в 1С:Бух77 ред.533 Начисление ФФОМС при ЕНВД

Практика программирования Зарплата Зарплата v77::БУ 1С7:Бух Россия Бесплатно (free)

При начислении налогов с ФОТ (док.ЗакрытиеМесяца) не расчитываются налоги ФФОМС, если начисление зарплаты проводится как "облагаемые ЕНВД".

22.01.2012    10305    lelbraun    3    

Медленное формирование отчета в ФСС. Ошибка в алгоритме файл: ESN_GET.ERT

Практика программирования v77::БУ 1С7:Бух Россия Бесплатно (free)

Достаточно старая ошибка 1С (исправляю уже пару лет) в файле ESN_GET.ERT (1С7.7 бухгалтерский учет). Проявляется в том, что очень медленно формируются регламентные отчеты в фонды ФСС и ПФР, если в типовой бухгалтерии ведётся начисление зарплаты сотрудникам и количество сотрудников превышает определённое количество (в моём примере 90, но замедление скорости видно и на 20)

11.01.2012    7478    Digo65    2    

Ошибка в обработке "ПодборЗатратПоУслугам" в типовой Бухгалтерии для бюджетных учреждений 6.2 (647)

Практика программирования v77::БУ 1С7:ББУ Государственные, бюджетные структуры Россия Бесплатно (free)

В текущем на момент публикации релизе 647 конфигурации "Бухгалтерия для бюджетных учреждений 6.2" при заполнении документа "Списание затрат по услугам" наблюдается следующая ошибка: в режиме заполнения (F5) невозможно выбрать значение субконто, если тип субконто - подчиненный справочник.

30.12.2011    10260    demon_infernal    1    

Как заполнить справку 2-НДФЛ в Бухгалтерии 7.7?

Справки Зарплата Зарплата v77::БУ 1С7:Бух Россия БУ НДФЛ Бесплатно (free)

Многие при попытке сформировать справку 2 НДФЛ сталкиваются с ошибкой «Данных о доходах за 2011 год не обнаружено»

12.12.2011    35619    Myst_    18    

Прямые запросы: ускорение получения цен для типовой ТиС 7.7

Практика программирования Разработка внешних компонент v77::ОУ 1С7:Комплекс 1С7:ТиС Россия Бесплатно (free)

Первая статья из цикла статей "Прямые запросы:...". Рассказывается о применении класса ПрямойЗапрос и компоненты 1С++ для ускорения функции глВернутьЦену() в типовой конфигурации Торговля и склад. Платформа 7.7.

15.11.2011    15661    leshik    21    

1С:Торговля и Склад - ошибка во всех релизах, При использовании нескольких фирм и префиксов номеров документов.

Практика программирования v77::ОУ 1С7:ТиС Россия Бесплатно (free)

Собственно сегодня обнаружил ошибку, которая присутствует во всех релизах конфигурации Торговля и Склад 7.7 вплоть до текущего 7.70.969, при использовании нескольких фирм и префиксов документов для некоторых из них.

04.11.2011    15663    twilight5023    8    

Перерасчет ФСС НС за предыдущий период в ЗиК 315

Адаптация типовых решений Зарплата Зарплата v77::Расчет 1С7:ЗиК Россия БУ ФОМС, ПФ, ФСС Бесплатно (free)

Если изменить базу вида расчета «ФСС НС», то в релизе 1С:Зарплата и Кадры 7.70.315, в текущем расчетном периоде не происходит перерасчет за предыдущие периоды.

02.11.2011    17715    Nicholas    13    

Функция проверки валидности e-mail с использованием регулярных выражений RegExp (7.7)

Практика программирования openconf v77::БУ 1cv7.md Россия Бесплатно (free)

Функция проверки валидности e-mail с использованием регулярных выражений RegExp (7.7). Данную функцию можно вставить в Глобальный модуль и пользоваться, например, при вводе или сохранении e-mail.

30.10.2011    11122    zaursoft    11    

Ошибка при формировании Отчета по налогу на прибыль за 9 месяцев 2011 г. (версия 11q300x) для Бухгалтерии 7.7

Регламентированная отчетность Практика программирования v77::БУ 1С7:Бух Россия Налог на прибыль Бесплатно (free)

При формировании Отчета по налогу на прибыль из конфигурации Бухгалтерский учет - Регламентированная отчетность за 9 месяцев 2011 года (версия 11q3002/11q3003/11q3004) - неправильно формируются суммы ежемесячных авансовых платежей в бюджет субъекта Российской Федерации для организаций, имеющих обособленные подразделения (подраздел 1.2 раздела 1 ОСН, строки 220-240)

28.10.2011    13488    vkr    5    

Компенсация отпуска, оплата дней доноров и оплата льготных дней родителей в ЗиК

Практика программирования Зарплата Зарплата v77::Расчет 1cv7.md 1С7:ЗиК Россия Бесплатно (free)

"Компенсация отпуска"," Оплата дней доноров" и "Оплата льготных дней родителей" - эти виды расчетов должны облагаться страховыми взносами с 01.01.2011 года.

04.10.2011    9294    maxim305    18    

7.7.: Готовим md-файл для публикации. В картинках.

Практика программирования v7.7 1cv7.md Россия Бесплатно (free)

Вы доработали типовую конфигурацию: скажем, добавили новый Документ, и хотите им поделиться с обществом ИС. Но нельзя же выложить МД-шник целиком, это будет нарушением правил. И как тут быть?

14.09.2011    17456    Арчибальд    21