Районный коэффициент на премию текущего месяца уволенным сотрудникам в предыдущем месяце

26.05.11

Разработка - Механизмы типовых конфигураций

Смотрел много информации в интернете, а именно по такой ситуации:

У нас в организации премия(процентом) начисляется месям позже, но есть такие случаии что человек уволился, а премию необходимо ему выплатить в следующем месяце за предыдущий, с этим проблем нет создаем документ Начисление премии и вперед, но на него также необходимо расчитать районный коэффициент и НДФЛ, что не возможно сделать штатными средствами, т.к. человек уже уволенный и приходилось вручную всем начислять районник и НДФЛ.

Соответственно было много советов, но ни один из них не подходил, пришлось дописывать конфигурацию, а именно для того чтобы все работало необходимо сделать в Документе "НачислениеЗарплатыРаботникамОрганизаций" новую кнопку, в моем случае я ее назвал "Заполнить уволенных", в действие кнопки необходимо добавить модуль:

 

Процедура Заполнить_уволенныхНажатие(Элемент)

//очищает список перед заполнением с предупреждением

Если Начисления.Количество()>0

ИЛИ ДополнительныеНачисления.Количество()>0

ИЛИ ДоговорыНаВыполнениеРабот.Количество()>0

ИЛИ НДФЛ.Количество()>0

ИЛИ ПогашениеЗаймов.Количество()>0 

ИЛИ Удержания.Количество()>0 Тогда

ТекстВопроса = "Все таблицы документа будут очищены. Продолжить?";

Ответ = Вопрос(ТекстВопроса, РежимДиалогаВопрос.ДаНет, , КодВозвратаДиалога.Да,);

Если Ответ <> КодВозвратаДиалога.Да Тогда

Возврат;

КонецЕсли;

Начисления.Очистить();

ДополнительныеНачисления.Очистить();

ДоговорыНаВыполнениеРабот.Очистить();

Удержания.Очистить();

НДФЛ.Очистить();

ПогашениеЗаймов.Очистить();

КонецЕсли;

ЭлементыФормы.ТабличноеПолеРасчетногоЛистка.Очистить();

мТекущееФизлицо = Справочники.ФизическиеЛица.ПустаяСсылка();

мТекущийСотрудник = Справочники.СотрудникиОрганизаций.ПустаяСсылка();

//выбор уволенных сотрудников из регистра сведений

Запрос = Новый Запрос;

    Запрос.Текст = 

"ВЫБРАТЬ

    |    СписокУволенных.Сотрудник,

    |    СписокУволенных.ПричинаИзмененияСостоянияЗавершения КАК Пр

    |ИЗ

    |    РегистрСведений.РаботникиОрганизаций.СрезПоследних(&Конец,) КАК СписокУволенных

|ГДЕ

| ПричинаИзмененияСостояния = ЗНАЧЕНИЕ(Перечисление.ПричиныИзмененияСостояния.Увольнение) И

| Период>=&Начало и Период<=&Конец";

ДатаНач=Дата(Год(ПериодНачисленияДатаНачала),Месяц(ПериодНачисленияДатаНачала)-1,1);

Запрос.УстановитьПараметр("Начало",ДатаНач);

Запрос.УстановитьПараметр("Конец",КонецМесяца(ДатаНач)+1);

Запрос.УстановитьПараметр("Причина",Перечисления.ПричиныИзмененияСостояния.Увольнение);

Рез = Запрос.Выполнить().Выбрать();

//заполнение таблицы начисления

Пока Рез.Следующий() Цикл

//выбор сумм по физлицам и характеру взаиморасчета из регистра накоплений

Запрос = Новый Запрос;

    Запрос.Текст =

"ВЫБРАТЬ РАЗРЕШЕННЫЕ

    |   Премии.Физлицо,

    |   СУММА(Премии.СуммаВзаиморасчетов) КАК Начислено

    |ИЗ

    |   РегистрНакопления.ЗарплатаЗаМесяцОрганизаций КАК Премии

|ГДЕ

    |    Премии.ПериодВзаиморасчетов >= &ДатаНачала И Премии.ПериодВзаиморасчетов <= &ДатаКонца

|    И Премии.ФизЛицо =&ФизЛ

    |    И Премии.СуммаВзаиморасчетов <> 0

    |    И Премии.Организация = &Организация

| И Премии.ХарактерВыплаты = &Хар

    |СГРУППИРОВАТЬ ПО

    |    Премии.Физлицо";

Запрос.УстановитьПараметр("Организация",Справочники.Организации.НайтиПоКоду("000000001"));

Запрос.УстановитьПараметр("ФизЛ",Рез.Сотрудник.ФизЛицо);

Запрос.УстановитьПараметр("ДатаНачала",ПериодНачисленияДатаНачала);

Запрос.УстановитьПараметр("ДатаКонца",ПериодНачисленияДатаОкончания);

Запрос.УстановитьПараметр("Хар",Перечисления.ХарактерВыплатыЗарплаты.Премии);

Пр = Запрос.Выполнить().Выбрать();

//заполнение таблицы начисления

Пока Пр.Следующий() Цикл

НоваяСтрока=Начисления.Добавить();

НоваяСтрока.Сотрудник=Рез.Сотрудник;

НоваяСтрока.ВидРасчета=ПланыВидовРасчета.ОсновныеНачисленияОрганизаций.НайтиПоКоду("00150");

НоваяСтрока.ПодразделениеОрганизации=Рез.Сотрудник.ТекущееПодразделениеОрганизации;

НоваяСтрока.Показатель1=25;

   НоваяСтрока.Результат=Пр.Начислено*0.25;

НоваяСтрока.ДатаНачала=ПериодНачисленияДатаНачала;

НоваяСтрока.ДатаОкончания=ПериодНачисленияДатаОкончания;

НоваяСтрока.ДатаНачалаСобытия=ПериодНачисленияДатаНачала;

мТекущееФизЛицо=Рез.Сотрудник.ФизЛицо;

РассчитатьРаботника(Ложь);

НоваяСтрока.Авторасчет=1;

КонецЦикла;

КонецЦикла;

КонецПроцедуры

И все, теперь документ будет брать людей уволенных за предыдущий месяц, но в документе необходимо указывать дату текущую, т.е. если сотрудник уволился в ноябре, то в документе необходимо указывать декабрь. 
Также процедура автоматически расчитывает НДФЛ.

 

См. также

Ценовая власть. Выносим из цикла схему СКД

Механизмы типовых конфигураций Ценообразование, анализ цен Программист Пользователь Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 Россия Абонемент ($m)

Продолжение темы вынесения кусков повторно-используемого кода в запрос. В прошлый раз мы сделали это с вычислением пользовательских формул. Здесь замахнулись на формулы, задаваемые пользователем запросами.

1 стартмани

11.04.2024    641    tango    1    

3

Формула в реквизите. Приквелл к сериалу "Ценовая власть"

Механизмы типовых конфигураций Программист Платформа 1С v8.3 1С:Управление торговлей 11 Россия Абонемент ($m)

Какому-либо элементу списка сопоставляется числовое значение, зависящее от других значений, причем эта зависимость изменяется от элемента к элементу. Так, в справочнике "Валюты" курс какой-либо валюты может быть задан формулой (или даже запросом) от значения другой валюты. А в справочнике "Виды цен" формула определяет расчет цены для товарной позиции, т.е. элементов справочника "Номенклатура", у которых в карточке указан этот вид цены. А в 1С:ERP, например, этот механизм используется в ресурсной спецификации.

10 стартмани

11.04.2024    500    tango    5    

4

Ценовая власть. Второй сезон

Механизмы типовых конфигураций Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 Россия Бесплатно (free)

В первом сезоне мы рассмотрели (с точки зрения программиста) внутренний механизм, помещающий цены в регистр "Цены". Из этого регистра цена попадает в исходящие УПД (в продажи). Но эта цена (в прайс-листе) дифференцирована (ценообразована) в разрезах свойств самой номенклатуры. Но стратегия ценообразования, ценовая власть - это в первую очередь о работе с ценами для клиента. И тут вступает в дело второй акт марлезонского, Скидки (наценки) и кешбек.

08.04.2024    862    tango    0    

2

Ценовая власть или Управление ценообразованием (УТ 11.5)

Ценообразование, анализ цен Механизмы типовых конфигураций Программист Бизнес-аналитик Пользователь Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 11 Россия Управленческий учет Абонемент ($m)

Ценовая власть - это способность (возможность) компании изменять в некоторых пределах отпускную цену своего товара (услуг, продукции). Чем в более широких пределах вы можете играть в цену продажи, тем больше этой власти у вас. Если вы не можете управлять отпускной ценой, то это или не ваш бизнес, или не бизнес вовсе. Здесь в рубрике "База знаний аналитика и руководителя проекта" слово проект не ограничено "проектом в 1С". Посмотрим, что для этого есть в УТ 11.5.

1 стартмани

05.04.2024    721    tango    12    

2

Расширяем возможности дополнительных обработок и настраиваем их отладку

БСП (Библиотека стандартных подсистем) Механизмы типовых конфигураций Программист Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

Уже не одна веб-страница исписана знаниями о дополнительных обработках, как создать, как подключить. Есть масса вариантов, как их можно отладить. Я разобрался в кишках работы библиотеки и покажу, как можно расширить возможности дополнительных отчетов, а также покажу удобный способ отладки.

07.02.2024    2942    YA_418728146    11    

49

Регистры накопления в 1С:КА2 и 1С:ERP для расчета НДФЛ, страховых взносов и взаиморасчетов с сотрудниками на январь 2024 года. Краткое описание

Зарплата Механизмы типовых конфигураций Программист Бухгалтер Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Комплексная автоматизация 2.х Россия Бухгалтерский учет НДФЛ Абонемент ($m)

Для расчета зарплаты и соответствующих налогов в конфигурациях 1С:КА2 и 1С:ERP используется 22 регистра накопления, 7 регистров сведений, 1 регистр расчета и бухгалтерские проводки. В таблице приведены названия этих регистров, указаны основные регистраторы и виды движений приход/расход. В описании приводится краткое функциональное назначение регистров в основных зарплатных процессах. Описание регистров родилось из черновиков при написании различных отчетов и обработок при эксплуатации 1С-овских конфигураций и исправлении ошибок по НДФЛ, взаиморасчетов с сотрудниками и прочих. Информация не претендует на полноценное описание работы регистров, скорее это дискуссионный материал. Но, возможно, кому-то пригодится и сократит время при подготовке отчетности за непростой (в плане учета зарплаты) 2023 год. А возможно, кто-то поделится своим опытом.

1 стартмани

10.01.2024    1429    9    2ncom    6    

8

Шаблоны новых объектов 1С для 1С:Бухгалтерии предприятия

Инструментарий разработчика БСП (Библиотека стандартных подсистем) Механизмы типовых конфигураций Программист Стажер Платформа 1С v8.3 1С:Бухгалтерия 3.0 Бесплатно (free)

Используются для создания новых объектов в конфигурации, чтобы не забыть, что нужно сделать. Сделано на примере 1С:Бухгалтерия предприятия, в других конфигурациях могут быть другие, а могут быть и похожие объекты.

28.12.2023    5277    mrXoxot    11    

104
Оставьте свое сообщение