Основы компьютерной графики (Часть 2)

Публикация № 880140 03.08.18

Разработка - Практика программирования

Графика Проекции

Статья является продолжением публикации "Основы компьютерной графики". Во второй части будут рассмотрены следующие темы: 1. Преобразования в трехмерном пространстве. 2. Ортографическая проекция трехмерного изображения на экран. 3. Определение, какой поверхностью (лицевой/задней) проецируется грань на экран. 4. Перспективная проекция.

Основы компьютерной графики (часть 2)

Выводы из первой части

Во второй части мы будем использовать весь накопленный опыт первой части. Перечислим итоги первой части статьи:

  1. Выполнять операции преобразования можно с помощью умножения специально заполненных матриц 3х3.
  2. С помощью матриц 3х3 можно накапливать результаты операций преобразований.
  3. Используя несколько матриц, можно организовать вставку преобразования в любое место цепочки преобразований.

Переходим к 3D

На этом моменте многих ждет разочарование. Расчет координат в 3-м мерном пространстве не сильно отличается, от расчета координат в 2-мерном пространстве.
Матрица точки теперь выглядит так (x,y,z,1)
Матрица перемещения

Матрица масштабирования

где  X,Y,Z – коэффициенты масштабирования по соответствующим координатам

С вращением немного сложнее, ключевое слово «немного».  Для начала определим как расположены оси координат. Центр координат расположен в центре экрана (отображаемой области). Ось X – направлена вправо, ось Y – направлена вверх, ось Z – направлена перпендикулярно плоскости монитора в даль, в геометрии обычно обозначают «х» - хвост стрелы.
Надеюсь, многие поняли, что в первой части вы выполняли вращение в плоскости Y0X вокруг оси Z, т.е. у нас уже есть готовая матрица поворота вокруг оси Z.

Матрицы поворота вокруг осей X,Y выводятся подобным образом.
Матрица поворота вокруг оси X

Матрица поворота вокруг оси Y

Программный код для вычисления координат в 3-мерном пространстве не многим отличается от кода для 2-мерного пространства.

Ортографическая проекция

Координаты вычислили, но монитор плоский, маловероятно, но возможно, у кого-то и не плоский, но экран все равно плоский.  Как выводить 3-х мерное изображение на плоский экран?
Мы будем проецировать изображение на (плоскость Y0X). Для начала мы построим ортографическую проекцию – координаты x, y не будут изменятся в зависимости от координаты z. Такие проекции строят, как правило, САПР (системы автоматизированного проектирования), где важно сохранение пропорций и размеров, а не реалистичность.

Теперь у нас уже не квадрат а куб. Точек стало больше, отрезки превратились в ребра, и стало их соответственно тоже больше.

&НаКлиенте
Процедура Инициализация()
	Куб = Новый Структура("Матрицы,Ребра,Точки,Владелец");
	
	Куб.Владелец = Неопределено;
	
	Точки = Новый Массив();
	Точки.Добавить(ПолучитьТочку(-10, -10, -10));
	Точки.Добавить(ПолучитьТочку(-10, 10, -10));
	Точки.Добавить(ПолучитьТочку(10, 10, -10));
	Точки.Добавить(ПолучитьТочку(10, -10, -10));
	
	Точки.Добавить(ПолучитьТочку(-10, -10, 10));
	Точки.Добавить(ПолучитьТочку(-10, 10, 10));
	Точки.Добавить(ПолучитьТочку(10, 10, 10));
	Точки.Добавить(ПолучитьТочку(10, -10, 10));
	
	Куб.Точки = Точки;
	
	Ребра = Новый Массив();
	Ребра.Добавить(ПолучитьРебро(0,1));
	Ребра.Добавить(ПолучитьРебро(1,2));
	Ребра.Добавить(ПолучитьРебро(2,3));
	Ребра.Добавить(ПолучитьРебро(3,0));
	
	Ребра.Добавить(ПолучитьРебро(4,5));
	Ребра.Добавить(ПолучитьРебро(5,6));
	Ребра.Добавить(ПолучитьРебро(6,7));
	Ребра.Добавить(ПолучитьРебро(7,4));
	
	Ребра.Добавить(ПолучитьРебро(0,4));
	Ребра.Добавить(ПолучитьРебро(1,5));
	Ребра.Добавить(ПолучитьРебро(2,6));
	Ребра.Добавить(ПолучитьРебро(3,7));
	
	Куб.Ребра = Ребра;
	
	М = ПолучитьЕдиничнуюМатрицу4х4();
	М[0][0] = 3;
	М[1][1] = 3;
	М[2][2] = 3;
	
	М[3][2] = 20;	
	
	Куб.Матрицы = Новый Массив();
	Куб.Матрицы.Добавить(М);
	
	ВывестиОбъект(Куб);
КонецПроцедуры

Все преобразования выполняются схожим образом.

&НаКлиенте
Функция ПолучитьМатрицуПоворотаZ(Угол)
	М = ПолучитьЕдиничнуюМатрицу4х4();
	
	Pi = 3.1415926535897932;
	УголРадианы = Угол / 180 * Pi;
	Косинус = Cos(УголРадианы);
	Синус = Sin(УголРадианы);
	
	М[0][0] = Косинус;
	М[0][1] = -Синус;
	М[1][0] = Синус;
	М[1][1] = Косинус;

	Возврат М;
	
КонецФункции


&НаКлиенте
Процедура КомандаПоворотZ(Команда)
	// Вставить содержимое обработчика.
	М = ПолучитьМатрицуПоворотаZ(УголПоворота);
	
	Если МестоВставки = 0 Тогда
		УмножитьМатрицы4х4(М, Куб.Матрицы[0]);
		Куб.Матрицы[0] = М;		
	Иначе
		УмножитьМатрицы4х4(Куб.Матрицы[0], М);
	КонецЕсли;
	
	ВывестиОбъект(Куб);
	
КонецПроцедуры

Получение координат после всех преобразований:

&НаКлиенте
Функция ПолучитьМатрицуПреобразований(Объект)
	М = ПолучитьЕдиничнуюМатрицу4х4();
	
	Для Каждого Матрица Из Объект.Матрицы Цикл
		УмножитьМатрицы4х4(М, Матрица);		
	КонецЦикла;
	
	Если Объект.Владелец <> Неопределено Тогда
		Для Каждого Матрица Из Объект.Владелец.Матрицы Цикл
			УмножитьМатрицы4х4(М, Матрица);		
		КонецЦикла;		
	КонецЕсли;
	
	Возврат М;
КонецФункции

&НаКлиенте
Функция ПолучитьКоордиантыТочек(Объект, МатрицаПреобразований)
	рТочки = Новый Массив();
	
	Для Каждого Точка Из Объект.Точки Цикл
		рТочка = Новый Массив(4);
		рТочка[0] = Точка[0] * МатрицаПреобразований[0][0] + Точка[1] * МатрицаПреобразований[1][0] + Точка[2] * МатрицаПреобразований[2][0] + Точка[3] * МатрицаПреобразований[3][0];
		рТочка[1] = Точка[0] * МатрицаПреобразований[0][1] + Точка[1] * МатрицаПреобразований[1][1] + Точка[2] * МатрицаПреобразований[2][1] + Точка[3] * МатрицаПреобразований[3][1];
		рТочка[2] = Точка[0] * МатрицаПреобразований[0][2] + Точка[1] * МатрицаПреобразований[1][2] + Точка[2] * МатрицаПреобразований[2][2] + Точка[3] * МатрицаПреобразований[3][2];
		рТочка[3] = Точка[0] * МатрицаПреобразований[0][2] + Точка[1] * МатрицаПреобразований[1][2] + Точка[2] * МатрицаПреобразований[2][2] + Точка[3] * МатрицаПреобразований[3][3];
			
		рТочка[0] = рТочка[0] + 80;
		рТочка[1] = -рТочка[1] + 80;
		
		рТочки.Добавить(рТочка);		
	КонецЦикла;
	
	Возврат рТочки;
	
КонецФункции

&НаКлиенте
Процедура ОбновитьКоординатыРебер(Объект, Точки)
	Для Каждого Ребро Из Объект.Ребра Цикл
		Линия = Ребро[0];
		Точка1 = Точки[Ребро[1]];
		Точка2 = Точки[Ребро[2]];
		
		Линия.Лево = Точка1[0];
		Линия.Верх = Точка1[1];
		Линия.Ширина = Точка2[0] - Точка1[0];
		Линия.Высота = Точка2[1] - Точка1[1];		
	КонецЦикла;
КонецПроцедуры

Результат выглядит так.

Выделение невидимых граней куба

На предыдущем скриншоте у нас получился каркас куба. У проекции куба не все грани должны отображаться. Как определить должна отображаться грань либо нет?
У грани есть две поверхности лицевая и задняя. Если грань повернута в экран лицевой поверхностью, значит её нужно отображать, иначе нет.

Для определения какой поверхностью грань повернута к экрану, воспользуемся следующим свойством:
Векторное произведение двух векторов
 в трехмерном евклидовом пространстве - вектор, перпендикулярный обоим исходным векторам. В нашем случае перпендикулярный грани. Координата Z как раз показывает в экран направлен вектор, либо наоборот.

Произведение векторов находится следующим образом:

Нас интересует только составляющая вектора z, которая у нас получилась равна axbyaybx .

Теперь у нашего куба появились грани, которые состоят из точек и ребер. Для грани важен порядок точек, я указал по порядку, в направлении хода часовой стрелки.

&НаКлиенте
Процедура Инициализация()
	Куб = Новый Структура("Матрицы,Ребра,Точки,Владелец,Грани");
	
	Куб.Грани = Новый Массив();
	Куб.Грани.Добавить(ПолучитьГрань(0,1,2,3,0,1,2,3));
	Куб.Грани.Добавить(ПолучитьГрань(1,5,6,2,9,5,10,1));
	Куб.Грани.Добавить(ПолучитьГрань(3,2,6,7,2,10,6,11));
	Куб.Грани.Добавить(ПолучитьГрань(0,3,7,4,3,11,2,8));
	Куб.Грани.Добавить(ПолучитьГрань(0,4,5,1,8,4,9,0));
	Куб.Грани.Добавить(ПолучитьГрань(4,7,6,5,7,6,5,1));	
	
КонецПроцедуры

&НаКлиенте
Функция ПолучитьГрань(Т0,Т1,Т2,Т3,Р0,Р1,Р2,Р3)
	Грань = Новый Структура("Точки,Ребра");
	Грань.Точки = Новый Массив(4);
	Грань.Точки[0] = Т0;
	Грань.Точки[1] = Т1;
	Грань.Точки[2] = Т2;
	Грань.Точки[3] = Т3;
	
	Грань.Ребра = Новый Массив(4);
	Грань.Ребра[0] = Р0;
	Грань.Ребра[1] = Р1;
	Грань.Ребра[2] = Р2;
	Грань.Ребра[3] = Р3;
	
	Возврат Грань;
КонецФункции

С наименованиями свойств я особо не заморачивался, и уже в таком небольшом коде, можно запутаться, иногда точки - это координаты точек, а иногда индексы точек, тоже самое и с ребрами.

Возможно кому-то кажется, что было бы изящнее вместо куба взять более интересный объект, например, сделать объемную запись 1С. Во-первых на кубе - объяснять проще, а во-вторых - я уже даже на кубе запутался сам с ребрами, где-то в грани указал неправильный индекс ребра.

Изначально я хотел невидимые ребра выводить пунктирной линией, а видимые сплошной, но реализовать это оказалось не просто, т.к. свойство «тип линии», оказалось, доступным только для чтения. Остановился на том что видимые ребра – синие, невидимые – зеленные.

Добавляем определение видимости граней в код.

&НаКлиенте
Процедура ВывестиОбъект(Объект)
	МатрицаПреобразований = ПолучитьМатрицуПреобразований(Объект);
	Точки = ПолучитьКоордиантыТочек(Объект, МатрицаПреобразований);
	ОбновитьКоординатыРебер(Объект, Точки);
	
	ОпределитьВидимостьГраней(Объект, Точки);
	
КонецПроцедуры

Реализация

&НаКлиенте
Процедура ОпределитьВидимостьГраней(Объект, Точки)
	Для Каждого Ребро Из Объект.Ребра Цикл
		Линия = Ребро[0];
		Линия.ЦветЛинии = Новый Цвет(0,150,0);
	КонецЦикла;
	
	Для Каждого Грань Из Объект.Грани Цикл
		Точка0 = Точки[Грань.Точки[0]];
		Точка1 = Точки[Грань.Точки[1]];
		Точка2 = Точки[Грань.Точки[2]];
		
		Ах = Точка1[0] - Точка0[0];
		Ау = Точка1[1] - Точка0[1];
		
		Вх = Точка2[0] - Точка1[0];
		Ву = Точка2[1] - Точка1[1];
		
		Z = Ах * Ву - Ау * Вх;
		
		//Сообщить(Z);
		
		Если Z < 0 Тогда
			Для Каждого ИндексРебра Из Грань.Ребра Цикл
				Линия = Объект.Ребра[ИндексРебра][0];	
				Линия.ЦветЛинии = Новый Цвет(0,0,150);
			КонецЦикла;			
		КонецЕсли;
		
	КонецЦикла
	
КонецПроцедуры

Результат.

Не сразу понятно, что куб наклонен вниз.

Перспективная проекция

Добавим еще реалистичности нашему изображения. На зрачок человеческого глаза попадает, конечно, не ортографическая проекция, а перспективная. Добиться настоящей реалистичности очень сложно, тут очень много факторов: у человека два глаза, зрачок умеет фокусироваться, изменять чувствительность к яркости, кроме того полученное изображение обрабатывается мозгом. Когда мы смотрим, допустим, на ламинат с близкого расстояния, мы видим параллельные прямые, хотя они, вроде должны быть не параллельными в перспективной проекции. Я позволил себе небольшое отступление, вернемся к перспективной проекции.

Перспективу можно описать следующим образом – чем дальше объект, тем он меньше. Насколько объект удален от нас, зависит от координаты Z. Соответственно при удалении координаты x,y будут смещаться в центр, т.е. уменьшаться.
Вычислять новые координаты будем по следующие формуле:
x’ = x * F / (F + z)
где F – фокусное расстояние.

&НаКлиенте
Функция ПолучитьКоордиантыТочек(Объект, МатрицаПреобразований)
	рТочки = Новый Массив();
	
	Для Каждого Точка Из Объект.Точки Цикл
		рТочка = Новый Массив(4);
		рТочка[0] = Точка[0] * МатрицаПреобразований[0][0] + Точка[1] * МатрицаПреобразований[1][0] + Точка[2] * МатрицаПреобразований[2][0] + Точка[3] * МатрицаПреобразований[3][0];
		рТочка[1] = Точка[0] * МатрицаПреобразований[0][1] + Точка[1] * МатрицаПреобразований[1][1] + Точка[2] * МатрицаПреобразований[2][1] + Точка[3] * МатрицаПреобразований[3][1];
		рТочка[2] = Точка[0] * МатрицаПреобразований[0][2] + Точка[1] * МатрицаПреобразований[1][2] + Точка[2] * МатрицаПреобразований[2][2] + Точка[3] * МатрицаПреобразований[3][2];
		рТочка[3] = Точка[0] * МатрицаПреобразований[0][2] + Точка[1] * МатрицаПреобразований[1][2] + Точка[2] * МатрицаПреобразований[2][2] + Точка[3] * МатрицаПреобразований[3][3];
			
		рТочка[2] = рТочка[2] + 40;		
		
		//УголОбзора = 90;
		//рТочка[0] = рТочка[0] * УголОбзора/рТочка[2] + 80;
		//рТочка[1] = рТочка[1] * УголОбзора/рТочка[2] + 80;
		
		ФокусноеРасстояние = 80;
		рТочка[0] = рТочка[0] * ФокусноеРасстояние / (ФокусноеРасстояние + рТочка[2]) + 80;
		рТочка[1] = рТочка[1] * ФокусноеРасстояние / (ФокусноеРасстояние + рТочка[2]) + 80;
		
				
		рТочки.Добавить(рТочка);		
	КонецЦикла;
	
	Возврат рТочки;
	
КонецФункции

Куб в начальной позиции.

Добавим преобразования поворот вокруг осей

Обработка тестировалась на программных файлах 1С:Предприятие 8.3 (8.3.12.1529), подключение - тонкий клиент.

 

Скачать файлы

Наименование Файл Версия Размер
Пример работы с 3Д графикой

.epf 9,58Kb
7
.epf 1.1.2 9,58Kb 7 Скачать

Специальные предложения

Лучшие комментарии
3. Dmitri_1C 163 03.08.18 23:56 Сейчас в теме
Помню, NN-лет назад такое на паскале рисовал.
Ностальгия.
+
Остальные комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. WalterMort 335 03.08.18 15:45 Сейчас в теме
Где матрицы перспективного проецирования? Где шарнирный замок? Где кватернионы?
2. mszsuz 259 03.08.18 23:46 Сейчас в теме
так скоро и "DOOM" получится - первую комнату уже нарисовали.
3. Dmitri_1C 163 03.08.18 23:56 Сейчас в теме
Помню, NN-лет назад такое на паскале рисовал.
Ностальгия.
+
4. HAMMER_59 223 04.08.18 16:26 Сейчас в теме
Как я уже написал в статье, при добавление граней, запутался с ребрами. Изменил код добавления граней, грань теперь добавляется по точкам, ребра добавляются автоматически.
&НаКлиенте
Процедура ДобавитьГрань(Объект,Т0,Т1,Т2,Т3)
	Грань = Новый Структура("Точки,Ребра");
	Грань.Ребра = Новый Массив();
	
	Грань.Точки = Новый Массив(4);
	Грань.Точки[0] = Т0;
	Грань.Точки[1] = Т1;
	Грань.Точки[2] = Т2;
	Грань.Точки[3] = Т3;
	
	ИндексПервойТочки = Т3;
	Для Каждого ИндексТочки Из Грань.Точки Цикл
		ИндексВторойТочки = ИндексТочки;
		Сч = 0;
		Для Каждого Ребро Из Объект.Ребра Цикл
			Если ((Ребро[1] = ИндексПервойТочки) И (Ребро[2] = ИндексВторойТочки))
				ИЛИ ((Ребро[2] = ИндексПервойТочки) И (Ребро[1] = ИндексВторойТочки)) Тогда
					Грань.Ребра.Добавить(Сч);
				Прервать;
			КонецЕсли;
			Сч = Сч + 1;
		КонецЦикла;
		ИндексПервойТочки = ИндексВторойТочки;
	КонецЦикла;
	
	
	Куб.Грани.Добавить(Грань);
КонецПроцедуры
Показать
5. Неопределено 87 04.08.18 17:16 Сейчас в теме
Хочется посмотреть на анимированный пример вращения в режиме реального времени.
6. Неопределено 87 06.08.18 07:26 Сейчас в теме
Не сразу понятно, что куб наклонен вниз.
Да, не сразу. А после этого так вообще. Что вы сделали с кубом? Зачем так растянули и исказили его? Я имею в виду, очевидно что спереди находятся зелёные грани Это явно не куб, а что-то трапецевидное.
7. HAMMER_59 223 06.08.18 09:08 Сейчас в теме
(6)
то вы сделали с кубом? Зачем так растянули и исказили его?


Бывают люди адекватные, а бывают неадекватные. Нормальная реакция адекватного человека - подвергать все критическому мышлению. Т.е. ознакомился с материалом, затем проверил. Как проверить? Посмотреть в других источниках информации. В конце концов запустить в программе подобной 3Д макс, построить куб, построить перспективную проекцию - и убедиться, что куб действительно получается именно таким. Потом сами же пишите, что кто-то Вас идиотом выставляют. Может дело в Вас, может Вы так себе ведете?


(6)
очевидно что спереди находятся зелёные грани

Опять же достаточно внимательно прочитать статью, где написано, что мы не пытаемся получить 100% реалистичность (как-то забавно в рамках 1С говорить о реалистичной модели), мы строим приближенную модель. В данном случае не грани, а ребра отмечены разными цветами, даже не для реалистичности, а чтобы показать, что мы правильно определили какой поверхностью грань проецируется на экран.

Фраза сравнима с мышлением школьника, естественно не лучшего: "Так формулы из школьного курса по физике не точные, например, не учтено что масса изменяется от скорости". А если еще добавить, когда мы отмерили линеечкой 127 мм, так это ведь не точно 127 мм там ведь тоже погрешность, а расстояние там и того хуже порой метрами меряем. Как дальше жить?

Какое говорите образование? Не программист, а инженер? Странно, похоже, зря только время потратили на институт, знания мимо Вас прошли. В институте крайне доходчиво и не раз объясняют, что максимальная точность - крайне редко эффективна.
8. Неопределено 87 06.08.18 09:22 Сейчас в теме
(7)
Может дело в Вас

Я просто решил поддержать вашу традицию писать как это не похоже на куб.

мы строим приближенную модель

Да, мы тоже строили приближённую, но вам это не помешало написать что у нас не 3D и не куб.

В институте крайне доходчиво и не раз объясняют, что максимальная точность - крайне редко эффективна.

Может быть у вас и объясняют. Меня научили тому, что малейшее отклонение и волновод уже работает на пропуск другой частоты, а антенна перестаёт ловить сигнал в заданном диапазоне, а если дорожку специальными ухищрениями LГLГLГLГLГ не удлинить в нужном месте, байты будут добегать с разной скоростью и сумматор не заработает как положено.
9. HAMMER_59 223 06.08.18 10:27 Сейчас в теме
(8)
Да, мы тоже строили приближённую, но вам это не помешало написать что у нас не 3D и не куб.


Это Вы сами себе додумали, я так не писал. Опять же если прочитать повнимательнее статью в ней написано, что математическая модель той части, которую Вы использовали для отображения в 3Д, ничем не отличается от 2Д.


(8)
Может быть у вас и объясняют. Меня научили тому, что малейшее отклонение и волновод уже работает на пропуск другой частоты

У Вас один предмет был в институте? Несмотря на то, что учился я на специальности "Автоматизация систем управления", при этом на электротехнической кафедре, поэтому пришлось немного окунуться и в электричество и в электронику. Был у нас такой предмет "Основы теории автоматизации управления". Прекрасный предмет, где просто очень много теории. Предмет, конечно, не только про электронику, но в основном как раз речь шла про электронику, и как раз решались проблемы, что в электронике далеко все от идеала, обычный усилитель - это уже целая история, т.к. показатели какому-нибудь транзистора не линейны.

Малейшее отклонение - вещь крайне растяжимая. Крайне странные вещи вы пишите, крайне странные. Вся электроника - это диапазоны и отклонения, вы точно в институте учились, а не кружок радиолюбителя посещали?
10. Неопределено 87 06.08.18 10:45 Сейчас в теме
У Вас один предмет был в институте?

Предложение, начинающееся с "Меня научили тому", включает в себя описание четырёх предметов.
пришлось немного окунуться
в основы теории
Вся электроника - это...

Вопросов больше нет.

Если абстрагироваться от нашей игры в снежки, на уровне кода и механики всё предельно понятно. Есть координаты точек в трёхмерном пространстве, с которыми мы взаимодействуем на уровне кода. Если построить их в голове, виден объёмный объект -- обычный куб. Как в вашем, так и в моём посте. Но вам не понравилась моя визуализация. Вы посчитали её не информативной. А затем повторно не закрасили синие рёбра куба и тем самым визуально вывели зелёные на передний план и дали мне возможность показать как некрасиво вы повели себя в моём посте. А так, мой пост зачётный. Шучу, этот на самом деле круче, но на анимацию вращения всё равно хочется посмотреть.
11. HAMMER_59 223 06.08.18 12:10 Сейчас в теме
(10)
Но вам не понравилась моя визуализация


Еще раз повторю, что мне не понравилась математическая модель, не знаю почему Вы так упорно настаиваете на визуализации.


(10)
Вы посчитали её не информативной

Уже устал повторять, что не в визуализации дело. Точно такую же математическую модель можно было построить в 2Д.

(10)
А затем повторно не закрасили синие рёбра куба

Участок кода из статьи - определение видимости граней.
&НаКлиенте
Процедура ОпределитьВидимостьГраней(Объект, Точки)
	Для Каждого Ребро Из Объект.Ребра Цикл
		Линия = Ребро[0];
		Линия.ЦветЛинии = Новый Цвет(0,150,0);
	КонецЦикла;
	
	Для Каждого Грань Из Объект.Грани Цикл
		Точка0 = Точки[Грань.Точки[0]];
		Точка1 = Точки[Грань.Точки[1]];
		Точка2 = Точки[Грань.Точки[2]];
		
		Ах = Точка1[0] - Точка0[0];
		Ау = Точка1[1] - Точка0[1];
		
		Вх = Точка2[0] - Точка1[0];
		Ву = Точка2[1] - Точка1[1];
		
		Z = Ах * Ву - Ау * Вх;
		
		//Сообщить(Z);
		
		Если Z < 0 Тогда
			Для Каждого ИндексРебра Из Грань.Ребра Цикл
				Линия = Объект.Ребра[ИндексРебра][0];	
				Линия.ЦветЛинии = Новый Цвет(0,0,150);
			КонецЦикла;			
		КонецЕсли;
		
	КонецЦикла
	
КонецПроцедуры
Показать


Вроде всё должно быть понятно. Сначала ко всем ребрам применяется зеленый цвет, а затем ребрам видимых граней цвет изменяется на синий.
Линии заново каждый раз не создаются, и скорее всего отображаются в том порядке, в котором изначально были созданы, но не факт.



(10)
но на анимацию вращения всё равно хочется посмотреть

Хотите проверить как я умею записывать видео с экрана, затем делать из них гифку? Я никогда этим не занимался.
12. Неопределено 87 07.08.18 03:10 Сейчас в теме
(11)
Я никогда этим не занимался.

Я тоже, но потом начал делать публикации и загуглил подходящую программу за пару минут. Сейчас можно писать с экрана сразу в gif.
13. yarsort 06.05.19 10:53 Сейчас в теме
Сколько же у людей свободного времени бывает... :)
Оставьте свое сообщение

См. также

Безопасная работа с транзакциями во встроенном языке Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

Разбираемся с опасностями использования транзакций во встроенном языке 1С. Познаем ошибку "В данной транзакции уже происходили ошибки". Учимся защищаться от них.

1 стартмани

25.03.2019    45597    tormozit    58    

Пример создания документа с движениями в ERP 2.5.7

БСП (Библиотека стандартных подсистем) Практика программирования v8 ERP2 Россия УУ Абонемент ($m)

Пример создания документа с движениями в ERP 2.5.7, а также включение документа в основные подсистемы, а именно по управлению доступом, датам запрета изменения, контролю остатков, использованию характеристик и серий и прочее.

1 стартмани

10.08.2021    2001    maraty    10    

Работа с абстрактным массивом

Практика программирования Математика и алгоритмы v8 Россия Абонемент ($m)

Абстрактные типы данных и алгоритмы уверенно набирают популярность в языках общего назначения. Встроенный язык 1С является предметно-ориентированным и не спешит развиваться в сторону поддержки абстракций. Однако потребность в них существует, т.к. задачи, решаемые на платформе, не уступают разнообразию из других ЯП. Предлагаю рассмотреть вариант реализации абстрактного массива в 1С.

1 стартмани

07.07.2021    3749    kalyaka    56    

Семеро одного не ждут? Асинхронное исследование асинхронности

Практика программирования Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Все уже, наверное, знают о появлении в новых версиях платформы асинхронных функций и конструкций Асинх/Ждать. Многие, возможно, уже их используют. Но что будет, если создать свои асинхронные функции, запустить и не дожидаться окончания их выполнения? Неужели можно запустить несколько процессов параллельно?

1 стартмани

08.06.2021    5439    Alxby    45    

Как выполнить отчет на СКД через COM и получить данные отчета? Промо

Практика программирования v8 УПП1 Россия Абонемент ($m)

Для чего это нужно. Например, нужно в одной базе получить какой-либо показатель из другой базы. Этот показатель вычисляется в каком-либо сложном отчете, который написан на СКД. Можно, конечно, "скопипастить" текст запроса из другой базы, немного подправить его и выполнять в том же COM подключении. Но с этим теряется гибкость: если отчет изменился, то нужно помнить о том, что где-то есть его "немного модифицированная" копия. В статье будет рассмотрен пример получения данных из базы ЗУП.

2 стартмани

08.05.2018    32296    wowik    3    

Связи параметров выбора номенклатуры и характеристики в 1С 8.3

Практика программирования v8 v8::УФ 1cv8.cf УТ11 КА2 Россия Абонемент ($m)

Из этой статьи вы узнаете, как, используя системы стандартов и методик разработки 1С, правильно настроить связи параметров выбора номенклатуры и характеристики в новой табличной части.

1 стартмани

22.02.2021    1383    plotnikov1c    2    

СКД: все, что вы хотели знать о подмене схемы компоновки данных в отчетах и обработках

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Довольно часто на различных тематических форумах задается вопрос, можно ли использовать в отчете/обработке несколько схем компоновки данных, подменяя одну другой по мере надобности? При этом желательно, чтобы и пользовательские настройки при смене схемы менялись соответственно.

1 стартмани

07.12.2020    5128    user1502278    18    

Cбор и анализ ошибок при помощи Sentry, или как упростить жизнь себе и пользователям

Практика программирования Интеграция v8 Абонемент ($m)

Цель данной статьи - сделать процесс сбора и анализа ошибок, происходящих в базе, максимально простым, быстрым и удобным, собирать статистику по ошибкам, местам их возникновения и частоте их появления, а также в деталях разобрать все тонкости по интеграции 1С с Sentry.

1 стартмани

09.10.2020    7413    hexhoc    12    

Программное создание динамического списка на управляемой форме. (Динамическое создание динамического списка). Готовая процедура + обработка - демонстрационный пример Промо

Практика программирования Универсальные функции v8::УФ 1cv8.cf Абонемент ($m)

Если у вас возникает необходимость на форму влиять динамически и создавать элементы управляемой формы программно, а особенно хотите вывести программно (динамически) динамический список, вам будет интересна эта процедура. Процедура включает также возможность формирования своей командной панели (а-ля снятие галочки "Автозаполнение" у стандартной командной панели списка).

1 стартмани

19.01.2018    69981    rpgshnik    31    

Программная корректировка при выводе отчета СКД

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Большинство отчетов на СКД, требующих программной корректировки, реализуются с помощью программной настройки СКД или обработки табличного документа уже после вывода отчета. Но во многих случаях более оптимально будет выполнять программную корректировку в процессе вывода отчета. Для этого существуют программные объекты, о которых я расскажу в данной статье.

1 стартмани

08.10.2020    10896    dabu-dabu    16    

Загрузка, скачивание, удаление файлов с помощью НачатьПомещениеФайлаНаСервер() и НачатьПолучениеФайлаССервера()

Практика программирования v8 1cv8.cf Абонемент ($m)

В платформе 8.3.15 появились новые методы НачатьПомещениеФайлаНаСервер() и НачатьПолучениеФайлаССервера(). В данной статье рассмотрено готовое решение проверенное и прекрасно работающее на тонком и веб-клиенте.

1 стартмани

25.07.2020    11780    Flashill    15    

Запуск фонового задания во внешней обработке без регистрации в справочнике "Дополнительные отчеты и обработки"

Практика программирования v8::УФ ЗУП3.x Россия Абонемент ($m)

Описал, как показать прогресс выполнения длительной операции во внешней обработке, и при этом не регистрировать обработку в справочнике "ДополнительныеОтчетыИОбработки". Проверял на БСП версии "3.1.2.264".

1 стартмани

09.03.2020    7476    VinnieThePOOH    5    

Как нарисовать граф на 1С Промо

Практика программирования v8 Абонемент ($m)

Описывается реализация на языке запросов 1С метода расположения вершин графа на плоскости, основанного на использовании электромеханической аналогии. При этом вершины графа представляются одноименными электрическими зарядами, дуги - пружинками. Силы взаимодействия вершин в этой системе переводят их из случайного начального в нужное конечное положение. Приведена обработка рисования графов "ГрафОграф", реализующая данный подход, показывающая также динамику процесса. Граф можно задать списком ребер вручную, выбрать из нескольких предопределенных примеров или сформировать по данным информационной базы.

1 стартмани

09.08.2013    73514    ildarovich    117    

Методика обновления формы объекта данных при изменении объекта

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

В формах объектов данных часто встречаются элементы, косвенно связанные с объектом. Логику обновления этих элементов при изменении объекта обычно вызывают из обработчиков ПриСозданнииНаСервере и ПриОткрытии, забывая про наличие других способов изменения объекта. В статье предложена методика для обычных и управляемых форм, учитывающая все способы.

1 стартмани

09.03.2020    20451    tormozit    16    

Отправка уведомлений с помощью командной строки, Оповещения с сервера на клиент с помощью командной строки

Практика программирования v8 1cv8.cf Россия Абонемент ($m)

Отправка уведомлений с помощью команды командной строки msg. Оповестить пользователей из серверного модуля или регламентного задания, с помощью командной строки msg.

1 стартмани

05.03.2020    8119    user5300    3    

Вывод сообщений в HTML поле средствами 1С

Практика программирования v8 v8::УФ Абонемент ($m)

Пример использования вывода большого количества сообщений в поле HTML. С возможностью открывать ссылочные объекты и создавать новые объекты передавая параметры прямо из HTML поля. Протестировано на релизах 8.3.12 и 8.3.15+

2 стартмани

31.01.2020    10906    burni4    16    

Простой способ индексирования интервалов Промо

Практика программирования v8 Абонемент ($m)

Предлагается простой способ индексирования интервалов для решения задач выборки записей, включающих заданный момент времени, пересекающихся с заданным интервалом или множеством интервалов. Способ основан на добавлении к исходной таблице особого числового индексированного поля, рассчитываемого по специальной формуле. Приведен код функций, необходимых для расчетов поля поиска и параметров поисковых запросов. Приведены также результаты тестирования метода, доказывающие его высокую эффективность.

1 стартмани

28.09.2016    42045    ildarovich    22    

Как в 1С создать паутинку "как на Инфостарте"

Практика программирования v8::УФ 1cv8.cf Россия Абонемент ($m)

Добрый день, уважаемы коллеги! В этой статье я расскажу, как в 1С создать отчет - "паутинку" на примере отчета по компетенциям сотрудника (разрабатывала на платформе 1С:Предприятие 8.3 (8.3.13.1865).

1 стартмани

15.01.2020    9785    user660153_aleks.pisanets    17    

Краткое руководство по внесению изменений в конфигурацию

Практика программирования v8 1cv8.cf Абонемент ($m)

Кратко описаны основополагающие моменты при старте групповой разработки конфигурации несколькими программистами. Полезно для проектной документации как требование к разработчикам или сопровождающей компании.

1 стартмани

13.01.2020    22755    sapervodichka    41    

Универсальные функции: разложение произвольной строки адреса в структуру

Практика программирования Универсальные функции v8 1cv8.cf Абонемент ($m)

Процедуры и функции раскладывают произвольную строку адрес в структуру по ключевым словам.

1 стартмани

30.12.2019    5938    vik070777    10    

Бесплатная проверка контрагентов в ФНС (общий модуль с алгоритмом). На примере выводим статус в список справочника контрагентов Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

Если вам интересно проверить контрагенте в ФНС, вам поможет данная публикация. Весь алгоритм работы строится на основе данных, полученных с сервиса http://npchk.nalog.ru совершенно бесплатно.

1 стартмани

01.02.2018    38417    rpgshnik    56    

"Живые" картинки со Snap.SVG

Практика программирования WEB Работа с интерфейсом v8 Абонемент ($m)

В статье рассмотрен пример использования http-сервисов для визуализации данных

1 стартмани

24.10.2019    15143    blackhole321    7    

RLS - дубли условий в запросах к СУБД

Практика программирования Роли и права v8 v8::Права 1cv8.cf Абонемент ($m)

"Подводные камни", возникающие при бездумном копировании ролей с ограничениями RLS, как это отражается на производительности, разбор примера и инструмент для анализа.

1 стартмани

07.10.2019    10061    geron4    4    

Полное копирование одной формы в другую

Практика программирования Универсальные обработки Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Однажды я столкнулся с необходимостью открыть форму ЛЮБОГО документа с определенными изменениями, не зависящими от структуры объекта (например, заблокировать все кнопки). В интернете решения я не нашел. Обычно на форумах на запросы подобного рода отвечают чем-то вроде "покажи первоначальную задачу, а не спрашивай как реализовать то, что ты придумал". Тем не менее, мне стало интересно, как это можно сделать.

1 стартмани

03.10.2019    8011    nekit_rdx    25    

БСП: Дополнительная обработка (Регламенты), примеры от простого к сложному Промо

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Очень много попадается странных решений, которые можно решить через БСП:Дополнительные отчеты и обработки. Я бы вообще БСП из-за этой подсистемы переименовал в «Большое Спасибо Программистам». Поработаем с подсистемой в части написания регламентных заданий.

1 стартмани

10.05.2018    54286    dsdred    46    

Многопоточная обработка данных на примере перепроведения документов

Обработка документов Практика программирования v8 ERP2 УТ11 КА2 Абонемент ($m)

Дальнейшее развитие темы фоновой обработки данных - проведение документов в потоках. Настройка параметров и запуск основного процесса (менеджера потоков). Разбивка документов для проведения на не связанные друг с другом наборы и запуск дополнительных фоновых заданий для отдельных потоков. Отслеживание выполнения каждого потока в родительском сеансе.

1 стартмани

17.09.2019    12868    ids79    46    

Отображение истории выполнения по всем задачам комплексного процесса в документообороте

Документооборот и делопроизводство Практика программирования v8 ДО УУ Абонемент ($m)

Коллеги, предлагаю вашему вниманию доработку для вывода полной истории в задачах комплексного процесса.

1 стартмани

15.09.2019    8803    pavelpribytkin96    8    

Описание формата внутреннего представления данных 1С в контексте обмена данными

Практика программирования Внешние источники данных v8 v8::УФ 1cv8.cf Абонемент ($m)

Фирма 1С не рекомендует использовать внутреннее представление данных для любых целей, которые отличны от обмена с 1С:Предприятием 7.7. Но сама возможность заглянуть на "внутреннюю кухню" платформы с помощью функций ЗначениеВСтрокуВнутр(), ЗначениеВФайл(), ЗначениеИзСтрокиВнутр() и ЗначениеИзФайла(), дала возможность сообществу программистов 1С разработать новые приемы разработки и анализа. Так, именно на использовании внутреннего представления был построен алгоритм "быстрого массива", который позволяет практически мгновенно создать массив в памяти на основании строки с разделителями. С помощью разбора внутреннего представления можно "на лету" программным кодом выполнить анализ обычной формы и даже сделать редактор графической схемы. Во внутреннем формате сохраняют свои данные между сеансами различные популярные внешние обработки. А еще это возможность сделать быстрый обмен с внешними системами.

1 стартмани

06.09.2019    21782    Dementor    31    

Некоторая работа с данными через COM Промо

Практика программирования v8 Абонемент ($m)

В статье приведены примеры работы с Платформой 8.X через COM (точнее, через объект COMConnector). Примеры кода были использованы при реализации прикладных задач в процессе трудовой деятельности.

2 стартмани

05.12.2012    59992    wowik    32    

Удобный просмотр результата запроса с большим количеством временных таблиц

Практика программирования v8 Абонемент ($m)

Если Вам часто приходится просматривать в отладчике сложные пакетные запросы с большим количеством временных таблиц, то эта статья для Вас.

1 стартмани

27.08.2019    12870    ids79    22    

Запуск фонового задания во внешней обработке. Отключение предупреждений защиты от опасных действий в фоновом задании

Практика программирования v8 1cv8.cf Абонемент ($m)

Как запустить фоновое задание из модуля внешней обработки используя БСП. Как отключить безопасный режим и сообщения защиты от опасных действий независимо от профиля безопасности пользователя в фоновом задании во внешней обработке.

2 стартмани

24.08.2019    17140    BenGunn    22    

Организация функционала наценок по позициям либо сегментам номенклатуры в УТ 11.4

Ценообразование, анализ цен Практика программирования Ценообразование, анализ цен Разработка v8::ОУ v8::УФ УТ11 Россия УУ Абонемент ($m)

В статье описан один из методов реализации задачи установки скидок/наценок в соответствии с заданным процентом по позициям/сегментам номенклатуры. Так-же продемонстрирован принцип создания произвольного запроса к ИБ в виде цен. Протестировано на релизе Управление торговлей, редакция 11.4.8.92.

1 стартмани

07.08.2019    4961    cheiser1982    2    

Работа со схемой запроса Промо

Инструментарий разработчика Практика программирования v8 v8::Запросы Абонемент ($m)

Стандартом взаимодействия с реляционной базой данных стал язык SQL. Приемником SQL в 1С является язык запросов. Язык запросов, также как и SQL, является структурированным. Составляющие структуры запроса отвечают на разные вопросы о том, какие данные требуется получить и какие манипуляции с множествами данных необходимо произвести при получении. В простых случаях текст запроса можно написать вручную, однако в сложных случаях, а также при программном формировании, - лучше воспользоваться объектной моделью запроса и использовать объект "Схема запроса". В статье дается описание объектной модели и особенностей работы с ней, а также приводится решение, упрощающее взаимодействие с объектом "Схема запроса".

1 стартмани

24.04.2018    52087    kalyaka    41    

Изменяющееся контекстное меню в 1С 8.3

Практика программирования Работа с интерфейсом Разработка v8 v8::УФ Абонемент ($m)

В одной практической задаче мне пришлось разрабатывать контекстное меню таблицы управляемой формы, которое должно было меняться в зависимости от данных, находящихся в этой таблице. Ниже приведен мой способ решения этой задачи.

1 стартмани

06.08.2019    22494    signum2009    16    

Процедура ПриКомпоновкеРезультата

Практика программирования v8 1cv8.cf Абонемент ($m)

Коллекция кода

1 стартмани

26.07.2019    58982    vasilev2015    66    

10 способов получить модуль числа (а может, и больше)

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

Пишем функцию вычисления модуля числа. Сколько способов существует? Давайте посчитаем!

1 стартмани

11.07.2019    14540    sam441    33    

Многопоточность. Универсальный «Менеджер потоков» (фреймворк) с отслеживанием зависимости объектов Промо

Практика программирования Математика и алгоритмы Универсальные функции Производительность и оптимизация (HighLoad) v8 1cv8.cf Россия Абонемент ($m)

Восстановление партий, расчет зарплаты, пакетное формирование документов или отчетов - теперь все это стало доступнее. * Есть желание повысить скорость работы медленных алгоритмов! Но... * Нет времени думать о реализации многопоточности? * о запуске и остановке потоков? * о поддержании потоков в рабочем состоянии? * о передаче данных в потоки и как получить ответ из потока? * об организации последовательности? Тогда ЭТО - то что надо!!!

26.05.2017    51447    DarkAn    87    

Ловец дедлоков СУБД

Производительность и оптимизация (HighLoad) Практика программирования ЦУП v8 Россия Абонемент ($m)

Анализ простейшего дедлока СУБД в рабочей базе с использованием ЦУП (центра управления производительностью) и profiler MS SQL (Microsoft SQL Server). Эта статья будет полезна людям, изучающим вопросы оптимизации работы 1С, или тем, у кого возникают дедлоки в рабочей базе. UPD 09.07.2019 добавлено воспроизведение блокировки в случае установки управляемой блокировки перед чтением набора записей регистра сведений. UPD 10.07.2019 добавлена тестовая база с примером.

1 стартмани

08.07.2019    12695    azazana    80    

Многоуровневая нумерация в отчете СКД (программный вывод)

Практика программирования v8::СКД 1cv8.cf Абонемент ($m)

Реализация многоуровневой нумерации при программном выводе отчета СКД основываясь на его структуре.

1 стартмани

01.07.2019    7812    lmnlmn    7    

Мониторинг производительности и искусственный интеллект

Производительность и оптимизация (HighLoad) Практика программирования Искусственный интеллект (AI) v8 Абонемент ($m)

Расскажем и покажем практически, как использовать искусственный интеллект на страже мониторинга производительности. У вас появится возможность создать собственного помощника Ларису, которая возьмет на себя вопросы по контролю и диагностике состояния обслуживаемой системы.

1 стартмани

01.07.2019    10354    ivanov660    28    

Новый запрос и новая таблица значений как функции Промо

Практика программирования v8 Абонемент ($m)

Предлагается две простые функции, использование которых уменьшает объем кода в конфигурациях на платформе «1С:Предприятие 8». Эти функции можно добавлять к своему общему модулю, что сделает процесс программирования более эффективным.

1 стартмани

27.11.2012    46466    ildarovich    49    

"Убер на складе": динамический расчет маршрутов с учетом реальных расстояний

Учет ТМЦ Практика программирования Учет ТМЦ v8 УУ Абонемент ($m)

Представляю методику и инструмент для динамического расчета маршрутов отбора на высоконагруженных складах для максимального повышения эффективности склада, ускорения проходимости и, как следствие, экономии денег. Это методика и обработка для интеграции в WMS решения. Тестировалось на 1С 8.3.14.1565.

3 стартмани

24.06.2019    19584    informa1555    17    

1С:Ассемблер. Немного летнего веселья!

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

Все вы, наверное, слышали, что 1С-ники жалуются на свою систему, считая язык 1С недостаточно низкоуровневым, скучным и т.п. Все они с тоской поглядывают в сторону "настоящих" языков программирования. Так вот, господа, они неправы. В системе 1С есть места, где можно размять программерский мозг и получить удовольствие от низкоуровневой техники. Предлагаю вам погрузиться в недра виртуальной машины 1С и понять, как она работает. Там есть свой "ассемблер" и мы попробуем его в действии!

1 стартмани

21.06.2019    34076    Evil Beaver    145    

Простые примеры сложных отчетов на СКД

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Подписи в отчете. Особенности соединения наборов: как соединить несоединяемое. Остатки на дату и обороты по месяцам в одном отчете. Курс валюты на каждую дату без группировок и соединений в запросе. Отчет с произвольными колонками и с произвольной последовательностью. "Неадекватный отчет".

1 стартмани

12.06.2019    36822    Hatson    32    

Уровни, глубина, прародители, циклы и аналоги запросом Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

В продолжение публикации «Транзитивное замыкание запросом» [http://infostart.ru/public/158512/] добавлены другие варианты использования того же приема. Приведены запросы для быстрого определения уровней всех элементов справочника, максимальной глубины справочника, прародителей произвольных элементов справочника, запрос для быстрого определения циклов (на примере справочника спецификаций «1С:Управление производственным предприятием») и определения множеств аналогов номенклатуры (также на примере конфигурации «1С:Управление производственным предприятием»).

1 стартмани

13.11.2012    120279    ildarovich    102    

Картинки во внешней печатной форме (Шапка и табличная часть)

Печатные формы документов Практика программирования Разработка v8::ОУ v8::УФ УТ11 Россия Абонемент ($m)

Способы вывести на печать картинку в шапке и в табличной части внешней печатной формы. Управление торговлей, редакция 11 (11.4.7.150).

1 стартмани

27.05.2019    18249    Povinger    3    

Создание внешней печатной формы в формате документа Word

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

В статье написано, как создать внешнюю печатную форму (для конфигураций с БСП) в формате Word.

1 стартмани

17.05.2019    24269    ВикторП    22    

Поле адреса в своем справочнике на примере 1С:Бухгалтерия 3

Практика программирования Разработка v8 v8::БУ БП3.0 Россия Абонемент ($m)

В публикации описано, как добавить поле адреса в свой справочник, чтобы вводить адрес через адресный классификатор.

1 стартмани

17.05.2019    8436    vasilievil    5    

Неоплаченные долги при распределении оплаты по правилу ФИФО одним запросом и намного быстрее, чем Вы думали Промо

Практика программирования Дебиторская и кредиторская задолженность Дебиторская и кредиторская задолженность v8 v8::СКД КА1 УТ10 УПП1 УУ Абонемент ($m)

Предлагается метод для быстрого нахождения неоплаченных долгов при распределении оплаты по правилу ФИФО, основанный на дихотомии. Описывается реализация метода в виде достаточно простого запроса, решающего за линейное время указанную задачу, считавшуюся ранее существенно более трудоемкой. Приводятся примеры использования запроса в отчетах на СКД для конфигураций УТ, КА, УПП.

1 стартмани

28.02.2014    71050    ildarovich    131    

Табличная часть из дополнительных реквизитов с обработкой событий в расширении

Практика программирования Работа с интерфейсом Разработка v8::УФ 1cv8.cf Абонемент ($m)

Эмуляция табличной части с помощью дополнительных реквизитов и расширения. Подход применим к любой конфигурации на управляемых формах с БСП и режимом совместимости, допускающим использование расширений. Весь код в статье.

1 стартмани

13.05.2019    13338    mvxyz    17    

Пример настройки шаблонов и реализации печати отчетов в документ MS Word используя функциональную часть "Библиотеки Стандартных Подсистем 1С" (БСП)

Практика программирования Разработка v8 Россия Абонемент ($m)

В конфигурации выбраны и использованы только необходимые объекты библиотеки стандартных подсистем для реализации вывода отчёта, с табличными частями, в документ MS Word. Показан пример создания необходимых областей в шаблоне для вывода параметров в отчёт.

1 стартмани

23.04.2019    8880    olegpkc    11    

Ops средствами 1С:Предприятие

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

В статье описан программный пакет "Автоматизация ИТ-процессов" (АИТП), позволяющий автоматизировать задачи по администрированию, управлению и обслуживанию ИТ-инфраструктуры.

1 стартмани

23.04.2019    18683    blackhole321    28    

1C + Python + Django Rest Framework + Vue.js. Опыт несложной full-stack разработки

Практика программирования Внешние источники данных Обмен через XML WEB Разработка v8 1cv8.cf Абонемент ($m)

В этой статье мы рассмотрим путь и основные моменты создания небольшого вэб-сервиса, который мы называем "Онлайн Прайс-лист". Выгрузка из 1С, бэкенд, фронтенд, получение заказов в 1С.

1 стартмани

22.04.2019    41145    riposte    69