Универсальный конвертер DBF -> CSV (dbf2csv)

10.09.12

Интеграция - Файловый обмен (TXT, XML, DBF), FTP

В данной обработке "dbf2csv" представлена переведенная мной на платформу 1С:Предприятие 7.7  Обработка "Экспорт ТЗ в CSV формат (пратформа 8.0/8.1)", и созданая мной функция ЭкспортТЗвCSV() для 1С:Предприятие 7.7

Скачать исходный код

Наименование Файл Версия Размер
dbf2csv.ert
.ert 128,00Kb
29
.ert 128,00Kb 29 Скачать

На основе разработки "Экспорт ТЗ в CSV формат (платформа 8.0/8.1)" //infostart.ru/public/19321/

я перевел "Экспорт ТЗ в CSV формат (платформа 8.0/8.1)" на платформу 1С:Предприятие 7.7, создана функция ЭкспортТЗвCSV() на платформе 1С:Предприятие 7.7 (текст этой функции представлен в этом описании ниже).

Эта функция сохраняет на диск файл "Comma separated values" (предназначенный для представления табличных данных) http://ru.wikipedia.org/wiki/CSV который используется для обмена коммерческой информацией с поставщиками, дистрибьюторами и интернет-сайтами.

Демонстрация возможностей экспорта подготовлена на платформе обработки "ОбзорДБФ" от Melnik - члена клуба профессионалов 1С  http://1c.proclub.ru/userinfo.php?uid=18579 которая входит в комплект Редактор DBF-файлов (ReDBF)
(25/02/2005 23:00:00) http://1c.proclub.ru/modules/mydownloads/personal.php?cid=76&lid=3901

Еще один способ загрузки DBF из ТЗ для преобразования в CVS описан в разработке "Функция загрузки dbf" //infostart.ru/public/57110/

 

Привожу текст процедур преобразования таблицы значений в CVS файл:

 

//ПреобразоватьПолеДляCSV () Преобразует поле строку к формату CSV
//Параметры:
//Поле            (Строка)            - Поле которое преобразуется к формату CSV
//Разделитель    (Строка)            - Для формата CSV разделителем является ',', но т.к.
//                                      Excel берет разделитель из региональных стандартов чтобы открывалось внем
//                                      нужно устанавливать разделитель ';'
//Возращает: (Строка) преобразованное к формату CSV поле
Функция ПреобразоватьПолеДляCSV(Поле,Разделитель = ";")
    //Так как Excel Берет настройки из рег. стандартов разделитель элементов списка, а у нас в России это ';'
    ПреобразованноеПоле = Поле;
    //по правилам CSV если поле содержит двойные ковычки они должны повторятся дважды
    Если Найти(ПреобразованноеПоле,"""") > 0 Тогда
        ПреобразованноеПоле = СтрЗаменить(ПреобразованноеПоле,"""","""""");
    КонецЕсли;
    //по правилам CSV если поле содержит перенос строки или запятую оно должно заключатся в двойные ковычки
    Если (Найти(ПреобразованноеПоле,Разделитель)=0) ИЛИ (Найти(ПреобразованноеПоле,"""")=0) Тогда
        ПреобразованноеПоле = "" + ПреобразованноеПоле + "";
    КонецЕсли;
    Возврат ПреобразованноеПоле;
КонецФункции

//ЭкспортТЗвCSV () экспортирует данные ТЗ в файл в формате CSV
//Параметры:
//ИмяФайла        (Строка)            - Имя файла в который производится сохранение
//ТЗ            (ТаблицаЗначений)    - Таблица значений данные которые сохраняются в файл
//Разделитель    (Строка)            - Для формата CSV разделителем является ',', но т.к.
//                                      Excel берет разделитель из региональных стандартов чтобы открывалось внем
//                                      нужно устанавливать разделитель ';'
//Возращает:(Булево) Истина - если файл успешно сохранен иначе ложь
Функция ЭкспортТЗвCSV(ТЗ, ИмяФайла, флЭкспортироватьИменаКолонок = 1, Разделитель = ";") Экспорт
    МаксКол = ТЗ.КоличествоКолонок();
    МаксСтр = ТЗ.КоличествоСтрок();
    Если (МаксКол = 0) ИЛИ (МаксСтр = 0) Тогда
        Возврат 0;
    КонецЕсли;
    Попытка
        ФайлCVS = создатьОбъект("Текст");
        // открыть файл
        ФайлCVS.Записать(ИмяФайла);
        ФайлCVS.КодоваяСтраница(1); //задаем кодировку: 0 - windows, 1 - DOS
        ФайлCVS.Шаблон(1);
        //Если нужно выгружать наименование колонок Выгружаем
        ПодготовленнаяСтрока = "";
        ШаблонCVS = "";
        Для СчКол = 1 По МаксКол Цикл
            КолонкаИмя = ТЗ.ПолучитьПараметрыКолонки(СчКол);
            ПодготовленнаяСтрока = ПодготовленнаяСтрока +""+ КолонкаИмя +""+ Разделитель;
            ШаблонCVS = ШаблонCVS + """[ПреобразоватьПолеДляCSV(СокрЛП(ТЗ.ПолучитьЗначение(СчСтр,"""+КолонкаИмя+""")))]"""+Разделитель;
        КонецЦикла;
        ПодготовленнаяСтрока = Лев (ПодготовленнаяСтрока,СтрДлина(ПодготовленнаяСтрока)-1);
        ШаблонCVS = Лев (ШаблонCVS,СтрДлина(ШаблонCVS)-1);
        Если флЭкспортироватьИменаКолонок = 1 Тогда
            ФайлCVS.ДобавитьСтроку(""+ПодготовленнаяСтрока+"");
        КонецЕсли;
        Для СчСтр = 1 По МаксСтр Цикл
            ФайлCVS.ДобавитьСтроку(ШаблонCVS);
        КонецЦикла;
    Исключение
        Возврат 1;
    КонецПопытки;
    ФайлCVS.Записать(ИмяФайла);
    Возврат 0;
КонецФункции

См. также

Загрузка документов в 1С (7.7) из табличных файлов Excel,OpenOffice,1C,DBF,TXT (обработка)

Файловый обмен (TXT, XML, DBF), FTP Загрузка и выгрузка в Excel Платформа 1С v7.7 Конфигурации 1cv7 Платные (руб)

Обработка решает поставленную задачу по вводу документов, а кроме того обладает важной функцией: настраивается на ассортимент конкретного поставщика, запоминая соответствие между его номенклатурой и «нашей». Т.е. фактически – является самообучающейся системой ввода накладных. У разных поставщиков могут быть накладные различного типа, с разным количеством полей, поэтому для каждого из них может быть сохранена своя собственная настройка диалоговой формы так, что любая поступающая накладная может быть обработана. По отношению к программе "1С:Предприятие 7.7" данное решение является внешними файлами. Для использования данного продукта не требуется вносить изменения в алгоритм существующих программ или используемых конфигураций.

2400 руб.

10.12.2009    76860    58    93    

68

Выгрузка документа Поступление товаров на комиссию из 1С 7.7 в универсальный формат EnterpriseData 1.12 для загрузки в 1С: Бухгалтерию 3

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v7.7 НДС Абонемент ($m)

Пример создания документа Поступление (акт, накладная, УПД) в 1С: Бухгалтерии 3 путем загрузки из XML универсального формата EnterpriseData 1.12 файла, сгенерированного обработкой документа "Реализация". Выгрузка реализации написана в самописной конфигурации на платформе 1С:Предприятие 7.7. Способ заполнения реквизитов поступления можно переделать под себя, выгрузка XML в универсальный формат EnterpriseData останется работоспособной.

1 стартмани

14.02.2023    2773    6    ksnik    0    

6

Робот-загрузчик и архив документов. Распознавание/загрузка сканов документов в 1С8(7.7), архив сканированных документов.

Файловый обмен (TXT, XML, DBF), FTP Учет документов Распознавание документов и образов Платформа 1С v7.7 Платформа 1С v8.3 Платформа 1C v8.2 Конфигурации 1cv8 Конфигурации 1cv7 Россия Платные (руб)

Программный комплекс способный распознавать сотни листов за раз любых сканированных(фото) документов (УПД, ТОРГ12, СФ, паспорт и пр.) и загружать их в любую 1С (БП3.0, УТ, КА, УНФ, УПП, 1С7.7 ТиС, ЗУП3 и пр.), а также формировать архив сканированных документов.<br> Робот применяет до 5 способов распознавания. Максимальное качество загрузки документов из бесплатных OCR. Работает без Интернета.

10800 руб.

13.10.2022    7976    1    12    

9

Реестр необлагаемых по 7 разделу декларации НДС операций

Файловый обмен (TXT, XML, DBF), FTP Бухгалтерский учет 7.7 1С:Бухгалтерия 7.7 Россия Бухгалтерский учет НДС Абонемент ($m)

Выгрузка реестра необлагаемых НДС операций в ответ на требование налоговой инспекции. В формате xml согласно требованиям законодательства https://sbis.ru/formats/docFormatCard/120287/help/?scrollTo=description Реестр документов подаётся в ответ на требование налоговой о представлении пояснений. Начиная с 23 ноября 2020 года, его можно направлять по ТКС, в электронном виде в формате xml (письмо ФНС России от 12.11.2020 № ЕА-4-15/18589). Данная обработка просто выбирает необлагаемые суммы (не по ставке 0%) по книги продаж за выбранный квартал и включает их в реестр с кодом операции, который выбран в самой обработке.

1 стартмани

24.09.2021    4515    5    AndKovalchuk    0    

3

Выгрузка из 1С ТиС 9.2 в 1С БП 3.0 с дополнительными фильтрами по Фирме, Складу, Контрагенту, Проекту, Автору и Юрлицу

Файловый обмен (TXT, XML, DBF), FTP Перенос данных 1C Платформа 1С v8.3 Оперативный учет 7.7 1С:Торговля и склад 7.7 1С:Бухгалтерия 3.0 Бухгалтерский учет Управленческий учет Абонемент ($m)

Обработка и правила обмена данными для выгрузки документов и всех связанных с ними справочников из 1С7.7 ТиС 9.2 в 1С8.3 БП 3.0 через файл XML. В типовых конфигурациях уже есть такое решение. Это немного доработанные правила и сама обработка выгрузки, добавлена возможность устанавливать отбор по выгружаемым документам по Фирме, Контрагенту, Складу, Проекту, Автору, ЮрЛицу. А также это внешняя обработка, что даёт возможность адаптировать её под нетиповую ТиС. Обработка и правила тестировались на платформах: 1С: Предприятие 7.7 и 1С: Предприятие 8.3.18.1334. На типовых конфигурациях: «Торговля + склад», редакция 9.2 (7.70 1004) и «Бухгалтерия предприятия» редакция 3.0 (3.0.96.30).

1 стартмани

13.08.2021    8547    53    Kuzya_brаtsk    8    

11

Выгрузка УПД И УКД в формате ЭДО для Бухгалтерии 7.7 (ПУБ 7.7, УСН 7.7, ТиС 7.7, Комплексной 7.7)

Файловый обмен (TXT, XML, DBF), FTP ЭДО и ОФД Бухгалтерский учет 7.7 1С:Бухгалтерия 7.7 1С:Торговля и склад 7.7 1С:Бухгалтерия 1.6 1С:Упрощенное налогообложение 7.7 Россия Бухгалтерский учет Абонемент ($m)

Обмениваемся УПД (УКД) с различными контрагентами через СБИС. А чтобы загрузить УПД (УКД) из 7.7 в Сбис, используем данную обработку, которая создает файл в формате XML, который можно импортировать в систему электронного документооборота. Для конфигурации "Бухгалтерский учет" (тестировалась на релизе 7.70.663) Для конфигурации "Упрощенная система налогообложения" ( тестировалась на релизе 7.70.305) Для конфигурации "Торговля и Склад 7.7" (тестировалась на релизе 7.70.1007)

1 стартмани

31.07.2021    15312    211    AndKovalchuk    49    

17
Оставьте свое сообщение