Отборы СКД на форме УФ

22.04.22

Разработка - СКД

Создание отборов из СКД для таблиц значений.

Скачать файлы

Наименование Файл Версия Размер
Отборы СКД на форме УФ:
.epf 11,50Kb
5
.epf 1 11,50Kb 5 Скачать

Доброго времени суток. Возникла у меня потребность в динамическом отборе таблицы значений. На не управляемых формах эту функцию использовал очень часто. Но на УФ как то не доводилось. Но понадобилось. И после изучения данного вопроса получился аккуратный шаблон для использования.

Создание динамического отбора для ТЗ

  1. Создаем реквизит с типом «КомпоновщикНастроекКомпоновкиДанных»
  2. Создадим для наглядности два реквизита ДатаНачала и ДатаОкончания
  3. Далее создаем Макет СКД который будит выбирать необходимую таблицу значений.

С одним условием Период ДатаНач и ДатаОкон.

 

 

В запросе СКД я выбираю Список документов за период.

Дальше создаем таблицу значений и переходим к формированию формы.

  1. Выносим реквизиты Периода
  2. Потом выносим реквизит на форму для формирования отбора Настройки (это наш КомпоновщикНастроекКомпоновкиДанных )->Настройки->Отбор (Объект.Настройки.Настройки.Отбор)
  3. И ,соответственно, нашу таблицу значений выносим на форму. Также не забываем команду для запуска отбора
  4. Далее переходим в модуль формы
  5. При создании на сервере прописываем такой код. Это необходимо для того чтобы в таблицу подтянулись настройки отборов из СКД  
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	
	ОО = РеквизитФормыВЗначение("Объект");	
	
	СКД = ОО.ПолучитьМакет("МакетСКД");
	
	URLСКД = ПоместитьВоВременноеХранилище(СКД, Новый УникальныйИдентификатор()); 	
	ОО.Настройки.Инициализировать(Новый ИсточникДоступныхНастроекКомпоновкиДанных(URLСКД));	
	
	НастройкиПоУмолчанию = СКД.НастройкиПоУмолчанию;	
	ОО.Настройки.ЗагрузитьНастройки(НастройкиПоУмолчанию);	
	ЗначениеВРеквизитФормы(ОО, "Объект");
	
КонецПроцедуры

 

  1. Описываем команду для формирования ТЗ
&НаКлиенте
Процедура Команда1(Команда)	
	Страт();
КонецПроцедуры

&Насервере
Процедура Страт()
	
	// Запуск работы с СКД
	ОО = РеквизитФормыВЗначение("Объект");	
	СхемаКомпоновкиДанных = ОО.ПолучитьМакет("МакетСКД"); 	
	//УстановитьСтруктуруНастроекДляВыводаВТаблицуСКолонкойСсылка(ОО.Настройки.Настройки);	
	// Получение таб значения из СКД
	ТЗВыгрузкаИзСКД = СкомпоноватьВТаблицуЗначений(СхемаКомпоновкиДанных, ОО.Настройки);	
	Для каждого Стр из ТЗВыгрузкаИзСКД цикл
		НС=Объект.ТабличнаяЧасть.Добавить();
		нс.ссылка=Стр.Ссылка;
	КонецЦикла;
	
КонецПроцедуры


&НаСервере
Функция СкомпоноватьВТаблицуЗначений(СхемаКомпоновкиДанных, КомпоновщикНастроек) Экспорт
	
	НастройкиСКД = КомпоновщикНастроек.Настройки;	
	//установка параметров отчета	
	НастройкиСКД.ПараметрыДанных.УстановитьЗначениеПараметра("ДатаНач",Объект.ДатаНачала);
	НастройкиСКД.ПараметрыДанных.УстановитьЗначениеПараметра("ДатаОкон",Объект.ДатаОкончания);
	
	
	//Запускаем компоновку
	
	КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных; 	
	МакетКомпоновки = КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных, КомпоновщикНастроек.Настройки,,,Тип("ГенераторМакетаКомпоновкиДанныхДляКоллекцииЗначений"));	
	//Создаем процессор компоновки	
	ПроцессорКомпоновки = Новый ПроцессорКомпоновкиДанных; 	
	ПроцессорКомпоновки.Инициализировать(МакетКомпоновки);	
	//Выводим в таблицу значений 	
	ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВКоллекциюЗначений; 	
	ТЗ = ПроцессорВывода.Вывести(ПроцессорКомпоновки, истина); 	
	
	Возврат ТЗ; 	
КонецФункции

 

Сохраняем и проверяем.

 

Вот что у нас получилось. Спасибо за внимание .

PS 

 

 

Тестировалась на платформе 1С:Предприятие 8.3 (8.3.18.1741).

СКД Отбор УФ

См. также

Infostart Toolkit: Инструменты разработчика 1С 8.3 на управляемых формах

Инструментарий разработчика Роли и права Запросы СКД Платформа 1С v8.3 Управляемые формы Запросы Система компоновки данных Конфигурации 1cv8 Платные (руб)

Набор инструментов программиста и специалиста 1С для всех конфигураций на управляемых формах. В состав входят инструменты: Консоль запросов, Консоль СКД, Консоль кода, Редактор объекта, Анализ прав доступа, Метаданные, Поиск ссылок, Сравнение объектов, Все функции, Подписки на события и др. Редактор запросов и кода с раскраской и контекстной подсказкой. Доработанный конструктор запросов тонкого клиента. Продукт хорошо оптимизирован и обладает самым широким функционалом среди всех инструментов, представленных на рынке.

12000 руб.

02.09.2020    102149    565    385    

612

Использование менеджера временных таблиц в СКД

СКД Платформа 1С v8.3 Система компоновки данных Конфигурации 1cv8 Бесплатно (free)

Рассмотрим еще не получивший широкого распространения способ работы с внешними данным в СКД. В процессе обсуждения работы с СКД выяснилось, что многие не знакомы со способом помещения туда временной таблицы, полученной предварительно. Статья будет полезна разработчикам, знакомым с программным созданием СКД.

05.12.2023    2196    ProgrammingStore    13    

49

Модель СКД

Инструментарий разработчика СКД Платформа 1С v8.3 Система компоновки данных Абонемент ($m)

DSL для работы с СКД.

1 стартмани

15.11.2023    4167    10    kalyaka    4    

82

Разрыв страницы в СКД. Легко!

СКД Платформа 1С v8.3 Система компоновки данных Бесплатно (free)

Когда отчет надо разделить по страницам, это всегда проблема для разработчика. Поскольку в СКД нет стандартных вариантов, как это сделать. Нашел (на свой взгляд) самое простое и оптимальное решение.

01.09.2023    3266    KVIKS    15    

76

Гибкие отборы через СКД на управляемых формах. Демо-обработка

СКД Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Абонемент ($m)

В данной публикации предлагаю вам рабочий пример использования системы компоновки данных для отборов на управляемых формах.

2 стартмани

07.06.2023    4639    26    quazare    7    

46

Вывод элементов иерархии верхнего уровня на СКД

СКД Платформа 1С v8.3 Абонемент ($m)

Как получить родителя первого уровня иерархического справочника с помощью СКД.

1 стартмани

06.06.2023    4281    echo77    6    

72

Обработка результатов запроса произвольными вычисляемыми полями. Обзор некоторых новых функций СКД

Запросы СКД Платформа 1С v8.3 Запросы Система компоновки данных Конфигурации 1cv8 Бесплатно (free)

В данной статье вспомним, как обрабатывать результаты запроса в вычисляемых полях СКД, а также сделаем небольшой обзор на новые функции СКД платформы 8.3.20.

07.02.2023    5591    quazare    8    

38
Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. quazare 3491 23.04.22 04:35 Сейчас в теме
писали уже все об этом - все кто может и не может https://infostart.ru/1c/articles/1577316/
4. rozer 304 04.05.22 16:22 Сейчас в теме
(1)
писали уже все об этом - все кто может и не может

ну не нужно так строго ) автор тебе доброе дело сделал - плюсы все тебе как "первоисточнику" будут...
2. TimurD 6 24.04.22 00:51 Сейчас в теме
Русский язык подучи!
3. mondordom 24.04.22 21:19 Сейчас в теме
А смысл городить на УФ таблицу значений, если для таких целей есть динамический список? С отборами, сортировками и прочими плюшками.
Оставьте свое сообщение