Очистка кэша пользователя

27.09.13

База данных - Чистка данных

Очистка кэша пользователя, обновление GUID базы.

Скачать исходный код

Наименование Файл Версия Размер
ОчисткаКэша
.epf 11,77Kb
67
.epf 11,77Kb 67 Скачать

На основе этой обработки.

Текст модуля

Процедура КнопкаВыполнитьНажатие(Кнопка)
	
	WSH = Новый COMobject("wscript.shell"); 
	ПрофильПользователя = WSH.ExpandEnvironmentStrings("%APPDATA%");//Возвращает используемое по умолчанию размещение данных приложений
	
	Каталог1CEStart = ПрофильПользователя + "\1C\1CEStart\";    
	КаталогСуществует = КаталогИлиФайлСуществует(Каталог1CEStart);    
	
	Если КаталогСуществует  = Ложь Тогда
		Сообщить("Не найден каталог инфрормационной базы. Очистка кэша невозможна.");
		Возврат;
	КонецЕсли;
	
	// Заменим GUID в списке баз на новый
	Файлibases = Каталог1CEStart + "ibases.v8i"; // путь к списку информационных баз пользователя
	Если КаталогИлиФайлСуществует(Файлibases) Тогда
		
		// найдём GUID текущей базы
		СписокБаз = Новый ТекстовыйДокумент;
		СписокБаз.Прочитать(Файлibases);
		
		ТекстФайла = СписокБаз.ПолучитьТекст();
		
		Позиция = Найти(ТекстФайла, СтрокаСоединенияИнформационнойБазы());
		Если Позиция = 0 Тогда
			Сообщить("Информационная база не найдена в ibases.v8i. Очистка кэша невозможна.");
			Возврат;
		Иначе    
			ТекстФайлаCut = Прав(ТекстФайла, СтрДлина(ТекстФайла) - Позиция + 1);
			Позиция = Найти(ТекстФайлаCut, "ID=");
			GUID = Сред(ТекстФайлаCut, Позиция + 3, 36);
			
			// Если надо обновить GUID
			Если ОбновитьGUID Тогда
				НовыйGUID = Новый УникальныйИдентификатор;
				
				// Если такой идентификатор уже есть - получим новый и снова проверим
				Пока Найти(ТекстФайла, НовыйGUID) > 0 Цикл
					НовыйGUID = Новый УникальныйИдентификатор;
				КонецЦикла;    
				
				Если Вопрос("Будет обновлён список баз.
					|Актуально только для баз из пользовательского списка баз!
					|Базы из общего списка баз не меняются!
					|Текущий GUID " + GUID + ".
					|Новый GUID " + НовыйGUID + ".
					|Продолжить?", РежимДиалогаВопрос.ДаНет) = КодВозвратаДиалога.Нет Тогда
					Возврат;
				КонецЕсли;    
				
				//Присвоим базе новый идентификатор
				ТекстФайлаНовый = СтрЗаменить(ТекстФайла, GUID, НовыйGUID);
				СписокБаз.УстановитьТекст(ТекстФайлаНовый);
				СписокБаз.Записать(Файлibases);
			КонецЕсли;
		КонецЕсли;
		
	Иначе
		Сообщить("Файл " + Файлibases + " не найден. Очистка кэша невозможна.");
		Возврат;
	КонецЕсли;
	
	// Создадим и запустим bat-файл, очищающий папку со старым кэшем
	// При этом, если обновляем GUID, то очистку делаем вне зависимости от ответа, чтобы не оставались ненужные папки
	Если Не ОбновитьGUID Тогда
		Если Вопрос("Будет очищена папка " + GUID + ". 
			|Программа будет завершена. Продолжить?", РежимДиалогаВопрос.ДаНет) = КодВозвратаДиалога.Нет Тогда
			Возврат;
		КонецЕсли;    
	КонецЕсли;    
	
	//КаталогGUID = ПрофильПользователя + "\1C\1Cv82\" + GUID + "\";
	КаталогGUID = ПрофильПользователя + "\1C\1Cv82\" + GUID;
	Если КаталогИлиФайлСуществует(КаталогGUID) Тогда
		
		ПутьКФайлуLck = КаталогGUID + "\1Cv8.lck";
		
		ТекстBatФайла = "@echo off
		|cls
		|cd \
		|Echo Ожидание снятия блокировки с файла 1Cv8.lck...
		|rem Файл работает следующим образом.
		|rem Сначала ждем 5х8=40 с., пока удалится файл 1Cv8.lck (удаляется при закрытии 1С), затем удаляем папку с кэшем.
		|rem Если файл не удаляется - завершаем работу программы.
		|set /a count=1
		|:flag
		|rem Если count > 8
		|if %count% gtr 8 goto end
		|if Not exist """ + ПутьКФайлуLck + """ goto go
		|ping -n 5 127.0.0.1 > NUL
		|call set /a count+=1
		|goto flag
		|:go
		//|rem Удаляем только файлы
		//|Del /F /Q """ + КаталогGUID + "\*.*""
		//|rem Удаляем только каталоги внутри
		//|for /d %%i in ("""+ КаталогGUID + "\*"") do rmDir /s /q ""%%i""
		|rem Удаляем основной каталог и всё, что в нём
		|Echo Удаление папки " + КаталогGUID + "...
		|rmDir """ + КаталогGUID + """ + /s /q
		|:end
		// Если надо после очистки запустить 1С, то убрать комментарий в следующих 2 строках и 2-х модулей в конце модуля, но при этом будет появлятся папка 00000000-0000-0000-0000-000000000000
		//|Echo Запускаем 1С
		//|start """" " + ПолучитьСтрокуЗапуска1С() + "
		|rem Удаляем этот файл
		|del %0
		|";
		
		БатФайл = Новый ТекстовыйДокумент;
		БатФайл.УстановитьТекст(ТекстBatФайла);
		БатФайл.Записать(КаталогВременныхФайлов() + "\ClearCache.bat", КодировкаТекста.OEM);
		ЗапуститьПриложение("""" + КаталогВременныхФайлов() + "\ClearCache.bat""");            
		ЗавершитьРаботуСистемы(Ложь);
		
	Иначе
		Сообщить("Каталог """ + КаталогGUID + """ не найден. Очистка кэша невозможна.");
		Возврат;
	КонецЕсли;    
	
КонецПроцедуры

// Проверяет существование каталога
// Параметры
//         Путь - путь к проверяемому каталогу
//
// Возвращаемое значение
//      Булево. Истина, если каталог существует, Ложь, если каталог не существует
//
Функция КаталогИлиФайлСуществует(Путь)
	
	КаталогНаДиске = Новый Файл(Путь);
	
	Если КаталогНаДиске.Существует() Тогда
		Возврат Истина;
	Иначе
		Возврат Ложь;
	КонецЕсли;    
	
КонецФункции

 

См. также

Удаление данных с отбором и построением дерева ссылок в базах 1С 8.1-8.3 УТ 10.3./11, БП 2/3, ЗУП 2.5/3, КА 1.1/2, УНФ 1.6/3.0

Чистка данных Системный администратор Программист Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 1С:Управление торговлей 10 1С:Управление торговлей 11 Платные (руб)

Данные обработки помогут Вам легко и, главное быстро, выполнить удаление любых данных в Ваших базах 1С на платформах 8.1-8.3. Обработки помогут легко просмотреть связи ссылок в виде дерева, выбрать что удалять, а что нет, используя любые отборы. Это позволит уменьшить объем лишней и не нужной информации в справочниках и документах, планах видов характеристик и др. объектах и облегчит работу с данными пользователям и Вам. Понятное расположение команд и настроек, в сочетании с описанием и справкой, еще упростят процесс. (Обновление от 04.10.2023, версия 4.2)

9600 руб.

22.02.2013    136762    249    144    

419

Универсальное выборочное удаление данных из базы 1С (любые конфигурации на упр.формах: БП 3.0, УТ 11, КА 2, ERP, УНФ, ЗУП 3, Розница и т.д.)

Чистка данных Программист Пользователь Платформа 1С v8.3 Управляемые формы 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Зарплата и кадры государственного учреждения 3 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x Платные (руб)

Обработка позволяет удобно выборочно удалить данные из базы 1С. Это могут быть как неиспользуемые элементы справочников, так и неактуальные организации. При этом есть возможность провести анализ пересечений документов с другими организациями и таким образом уберечься от того, что при удалении обороты по другой организации изменятся.

3350 руб.

28.11.2019    24707    49    16    

64

Выборочное удаление организаций из информационных баз 1С (управляемые формы), с удалением всех ссылающихся на эти организации данных

Чистка данных Системный администратор Программист Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Розница 3.0 Платные (руб)

Позволяет удалить организации из любых из информационных баз 1С на управляемых формах (БП 3.0, УТ 11, КА 2, ERP 2, ЗУП 3.0, УНФ, Розница 2.0 и пр.). Главное требование - программа должна содержать справочник "Организации". Реализован самый быстрый алгоритм непосредственного удаления объектов. Работает даже на базах большого размера. Для ускорения работы алгоритма не запускается проверка контроля ссылочной целостности. Проверку учета можно запустить отдельно с помощью дополнительной обработки. Необходимо перед удалением самостоятельно проверить базу на наличие перекрестных ссылок разных организаций в одном документе. Эту дополнительную обработку проверки перекрестных ссылок по запросу предоставляем бесплатно нашим покупателям.

3582 руб.

16.03.2015    114606    184    77    

220

Замена Номенклатуры в документах 1С+Характеристики для УНФ 1.6

Чистка данных Логистика, склад и ТМЦ Бухгалтер Пользователь Платформа 1С v8.3 План видов характеристик 1С:Комплексная автоматизация 1.х 1С:Управление производственным предприятием 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Платные (руб)

Настраиваемая обработка, позволяющая заменить пару: Номенклатура+Характеристика в 1С в документах, их движениях и независимых регистрах сведений. Без перепроведения. Поможет, если вы по каким-то причинам решили отказаться от характеристик

3600 руб.

04.08.2015    41459    89    70    

50

Удаление битых ссылок 1С в базе без монопольного режима

Чистка данных Программист Платформа 1С v8.3 Конфигурации 1cv8 Платные (руб)

Если в вашей информационной базе крутится очень много данных, или база должна быть доступна 24/7 (как в моем случае), или же вы боитесь запускать тестирование и исправление, НО существует потребность удалить битые ссылки, тогда эта обработка сможет Вам помочь. Обработка выявляет битые ссылки как в самих объектах метаданных, так и в их табличных частях(!), а так же может их удалить.

2400 руб.

23.08.2021    9435    16    3    

22

Удаление проводок удаленного документа

Чистка данных Системный администратор Платформа 1С v8.3 Конфигурации 1cv8 Россия Платные (руб)

Такое бывает? Удалили документ, а проводки (движения) остались? Эта простая обработка решает данную проблему.. почему по проводкам? да потому что обычно такие вещи замечают именно бухгалтера.на самом же деле данная обработка при нахождении документа удаленного или помеченного на удаление и имеющего движения очищает все движения без исключений.

1200 руб.

06.02.2012    35841    361    30    

30

Очистка регистров сведений от записей по помеченным на удаление элементам

Чистка данных Системный администратор Платформа 1С v8.3 Конфигурации 1cv8 Платные (руб)

в современных конфигурациях стало очень много регистров сведений, хранящих вспомогательную и периодическую информацию и администраторы информационных систем стали сталкиваться с проблемой удаления помеченных на удаление объектов, так как ссылки на них хранятся в многочисленных регистрах сведений. Помочь почистить базу от ненужных записей предназначенная данная внешняя обработка на управляемой форме, которая ищет записи во всех регистрах сведений по помеченным на удаление объектах и очищает по ним записи их после использования данной обработки дальше можно смело пользоваться типовой обработкой удаление помеченных на удаление и проблем с удалением не возникнет! Удачи всем!

1200 руб.

21.01.2022    7340    6    6    

11

Очистка кэша 1С. Исполнитель

Чистка данных Инструментарий разработчика Системный администратор Программист Платформа 1С v8.3 Абонемент ($m)

Очередная вариативная очистка кэша 1С с помощью Исполнителя 3.0.2.2.

1 стартмани

25.10.2023    4827    4    SerVer1C    26    

22
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. petrov_al 10 27.09.13 17:23 Сейчас в теме
Хоть и тема не новая но решение очень даже приличное.
2. AltF1 8 30.09.13 10:38 Сейчас в теме
Ключ запуска прописать для ярлыка.
При запуске пользователем ИБ - кэш будет чиститься.
3. spaminfostart 16 30.09.13 11:07 Сейчас в теме
(2) kiv82, да, но он будет чиститься каждый раз, что может не понравится пользователю, настраивающему сложные отчёты.
4. dyak84 30.09.13 11:39 Сейчас в теме
Автор подскажите а обстоит ситуация когда профиль 1С размещен не стандартно на диске D: Очистка кеша будет работать или нет. И еще такой вопрос как настройки имя последнего пользователя они тоже по идее будут стерті так ли ето.Зарание спасибо за ответ
5. spaminfostart 16 30.09.13 14:12 Сейчас в теме
(4) dyak84, должно работать, т. к. читаем используемое по умолчанию размещение данных приложений - папка AppData. При очистке кэша конечно имя последнего пользователя тоже теряется.
6. spaminfostart 16 02.10.13 11:19 Сейчас в теме
Готова другая обработка, предназначенная для встраивания в стороннюю конфигурацию. Актуально для закрытых конфигураций, в которых запрещён запуск внешних обработок.
Сделана на управляемых формах. Обошлось без батников, т. к. закрывать нужно не текущую конфигурацию (при попытке очистить кэш текущей - сообщит об ошибке совместного доступа).
Если надо - выложу.
Прикрепленные файлы:
7. wolfsoft 2422 02.10.13 13:20 Сейчас в теме
Плюсанул, может пригодится.
8. Schulz Hesse 18.06.14 03:41 Сейчас в теме
Пригодилось, благодарю!!!
9. esa35 89 10.02.16 18:39 Сейчас в теме
10. IrinaKostroma1 08.06.16 14:51 Сейчас в теме
Оставьте свое сообщение