Печатаем этикетки - быстро, просто и легко

16.09.18

Задачи пользователя - Этикетки, ценники

В сегодняшнем примере речь пойдет об автоматизации печати этикеток более простыми и легкими способами: Табличная часть "товары" обработки "Печать этикеток" может быть заполнена обоими способами. В данной статье описан метод передачи из документа и приема параметров в форме обработки "Печать этикеток"

Скачать файл

ВНИМАНИЕ: Файлы из Базы знаний - это исходный код разработки. Это примеры решения задач, шаблоны, заготовки, "строительные материалы" для учетной системы. Файлы ориентированы на специалистов 1С, которые могут разобраться в коде и оптимизировать программу для запуска в базе данных. Гарантии работоспособности нет. Возврата нет. Технической поддержки нет.

Наименование SM По подписке [?] Купить один файл
Печать этикетки прямо из документа
.epf 43,14Kb
7
7
2 SM
Скачать Купить за 2 150 руб.

1. Путем ввода штрихкода

Этикетки вводятся при вводе штрихкода при нажатии ENTER если зайти через операции, обработки, Печать Самоклеек.

2. Прямо из документа установки цен номенклатуры

Данные передаются в форму обработки для печати этикеток из документа "Установка цен номенклатуры в магазине" Во втором способе ввод по штрихкоду в табличную часть неактивен. он передает введенные данные из документа "Установка цен в магазине"


Печатаем этикетку прямо из документа.

Вызываем из общего модуля процедуру "ОткрытьФормуСамоклейкиБирки

Процедура КПТНапечататьСамоклейкиБирки(Кнопка)
    
    РаботаСДокументами.ОткрытьФормуСамоклейкиБирки(ЭтаФорма, Организация, ЭтотОбъект);
    
КонецПроцедуры

// Загружаем нашу обработку в конфигураторе в разделе прикладных объектов:

// ОБРАБОТКИ, -> ВСТАВИТЬ ВНЕШНЮЮ ОБРАБОТКУ, ОТЧЕТ.

// Переходим в общие модули и создаем общий модуль "Работа с документами"

// Текст процедуры прилагается далее. он размещается в общем модуле "Работа с документами"

 
Процедура ОткрытьФормуСамоклейкиБирки(Форма, Организация, ДокументОбъект) Экспорт

	
	Если Не ЗаписатьНовыйОбъектВФорме(Форма) Тогда
		
		Возврат;
		
	КонецЕсли;
	
	Если Форма.Модифицированность Тогда

		Проведен    = Метаданные.Документы.Содержит(ДокументОбъект.Метаданные()) И ДокументОбъект.Проведен;
		СтрПроведен = ?(Проведен, " и провести","");
		
		Ответ = Вопрос("Документ изменен. Для печати  ценников его необходимо записать"+ СтрПроведен +".
		               |Записать" + СтрПроведен + "?",
		               РежимДиалогаВопрос.ОКОтмена, , 
		               КодВозвратаДиалога.Отмена,
		               "Документ изменен");

		Если Ответ = КодВозвратаДиалога.ОК Тогда

			Если Проведен Тогда

				Попытка

					Форма.ЗаписатьВФорме(РежимЗаписиДокумента.Проведение);

				Исключение

					Предупреждение("Операция не выполнена!");
					Возврат;

				КонецПопытки;

			Иначе
				Форма.ЗаписатьВФорме();
			КонецЕсли;
			
		Иначе
			
			Возврат;

		КонецЕсли;
		
	КонецЕсли;
	
	ФормаПечатиЦенников = Обработки.ПечатьСамоклеек.ПолучитьФорму("ЭтикеткиСамоклейкиУЦНМка", Форма, Форма);
	Структура = Новый Структура;
	Структура.Вставить("Организация",Организация);
	//Структура.Вставить("Подпись",ДокументОбъект.Подпись);

	Структура.Вставить("Хран",ПоместитьВоВременноеХранилище(ДокументОбъект.Товары.Выгрузить()));
	ФормаПечатиЦенников.Параметр = Структура;
	ФормаПечатиЦенников.Открыть();
	
КонецПроцедуры

 
// Текст следующей процедуры позволяет принять передаваемые пареметры от формы документа.
// Размещается же он в форме самой обработки.

 
Процедура ПриОткрытии()

    Перем ЗаполнитьЦены;

    Перем НастройкиПостроителя;


    СтруктураНастроек = ВосстановитьЗначение("Обработка.ПечатьЦенников.Настройки");
    Если ТипЗнч(СтруктураНастроек) = Тип("Структура") Тогда
        СтруктураНастроек.Свойство("Организация", Организация);
        СтруктураНастроек.Свойство("ТипЦен", ТипЦен);
        СтруктураНастроек.Свойство("Валюта", Валюта);
        СтруктураНастроек.Свойство("ТолькоИмеющиесяВНаличии", ТолькоИмеющиесяВНаличии);
        СтруктураНастроек.Свойство("НастройкиПостроителя", НастройкиПостроителя);
    КонецЕсли;

    ЗаполнитьПостроительОтчета();

    Если НастройкиПостроителя <> Неопределено Тогда
        ПостроительОтчета.УстановитьНастройки(НастройкиПостроителя);
    КонецЕсли;

    Если ТипЗнч(Параметр) = Тип("Структура") Тогда
        Параметр.Свойство("ЗаполнитьЦены", ЗаполнитьЦены);
        Если ЗаполнитьЦены = Истина Тогда
            Если ПроверитьПараметрыЗаполненияЦен(Параметр.Свойство("ПечетьБезПроверкиЗаполненияПараметров")) Тогда
                ПерезаполнитьЦены();
            КонецЕсли;
        КонецЕсли;
    КонецЕсли;
    
    Если ТипЗнч(Параметр) = Тип("Структура") Тогда
         ОбработкаОбъект.Организация = Параметр.Организация;
         //ОбработкаОбъект.Подпись   = Параметр.Подпись;
         Таблица = ПолучитьИзВременногоХранилища(Параметр.Хран);
         ОбработкаОбъект.Товары.Загрузить(Таблица);
         Для каждого Эл Из ОбработкаОбъект.Товары Цикл
                    Эл.Печать = Истина;
         КонецЦикла;
     КонецЕсли; 

КонецПроцедуры // ПриОткрытии() 

СканерШК этикетка Разработка

См. также

Этикетки, ценники Программист Пользователь Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 Россия Управленческий учет Платные (руб)

Решение позволяет в шаблон этикетки с типом "Этикетка (обувь, одежда, табак...)" добавлять штрих-коды другого типа, например, GTIN в Code128.

4000 руб.

09.06.2021    15687    10    8    

14

Этикетки, ценники Пользователь Платформа 1С v8.3 Конфигурации 1cv8 Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Беларусь Украина Россия Управленческий учет Платные (руб)

Простая в использовании обработка для формирования и печати ценников и этикеток со штрих-кодом, с дополнительной ценой, для 1С8.х Большое разнообразие шаблонов печатных форм. Управляемая форма (Такси) + Обычный режим.

3588 руб.

11.11.2020    48746    56    44    

67

Этикетки, ценники Пользователь Платформа 1С v8.3 Управляемые формы 1С:Розница 2 1С:Управление нашей фирмой 1.6 Платные (руб)

Встроенная в конфигурации Розница 2.3 и УНФ 1.6 подсистема печати ценников по мне слишком неповоротлива и с усилиями поддается тонкой настройке, решил с нуля написать свою универсальную печать ценников для этих конфигураций.

2000 руб.

04.11.2019    28725    114    87    

53

Логистика, склад и ТМЦ Этикетки, ценники Пользователь Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Управленческий учет Абонемент ($m)

Выводит при печати этикетки складской ячейки в качестве штрихкода адрес ячейки вместо уникального идентификатора

1 стартмани

20.06.2024    577    2    Alexei_Siva    4    

6

Этикетки, ценники Программист Мобильная платформа Бесплатно (free)

Печать этикеток на принтер WiFi без драйвера.

20.01.2023    2186    aldar    0    

9

Этикетки, ценники Пользователь Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Управление нашей фирмой 3.0 Россия Управленческий учет Абонемент ($m)

Внешняя печатная форма для принтера этикеток. В отличие от базовой обработки для печати этикеток эта может выводить на печать дополнительные свойства справочника Номенклатура, а также в ней несложный программный код, что позволяет легко дорабатывать обработку под свои нужды.

2 стартмани

03.01.2023    3573    23    AndreyPonom    7    

11

Этикетки, ценники Пользователь Платформа 1С v8.3 1С:Розница 2 Розничная и сетевая торговля (FMCG) Россия Управленческий учет Абонемент ($m)

Архив с экспортными шаблонами этикеток (ценников) формата 58х40. Для тех, кто не хочет сам рисовать их.

3 стартмани

04.05.2022    13656    48    aximo    3    

12
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. bridgeuper178 22.04.16 13:12 Сейчас в теме
Сделано неплохо, на один видно вид ленту Ш=58 В=60?
А можно сделать чтобы было реализовано на несколько самых популярных типов лент?
2. goldencity178 8 22.04.16 13:16 Сейчас в теме
Следующая моя публикация как раз и посвящена решению этого вопроса. Там будет реализована печать как на нескольких типах лент, так и на специальной бумаге формата А4
3. goldencity178 8 24.04.16 06:07 Сейчас в теме
По вашему вопросу готова моя разработка. Вы можете заказать внедрение. интегрируется в течение около 2 часов
4. goldencity178 8 24.04.16 06:07 Сейчас в теме
о принципе ее работы будет рассказано в следующем постинге
5. cas 7 18.05.16 07:59 Сейчас в теме
Для УТ 10.3 не работает.

Вот этот код божественен:
ПечШирина = Мин(Макс(ПечШирина, ?(НЕ БольшойЦенник, 58, 58)), 58);
@lexandr; goldencity178; +2 Ответить
6. @lexandr 143 24.05.16 23:40 Сейчас в теме
(5) cas,
ПечШирина = Мин(Макс(ПечШирина, ?(НЕ БольшойЦенник, 58, 58)), 58);
Только годы практики и постоянного самосовершенствования дают такие результаты. Сарказм и ирония посещают инфостарт.:))
goldencity178; +1 Ответить
7. s_uu 22 28.12.16 15:13 Сейчас в теме
Добрый день, ваша обработка на Розница 1.0 работает?
8. goldencity178 8 14.01.17 06:49 Сейчас в теме
Да работает, можете скачивать и пользоваться
Оставьте свое сообщение