Бегство из Frontol в Далион или очередной день программиста

22.09.16

Интеграция - ККМ

Если к вам пришел маленький серый зайчик в виде сломанного жесткого диска, и вы забыли, что нужно быть нежными и пушистыми и делать копии, то эта статья для вас

Скачать файл

ВНИМАНИЕ: Файлы из Базы знаний - это исходный код разработки. Это примеры решения задач, шаблоны, заготовки, "строительные материалы" для учетной системы. Файлы ориентированы на специалистов 1С, которые могут разобраться в коде и оптимизировать программу для запуска в базе данных. Гарантии работоспособности нет. Возврата нет. Технической поддержки нет.

Наименование SM По подписке [?] Купить один файл
ЗагрузитьИзFrontolDBF
.epf 8,64Kb
14
14
1 SM
Скачать Купить за 1 850 руб.

Немножко предыстории.

Все началось с того, что сломался очередной жесткий диск и, как всегда, копий нет. Но есть рабочая касса под руководством программы FRONTOL 4 и нужно быстро реанимировать 1С хотя бы в части справочника номенклатуры, ну и цен соответственно.

Учет ведется в программе Далион:УНО (ПРО, Сеть)

Для того, чтобы все это осуществить, нам понадобится программа, которая умеет экспортировать из базы данных INTERBASE/FIRIBERD в Exсel или DBF,  я использовал вот такую:

IBExpert (http://www.ibexpert.net/ibe/index.php) (не спрашивайте, где брать не демо).

  1. Экспортируем следующие таблицы: SPRT -- SPRT.DBF, PRICEDATA -- PRICEDAT.DBF, BARCODE -- BARCODE.DBF, REMAIN -- REMAIN.DBF (для тех, кто использует сложные разрезы цен, думайте сами)
  2. Восстанавливаем чистую базу из шаблона или другим способом
  3. Запускаем обработку указываем ей каталог (жестко прописан, выбор не работает).
  4. После всего этого работать будет все, кроме выгрузки  в кассу.

Чтобы заработала выгрузка в кассу, нужно или заново перезаписать каждую группу, или написать обработку, которая заполнит регистр сведений "АссортиментСкладов"

Для всех, кто будет просить скачать ему обработку у друзей, привожу ее полный код. Не ленитесь, господа.

Функция ОткрытьТаблицуDBF(ИмяТаблицы)
    xbase = Новый xBase; xBase.ОткрытьФайл(ИмяТаблицы);
    Если xBase.Открыта() Тогда    Возврат xBase; иначе Возврат Неопределено; КонецЕсли;
КонецФункции

Процедура СкопироватьxBaseВТЗ(xBase,ТЗн)
    xBase.Первая();
    Пока НЕ xBase.вКонце() Цикл
        НоваяСтрока = ТЗн.Добавить();ЗаполнитьЗначенияСвойств(НоваяСтрока,xBase); xBase.Следующая();    
    КонецЦикла;
КонецПроцедуры

Процедура КнопкаВыполнитьНажатие(Кнопка)
    xBaseТовары         = ОткрытьТаблицуDBF(СокрЛП(КаталогТаблиц)+"SPRT.DBF");
    xBaseШтрихКоды         = ОткрытьТаблицуDBF(СокрЛП(КаталогТаблиц)+"BARCODE.DBF");
    xBaseЦены             = ОткрытьТаблицуDBF(СокрЛП(КаталогТаблиц)+"PRICEDAT.DBF");
    xBaseЦеныОстатка     = ОткрытьТаблицуDBF(СокрЛП(КаталогТаблиц)+"REMAIN.DBF");
    Если xBaseТовары=Неопределено или xBaseШтрихКоды =Неопределено или
        xBaseЦены =Неопределено или xBaseЦеныОстатка =Неопределено Тогда
        Сообщить("не могу открыть таблицы SPRT.DBF BARCODE.DBF PRICEDAT.DBF REMAIN.DBF");
        Возврат;
    КонецЕсли;
    
    ТзнШтрихКоды = Новый таблицаЗначений;
    ТзнШтрихКоды.Колонки.Добавить("ID",Новый ОписаниеТипов("Число"));
    ТзнШтрихКоды.Колонки.Добавить("WareID",Новый ОписаниеТипов("Число"));
    ТзнШтрихКоды.Колонки.Добавить("Barcode",Новый ОписаниеТипов("Строка"));
    ТзнШтрихКоды.Колонки.Добавить("Factor",Новый ОписаниеТипов("Число"));
    
    ТзнЦены = Новый таблицаЗначений;
    ТзнЦены.Колонки.Добавить("ID",Новый ОписаниеТипов("Число"));
    ТзнЦены.Колонки.Добавить("Price",Новый ОписаниеТипов("Число"));
    ТзнЦены.Колонки.Добавить("RemainID",Новый ОписаниеТипов("Число"));    //брать из таблице remain поле ID
    
    ТзнЦеныОстатка = Новый таблицаЗначений;
    ТзнЦеныОстатка.Колонки.Добавить("ID",Новый ОписаниеТипов("Число"));
    ТзнЦеныОстатка.Колонки.Добавить("WareID",Новый ОписаниеТипов("Число"));
    
    ТзнТовары = Новый ТаблицаЗначений;
    ТзнТовары.Колонки.Добавить("ID",Новый ОписаниеТипов("Число"));
    ТзнТовары.Колонки.Добавить("PARENTID",Новый ОписаниеТипов("Число"));
    ТзнТовары.Колонки.Добавить("Code",Новый ОписаниеТипов("Число"));
    ТзнТовары.Колонки.Добавить("Name",Новый ОписаниеТипов("Строка"));
    ТзнТовары.Колонки.Добавить("Text",Новый ОписаниеТипов("Строка"));
    ТзнТовары.Колонки.Добавить("Flags",Новый ОписаниеТипов("Число"));    //Flags = //9727 весовой товар
                                                                        //9726 - обычный товар  254 - группа
    ТзнТовары.Колонки.Добавить("IsWare",Новый ОписаниеТипов("Число"));    // 1- Товар
    ТзнТовары.Колонки.Добавить("Номенклатура",Новый ОписаниеТипов("СправочникСсылка.Номенклатура"));
    
    СкопироватьxBaseВТЗ(xBaseШтрихКоды,ТзнШтрихКоды);
    СкопироватьxBaseВТЗ(xBaseЦены,ТзнЦены);
    СкопироватьxBaseВТЗ(xBaseЦеныОстатка,ТзнЦеныОстатка);
    
    Начатьтранзакцию();
    
    ДокАкт = Документы.АктПереоценки.СоздатьДокумент();
    ДокАкт.Дата = Рабочаядата;
    ЗаполнитьШапкуДокумента(ДокАкт, ПараметрыСеанса.ТекущийПользователь);
    ДокАкт.ВидОперации = Перечисления.ВидыОперацийАктПереоценки.Переоценка;
    ДокАкт.ТОСоздания = ПараметрыСеанса.ТекущийТО;
    УстановитьНомерДокумента(ДокАкт.ЭтотОбъект);
    ДокАкт.ЗаписыватьРасценку = УправлениеРИБ.ТребуетсяПодтверждениеПереоценки(ДокАкт);
    
    xBaseТовары.Первая();
    Пока НЕ xBaseТовары.вКонце() Цикл
        НоваяСтрока = ТзнТОвары.Добавить();
        ЗаполнитьЗначенияСвойств(НоваяСтрока,xBaseТовары);
        
        Если xBaseТовары.IsWare<>1 Тогда    
            НовЭлем = Справочники.Номенклатура.СоздатьГруппу();
            НовЭлем.Код = xBaseТовары.Code;
            НовЭлем.Наименование = xBaseТовары.Name;
            НовЭлем.Записать();
            
            НоваяСтрока.Номенклатура = НовЭлем.Ссылка;    // для идетификации групп
            
            Если  xBaseТовары.PARENTID <> 0  Тогда
                НайденаяГруппа = ТзнТовары.Найти(xBaseТовары.PARENTID,"ID" );
                Если НЕ НайденаяГруппа=неопределено Тогда
                    НовЭлем.Родитель =НайденаяГруппа.Номенклатура;
                    НовЭлем.Записать();
                КонецЕсли;
            КонецЕсли;
        КонецЕсли;
        xBaseТовары.Следующая();
    КонецЦикла;
    
    Для каждого СтрокаТзн Из ТзнТОвары Цикл
        Если СтрокаТзн.IsWare <> 1 Тогда
            Продолжить;
        КонецЕсли;
        НовЭлем = Справочники.Номенклатура.СоздатьЭлемент();
        НовЭлем.Код             = СтрокаТзн.Code;
        НовЭлем.Наименование     = СтрокаТзн.Name;
        НовЭлем.НаименованиеПолное = СтрокаТзн.Text;
        
        НовЭлем.КатегорияТовара    = Справочники.КатегорииТоваров.УчетПоХарактеристикамНеВедется;
        Если Константы.УстанавливатьПроизводителяПоШК.Получить() Тогда
            НовЭлем.Производитель = Справочники.КлассификаторСтранМира.ПустаяСсылка();
        ИначеЕсли Не ЗначениеЗаполнено(НовЭлем.Производитель) Тогда
            НовЭлем.Производитель =  Константы.ОсновнойПроизводитель.Получить();
        КонецЕсли;
        НовЭлем.СтавкаНДС          = Константы.ОсновнаяСтавкаНДС.Получить();
        НовЭлем.ФирмаФР            = Константы.УправленческаяФирма.Получить();
        НовЭлем.ГруппаТоваровДляПривязкиКФР = Справочники.ГруппыТоваровДляПривязкиКФР.ОсновнаяГруппаТоваров;
        НовЭлем.ОсновноеИзображение = Справочники.ХранилищеДополнительнойИнформации.ПустаяСсылка();
            
        Если СтрокаТзн.Flags=9726 Тогда
            БазоваяЕдиницаОКЕИ = Константы.ОсновнаяЕдиницаОКЕИ.Получить();
        ИначеЕсли СтрокаТзн.Flags=9727 Тогда  
            БазоваяЕдиницаОКЕИ = Константы.ОсновнаяЕдиницаОКЕИВес.Получить();
            НовЭлем.ВыгружатьВВесы                 = истина;
            НовЭлем.РазрешеноДробноеКоличество     = истина;
            НовЭлем.ШтрихКодВключаетКоличество     = истина;
        Иначе
            БазоваяЕдиницаОКЕИ = Константы.ОсновнаяЕдиницаОКЕИ.Получить();
        КонецЕсли;
        НовЭлем.ОбменДанными.Загрузка = Истина;    //чтоб дал записать единицы измерения
        НовЭлем.Записать();
        
        НовЕдиница = Справочники.ЕдиницыИзмерения.СоздатьЭлемент();
        НовЕдиница.Владелец                 = НовЭлем.Ссылка;
        НовЕдиница.ЕдиницаПоКлассификатору     = БазоваяЕдиницаОКЕИ;
        НовЕдиница.Наименование             = БазоваяЕдиницаОКЕИ;
        НовЕдиница.Коэффициент                 = 1;
        НовЕдиница.Записать();
        
        НовЭлем.БазоваяЕдиницаИзмерения = НовЕдиница.Ссылка;
        НовЭлем.ЕдиницаИзмеренияОтчетов = НовЕдиница.Ссылка;
        НовЭлем.ЕдиницаИзмеренияЗаказов = НовЕдиница.Ссылка;
        НовЭлем.Записать();
        
        СтрокаТзн.Номенклатура = НовЭлем.Ссылка;
        
        Если  СтрокаТзн.PARENTID <> 0  Тогда
            НайденаяГруппа = ТзнТовары.Найти(СтрокаТзн.PARENTID,"ID" );
            Если НЕ НайденаяГруппа=неопределено Тогда
                НовЭлем.Родитель =НайденаяГруппа.Номенклатура;
                НовЭлем.Записать();
            КонецЕсли;
        КонецЕсли;
        
        НайденныеШтрихКоды = ТзнШтрихКоды.НайтиСтроки(Новый Структура("WareID",СтрокаТзн.ID));
        Для каждого СтрокаШтрихКод Из НайденныеШтрихКоды Цикл
            
            НаборЗаписей = РегистрыСведений.Штрихкоды.СоздатьНаборЗаписей();
            НаборЗаписей.Отбор.ШтрихКод.Установить(СокрЛП(СтрокаШтрихКод.Barcode));
            НаборЗаписей.Отбор.Номенклатура.Установить(НовЭлем.Ссылка);
            НаборЗаписей.Записать();
            
            НоваяЗапись = НаборЗаписей.Добавить();
            НоваяЗапись.Номенклатура     = НовЭлем.Ссылка;
            НоваяЗапись.Штрихкод         = СокрЛП(СтрокаШтрихКод.Barcode);
             НоваяЗапись.ТипШтрихкода     = ПланыВидовХарактеристик.ТипыШтрихкодов.EAN13;
            Новаязапись.ЕдиницаИзмерения= НовЭлем.БазоваяЕдиницаИзмерения;
            НаборЗаписей.Записать();
            
        КонецЦикла;
        //самое трудное
        найденыйостатокЦены = ТзнЦеныОстатка.Найти(СтрокаТзн.ID,"WareID");
        Если НЕ найденыйостатокЦены = Неопределено Тогда
            НайденнаяЦена             = ТзнЦены.найти(найденыйостатокЦены.ID,"RemainID");
            НоваяЦена                 = ДокАкт.Товары.Добавить();
            НоваяЦена.Номенклатура     = НовЭлем.Ссылка;
            НоваяЦена.Цена             = НайденнаяЦена.Price;
            //Сообщить("найденая цена "+СтрокаТзн.Code+" "+СтрокаТзн.Name+" "+НайденнаяЦена.Price);
        КонецЕсли;
    КонецЦикла;
    ДокАкт.Записать(РежимЗаписиДокумента.Запись);
    ЗафиксироватьТранзакцию();
КонецПроцедуры

Процедура КаталогТаблицНачалоВыбора(Элемент, СтандартнаяОбработка)
КонецПроцедуры

КаталогТаблиц = "D:\Supermarket\";

ВОТ ТАК И ЗАКОНЧИЛИСЬ ОЧЕРЕДНЫЕ БЕССОННЫЕ ВЫХОДНЫЕ.

Доработок не будет.

frontol Далион

См. также

ККМ Кассовые операции Розничная торговля Системный администратор Программист Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Бухгалтерия государственного учреждения 1С:Бухгалтерия 1.6 1С:Бухгалтерия автономного учреждения 1С:CRM ПРОФ, КОРП Россия Платные (руб)

Универсальная обработка для обслуживания любых фискальных регистраторов (ККТ), в том числе Веб сервер АТОЛ. Работает в соответствии с 54-ФЗ. (ФФД 1.0, ФФД 1.05, ФФД 1.1). Подключайте любую онлайн кассу к практически любой конфигурации. Нет необходимости обновлять 1С. Можно бесплатно скачать и протестировать. Может работать одновременно с несколькими онлайн-кассами, либо одной с разных рабочих мест. (через RDP, TCP\IP или веб-сервер) Позволяет разделить один чек сразу на несколько ККТ или на несколько систем налогообложения. Поддерживает разрешительный режим. Можно настроить собственный шаблонов чека. Можно использовать эквайринг там, где он не поддерживается. Работает на LINUX и Windows ЭМУЛЯТОР + ЭКВАЙРИНГ + МАРКИРОВКА + ПОДДЕРЖКА ФФД 1.2

6000 руб.

27.02.2017    787904    4749    9507    

2816

ККМ Кассовые операции Розничная торговля Системный администратор Программист Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Бухгалтерия государственного учреждения 1С:Бухгалтерия автономного учреждения Россия Платные (руб)

Обработка осуществляет обслуживание ККТ АТОЛ, Штрих и Меркурий для конфигураций "УТ 10.3", "КА 1.1", "УПП 1.3", "Розница 1.0", "БП 2.0" и других отраслевых решений, построенных на основе указанных выше конфигурациях. Поддерживает возможность параллельно пробития чеков на одной ККМ несколькими пользователями. Поддерживает Веб-сервер Атол. Соответствует требованиям 54-ФЗ. Поддерживает ФФД 1.0, 1.05, 1.1 и 1.2. Разделяет чеки по нескольким СНО. Поддерживает механизмы подключения ККТ по TCP/IP, для работы через RDP или интернет. Поддержка маркировки и разрешительного режима.

5400 руб.

25.05.2015    330362    1898    3031    

1013

ККМ Розничная торговля Системный администратор Программист Платформа 1С v8.3 Оперативный учет 1С:Розница 2 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Обмен между 1С:Розница и Frontol 6 при торговле от нескольких организаций, а также ряд других полезных функций. Данный модуль синхронизации незаменим для тех, кто ведёт учет по нескольким организациям в 1С:Розница, а на РМК (рабочем месте кассира) установлен Frontol или планируется его установка. Подходит для 1С:Розница 2.3 / 3.0, 1С:УНФ 3.0

1500 руб.

22.03.2019    81595    446    478    

174

ККМ Кассовые операции Розничная торговля Обмен с ГосИС Программист Бухгалтер Пользователь Бухгалтерский учет Оперативный учет Управляемые формы 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Платные (руб)

Расширение конфигурации для УТ 11.4, 11.5, КА 2.4, 2.5, Розница 3.0, 2.3 и 2.2, УНФ 1.6, УНФ 3x, ERP 2.4, 2.5, БП 3, БГУ2 (Управляемые формы) позволяет выполнять печать кассовых чеков на одну ККМ 54-ФЗ с нескольких рабочих мест. НИКАКИХ НАСТРОЕК В РАЗРАБОТКЕ - ПОДКЛЮЧИЛ И ПЕЧАТАЙ. Если у вас несколько отделов и одна ККМ - печатайте на одной ККМ! Если у вас две ККМ и одна поломалась - печатайте на одной ККМ, пока ремонтируете другую!

4000 руб.

27.08.2018    119038    1015    571    

845

ККМ Кассовые операции Розничная торговля Системный администратор Программист Пользователь Платформа 1С v8.3 Конфигурации 1cv8 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Рестораны, кафе и фаст-фуд Россия Платные (руб)

«Сервер ККМ» позволяет приложениям работать с фискальными регистраторами по локальной сети или интернет, организовать печать на одном ККМ с нескольких рабочих мест. Поддержка драйверов Атол, Штрих и VikiPrint. Поддержка 54-ФЗ и разрешительного режима, ФФД 1.05,1.2. Подключается к 1С Торговля и склад 7.7, 1С:УТ 10/11, 1С:УНФ, 1С:Розница 1/2, 1С:БП 2/3, 1С КА 1/2., 1С:ERP, УПП. Ускоряет печать из терминального сеанса Windows. Работает с разрешительным режимом даже из старых конфигураций. Предоставляет REST API для печати через веб-сервис.

3000 руб.

02.09.2016    134444    130    192    

171

Кассовые операции ККМ Системный администратор Программист Бухгалтер Платформа 1С v7.7 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv7 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Программа для управления ККМ Атол и Штрих нового поколения (он-лайн ККТ под 54-ФЗ) с помощью текстового файла (ini файла) с изменениями включена 1 лицензия Для любых программ, которые умеют работать с текстовыми файлами. Внутри комплекта есть готовые к использованию обработки

4800 руб.

31.07.2017    168359    577    605    

199

Кассовые операции ККМ Пользователь Платформа 1С v8.3 1С:Управление торговлей 11 Розничная и сетевая торговля (FMCG) Россия Управленческий учет Платные (руб)

Расширение для 1С:Управление торговлей 11.5, которое позволяет пробивать чеки ККМ и списывать товар с разных складов. Склад списание товара можно указывать в табличной части рабочего места кассира (РМК).

5880 руб.

12.04.2023    8591    36    2    

31

ККМ Пользователь Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 Россия Платные (руб)

Создание электронных чеков по документам 1С РеализацияТоваров (РасходнаяНакладная), КорректировкаРеализации, СчетНаОплату, ЗаказКлиента, ЧекККМ. Соответствует требованиям 54-ФЗ. Одна облачная касса может использоваться всеми подразделениями организации, без привязки к рабочим местам. Электронные чеки отправляются на email клиента и всегда доступны в 1С, по требованию можно распечатать. Легкая настройка: после регистрации кассы на сайте АТОЛ.ОНЛАЙН, в обработке необходимо указать логин, пароль и идентификатор группы ККТ (берутся в личном кабинете АТОЛ.ОНЛАЙН). Одну кассу можно использовать с 1С при расчетах с физ. и юр. лицами и для интернет-магазина. Эквайринг позволяет делать ссылки на форму оплаты по документам 1С и проверять состояние оплаты.

21600 руб.

23.08.2022    11379    28    4    

26
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. maljaev 789 20.01.17 11:54 Сейчас в теме
Спасибо, помогло раскрутить связку tranzt-sprt-remain-pricedata при построении запроса.
P.S. Кстати да, а чего ADODB и запросы не юзаешь-то? Зачем этот изврат с DBF?
2. sodrk 08.09.21 23:41 Сейчас в теме
Спасибо за обработку, круто выручила. Правда, что-то с кодировкой и при загрузке номенклатуры вместо русских букв загрузились кракозябры, потом исправил загрузкой из табличного документа с перезаписью наименований. 3 минуты работы
Оставьте свое сообщение