Отчет по метаданным. Количество элементов справочников, документов, регистров. Отбор по периоду

Публикация № 1010276

Администрирование - Администрирование данных 1С - Статистика базы данных

Метаданные Анализ БД

Отчет по метаданным. Количество элементов справочников, документов, регистров. Есть отбор по периоду для периодических метаданных. Можно использовать для анализа при переносе данных. 8.3.13.1644.

Отчет строится универсально по метаданным. В данный момент реализовано для справочников. документов, регистров сведений и накоплений. Возможно добавить свои. Показывается количество записей в каждом объекте метаданных. Сделано для сравнения при переносе данных и текущего объема в информационной базе. Тестировалось на 8.3.13.1644.

Сначала делается обход по метаданным. Запросом в цикле получаем количество элементов, собираем в таблицу. Полученную таблицу передаем в СКД для вывода отчета. За счет того, что таблица с данными уже загружена в СКД, можете только настроить структура под себя и нужный отчет готов. Код открытый.

Для желающих сделать все самостоятельно выкладываю код для формирования внешней таблицы, дальше программно формируете отчет на СКД и подключаете внешние данные.

 

Функция ПолучитьТаблицуМетаданных(ПериодЗапроса)
	
	ТЗ = Новый ТаблицаЗначений;
		
	ОписаниеЧисла = Новый ОписаниеТипов("Число");
    ОписаниеСтроки = Новый ОписаниеТипов("Строка");   
    ОписаниеДаты = Новый ОписаниеТипов("Дата");      
    ОписаниеБулева = Новый ОписаниеТипов("Булево");
	
	ТЗ.Колонки.Добавить("Тип",ОписаниеСтроки);
	ТЗ.Колонки.Добавить("Вид",ОписаниеСтроки);
	ТЗ.Колонки.Добавить("Периодичность",ОписаниеБулева);
	ТЗ.Колонки.Добавить("Количество",ОписаниеЧисла);
	
	ТипМД = "Справочник";
	Для Каждого Эл Из Метаданные.Справочники Цикл
		ВидМД = Эл.Имя;
		Запрос = Новый Запрос;
		Запрос.Текст = "Выбрать ЕстьNULL(Сумма(1),0) КАК Количество Из " + ТипМД + "." +ВидМД;
		РезультатЗапроса = Запрос.Выполнить();
		Выборка = РезультатЗапроса.Выбрать();
		Выборка.Следующий();
		
		НоваяСтрока = ТЗ.Добавить();
		НоваяСтрока.Тип = ТипМД;
		НоваяСтрока.Вид = Эл.Имя;
		НоваяСтрока.Периодичность = Ложь;
		НоваяСтрока.Количество = Выборка.Количество;
	КонецЦикла;
	
	ТипМД = "Документ";
	Для Каждого Эл Из Метаданные.Документы Цикл
		ВидМД = Эл.Имя;
		Запрос = Новый Запрос;
		Запрос.Текст = "Выбрать ЕстьNULL(Сумма(1),0) КАК Количество Из " + ТипМД + "." +ВидМД;
		Если ПериодЗапроса <> Неопределено Тогда
			Запрос.Текст = Запрос.Текст + " ГДЕ Дата >= &НачДата И Дата <= &КонДата";
			Запрос.УстановитьПараметр("НачДата",ПериодЗапроса.ДатаНачала);
			Запрос.УстановитьПараметр("КонДата",ПериодЗапроса.ДатаОкончания);
		КонецЕсли;		
		РезультатЗапроса = Запрос.Выполнить();
		Выборка = РезультатЗапроса.Выбрать();
		Выборка.Следующий();
		
		НоваяСтрока = ТЗ.Добавить();
		НоваяСтрока.Тип = ТипМД;
		НоваяСтрока.Вид = Эл.Имя;
		НоваяСтрока.Периодичность = Истина;
		НоваяСтрока.Количество = Выборка.Количество;
	КонецЦикла;
	
	ТипМД = "РегистрСведений";
	Для Каждого Эл Из Метаданные.РегистрыСведений Цикл
		ВидМД = Эл.Имя;
		Запрос = Новый Запрос;
		Запрос.Текст = "Выбрать ЕстьNULL(Сумма(1),0) КАК Количество Из " + ТипМД + "." +ВидМД;
		
		Периодичность = Не Эл.ПериодичностьРегистраСведений = Метаданные.СвойстваОбъектов.ПериодичностьРегистраСведений.Непериодический;
		Если Периодичность И ПериодЗапроса <> Неопределено Тогда
			Запрос.Текст = Запрос.Текст + " ГДЕ Период >= &НачДата И Период <= &КонДата";
			Запрос.УстановитьПараметр("НачДата",ПериодЗапроса.ДатаНачала);
			Запрос.УстановитьПараметр("КонДата",ПериодЗапроса.ДатаОкончания);
		КонецЕсли;		    		
		
		РезультатЗапроса = Запрос.Выполнить();
		Выборка = РезультатЗапроса.Выбрать();
		Выборка.Следующий();
		
		НоваяСтрока = ТЗ.Добавить();
		НоваяСтрока.Тип = ТипМД;
		НоваяСтрока.Вид = Эл.Имя;
		НоваяСтрока.Периодичность = Периодичность;
		НоваяСтрока.Количество = Выборка.Количество;
	КонецЦикла;
	
	ТипМД = "РегистрНакопления";
	Для Каждого Эл Из Метаданные.РегистрыНакопления Цикл
		ВидМД = Эл.Имя;
		Запрос = Новый Запрос;
		Запрос.Текст = "Выбрать ЕстьNULL(Сумма(1),0) КАК Количество Из " + ТипМД + "." +ВидМД;
		
		Если ПериодЗапроса <> Неопределено Тогда
			Запрос.Текст = Запрос.Текст + " ГДЕ Период >= &НачДата И Период <= &КонДата";
			Запрос.УстановитьПараметр("НачДата",ПериодЗапроса.ДатаНачала);
			Запрос.УстановитьПараметр("КонДата",ПериодЗапроса.ДатаОкончания);
		КонецЕсли;		
		
		РезультатЗапроса = Запрос.Выполнить();
		Выборка = РезультатЗапроса.Выбрать();
		Выборка.Следующий();
		
		НоваяСтрока = ТЗ.Добавить();
		НоваяСтрока.Тип = ТипМД;
		НоваяСтрока.Вид = Эл.Имя;
		НоваяСтрока.Периодичность = Истина;
		НоваяСтрока.Количество = Выборка.Количество;
	КонецЦикла;
	
	Возврат ТЗ;
	
КонецФункции

 

Скачать файлы

Наименование Файл Версия Размер
Отчет по метаданным. Количество элементов справочников, документов, регистров. Отбор по периоду.

.erf 7,39Kb
16
.erf 7,39Kb 16 Скачать

Специальные предложения

Оставьте свое сообщение

См. также

Виды заполненных документов и справочников, УФ Промо

Статистика базы данных v8 v8::УФ v8::СКД 1cv8.cf Абонемент ($m)

Количество документов и справочников в любой базе. Отборы, переход в журнал с отбором.

1 стартмани

04.05.2008    28750    214    MaxS    12    

Отчет по структуре базы данных 1С (обычные и управляемые формы)

Статистика базы данных v8 1cv8.cf Абонемент ($m)

Отчет по структуре базы данных 1С показывает количество записей во всех таблицах базы данных с группировкой по типу таблицы и названию объекта.

1 стартмани

04.08.2020    2663    18    Denr83    0    

Сведения об информационной базе (обычные и управляемые формы)

Статистика базы данных v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработка показывает сведения об информационной базе.

1 стартмани

17.02.2020    3834    2    Denr83    0    

Статистика количества записей базы данных (ссылочные объекты и регистры)

Статистика базы данных v8 v8::УФ 1cv8.cf Россия Абонемент ($m)

Простой отчет, который выводит в таблицу значений на форму данные о количестве объектов и записей регистров. Работает на управляемых формах, от конфигурации не зависит. Можно зарегистрировать как внешний отчет в базе и вывести в меню.

1 стартмани

29.01.2020    3972    5    user1286683    1    

Список объектов информационной базы

Статистика базы данных v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработка по получению списка объектов информационной базы. Для обычных и управляемых форм.

1 стартмани

23.01.2020    3779    13    Mike1978    0    

Статистика документов на СКД для любой конфигурации

Статистика базы данных v8 v8::СКД 1cv8.cf Абонемент ($m)

Отчет формирует статистику документов. Делает это быстро даже на больших объемах. Работает в любых конфигурациях на платформах 8.*. Полезен для оценки объемов документов. Использует СКД со всеми вытекающими возможностями отбора, сортировки, группировки, представления и т.д. ...

1 стартмани

21.01.2020    4270    25    bme    0    

Анализ трудозатрат пользователей. Подсчет количества введенных документов с учетом табличных частей

Анализ учета Учет рабочего времени Учет рабочего времени Статистика базы данных v8 БП2.0 БП3.0 Россия БУ Абонемент ($m)

Данный внешний отчет предназначен для подсчета введенной информации работниками организации. Будет полезна руководителю организации, главному бухгалтеру.

1 стартмани

04.01.2020    5460    12    kj6370    6    

Количество документов (каждого вида) в базе и элементов справочников (каждого вида)

Статистика базы данных v8 v8::УФ УПП1 КА2 Россия Абонемент ($m)

Обработка показывает количество элементов справочников и документов каждого вида с отбором по организации или по всей базе, обычное и управляемое приложение.

1 стартмани

24.12.2019    4168    19    user1233211    3    

Данные в хранилище значений

Статистика базы данных v8 v8::СКД 1cv8.cf Россия Абонемент ($m)

Обработка, показывающая размер, занимаемый данными типа Хранилище значения.

1 стартмани

11.12.2019    5988    12    kosmo0    0    

Статистика подключений пользователей за период

Статистика базы данных v8::УФ Розница БП3.0 Россия Абонемент ($m)

Доработка формирует отчет по сеансам пользователей в разрезе выбранных баз.

1 стартмани

14.10.2019    4803    1    VslavKup    0    

Статистика объектов информационных баз 1C 8.x (обычные и управляемые формы, СКД)

Статистика базы данных v8 v8::УФ v8::СКД 1cv8.cf Абонемент ($m)

Внешний универсальный отчет по статистике объектов информационных баз 1C 8.x для обычных и управляемых форм с возможностью группировки по периодам.

1 стартмани

08.08.2019    6101    45    as.1c.nik    3    

Количество активных пользователей

Статистика базы данных v8 v8::СКД 1cv8.cf Абонемент ($m)

Отчет СКД в форме таблицы на основе регистров сведений ЗамерыВремени, ЗамерыВремениТехнологические.

1 стартмани

07.08.2019    4900    1    Mari_Kuznetzova    1    

Количество документов за период

Статистика базы данных v8 v8::УФ v8::СКД 1cv8.cf Россия Абонемент ($m)

Отчет показывает типы используемых документов в информационной базе за выбранный период и их количество по месяцам. Есть отбор по признаку документа ("проведен"/"распроведен"/"помечен на удаление"). Отчет универсальный подойдет для любой конфигурации.

2 стартмани

12.07.2019    6552    45    trntv    4    

Количество элементов в базе по метаданным и их размер для файловой информационной базы

Статистика базы данных v8 1cv8.cf Абонемент ($m)

В версии платформы 8.3.15, вышедшей 26.06.2019 (8.3.15.1489), была реализована возможность получить (оценить) размер данных, которые они занимают в таблицах СУБД - метод глобального контекста ПолучитьРазмерДанныхБазыДанных(). В данной обработке реализована данная возможность.

1 стартмани

27.06.2019    7885    144    BurlakovIvan    0    

Статистика по присоединенным файлам. Бухгалтерия 3

Статистика базы данных v8 v8::СКД БП3.0 Россия Абонемент ($m)

Формирует статистику загруженных в базу файлов в Бухгалтерии 3

1 стартмани

23.06.2019    6011    7    shurubchik    0    

Количество документов за период (Управляемые + Обычные формы, все конфигурации)

Статистика базы данных v8 v8::УФ 1cv8.cf Абонемент ($m)

Представляю вашему вниманию маленькую но быструю и полезную обработку. Эта обработка выводит количество документов за произвольный период. Берутся все документы конфигурации. В сообщения выводятся: Представление документа, имя документа (в конфигураторе), количество документов за выбранный период. Обработка работает в обычных формах и управляемых формах. Для запуска в обычном приложении, а также в управляемом приложении (толстый клиент) достаточно открыть файл обработки. Для запуска в тонком клиенте, обработку необходимо регистрировать в конфигурации как встроенную обработку.

1 стартмани

20.06.2019    5611    7    pvlunegov    1    

Размер файлов хранилища

Статистика базы данных v8 1cv8.cf Абонемент ($m)

Обработка предназначена для вычисления объема информации, расположенного в справочнике ХранилищеДополнительнойИнформации для обычных форм.

1 стартмани

11.06.2019    7426    9    needmic    4    

Количество документов и справочников с отбором по организации для обычных и управляемых форм

Статистика базы данных v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработка позволяет вывести количество документов и справочников информационной базы с отбором по организации для обычных и управляемых форм.

1 стартмани

08.06.2019    6305    17    Dadriel619960    3    

Базомер (показывает количество записей в таблицах)

Статистика базы данных v8 1cv8.cf Россия Абонемент ($m)

Базомер показывает количество записей во всех регистрах сведений, регистрах накопления, документах и справочниках.

1 стартмани

31.05.2019    6987    14    bars21rus    8    

Обороты по документам для 1С: Бухгалтерия предприятия ред.3

Анализ учета Статистика базы данных Управленческие Документооборот и делопроизводство Документооборот и делопроизводство v8::СКД БП3.0 Россия БУ Абонемент ($m)

Отчет позволяет быстро получить данные для анализа в целом по компании и в динамике с произвольной периодичностью: день, неделя, месяц, квартал, год. Отчет написан на СКД и позволяет произвольно менять настройки, а также получать расшифровки вплоть до конкретного документа и в различных разрезах: по контрагентам, по видам операций, по организациям, подразделениям, складам, физическим лицам.

4 стартмани

23.05.2019    6468    7    rusmil    7    

Количество элементов в справочниках и документах системы

Статистика базы данных v8 v8::СКД 1cv8.cf Россия Абонемент ($m)

Отчет для любой конфигурации на платформе 8.х по количеству элементов в справочниках и документах системы Открывается как внешний файл (меню Файл - Открыть) на любом релизе платформы 8.х Формируется по кнопке Сформировать - см. скриншот

1 стартмани

21.05.2019    5599    7    denis_r    0    

Размеры таблиц SQL

Статистика базы данных v8::СКД 1cv8.cf Россия Абонемент ($m)

Сколько места занимает справочник? Почему такая большая база? Отчет покажет!

1 стартмани

15.05.2019    10745    150    SnubbyAston    11    

Подсчёт общего количества объектов (справочников и документов) в базе данных

Статистика базы данных v8 1cv8.cf Россия Абонемент ($m)

Обработка подсчитывает количество всех типов документов и справочников в базе 1С и выводит в таблицу. Ведёт подсчёт общего количества документов, проведённых, не проведённых и помеченных на удаление. Подсчитывает общее количество элементов каждого справочника, помеченные на удаление и предопределённые элементы. Предназначена для общих целей анализа базы, особенно для прогнозирования времени свёртки/тестирования/обновления/синхронизации базы данных, а также для сравнения двух баз по количеству объектов (например, источник и приёмник при конвертации). Есть возможность выбора периода, выбора сортировки по количеству/наименованию и скрывать/показывать нулевые.

1 стартмани

22.04.2019    6774    16    Aleksandr55555    3    

Сбор статистики базы данных

Статистика базы данных v8::УФ 1cv8.cf Россия Абонемент ($m)

Обработка собирает данные о количестве элементов справочников и документов за выбранный период. Отдельно показывается количество помеченных на удаление элементов.

1 стартмани

27.03.2019    4538    8    Sharaa    3    

Количество элементов справочников и документов для 1С 8.x (обычные и управляемые формы)

Статистика базы данных v8 v8::УФ 1cv8.cf Россия Абонемент ($m)

Отчет позволяет быстро оценить количество элементов справочников и документов в базах 1С 8.x (обычные и управляемые формы).

1 стартмани

26.03.2019    5842    7    black.nik    0    

Подсчет количества документов в конфигурации

Статистика базы данных v8 1cv8.cf Украина Абонемент ($m)

Как-то всё руки не доходили, но вот написал для себя, и делюсь с другими, обработку для подсчета количества документов в конфигурации. Может, кому-то будет полезной.

1 стартмани

23.02.2019    6331    5    forwork1c    1    

Анализ документов базы по пользователям

Статистика базы данных v8 1cv8.cf Россия Абонемент ($m)

Анализ документов, введённых пользователями: внешний отчёт, позволяющий увидеть количество документов каждого вида, введённых каждым пользователем (количественные показатели работы).

1 стартмани

16.02.2019    5519    4    Fantasisto    0    

Статистика ролей пользователей

Статистика базы данных Информационная безопасность v8 1cv8.cf Россия Абонемент ($m)

Обработка формирует отчет по ролям пользователей в разрезе выбранных баз.

1 стартмани

26.01.2019    6574    0    VslavKup    0    

Анализ количества элементов справочников и документов (управляемые формы)

Статистика базы данных v8::УФ 1cv8.cf Абонемент ($m)

Обработка позволяет получить количество ссылок на документы и справочники с разделением по типам.

1 стартмани

25.01.2019    5018    5    Bubuyka    0    

Статистика по количеству документов и проводок в базе в разрезе организации и типов документов

Статистика базы данных v8 v8::БУ БП3.0 Абонемент ($m)

Данный отчет будет полезен для анализа производительности пользователей в базе.

2 стартмани

23.01.2019    5097    11    gvsgvs    0    

Отчет по базе данных

Статистика базы данных v8 v8::УФ 1cv8.cf Россия Абонемент ($m)

Внешний отчет по содержимому базы данных, формирует структуру базы данных, а также по конкретным объектам конфигурации можно посмотреть поля СУБД и индексы. (УФ)

1 стартмани

12.01.2019    7036    15    user5300    0    

Отчет "Всего объектов"

Статистика базы данных v8 1cv8.cf Россия Абонемент ($m)

Отчет показывает количество документов и справочников в разрезе метаданных с отбором по организации. Протестировано: на платформе 1С:Предприятие 8.3 (8.3.12.1616).

1 стартмани

25.12.2018    5129    3    birk    1    

Анализ максимального количества пользователей в базах средствами 1С (БСП)

Статистика базы данных v8 ДО ERP2 БП3.0 УТ11 КА2 ЗУП3.x Россия Абонемент ($m)

Подсистема для хранения и анализа количества подключений пользователей к указанным базам. Данные хранятся в отдельном регистре сведений, подключение выполняется средствами БСП.

1 стартмани

13.12.2018    6721    9    DarkPinch222    1    

Универсальный реестр документов (обычные и управляемые формы)

Статистика базы данных v8 v8::УФ 1cv8.cf Россия Абонемент ($m)

Обработка для вывода списка ВСЕХ документов (всех видов) за указанный период.

1 стартмани

28.11.2018    6423    12    DarkPinch222    1    

Замер производительности. КА 2, УТ 11

Статистика базы данных Производительность и оптимизация (HighLoad) v8 УТ11 Абонемент ($m)

Отчет позволяет замерять на актуальных базах КА2 и УТ11 (в том числе на демо-базах) три параметра: время выборки данных, время передачи с клиента на сервер, время вывода данных. Тестировал на релизах КА 2.4.1.240 и УТ 11.4.5.32.

1 стартмани

22.11.2018    8622    6    FarFar    11    

Считаем количество элементов объекта

Статистика базы данных v8 1cv8.cf Беларусь Украина Россия Абонемент ($m)

Обработка подсчета количества элементов в справочники, документе, регистре сведений.

1 стартмани

25.10.2018    7219    6    kaliuzhnyi    6    

Как узнать, какие типы документов в базе рабочие и сколько документов каждого типа?

Статистика базы данных v8 v8::УФ 1cv8.cf Абонемент ($m)

При разработке правил обмена необходимо определить, какие типы документов используются последние 2 года или 1 год.

1 стартмани

14.09.2018    7265    8    wowik    0    

Количество пользователей программы за период (по журналу регистрации)

Статистика базы данных v8 1cv8.cf Абонемент ($m)

Обработка родилась от необходимости оценки реального количества пользователей систем. Расчет выполняется на основании данных журнала регистрации.

1 стартмани

12.09.2018    5243    5    Kaavan    4    

Статистика работы с документами в базе

Статистика базы данных v8::БУ БП3.0 Россия БУ Абонемент ($m)

Статистика по документам в базе. Пригодится для анализа объема работ бухгалтерии, в т.ч. и аутсерсинговым организациям, у которых стоимость услуг зависит от объема документооборота.

1 стартмани

15.08.2018    5728    16    lvk74    0    

Отчет по количеству документов и строк в ТЧ (по видам документов, с заданной периодичностью)

Статистика базы данных v8 v8::УФ v8::СКД 1cv8.cf Абонемент ($m)

Предлагаю вашему вниманию отчет, который выводит информацию о количестве документов в информационной базе в разрезе видов документов с заданной периодичностью.

1 стартмани

30.07.2018    9574    38    Tavalik    7    

Размер данных в базе 1С

Статистика базы данных v8 1cv8.cf Россия Абонемент ($m)

Оценка размера данных в байтах. Отчёт не предназначен для точной оценки размеров данных, т.к. для многих типов размер вычисляется в попугаях. Этот отчёт не является верхом совершенства и работает крайне медленно. Но именно этот отчёт позволяет наглядно увидеть, как просто вывести данные через СКД и насколько это проще, нежели вывод обычным способом. В то же самое время данный отчёт показывает наглядно, как просто создавать инструменты одновременно и под обычные формы, и под управляемые. Также можно очень наглядно увидеть распределение данных по различным объектам метаданных.

1 стартмани

03.04.2018    9539    34    strange2007    3