Табличная часть из дополнительных реквизитов с обработкой событий в расширении

Публикация № 1059267

Разработка - Практика программирования

табличная часть ТЧ дополнительные реквизиты допреквизиты расширение

Эмуляция табличной части с помощью дополнительных реквизитов и расширения. Подход применим к любой конфигурации на управляемых формах с БСП и режимом совместимости, допускающим использование расширений. Весь код в статье.

С версии платформы 8.3.11.2867 стало возможным с помощью расширений добавлять к прикладному решению собственные структуры для хранения данных, в том числе табличные части и реквизиты табличных частей. И это замечательно. Однако не всегда конфигурация работает на старшей версии платформы и в нужном режиме совместимости. Кроме того, при добавлении в расширение объектов хранения данных возможны неочевидные проблемы при обновлении (см., например, публикацию 1039552). Поэтому в ряде случаев представляется разумным использовать совместно с расширением механизм дополнительных реквизитов.

Пример выполнен в конфигурации "1С:Документооборот КОРП 2.1" (далее ДО), однако подход применим к любой конфигурации на управляемых формах с БСП и режимом совместимости, допускающим использование расширений.

 

Постановка задачи

В конфигурации ДО необходимо создать вид внутреннего документа Премия, с табличной частью позволяющей учитывать премии сотрудников подразделения. При выборе сотрудника в строке табличной части должна подставляться его должность. Реквизит Должность должен быть недоступен для изменения. При изменении в строке ТЧ суммы премии должна изменяться сумма документа – реквизит Итого распределено. Конфигурация на полной поддержке, включать возможность изменения нельзя.

 

Решение

Создаем вид внутреннего документа – Премия (НСИ / Виды документов / Создать). Устанавливаем флаг Учитывать сумму документа. Остальные настройки – по желанию. (Напомню, что внутренний документ в ДО – это справочник).

 

Добавляем дополнительные реквизиты для документа Премия (Настройка и администрирование / Дополнительные реквизиты). Каждый доп. реквизит – ячейка эмулируемой табличной части. Предположим для примера, что в подразделении не более трех сотрудников, т.е. в таб. части должно быть три строки.

Итак, добавляем три новых доп. реквизита Сотрудник1 – Соотрудник3:

Обратите внимание, свойства Виден, Доступен и др. заполнять следует только в том случае, если мы не собираемся их изменять программно. Ручные настройки перекрывают программные. В текущей задаче свойства доп. реквизитов заполнять не следует. Исключение – доп. реквизит Фактическая численность, у которого можно установить флаг Заполнять обязательно.

 Совет

Добавляем три доп. реквизита Должность1Должность3 (тип Должность):

Добавляем три доп. реквизита Сумма1Сумма3 (тип Число 10, 2):

Аналогично добавляем три доп. реквизита Основание1Основание3 (тип Строка).

И добавляем реквизиты шапки:  Итого распределено (тип Число 10, 2)  и Фактическая численность (тип Число 2,0; Заполнять обязательно).

В результате получаем 14 доп. реквизитов документа Премия, из них два – реквизиты шапки и 12 – реквизиты собственно таблицы:

Далее нужно настроить внешний вид документа Премия. Создаем новый документ вида  Премия и переходим на вкладку Свойства, которая будет выглядеть примерно так:

Идем в меню Еще / Настройки / Изменить форму и настраиваем.

У группы Премия устанавливаем горизонтальную группировку.

В группе Премия создаем четыре группы:

- Сотрудник (Отображение – Слабое выделение);

- Занимаемая должность (Отображение – Сильное выделение)

- Сумма премии (Отображение – Сильное выделение)

- Основание (Отображение – Сильное выделение)

У всех групп группировка вертикальная, флаг Отображать заголовок установлен.

Перетаскиваем поля доп. реквизитов в соответствующие группы. В результате форма настройки будет выглядеть так:

 

У всех полей доп. реквизитов устанавливаем Положение заголовкаНет.

 

Настраиваем шапку. В группе Свойства создаем группу Шапка (Отображение – Нет, Группировка – Вертикальная, Отображать заголовок – Нет).

В группе Шапка создаем две группы: Группа подразделение и Группа сумма и численность. У обеих групп Отображение – Нет, Группировка – Горизонтальная, Отображать заголовок – Нет.

В группу Группа подразделение  перетаскиваем из группы Реквизиты / Группа элемента / ГруппаПраво / Реквизиты реквизит (стандартный, не доп.) Подразделение и, выделив этот реквизит, добавляем кнопкой Добавить поля реквизит Руководитель.

В группу Группа сумма и численность перетаскиваем из той же группы Реквизиты / Группа элемента / ГруппаПраво / Реквизиты группу Группа сумма и наш доп. реквизит Фактическая численность. У реквизита Сумма устанавливаем заголовок Премиальный фонд (сумма).

Доп. реквизит Итого распределено перемещаем в группу Шапка.

В результате форма настройки будет выглядеть так:

 

А вкладка Свойства  документа Премия так:

 

 

Далее открываем конфигуратор и добавляем расширение (Конфигурация / Расширения конфигурации / Добавить):

 

Добавляем в расширение форму элемента справочника ВнутренниеДокументы и План видов характеристик ДополнительныеРеквизитыИСведения (нужен для установки типа реквизита формы).

В расширении добавляем реквизиты формы:

- ЭтоПремия – тип Булево;

- КоличествоСтрокВТаблицеПремия – тип Число 3,0;

- ИтогоСумма – тип Число 10,2.

- СвойствоИтогоРаспределено – тип ПланВидовХарактеристикСсылка.ДополнительныеРеквизитыИСведения.

В принципе, можно обойтись без реквизитов формы, однако тогда форма будет работать медленнее.

Код модуля формы элемента справочника ВнутренниеДокументы в расширении представлен ниже:

 

 

// Добавлены реквизиты формы(для документа вида Премия):
// ЭтоПремия - Булево
// ИтогоСумма - Число 
// КоличествоСтрокВТаблицеПремия - Число
// СвойствоИтогоРаспределено - ПланВидовХарактеристикСсылка.ДополнительныеРеквизитыИСведения

#Область ОбработчикиСобытийФормы

&НаСервере
Процедура Премия_ПриСозданииНаСервереПосле(Отказ, СтандартнаяОбработка)
	
	Если Объект.ВидДокумента = Справочники.ВидыВнутреннихДокументов.НайтиПоНаименованию("Премия") Тогда
		
		ЭтоПремия = Истина;
		
		///////////////////////////////////
		КоличествоСтрокВТаблицеПремия = 3;
		///////////////////////////////////
		
		СвойствоИтогоРаспределено = ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("Итого распределено (Премия)");
		
		ОбработатьУстановкуДействияДляДопреквизитов_Премия(Отказ, СтандартнаяОбработка, Неопределено);
		
	Иначе
		ЭтоПремия = Ложь; 
	КонецЕсли;
	
КонецПроцедуры

&НаКлиенте
Процедура Премия_ПриОткрытииПосле(Отказ)
	
	Если ЭтоПремия Тогда
		
		Элементы.Подразделение.АвтоОтметкаНезаполненного = Истина;
		
		УстановитьСвойстваПолей_Премия();
		
	КонецЕсли;
	
КонецПроцедуры


&НаСервере
Процедура Премия_ОбработкаПроверкиЗаполненияНаСервере(Отказ, ПроверяемыеРеквизиты)
	
	Если ЭтоПремия Тогда
		Если НЕ ЗначениеЗаполнено(Объект.Подразделение) Тогда
			ОбщегоНазначенияКлиентСервер.СообщитьПользователю(
			НСтр("ru = 'Поле ""Подразделение"" не заполнено'"), ,
			"Подразделение", "Объект");
			Отказ = Истина;
		КонецЕсли;	
	КонецЕсли;
	
КонецПроцедуры

&НаКлиенте
Процедура Премия_ПослеЗаписи(ПараметрыЗаписи)
	УстановитьСвойстваПолей_Премия();
КонецПроцедуры

#КонецОбласти

#Область ОбработчикиСобытийЭлементовТаблицыФормыПремияНазначаемые

&НаКлиенте
Процедура СуммаПриИзменении_Премия()
	
	ИтогоСумма = 0;
	Для Сч=1 По КоличествоСтрокВТаблицеПремия Цикл
		СуммаТекущая = НайтиДопреквизитВФорме("Сумма"+СокрЛП(Сч));
		Если СуммаТекущая.Видимость Тогда
			ИтогоСумма = ИтогоСумма + Число(СокрЛП(СуммаТекущая.ТекстРедактирования));
		КонецЕсли;
	КонецЦикла;
	
	УстановитьЗначениеДопРеквизитаИтогоРаспределено();
	
	УстановитьСвойстваПолей_Премия();
	
КонецПроцедуры

&НаКлиенте
Процедура СотрудникПриИзменении()
	
	ЗначениеДопРеквизитаСотрудник = Вычислить("ЭтаФорма." + ТекущийЭлемент.Имя);
	Должность = РаботаСПользователями.ПолучитьДолжность(ЗначениеДопРеквизитаСотрудник);
	
	НаименованиеДопреквизитаСотрудник = ПолучитьНаименованиеДопреквизитаПоИмени(ТекущийЭлемент.Имя);
	НомерСтрокиТаблицы = СтрЗаменить(НаименованиеДопреквизитаСотрудник,"Сотрудник","");
	
	НаименованиеДопреквизитаДолжность = "Должность" + НомерСтрокиТаблицы + " (Премия)";	
	УстановитьЗначениеДопРеквизитаДолжность(НаименованиеДопреквизитаДолжность, Должность);
	
	УстановитьСвойстваПолей_Премия();
	
КонецПроцедуры

#КонецОбласти

#Область СлужебныеПроцедурыИФункции

&НаСервере
Процедура УстановитьДействияДляДопреквизита(НаименованиеДопРеквизита, ДействиеСтрока, ПроцедураСтрока)
	
	СтруктураПоиска = Новый Структура("Наименование", НаименованиеДопРеквизита);
	ИмяДопРеквизита = ЭтаФорма.Свойства_ОписаниеДополнительныхРеквизитов.НайтиСтроки(СтруктураПоиска)[0].ИмяРеквизитаЗначение;
	ДопРеквизит = Элементы[ИмяДопРеквизита];
	ДопРеквизит.УстановитьДействие(ДействиеСтрока, ПроцедураСтрока);
	
КонецПроцедуры

// Параметры:
//  НаименованиеДопРеквизита  - Строка
// Возвращаемое значение:
//  ПолеФормы   - искомый допреквизит типа ПолеФормы
&НаКлиенте
Функция НайтиДопреквизитВФорме(НаименованиеДопРеквизита)
	
	СтруктураПоиска = Новый Структура("Наименование", НаименованиеДопРеквизита);
	МассивСтрок = ЭтаФорма.Свойства_ОписаниеДополнительныхРеквизитов.НайтиСтроки(СтруктураПоиска);
	Если МассивСтрок.Количество() = 0 Тогда
		Возврат Неопределено;
	Иначе
		ИмяДопРеквизита = МассивСтрок[0].ИмяРеквизитаЗначение;
		ДопРеквизит = Элементы[ИмяДопРеквизита];
		Возврат ДопРеквизит;
	КонецЕсли;
	
КонецФункции

&НаСервере
Процедура ОбработатьУстановкуДействияДляДопреквизитов_Премия(Отказ, СтандартнаяОбработка, ДополнительныеПараметры)
	
	Для Сч=1 По КоличествоСтрокВТаблицеПремия Цикл
		УстановитьДействияДляДопреквизита("Сумма" + СокрЛП(Сч), "ПриИзменении", "СуммаПриИзменении_Премия");
		УстановитьДействияДляДопреквизита("Сотрудник" + СокрЛП(Сч), "ПриИзменении", "СотрудникПриИзменении");
	КонецЦикла;
	
КонецПроцедуры

&НаКлиенте
Процедура УстановитьСвойстваПолей_Премия()
	
	УстановитьТолькоПросмотрДляПоля("Итого распределено");
	УстановитьТолькоПросмотрДляПолейДолжность();
	УстановитьКнопкаОткрытияЛожьДляПолейДолжность();
	
КонецПроцедуры

// Возвращает наименование доп. реквизита
// Параметры:
//  ИмяДопреквизита  - Строка. Например, ДополнительныйРеквизитЗначение_71A6C86Dx0E4Ex11E8x873Dx0022155C4930_71A6C875x0E4Ex11E8x873Dx0022155C4930
// Возвращаемое значение:
//  НаименованиеДопреквизита  - Строка. Например, Сотрудник1
//
&НаКлиенте
Функция ПолучитьНаименованиеДопреквизитаПоИмени(ИмяДопреквизита)
	
	СтруктураПоиска = Новый Структура("ИмяРеквизитаЗначение", ИмяДопреквизита);
	МассивСтрок = ЭтаФорма.Свойства_ОписаниеДополнительныхРеквизитов.НайтиСтроки(СтруктураПоиска);
	Если МассивСтрок.Количество()=0 Тогда
		Возврат Неопределено;
	Иначе
		НаименованиеДопреквизита = МассивСтрок[0].Наименование;
		Возврат НаименованиеДопреквизита;
	КонецЕсли;
	
КонецФункции

&НаСервере
Процедура УстановитьЗначениеДопРеквизитаИтогоРаспределено()
	
	УправлениеСвойствами.ПеренестиЗначенияИзРеквизитовФормыВОбъект(ЭтаФорма, Объект);
	
	НашлиСтроку = Ложь;
	Если Объект.ДополнительныеРеквизиты.Количество() = 0 Тогда
		НоваяСтрока = Объект.ДополнительныеРеквизиты.Добавить();
		НоваяСтрока.Свойство = СвойствоИтогоРаспределено;
		НоваяСтрока.Значение = ИтогоСумма;
	Иначе
		
		Для каждого Строка Из Объект.ДополнительныеРеквизиты Цикл
			Если Строка.Свойство.Ссылка = СвойствоИтогоРаспределено Тогда
				Строка.Значение = ИтогоСумма;
				НашлиСтроку = Истина;
			КонецЕсли;
		КонецЦикла;
		
		Если НЕ НашлиСтроку Тогда
			НоваяСтрока = Объект.ДополнительныеРеквизиты.Добавить();
			НоваяСтрока.Свойство = СвойствоИтогоРаспределено;
			НоваяСтрока.Значение = ИтогоСумма;
		КонецЕсли;
		
	КонецЕсли;
	
	УправлениеСвойствами.ЗаполнитьДополнительныеРеквизитыВФорме(ЭтаФорма, Объект);
	ОбработатьУстановкуДействияДляДопреквизитов_Премия(Неопределено, Неопределено, Неопределено);
	Модифицированность = Истина;
	
КонецПроцедуры

&НаСервере
Процедура УстановитьЗначениеДопРеквизитаДолжность(НаименованиеДопреквизитаДолжность, Должность)
	
	УправлениеСвойствами.ПеренестиЗначенияИзРеквизитовФормыВОбъект(ЭтаФорма, Объект);
	
	Если Объект.ДополнительныеРеквизиты.Количество() = 0 Тогда
		Возврат;
	КонецЕсли;
	
	СвойствоТекущаяДолжность = ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию(НаименованиеДопреквизитаДолжность);
	
	НашлиСтроку = Ложь;
	Для каждого Строка Из Объект.ДополнительныеРеквизиты Цикл
		Если Строка.Свойство.Ссылка = СвойствоТекущаяДолжность Тогда
			Строка.Значение = Должность;
			НашлиСтроку = Истина;
			Прервать;
		КонецЕсли;
	КонецЦикла;
	
	Если НЕ НашлиСтроку Тогда
		НоваяСтрока = Объект.ДополнительныеРеквизиты.Добавить();
		НоваяСтрока.Свойство = СвойствоТекущаяДолжность;
		НоваяСтрока.Значение = Должность; 
	КонецЕсли;
	
	УправлениеСвойствами.ЗаполнитьДополнительныеРеквизитыВФорме(ЭтаФорма, Объект);
	ОбработатьУстановкуДействияДляДопреквизитов_Премия(Неопределено, Неопределено, Неопределено);
	Модифицированность = Истина;
	
КонецПроцедуры

&НаКлиенте
Процедура УстановитьТолькоПросмотрДляПоля(НаименованиеДопРеквизита)
	
	ДопРеквизитПоле = НайтиДопреквизитВФорме(НаименованиеДопРеквизита);
	Если ДопРеквизитПоле <> Неопределено Тогда
		ДопРеквизитПоле.ТолькоПросмотр = Истина;
	КонецЕсли;
	
КонецПроцедуры

&НаКлиенте
Процедура УстановитьТолькоПросмотрДляПолейДолжность()
	
	Для Сч =1 По КоличествоСтрокВТаблицеПремия Цикл
		УстановитьТолькоПросмотрДляПоля("Должность" + СокрЛП(Сч));
	КонецЦикла;
	
КонецПроцедуры

&НаКлиенте
Процедура УстановитьЗначениеСвойстваПоляФормыДопРеквизита(НаименованиеДопРеквизита, СвойствоПоляФормы, ЗначениеСвойстваПоляФормы)
	
	ДопРеквизитПоле = НайтиДопреквизитВФорме(НаименованиеДопРеквизита);
	Если ДопРеквизитПоле <> Неопределено Тогда
		Выполнить("ДопРеквизитПоле." + СвойствоПоляФормы + "=" + ЗначениеСвойстваПоляФормы);
	КонецЕсли;
	
КонецПроцедуры

&НаКлиенте
Процедура УстановитьКнопкаОткрытияЛожьДляПолейДолжность()
	
	Для Сч =1 По КоличествоСтрокВТаблицеПремия Цикл
		УстановитьЗначениеСвойстваПоляФормыДопРеквизита("Должность" + СокрЛП(Сч), "КнопкаОткрытия", "Ложь")
	КонецЦикла;
	
КонецПроцедуры

#КонецОбласти

 

Таким образом, в документе получаем таблицу следующего вида:

При выборе сотрудника программно подставляется должность. При изменении суммы в "строке" пересчитывается поле Итого распределено.

Остается только перейти в Настройка и администрирование / Поддержка и обслуживание / Управление пользовательскими настройками и скопировать настройки документа всем (или избранным) пользователям. Это функционал БСП.

В реальной боевой базе (госучреждение) внутренний документ Премия содержит 30 строк. Таково максимальное количество сотрудников в отделе. Кроме того, настроен автозаполняемый шаблон Word, бизнес-процесс согласования-утверждения документа, настроены права, сделан отчет. Работают два года, все довольны. Конфигурация на полной поддержке. Это к тому, что на доп. реквизитах можно делать полноценную автоматизацию.

Боевая конфигурация ДГУ 2.1.9.3 работает на платформе 8.3.9.1850. Настоящая публикация готовилась на платформе 8.3.13.1690 в демо-версии ДО 2.1.12.2 (режим совместимости 8.3.8).

Скачать файлы

Наименование Файл Версия Размер
ТабЧастьИзДопРеквизитов

.cfe 256,11Kb
12.05.19
3
.cfe 12.05.19 256,11Kb 3 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
1. ilya.rudziak 33 14.05.19 10:22 Сейчас в теме
Здравствуйте.Решение хорошее. А вы не пробовали определить вид вкладки Свойства прямо в расширении в зависимости от внутреннего вида документа (программно)?
2. mvxyz 170 14.05.19 14:45 Сейчас в теме
(1) А есть ли смысл усложнять? В данном случае и так будут отображаться только допреквизиты соответствующего вида документа.
3. mvxyz 170 14.05.19 14:51 Сейчас в теме
(1) Программно в зависимости от вида документа менял заголовок вкладки "Свойства", например, на "Премия".
4. Gomodrila 15.05.19 18:13 Сейчас в теме
Не юзабельно. Таких документов возможно потребуется не один десяток. Настраивать каждый, писать отдельный код и прочее. Да и настройки скорее всего в конце концов поедут.

Для одного документов, возможно, рабочее решение, но не более.
5. mvxyz 170 15.05.19 20:34 Сейчас в теме
А как юзабельно? Да, в ДО обычно не один десяток видов внутренних документов (а также входящих и исходящих), которые являются элементами справочника. И каждый вид нужно настраивать. Вы предлагаете не настраивать? Забить?
Настройки никуда не едут. Если пользователь сам испортит свои настройки, то ничто не мешает скопировать их ему от администратора или другого пользователя. Это очень просто.
Если Вы смотрели код, то могли заметить, что большая часть кода универсальна.
6. MSK_Step 20 16.05.19 22:10 Сейчас в теме
Что плохого в снятие конфигурации с поддержки? Если она выполнена грамотно. У заказчиков такие страхи обычно из за предыдущих "разработчиков" после которых уже было не обновить 1с. А тем более 1с документооборот конфигурация обновляется раз в два года)) Как в знаменитой фразе : "Разработка хорошая, но зачем"
7. mvxyz 170 16.05.19 22:54 Сейчас в теме
(6) Если у организации есть фикси, который занимается конфигурацией, и есть уверенность, что он не уволится, то включение возможности изменения в принципе, конечно, не страшно. А если организация обращается к франчу, где движение кадров сопоставимо со скоростью смены времен года? Опыт подсказывает мне, что если есть возможность оставить на полной поддержке, то лучше оставить.
klaus38; acanta; +2 Ответить
8. insurgut 190 30.05.20 17:15 Сейчас в теме
В результате получаем 14 доп. реквизитов документа Премия, из них два – реквизиты шапки и 12 – реквизиты собственно таблицы

Наверное не лучший подход к решению задачи. Чтобы сохранить табличную часть в доп. реквизитах достаточно 1 реквизита! Устанавливаем для него тип - Строка (неограниченная). При создании на сервере мы этот реквизит считываем как запись JSON, перед записью соответственно преобразует таблицу в строку записи JSON.
9. mvxyz 170 30.05.20 21:12 Сейчас в теме
(8) А что мы в этом случае выигрываем?
И как строить отчеты? Разбирать JSON в ПриКомпоновкеРезультата?
10. insurgut 190 31.05.20 07:15 Сейчас в теме
(9) как что? Гибкость разработки, любое количество строк в таблице без необходимости доработки формы и отчетов. В вашем случае если понадобится добавить ещё одну строку, нужно будет "допиливать" и форму и отчет. Как частный случай создание отдельного реквизита на отдельную ячейку таблицы конечно подойдет, но универсальным его точно не назовешь.
11. mvxyz 170 31.05.20 11:02 Сейчас в теме
(10) Эта конструкция по-определению не предназначена для таблиц с большим количеством строк. В данном примере мы знаем, что в отделе не больше 30 человек, то есть строк не больше 30.
Но Ваше предложение - интересное, спасибо. И да, так, конечно, существенно универсальнее. Стоит попробовать.
12. Yashazz 3260 31.05.20 16:55 Сейчас в теме
Я такое делал ещё в 2008 году для БП 1.6, гораздо проще и гибче, нежели предложенное решение.
13. mvxyz 170 31.05.20 23:14 Сейчас в теме
(12) В 2008 году не было расширений. Механизм расширений появился в платформе 8.3.6 в 2015 году.
14. Yashazz 3260 01.06.20 20:05 Сейчас в теме
(13) Естественно. Так вот я и без расширений сделал быстро и удобно портируемый механизм. Я вам открою секрет: и до расширений люди работали, и без них жизнь возможна. Более того, без них она порой гораздо лучше)
15. mvxyz 170 01.06.20 23:23 Сейчас в теме
(14) Публикация про то, как добавить табличную часть к объекту конфигурации, не включая возможность изменения конфигурации. Вам удалось реализовать такое в 2008 году для БП 1.6?
За открытый секрет - спасибо. Я и не подозревал, что и без расширений люди работают. Наверное, это выдающиеся специалисты.
16. Yashazz 3260 04.06.20 11:15 Сейчас в теме
(15) Ну изменения-то были - прям целая подсистема. Но публикация-то вовсе не про "возможность изменения". Потому как "не включая возможность изменения" - это за вас уже 1С сделала в виде той самой концепции расширений, и тут вы нифига нового не изобрели, а лишь пользуетесь. И не стоит подавать свою поделку как изобретение означенного способа, ибо не ваше это изобретение.
А ваше - довольно странный и не самый удобный способ реализовать некий функционал. Смекаете разницу? Не принцип, а всего лишь функционал. Впрочем, если вы не гнушаетесь грязного популизма, и желаете выдать разработку фирмы 1С за своё новшество, то флаг в руки)
17. mvxyz 170 04.06.20 16:22 Сейчас в теме
(16)
если вы не гнушаетесь грязного популизма, и желаете выдать разработку фирмы 1С за своё новшество, то флаг в руки

Эк вас понесло... Вы публикацию то читали? Хотя бы первые два абзаца?
Оставьте свое сообщение

См. также

Рабочий стол зарплатчика Промо

Зарплата Рабочее место v8 v8::СПР v8::УФ ЗУП3.x Россия БУ Абонемент ($m)

Назначение обработки: - Консолидация основных операций работника кадровой службы, расчетчика заработной платы в одном окне; - Весь цикл кадровых операций: от создания сотрудника, до ввода любого необходимого кадрового документа; - Ввод зарплатных документов: плановых начислений, удержаний; ввода документов расчета, перерасчета, выплаты зарплаты; ввода налоговых документов.

15.01.2020    4958    4    HostHost    0    

Консоль выполнения кода в 1С (обычные и управляемые формы)

Прочие инструменты разработчика v8 v8::УФ 1cv8.cf Абонемент ($m)

Иногда возникает необходимость выполнить некоторые действия в 1С, ради которых не хочется писать внешнюю обработку на пару строк кода. Для таких действия предназначена "Консоль выполнения кода в 1С".

1 стартмани

19.06.2020    5736    49    Denr83    0    

Подсистема "Редактор Markdown 1C"

Прочие инструменты разработчика v8 v8::УФ 1cv8.cf Абонемент ($m)

Подсистема для быстрого встраивания в форму редактора языка разметки markdown

2 стартмани

19.04.2020    3340    6    cprit    11    

Открыть форму внутри другой формы - наконец-то возможно!

Работа с интерфейсом v8::УФ Абонемент ($m)

Я давно мечтал о возможности открытия форм 1С внутри других форм, мне время от времени попадаются задачи, где это бы пригодилось. И вот в версии 8.3.16 наконец-то это можно реализовать! Конечно, это не совсем то, что я ожидал, но получилось все равно интересно. Давайте посмотрим.

1 стартмани

15.04.2020    9786    4    CyberCerber    52    

Консоль запросов с графом (Анализатор сложных запросов) Промо

Консоль запросов v8::УФ v8::Запросы 1cv8.cf Абонемент ($m)

Консоль запросов для анализа запросов с большим количеством временных таблиц и вложенных запросов. Отображает структуру взаимосвязей временных таблиц в виде графа. Позволяет быстро передвигаться по тексту запроса и получать результат выполнения подзапросов. Единственная консоль запросов, которая позволяет выводить результат выполнения вложенных запросов и любой части объединения запроса. Удобное получение данных запроса из отладчика включая временные таблицы. Текст запроса в структурированном виде (можно свернуть, развернуть текст подзапроса). И еще много другого, чего вы не найдете в других консолях запросов. Поддержка УФ и ОФ. Версия 0.9.1 от 18.10.2019 (поддержка WebKit).

10 стартмани

03.05.2017    93668    406    manuel    248    

Запуск фонового задания во внешней обработке без регистрации в справочнике "Дополнительные отчеты и обработки"

Практика программирования v8::УФ ЗУП3.x Россия Абонемент ($m)

Описал, как показать прогресс выполнения длительной операции во внешней обработке, и при этом не регистрировать обработку в справочнике "ДополнительныеОтчетыИОбработки". Проверял на БСП версии "3.1.2.264".

1 стартмани

09.03.2020    3211    8    VinnieThePOOH    5    

Методика обновления формы объекта данных при изменении объекта

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

В формах объектов данных часто встречаются элементы, косвенно связанные с объектом. Логику обновления этих элементов при изменении объекта обычно вызывают из обработчиков ПриСозданнииНаСервере и ПриОткрытии, забывая про наличие других способов изменения объекта. В статье предложена методика для обычных и управляемых форм, учитывающая все способы.

1 стартмани

09.03.2020    6020    0    tormozit    13    

Вывод сообщений в HTML поле средствами 1С

Практика программирования v8 v8::УФ Абонемент ($m)

Пример использования вывода большого количества сообщений в поле HTML. С возможностью открывать ссылочные объекты и создавать новые объекты передавая параметры прямо из HTML поля. Протестировано на релизах 8.3.12 и 8.3.15+

2 стартмани

31.01.2020    4762    6    burni4    16    

Навигатор по конфигурации базы 1С 8.3 Промо

Инструментарий разработчика Универсальные обработки v8 v8::УФ 1cv8.cf Россия Абонемент ($m)

Универсальная внешняя обработка для просмотра метаданных конфигураций баз 1С 8.3. Отображает свойства и реквизиты объектов конфигурации, их количество, основные права доступа и т.д. Отображаемые характеристики объектов: свойства, реквизиты, стандартные рекизиты, реквизиты табличных частей, предопределенные данные, регистраторы для регистров, движения для документов, команды, чужие команды, подписки на события, подсистемы. Отображает структуру хранения объектов базы данных, для регистров доступен сервис "Управление итогами". Платформа 8.3, управляемые формы. Версия 1.1.0.63 от 10.06.2020

3 стартмани

28.10.2018    29313    276    ROL32    67    

Взаимодействие HTML (COM объект, WebKit) с 1С (обычные и управляемые формы)

Внешние источники данных WEB v8 v8::УФ 1cv8.cf Абонемент ($m)

Показан пример использования HTML (COM объект, WebKit) в 1С (8.3).

2 стартмани

18.01.2020    6159    19    Deniskinr83    0    

Как в 1С создать паутинку "как на Инфостарте"

Практика программирования v8::УФ 1cv8.cf Россия Абонемент ($m)

Добрый день, уважаемы коллеги! В этой статье я расскажу, как в 1С создать отчет - "паутинку" на примере отчета по компетенциям сотрудника (разрабатывала на платформе 1С:Предприятие 8.3 (8.3.13.1865).

1 стартмани

15.01.2020    8621    4    user660153_aleks.pisanets    17    

Индикация прогресса выполнения фонового задания на управляемой форме внешней обработки

БСП (Библиотека стандартных подсистем) Работа с интерфейсом v8 v8::УФ 1cv8.cf Абонемент ($m)

Внешняя обработка с фоновым выполнением и индикацией процесса для любой конфигурации на основе БСП >= 2.3 без изменения конфигурации и встраивания обработки в "Дополнительные отчеты и обработки".

1 стартмани

27.12.2019    7332    10    1sig    12    

Корректировка остатков регистров бухгалтерии (обычные и управляемые формы) Промо

Свертка базы Универсальные обработки Закрытие периода Чистка базы v8::БУ v8::УФ 1cv8.cf БУ НУ Абонемент ($m)

Внешняя обработка, предназначенная для удобного исправления остатков по регистрам бухгалтерии (Хозрасчетный, Налоговый или любой другой) посредством автоматизации ввода корректировочного документа ("Операция", "Корректировка записей регистров"), приводящего регистр в нужное состояние остатков от текущего. Удобна для массовых правок остатков по бухгалтерскому и налоговому учету на какую-то дату (обычно перед реорганизацией учета, сверткой базы и т.п.)

2 стартмани

03.06.2017    28856    153    stvorl    24    

Многоуровневые списки выбора с оформлением элементов

Практика программирования Работа с интерфейсом v8 v8::УФ 1cv8.cf Абонемент ($m)

Данная статья - попытка решить один маленький кусочек большой проблемы платформы 1С, а именно - бедные и невыразительные пользовательские интерфейсы. Поскольку 1С в режиме управляемого приложения позволяет задействовать веб-клиент, то хочется реализовывать интерфейсы как у взрослых веб-приложений - красивые, дружелюбные для пользователя и, желательно, с положительным UX. Возможно, кто-то со мной не согласится и скажет, что учетные системы должны быть строгие и линейные. Но мы все знаем, что 1С - это уже не только про бухгалтерию. Небольшое отступление для разработчиков, работающих с типовыми конфигурациями. Я не знаю, использует ли фирма 1С что-то похожее в своих разработках. Если да, то данная статья навряд ли будет вам полезна.

1 стартмани

17.12.2019    6464    2    azhilichev    5    

Инструменты оптимизации для 1С на MS SQL Server

Прочие инструменты разработчика v8 v8::УФ 1cv8.cf Абонемент ($m)

Набор базовых инструментов для поиска узких мест в работе 1С на MS SQL Server.

1 стартмани

15.12.2019    14629    192    berezdetsky    23    

Разбираемся с web-kit в 1С, на примере интеграции TinyMCE в управляемую форму в УТ 11.4. Допиливаем обмен с сайтом в УТ 11.4

Обмен данными 1С Интеграция Адаптация типовых решений v8 v8::УФ УТ11 Абонемент ($m)

Многие уже знают, что в релизе платформы 8.3.14.1565, браузер Internet Explorer был заменен на Web-Kit, это на самом деле большой шаг вперед, но я уверен, многим, как и мне, пока не совсем понятно, что к чему. Возник опыт использования web-kit в 1С, вызова JS из 1С и вызова 1С из JS. Давайте вместе попробуем понять, чем одно отличается от другого, и заодно сделаем, что-нибудь полезное. Да и наверняка многим придется переписывать свои подобные поделки после обновления на новую платформу, так что надеюсь мой опыт окажется полезным.

2 стартмани

08.12.2019    7312    12    Бэнни    25    

Перенос объектов 1С Промо

Перенос данных из 1C8 в 1C8 v8 v8::УФ 1cv8.cf Абонемент ($m)

Простой и наглядный перенос объектов между любыми базами 1С 8 с предварительным анализом на возможные различия в данных (через файл, через интернет, через буфер обмена). Интерактивная настройка правил обмена на стороне источника и получателя. В обработке есть удобный обзор по подсистемам, поиск и обработка данных по заданному фильтру. Сравнение объектов, поиск ссылок. Конструктор кода по созданию объектов, написание скриптов и отладка мини-функций в УФ. Отключение/включение регламентных заданий. Регистрация/снятие с регистрации объектов в планах обмена. И многое другое. Инструменты администратора в одной обработке.

1 стартмани

16.03.2015    86611    1377    moolex    193    

Архив шаблонов: Внешняя печатная форма (клиентский метод), Внешняя печатная форма (серверный метод), Внешний отчет, Внешние дополнительные обработки

Прочие инструменты разработчика v8 v8::УФ 1cv8.cf Абонемент ($m)

Шаблоны подключаемых обработок для управляемых форм. Состав архива 1. Шаблон внешнего отчета на СКД 2. Шаблон дополнительной внешней обработки с открытием формы 3. Шаблон дополнительной внешней обработки без открытия формы (возможно использование в качестве фонового задания) 4. Шаблон внешней печатной формы (серверный метод) 5. Шаблон внешней печатной формы с открытием формы (клиентский метод). 6. Шаблон обработки заполнения документа

2 стартмани

01.12.2019    4852    20    roma_semenov79    0    

[Взрыв шаблона!] Новый способ программной настройки условного оформления

Работа с интерфейсом v8::УФ 1cv8.cf Абонемент ($m)

Условное оформление форм и списков это великолепная возможность их настройки по заданным условиям. Но существенным недостатком является трудоемкость написания и сопровождения программного кода. В публикации предлагается новый способ программной настройки условного оформления.

1 стартмани

01.12.2019    9384    33    mszsuz    11    

Работа с Яндекс-картами в 1С (вывод меток, прокладка маршрута, отображение балуна, вывод меток в кластеры) (обычное и управляемое приложение)

WEB v8 v8::УФ 1cv8.cf Абонемент ($m)

Работа с Яндекс-картами в 1С (управляемое приложение). Обработка показывает, как можно найти адреса на карте Яндекс, проложить маршрут.

2 стартмани

20.11.2019    9789    97    Denr83    0    

Быстрый запрос Промо

Универсальные обработки v8 v8::УФ 1cv8.cf Абонемент ($m)

Можно ли дать пользователю "удочку", а не "рыбу"? До сих пор ответ на этот вопрос был отрицательным. Всякий инструмент, который мог бы делать с базой данных все или почти все (или хотя бы многое), отвергался пользователями, как слишком сложный. Вспомните тот же SQL, который изначально разрабатывался именно как пользовательский инструмент. "Быстрый запрос" - это попытка устранить сложность, но сохранить при этом универсальность.

1 стартмани

29.04.2019    13749    26    mkalimulin    28    

Быстрая реструктуризация базы данных

Производительность и оптимизация (HighLoad) Конфигурирование 1С v8 v8::УФ 1cv8.cf Россия Абонемент ($m)

Внешняя обработка для быстрой реструктуризации клиент-серверной базы данных. Способ ускорения реструктуризации - замена таблиц большого объема пустыми копиями перед проведением обновления БД и возврат к исходным таблицам после обновления с предварительной корректировкой их структуры. Полностью автоматизировано создание и выполнение всех требуемых скриптов SQL. Представлены версии обработки для обычных форм (1С:Предприятие 8.2 (8.2.19.130)) и управляемого приложения (1С:Предприятие 8.3 (8.3.9.1818)).

1 стартмани

05.11.2019    11796    42    dmitrydemenew    36    

Конфигурация для администраторов "Центр управления базами" для 8.3 УФ

Администрирование данных 1С БСП (Библиотека стандартных подсистем) v8 v8::УФ 1cv8.cf Абонемент ($m)

Конфигурация предназначена для централизованного управления информационными базами предприятия. Разработана на БСП версии 2.4.4.76. В работе использует COM-соединение.

3 стартмани

09.10.2019    5640    19    WhiteOwl    9    

Описание формата внутреннего представления данных 1С в контексте обмена данными

Практика программирования Внешние источники данных v8 v8::УФ 1cv8.cf Абонемент ($m)

Фирма 1С не рекомендует использовать внутреннее представление данных для любых целей, которые отличны от обмена с 1С:Предприятием 7.7. Но сама возможность заглянуть на "внутреннюю кухню" платформы с помощью функций ЗначениеВСтрокуВнутр(), ЗначениеВФайл(), ЗначениеИзСтрокиВнутр() и ЗначениеИзФайла(), дала возможность сообществу программистов 1С разработать новые приемы разработки и анализа. Так, именно на использовании внутреннего представления был построен алгоритм "быстрого массива", который позволяет практически мгновенно создать массив в памяти на основании строки с разделителями. С помощью разбора внутреннего представления можно "на лету" программным кодом выполнить анализ обычной формы и даже сделать редактор графической схемы. Во внутреннем формате сохраняют свои данные между сеансами различные популярные внешние обработки. А еще это возможность сделать быстрый обмен с внешними системами.

1 стартмани

06.09.2019    17019    11    Dementor    30    

Менеджер открытых форм Промо

Работа с интерфейсом v8::УФ 1cv8.cf Абонемент ($m)

Обработка получает информацию об открытых формах и позволяет ими манипулировать.

1 стартмани

13.04.2017    19856    35    SeiOkami    19    

Запутывание кода 1С

Защита и шифрование v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработка запутывания (обфускации) исходного кода 1С с помощью регулярных выражений.

2 стартмани

02.09.2019    8414    42    leoxz    66    

Простая выгрузка данных в универсальном формате Enterprise Data

Обмен через XML v8::УФ Розница УНФ ERP2 ЗКГУ3.0 БП3.0 УТ11 КА2 ЗУП3.x Абонемент ($m)

Пошагово разобран текст процедуры, позволяющей выгрузить произвольный набор объектов в формате Enterprise Data (конечно, если это позволяет конфигурация). Приложена обработка, позволяющая выгружать произвольные объекты, в том числе запросом или по данным журнала регистрации.

2 стартмани

26.08.2019    10622    31    Iyar    3    

Удобный выбор из таблицы/дерева в УФ

Практика программирования Работа с интерфейсом Разработка v8 v8::УФ 1cv8.cf Абонемент ($m)

Выбор из таблицы значений или дерева значений в выпадающем списке рядом с полем ввода - УФ, быстро и просто!

1 стартмани

12.08.2019    11112    7    Yashazz    18    

Расширенная настройка динамического списка УФ Промо

Работа с интерфейсом v8 v8::УФ 1cv8.cf Абонемент ($m)

Открывая управляемую форму выбора и не увидев там видимых в форме списка элементов, часто хочется узнать причину их отсутствия там, т. е. какой наложен отбор. Но стандартная настройка списка управляемой формы показывает только пользовательские настройки, скрывая от пользователя фиксированный отбор. Предлагаю вам расширение конфигурации с расширенной настройкой динамического списка, отображающей пользователю кроме пользовательских настроек еще фиксированные.

1 стартмани

31.05.2017    29979    147    tormozit    23    

Отбор на управляемой форме из списка значений

Практика программирования Работа с интерфейсом Разработка v8 v8::УФ 1cv8.cf Абонемент ($m)

Пример простого удобного отбора любых данных ссылочного типа на управляемой форме. Работа обработки проверена на релизе: 1С:Предприятие 8.3.13.1513.

1 стартмани

09.08.2019    13925    17    nagaitseff    6    

Изменяющееся контекстное меню в 1С 8.3

Практика программирования Работа с интерфейсом Разработка v8 v8::УФ Абонемент ($m)

В одной практической задаче мне пришлось разрабатывать контекстное меню таблицы управляемой формы, которое должно было меняться в зависимости от данных, находящихся в этой таблице. Ниже приведен мой способ решения этой задачи.

1 стартмани

06.08.2019    13753    2    signum2009    15    

Markdown-editor в 1С (с сохранением в HTML)

Универсальные обработки v8::УФ 1cv8.cf Абонемент ($m)

В этой обработке вы пишете свой текст, используя синтаксис Markdown, а на выходе получаете чистый HTML-код, избавленный от JS-библиотеки, которая его сформировала.

1 стартмани

04.07.2019    6262    12    riposte    3    

Редактор объектов информационной базы 8.3 Промо

Универсальные обработки Обмен через XML v8 v8::УФ 1cv8.cf Россия Абонемент ($m)

Универсальная внешняя обработка для редактирования реквизитов и табличных частей объектов информационной базы, редактирование движений документов. Доступ ко всем реквизитам объектов, есть возможность выгрузки и загрузки данных (объекты и движения документов) через XML. Платформа 8.3, управляемые формы. Версия 1.1.0.47 от 08.06.2020

2 стартмани

23.01.2019    24431    257    ROL32    33    

Обработка-редактор HTML

Работа с интерфейсом v8 v8::УФ 1cv8.cf Абонемент ($m)

Редактор HTML для управляемого интерфейса 8.3.

1 стартмани

10.06.2019    6443    52    ValeriVP    11    

Работа с файлами (обычная и управляемая форма)

Универсальные обработки v8 v8::УФ 1cv8.cf Абонемент ($m)

Нужно загрузить файл с клиента на сервер или же, наоборот, файл загрузить с сервера на клиент, а впридачу все это на web-клиенте, да еще и асинхронно? Нет ничего проще, читай далее, как это сделать!

1 стартмани

10.06.2019    19717    124    Xershi    76    

Работа с графической схемой в объектной модели DOM

Универсальные функции v8 v8::УФ Абонемент ($m)

Пример кода для работы с графической схемой в объектной модели DOM, платформа 8.3.12.

1 стартмани

04.06.2019    7539    5    botokash    19    

Выгрузка и загрузка данных из файла Excel с поиском по любым полям (есть поиск по ссылке, всего три итерации поиска. Управляемые формы или "Такси") Промо

Загрузка и выгрузка в Excel Обработка документов v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработка позволяет загружать данные с поиском по ссылке как для загружаемого объекта, так и его свойств. Загружает справочники, документы, планы видов характеристик. Будет полезна как замена использования конвертации данных для задач переноса, а также как классическая загрузка из табличного документа (Excel). Поиск объекта при загрузке выполняется до трех раз с разными полями поиска (поля поиска настраиваются). Также реализована выгрузка в Excel по ссылкам. У обработки удобный интерфейс, в котором разберется даже начинающий пользователь. Загрузка накладных из файлов xls реализована с интеллектуальным поиском колонок с данными. В интеллектуальном поиске поддерживаются все основные типовые печатные формы.

5 стартмани

16.10.2015    57088    502    primat    33    

Спутник программиста - каркасная конфигурация начинающим программистам 1С

Практика программирования Разработка v8::УФ 1cv8.cf Россия Абонемент ($m)

Спутник программиста - каркасная конфигурация с примерами для разработки начинающим программистам 1С.

1 стартмани

23.05.2019    12712    98    bulas    27    

Немного о графических файлах. Сжатие. Распознавание текста

Инструментарий разработчика v8 v8::УФ 1cv8.cf Россия Абонемент ($m)

Простые и доступные методы борьбы с лишним весом графических файлов и распознавание текста.

1 стартмани

06.05.2019    6686    10    tusv    6    

Групповая проверка доработок

Прочие инструменты разработчика v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработка для массовой проверки доработок конфигурации: Открытие форм, Печать, Формирование отчетов, Проведение документов, Запись справочников, ПВХ, ПВР. Выдает список обнаруженных ошибок. Рекомендуется применять для тестирования обновленной конфигурации, перед установкой пользователям. В коде используются универсальные методы поэтому подходит для большинства конфигураций, построенных на базе библиотеки стандартных подсистем. Проверялась на Зарплата и управление персоналом КОРП 3.1.8.216, Управление торговлей 11, 1С:ERP Управление предприятием 2.4.7.141, Бухгалтерия предприятия КОРП 3.0.68.66.

2 стартмани

05.05.2019    13088    94    sapervodichka    23    

Консоль запросов для УФ универсальная 8.3.7.3 Промо

Консоль запросов v8::УФ v8::Запросы 1cv8.cf Абонемент ($m)

Реализован программный вызов консоли для захвата "рваного" запроса, МВТ и параметров. В консоли реализована полная поддержка работы с таблицами значений. Выборочный просмотр пакетов и временных таблиц. Возможность выборочной выгрузки пакета запроса в ТЗ, с последующим её редактированием, сохранением на диск. Использование сохранённой ТЗ в качестве параметра для других запросов. Возможность обхода ТЗ в цикле с выполнением кода. Отсутствуют ошибки при наличии уничтожения временных таблиц. Замер времени выполнения каждого пакета запроса. Приличное окно настройки типа (только для параметров запроса), лёгкое преобразование в список значений и обратно. Поддержка дополнительных типов: ТЗ, Граница, Момент времени, Вид счёта, Вид движения и т.д. Форматирование типа значения при выводе запроса (NULL, пустая ссылка, пустая строка и т.п.). Наверное, самый лучший подбор ширины колонок. Возможность добавлять листы для вывода результатов запросов. Генерируется текст для конфигуратора с учётом количества результирующих пакетов, для каждого пакета можно настроить выборку или выгрузку и пересоздать текст.... Короче, лучше один раз увидеть ...

5 стартмани

12.03.2015    140476    3405    akor77    717    

Универсальный обмен данными XML (с гибкими отборами и сохранением вариантов настроек)

Обмен через XML v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработка предназначена для загрузки и выгрузки данных по правилам обмена в любых конфигурациях, реализованных на платформе 1С:Предприятие 8.3. Преимуществом перед типовой обработкой является добавленный функционал: #1. Установка произвольных фильтров на выгружаемые объекты при помощи механизма системы компоновки данных #2. Сохранение различных вариантов настроек (сохраняются правила обмена, фильтры выгрузки, параметры, настройки обработки) - что позволяет гибко настроить в базе-источнике фильтры для выгрузки объектов по различным правилам обмена для различных баз-приемников, сохранить выполненные настройки и в будущем уже пользоваться этими вариантами настроек. Проверялась на 1С:ERP Управление предприятием 2.4.7.141.

1 стартмани

29.04.2019    12476    231    sapervodichka    20    

Электронная таблица в 1С средствами табличного документа

Универсальные обработки v8 v8::УФ 1cv8.cf Россия Абонемент ($m)

Функционал электронной таблицы для программ на платформе 1С реализован на основе табличного документа. Функционал реализован в виде обработки (тонкий клиент). В формулах электронной таблицы можно использовать любые языковые конструкции, процедуры и функции 1С, ссылки на другие ячейки электронной таблицы. Допустимо обращаться к ячейкам электронной таблицы по имени именованной области. В случае использования в формулах электронной таблицы данных из самой таблицы пересчет зависимых ячеек с формулами производится автоматически. Электронную таблицу можно сохранить в файл формата xml.

1 стартмани

23.04.2019    13613    57    user706545_kseg1971    36    

Аутентификация на внешних сервисах посредством OAuth

Информационная безопасность Внешние источники данных v8 v8::УФ 1cv8.cf Абонемент ($m)

Пример подключения к сервисам Google из 1С с помощью протокола OAuth и получения данных с внешнего сервиса.

1 стартмани

03.04.2019    17372    18    binx    123    

Работа с картой. Кадастровый учет (Росреестр). Тематические карты Промо

WEB Рабочее место v8 v8::УФ 1cv8.cf Абонемент ($m)

Внешняя обработка для работы с картами в 1С. Получения изображения с публичной кадастровой карты России, построения тематических карт

5 стартмани

31.08.2017    15940    10    vipchep    0    

Расширение "Быстрая проверка кода" для конфигурации 1С:Автоматизированная проверка конфигураций

Инструментарий разработчика v8 v8::УФ 1cv8.cf Абонемент ($m)

Расширение для конфигурации "1С:Автоматизированная проверка конфигураций", позволяющее проверять произвольный код.

1 стартмани

26.03.2019    16961    55    Bazil    25    

Снятие блокировки элементов управляемой формы для редактирования

Универсальные обработки v8 v8::УФ 1cv8.cf Абонемент ($m)

Внешняя обработка + код с одной функций разблокировки элементов управляемой формы владельца для редактирования в любых конфигурациях с использованием БСП. Тестировалось на платформе 8.3.10.2667 и выше

1 стартмани

21.03.2019    5342    4    independ    6    

Методика оптимизации программного кода 1С: проведение документов

Обработка документов Производительность и оптимизация (HighLoad) Инструментарий разработчика v8 v8::УФ Абонемент ($m)

Описание простого метода анализа производительности программного кода 1С, способов его оптимизации и оценки результатов в виде числовых показателей прироста производительности. Не требует сторонних программных продуктов, используются только типовые возможности платформ 1С. Методика проверена на линейке платформ начиная с 1С:Предприятие 8.2 (обычные формы, управляемые формы). Позволяет ускорить проведение проблемных документов в 3 и более раз, провести проверку корректности формирования проводок оптимизированным кодом и подтвердить результаты оптимизации реальными замерами производительности в режиме предприятия. К публикации приложены демонстрационные базы для режимов обычного и управляемого приложения на платформе 1С:Предприятие 8.3 (8.3.9.2033).

1 стартмани

19.03.2019    21858    16    dmitrydemenew    83    

Расширение: Темы для 1С: Предприятия Промо

Работа с интерфейсом v8::УФ 1cv8.cf Абонемент ($m)

Расширение позволяет сменить цвет оформления для интерфейса Такси.

1 стартмани

10.02.2019    12473    56    spec8s    10    

Программное создание реквизита управляемой формы с помощью механизма расширений

Практика программирования Разработка v8 v8::УФ 1cv8.cf Абонемент ($m)

В ЗУП 3 возникла задача добавить реквизит в справочник не внося изменений в конфигурацию. БСП с механизмом дополнительных реквизитов использовать было нежелательно, поэтому был использован механизм расширений. Для вывода данного реквизита на форму добавлять саму форму в расширение не хотелось по ряду причин, описанных ниже. Создание реквизита и элемента формы, соответствующего данному реквизиту было решено сделать программно в самом расширении, следуя принципу минимального воздействия на конфигурацию.

1 стартмани

12.03.2019    30175    8    ni_cola    28    

Инструктор. Прототип инструмента создания быстрых пользовательских инструкций

Пользователю системы Инструментарий разработчика v8 v8::УФ Россия Абонемент ($m)

Прототип дружелюбного и эффективного инструмента для написания пользовательских экспресс-инструкций. Задействована штатная утилита Windows, о существовании которой многие не знают и которая умеет делать огромную работу по логированию действий и снятию скриншотов на всех ПК с Windows (начиная с версии Win7). "Инструктор" не требует никакой установки и дополнительных библиотек! Это означает, что инструмент будет работать и на домашнем ПК и на "чужом ноутбуке" и на терминальном win-сервере у заказчика, где ваши права сильно ограничены. Вы просто подключаете легкую файловую базу 1С и получаете инструмент по снятию скриншотов с интересной функциональностью...

1 стартмани

15.02.2019    11751    42    ROM_NN    8