Внешняя компонента для работы с драйвером "Атол v.10". 1С:8.3

Публикация № 1093799

Разработка - Разработка внешних компонент

Атол Atol KKT ККТ Драйвер Внешняя компонента JSON 10 Чек ККМ Продажа Касса

Внешняя компонента, для работы с драйвером «Атол v.10», посредством JSON-заданий.

Внешняя компонента, для работы с драйвером «Атол v.10», посредством JSON-заданий.
Описание JSON заданий, можно посмотреть на официальном сайте атол: http://integration.atol.ru/api/#json-tasks
Так как атоловский "WEB сервер", работал не стабильно и зависал через 2 часа работы, решил написать свою компоненту.
Компонента позволяет - проверить состояние смены, и оправить JSON-задание.
Для работы необходима библиотека "fptr10.dll" из поставки Атол "Драйвер контрольно-кассовой техники v.10" и VCREDIST 2015.
Рекомендую хранить библиотеку в общем макете для "32bit" и "64bit" систем.

Компонента ведет логи в "папка пользователя"\Documents\NativeAtolKKT.log

При вылетах и системных ошибках нужно смотреть логи.

Список JSON-заданий драйвера Атол v.10:

На данный момент компонента используется для пакетной печати чеков - на один электронный (без печати) чек, уходит 3 секунды.

Внимание перед установкой параметров соединения с ККТ необходимо выполнить "Атол.Инициализировать"


Свойства:

Атол.ПарольДоступа (Атол.AccessPassword)
Синтаксис:
Атол.ПарольДоступа = "30";
Описание:
Использование: чтение, запись.
Тип: Строка.
Устанавливает параметр - пароль доступа.

 

Атол.ПарольПользователя (Атол.UserPassword)
Синтаксис:

Атол.ПарольПользователя = "30";
Описание:
Использование: чтение, запись.
Тип: Строка.
Устанавливает параметр - пароль пользователя.

 

Атол.КаналОФД (Атол.OfdChannel)
Синтаксис:

Атол.КаналОФД = "0";
Описание:
Использование: чтение, запись.
Тип: Строка.
Устанавливает параметр - канал обмена с ОФД.
Значения:
NONE = 0
USB = 1
PROTO = 2

 

Атол.КаналСвязи (Атол.Channel)
Синтаксис:
Атол.КаналСвязи = "2";
Описание:
Использование: чтение, запись.
Тип: Строка.
Устанавливает параметр - способ связи с ККТ.
Значения:
COM = 0
USB = 1
TCPIP = 2
BLUETOOTH = 3

 

Атол.КомСкорость (Атол.BaudRate)
Синтаксис:

Атол.КаналСвязи = "9600";
Описание:
Использование: чтение, запись.
Тип: Строка.
Устанавливает параметр - скорость работы ККТ по RS232.
Значения:
BR_1200 = 1200
BR_2400 = 2400
BR_4800 = 4800
BR_9600 = 9600
BR_19200 = 19200
BR_38400 = 38400
BR_57600 = 57600
BR_115200 = 115200
BR_230400 = 230400
BR_460800 = 460800
BR_921600 = 921600

 

Атол.КомБит (Атол.Bits)
Синтаксис:

Атол.КомБит = "8";
Описание:
Использование: чтение, запись.
Тип: Строка.
Устанавливает параметр - количество бит в байте канала RS232.
Значения:
BITS_7 = 7
BITS_8 = 8

 

Атол.КомСтопБит (Атол.StopBits)
Синтаксис:

Атол.КомСтопБит = "1";
Описание:
Использование: чтение, запись.
Тип: Строка.
Устанавливает параметр - количество стоп-битов канала RS232.
Значения:
SB_1 = 0
SB_1_5 = 1
SB_2 = 2

 

Атол.КомЧетность (Атол.Parity)
Синтаксис:

Атол.КомЧетность = "0";
Описание:
Использование: чтение, запись.
Тип: Строка.
Устанавливает параметр - четность канала RS232.
Значения:
PARITY_NO - нет = 0
PARITY_ODD - четность = 1
PARITY_EVEN - нечетность = 2
PARITY_MARK - установлена = 3
PARITY_SPACE - сброшена = 4

 

Атол.КомПорт (Атол.ComFile)
Синтаксис:

Атол.КомПорт = "1";
Описание:
Использование: чтение, запись.
Тип: Строка.
Устанавливает параметр - номер порта.
Значения: идентификатор порта. Для Windows - номер COM-порта (например, "15" или "COM15").
Для Linux - путь к TTY-файлу (например, "/dev/ttyS5" или "/dev/ttyACM0").


Атол.ЛинуксПутьКУСБ (Атол.UsbDevicePath)
Синтаксис:

Атол.ЛинуксПутьКУСБ = "auto";
Описание:
Использование: чтение, запись.
Тип: Строка.
Устанавливает параметр - расположение USB-устройства в системе (только Linux).
Значения: расположение USB-устройства в системе (только Linux).
Если настройка не указана, имеет значение "auto" или пустое значение, то поиск и подключение к устройству будет проводиться по известным драйверу VendorID и ProductID.
На Windows подключение всегда ведется по VendorID и ProductID.


Атол.ИПАдрес (Атол.IPAddress)
Синтаксис:

Атол.ИПАдрес = "192.168.1.25";
Описание:
Использование: чтение, запись.
Тип: Строка.
Устанавливает параметр - IP-адрес ККТ.
Значения: Может быть как ip-адресом, так и hostname-ом.

 

Атол.ИППорт (Атол.IPPort)
Синтаксис:

Атол.ИППорт = "5555";
Описание:
Использование: чтение, запись.
Тип: Строка.
Устанавливает параметр - IP-порт ККТ.
Значения: 1-65535

 

Атол.МАКАдрес (Атол.MACAddress)
Синтаксис:

Атол.МАКАдрес = "FF:FF:FF:FF:FF:FF";
Описание:
Использование: чтение, запись.
Тип: Строка.
Устанавливает параметр - Bluetooth MAC-адрес ККТ.
Значения: Bluetooth MAC-адрес ККТ.
Устройство должно быть предварительно сопряжено с хостом средствами ОС.

 

Атол.Ошибка (Атол.GetError)
Синтаксис:

Сообщить(Атол.Ошибка);
Описание:
Использование: чтение.
Тип: Строка.
Возвращает последнюю ошибку компоненты.

 

Атол.КодОшибки (Атол.GetErrorCode)
Синтаксис:

Сообщить(Атол.КодОшибки);
Описание:
Использование: чтение.
Тип: Целое число.
Возвращает код ошибки, драйвера Атол. (используется как проверка на "ошибок нет" = 0)
Описание кодов, можно посмотреть в документации: http://integration.atol.ru/api/#f9886ca2bc

 

Атол.СостояниеСоединения (Атол.Opened)
Синтаксис:

Сообщить(Атол.СостояниеСоединения);
Описание:
Использование: чтение.
Тип: Булево.
Возвращает "истина" если соединение с ККТ установлено, иначе "ложь".


Атол.СостояниеСмены (Атол.Shift_State)
Синтаксис:

Сообщить(Атол.СостояниеСмены);
Описание:
Использование: чтение.
Тип: Целое число.
Возвращаемое значение:
Смена открыта = 0
Смена закрыта = 1
Смена истекла = 2

Функции:

Атол.Инициализировать (Атол.Initialize)
Синтаксис:

Атол.Инициализировать(<ПутьКбиблиотеке_fptr10.dll>);
Параметры:
<ПутьКбиблиотеке_fptr10.dll> - путь к библиотеке драйвера Атол 10, на диске.
Возвращаемое значение: булево, (истина - успех)
Описание:
Подключает библиотеку (fptr10.dll) драйвера атол.
Библиотеку нужно указвать той-же разрядности что и 1С.

 

Атол.Открыть (Атол.Open)
Синтаксис:

Атол.Открыть();
Возвращаемое значение: булево, (истина - успех)
Описание:
Открывает соединение с ККТ.

 

Атол.Закрыть (Атол.Close)
Синтаксис:

Атол.Закрыть();
Возвращаемое значение: булево, (истина - успех)
Описание:
Закрывает соединение с ККТ.

 

Атол.ОтправитьJSON (Атол.RequestJSON)
Синтаксис:

ОтветJSON = Атол.ОтправитьJSON(<JSONтекст>);
Параметры:
<JSONтекст> - текст с JSON структурой.
Возвращаемое значение: Строка (Текст с JSON структурой.) Описание смотри в документации: http://integration.atol.ru/api/#json-tasks
Описание:
Отправляет JSON-задание на ККТ.

 

************************************************

Пример реализации:

ОбщийМакет.АтолККТ - двоичные данные, "zip" архив внешней компоненты. 

ОбщийМакет.fptr10x64 - библиотека драйвера Атол 64 битная.

ОбщийМакет.fptr10 - библиотека драйвера Атол 32 битная.

Общий модуль: МодульККТ


Функция ПодключитьАтолКомпоненту() Экспорт 
	
	Попытка
		Если НЕ ПустаяСтрока(ПараметрыСеанса.АдресХранилищаАтолСоединение) Тогда
			Подключение = ПолучитьИзВременногоХранилища(ПараметрыСеанса.АдресХранилищаАтолСоединение).АтолККТ;
			Возврат Подключение;
		КонецЕсли;
	Исключение
		ПараметрыСеанса.АдресХранилищаАтолСоединение = "";
	КонецПопытки;	
	
	КомпУст=Ложь;
	Попытка
		КомпУст=ПодключитьВнешнююКомпоненту("ОбщийМакет.АтолККТ","NativeAtol",ТипВнешнейКомпоненты.Native);
	Исключение
		ПоказатьОповещениеПользователя("Произошла исключительная ошибка при подключении компоненты!",,ОписаниеОшибки(),БиблиотекаКартинок.Остановить);
	КонецПопытки;
	Если Не КомпУст Тогда
		ПоказатьОповещениеПользователя("Произошла ошибка при подключении компоненты!",,"",БиблиотекаКартинок.Остановить);
	КонецЕсли;
	
	Попытка 
		СисИнфо = Новый СистемнаяИнформация;
		Если СисИнфо.ТипПлатформы = ТипПлатформы.Windows_x86 Тогда
			ПолучитьОбщийМакет("fptr10").Записать(КаталогВременныхФайлов()+"fptr10.dll");
		ИначеЕсли СисИнфо.ТипПлатформы = ТипПлатформы.Windows_x86_64 Тогда
			ПолучитьОбщийМакет("fptr10x64").Записать(КаталогВременныхФайлов()+"fptr10.dll");
		КонецЕсли;
	Исключение
		ЗаписьЖурналаРегистрации("АтолККТ",УровеньЖурналаРегистрации.Ошибка,,ОписаниеОшибки());
		//Возврат Неопределено;
	КонецПопытки;
	
	АтолККТ = Новый("AddIn.NativeAtol.АтолККТ");
	АтолККТ.Инициализировать(КаталогВременныхФайлов()+"fptr10.dll");
	АтолККТ.КаналСвязи = "2"; 
	АтолККТ.ИПАдрес = СокрЛП(Константы.ИпАдресСервераККТ.Получить());
	АтолККТ.ИППорт = "5555";
	
	Попытка
		СтруктураАтолКомпонента = Новый Структура("АтолККТ",АтолККТ);
		АдресАтолККТ = ПоместитьВоВременноеХранилище(СтруктураАтолКомпонента,Новый УникальныйИдентификатор);
		ПараметрыСеанса.АдресХранилищаАтолСоединение = АдресАтолККТ;
		Возврат АтолККТ;
	Исключение
		ЗаписьЖурналаРегистрации("АтолККТ",УровеньЖурналаРегистрации.Ошибка,,ОписаниеОшибки());
		Возврат Неопределено;
	КонецПопытки;
	
КонецФункции

Функция СформироватьJSONЧек(Продажа,ТелоЧека) Экспорт  //Продажа(истина) - продажа, возврат продажи
	//ТелоЧека-структура с данными чека(Оператор;Итог;ЕмаилИлиТелефон,ИмяКлиента,ИННКлиента;СтрокиЧека-массив со структурами(Наименование,Цена,Количество,Сумма,НДС)) 
	
	Чек = Новый Структура;
	Позиции = Новый Массив;
	Оплаты = Новый Массив;
	
	Для Каждого ПозицияЧека Из ТелоЧека.СтрокиЧека Цикл 
		Позиция = Новый Структура;
		Позиция.Вставить("type","position");
		Позиция.Вставить("name",ПозицияЧека.Наименование);
		Позиция.Вставить("price",ПозицияЧека.Цена);
		Позиция.Вставить("quantity",ПозицияЧека.Количество);
		Позиция.Вставить("amount",ПозицияЧека.Сумма);
		Позиция.Вставить("department",1);
		Позиция.Вставить("paymentMethod","fullPayment");
		Позиция.Вставить("paymentObject","service");
		Позиция.Вставить("tax",Новый Структура("type",ПолучитьНалог(ПозицияЧека.НДС)));
		Позиции.Добавить(Позиция);
	КонецЦикла;
	
	Оплаты.Вставить(0,Новый Структура("type,sum","electronically",ТелоЧека.Итог));
	
	Чек.Вставить("type",?(Продажа = Истина,"sell","sellReturn"));
	Чек.Вставить("taxationType","osn");
	Чек.Вставить("electronically",Истина);
	Чек.Вставить("operator",Новый Структура("name",ТелоЧека.Оператор));
	Чек.Вставить("clientInfo",Новый Структура("emailOrPhone,name,vatin",ТелоЧека.ЕмаилИлиТелефон,ТелоЧека.ИмяКлиента,ТелоЧека.ИННКлиента));
	Чек.Вставить("items",Позиции);
	Чек.Вставить("payments",Оплаты);
	Чек.Вставить("total",ТелоЧека.Итог);

	ЗаписьJSON = Новый ЗаписьJSON;
	ЗаписьJSON.УстановитьСтроку();
	ЗаписатьJSON(ЗаписьJSON,Чек);
	ДанныеJson = ЗаписьJSON.Закрыть();
	
	Возврат ДанныеJson;
	
КонецФункции

Функция ПолучитьСтруктуруJSON(ОтветJson) Экспорт 
	
	ЧтениеJSON = Новый ЧтениеJSON;
	ЧтениеJSON.УстановитьСтроку(ОтветJson);
	СтруктураJson = ПрочитатьJSON(ЧтениеJSON);
	ЧтениеJSON.Закрыть();
	
	
	fiscalParams = ЗначениеСвойстваJSON(СтруктураJson,"fiscalParams"); //чек
	shiftStatus = ЗначениеСвойстваJSON(СтруктураJson,"shiftStatus");   //состояние смены
	
	ОтветСтруктура = Новый Структура;
	Если НЕ fiscalParams = Неопределено Тогда 
		ОтветСтруктура.Вставить("ДатаВремяЧека",ПрочитатьДатуJSON(fiscalParams.fiscalDocumentDateTime,ФорматДатыJSON.ISO));
		ОтветСтруктура.Вставить("ФПДЧека",fiscalParams.fiscalDocumentSign);
		ОтветСтруктура.Вставить("РегНомерККТ",fiscalParams.registrationNumber);
		ОтветСтруктура.Вставить("НомерФДЧека",fiscalParams.fiscalDocumentNumber);
	КонецЕсли;	
	Если НЕ shiftStatus = Неопределено Тогда
		ОтветСтруктура.Вставить("СтатусСмены",shiftStatus.state);
		ОтветСтруктура.Вставить("СменаИстечет",ПрочитатьДатуJSON(shiftStatus.expiredTime,ФорматДатыJSON.ISO));
	КонецЕсли;
	
	Возврат ОтветСтруктура;
	
КонецФункции

Функция ОткрытьПроверитьСмену(ИмяОператора) Экспорт 
	
	АтолККТ = ПодключитьАтолКомпоненту();
	СостояниеСмены = АтолККТ.СостояниеСмены;
	Если АтолККТ.КодОшибки = 0 Тогда 
		Если СостояниеСмены = 0 Тогда //закрыта
			json="{""type"": ""openShift"",""electronically"":""true"",""operator"": {""name"": """+ИмяОператора+"""}}";
			ОтветJSON = АтолККТ.ОтправитьJSON(json);
			Если АтолККТ.КодОшибки = 0 Тогда 
				Возврат Истина;
				//Результат = ПолучитьСтруктуруJSON(ОтветJSON);
			Иначе 
				ПоказатьОповещениеПользователя("Ошибка открытия смены!",,АтолККТ.Ошибка,БиблиотекаКартинок.Остановить);
			КонецЕсли;
		ИначеЕсли СостояниеСмены = 1 Тогда //открыта
			Возврат Истина;
		ИначеЕсли СостояниеСмены = 2 Тогда //просрочена
			ПоказатьОповещениеПользователя("Внимание!",,"Смена истекла",БиблиотекаКартинок.Остановить);
			Возврат Ложь;
		КонецЕсли;
	Иначе 
		ПоказатьОповещениеПользователя("Ошибка проверки состояния смены!",,АтолККТ.Ошибка,БиблиотекаКартинок.Остановить);
	КонецЕсли;
	
	Возврат Ложь;
	
КонецФункции

Функция ЗакрытьСмену(ИмяОператора) Экспорт 
	
	АтолККТ = ПодключитьАтолКомпоненту();
	СостояниеСмены = АтолККТ.СостояниеСмены;
	Если АтолККТ.КодОшибки = 0 Тогда 
		Если НЕ СостояниеСмены = 0 Тогда 
			json="{""type"": ""closeShift"",""electronically"":""true"",""operator"": {""name"": """+ИмяОператора+"""}}";
			ОтветJSON = АтолККТ.ОтправитьJSON(json);
			Если АтолККТ.КодОшибки = 0 Тогда 
				Возврат Истина;
				//Результат = ПолучитьСтруктуруJSON(ОтветJSON);
			Иначе 
				ПоказатьОповещениеПользователя("Ошибка закрытия смены!",,АтолККТ.Ошибка,БиблиотекаКартинок.Остановить);
			КонецЕсли;
		ИначеЕсли СостояниеСмены = 0 Тогда //закрыта
			Возврат Истина;
		КонецЕсли;
	Иначе 
		 ПоказатьОповещениеПользователя("Ошибка проверки состояния смены!",,АтолККТ.Ошибка,БиблиотекаКартинок.Остановить);
	КонецЕсли;
	
	Возврат Ложь;
	
КонецФункции

Функция ПолучитьНалог(НДС) //НДС - текст
	
	Налог = "none"; //БезНДС
	Если НДС = Перечисления.СтавкиНДС.БезНДС Тогда 
		Налог = "none";
	ИначеЕсли НДС = Перечисления.СтавкиНДС.НДС18 Тогда 
		Налог = "vat18";
	ИначеЕсли НДС = Перечисления.СтавкиНДС.НДС20 Тогда 
		Налог = "vat20";
	ИначеЕсли НДС = Перечисления.СтавкиНДС.НДС0 Тогда 
		Налог = "vat0";
	ИначеЕсли НДС = Перечисления.СтавкиНДС.НДС10 Тогда 
		Налог = "vat10";
	КонецЕсли;
	Возврат Налог;
	
КонецФункции

Функция ЗначениеСвойстваJSON(ОбъектСвойства,Свойство)
	
	Если ОбъектСвойства = Неопределено Тогда 
		Возврат Неопределено;
	КонецЕсли;
	ВремЗначение = Неопределено;
	Если ОбъектСвойства.Свойство(Свойство,ВремЗначение) Тогда 
		Возврат ВремЗначение;
	Иначе
		Возврат Неопределено;
	КонецЕсли;
	
КонецФункции


Функция печати чека:

функция Чек()
	АтолККТ = МодульККТ.ПодключитьАтолКомпоненту();
	Если АтолККТ.Открыть() Тогда
		//ЕСЛИ СМЕНА ЗАКРЫТА ОТКРЫВАЕМ
		Если МодульККТ.ОткрытьПроверитьСмену(Объект.Оператор.Наименование) Тогда
			
			СтрокиЧека = Новый Массив;
			Позиция = Новый Структура("Наименование,Цена,Количество,Сумма,НДС","сапоги",154.12,2,308.24, Перечисления.СтавкиНДС.БезНДС);
			СтрокиЧека.Добавить(Позиция);
			
			ТелоЧека = Новый Структура;
			ТелоЧека.Вставить("Оператор","оператор1");
			ТелоЧека.Вставить("ЕмаилИлиТелефон","a@a.a");//если поле будет пустым, чек распечатается.
			ТелоЧека.Вставить("ИмяКлиента","Пупкин.П.П");
			ТелоЧека.Вставить("ИННКлиента","12121212121");
			ТелоЧека.Вставить("Итог",308.24);
			ТелоЧека.Вставить("СтрокиЧека",СтрокиЧека);
			//отправка чека
			//ТелоЧека-структура с данными чека(Оператор;Итог;ЕмаилИлиТелефон,ИмяКлиента,ИННКлиента;СтрокиЧека-массив со структурами(Наименование,Цена,Количество,Сумма,НДС)) 
			ОтветJSON = АтолККТ.ОтправитьJSON(МодульККТ.СформироватьJSONЧек(Продажа,ТелоЧека));
			Если АтолККТ.КодОшибки = 0 Тогда 
				//ошибок нет получаем результат
				Результат = МодульККТ.ПолучитьСтруктуруJSON(ОтветJSON);
				//обрабатываем результат
			Иначе 
				//АтолККТ.Ошибка;
				//АтолККТ.КодОшибки;
			КонецЕсли;
			
			Если НЕ АтолККТ.КодОшибки = 0 Тогда
				ПоказатьОповещениеПользователя("Ошибка чека, отправка прервана!",,АтолККТ.Ошибка,БиблиотекаКартинок.Остановить);
				Возврат Ложь;
			КонецЕсли;
		КонецЕсли;
		
		АтолККТ.Закрыть();
		Возврат Истина;
	Иначе
		ПоказатьПредупреждение(,АтолККТ.Ошибка,0,"Ошибка подключения к кассе!");
		Возврат Ложь;
	КонецЕсли;
конецфункции

 

Скачать файлы

Наименование Файл Версия Размер
1С8.3: Внешняя компонента, для работы с драйвером «Атол v.10»: Атол ККТ zip

.zip 203,40Kb
22
.zip 1 203,40Kb 22 Скачать
Библиотеки драйвера Атол ККТ 10 (32-64 бит) - можно скачать с сайта атол

.7z 1,34Mb
8
.7z 10 1,34Mb 8 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. alex_makhnov 07.02.20 17:35 Сейчас в теме
Все хорошо, но почему-то на ОтветJSON = Атол.ОтправитьJSON(<JSONтекст>); 1С вылетает.
При этом чек пробивается...
2. gortrex 59 08.02.20 22:20 Сейчас в теме
(1) Посмотрите логи компоненты, они находятся в папке документы: "папка пользователя"\Documents\NativeAtolKKT.log
3. Vil1983 29.06.20 16:17 Сейчас в теме
А с чем может быть связанна проблема вылета 1с после запрос? Отправляю команду снятия Х-отчета, без каких либо доп параметров. Отчет выходит, но тут же по ошибке закрывается 1с, не переходит даже на следующую строку кода.
4. gortrex 59 03.07.20 21:05 Сейчас в теме
(3)Посмотрите логи компоненты, они находятся в папке документы: "папка пользователя"\Documents\NativeAtolKKT.log
5. mol70 13.12.20 16:00 Сейчас в теме
Купил обработку нужна срочно небольшая консультация
Оставьте свое сообщение

См. также

Пакетное пробитие чеков на Онлайн-кассе при оплатах от физических лиц на расчетный счет Промо

Банковские операции Кассовые операции Обработка документов v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Автоматизация процесса пробития чеков онлайн при поступлениях на расчетный счет от физических лиц. Помогает сократить трудозатраты таким организациям, как МФЦ, Управляющие компании и т.д. Подходит для 1С:Бухгалтерия 3.0 любой версии (базовая, ПРОФ, КОРП). Не изменяет конфигурацию. Конфигурация остается на поддержке (типовая).

2 стартмани

24.09.2019    14410    4    r.resh39    6    

Использование встроенного сканера ТСД на Android в мобильном клиенте и мобильном приложении (драйвер сканера Android для 1С)

Разработка внешних компонент Мобильная разработка v8 Абонемент ($m)

Используя данный драйвер, можно без единой строки кода, просто установив на ТСД мобильный клиент 1С, сразу начать подбирать товары в документах вашей учётной системы. А, адаптировав нужные формы под небольшой размер экрана ТСД, можно просто создать полноценное рабочее место для выполнения операций с помощью ТСД, не прибегая к стороннему софту. Если же на складе плохая связь (или её нет вовсе), то можно использовать возможности мобильного клиента в автономном режиме (потребуется доработка вашей конфигурации). Драйвер также можно использовать и для Android приложения на мобильной платформе. В результате чего можно обойтись без ненужных полей ввода и клавиатуры «на пол-экрана».

3 стартмани

09.10.2020    7524    74    ltfriend    71    

Диагностика контекста выполнения (внешняя компонента)

Разработка внешних компонент v8 1cv8.cf Абонемент ($m)

Небольшая экспериментальная внешняя компонента для получения дополнительной информации о контексте выполнения.

1 стартмани

24.07.2020    5793    2    YPermitin    14    

Универсальная обертка для использования NATIVE компонент на платформе 1С 7.7, 8.0 и 8.1

Разработка внешних компонент v8 Абонемент ($m)

Используете 1С 7.7, 8.0 или 8.1 и вас раздражает, что под вашу 1С уже не выпускаются современные компоненты. А хотелось бы?

1 стартмани

07.07.2020    3904    7    karpik666    4    

Внешняя компонента для работы по Web-socket протоколу x32 x64 Промо

Разработка внешних компонент WEB v8 Абонемент ($m)

Кто когда-нибудь сталкивался с обменом данными по Web-Socket (wss) протоколу из 1С, тому известно, что в платформе отсутствуют данные механизмы (не путать с HTTP запросами и WebServices). Предлагается использовать внешнюю компоненту, написанную по технологии NativeAPI, для подключения и обмена с серверами из 1С-Предприятия, работающими по протоколу Web-Socket.

1 стартмани

30.03.2018    29278    36    Ditron    86    

Нано HTTP сервер - внешняя компонента для мобильного приложения 1C, на Android

Разработка внешних компонент Мобильная разработка v8 v8::Mobile 1cv8.cf Абонемент ($m)

Нано HTTP сервер на терминале сбора данных "ATOL Smart.Lite android 7.0". Работает только с GET и POST запросами. Аутентификация BASE64. Не поддерживает HTTPS и не передает файлы. В прикрепленном архиве исходники на компоненту (С++ и java для Android Studio 3.6.2), ЦФ - мобильного приложения и тестовая обработка.

1 стартмани

22.06.2020    3814    10    SanyMaga    19    

Кассовая программа "АрсКасса" на C# - без ограничений

Розничная торговля Кассовые операции Рабочее место v8 Розница Розничная и сетевая торговля (FMCG) Россия УУ Абонемент ($m)

Кассовая программа "АрсКасса" предназначена для автоматизации рабочего места кассира, без дополнительных затрат на покупку лицензий ПО.

1 стартмани

03.05.2020    5671    17    coolseo    7    

Получение фото с веб-камеры

Разработка внешних компонент v8 Абонемент ($m)

Получение фото с веб-камеры без ActiveX. Внешняя компонента по технологии Native API.

1 стартмани

25.03.2020    6793    61    berezdetsky    40    

Печать чеков для ККМ АТОЛ и ШТРИХ на основании текстового файла, где содержится описание товаров, цен, НДС (все требования 54-ФЗ, поддержка изменений от 01/07/19). Для 1С (7.7 и 8 УФ, обычных форм) есть готовые обработки Промо

ККМ Фискальный регистратор Кассовые операции Оптовая торговля Розничная торговля Кассовые операции Оптовая торговля Розничная торговля v7.7 v8 v8::УФ 1cv8.cf 1cv7.md Россия Абонемент ($m)

Это программа печати чеков, которая читает обычный текстовый файл, где перечислено, что надо распечатать на ФР - описание содержимого чека. Такой механизм позволяет использовать комплект для WEB сайтов, для не типовых или сильно измененных 1с7 или 1с8. Для любых программ которые умеют работать с текстовыми файлами (будь то CLIPPER,FOXPRO,JAVA, WSH, VBS итд). Внутри комплекта лежат готовые внешние печатные формы для печати из документов Реализация товаров и услуг 1с8 УТ10, БП2, БП2Базовая, БП2Корп, УТ11, БП3, БП3Базовая, БП3Корп, Для 1с:ТиС 7.7 Реализация ТМЦ, Бух4.5, Бух1.3 и Печать из ПКО Подключать ФР к 1С не надо! Не надо открывать смену. Подходит для любой конфигурации, для любого документа. Более 300 внедрений на ккм Штрих-Мини-ФР-К, Штрих ОнЛайн Атол 11Ф, 55Ф, 30. Возможна пробитие оплаты наличным или VISA  (Электронные деньги). Поддерживает передачу в ОФД имени кассира, телефон или email покупателя. Для каждого чека можно поменять ОСН (ЕНВД, Доходы-расходы итд). Возможна печать чека с выровненными колонками, Наименование,Количество Цена, Сумма, в этом случае фискализация будет одной строкой с общей суммой. Можно пробить не фискальный чек. (чек будет, но в налоговую не уйдет). Добавлена расшифровка длинных наименований, что актуально для Штрих (программа сама переносит длинные наименования на след строку). Есть внесение и выплата денег. 29.06.17 добавлено пробитие 2 видов оплат в одном чеке.

10 стартмани

11.04.2017    75345    222    ah7777777    575    

Маркировка в УТ 10.3.59.2: ошибки в релизе

Кассовые операции Розничная торговля v8 УТ10 Россия Абонемент ($m)

Вышел релиз УТ 10.3.59.2, в котором реализована поддержка маркировки обуви. Релиз содержит некоторое количество ошибок, не позволяющих использовать его при продаже обуви.

1 стартмани

28.02.2020    23439    4    Sholl    72    

Быстрая печать этикеток (ZPL, EPL, TSPL, EZPL, GEPL, TSPL-EZ)

Разработка внешних компонент v8 v8::УФ 1cv8.cf Абонемент ($m)

Качественная и быстрая печать на внутреннем языке принтеров этикеток.

4 стартмани

02.02.2020    8499    34    Johny_v    13    

Выставление счета ссылкой на оплату через платежный шлюз Сбербанка из интерфейса 1С

Банковские операции Кассовые операции Оптовая торговля Розничная торговля v7.7 v8 1cv8.cf 1cv7.md Россия Абонемент ($m)

Внешняя обработка для выбора документа и формирования ссылки на оплату, которую можно скопировать в буфер обмена и отправить любыми средствами. Совместимо с интернет-эквайрингом Сбербанк.

1 стартмани

14.01.2020    13988    78    etmarket    37    

TextRadar - нечеткий поиск в тексте Промо

Разработка внешних компонент Поиск данных v8 1cv8.cf Абонемент ($m)

В отличие от нечеткого сравнения строк, когда обе сравниваемых строки равнозначны, в задаче нечеткого поиска выделяются строка поиска и строка данных, а вычислить необходимо не степень похожести двух строк, а степень присутствия строки поиска в строке данных. Нормированный коэффициент, находящийся между 0 и 1 позволяет отсечь заведомо низкие результаты, организовать поиск по синонимам и т.д. Наглядное отображение результатов в кратком и детальном виде поможет быстро найти интересующий фрагмент.

1 стартмани

19.09.2018    19264    30    TSSV    19    

Сканирование по TWAIN в 1С (обычные и управляемые формы)

Разработка внешних компонент v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработка показывает пример, как можно в 1С проводить сканирование с помощью компоненты TWAIN.

3 стартмани

03.01.2020    6524    27    Denr83    0    

Слипы вышли, а чек - нет!

Розничная торговля Расширения Кассовые операции v8 v8::УФ Розница Розничная и сетевая торговля (FMCG) Россия Абонемент ($m)

Флаг устанавливающий Эквайринговый терминал как эмулятор для пробития чеков по карте.

1 стартмани

14.11.2019    20683    44    obmanOZ    39    

Маленькая и скромная мобильная внешняя компонента

Разработка внешних компонент v8 Абонемент ($m)

Изваять простенькую мобильную компоненту на 1С для android не так-то просто. Посему назло отдельным супостатам, не желающим делится исходниками, представляю весь свой скромный труд на публичный суд.

1 стартмани

21.10.2019    10275    6    ripreal1    34    

Native внешняя компонента для оповещения по UDP или TCP

Разработка внешних компонент v8 Абонемент ($m)

Native внешняя компонента для оповещения по UDP или TCP, которая реализует возможность в 1С передавать сообщения с сервера на клиента. Исходный код компоненты также представлен.

1 стартмани

06.10.2019    11391    24    vdv2701    31    

Внешняя компонента Sundries: несколько полезных системных функций

Разработка внешних компонент v8 Абонемент ($m)

Звук, пауза, буфер обмена, раскладки клавиатуры и т.д.

4 стартмани

30.08.2019    6679    8    sivin-alexey    12    

1С:Деньги - Автоматическое заполнение расходов по QR-кодам чеков с помощью API ФНС

Обработка документов WEB Банковские операции Кассовые операции Банковские операции Кассовые операции v8 1cv8.cf Домашние учет и финансы Россия УУ Абонемент ($m)

UPDATE 2020.11 Учтено новое API взаимодействия с серверами проверки чеков ФНС. Реализована верификация по номеру телефона и кода из SMS. Обработка поможет сократить время на ввод данных о расходах в 1С:Деньги. Достаточно отсканировать QR-код чека смартфоном, с предустановленным официальным приложением проверки чеков от ФНС. Данные чека будут загружены в базу из данных электронного чека, которые хранятся на серверах ФНС. Обработка протестирована на последнем релизе 2.0.36.18.

1 стартмани

28.07.2019    8632    39    1sig    29    

Быстрая настройка ККМ из 1С с использованием драйвера от Атол без тест-драйвера Промо

Кассовые операции ККМ Кассовые операции v8 Розница Абонемент ($m)

В нашей компании на кассовых местах подключено несколько ККМ от Атола. При подключении к штатным разъемам USB на материнской плате все работает без проблем. Проблемы в тех магазинах, где кассы подключаются через USB-Hub. Данная обработка позволяет быстро, без запуска "Тест-драйвера" и "Управление драйверами", настроить кассовое оборудование. Протестировано на 32-х битной версии 1С и конфигурации 1С:Розница 2.2 с версиями драйверов от Атол 8.16.1.8701 и 9.12.1.6236

1 стартмани

27.08.2018    20558    13    valerasv    7    

Печать покупателя в чеке ККМ с 01.07.2019

ККМ Кассовые операции Печатные формы документов Кассовые операции v8 ERP2 БУ Абонемент ($m)

C 01.07.2019 если организация/ИП покупает у другой организации/ИП товары, работы или услуги, то в Чеке ККМ требуется указать: Покупателя (тег 1227) и ИНН (тег 1228). Если чек отправляется в ОФД без этих данных, то будет штраф . Но в 1С ERP вывод данных полей не предусмотрен. Предлагаемое расширение устраняет данную проблему.

1 стартмани

17.07.2019    30486    22    sapervodichka    14    

Обработка вывода на печать QR-кода и штрихкодов в различных форматах (одномерные и двумерные)

Разработка внешних компонент Ценники v8 v8::УФ 1cv8.cf Россия Абонемент ($m)

Обработка предназначена для вывода на печать QR-кода и штрихкодов в различных форматах без установки дополнительных ActiveX компонент. Тестировалась на чистой базе платформы 1С:Предприятие 8.3 (8.3.14.1630), а так же в конфигурациях Бухгалтерия предприятия КОРП, редакция (3.0.69.35) и на Бухгалтерия предприятия (3.0.70.30)

2 стартмани

22.05.2019    11690    45    MGemini    3    

DLL для обмена между 1С (и не только) через UDP порты (32/64 клиенты)

Разработка внешних компонент v8 1cv8.cf Россия Абонемент ($m)

Библиотеки для создания функционала для прослушивания портов из 1С и отправки сообщений на удаленный udp порт.

1 стартмани

28.02.2019    7906    9    xxxAndricxxx    2    

Использование сборок .NET в 1С 7. и 8.x. Создание внешних Компонент. Промо

Разработка внешних компонент v7.7 v8 1cv8.cf 1cv7.md Абонемент ($m)

Данная разработка создана для использования сборок .Net в 1С через преобразование объектов и классов в COM-объекты, которые можно использовать в 1С. Достигается это путем создания класса, реализующего методы интерфейса IReflect public class AutoWrap: IReflect.

1 стартмани

28.11.2013    86035    279    Serginio    74    

API Яндекс.Кассы v4 и 1С

WEB Кассовые операции Кассовые операции v8 v8::ОУ УТ11 Россия Абонемент ($m)

Работа с api яндекс кассы v4.

1 стартмани

29.01.2019    9021    23    kickout    2    

Эмулятор ККМ по стандарту ФФД 1.1

Разработка внешних компонент Кассовые операции ККМ Кассовые операции v8 Розница УТ11 Россия Абонемент ($m)

Эмулятор драйвера ККМ по стандарту ФФД 1.1 предназначен для использования всех возможностей программы, при отсутствии физической кассы. Подойдет как программистам при разработке интерфейса РМК, например, так и пользователям для тестирования возможностей программы.

1 стартмани

30.12.2018    24497    146    Matveymc    28    

ККТ Атол: настраиваем работу по новому порядку. 54ФЗ, ФФД 1.05, НДС 20%. + Работа ККТ по сети или как работать c ККТ из терминального сервера RDP + Работа в LINUX

ККМ Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 УТ10 УПП1 Абонемент ($m)

Настройка ККТ АТОЛ для работы по сети. Обработка обслуживания ККТ для конфигураций на обычных формах. Тестировал на УПП 1.3.106.2, УТ10.3.47.3. Платформа 8.3.10.2753

1 стартмани

14.12.2018    69632    78    Johny_v    48    

Пробитие чеков через ККМ в офисе (для курьеров) Промо

ККМ Фискальный регистратор Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 v8::ОУ Розница УТ11 Россия БУ Абонемент ($m)

Предлагается интеграция 1С с ККТ СтарРус. Поддерживается одновременная работа с разных рабочих мест. ККТ СтарРус работает как сервер, и принимает команды через API по http-протоколу, что позволяет пробивать чеки через центральную базу 1С для интернет-магазина и для курьеров.

1 стартмани

07.06.2018    34404    28    Kutuzov    12    

АТОЛ ВЕБ-СЕРВИС 54ФЗ. Для работы с онлайн-кассами АТОЛ через веб-сервер (Ревизия 3002)

ККМ Кассовые операции Кассовые операции v8 КА1 УТ10 УПП1 БГУ БАУ 1С:CRM Россия Абонемент ($m)

Хотите ускорить печать чеков, или печатать с разных рабочих мест на один фискальный регистратор? В этом вам поможет, настроенный веб-сервис от фирмы АТОЛ, а данная разработка позволит интегрировать его с вашей программой 1С.

4 стартмани

03.12.2018    46520    279    karpik666    419    

WebSocket Клиент / Сервер. Внешний компонент

Разработка внешних компонент v8 1cv8.cf Абонемент ($m)

Реализация протокола WebSocket. Клиентская часть для взаимодействия с внешними сервисами. Серверная часть для организации собственного сервера, принимающего клиентские соединения в многопоточном режиме. Возможно взаимодействие RabbitMQ Slack Asterisk и другие

1 стартмани

16.11.2018    18147    81    nomadon    66    

Внешняя компонента для выполнения регулярных выражений

Разработка внешних компонент v8 Абонемент ($m)

Внешняя Native API компонента для выполнения регулярных выражений на платформе 1С:Предприятие 8. Написана на C++. Используется движок boost::regex (v 1.69, v 1.68 - для Android). Версия синтаксиса Perl Compatible Regular Expressions.

1 стартмани

12.11.2018    13883    33    KAV2    64    

Tool1CD Beta в деле Промо

Разработка внешних компонент v8 Абонемент ($m)

Пс, парень! Не хочешь немного сырых байтов?

1 стартмани

09.05.2018    27369    30    baton_pk    26    

Загрузка чека онлайн-касс (загрузка товаров из чека)

Внешние источники данных WEB Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 1cv8.cf Абонемент ($m)

Обработка-пример, позволяет любому и из любой конфигурации загрузить информацию о товарах из чека(и не только) из почтового сообщения, отправленного из приложения ФНС проверка чеков.

2 стартмани

08.10.2018    23452    39    echo77    73    

001. Криптография и цифровая подпись RSA-sha256 на платформе 1С

Разработка внешних компонент v8 1cv8.cf Абонемент ($m)

Внешняя компонента, исходники, обработка для 1С.

5 стартмани

04.09.2018    16404    30    Nikola23    69    

Продажа с двух касс ККМ в 1С:Розница 2.2, Розница2.3, Розница Аптека 2.3. Выбор, по какой кассе пробить чек

ККМ Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 Розница Абонемент ($m)

Данное расширение конфигурации позволяет выбрать из списка кассу (ККМ), по которой необходимо пробить чек.

3 стартмани

09.08.2018    16859    70    pogroleg    107    

БП 2.0 онлайн-касса (ККТ с передачей данных) 54 ФЗ Промо

ККМ Фискальный регистратор Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 v8::БУ БП2.0 Россия БУ Абонемент ($m)

Изменения для объединения с конфигурацией "Бухгалтерия предприятия 2.0" с функционалом для работы с ККТ с передачей данных в ОФД (онлайн-касса), сделана согласно методическим указаниям.

2 стартмани

09.07.2017    46963    158    bob_    58    

Класс-обработка “Работа с картами Яндекс”

Разработка внешних компонент WEB v8 Абонемент ($m)

Как показать точку или маршрут на карте Яндекс. Как получить координаты по строке адреса (геокодирование).

1 стартмани

01.08.2018    27889    214    RSConsulting    17    

Эмулятор эквайрингового терминала

ККМ Кассовые операции Кассовые операции v8 Розница Россия УУ Абонемент ($m)

Эмулятор эквайрингового терминала для тестирования взаимодействий с разрабатываемыми или типовыми решениями.

1 стартмани

26.07.2018    22037    222    trigor    24    

Распознавание лиц (off-line). Демонстрационная база.

Разработка внешних компонент v8 Абонемент ($m)

Распознавание лиц входит в нашу жизнь стремительными темпами, бизнес стремится за событиями. В публикации находится описание и пример использования нейросетей для распознавания лиц.

1 стартмани

17.07.2018    17362    74    nomadon    45    

Простая печать чеков в соответствии с 54-ФЗ. Промо

Кассовые операции Фискальный регистратор Кассовые операции v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Простая программа для печати чеков на фискальных регистраторах через драйвер компании Штрих-М. Соответствует 54-ФЗ. Подходит для интернет-магазинов.

3 стартмани

07.07.2017    31243    28    Rik30    17    

QR-code полная версия (без шрифта и внешней компоненты для 8.2, 8.3 и любого типа клиента)

Разработка внешних компонент Сканер штрих-кода v8 1cv8.cf Абонемент ($m)

Предназначена для создания QR-code с указанием процента восстановления потерянных данных. Строка кодирования может содержать все печатаемые символы, в том числе и кириллические. Для работы не требуется внешняя компонента или шрифт.

2 стартмани

10.07.2018    12963    16    bobank    6    

Внешняя компонента для ping'а

Разработка внешних компонент v8 1cv8.cf Абонемент ($m)

Внешняя компонента для выполнения ping'а из 1С:Предприятия 8.

1 стартмани

04.07.2018    11701    5    frkbvfnjh    24    

УТ 10. Система налогообложения - патент

ККМ Кассовые операции Кассовые операции v8 v8::ОУ УТ10 Россия Абонемент ($m)

Дописанная стандартная обработка торгового оборудования ККТ Штрих в. 1.7, позволяющая без изменений конфигурации добавить возможность регистрации чеков с СНО: Патент. Расширение для УТ11.4 с СНО Патент.

1 стартмани

02.07.2018    23779    55    asdfgcom    35    

54-ФЗ: Онлайн-кассы для 1С 8.1 УТ 10.2. Поддержка Native драйверов Атол Промо

Кассовые операции Оптовая торговля Розничная торговля ККМ Кассовые операции Оптовая торговля Розничная торговля v8 v8::ОУ УТ10 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия УУ Абонемент ($m)

Доработан и адаптирован функционал работы ККТ по 54_ФЗ на УТ 10.2 платформы 8.1. Поддержка драйверов Атол версии 9 (native) и эмулятора ККТ. Код полностью открыт и внесены комментарии для самостоятельной доработки. Протестировано на Атол 11Ф. Распространяется как есть.

10 стартмани

18.04.2017    56637    127    Atom74    69    

JVM Native API плагин - для запуска в 1С плагинов написанных на Java

Разработка внешних компонент v8 Абонемент ($m)

Запускаем виртуальную машину Java в 1С. Собрана внешняя компонента которая позволяет запускать виртуальную машину java в среде 1С. Позволяет как передавать параметры в java - так и получать уведомление через externalevent. Предпосылкой создания являлся тот факт, что есть много готового функционала которого не хватает в 1С. Язык сpp - довольно сложен для быстрой разработки, и теперь возможно использовать готовые сборки java классов (так называемые jar-файлы) для использования в 1С.

1 стартмани

20.06.2018    13722    36    minimajack    73    

Атол ККТ:Онлайн 54ФЗ для 1С 8.1 УТ 10.3 (без изменения конфигурации)

ККМ Фискальный регистратор Кассовые операции Кассовые операции v8 v8::ОУ УТ10 Россия Абонемент ($m)

Обработка обслуживания драйвера "АТОЛ: Драйвер ККТ (54ФЗ) версия 8.16" для Управление торговлей 10.3 на платформе 1С:8.1. Не требует изменения конфигурации - подключение как "Фискальный регистратор".

4 стартмани

15.06.2018    43324    122    1st    61    

NativeDraw: Компонента рисования для 1С [V2.6.2] Промо

Разработка внешних компонент Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Рисуйте в формах 1С, также предлагается небольшое количество нерисовальных функций

1 стартмани

13.07.2015    48992    463    ПерваяСистема    147