Внешняя компонента для работы с драйвером "Атол v.10". 1С:8.3

Публикация № 1093799

Разработка - Разработка внешних компонент

Атол Atol KKT ККТ Драйвер Внешняя компонента JSON 10 Чек ККМ Продажа Касса

Внешняя компонента, для работы с драйвером «Атол v.10», посредством JSON-заданий.

Внешняя компонента, для работы с драйвером «Атол v.10», посредством JSON-заданий.
Описание JSON заданий, можно посмотреть на официальном сайте атол: http://integration.atol.ru/api/#json-tasks
Так как атоловский "WEB сервер", работал не стабильно и зависал через 2 часа работы, решил написать свою компоненту.
Компонента позволяет - проверить состояние смены, и оправить JSON-задание.
Для работы необходима библиотека "fptr10.dll" из поставки Атол "Драйвер контрольно-кассовой техники v.10" и VCREDIST 2015.
Рекомендую хранить библиотеку в общем макете для "32bit" и "64bit" систем.

Компонента ведет логи в "папка пользователя"\Documents\NativeAtolKKT.log

При вылетах и системных ошибках нужно смотреть логи.

Список JSON-заданий драйвера Атол v.10:

На данный момент компонента используется для пакетной печати чеков - на один электронный (без печати) чек, уходит 3 секунды.

Внимание перед установкой параметров соединения с ККТ необходимо выполнить "Атол.Инициализировать"


Свойства:

Атол.ПарольДоступа (Атол.AccessPassword)
Синтаксис:
Атол.ПарольДоступа = "30";
Описание:
Использование: чтение, запись.
Тип: Строка.
Устанавливает параметр - пароль доступа.

 

Атол.ПарольПользователя (Атол.UserPassword)
Синтаксис:

Атол.ПарольПользователя = "30";
Описание:
Использование: чтение, запись.
Тип: Строка.
Устанавливает параметр - пароль пользователя.

 

Атол.КаналОФД (Атол.OfdChannel)
Синтаксис:

Атол.КаналОФД = "0";
Описание:
Использование: чтение, запись.
Тип: Строка.
Устанавливает параметр - канал обмена с ОФД.
Значения:
NONE = 0
USB = 1
PROTO = 2

 

Атол.КаналСвязи (Атол.Channel)
Синтаксис:
Атол.КаналСвязи = "2";
Описание:
Использование: чтение, запись.
Тип: Строка.
Устанавливает параметр - способ связи с ККТ.
Значения:
COM = 0
USB = 1
TCPIP = 2
BLUETOOTH = 3

 

Атол.КомСкорость (Атол.BaudRate)
Синтаксис:

Атол.КаналСвязи = "9600";
Описание:
Использование: чтение, запись.
Тип: Строка.
Устанавливает параметр - скорость работы ККТ по RS232.
Значения:
BR_1200 = 1200
BR_2400 = 2400
BR_4800 = 4800
BR_9600 = 9600
BR_19200 = 19200
BR_38400 = 38400
BR_57600 = 57600
BR_115200 = 115200
BR_230400 = 230400
BR_460800 = 460800
BR_921600 = 921600

 

Атол.КомБит (Атол.Bits)
Синтаксис:

Атол.КомБит = "8";
Описание:
Использование: чтение, запись.
Тип: Строка.
Устанавливает параметр - количество бит в байте канала RS232.
Значения:
BITS_7 = 7
BITS_8 = 8

 

Атол.КомСтопБит (Атол.StopBits)
Синтаксис:

Атол.КомСтопБит = "1";
Описание:
Использование: чтение, запись.
Тип: Строка.
Устанавливает параметр - количество стоп-битов канала RS232.
Значения:
SB_1 = 0
SB_1_5 = 1
SB_2 = 2

 

Атол.КомЧетность (Атол.Parity)
Синтаксис:

Атол.КомЧетность = "0";
Описание:
Использование: чтение, запись.
Тип: Строка.
Устанавливает параметр - четность канала RS232.
Значения:
PARITY_NO - нет = 0
PARITY_ODD - четность = 1
PARITY_EVEN - нечетность = 2
PARITY_MARK - установлена = 3
PARITY_SPACE - сброшена = 4

 

Атол.КомПорт (Атол.ComFile)
Синтаксис:

Атол.КомПорт = "1";
Описание:
Использование: чтение, запись.
Тип: Строка.
Устанавливает параметр - номер порта.
Значения: идентификатор порта. Для Windows - номер COM-порта (например, "15" или "COM15").
Для Linux - путь к TTY-файлу (например, "/dev/ttyS5" или "/dev/ttyACM0").


Атол.ЛинуксПутьКУСБ (Атол.UsbDevicePath)
Синтаксис:

Атол.ЛинуксПутьКУСБ = "auto";
Описание:
Использование: чтение, запись.
Тип: Строка.
Устанавливает параметр - расположение USB-устройства в системе (только Linux).
Значения: расположение USB-устройства в системе (только Linux).
Если настройка не указана, имеет значение "auto" или пустое значение, то поиск и подключение к устройству будет проводиться по известным драйверу VendorID и ProductID.
На Windows подключение всегда ведется по VendorID и ProductID.


Атол.ИПАдрес (Атол.IPAddress)
Синтаксис:

Атол.ИПАдрес = "192.168.1.25";
Описание:
Использование: чтение, запись.
Тип: Строка.
Устанавливает параметр - IP-адрес ККТ.
Значения: Может быть как ip-адресом, так и hostname-ом.

 

Атол.ИППорт (Атол.IPPort)
Синтаксис:

Атол.ИППорт = "5555";
Описание:
Использование: чтение, запись.
Тип: Строка.
Устанавливает параметр - IP-порт ККТ.
Значения: 1-65535

 

Атол.МАКАдрес (Атол.MACAddress)
Синтаксис:

Атол.МАКАдрес = "FF:FF:FF:FF:FF:FF";
Описание:
Использование: чтение, запись.
Тип: Строка.
Устанавливает параметр - Bluetooth MAC-адрес ККТ.
Значения: Bluetooth MAC-адрес ККТ.
Устройство должно быть предварительно сопряжено с хостом средствами ОС.

 

Атол.Ошибка (Атол.GetError)
Синтаксис:

Сообщить(Атол.Ошибка);
Описание:
Использование: чтение.
Тип: Строка.
Возвращает последнюю ошибку компоненты.

 

Атол.КодОшибки (Атол.GetErrorCode)
Синтаксис:

Сообщить(Атол.КодОшибки);
Описание:
Использование: чтение.
Тип: Целое число.
Возвращает код ошибки, драйвера Атол. (используется как проверка на "ошибок нет" = 0)
Описание кодов, можно посмотреть в документации: http://integration.atol.ru/api/#f9886ca2bc

 

Атол.СостояниеСоединения (Атол.Opened)
Синтаксис:

Сообщить(Атол.СостояниеСоединения);
Описание:
Использование: чтение.
Тип: Булево.
Возвращает "истина" если соединение с ККТ установлено, иначе "ложь".


Атол.СостояниеСмены (Атол.Shift_State)
Синтаксис:

Сообщить(Атол.СостояниеСмены);
Описание:
Использование: чтение.
Тип: Целое число.
Возвращаемое значение:
Смена открыта = 0
Смена закрыта = 1
Смена истекла = 2

Функции:

Атол.Инициализировать (Атол.Initialize)
Синтаксис:

Атол.Инициализировать(<ПутьКбиблиотеке_fptr10.dll>);
Параметры:
<ПутьКбиблиотеке_fptr10.dll> - путь к библиотеке драйвера Атол 10, на диске.
Возвращаемое значение: булево, (истина - успех)
Описание:
Подключает библиотеку (fptr10.dll) драйвера атол.
Библиотеку нужно указвать той-же разрядности что и 1С.

 

Атол.Открыть (Атол.Open)
Синтаксис:

Атол.Открыть();
Возвращаемое значение: булево, (истина - успех)
Описание:
Открывает соединение с ККТ.

 

Атол.Закрыть (Атол.Close)
Синтаксис:

Атол.Закрыть();
Возвращаемое значение: булево, (истина - успех)
Описание:
Закрывает соединение с ККТ.

 

Атол.ОтправитьJSON (Атол.RequestJSON)
Синтаксис:

ОтветJSON = Атол.ОтправитьJSON(<JSONтекст>);
Параметры:
<JSONтекст> - текст с JSON структурой.
Возвращаемое значение: Строка (Текст с JSON структурой.) Описание смотри в документации: http://integration.atol.ru/api/#json-tasks
Описание:
Отправляет JSON-задание на ККТ.

 

************************************************

Пример реализации:

ОбщийМакет.АтолККТ - двоичные данные, "zip" архив внешней компоненты. 

ОбщийМакет.fptr10x64 - библиотека драйвера Атол 64 битная.

ОбщийМакет.fptr10 - библиотека драйвера Атол 32 битная.

Общий модуль: МодульККТ


Функция ПодключитьАтолКомпоненту() Экспорт 
	
	Попытка
		Если НЕ ПустаяСтрока(ПараметрыСеанса.АдресХранилищаАтолСоединение) Тогда
			Подключение = ПолучитьИзВременногоХранилища(ПараметрыСеанса.АдресХранилищаАтолСоединение).АтолККТ;
			Возврат Подключение;
		КонецЕсли;
	Исключение
		ПараметрыСеанса.АдресХранилищаАтолСоединение = "";
	КонецПопытки;	
	
	КомпУст=Ложь;
	Попытка
		КомпУст=ПодключитьВнешнююКомпоненту("ОбщийМакет.АтолККТ","NativeAtol",ТипВнешнейКомпоненты.Native);
	Исключение
		ПоказатьОповещениеПользователя("Произошла исключительная ошибка при подключении компоненты!",,ОписаниеОшибки(),БиблиотекаКартинок.Остановить);
	КонецПопытки;
	Если Не КомпУст Тогда
		ПоказатьОповещениеПользователя("Произошла ошибка при подключении компоненты!",,"",БиблиотекаКартинок.Остановить);
	КонецЕсли;
	
	Попытка 
		СисИнфо = Новый СистемнаяИнформация;
		Если СисИнфо.ТипПлатформы = ТипПлатформы.Windows_x86 Тогда
			ПолучитьОбщийМакет("fptr10").Записать(КаталогВременныхФайлов()+"fptr10.dll");
		ИначеЕсли СисИнфо.ТипПлатформы = ТипПлатформы.Windows_x86_64 Тогда
			ПолучитьОбщийМакет("fptr10x64").Записать(КаталогВременныхФайлов()+"fptr10.dll");
		КонецЕсли;
	Исключение
		ЗаписьЖурналаРегистрации("АтолККТ",УровеньЖурналаРегистрации.Ошибка,,ОписаниеОшибки());
		//Возврат Неопределено;
	КонецПопытки;
	
	АтолККТ = Новый("AddIn.NativeAtol.АтолККТ");
	АтолККТ.Инициализировать(КаталогВременныхФайлов()+"fptr10.dll");
	АтолККТ.КаналСвязи = "2"; 
	АтолККТ.ИПАдрес = СокрЛП(Константы.ИпАдресСервераККТ.Получить());
	АтолККТ.ИППорт = "5555";
	
	Попытка
		СтруктураАтолКомпонента = Новый Структура("АтолККТ",АтолККТ);
		АдресАтолККТ = ПоместитьВоВременноеХранилище(СтруктураАтолКомпонента,Новый УникальныйИдентификатор);
		ПараметрыСеанса.АдресХранилищаАтолСоединение = АдресАтолККТ;
		Возврат АтолККТ;
	Исключение
		ЗаписьЖурналаРегистрации("АтолККТ",УровеньЖурналаРегистрации.Ошибка,,ОписаниеОшибки());
		Возврат Неопределено;
	КонецПопытки;
	
КонецФункции

Функция СформироватьJSONЧек(Продажа,ТелоЧека) Экспорт  //Продажа(истина) - продажа, возврат продажи
	//ТелоЧека-структура с данными чека(Оператор;Итог;ЕмаилИлиТелефон,ИмяКлиента,ИННКлиента;СтрокиЧека-массив со структурами(Наименование,Цена,Количество,Сумма,НДС)) 
	
	Чек = Новый Структура;
	Позиции = Новый Массив;
	Оплаты = Новый Массив;
	
	Для Каждого ПозицияЧека Из ТелоЧека.СтрокиЧека Цикл 
		Позиция = Новый Структура;
		Позиция.Вставить("type","position");
		Позиция.Вставить("name",ПозицияЧека.Наименование);
		Позиция.Вставить("price",ПозицияЧека.Цена);
		Позиция.Вставить("quantity",ПозицияЧека.Количество);
		Позиция.Вставить("amount",ПозицияЧека.Сумма);
		Позиция.Вставить("department",1);
		Позиция.Вставить("paymentMethod","fullPayment");
		Позиция.Вставить("paymentObject","service");
		Позиция.Вставить("tax",Новый Структура("type",ПолучитьНалог(ПозицияЧека.НДС)));
		Позиции.Добавить(Позиция);
	КонецЦикла;
	
	Оплаты.Вставить(0,Новый Структура("type,sum","electronically",ТелоЧека.Итог));
	
	Чек.Вставить("type",?(Продажа = Истина,"sell","sellReturn"));
	Чек.Вставить("taxationType","osn");
	Чек.Вставить("electronically",Истина);
	Чек.Вставить("operator",Новый Структура("name",ТелоЧека.Оператор));
	Чек.Вставить("clientInfo",Новый Структура("emailOrPhone,name,vatin",ТелоЧека.ЕмаилИлиТелефон,ТелоЧека.ИмяКлиента,ТелоЧека.ИННКлиента));
	Чек.Вставить("items",Позиции);
	Чек.Вставить("payments",Оплаты);
	Чек.Вставить("total",ТелоЧека.Итог);

	ЗаписьJSON = Новый ЗаписьJSON;
	ЗаписьJSON.УстановитьСтроку();
	ЗаписатьJSON(ЗаписьJSON,Чек);
	ДанныеJson = ЗаписьJSON.Закрыть();
	
	Возврат ДанныеJson;
	
КонецФункции

Функция ПолучитьСтруктуруJSON(ОтветJson) Экспорт 
	
	ЧтениеJSON = Новый ЧтениеJSON;
	ЧтениеJSON.УстановитьСтроку(ОтветJson);
	СтруктураJson = ПрочитатьJSON(ЧтениеJSON);
	ЧтениеJSON.Закрыть();
	
	
	fiscalParams = ЗначениеСвойстваJSON(СтруктураJson,"fiscalParams"); //чек
	shiftStatus = ЗначениеСвойстваJSON(СтруктураJson,"shiftStatus");   //состояние смены
	
	ОтветСтруктура = Новый Структура;
	Если НЕ fiscalParams = Неопределено Тогда 
		ОтветСтруктура.Вставить("ДатаВремяЧека",ПрочитатьДатуJSON(fiscalParams.fiscalDocumentDateTime,ФорматДатыJSON.ISO));
		ОтветСтруктура.Вставить("ФПДЧека",fiscalParams.fiscalDocumentSign);
		ОтветСтруктура.Вставить("РегНомерККТ",fiscalParams.registrationNumber);
		ОтветСтруктура.Вставить("НомерФДЧека",fiscalParams.fiscalDocumentNumber);
	КонецЕсли;	
	Если НЕ shiftStatus = Неопределено Тогда
		ОтветСтруктура.Вставить("СтатусСмены",shiftStatus.state);
		ОтветСтруктура.Вставить("СменаИстечет",ПрочитатьДатуJSON(shiftStatus.expiredTime,ФорматДатыJSON.ISO));
	КонецЕсли;
	
	Возврат ОтветСтруктура;
	
КонецФункции

Функция ОткрытьПроверитьСмену(ИмяОператора) Экспорт 
	
	АтолККТ = ПодключитьАтолКомпоненту();
	СостояниеСмены = АтолККТ.СостояниеСмены;
	Если АтолККТ.КодОшибки = 0 Тогда 
		Если СостояниеСмены = 0 Тогда //закрыта
			json="{""type"": ""openShift"",""electronically"":""true"",""operator"": {""name"": """+ИмяОператора+"""}}";
			ОтветJSON = АтолККТ.ОтправитьJSON(json);
			Если АтолККТ.КодОшибки = 0 Тогда 
				Возврат Истина;
				//Результат = ПолучитьСтруктуруJSON(ОтветJSON);
			Иначе 
				ПоказатьОповещениеПользователя("Ошибка открытия смены!",,АтолККТ.Ошибка,БиблиотекаКартинок.Остановить);
			КонецЕсли;
		ИначеЕсли СостояниеСмены = 1 Тогда //открыта
			Возврат Истина;
		ИначеЕсли СостояниеСмены = 2 Тогда //просрочена
			ПоказатьОповещениеПользователя("Внимание!",,"Смена истекла",БиблиотекаКартинок.Остановить);
			Возврат Ложь;
		КонецЕсли;
	Иначе 
		ПоказатьОповещениеПользователя("Ошибка проверки состояния смены!",,АтолККТ.Ошибка,БиблиотекаКартинок.Остановить);
	КонецЕсли;
	
	Возврат Ложь;
	
КонецФункции

Функция ЗакрытьСмену(ИмяОператора) Экспорт 
	
	АтолККТ = ПодключитьАтолКомпоненту();
	СостояниеСмены = АтолККТ.СостояниеСмены;
	Если АтолККТ.КодОшибки = 0 Тогда 
		Если НЕ СостояниеСмены = 0 Тогда 
			json="{""type"": ""closeShift"",""electronically"":""true"",""operator"": {""name"": """+ИмяОператора+"""}}";
			ОтветJSON = АтолККТ.ОтправитьJSON(json);
			Если АтолККТ.КодОшибки = 0 Тогда 
				Возврат Истина;
				//Результат = ПолучитьСтруктуруJSON(ОтветJSON);
			Иначе 
				ПоказатьОповещениеПользователя("Ошибка закрытия смены!",,АтолККТ.Ошибка,БиблиотекаКартинок.Остановить);
			КонецЕсли;
		ИначеЕсли СостояниеСмены = 0 Тогда //закрыта
			Возврат Истина;
		КонецЕсли;
	Иначе 
		 ПоказатьОповещениеПользователя("Ошибка проверки состояния смены!",,АтолККТ.Ошибка,БиблиотекаКартинок.Остановить);
	КонецЕсли;
	
	Возврат Ложь;
	
КонецФункции

Функция ПолучитьНалог(НДС) //НДС - текст
	
	Налог = "none"; //БезНДС
	Если НДС = Перечисления.СтавкиНДС.БезНДС Тогда 
		Налог = "none";
	ИначеЕсли НДС = Перечисления.СтавкиНДС.НДС18 Тогда 
		Налог = "vat18";
	ИначеЕсли НДС = Перечисления.СтавкиНДС.НДС20 Тогда 
		Налог = "vat20";
	ИначеЕсли НДС = Перечисления.СтавкиНДС.НДС0 Тогда 
		Налог = "vat0";
	ИначеЕсли НДС = Перечисления.СтавкиНДС.НДС10 Тогда 
		Налог = "vat10";
	КонецЕсли;
	Возврат Налог;
	
КонецФункции

Функция ЗначениеСвойстваJSON(ОбъектСвойства,Свойство)
	
	Если ОбъектСвойства = Неопределено Тогда 
		Возврат Неопределено;
	КонецЕсли;
	ВремЗначение = Неопределено;
	Если ОбъектСвойства.Свойство(Свойство,ВремЗначение) Тогда 
		Возврат ВремЗначение;
	Иначе
		Возврат Неопределено;
	КонецЕсли;
	
КонецФункции


Функция печати чека:

функция Чек()
	АтолККТ = МодульККТ.ПодключитьАтолКомпоненту();
	Если АтолККТ.Открыть() Тогда
		//ЕСЛИ СМЕНА ЗАКРЫТА ОТКРЫВАЕМ
		Если МодульККТ.ОткрытьПроверитьСмену(Объект.Оператор.Наименование) Тогда
			
			СтрокиЧека = Новый Массив;
			Позиция = Новый Структура("Наименование,Цена,Количество,Сумма,НДС","сапоги",154.12,2,308.24, Перечисления.СтавкиНДС.БезНДС);
			СтрокиЧека.Добавить(Позиция);
			
			ТелоЧека = Новый Структура;
			ТелоЧека.Вставить("Оператор","оператор1");
			ТелоЧека.Вставить("ЕмаилИлиТелефон","a@a.a");//если поле будет пустым, чек распечатается.
			ТелоЧека.Вставить("ИмяКлиента","Пупкин.П.П");
			ТелоЧека.Вставить("ИННКлиента","12121212121");
			ТелоЧека.Вставить("Итог",308.24);
			ТелоЧека.Вставить("СтрокиЧека",СтрокиЧека);
			//отправка чека
			//ТелоЧека-структура с данными чека(Оператор;Итог;ЕмаилИлиТелефон,ИмяКлиента,ИННКлиента;СтрокиЧека-массив со структурами(Наименование,Цена,Количество,Сумма,НДС)) 
			ОтветJSON = АтолККТ.ОтправитьJSON(МодульККТ.СформироватьJSONЧек(Продажа,ТелоЧека));
			Если АтолККТ.КодОшибки = 0 Тогда 
				//ошибок нет получаем результат
				Результат = МодульККТ.ПолучитьСтруктуруJSON(ОтветJSON);
				//обрабатываем результат
			Иначе 
				//АтолККТ.Ошибка;
				//АтолККТ.КодОшибки;
			КонецЕсли;
			
			Если НЕ АтолККТ.КодОшибки = 0 Тогда
				ПоказатьОповещениеПользователя("Ошибка чека, отправка прервана!",,АтолККТ.Ошибка,БиблиотекаКартинок.Остановить);
				Возврат Ложь;
			КонецЕсли;
		КонецЕсли;
		
		АтолККТ.Закрыть();
		Возврат Истина;
	Иначе
		ПоказатьПредупреждение(,АтолККТ.Ошибка,0,"Ошибка подключения к кассе!");
		Возврат Ложь;
	КонецЕсли;
конецфункции

 

Скачать файлы

Наименование Файл Версия Размер
1С8.3: Внешняя компонента, для работы с драйвером «Атол v.10»: Атол ККТ zip
.zip 203,40Kb
15.07.19
7
.zip 1 203,40Kb 7 Скачать
Библиотеки драйвера Атол ККТ 10 (32-64 бит) - можно скачать с сайта атол
.7z 1,34Mb
08.02.20
2
.7z 10 1,34Mb 2 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. alex_makhnov 07.02.20 17:35 Сейчас в теме
Все хорошо, но почему-то на ОтветJSON = Атол.ОтправитьJSON(<JSONтекст>); 1С вылетает.
При этом чек пробивается...
2. gortrex 58 08.02.20 22:20 Сейчас в теме
(1) Посмотрите логи компоненты, они находятся в папке документы: "папка пользователя"\Documents\NativeAtolKKT.log
Оставьте свое сообщение

См. также

Быстрая печать этикеток (ZPL, EPL, TSPL, EZPL, GEPL, TSPL-EZ)

Инструменты и обработки Программист Архив с данными v8 v8::УФ 1cv8.cf Абонемент ($m) Разработка внешних компонент

Качественная и быстрая печать на внутреннем языке принтеров этикеток.

4 стартмани

02.02.2020    1863    8    Johny_v    3       

Сдача регламентированной отчетности из программ 1С Промо

Сдача регламентированной отчетности из программ "1С" во все контролирующие органы без выгрузок и загрузок в другие программы. Для групп компаний действуют специальные предложения.

от 1500 руб.

Сканирование по TWAIN в 1С (обычные и управляемые формы)

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Разработка внешних компонент

Обработка показывает пример, как можно в 1С проводить сканирование с помощью компоненты TWAIN.

2 стартмани

03.01.2020    1457    9    Diana.dedov.91    0       

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

Маленькая и скромная мобильная внешняя компонента

Вопрос Программист Архив с данными v8 Абонемент ($m) Разработка внешних компонент

Изваять простенькую мобильную компоненту на 1С для android не так-то просто. Посему назло отдельным супостатам, не желающим делится исходниками, представляю весь свой скромный труд на публичный суд.

1 стартмани

21.10.2019    5046    1    ripreal1    16       

Native внешняя компонента для оповещения по UDP или TCP

Инструменты и обработки Программист Архив с данными v8 Windows Абонемент ($m) Разработка внешних компонент

Native внешняя компонента для оповещения по UDP или TCP, которая реализует возможность в 1С передавать сообщения с сервера на клиента. Исходный код компоненты также представлен.

1 стартмани

06.10.2019    4732    9    vdv2701    13       

Базовый курс по обмену данными в системе 1С:Предприятие. Онлайн-интенсив с 12 по 28 мая 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, обеспечивающих обмен данными между различными прикладными 1С-решениями и взаимодействие с другими информационными системами. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”.

5500 рублей

Печать покупателя в чеке ККМ с 01.07.2019

Отчеты и формы Программист Бухгалтер Пользователь Расширение (cfe) v8 ERP2 БУ Кассовые операции Абонемент ($m) ККМ Печатные формы документов

C 01.07.2019 если организация/ИП покупает у другой организации/ИП товары, работы или услуги, то в Чеке ККМ требуется указать: Покупателя (тег 1227) и ИНН (тег 1228). Если чек отправляется в ОФД без этих данных, то будет штраф . Но в 1С ERP вывод данных полей не предусмотрен. Предлагаемое расширение устраняет данную проблему.

1 стартмани

17.07.2019    14869    20    sapervodichka    14       

INFOSTART MEETUP Kazan. 13 марта 2020 г. Промо

Инфостарт продолжает путешествие по России. Следующая остановка - Казань. Тема мероприятия - управление и технологии автоматизации учета на платформе "1С: Предприятие". Ждем всех: докладчиков и участников! Стоимость участия - 5 500 рублей. Цена действительна до 30.01.2020

5 500

Эмулятор ККМ по стандарту ФФД 1.1

Инструменты и обработки Программист Архив с данными v8 Розница УТ11 Россия Windows Кассовые операции Абонемент ($m) Разработка внешних компонент ККМ

Эмулятор драйвера ККМ по стандарту ФФД 1.1 предназначен для использования всех возможностей программы, при отсутствии физической кассы. Подойдет как программистам при разработке интерфейса РМК, например, так и пользователям для тестирования возможностей программы.

1 стартмани

30.12.2018    13281    106    Matveymc    20       

ККТ Атол: настраиваем работу по новому порядку. 54ФЗ, ФФД 1.05, НДС 20%. + Работа ККТ по сети или как работать c ККТ из терминального сервера RDP + Работа в LINUX

Инструменты и обработки Системный администратор Архив с данными v8 УТ10 УПП1 ОС Кассовые операции Розничная торговля Абонемент ($m) ККМ

Настройка ККТ АТОЛ для работы по сети. Обработка обслуживания ККТ для конфигураций на обычных формах. Тестировал на УПП 1.3.106.2, УТ10.3.47.3. Платформа 8.3.10.2753

1 стартмани

14.12.2018    40224    54    Johny_v    42       

Голосование за доклады на INFOSTART MEETUP Kazan - до 25 февраля. Промо

Выбирайте и голосуйте за самые интересные доклады! Лучшие из лучших попадут в окончательную программу казанского митапа. Оставить свой голос можно до 25 февраля 2020 года.

АТОЛ ВЕБ-СЕРВИС. Обработка для работы с ККТ 54 ФЗ + ИЗМЕНЕНИЯ С 01.07.2019

Инструменты и обработки Системный администратор Программист Бухгалтер Внешняя обработка (ert,epf) v8 КА1 УТ10 УПП1 БГУ БАУ 1С:CRM Россия Windows Кассовые операции Абонемент ($m) ККМ

Хотите ускорить печать чеков, или печатать с разных рабочих мест на один фискальный регистратор? В этом вам поможет, настроенный веб-сервис от фирмы АТОЛ, а данная разработка позволит интегрировать его с вашей программой 1С.

4 стартмани

03.12.2018    25157    181    karpik666    232       

WebSocket Клиент / Сервер. Внешний компонент

Инструменты и обработки Системный администратор Программист Компонента, плагин (dll, vbs,..) v8 1cv8.cf Абонемент ($m) Разработка внешних компонент

Реализация протокола WebSocket. Клиентская часть для взаимодействия с внешними сервисами. Серверная часть для организации собственного сервера, принимающего клиентские соединения в многопоточном режиме. Возможно взаимодействие RabbitMQ Slack Asterisk и другие

1 стартмани

16.11.2018    8256    49    nomadon    30       

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

Внешняя компонента для выполнения регулярных выражений

Инструменты и обработки Программист Архив с данными v8 Абонемент ($m) Разработка внешних компонент

Внешняя Native API компонента для выполнения регулярных выражений на платформе 1С:Предприятие 8. Написана на C++. Используется движок boost::regex (v 1.69, v 1.68 - для Android). Версия синтаксиса Perl Compatible Regular Expressions.

1 стартмани

12.11.2018    8160    25    KAV2    57       

1C:Предприятие для программистов: Запросы и отчеты. Второй поток. Онлайн-интенсив с 17 марта по 16 апреля 2020 г. Промо

Данный онлайн-курс предусматривает углубленное изучение языка запросов и возможностей системы компоновки данных, которые понадобятся при разработке отчетов, работающих на платформе “1С:Предприятие” в рамках различных прикладных решений. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей различных прикладных решений, которые используют в своей работе отчеты разного назначения.

6500 рублей

Загрузка чека онлайн-касс (загрузка товаров из чека)

Инструменты и обработки Системный администратор Программист Бухгалтер Внешняя обработка (ert,epf) v8 1cv8.cf Кассовые операции Розничная торговля Абонемент ($m) Внешние источники данных WEB

Обработка-пример, позволяет любому и из любой конфигурации загрузить информацию о товарах из чека(и не только) с сервера ФНС proverkacheka.nalog.ru

2 стартмани

08.10.2018    11286    26    echo77    33       

TextRadar - нечеткий поиск в тексте

Инструменты и обработки Программист Компонента, плагин (dll, vbs,..) v8 1cv8.cf Абонемент ($m) Разработка внешних компонент Поиск данных

В отличие от нечеткого сравнения строк, когда обе сравниваемых строки равнозначны, в задаче нечеткого поиска выделяются строка поиска и строка данных, а вычислить необходимо не степень похожести двух строк, а степень присутствия строки поиска в строке данных. Нормированный коэффициент, находящийся между 0 и 1 позволяет отсечь заведомо низкие результаты, организовать поиск по синонимам и т.д. Наглядное отображение результатов в кратком и детальном виде поможет быстро найти интересующий фрагмент.

5 стартмани

19.09.2018    10049    15    TSSV    14       

Базовый курс по управлению ИТ-проектами. Курс проходит с 26 февраля по 22 апреля 2020 года. Промо

Отличительная черта курса - органичное сочетание трех вещей: 1.Теория проектного управления (PMI®+Agile Alliance+Российские ГОСТ+Методологии от 1С); 2. Опыт внедрения продуктов 1С (опыт франчайзи и успешных компаний + тренды Infostart Event и Agile Days); 3. Разбор реальных проблем и рекомендации экспертов по проектам слушателей. Мы будем фиксироваться на тех инструментах, которые реально оказываются полезными в практике руководителей проектов внедрения. Ведущая курса - Мария Темчина.

от 11000 рублей

Быстрая настройка ККМ из 1С с использованием драйвера от Атол без тест-драйвера

Инструменты и обработки Системный администратор Внешняя обработка (ert,epf) v8 Розница Windows Кассовые операции Абонемент ($m) ККМ

В нашей компании на кассовых местах подключено несколько ККМ от Атола. При подключении к штатным разъемам USB на материнской плате все работает без проблем. Проблемы в тех магазинах, где кассы подключаются через USB-Hub. Данная обработка позволяет быстро, без запуска "Тест-драйвера" и "Управление драйверами", настроить кассовое оборудование. Протестировано на 32-х битной версии 1С и конфигурации 1С:Розница 2.2 с версиями драйверов от Атол 8.16.1.8701 и 9.12.1.6236

1 стартмани

27.08.2018    12691    14    valerasv    7       

Продажа с двух касс ККМ в 1С:Розница 2.2. Выбор, по какой кассе пробить чек

Отчеты и формы Бухгалтер Пользователь Архив с данными v8 Розница Кассовые операции Розничная торговля Абонемент ($m) ККМ

Данное расширение конфигурации позволяет выбрать из списка кассу (ККМ), по которой необходимо пробить чек.

3 стартмани

09.08.2018    8933    32    pogroleg    45       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

Класс-обработка “Работа с картами Яндекс”

Инструменты и обработки Программист Конфигурация (md, cf) v8 Абонемент ($m) Разработка внешних компонент WEB

Как показать точку или маршрут на карте Яндекс. Как получить координаты по строке адреса (геокодирование).

1 стартмани

01.08.2018    15525    149    RSConsulting    14       

Эмулятор эквайрингового терминала

Инструменты и обработки Программист Архив с данными v8 Розница Россия УУ Windows Кассовые операции Абонемент ($m) ККМ

Эмулятор эквайрингового терминала для тестирования взаимодействий с разрабатываемыми или типовыми решениями.

1 стартмани

26.07.2018    13198    112    trigor    15       

Управление ИТ-проектами. Модуль 2: продвинутый онлайн-курс по классическим методам управления проектами. Вебинары проходят с 12 марта по 11 июня 2020 года. Промо

Продвинутый онлайн-курс по классическому управлению ИТ-проектами позволит слушателям освоить инструменты из PMBoK® и 1С:Технологии корпоративного внедрения и научиться их применять для проектов любого масштаба. Курс включает в себя 12 вебинаров и 12 видеолекции, разбор кейсов и рекомендации экспертов по проектам слушателей. Ведущая курса - Мария Темчина.

от 13000 рублей

Распознавание лиц (off-line). Демонстрационная база.

Инструменты и обработки Системный администратор Пользователь Руководитель проекта Архив с данными v8 Абонемент ($m) Разработка внешних компонент

Распознавание лиц входит в нашу жизнь стремительными темпами, бизнес стремится за событиями. В публикации находится описание и пример использования нейросетей для распознавания лиц.

1 стартмани

17.07.2018    12408    75    nomadon    45       

Внешняя компонента для ping'а

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Разработка внешних компонент

Внешняя компонента для выполнения ping'а из 1С:Предприятия 8.

1 стартмани

04.07.2018    7772    5    frkbvfnjh    24       

1C:Предприятие для программистов: Расчетные задачи (зарплата). Онлайн-интенсив с 01 по 17 июня 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, которые предназначены для автоматизации периодических расчетов, а именно - для расчета зарплаты. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей прикладного решения “1С:Зарплата и управление персоналом” и прочих прикладных решений, в которых реализован функционал расчета зарплаты.

4900 рублей

JVM Native API плагин - для запуска в 1С плагинов написанных на Java

Инструменты и обработки Программист Архив с данными v8 Windows Абонемент ($m) Разработка внешних компонент

Запускаем виртуальную машину Java в 1С. Собрана внешняя компонента которая позволяет запускать виртуальную машину java в среде 1С. Позволяет как передавать параметры в java - так и получать уведомление через externalevent. Предпосылкой создания являлся тот факт, что есть много готового функционала которого не хватает в 1С. Язык сpp - довольно сложен для быстрой разработки, и теперь возможно использовать готовые сборки java классов (так называемые jar-файлы) для использования в 1С.

1 стартмани

20.06.2018    7908    16    minimajack    63       

Пробитие чеков через ККМ в офисе (для курьеров)

Инструменты и обработки Пользователь Расширение (cfe) v8 v8::ОУ Розница УТ11 Россия БУ Кассовые операции Розничная торговля Абонемент ($m) ККМ Фискальный регистратор

Предлагается интеграция 1С с ККТ СтарРус. Поддерживается одновременная работа с разных рабочих мест. ККТ СтарРус работает как сервер, и принимает команды через API по http-протоколу, что позволяет пробивать чеки через центральную базу 1С для интернет-магазина и для курьеров.

1 стартмани

07.06.2018    22183    27    Kutuzov    12       

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

Tool1CD Beta в деле

Инструменты и обработки Программист Компонента, плагин (dll, vbs,..) v8 Абонемент ($m) Разработка внешних компонент

Пс, парень! Не хочешь немного сырых байтов?

1 стартмани

09.05.2018    20160    29    baton_pk    26