Отмена выполнения задачи исполнителя и вложенных бизнес-процессов

Публикация № 1180278

Управление - Управление бизнес-процессами (BPM)

Бизнес-процессы Задача исполнителя

После реализации проекта, основанного на бизнес-процессах - потребовался некий инструмент для администрирования задач исполнителя. Для отмены ошибочно выполненных задач и для отмены ошибочных переходов во вложенные бизнес-процессы.

Скажу сразу, ранее практически не попадалось задач по бизнес-процессам. А тут пришлось с нуля в также не знакомой мне области создавать подсистему "Претензионно-исковая деятельность". 

Проект сдан, теперь началась работа пользователей и появилась потребность администрирования их работы. Всё, что находилось в 1С блогосфере - было по созданию бизнес-процессов и ничего не нашлось толкового по отмене задачи ошибочной и тем более по отмене ошибочного перехода в вложенный БП (бизнес-процесс далее).

Конечно, прилагаемая обработка не взлетит у Вас! У меня свои названия БП и Задача исполнителя так же не стандартно названа. Но для понимания принципа, как образец к действию сгодится для начинающих (а опытные могут дать свои замечания и критику).

Шапка наполнена реквизитами под учет моих карт и моих БП. У меня 11 БП, которые могут стартовать в одном из двух  БП, дальше вызовом вложенных сливаются в один маршрут и по цепочке маршрута могут циклически вызываться из одного в другой и снова возвращаться в середину. 

Судебное ведение дела уходит то в Апелляцию, может в Кассацию. Из них вызывается Сопровождение в суде, мировое соглашение или на Исполнительное производство. Очень запутанные схемы и пользователи естественно будут ошибаться и не то выбирать при выполнении очередной задачи.

По схемам у меня раздвоение более чем на две ветки не случается и поэтому в шапку забил поля под две ветки. Сначала потерял время над попыткой автоматизации заполнения задачами шапки при выборе документа Претензия, это у меня ведущий документ - из которого централизованно ведется весь ход и управление маршрутом\задачами. Но автоматизации не вышло, это нужно было предусмотреть на стадии проектирования. А я когда проектировал предусмотрел это мне казалось, но только для линейных схем. В задаче у меня был предусмотрен реквизит - Следующая задача и он заполнялся при создании следующей задачи. Но после разделения на две ветки, одна задача созданная из двух уже теряется в этой цепочке.

Тогда принял решение не терять время, на будущее решил, нужно будет создать регистр сведений для записи последовательности задач исполнителя, но это на будущее. А сейчас сделал просто вывод сразу всех полей без управления их видимостью в зависимости от ситуации на маршруте и пользователю выводится карта текущая с отметками выполненных и ожидающих выполнения задач. Пользователь уже сам, проанализировав карту, решает, какую задачу следует удалить и отменить выполнение предыдущей - они выведены в шапку всегда. Напомню, поля заполняются автоматически при выборе документа Претензия.

Так же при переходе в вложенный БП, если это первый шаг нового БП и он ожидает выполнения, то поле с выполненной задачей 1 будет заполнено последней выполненной задачей из БП вызвавшего это вложенный БП. Поле Предыдущий БП заполнится исходным БП. Отменить в этот момент можно текущий БП, при этом автоматом отметятся к удалению задача которая ожидает выполнения в вложенном БП, отменится выполнение предыдущей задачи из вызвавшего БП, удалится ведущая задача, которую автоматически создал БП при создании вложенного и в моем случае ещё свои мелкие необходимости, как например перезапись реквизита Текущий БП у документа Претензия.

Так же замечу, у меня при удалении задачи исполнителя дополнительно производятся нужные в моём частном случае действия, как например установка дополнительных свойств у объекта, для отмены проверки установки пометки удаления на задачу. Это у меня программно запрещено пользователю! Иначе там сразу начался ужас в данных. Но это все сопутствующая лирика.

Так же в правой части шапки добавил возможность руками выбрать из списка точек, нужную точку маршрута и автоматом подтягивается к ней предыдущая точка. Это понадобилось для случая, когда раздвоение маршрута одной веткой упёрлось в точку слияния и этот шаг у нас становится выполненным, но что бы его отменить - придется его отдельно выбрать руками. Автоматом его не определить так просто. Там же, справа, расположена командная кнопка "Отмена выбранной задачи" и под кнопкой пояснение боле менее подробное. Логика работы кнопки зависит от состояния задачи в поле Ручной выбор задачи. Если она выполнена, то предыдущая тоже выполнена и первое нажатие кнопки отменит выполнение выбранной задачи. Карта при этом обновит состояние, она вообще обновляется при основных действиях и есть кнопка обновления карты и заодно кнопка для левого поля шапки обновить задачи. Так вот, вернемся к нашей кнопке в правом поле. Второе нажатие уже удалит отмененную с выполнения первым нажатием задачу и отменит выполнение у предыдущей. Третий раз нажимать не надо, проверок на все случаи не вставлял)))

Спасибо awk, принял замечание по установке транзакции и заодно ещё скорректировал некоторые моменты, в частности получение ведущей задачи у удаляемого БП. Вот скорректированный код основных процедур, кто-то успел скачать уже обработку без исправления к сожалению, а там действительно транзакции не правильно в корне установлены были.

Процедура удаления не выполненного шага и отмены выполнения предыдущего или удаления входа в вложенный БП:

 


 

&НаСервере
Процедура ОтменаВложенногоБПНаСервере()
	
	Запрос = Новый Запрос;   //При удалении БП на всякий случай удалим все имеющиеся по нему задачи
	//на случай если по циклам маршрут вернулся к первому шагу и есть несколько задач уже выполненных
	Запрос.Текст = 
	"ВЫБРАТЬ
	|	пирЗадачаИсполнителя.Ссылка КАК Ссылка
	|ИЗ
	|	Задача.пирЗадачаИсполнителя КАК пирЗадачаИсполнителя
	|ГДЕ
	|	пирЗадачаИсполнителя.БизнесПроцесс = &БизнесПроцесс";
	
	Запрос.УстановитьПараметр("БизнесПроцесс", ТекущийБП);
	
	РезультатЗапроса = Запрос.Выполнить();
	
	ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
	
	Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
		УдаляемаяЗадача = ВыборкаДетальныеЗаписи.Ссылка.ПолучитьОбъект();
		УдаляемаяЗадача.ПометкаУдаления = Истина;
		УдаляемаяЗадача.ТочкаМаршрута 	= Неопределено;
		УдаляемаяЗадача.Претензия 		= Неопределено;
		УдаляемаяЗадача.ДополнительныеСвойства.Вставить("ОтменаВыполнения",Истина);
		УдаляемаяЗадача.Записать();
	КонецЦикла;
	ОтменяемаяЗадача = ПредыдущаяЗадача1.ПолучитьОбъект();
	ОтменяемаяЗадача.Выполнена 			= Ложь;
	ОтменяемаяЗадача.СледующаяЗадача 	= Неопределено;
	ОтменяемаяЗадача.ДатаИсполнения 	= Дата(1,1,1,0,0,0);
	ОтменяемаяЗадача.Записать();
	
	УдаляемаяВедущаяЗадачаТекБП = ТекущийБП.ВедущаяЗадача.ПолучитьОбъект();
	УдаляемаяВедущаяЗадачаТекБП.ПометкаУдаления = Истина;
	УдаляемаяВедущаяЗадачаТекБП.ТочкаМаршрута 	= Неопределено;
	УдаляемаяВедущаяЗадачаТекБП.Претензия 		= Неопределено;
	УдаляемаяВедущаяЗадачаТекБП.ДополнительныеСвойства.Вставить("ОтменаВыполнения",Истина);
	УдаляемаяВедущаяЗадачаТекБП.Записать();
	
	УдаляемыйБП = ТекущийБП.ПолучитьОбъект();
	УдаляемыйБП.ВедущаяЗадача 	= Неопределено;
	УдаляемыйБП.Стартован 		= Истина;
	УдаляемыйБП.Завершен 		= Истина;
	УдаляемыйБП.Записать();	
	ТекПретензия = Претензия.ПолучитьОбъект();
	ТекПретензия.ТекущийБП = ПредыдущийБП;
	ТекПретензия.Записать(РежимЗаписиДокумента.Проведение);
	
КонецПроцедуры
&НаСервере
Процедура ШагНазадНаСервере()
	
	Если УдалитьЗадачу1 И ЗначениеЗаполнено(ПоследняяЗадача1) Тогда
		УдаляемаяЗадача = ПоследняяЗадача1.ПолучитьОбъект();
		УдаляемаяЗадача.ПометкаУдаления = Истина;
		УдаляемаяЗадача.ТочкаМаршрута 	= Неопределено;
		УдаляемаяЗадача.Претензия 		= Неопределено;
		УдаляемаяЗадача.ДополнительныеСвойства.Вставить("ОтменаВыполнения",Истина);
		УдаляемаяЗадача.Записать();
	КонецЕсли;
	Если УдалитьЗадачу2 И ЗначениеЗаполнено(ПоследняяЗадача2) Тогда
		УдаляемаяЗадача = ПоследняяЗадача2.ПолучитьОбъект();
		УдаляемаяЗадача.ПометкаУдаления = Истина;
		УдаляемаяЗадача.ТочкаМаршрута 	= Неопределено;
		УдаляемаяЗадача.Претензия 		= Неопределено;
		УдаляемаяЗадача.ДополнительныеСвойства.Вставить("ОтменаВыполнения",Истина);
		УдаляемаяЗадача.Записать();
	КонецЕсли;
	
	Если ОтменитьЗадачу1 И ЗначениеЗаполнено(ПредыдущаяЗадача1) Тогда
		ОтменяемаяЗадача = ПредыдущаяЗадача1.ПолучитьОбъект();
		ОтменяемаяЗадача.Выполнена 			= Ложь;
		ОтменяемаяЗадача.СледующаяЗадача 	= Неопределено;
		ОтменяемаяЗадача.ДатаИсполнения 	= Дата(1,1,1,0,0,0);
		ОтменяемаяЗадача.Записать();
	КонецЕсли;
	
	Если ОтменитьЗадачу2 И ЗначениеЗаполнено(ПредыдущаяЗадача2) Тогда
		ОтменяемаяЗадача = ПредыдущаяЗадача2.ПолучитьОбъект();
		ОтменяемаяЗадача.Выполнена 			= Ложь;
		ОтменяемаяЗадача.СледующаяЗадача 	= Неопределено;
		ОтменяемаяЗадача.ДатаИсполнения 	= Дата(1,1,1,0,0,0);
		ОтменяемаяЗадача.Записать();
	КонецЕсли;
	
КонецПроцедуры

&НаСервере
Процедура ШагНазадНаСервере_()
	
	НачатьТранзакцию();
	Попытка
		Если ОтменитьБП Тогда
			ОтменаВложенногоБПНаСервере();
		Иначе
			ШагНазадНаСервере();
		КонецЕсли;
		ЗафиксироватьТранзакцию();
	Исключение
		ОтменитьТранзакцию();
		ТекстСообщенияОбОшибке = КраткоеПредставлениеОшибки(ИнформацияОбОшибке());
		ВызватьИсключение ТекстСообщенияОбОшибке ; // Запись в ЖР и т.п.
	КонецПопытки;
	
	ПретензияПриИзмененииНаСервере();
	Если ЗначениеЗаполнено(ТекущийБП) Тогда
		ПолучитьКартуНаСервере();
	КонецЕсли;
	
КонецПроцедуры

&НаКлиенте
Процедура ШагНазад(Команда)
	ШагНазадНаСервере_();
КонецПроцедуры

 

 

Разрабатываемая мной подсистема ПИР, для которой написал обработку, интегрирована в Управление холдингом 1.3

Версия платформы 1С:Предприятие 8.3 (8.3.13.1644)

Скачать файлы

Наименование Файл Версия Размер
Отмена выполнения задачи исполнителя и вложенных бизнес-процессов:

.epf 10,17Kb
15.01.20
4
.epf 1.2 10,17Kb 4 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
1. awk 714 16.01.20 09:24 Сейчас в теме
Нарушение стандарта 1С в коде, например "Работа с транзакциями"

1.3. При использовании транзакций необходимо предусмотреть обработку исключений, придерживаясь следующих правил:

* метод НачатьТранзакцию должен быть за пределами блока Попытка-Исключение непосредственно перед оператором Попытка;
2. dadel 9 16.01.20 10:15 Сейчас в теме
(1) Согласно 1.3 да, там рекомендуется непосредственно перед попыткой.
Но если у меня идет получение объектов из выборки в цикле и хоть в одной из нескольких записей если ошибка, то нужно отменить все изменения. Как тут согласно рекомендации п1.3 реализовать?
А вообще код не оптимизировал конечно, выложил просто как некий план к действию, направление в котором нужно копать. Мой частный случай вряд ли кому то подойдет, сами объекты не совпадут.
Но если поясните подробнее, как в моём случае правильнее прописать Транзакцию - буду благодарен!)
3. awk 714 16.01.20 13:16 Сейчас в теме
(2) Да легко.

Как пример:

&НаСервере
Процедура ОтменаВложенногоБПНаСервере_БезТранзакции()
    
    
    Запрос = Новый Запрос;
    Запрос.Текст = 
    "ВЫБРАТЬ
    |    пирЗадачаИсполнителя.Ссылка КАК Ссылка
    |ИЗ
    |    Задача.пирЗадачаИсполнителя КАК пирЗадачаИсполнителя
    |ГДЕ
    |    пирЗадачаИсполнителя.БизнесПроцесс = &БизнесПроцесс";
    
    Запрос.УстановитьПараметр("БизнесПроцесс", ТекущийБП);
    
    РезультатЗапроса = Запрос.Выполнить();
    
    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
    
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        УдаляемаяЗадача = ВыборкаДетальныеЗаписи.Ссылка.ПолучитьОбъект();
        УдаляемаяЗадача.ПометкаУдаления = Истина;
        УдаляемаяЗадача.ТочкаМаршрута     = Неопределено;
        УдаляемаяЗадача.Претензия         = Неопределено;
        УдаляемаяЗадача.ДополнительныеСвойства.Вставить("ОтменаВыполнения",Истина);
        УдаляемаяЗадача.Записать();
    КонецЦикла;
    ОтменяемаяЗадача = ПредыдущаяЗадача1.ПолучитьОбъект();
    ОтменяемаяЗадача.Выполнена             = Ложь;
    ОтменяемаяЗадача.СледующаяЗадача     = Неопределено;
    ОтменяемаяЗадача.ДатаИсполнения     = Дата(1,1,1,0,0,0);
    ОтменяемаяЗадача.Записать();
    
    Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ
        |    пирЗадачаИсполнителя.Ссылка КАК Ссылка
        |ИЗ
        |    Задача.пирЗадачаИсполнителя КАК пирЗадачаИсполнителя
        |ГДЕ
        |    пирЗадачаИсполнителя.БизнесПроцесс = &БизнесПроцесс
        |    И пирЗадачаИсполнителя.Дата >= &Дата
        |    И пирЗадачаИсполнителя.ЗадачаПредмет = НЕОПРЕДЕЛЕНО
        |    И НЕ пирЗадачаИсполнителя.Выполнена";
    
    Запрос.УстановитьПараметр("БизнесПроцесс", ПредыдущийБП);
    Запрос.УстановитьПараметр("Дата", ПредыдущаяЗадача1.Дата);
    
    РезультатЗапроса = Запрос.Выполнить();
    
    Выборка = РезультатЗапроса.Выбрать();
    
    Пока Выборка.Следующий() Цикл
        УдаляемаяЗадача = Выборка.Ссылка.ПолучитьОбъект();    //Ведущая задача для удаления
        УдаляемаяЗадача.ПометкаУдаления = Истина;
        УдаляемаяЗадача.ТочкаМаршрута     = Неопределено;
        УдаляемаяЗадача.Претензия         = Неопределено;
        УдаляемаяЗадача.ДополнительныеСвойства.Вставить("ОтменаВыполнения",Истина);
        УдаляемаяЗадача.Записать();

    КонецЦикла;

    УдаляемыйБП = ТекущийБП.ПолучитьОбъект();
    УдаляемыйБП.ВедущаяЗадача     = Неопределено;
    УдаляемыйБП.Стартован         = Истина;
    УдаляемыйБП.Завершен         = Истина;
    УдаляемыйБП.Записать();    
    ТекПретензия = Претензия.ПолучитьОбъект();
    ТекПретензия.ТекущийБП = ПредыдущийБП;
    ТекПретензия.Записать(РежимЗаписиДокумента.Проведение);
    
    
КонецПроцедуры

&НаСервере
Процедура ОтменаВложенногоБПНаСервере()
    
    НачатьТранзакцию();
    
    Попытка
        ОтменаВложенногоБПНаСервере_БезТранзакции()
        ЗафиксироватьТранзакцию(); 
    Исключение
        ОтменитьТранзакцию();
	ТекстСообщенияОбОшибке = КраткоеПредставлениеОшибки(ИнформацияОбОшибке());
        ВызватьИсключение ТекстСообщенияОбОшибке ; // Запись в ЖР и т.п.
    КонецПопытки;
        
КонецПроцедуры
Показать
4. dadel 9 16.01.20 16:40 Сейчас в теме
(3)
Попытка
ОтменаВложенногоБПНаСервере_БезТранзакции()
ЗафиксироватьТранзакцию();
Исключение
ОтменитьТранзакцию();
ТекстСообщенияОбОшибке = КраткоеПредставлениеОшибки(ИнформацияОбОшибке());
ВызватьИсключение ТекстСообщенияОбОшибке ; // Запись в ЖР и т.п.
КонецПопытки;

Здорово!)
И главное просто), приму к сведению.
9. dadel 9 17.01.20 10:31 Сейчас в теме
(3)Исправил обработку и текст по замечанию.
Спасибо!
Жаль кто-то скачал сегодня утром без исправлений (хотя я думал кода достаточно будет и не думал, что будут скачивать). А там действительно транзакция может при ошибке в середине отмениться и дальше будет работать обработка уже не в транзакции и получится не хорошо...
5. CyberCerber 559 16.01.20 20:19 Сейчас в теме
Где-то лет семь назад делал возможность возврата к произвольной точке маршрута. Можно было открыть схему, правой кнопкой нажать на блок и выбрать в меню. А потом еще извратился сделать переход наоборот вперед, т.е. вообще к любой точке.
Вообще механизм БП в 1С хороший, но жаль не популярный и поэтому мало развиваемый.
6. dadel 9 17.01.20 00:04 Сейчас в теме
(5)Ну просто перепрыгнуть в любую точку текущего БП можно просто изменив в задаче точку маршрута.
Я так делал для отладки, сразу перепрыгивал весь БП на точку перехода в вложенный БП. У меня схем(карт) куча и все они друг с другом связаны, по факту это один БП раздробленный. И попасть например в процесс Исполнения Судебного решения нужно только пройдя через Переговорную работу, Претензионную, Подготовку к Судебному процессу и т.д.
Перепрыгивать можно но говорить о сохранении целостности маршрута тут не приходится, я только в отладке так прыгал. А у меня задача как можно адекватнее откатить\отменить неправильные шаги.
Сначала в опытной эксплуатации у меня пользователям поле точка БП было открыто, так шаловливые именно так и стали прыгать))) Сразу увидел бардак и закрыл.
7. CyberCerber 559 17.01.20 00:09 Сейчас в теме
(6) Ну нет, через изменение точки маршрута в задаче не делал, это как-то слишком грубо. Происходило именно восстановление актуальности нужной задачи и отмена всех после нее.
А переход вперед был сделан уже для эксперимента, конечно, фактического смысла в нем было немного.
8. dadel 9 17.01.20 00:28 Сейчас в теме
(7)Я просто понял фразу "ткнуть в произвольную точку маршрута" именно так. Что можно из текущей перепрыгнуть в любую точку, пропустив все промежуточные например.
Оставьте свое сообщение

См. также

"Простые регламенты" - помощник создания правильных регламентов ваших бизнес-процессов !БЕСПЛАТНО! Промо

Управление бизнес-процессами (BPM) v8::Бизнес-процессы 1cv8.cf УУ Абонемент ($m)

В статье - презентация нового БЕСПЛАТНОГО продукта для регламентации ваших бизнес-процессов. С нашей методикой ваши регламенты будут работать!

1 стартмани

06.09.2018    15445    32    siddy    0    

Сохранение карт бизнес-процессов в файл картинки PNG и BMP

Универсальные обработки Управление бизнес-процессами (BPM) v8 v8::УФ v8::Бизнес-процессы Абонемент ($m)

Обработка открывает карту из файла в формате графической схемы и сохраняет в формате PNG и BMP. Будет полезна специалистам для оформления технической документации программного продукта.

1 стартмани

06.07.2020    510    1    solarstrike    0    

Анализ выполнения бизнес-процессов

Управление бизнес-процессами (BPM) v8 ERP2 УТ11 УУ Абонемент ($m)

Отчет позволяет посмотреть текущее состояние всех БП,  а также время выполнения на каждом этапе бизнес-процесса. Это дает возможность проанализировать узкие места в Вашем бизнесе, принять меры, если задержки на каком-либо этапе стали неоправданно расти.

2 стартмани

24.12.2019    2158    2    milkers    0    

Загрузка из ППР (Передовые платежные решения) - Сведения о заправках на АЗС за сутки из сервиса ППР

Учет ТМЦ Управление бизнес-процессами (BPM) Управленческий учет (прочее) Внешние источники данных v8 ERP2 БП3.0 1С:CRM Транспорт, автопарки, такси Россия БУ УУ Абонемент ($m)

Обработка «Загрузка заправок на АЗС из ППР» реализует механизм подключения через API к сервису агрегатора топливных карт Передовые Платежные Решения. Позволяет получить данные по всем заправкам автотранспорта за указанные сутки.

1 стартмани

17.11.2019    2734    10    aaa_pol    0    

УПП: история одного внедрения Промо

Управление проектом Управление бизнес-процессами (BPM) Управленческие Финансовый учет и бюджетирование (FRP) Финансовый учет и бюджетирование (FRP) v8 УПП1 Россия УУ Абонемент ($m)

Когда генеральный директор одного предприятия решил внедрить новую учетную систему вместо привычной 1С:Бухгалтерии, он ориентировался на привлекательное название: Управление производственным предприятием (УПП). Франчайзи, которые ему эту систему рекомендовали, затем продали, установили и «внедрили», ограничились привычным джентльменским набором: банк, касса, зарплата, закупки и продажи. Блок производства был представлен внедрением Отчетов производства за смену (итого выпуска продукции за месяц) и Требование-накладная (итог списанного сырья за месяц). Управившись с таким внедрением франчайзи были готовы ежемесячно сами помогать финансовому директору рассчитывать себестоимость. Это «действо» для остальных непосвященных было тайной. Но финдиректор, рассчитав годовой баланс, переутомился и ушел в запой. Встал вопрос о новом финдире. Новый финансовый директор, которого выбрал гендиректор, была женщина. Задача, которую поставил ей гендиректор, была «проста»: ликвидировать воровство на предприятии. Что и говорить: неучтенной продукцией, в частности пластиковыми пакетами, торговали на всех рынках в радиусе 100 км. Не помогали ни высокие заборы, ни видеонаблюдение, ни замена ЧОПов. Естественно, акционер был недоволен и сердился на гендиректора: ведь не помогло и внедрение УПП, проект достаточно затратный. Финдир себе в помощь позвала знакомых фрилансеров (меня и моего мужа). С этого момента внедрение УПП стало переживать новый этап.

10 стартмани

09.06.2012    42788    3    PAVI    150    

Канбан-доска для 1С:Предприятие 8.3

Управление бизнес-процессами (BPM) Agile (XP, SCRUM, Канбан) v8 v8::УФ 1cv8.cf ИТ-компания 1С:Франчайзи, автоматизация бизнеса УУ Абонемент ($m)

Scrum/agile board для 1С. Приложение для работы по методологиям scrum и agile - доска канбан (kanban board, scrum board).

8 стартмани

06.11.2019    20448    103    pfihr    56    

Центр компетенций 1С #1: Технологический блог

Управление бизнес-процессами (BPM) v8 Россия Абонемент ($m)

Привет! Меня зовут Андрей, я - директор по развитию 1С в международной переводческой компании. Представляете, наша ERP на платформе 1С работает в наших офисах по всему миру: Австрия, Великобритания, Германия, Чехия, Украина, Аргентина, США, Китай, Казахстан и конечно Россия. Директором по развитию я стал недавно и в связи с повышением по работе стал задаваться вопросами создания в компании центра компетенций 1С, где бы аккумулировались накопленные знания, кейсы, прецеденты и лучшие практики. Второй интересующий меня момент - развитие в группе разработки 1С принципа меритократии идей. Что означает поощрение и развитие компетентности и инициативы сотрудников для делегирования им большей ответственности. В перспективе это имеет большее качество, нежели авторитарное принятие решения руководителем. В мини-блоге на Инфостарте я буду делиться своими исследованиями по данной теме и буду рад их обсуждению.

1 стартмани

01.07.2019    4466    0    chuprina_as    0    

Автоматическая генерация технологических карт на основе графической схемы

Управление бизнес-процессами (BPM) Практика программирования Разработка v8 v8::УФ 1cv8.cf Россия Абонемент ($m)

В статье описывается способ генерация технологических карт на основе заданного графической схемой техпроцесса. Рассматриваются вопросы программного взаимодействия с объектом "графическая схема" и приведен механизм обхода графической схемы для получения карты техпроцесса. Тестировалось на платформе 8.3.12.

1 стартмани

27.03.2019    4339    1    all_net    0    

Программное управление бизнес-процессом "Заявка на Страхование" в 1С: Документооборот из внешней системы на практическом примере

Управление бизнес-процессами (BPM) Документооборот и делопроизводство Документооборот и делопроизводство v8 ДО Абонемент ($m)

В статье демонстрируется возможный пример реализации бизнес-процесса в ДО на примере практической задачи. Материал может быть полезен тем, кому быстро надо разобраться в архитектуре комплексных БП Документооборот.

1 стартмани

31.01.2019    5494    15    alexander-lubich    5    

Подсистема Бизнес-процессы. Создание бизнес-процессов в пользовательском режиме (управляемые формы)

Управление бизнес-процессами (BPM) v8::УФ v8::Бизнес-процессы 1cv8.cf УУ Абонемент ($m)

Подсистема бизнес-процессы позволяет расширить конфигурации в которых не используются бизнес-процессы. Бизнес-процессы создаются в пользовательском режиме различной сложности по усмотрению пользователя. Простой и понятный механизм создания бизнес-процессов.

1 стартмани

02.01.2019    7695    60    lesv    16    

Управление задачами в 1С - готовая подсистема с открытым кодом и широким базовым функционалом. Версия 1.0.6

Инструментарий разработчика Управление бизнес-процессами (BPM) Управление проектом v8 Абонемент ($m)

Конфигурация-подсистема для управления задачами с базовым функционалом, который, однако, может удовлетворить довольно широкий спектр запросов. Есть статусы и приоритеты, учёт трудозатрат по исполнителям и даже базовые разграничения по правам. А открытый исходный код позволит на базе данной конфигурации развить систему до любого уровня сложности.

2 стартмани

17.12.2018    17895    94    for_sale    38    

Применение цифровой подписи при организации учёта ТМЦ и ГСМ

Защита и шифрование Управление бизнес-процессами (BPM) Мобильная разработка v8::Mobile v8::Бизнес-процессы 1cv8.cf Абонемент ($m)

Статья о том, как внедрение мобильного приложения в бизнес-процессы компании сократило оборот бумажных документов, а простая электронная подпись - заменила аналоговую.

1 стартмани

25.10.2018    7022    2    ikekoval    2    

Шаблон бизнес-модели Остервальдера и Пинье

Управление бизнес-процессами (BPM) v8 Абонемент ($m)

Конфигурация с документом "Шаблон" и печатной формой шаблона бизнес-модели Остервальдера и Пинье.

1 стартмани

23.09.2018    6223    2    SergeySm    0    

Система по управлению задачами в 1С: УТ 11

Обработка документов Обработка справочников Управление бизнес-процессами (BPM) v8 v8::Бизнес-процессы УТ11 УУ Абонемент ($m)

В 1С: УТ 11 есть очень удобный механизм - задания. Можно создавать задание любому пользователю на основании справочника или документа. Например: "Исправить отчет о розничных продажах". Но можно прикреплять только один объект к задаче. А если необходимо обработать целый список документов? Данное расширение конфигурации позволяет прикреплять к задаче сразу несколько объектов. Благодаря этому механизму можно даже организовать передачу вопросов и обращений от пользователей к ИТ-службе.

2 стартмани

12.05.2018    13088    23    Kutuzov    3    

Получение актуального маршрута согласования комплексного процесса 1С Документооборот

Управление бизнес-процессами (BPM) v8::Бизнес-процессы ДО Россия Абонемент ($m)

Получение актуального маршрута согласования документа в 1С Документооборот.

1 стартмани

11.03.2018    13212    33    iolko    10    

Бизнес-процессы: Согласование скидки с клиентом

Управление бизнес-процессами (BPM) Оптовая торговля Ценообразование, анализ цен Оптовая торговля Ценообразование, анализ цен v8 1cv8.cf Оптовая торговля, дистрибуция, логистика УУ Абонемент ($m)

Пример бизнес-процесса согласования скидок клиентов. В статье шаблон типового процесса, схему которого можно скачать и адаптировать под свои нужны. Во вложение добавлена "рыба" регламента.

1 стартмани

04.12.2017    13135    7    siddy    0    

Бизнес-процессы: Процесс заключения договора с клиентом

Управление бизнес-процессами (BPM) Управление взаимоотношениями с клиентами (СRM) Управление взаимоотношениями с клиентами (СRM) v8 1cv8.cf УУ Абонемент ($m)

Статья о том, как построить процесс работы с договорами клиентов. Написана по мотивам наших автоматизаций - постарались обобщить знания в шаблонный процесс, который легко подправить под свои нужды. К публикации прикреплен пример регламента такого процесса.

1 стартмани

30.11.2017    20502    13    siddy    0    

Условия для дополнительных реквизитов в задачах бизнес-процессов (шаблоны) + доработка интерфейса многостраничные реквизиты - расширение

Управление бизнес-процессами (BPM) Документооборот и делопроизводство Работа с интерфейсом Документооборот и делопроизводство v8 ДО Абонемент ($m)

Существует проблема, когда добавляешь дополнительные реквизиты в шаблоны бизнес-процессов, нет отбора по шаблону. То есть когда мы на определённый шаблон, скажем - заявка на ремонт, хотим добавить реквизит - помещение, то это реквизит начинает отображаться во всех процессах. Что очень неудобно. Зачем реквизит помещение в процессе, скажем, создания договора? Расширение позволяет делать условие на шаблон и на папку шаблонов (без иерархии!!!) Плюс увеличивает размер многострочных реквизитов - в высоту *2 и в ширину 600.

4 стартмани

14.11.2017    9894    4    Vladimir45    19    

Автозадачи

Управление бизнес-процессами (BPM) Универсальные функции v8::СКД Россия Абонемент ($m)

Универсальный механизм управления потоками задач в информационной базе 1С. Самый востребованный инструмент из "кастомизации на лету".

1 стартмани

01.08.2017    28737    175    1c-intelligence    39    

Согласование (подсистема). Для любого справочника и документа в 1С. Встраивается в любые конфигурации

Управление бизнес-процессами (BPM) Обработка документов Обработка справочников Документооборот и делопроизводство Документооборот и делопроизводство v8 1cv8.cf БП3.0 КА2 УУ Абонемент ($m)

Подсистема для согласования в 1С. Для настройки нового согласования не требуется программировать, все делается в режиме исполнения. Открытый код. Бизнес-процессы. Документооборот. Проект выложен на GitHub.

1 стартмани

25.08.2016    49725    250    BlizD    200    

Работа с задачами исполнителя

Управление бизнес-процессами (BPM) v8 1cv8.cf Россия Абонемент ($m)

Выполнение или отмена выполнения любой задачи бизнес-процесса

1 стартмани

05.05.2016    14281    11    di0xa    2    

Торговля глазами ветврача. Оформление ветеринарно-сопроводительных документов в системе Меркурий (Часть 3)

Управление бизнес-процессами (BPM) Управленческий учет (прочее) Учет ТМЦ Учет ТМЦ v8 Сельское хозяйство и рыболовство Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Пищевая промышленность Беларусь Россия Казахстан УУ Абонемент ($m)

Для торговой компании объясняется, как выполнять типовые операции в системе Меркурий. Зачем нужен Меркурий? C его помощью можно оформлять ветсвидетельства бесплатно. Уточните у руководства, сколько денег платите ветеринарам. Например, сеть Перекресток платит 400 млн. руб. в год.

5 стартмани

22.01.2016    52051    9    axxell    5    

Производство глазами ветврача. Оформление ветеринарно-сопроводительных документов в системе Меркурий (Часть 2)

Управление бизнес-процессами (BPM) Управленческий учет (прочее) Бухгалтерский учет Производство готовой продукции (работ, услуг) Учет ТМЦ Производство готовой продукции (работ, услуг) Учет ТМЦ v7.7 v8 1С7:Комплекс УПП1 1С7:ПУБ Сельское хозяйство и рыболовство Пищевая промышленность Беларусь Россия Казахстан УУ Абонемент ($m)

Для предприятия по производству пищевых продуктов объясняется, как выполнять типовые операции в системе Меркурий. Зачем нужен Меркурий? C его помощью можно оформлять ветсвидетельства бесплатно. Уточните у руководства, сколько денег платите ветеринарам. Например, сеть Перекресток платит 400 млн. руб. в год.

5 стартмани

19.01.2016    78341    8    axxell    9    

Редактор графической схемы

Управление бизнес-процессами (BPM) v8 1cv8.cf Абонемент ($m)

Обработка для редактирования графической схемы.

1 стартмани

23.01.2015    31563    80    serzalx    10    

Бизнес-Процесс Для УПП УправлениеЗакупками

Управление бизнес-процессами (BPM) v8 УПП1 Россия БУ УУ Абонемент ($m)

Описание бизнес процесса в приложении в visio для блока управление закупками на 4х страницах с выходом в документы системы УПП ред 1.3. с проводками по документам

1 стартмани

24.05.2014    17202    18    BagiraN    1    

Сохранение графической схемы как картинки

Управление бизнес-процессами (BPM) v8 Абонемент ($m)

Простенькая обработка для сохранения схемы как картинки BMP.

1 стартмани

12.12.2013    14759    19    andrey3d    5    

Обработчик автоматической регистрации документа 1С:Документооборот после утверждения и автозаполнения файла по шаблону

Управление бизнес-процессами (BPM) Документооборот и делопроизводство Документооборот и делопроизводство v8 ДО Абонемент ($m)

Дополнительный обрабочик для 1С:Документооборот, позволяющий выполнять автоматическую регистрацию внутреннего документа после его утверждения и автоматическое заполнение прикрепленного шаблонного файла.

1 стартмани

29.05.2013    37030    6    Killgur    14    

Редактор регистра адресации

Управление бизнес-процессами (BPM) Учет рабочего времени Учет рабочего времени v8 1cv8.cf УУ Абонемент ($m)

Обработка предназначена для редактирования регистра адресации задач бизнес-процессов.

1 стартмани

30.07.2012    12558    0    redcat    1    

Настройка интеграции «1С:Управление торговлей 8 Редакция 11» и «1С:Документооборот». Бизнес-процессы, внешние роли исполнителей.

Документооборот и делопроизводство Управление бизнес-процессами (BPM) Перенос данных из 1C8 в 1C8 Документооборот и делопроизводство v8 УТ10 ДО Россия Абонемент ($m)

Моя первая статья про настройку интеграции 1С:Управление торговлей 8 Редакция 11 и 1С:Документооборот оказалась достаточно востребованной. Благодарю за отзывы. В продолжение темы хочу представить вашему вниманию продолжение - настройку бизнес-процессов и внешних ролей исполнителей.

1 стартмани

11.07.2012    43160    1    ReSY    11    

Учет особенностей бизнес-процессов на базе 1С Предприятия 8

Управление бизнес-процессами (BPM) v8 1cv8.cf Россия Абонемент ($m)

Презентация в MS PowerPoint-е об основных особенностях современных бизнес-процессов и их реализации в 1С Предприятии 8

1 стартмани

04.04.2012    13238    2    barankov.vv    5    

Карта маршрута бизнес процесса

Управление бизнес-процессами (BPM) v8 1cv8.cf Россия Абонемент ($m)

Позволяет показать карту маршрута любого бизнес-процесса в режиме 1с:Предприятия.

1 стартмани

25.03.2012    19396    6    fixin    13    

Экономический результат от внедрения: технология необходима, но не достаточна

Управление проектом Управление бизнес-процессами (BPM) Управление взаимоотношениями с клиентами (СRM) Управление взаимоотношениями с клиентами (СRM) v7.7 v8 1cv8.cf 1cv7.md Россия Абонемент ($m)

Что такое эффективность проекта внедрения и как ее обосновать клиенту? Часто слышу подход, при котором нужно удовлетворить требования клиента и быть счастливым. Ведь даже если клиент не прав, то он все-равно клиент. Проблема заключается в том, что «удовлетворяют» клиентов сотрудники(цы) другой профессии, не так ли?

1 стартмани

04.04.2011    11535    1    lokhnin    3    

Регламент управления торговлей для 1С УТ 8

Управление взаимоотношениями с клиентами (СRM) Управление бизнес-процессами (BPM) Управление взаимоотношениями с клиентами (СRM) v8 КА1 УТ10 УПП1 Россия Абонемент ($m)

Как обучить пользователя владению программой? Что сделать чтобы пользователь допускал меньше ошибок? Как доказать что программист не виноват в сбое?

1 стартмани

14.06.2010    51368    26        45