Параметры выбора и связи параметров выбора в панели быстрых настроек отчета СКД

Публикация № 1185743

Разработка - БСП (Библиотека стандартных подсистем)

Предложен способ задать параметры выбора и связи параметров выбора для отборов и параметров отчета СКД, выведенных в панель быстрых настроек.

При разработке отчета на СКД часто требуется указать связь между параметрами этого отчета. Например если в отчете имеется параметры "Номенклатура" и "Серия", при выборе серии показывать только серии данной номенклатуры. Или нужно отображать в списке выбора элементов справочника "ЗначенияСвойствОбъектов" только значения, принадлежащие определенному элементу плана видов характеристик "ДополнительныеРеквизитыИСведения". Несмотря на то, что в полях и параметрах СКД есть возможность указать параметры выбора и связи параметров выбора, этот механизм не работает (по крайней мере, так обстоит дело в ERP 2.4.9.98).

Можно написать свою форму отчета, разместить на ней элементы отбора и сделать в ней все, что угодно. Но не хотелось бы терять мощные механизмы общей формы "ФормаОтчета" или копипастить их в свой отчет.

Можно модифицировать общую форму "ФормаОтчета" под свои задачи. Но не хотелось бы это делать каждый раз при разработке нового отчетов.

Предлагаю пример решения этой задачи для двух вариантов:

1. Фиксированный параметр выбора для поля "Отбор". В отчете сделан отбор по полю с типом "Справочник.ЗначенияСвойствОбъектов". При выборе значения отбора требуется показать пользователю только элементы с заданным владельцем.

2. Связи параметров выбора для поля "Параметр". В отчете имеется 2 параметра: Номенклатура и Серия. При выборе серии, показывать пользователю только серии выбранной номенклатуры

 

1. Фиксированный параметр выбора

Создаем отчет (файл ВнешнийОтчет_ФиксированныеПараметрыОтбора.erf). 

Если отчет встроен в расширение, то необходимо:

1. Добавить в расширение подсистему ПодключаемыеОтчетыИОбработки

2. Добавить отчет в эту подсистему

3. В модуле менеджера отчета написать код:

#Если Сервер Или ТолстыйКлиентОбычноеПриложение Или ВнешнееСоединение Тогда

Процедура ПриОпределенииНастроек(Настройки) Экспорт
	
	Настройки.ОпределитьНастройкиФормы = Истина;
	
КонецПроцедуры	

#КонецЕсли

В 1С добавить дополнительный реквизит справочника Номенклатура "Раздел комплектации" с типом значений "Дополнительное значение". Указать или сгенерировать имя реквизита, в моем случае это "РазделКомплектации_c7a03c267bb64e0eb58489873f24c25e"

В отчете составляем текст запроса:
ВЫБРАТЬ
	НоменклатураДополнительныеРеквизиты.Ссылка КАК Ссылка,
	НоменклатураДополнительныеРеквизиты.Свойство КАК Свойство,
	НоменклатураДополнительныеРеквизиты.Значение КАК РазделКомплектации
ИЗ
	Справочник.Номенклатура.ДополнительныеРеквизиты КАК НоменклатураДополнительныеРеквизиты
ГДЕ
	НоменклатураДополнительныеРеквизиты.Свойство = &Свойство

Для поля "РазделКомплектации" нужно указать тип значения СправочникСсылка.ЗначенияСвойствОбъектов

На вкладке "Параметры" укажем выражение для параметра "Свойство": ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоРеквизиту("Имя", "РазделКомплектации_c7a03c267bb64e0eb58489873f24c25e", Истина)

Включим отбор по полю "РазделКомплектации" в пользовательские настройки: на вкладке "Настройки", "Отбор" добавими отбор "РазделКомплектации", щелкнем на нем правой кнопкой мыши, "Свойства элементов пользовательских настроек", установим флажок "Включать в пользовательские настройки".

В модуле отчета указываем, что мы перехватываем событие "ПослеЗаполненияПанелиБыстрыхНастроек":
Процедура ОпределитьНастройкиФормы(Форма, КлючВарианта, Настройки) Экспорт
	
	Настройки.События.ПослеЗаполненияПанелиБыстрыхНастроек = Истина;
	
КонецПроцедуры
В обработчике этого события нужно найти элемент формы в панели быстрого отбора, в котором пользователь указывает значение отбора "Раздел комплектации". В параметрах выбора этого элемента задаем отбор по владельцу - плану видов характеристик "Раздел комплектации":
Процедура ПослеЗаполненияПанелиБыстрыхНастроек(Форма, ПараметрыОбновления) Экспорт
	
	ПутьКДаннымПоля_РазделКомплектации = ПутьКДаннымЭлементаФормыЗначенияОтбора("РазделКомплектации");
	
	Для Каждого Элемент Из Форма.Элементы Цикл
		
		Если СтрНачинаетсяС(Элемент.Имя, "КомпоновщикНастроекПользовательскиеНастройкиЭлемент") 
			И ТипЗнч(Элемент) = Тип("ПолеФормы") Тогда
			
			Если Элемент.ПутьКДанным = ПутьКДаннымПоля_РазделКомплектации Тогда
				
				Массив = Новый Массив;
				Массив.Добавить(Новый ПараметрВыбора("Отбор.Владелец", ПВХ_РазделКомплектации())); 
				ПараметрыВыбора = Новый ФиксированныйМассив(Массив);
				Элемент.ПараметрыВыбора = ПараметрыВыбора;
				
			КонецЕсли;
			
		КонецЕсли;
		
	КонецЦикла;
	
КонецПроцедуры

Функция ПутьКДаннымЭлементаФормыЗначенияОтбора(ИмяПоляКомпоновкиДанных)
	
	ПолеКомпоновкиДанных = Новый ПолеКомпоновкиДанных(ИмяПоляКомпоновкиДанных);
	
	Для Каждого Элемент Из КомпоновщикНастроек.Настройки.Отбор.Элементы Цикл
		Если Элемент.ЛевоеЗначение = ПолеКомпоновкиДанных Тогда
			ИдентификаторПользовательскойНастройки = Элемент.ИдентификаторПользовательскойНастройки;
			Прервать;
		КонецЕсли;
	КонецЦикла;
	
	Если ИдентификаторПользовательскойНастройки = Неопределено Тогда
		возврат Неопределено;
	КонецЕсли;
	
	ПользовательскиеНастройки = КомпоновщикНастроек.ПользовательскиеНастройки.Элементы;
	Для Индекс = 0 По ПользовательскиеНастройки.Количество()-1 Цикл
		Если ПользовательскиеНастройки[Индекс].ИдентификаторПользовательскойНастройки = ИдентификаторПользовательскойНастройки Тогда
			возврат "Отчет.КомпоновщикНастроек.ПользовательскиеНастройки["+Формат(Индекс, "ЧДЦ=0; ЧН=0; ЧГ=")+"].Значение";
		КонецЕсли;
	КонецЦикла;
	
	возврат Неопределено;
	
КонецФункции

Функция ПВХ_РазделКомплектации()
	возврат ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоРеквизиту("Имя", "РазделКомплектации_c7a03c267bb64e0eb58489873f24c25e", Истина)	
КонецФункции

 

2. Связи параметров выбора

Здесь мне уже не получилось обойтись без модификации общей формы "ФормаОтчета". Произошло это потому, что не получилось задать связи параметров выбора в существующих элементах панели быстрых настроек. Я выбрал обходной путь - скрывать существующий элемент формы со значением отбора, и подставлять на его место свой элемент. Связи параметров выбора зависимого элемента (серии) я задаю с данными этого элемента. Я постарался свести изменения ФормыОтчета к минимуму, и сделать их универсальными (их не нужно переписывать при создании другого отчета).

Создаем отчет (файл ВнешнийОтчет_СвязиПараметровВыбора.erf). 

Как и в предыдущем примере, если отчет встроен в расширение, то необходимо:

1. Добавить в расширение подсистему ПодключаемыеОтчетыИОбработки

2. Добавить отчет в эту подсистему

3. В модуле менеджера отчета написать:

#Если Сервер Или ТолстыйКлиентОбычноеПриложение Или ВнешнееСоединение Тогда

Процедура ПриОпределенииНастроек(Настройки) Экспорт
	
	Настройки.ОпределитьНастройкиФормы = Истина;
	
КонецПроцедуры	

#КонецЕсли
В отчете составляем текст запроса:
ВЫБРАТЬ
	РеализацияТоваровУслугСерии.Ссылка КАК Ссылка,
	РеализацияТоваровУслугСерии.Количество КАК Количество
ИЗ
	Документ.РеализацияТоваровУслуг.Серии КАК РеализацияТоваровУслугСерии
ГДЕ
	РеализацияТоваровУслугСерии.Номенклатура = &Номенклатура
	И РеализацияТоваровУслугСерии.Серия = &Серия

Параметры "Номенклатура" и "Серия" включим в пользовательские настройки (см. выше).

В модуле отчета указываем, что мы перехватываем событие "ПослеЗаполненияПанелиБыстрыхНастроек":
Процедура ОпределитьНастройкиФормы(Форма, КлючВарианта, Настройки) Экспорт
	
	Настройки.События.ПослеЗаполненияПанелиБыстрыхНастроек = Истина;
	
КонецПроцедуры
В обработчике этого события:

1. Находим элементы формы - значения параметров "Номенклатура" и "Серия"

2. Добавляем в форму новый реквизит "МойРеквизит_Номенклатура". Добавить элемент формы для этого реквизита.
Элементу формы указать обработчик события "ПриИзменении" (обработчик этого события и будет то единственным изменением общей формы "ФормаОтчета").

3. Скрываем старый элемент формы "Номенклатура".

4. Для элемента формы "Серия" задаем связи параметров выбора.

5. Сохраняем необходимую в дальнейшем информацию в дополнительных свойствах пользовательских настроек компоновщика настроек:

Процедура ПослеЗаполненияПанелиБыстрыхНастроек(Форма, ПараметрыОбновления) Экспорт
	
	//находим элементы формы - параметры "Номенклатура" и "Серия"
	ИмяПараметра_Номенклатура = "Номенклатура";
	ИдентификаторПользовательскойНастройки_Номенклатура = ИдентификаторПользовательскойНастройки(ИмяПараметра_Номенклатура);
	ПутьКДаннымПоля_Номенклатура = ПутьКДаннымЭлементаФормыЗначениеПараметра(ИдентификаторПользовательскойНастройки_Номенклатура);
	
	ИмяПараметра_Серия = "Серия";
	ИдентификаторПользовательскойНастройки_Серия = ИдентификаторПользовательскойНастройки(ИмяПараметра_Серия);
	ПутьКДаннымПоля_Серия = ПутьКДаннымЭлементаФормыЗначениеПараметра(ИдентификаторПользовательскойНастройки_Серия);
	
	СтарыйЭлемент_Номенклатура = ЭлементФормыПоПутиКДанным(Форма, ПутьКДаннымПоля_Номенклатура);
	Если СтарыйЭлемент_Номенклатура = Неопределено Тогда
		возврат;
	КонецЕсли;
	
	ПараметрыКомпоновкиДанныхСоответствующиеДобавленнымРеквизитам = Новый Структура();
	ЗначенияВДобавленныхРеквизитахФормы = Новый Структура();
	
	//добавляем новый реквизит в форму
	ИмяДобавляемогоРеквизита_Номенклатура = "МойРеквизит_Номенклатура";
	Если Не СуществуетРеквизитФормы(Форма, ИмяДобавляемогоРеквизита_Номенклатура) Тогда
		ДобавляемыеРеквизиты = Новый Массив;
		РеквизитФормы = Новый РеквизитФормы(ИмяДобавляемогоРеквизита_Номенклатура, Новый ОписаниеТипов("СправочникСсылка.Номенклатура")); 
		ДобавляемыеРеквизиты.Добавить(РеквизитФормы);
		Форма.ИзменитьРеквизиты(ДобавляемыеРеквизиты);
	КонецЕсли;
	
	//заполняем его значение
	СохраненноеЗначение_Номенклатура = ПолучитьЗначениеПараметраПользовательскойНастройкиОтчета(Форма, ИдентификаторПользовательскойНастройки_Номенклатура);
	Форма[ИмяДобавляемогоРеквизита_Номенклатура] = СохраненноеЗначение_Номенклатура;
	
	//добавляем элемент формы в панель пользовательских настроек
	НовыйЭлемент_Номенклатура = Форма.Элементы.Вставить(ИмяДобавляемогоРеквизита_Номенклатура, Тип("ПолеФормы"), СтарыйЭлемент_Номенклатура.Родитель, СтарыйЭлемент_Номенклатура);
	НовыйЭлемент_Номенклатура.Вид = ВидПоляФормы.ПолеВвода;
	НовыйЭлемент_Номенклатура.ПутьКДанным = ИмяДобавляемогоРеквизита_Номенклатура;
	НовыйЭлемент_Номенклатура.ПоложениеЗаголовка = ПоложениеЗаголовкаЭлементаФормы.Нет;
	
	//эта процедура должна быть определена в общей форме "ФормаОтчета"
	НовыйЭлемент_Номенклатура.УстановитьДействие("ПриИзменении", "МоиДобавленныеЭлементыПриИзменении");
	
	//скрываем старый элемент формы
	СтарыйЭлемент_Номенклатура.Видимость = Ложь;
	
	//определяем связи параметров выбора
	Элемент_Серия = ЭлементФормыПоПутиКДанным(Форма, ПутьКДаннымПоля_Серия);
	Если Элемент_Серия <> Неопределено Тогда
		Массив = Новый Массив;
	    Массив.Добавить(Новый СвязьПараметраВыбора("Номенклатура", ИмяДобавляемогоРеквизита_Номенклатура, РежимИзмененияСвязанногоЗначения.Очищать)); 
	    СвязиПараметровВыбора = Новый ФиксированныйМассив(Массив);
	    Элемент_Серия.СвязиПараметровВыбора = СвязиПараметровВыбора;
	КонецЕсли;
	
	//сохраняем все необходимые связи в дополнительных свойствах пользовательских настроек.
	//они затем используются в процедурах ПриКомпоновкеРезультата этого модуля 
	//и в МоиДобавленныеЭлементыПриИзменении общей формы "ФормаОтчета"
	ПараметрыКомпоновкиДанныхСоответствующиеДобавленнымРеквизитам.Вставить(ИмяДобавляемогоРеквизита_Номенклатура, ИмяПараметра_Номенклатура);
	ЗначенияВДобавленныхРеквизитахФормы.Вставить(ИмяДобавляемогоРеквизита_Номенклатура, СохраненноеЗначение_Номенклатура);
	
	Форма.Отчет.КомпоновщикНастроек.ПользовательскиеНастройки.ДополнительныеСвойства.Вставить(
		"ЗначенияВДобавленныхРеквизитахФормы", ЗначенияВДобавленныхРеквизитахФормы);
	Форма.Отчет.КомпоновщикНастроек.ПользовательскиеНастройки.ДополнительныеСвойства.Вставить(
		"ПараметрыКомпоновкиДанныхСоответствующиеДобавленнымРеквизитам", ПараметрыКомпоновкиДанныхСоответствующиеДобавленнымРеквизитам);
	
КонецПроцедуры
В обработчике события "ПриИзменении" модуля формы "ФормаОтчета" сохраняем в дополнительных свойствах компоновщика выбранное значение поля "МойРеквизит_Номенклатура":
&НаКлиенте
Процедура МоиДобавленныеЭлементыПриИзменении(Элемент)
	
	ЗначенияВДобавленныхРеквизитахФормы = Неопределено;
	Если Отчет.КомпоновщикНастроек.ПользовательскиеНастройки.ДополнительныеСвойства.Свойство("ЗначенияВДобавленныхРеквизитахФормы", ЗначенияВДобавленныхРеквизитахФормы)
		И ТипЗнч(ЗначенияВДобавленныхРеквизитахФормы) = Тип("Структура") Тогда
		
		ЗначениеДобавленногоРеквизита = Неопределено;
		Если ЗначенияВДобавленныхРеквизитахФормы.Свойство(Элемент.Имя, ЗначениеДобавленногоРеквизита) Тогда
			//имя добавленного реквизита должно совпадать с именем элемента
			Отчет.КомпоновщикНастроек.ПользовательскиеНастройки.ДополнительныеСвойства["ЗначенияВДобавленныхРеквизитахФормы"].Вставить(Элемент.Имя, ЭтотОбъект[Элемент.Имя]);
		КонецЕсли;
		
	КонецЕсли;
	
КонецПроцедуры
В процедуре "При компоновке данных" извлекаем эти данные и подставляем в компоновщик:
Процедура ПриКомпоновкеРезультата(ДокументРезультат, ДанныеРасшифровки, СтандартнаяОбработка)
	
	Для Каждого КлючИЗначение Из КомпоновщикНастроек.ПользовательскиеНастройки.ДополнительныеСвойства.ПараметрыКомпоновкиДанныхСоответствующиеДобавленнымРеквизитам Цикл
		
		ПараметрКомпоновкиДанных = Новый ПараметрКомпоновкиДанных(КлючИЗначение.Значение);
		Если ПараметрКомпоновкиДанных<>Неопределено Тогда
			
			Для Каждого Элемент Из КомпоновщикНастроек.ПользовательскиеНастройки.Элементы Цикл
				Если Элемент.Параметр = ПараметрКомпоновкиДанных Тогда
					ЗначениеПользовательскойНастройки = КомпоновщикНастроек.ПользовательскиеНастройки.ДополнительныеСвойства.ЗначенияВДобавленныхРеквизитахФормы[КлючИЗначение.Ключ];
			        Элемент.Значение = ЗначениеПользовательскойНастройки;
			    КонецЕсли;
			КонецЦикла;
			
		КонецЕсли;
		
	КонецЦикла;
	
КонецПроцедуры

 

Вспомогательные процедуры модуля объекта отчета:
#Область Вспомогательные

Функция ЭлементФормыПоПутиКДанным(Форма, ПутьКДанным)
	
    Для Каждого Элемент Из Форма.Элементы Цикл
        
        Если СтрНачинаетсяС(Элемент.Имя, "КомпоновщикНастроекПользовательскиеНастройкиЭлемент") 
            И ТипЗнч(Элемент) = Тип("ПолеФормы") Тогда
            
            Если Элемент.ПутьКДанным = ПутьКДанным Тогда
				возврат Элемент;
			КонецЕсли;
                
        КонецЕсли;
        
    КонецЦикла;
    
КонецФункции

Функция ПутьКДаннымЭлементаФормыЗначениеПараметра(ИдентификаторПользовательскойНастройки)
    
    Если ИдентификаторПользовательскойНастройки = Неопределено Тогда
        возврат Неопределено;
    КонецЕсли;
    
    ПользовательскиеНастройки = КомпоновщикНастроек.ПользовательскиеНастройки.Элементы;
    Для Индекс = 0 По ПользовательскиеНастройки.Количество()-1 Цикл
        Если ПользовательскиеНастройки[Индекс].ИдентификаторПользовательскойНастройки = ИдентификаторПользовательскойНастройки Тогда
            возврат "Отчет.КомпоновщикНастроек.ПользовательскиеНастройки["+Формат(Индекс, "ЧДЦ=0; ЧН=0; ЧГ=")+"].Значение";
        КонецЕсли;
    КонецЦикла;
    
    возврат Неопределено;
    
КонецФункции

Функция ИдентификаторПользовательскойНастройки(ИмяПоляКомпоновкиДанных)
	
    ПараметрКомпоновкиДанных = Новый ПараметрКомпоновкиДанных(ИмяПоляКомпоновкиДанных);
    
    Для Каждого Элемент Из КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы Цикл
        Если Элемент.Параметр = ПараметрКомпоновкиДанных Тогда
            возврат Элемент.ИдентификаторПользовательскойНастройки;
        КонецЕсли;
	КонецЦикла;
	
КонецФункции

Функция ПолучитьЗначениеПараметраПользовательскойНастройкиОтчета(Форма, ИдентификаторПользовательскойНастройки)
	
    Если ИдентификаторПользовательскойНастройки = Неопределено Тогда
        возврат Неопределено;
    КонецЕсли;
    
	Для Каждого Элемент Из Форма.Отчет.КомпоновщикНастроек.ПользовательскиеНастройки.Элементы Цикл
		
		Если Элемент.ИдентификаторПользовательскойНастройки = ИдентификаторПользовательскойНастройки Тогда
			возврат Элемент.Значение;
		КонецЕсли;
		
	КонецЦикла;
	
КонецФункции

Функция СуществуетРеквизитФормы(Форма, ИмяРеквизита)
	
	РеквизитыФормы = Форма.ПолучитьРеквизиты();
	Для Каждого Реквизит Из РеквизитыФормы Цикл
		Если Реквизит.Имя = ИмяРеквизита Тогда
			возврат Истина;
		КонецЕсли;
	КонецЦикла;
	
	возврат Ложь;
	
КонецФункции

#КонецОбласти

 

Скачать файлы

Наименование Файл Версия Размер
Параметры выбора и связи параметров выбора в панели быстрых настроек отчета СКД:

.zip 10,36Kb
28.01.20
2
.zip 10,36Kb 2 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. user1049275 16.03.20 15:17 Сейчас в теме
Большое спасибо за наводку. Бился несколько дней, чтобы при открытии дополнительного отчета с общей формой "ФормаОтчета" из элемента справочника, выполнялся отбор по данному элементу. В процедуре "ПриСозданииНаСервере" никак не хотело отрабатывать нормально, при установке Форма.ФормаПараметры.Отбор сам отбор исчезал из панели быстрых настроек. В процедуре "ПослеЗаполненияПанелиБыстрыхНастроек" получилось. Не факт, что правильно, но пока делает то, что нужно. Благодарю за статью
Оставьте свое сообщение

См. также

Работа с релизами 1С и договорами ИТС Промо

WEB БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Работа с релизами 1С и партнерским кабинетом.

2 стартмани

15.08.2019    13675    39    RocKeR_13    15    

Генератор внешних печатных форм

Инструментарий разработчика БСП (Библиотека стандартных подсистем) Консоль запросов Прочие инструменты разработчика Универсальные печатные формы v8 1cv8.cf Абонемент ($m)

Генератор печатных форм - инструмент для создания внешних печатных форм в режиме предприятия с минимальным написанием кода

3 стартмани

18.09.2020    758    5    andy_zhav    7    

Простой почтовый клиент (Моя почта)

БСП (Библиотека стандартных подсистем) Email v8 1cv8.cf Абонемент ($m)

Почтовый клиент (Моя почта) на основе БСП.

2 стартмани

27.08.2020    958    1    m_aster    0    

Шаблон обработки заполнения объекта в форме

БСП (Библиотека стандартных подсистем) v8::УФ 1cv8.cf Абонемент ($m)

Шаблон обработки заполнения формы объекта без записи, с возможностью отладки.

1 стартмани

18.08.2020    701    1    Arc    1    

Настройка прав пользователей. БСП. Профиль доступа. Три клика. Промо

Информационная безопасность Сервисные утилиты БСП (Библиотека стандартных подсистем) v8 Розница УНФ БП3.0 УТ11 ЗУП3.x Абонемент ($m)

Простое и наглядное формирование профиля доступа с расширенными правами "EXPERT". Сопоставление ролей профилей конфигурации. Просмотр прав ролей. Управляемое приложение.

1 стартмани

06.03.2013    133290    818    StepByStep    83    

Оптимизация пакетной печати из 1С в MS Word

Пакетная печать Производительность и оптимизация (HighLoad) MS Office БСП (Библиотека стандартных подсистем) v8 ЗУП3.x Абонемент ($m)

Опыт оптимизации пакетной печати из 1С ЗУП 3.1 в MS Word. Об осторожности использования БСП. Внешние обработки: до и после оптимизации.

1 стартмани

14.08.2020    1104    1    info1i    5    

Шаблоны выполнения длительных операций (процедур и функций) без блокировки пользовательского интерфейса

БСП (Библиотека стандартных подсистем) v8 Розница УНФ ERP2 БП3.0 УТ11 КА2 Россия Абонемент ($m)

Шаблоны выполнения длительных операций (процедур и функций) без блокировки пользовательского интерфейса. Позволяют с минимальными затратами разработать и внедрить длительную процедуру (функцию),требующую фонового исполнения в свою конфигурацию или расширение.

1 стартмани

11.08.2020    984    15    Hitcher    8    

Хранилище внешних отчетов и обработок (интегрируемый модуль)

Хранилище Менеджеры внешних отчетов БСП (Библиотека стандартных подсистем) v8::УФ 1cv8.cf Абонемент ($m)

Сие идея по принципу хранилища конфигурации была реализована для удобства и надежности совместной работы программистов с внешними отчетами и обработками для БСП справочника "Дополнительные отчеты и обработки": все файлы ВОиО для спр. ДОиО всех подключенных ИБ хранятся и учитываются в одном месте; возможность захвата/освобождения файла ВОиО; создание версий с комментариями (добавление новой или обновление текущей); признак проверенности (для связки работы с аналитиком); проверочный механизм совместимости версий файла ВОиО и конфигурации; быстрое переключение между версиями.

5 стартмани

10.08.2020    866    0    mr_sav    0    

Не удаляются объекты, помеченные на удаление

БСП (Библиотека стандартных подсистем) Чистка базы v8 ERP2 БП3.0 УТ11 КА2 ЗУП3.x Абонемент ($m)

Когда в конфигурации включено "Ограничивать доступ на уровне записей" и вариант работы выбран "Производительный", при "Удалении помеченных объектов" не все объекты удаляются из базы.

1 стартмани

31.07.2020    1372    0    Maito    2    

Загрузка адресного классификатора из БД ФИАС с поддержкой адресов по муниципальному делению

БСП (Библиотека стандартных подсистем) Классификаторы v8 Розница УНФ ERP2 БП3.0 УТ11 КА2 Россия Абонемент ($m)

Расширение позволяет загрузить адресный классификатор из БД ФИАС с поддержкой адресов по муниципальному делению. Для загрузки используется стандартный механизм, заложенный в БСП. Внимание! Для работы с новым форматом ФИАС с поддержкой адресов по муниципальному делению требуется БСП версии 3.0.1 и выше.

2 стартмани

19.07.2020    1785    1    Hitcher    0    

Обозреватель данных подсистем

Администрирование данных 1С БСП (Библиотека стандартных подсистем) Прочие инструменты разработчика v8 v8::УФ 1cv8.cf Абонемент ($m)

Часто возникает необходимость быстро разобраться в наполнении справочников, документов, из которых состоит подсистема, и при этом сложность конфигураций и возможности настройки таковы, что сложно увидеть все вместе.

1 стартмани

15.07.2020    1890    1    sergbsv    1    

Загрузка классификатора банков с сайта РосБизнесКонсалтинг в конфигурациях, использующих БСП 3.1

БСП (Библиотека стандартных подсистем) Банковские операции WEB Классификаторы v8 v8::БУ 1cv8.cf Россия БУ Абонемент ($m)

Обработка позволяет скачать файл с сайта РосБизнесКонсалтинг  и обновить классификатор банков, используя стандартный интерактивный механизм обновления классификаторов, используемый в БСП 3.1. Не требует подключения к Интернет-поддержке от 1С.

1 стартмани

07.07.2020    1613    5    Hitcher    1    

Шаблон загрузки данных из табличного документа (Excel, Open Office, MXL, CSV) с использованием БСП для УФ

БСП (Библиотека стандартных подсистем) Загрузка и выгрузка в Excel v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработка предназначена для организации собственного механизма обработки данных из табличного документа (Excel, Open Office, MXL, CSV). Для загрузки используются механизмы БСП.

2 стартмани

26.06.2020    1751    7    Hitcher    2    

Управление задачами: новая БСП и RLS для задач

Управление задачами Управление задачами Инструментарий разработчика Практика программирования Управление проектом SonarQube Групповая разработка Git (GitHub, GitLab, BitBucket) БСП (Библиотека стандартных подсистем) Конфигурирование 1С v8 Абонемент ($m)

Управление задачами: новая БСП и RLS (ограничение доступа на уровне записей) для задач. Релиз 1.0.5.001 Обновлена БСП до версии 3.0.3.184 режим совместимости 8.3.12 Новое расширение: которое изменяет основной стиль с желтого на серый с синем (BAS) Проект проверяется Sonar и BSL Language Server

1 стартмани

11.06.2020    1768    2    BlizD    0    

Пользовательские макеты внешних печатных форм и настраиваемый комплект документов по договорам

БСП (Библиотека стандартных подсистем) Универсальные печатные формы v8::БУ БП3.0 Абонемент ($m)

- Расширение стандартной подсистемы печати, позволяющее редактировать макеты внешних печатных форм и сохранять их по аналогии с встроенными печатными формами - подсистема настраиваемых комплектов печатных форм с привязкой к договору контрагента.

5 стартмани

08.06.2020    1677    1    andy_zhav    0    

Установка даты запрета изменения по расписанию

БСП (Библиотека стандартных подсистем) Роли и права v8 БП3.0 Абонемент ($m)

Внешняя обработка для установки даты запрета изменений по расписанию. Применяется для всех пользователей, кроме уже имеющихся в списке дат запрета.

1 стартмани

14.04.2020    2520    2    user1393353    0    

Генератор штрихкодов. Формирование текста QR кода чека ККТ с проверкой на сайте ФНС

Практика программирования Сканер штрих-кода Фискальный регистратор БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Внешняя обработка. Позволяет генерировать штрих-коды разных типов. А также сформировать текст QR кода чека ККТ. Есть возможность проверить чек на корректность на сайте ФНС.

1 стартмани

02.04.2020    2138    5    viplelik    3    

Добавление контекстных дополнительных обработок в командную панель (немного практики по доработке БСП расширениями)

БСП (Библиотека стандартных подсистем) v8 УТ11 Абонемент ($m)

При добавлении контекстных дополнительных отчетов они не попадают в командную панель (КП), а открываются специальной командой из КП "Отчеты - Дополнительные отчеты..." Не всегда это удобно, и если контекстный отчет нужен для частого использования, то гораздо лучше, если бы он попадал сразу в подменю "Отчеты" на КП, а не требовал открытия дополнительной формы.

1 стартмани

18.03.2020    2819    0    work.sable    6    

Шаблоны внешних обработок (БСП, управляемые формы)

Обработки Печать Универсальные функции БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Набор из шаблонов для создания внешних обработок вида: Внешняя печатная форма, Отчет на СКД, Схема СКД для сегмента, Внешняя обработка (Самостоятельная, Заполнение объектов, Создание связанных объектов). Предварительно наполнены базовым функционалом и некоторыми механизмами для отладки.

1 стартмани

01.03.2020    3141    24    riposte    2    

БСП - Дополнительная обработка - Заполнение объекта - Произвольный алгоритм

БСП (Библиотека стандартных подсистем) Прочие инструменты разработчика v8 1cv8.cf Абонемент ($m)

Информационная система 1С ИТС: "При разработке решений следует учитывать, что опасно не только непосредственное выполнение кода, написанного в режиме Предприятие, но и те места, где методами Выполнить или Вычислить исполняется код, сконструированный на основе параметров, переданных в серверные функции и процедуры. Ограничение не распространяется на код, выполняемый на клиенте."

1 стартмани

13.02.2020    3505    1    duhh    2    

Перенос данных БП 3 - УТ 11 (Исправление обработки с ИТС)

БСП (Библиотека стандартных подсистем) Перенос данных из 1C8 в 1C8 v8 БП3.0 УТ11 Россия Абонемент ($m)

Для текущих на данный момент версий УТ 11.4.11.63 и БП 3.0.75.93 обработка с сайта обновлений 1С из указанного релиза торговли отказывается работать, ссылаясь на ошибки БСП и некорректные правила обмена. Исправляется совсем небольшим расширением и корректировкой указанной на сайте 1С обработки (прилагается).

1 стартмани

13.02.2020    2328    14    &rew    0    

Отключение напоминаний о динамическом обновлении базы

БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Отключаем всплывающее окно о том, что конфигурации была изменена и требуется выполнить перезапуск.

1 стартмани

13.01.2020    2802    7    DanDy    18    

Обновление пароля системной учетной записи электронной почты, если забыт/утерян текущий

Email БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Изменение пароля стандартной системной учетной записи электронной почты для отправки отчетов, печатных форм из 1С в любой конфигурации, в которую интегрирована подсистема БСП Органайзер, для возможности перезаполнения стандартной учетки новыми данными.

1 стартмани

06.01.2020    3301    5    1sig    6    

Индикация прогресса выполнения фонового задания на управляемой форме внешней обработки

БСП (Библиотека стандартных подсистем) Работа с интерфейсом v8 v8::УФ 1cv8.cf Абонемент ($m)

Внешняя обработка с фоновым выполнением и индикацией процесса для любой конфигурации на основе БСП >= 2.3 без изменения конфигурации и встраивания обработки в "Дополнительные отчеты и обработки".

1 стартмани

27.12.2019    9445    13    1sig    14    

Присоединенные файлы в расширении для БСП 3

БСП (Библиотека стандартных подсистем) v8 БП3.0 Абонемент ($m)

Для разработчиков и для себя). Предлагается решение с наименьшими затратами. Сделано виде инструкции с необходимыми изменения в основной конфигурации. И расширение(файл), где есть признак наличия присоединенных файлов в списках. Пример реализован для конфигурации 1С:Бухгалтерия предприятия, редакция 3.0(3.0.73.54) с БСП 3.0.3. Всё проще сделал для БСП 3.1.2.

1 стартмани

24.12.2019    5045    2    IgorXml    12    

Загрузка курсов валют на клиенте

БСП (Библиотека стандартных подсистем) Обработка справочников WEB Банковские операции v8 v8::УФ 1cv8.cf Абонемент ($m)

Расширение загрузки курсов валют НаКлиенте. Адаптивность стандартной обработки "ЗагрузитьКурсыВалют" для конфигураций, использующих БСП.

1 стартмани

07.12.2019    3446    4    logarifm    4    

Просмотр и изменение данных регистра сведений Безопасное хранилище данных или как изменить пароль настроек подключения

Администрирование данных 1С БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Обработка выводит в структуру данные, сохранённые в хранилище регистра сведений Безопасное хранилище данных и сохраняет обратно сделанные изменения. Обработка была написана для изменения пароля подключения для обмена РИБ в УНФ 1.6, так же может использоваться для просмотра и изменения других паролей, сохраненных в базе - к интернет поддержке и т.д.

1 стартмани

27.11.2019    3548    7    de0nis    4    

Расширим общую форму "Расширения", чтобы по метаданным расширения полнее понять, для чего это расширение

БСП (Библиотека стандартных подсистем) Структура метаданных Расширения v8 1cv8.cf Абонемент ($m)

Показывает метаданные расширения в общей форме БСП "Расширения" В конфигурации должна быть БСП. Версия платформы должна быть не меньше 8.3.13 Режим совместимости текущего расширения: 8.3.12 Для работы расширения безопасный режим должен быть отключен.

1 стартмани

07.11.2019    6185    3    K_A_O    0    

Влияние БСП на производительность базы 1С с добавленными метаданными

Производительность и оптимизация (HighLoad) Адаптация типовых решений БСП (Библиотека стандартных подсистем) v8 УТ11 Абонемент ($m)

Повод для статьи — заметное снижение быстродействия при переводе учета с УТ 11.1 на 11.4 по «нашим» не стандартным метаданным (регламенты работы с массовым заполнением/проведением документов/регистров). Предварительно причину увидел во влиянии БСП. Была создана тестовая подсистема, быстродействие которой оцениваем в демобазе "Управление торговлей". С включенными и выключенными подписками БСП.

5 стартмани

04.11.2019    6858    2    VsHome    1    

Печать табличного документа через типовой механизм печати БСП (3.0) ОбщаяФорма.ПечатьДокументов

Универсальные печатные формы БСП (Библиотека стандартных подсистем) v8 1cv8.cf Россия Абонемент ($m)

Для чего нужна: у вас есть табличный документ и вы хотите его вывести точно так же ,как и выводите любую печатную форму, т.е. через форму "Печать документов. Обработка позволяет, используя штатные механизмы печати, выводить любой табличный документ, по такому же механизму.

1 стартмани

16.10.2019    5564    3    IncomeGroup    6    

Конфигурация для администраторов "Центр управления базами" для 8.3 УФ

Администрирование данных 1С БСП (Библиотека стандартных подсистем) v8 v8::УФ 1cv8.cf Абонемент ($m)

Конфигурация предназначена для централизованного управления информационными базами предприятия. Разработана на БСП версии 2.4.4.76. В работе использует COM-соединение.

3 стартмани

09.10.2019    6503    22    WhiteOwl    9    

Шаблон разработки печатных форм и подключения к конфигурациям на БСП 2.х и БСП 3.0

Печатные формы документов БСП (Библиотека стандартных подсистем) Расширения v8 1cv8.cf Абонемент ($m)

«Вместо поставки внешних печатных форм в виде внешних обработок рекомендуется вести их разработку с помощью расширений конфигурации.» [ИТС, БСП гл. 3.38 Печать] У меня задачи типа «Требуется разработать печатную форму …» появляются регулярно, но с временными интервалами. Что бы вести разработку единообразно, для конфигураций на БСП, я заготовил шаблон для таких задачек, который позволяет мне сразу приступить к разработке макета и алгоритма формирования печатной формы, а «обертка» из БСП уже готова.

1 стартмани

04.10.2019    27555    48    tolX5    18    

Получение настроек учетных записей электронной почты

Email БСП (Библиотека стандартных подсистем) v8 v8::УФ 1cv8.cf Абонемент ($m)

При переносе настроек из одной базы 1С в другую, может потребоваться узнать настройки учетных записей электронной почты, настроенных в программе 1С.

1 стартмани

30.09.2019    4065    5    user-z99999    0    

Сохранение файлов в каталог или архив из форм списка или форм объектов для конфигураций на БСП

Универсальные обработки БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Коллеги, в данной статье хочу поделиться своей доработкой для сохранения файлов в каталог или архив с формы списка или формы объекта элемента системы.

1 стартмани

28.09.2019    3694    1    pavelpribytkin96    0    

Универсальные уведомления для БСП

Email SMS рассылки БСП (Библиотека стандартных подсистем) v8 1cv8.cf Россия Абонемент ($m)

Расширение, позволяющее создавать настраиваемые уведомления, с использованием стандартного функционала БСП "Шаблоны сообщений".

1 стартмани

10.06.2019    8095    23    wizard.ilmir02    8    

Наследование ролей в профилях групп доступа в конфигурациях на базе БСП

Практика программирования БСП (Библиотека стандартных подсистем) Роли и права v8 v8::Права 1cv8.cf Абонемент ($m)

С помощью данной доработки можно создать новый профиль групп доступа, с наследованием ролей от базового (поставляемого) профиля. В созданном профиле можно добавить или исключить какие-либо роли относительно базового профиля.

1 стартмани

15.03.2019    9123    12    ids79    1    

Расширение для загрузки адресов и телефонов банков для конфигураций на БСП

Обработка справочников Банковские операции Банковские операции БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Предлагаю Вашему вниманию расширение, исправляющее следующую "неполноценность" загрузки банков средствами БСП версии 2.4 - загрузка элементов справочника осуществляется без заполнения полей "Адрес" и "Телефоны".

1 стартмани

06.12.2018    5114    0    PoZiTiFFF    4    

Набор: Дополнительные обработки для конфигураций на БСП (УТ 11 и аналогов)

Обработка документов Оптовая торговля Ценообразование, анализ цен Оптовая торговля Ценообразование, анализ цен БСП (Библиотека стандартных подсистем) v8 1cv8.cf УУ Абонемент ($m)

У вас есть типовая конфигурация на БСП («1С:Библиотека стандартных подсистем») к примеру "Управление торговлей 11" (УТ11) или её аналог и вы хотите без модификации конфигурации улучшить её функционал? Тогда используйте уже готовые дополнительные обработки, которые нужно только скачать и зарегистрировать!

1 стартмани

16.05.2017    14636    14    Xershi    6    

Образец внешней обработки с длительной операцией на базе БСП 2.3 (Переработанная)

Универсальные обработки БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Переработанная внешняя обработка для запуска длительных операций на базе БСП 2.3. Показывает прогресс, не требует изменений в конфигурации, лёгкая в отладке и использовании, работает в безопасном режиме, простая для понимания.

1 стартмани

30.11.2016    29640    154    ЕСТЬNULL    15