IE2017

Сравнение прав пользователей (Альфа-Авто: Автосалон+Автосервис+Автозапчасти 4.1)

Администрирование - Защита, права, пароли

Обработка для конфигурации Альфа-Авто: Автосалон+Автосервис+Автозапчасти 4.1, позволяет сравнить права двух пользователей.

Обработка предназначена для сравнения прав 2х пользователей в конфигурации Рарус Альфа-Авто: Автосалон+Автосервис+Автозапчасти 4.1, в других не тестировалась, однако есть вероятность, что будет работать в других конфигурациях компании Рарус использующих схожую систему прав пользователей.

Работает просто, нужно выбрать двух пользователей. Нажать кнопку "Сравнить" и в дереве отобразятся ветки различающихся прав которые можно развернуть и посмотреть установки у первого и второго пользователя.

Скачать файлы

Наименование Файл Версия Размер
Обработка сравнения прав
.epf 8,11Kb
13.03.13
27
.epf 8,11Kb 27 Скачать

См. также

Комментарии
1. Nio Nio (Nio) 55 13.03.13 15:35 Сейчас в теме
А чем отчет стандартный не угодил?
2. Mishgan (BigTaur) 49 13.03.13 17:50 Сейчас в теме
Может я отстал от жизни, но отчет все подряд показывает, а как выбрать только различные я не нашел...
3. Al Ba (bananoed) 9 21.01.16 12:16 Сейчас в теме
Для некоторых прав возникает ошибка при определении родителя. Исправил заключив в Попытку определение родителя.
4. Константин Куликов (Светлый ум) 204 17.03.17 06:11 Сейчас в теме
Еще один вариант отчета, для получения списка пользователей у которых есть: то или иное право:
//приведу код - публиковать пока некогда:

(подойдет и для 4й Альфы и для 5й Альфы)

Процедура КнопкаВыполнитьНажатие(Кнопка)
	
	Выборка = Справочники.Пользователи.Выбрать();
	
	Пока Выборка.Следующий() Цикл
		
		РезультатП1 = обПолучитьПраваИНастройкиПользователя(Выборка.Ссылка);   //Пользователь	
		Пользователь =  Выборка.Ссылка;
		
		//масРодители = Новый Массив(6);
		Для каждого Право из РезультатП1 Цикл
			
			Если Найти(Строка(Право.Ключ), "Запретить продажу ниже себестоимости") Тогда
				
				Если Найти(Строка(Право.Значение), "Нет") Тогда
					
					Сообщить(СокрЛП(Пользователь) + ":  " + Строка(Право.Ключ.Родитель)+"\"+Строка(Право.Ключ) + " -- 1:"+Строка(Право.Значение));
				КонецЕсли;
				
			КонецЕсли; 
			
		КонецЦикла;

		
	КонецЦикла;
	
	Сообщить("Формирование списка окончено!");

		
КонецПроцедуры

...Показать Скрыть
Оставьте свое сообщение