Как ограничить "кривые руки" с полными правами или нужны ли в 1С “супер-права”?

Публикация № 225570

Администрирование - Информационная безопасность

10
Предлагается вариант решения проблемы ограничения прав пользователей с "полными правами" в режиме 1С:Предприятие на доступ к функционалу, имеющему критическое значение для целостности данных и общего функционирования системы.

Верить нельзя никому, даже себе!
...
Против лома нет приема!
...
Для любой хитрой сущности первого рода
есть сущность второго рода с винтом!
….
(три источника, три составных части
развития любой системы безопасности).

 

Описание проблемы:

Часто случается так, что в базе работают пользователи с полными правами, но имеют при этом «кривоватые руки». Иногда это бывают влиятельные «ответственные» лица, имеющие достаточно влияния, чтобы под благовидным предлогом «отжать» себе полные права. При этом отобрать у них полные права назад бывает нереально. Иногда это бывает из-за определенной неразберихи в системе прав,  либо при начальном этапе внедрения, либо обусловленной сложившимися бизнес-процессами.

Не всегда такие пользователи ответственно относятся к своей работе. И хорошо при этом, что они по незнанию не могут натворить ничего плохого в базе. Хуже, когда кто-то из них узнает о потенциально опасных инструментах (вроде групповых обработок) и начинает жать на «Выполнить», не осознавая в полной мере последствий своих действий.

Как правило, полный доступ таким пользователям нужен для того, чтобы, не обращаясь ни к кому, что-нибудь провести, записать в базе или выполнить какую-нибудь обработку не опасного характера. Поэтому для восстановления порядка и гармонии в базе достаточно бывает ограничить доступ к фиксированному списку объектов конфигурации, имеющих критическое значение.

Предлагаемое решение:

К сожалению, в подтверждение к сказанному в эпиграфе к статье, полного и окончательного решения обсуждаемой проблемы нет. Можно предлагать лишь меры частного характера, действующие при определенных условиях и до определенной степени хитрости «сущностей первого рода».

Например, решить озвученную задачу можно методом «умножения»:

1) Создадим второй набор «полных» прав и обзовем его, допустим, роль “SA” (super-administrator).

2) В какой-нибудь удобный общий серверный модуль добавим экспортную функцию
для усиленной проверки полного доступа к базе вроде следующей:

 

// усиленная проверка полного доступа к базе
Функция ДоступПолный_Проверить(UserName = "", НеУчитыватьSA = Ложь) Экспорт
    //для 8.1 функцию нужно поместить в привилегированный модуль
    УстановитьПривилегированныйРежим(Истина); //и убрать эту строку!
    Если ПустаяСтрока(UserName) Тогда
        User = Неопределено;
    Иначе
        User = ПользователиИнформационнойБазы.НайтиПоИмени(UserName);
    КонецЕсли;
    ДоступПолный = ПравоДоступа("Администрирование",Метаданные,User)
    И ПравоДоступа("ОбновлениеКонфигурацииБазыДанных",Метаданные,User)
    И ПравоДоступа("МонопольныйРежим",Метаданные,User)
    И ПравоДоступа("ИнтерактивноеОткрытиеВнешнихОбработок",Метаданные,User);
    Если НеУчитыватьSA <> Истина Тогда
        Если Метаданные.Роли.Найти("SA") <> Неопределено Тогда
            Если User = Неопределено Тогда
                ДоступПолный = ДоступПолный И РольДоступна("SA");
            Иначе
                ДоступПолный = ДоступПолный И User.Роли.Содержит(Метаданные.Роли["SA"]);
            КонецЕсли;
        КонецЕсли;
    КонецЕсли;
    Если Метаданные.Роли.Найти("ПолныеПрава") <> Неопределено Тогда
        Если User = Неопределено Тогда
            ДоступПолный = ДоступПолный И РольДоступна("ПолныеПрава");
        Иначе
            ДоступПолный = ДоступПолный И User.Роли.Содержит(Метаданные.Роли["ПолныеПрава"]);
        КонецЕсли;
    КонецЕсли;
    Возврат ДоступПолный;
КонецФункции


3) С помощью указанной выше функции перед открытием форм или выполнением команд,  имеющих критическое значение, проверяем наличие супер-прав и отказываем в доступе при их отсутствии.


Узкие места предлагаемого решения:

Помимо необходимости внесения изменения в конфигурацию базы, основным недостатком предлагаемого решения является то, что пользователь с «простыми» полными правами может сам себе назначить роль “SA”.

Для этого в 1С есть две стандартных возможности:

  1. Непосредственно в конфигураторе;
  2. Типовые средства управления правами в пользовательском режиме;

Допустим, средствами администрирования операционной системы (через публикацию нужных ярлыков)  в конфигуратор 1С запрещено заходить, кому не следует. Тогда нам остается запретить доступ к роли “SA” через средства управления правами типовой конфигурации.

Для реализации этого запрета нужно исключить набор прав “SA” из списков ролей, предлагаемых для выбора типовыми средствами управления правами. Также нужно исключить обработку роли “SA” в тех местах кода конфигурации, где фактически изменяются права пользователей (чтобы не сбросить доступ к роли “SA”, установленный в конфигураторе).

Сделать это достаточно просто, конкретная реализация зависит от конфигурации базы.
Пример реализации запрета для конфигураций «родственных» УТ-11.1 приведен ниже.


Но это еще не все:
Пользователь с «простыми» полными правами может запустить внешнюю обработку, например, какую-нибудь консоль кода,
и с ее помощью назначить себе нужные права, выполнив простенький код:

ЯЯ = ПользователиИнформационнойБазы.ТекущийПользователь();
//ЯЯ = ПользователиИнформационнойБазы.НайтиПоИмени("Вася");
SA = Метаданные.Роли.SA;
Если НЕ ЯЯ.Роли.Содержит(SA) Тогда
    ЯЯ.Роли.Добавить(SA);
    ЯЯ.Записать();
КонецЕсли;

Чтобы заткнуть эту дырку, потребуется подрезать «простые»  полные права:

  1. Запретить для "простых" полных прав запуск внешних отчетов и обработо;
  2. Также запретить публикацию внешних отчетов и обработок в справочнике «Дополнительные отчеты и обработки»;


Но и это еще не все (и продолжать можно до бесконечности):

Как верно подсказывает Stim213  в  //infostart.ru/public/182849/, продвинутый ушлый пользователь может с помощью блокнота вставить указанный выше код в нужное место файла выгрузки данных (например, в текст кода обработчика “Перед загрузкой данных”). А затем при загрузке данных из файла в информационную базу получить себе нужные права.


Работающий пример реализации запрета доступа к роли
SA:

Конфигурация «Управление торговлей, релиз 11.1.9.70» (версия БСП: 2.2.3.44).
Права пользователям задаются в  профилях безопасности.

Для запрета доступа к роли “SA” типовыми средствами нужно сделать несколько вставок (выделены авторскими комментариями //+yuraos ) в следующие места исполняемого кода конфигурации:


Общий модуль «ПользователиСлужебный»:

 

Процедура ПодготовитьДеревоРолей(Знач Коллекция, Знач СкрытьРольПолныеПрава, Знач ПоказатьТолькоВыбранныеРоли, КоллекцияРолей)
    Индекс = Коллекция.Количество()-1;
    Пока Индекс >= 0 Цикл
        Строка = Коллекция[Индекс];
        ПодготовитьДеревоРолей(Строка.Строки, СкрытьРольПолныеПрава, ПоказатьТолькоВыбранныеРоли, КоллекцияРолей);
        Если Строка.ЭтоРоль Тогда
            Если СкрытьРольПолныеПрава
               И (    ВРег(Строка.Имя) = ВРег("ПолныеПрава")
                  ИЛИ ВРег(Строка.Имя) = ВРег("АдминистраторСистемы")) Тогда
                Коллекция.Удалить(Индекс);
            Иначе
                //+yuraos
                Если СкрытьРольПолныеПрава И (ВРег(СокрЛП(Строка.Имя)) = "SA") Тогда
                // роль SA выставляем персонально каждому в конфигураторе
                    Коллекция.Удалить(Индекс);
                    Индекс = Индекс-1;
                    Продолжить;
                КонецЕсли;
                //+yuraos
                Строка.НомерКартинки = 7;
                Строка.Пометка = КоллекцияРолей.НайтиСтроки(
                                    Новый Структура("Роль", Строка.Имя)).Количество() > 0;
                Если ПоказатьТолькоВыбранныеРоли И НЕ Строка.Пометка Тогда
                    Коллекция.Удалить(Индекс);
                КонецЕсли;
            КонецЕсли;
        Иначе
            Если Строка.Строки.Количество() = 0 Тогда
                Коллекция.Удалить(Индекс);
            Иначе
                Строка.НомерКартинки = 6;
                Строка.Пометка = Строка.Строки.НайтиСтроки(
                                    Новый Структура("Пометка", Ложь)).Количество() = 0;
            КонецЕсли;
        КонецЕсли;
        Индекс = Индекс-1;
    КонецЦикла;
КонецПроцедуры

Процедура ОбновитьРолиВнешнихПользователей(Знач МассивВнешнихПользователей = Неопределено) Экспорт
    //*****
        Выборка = Запрос.Выполнить().Выбрать();
        ПользовательИБ = Неопределено;
        Пока Выборка.Следующий() Цикл
            //+yuraos
            Если ВРег(СокрЛП(Выборка.Роль)) = "SA" Тогда
                // роль SA выставляем персонально каждому в конфигураторе
                Продолжить;
            КонецЕсли;
            //+yuraos
            Если ЗначениеЗаполнено(Выборка.Роль) Тогда
                            ПользовательИБ.Роли.Добавить(Метаданные.Роли[Выборка.Роль]);
                Продолжить;
            КонецЕсли;
            Если ПользовательИБ <> Неопределено Тогда
                ПользовательИБ.Записать();
            КонецЕсли;
            ПользовательИБ = ПользователиИнформационнойБазы.НайтиПоУникальномуИдентификатор(ИдентификаторыПользователейИБ[Выборка.ВнешнийПользователь]);
            ПользовательИБ.Роли.Очистить();
        КонецЦикла;
        Если ПользовательИБ <> Неопределено Тогда
            ПользовательИБ.Записать();
        КонецЕсли;
    //*****
КонецПроцедуры



Общий модуль «УправлениеДоступомСлужебный»:

 

Процедура ОбновитьРолиПользователейИБ(ОбновляемыеПользователиИБ, ПарольПользователяСервиса)
    Для каждого КлючИЗначение Из ОбновляемыеПользователиИБ Цикл
        РолиДляДобавления  = КлючИЗначение.Значение.РолиДляДобавления;
        РолиДляУдаления    = КлючИЗначение.Значение.РолиДляУдаления;
        ПользовательИБ     = КлючИЗначение.Значение.ПользовательИБ;
        ПользовательСсылка = КлючИЗначение.Значение.ПользовательСсылка;
        БылиПолныеПрава = ПользовательИБ.Роли.Содержит(Метаданные.Роли.ПолныеПрава);
        Для каждого КлючИЗначение Из РолиДляДобавления Цикл
            //+yuraos
            Если ВРег(СокрЛП(КлючИЗначение.Ключ)) = "SA" Тогда
                // роль SA выставляем персонально каждому в конфигураторе
                Продолжить;
            КонецЕсли;
            //+yuraos
            ПользовательИБ.Роли.Добавить(Метаданные.Роли[КлючИЗначение.Ключ]);
        КонецЦикла;
        Для каждого КлючИЗначение Из РолиДляУдаления Цикл
            //+yuraos
            Если ВРег(СокрЛП(КлючИЗначение.Ключ)) = "SA" Тогда
                // роль SA выставляем персонально каждому в конфигураторе
                Продолжить;
            КонецЕсли;
            //+yuraos
            ПользовательИБ.Роли.Удалить(Метаданные.Роли[КлючИЗначение.Ключ]);
        КонецЦикла;
        ЗаписатьПользователяПриОбновленииРолей(ПользовательСсылка, ПользовательИБ, БылиПолныеПрава, ПарольПользователяСервиса);
    КонецЦикла;
КонецПроцедуры



10

Специальные предложения

Достаточна ли система безопасности в 1С:Предприятие - 8.х


К системе разрешений не хватает запрета доступа (46.67%, 14 голосов)
46.67%
Достаточна (43.33%, 13 голосов)
43.33%
Не хватает встроенных ролей безопасности (20%, 6 голосов)
20%

Комментарии
Избранное Подписка Сортировка: Древо
1. yuraos 958 01.11.13 05:42 Сейчас в теме
И так, достаточна ли система безопасности, имеющаяся в 1С?
Чего только в платформе не придумали за последнее время.

Например под 8.3 для каждого минорного релиза
(отличающегося третьей цифрой) придуман свой режим совместимости.

А до такой простой вещи как встроенные роли безопасности,
давно имеющиеся в развитых многопользовательских системах,
как-то руки не доходят.

Также кроме системы разрешений, явно не хватает запрета доступа.
14. yuraos 958 01.11.13 13:38 Сейчас в теме
(1)
---
Отсутствие встроенных ролей безовасности,
кстати,
приводит к небольшому неудобсту при создании пустой конфигурации с нуля.

Пока в конфигурации не создашь роль "ПолныеПрава" (или ей аналогичную)
- ты не можешь создать в базе пользователя.
было бы проще если при этом были бы встроенные роли, доступные для выбора.
---
ну хотя примерно как в MS SQL
2. Synoecium 666 01.11.13 06:30 Сейчас в теме
А может просто назвать профиль "Полные права", накидать туда ролей - стандартных и самописных(если надо), но не давать роль "ПолныеПрава". Тогда не надо будет дописывать никакой код в конфигурацию.
4. ChiginAV 01.11.13 07:53 Сейчас в теме
(2) Synoecium, А если пользователь захочет изменять данные в закрытом периоде?
13. yuraos 958 01.11.13 12:17 Сейчас в теме
(4) ChiginAV,
Речь идет не о широком ограничении доступа.
Раз пользователи отжали себе "полные права" и назад их не отдают - это бесмысленно.

(2) Synoecium,
эту стуацию по этой же причине трудно регулировать и профилями безопасности.

Просто иногда возникает необходимость выборочно закрыть доступ
к ряду опасных инструментов в базе
(типовых, а по большей частью - не типовых)
позволяющим допустим в массовом порядке удалять данные.
3. ChiginAV 01.11.13 07:51 Сейчас в теме
Если "сделать типовые «полные права» чуть менее полными, убрав доступ..." (пункт 4), то зачем 2 и 3? Просто поснимать нужные галки, раз уж "Полные права" и так станут не типовыми
7. Synoecium 666 01.11.13 08:06 Сейчас в теме
(3) ChiginAV, Есть же "Установка даты запрета изменения данных", где можно отдельным пользователям или группам пользователей установить дату запрета.
KEV8383; ChiginAV; +2 Ответить
9. kovaleks78 3 01.11.13 08:08 Сейчас в теме
(7) Synoecium, да, но это не запрещает редактировать справочники.
10. Synoecium 666 01.11.13 08:10 Сейчас в теме
(9) kovaleks78, А как справочники относятся к закрытым периодам? Идем в пункт (2) и ролями настраиваем.
12. kovaleks78 3 01.11.13 08:33 Сейчас в теме
(10) Synoecium, да никак не относятся. Я и говорю, что это не поможет. Для такого руководителя проще всего создать роль, где почти на все доступ на чтение и просмотр. и выдавать ему такую роль.
22. rus128 2 06.11.13 16:16 Сейчас в теме
(7)Synoecium, все бы хорошо, но типовой механизм "Установка даты запрета изменения данных" в нашем УПП 1.3 работает только для тех пользователей, которые в нем перечислены, а для всех остальных - не работает.
Прикольно, когда обнаруживается, что новый юзер, принятый на работу на прошлой неделе, начудил что-то в якобы давно и надежно закрытом периоде...
23. yuraos 958 06.11.13 17:39 Сейчас в теме
(22) rus128,
еще один повод, что бы тем или иным способом
выборочно блокировать потенциально опасные сервисы.
25. Synoecium 666 07.11.13 08:57 Сейчас в теме
(22) rus128, а вы пробовали ввести дату запрета в ячейку напротив корня дерева пользователей, напротив "Общая дата". Насколько я помню, там система приоритетов: Если пользователь не ограничен по группе или отдельно, то действует общая дата запрета (приоритет 3), если по группе - приоритет 2, отдельно - приоритет 1. Получается работает ограничение с наименьшим по значению приоритетом.
27. rus128 2 07.11.13 12:50 Сейчас в теме
(25) Пробовали, но у нас получилось именно так, как я описал выше: пользователь, не указанный в списке, спокойно обошел и общую дату, и дату ограничения по организации (на 2-й закладке).
УПП для Украины 1.3.
5. kovaleks78 3 01.11.13 07:56 Сейчас в теме
Таким руководителям обычно делаю права на просмотр всего-всего без права изменения. Обычно их это устраивает.
6. ChiginAV 01.11.13 08:04 Сейчас в теме
(5) kovaleks78, Вот, кстати, еще один прокол 1С. В типовых УПП, КА, БП (в других не знаю) нет роли "Полный просмотр" (например для аудиторов). Приходится делать самому
mikmike; yuraos; +2 Ответить
8. kovaleks78 3 01.11.13 08:07 Сейчас в теме
(6) ChiginAV, если все будет сразу готово, нам работы не будет! :))))
1С заботится о нас, чтобы армия программистов по всей россии с голоду не умерла. Государство тоже постоянно о нас заботится.
31. fixin 3893 29.04.16 12:54 Сейчас в теме
(6) аудиторам можно сливать копию, как вариант.
15. yuraos 958 01.11.13 15:17 Сейчас в теме
(5) kovaleks78,
предыстория этой статьи:

мне пришлось без особого удовольствия заняться доработкой базы,
где сидит блатная бухгалтерша.

Она не совсем понимает:
1. что перед тем как списать шины со склада
- туда сначала их надо как-то оприходовать.
2. что автомобильный прицеп или грузовик - вряд ли могут быть подразделением организации.

Зато она узнала откуда-то, что-такое групповая обработка документов
и творит ей чудеса (а виноват IT-отдел :) )

---
Я решил добавить в базу ряд своих примочек для комфортной работы (не для кривых рук!)...
... вот и пришлось выдумать SuperAdmin-а, чтобы перекрыть ей к ним доступ.
16. kovaleks78 3 02.11.13 06:18 Сейчас в теме
(15) надо дописать логирование того, что делает бухгалтерша групповой обработкой, чтобы потом можно было тыкать ее носом туда. Иначе ит-отдел так и будет всегда виноват.
vbuots; yuraos; +2 Ответить
18. yuraos 958 03.11.13 09:05 Сейчас в теме
(16) kovaleks78,
1. Вообще-то 1С-8.х и так по умолчанию все пишет в журнал регистрации.
Это в 7.7 можно было "без палева"
обработкой что-нибудь грохнуть или перепровести.

2. Такого типа люди привыкли сами других носом всех тыкать
так-что IT-отдел по любому "Виновен !".


11. straus 01.11.13 08:30 Сейчас в теме
Не понятно, почему "отобрать у них полные права назад бывает не реально", а "сделать типовые «полные права» чуть менее полными, убрав доступ к административным функциям и запуск внешних обработок" вполне возможно и подобные пользователи "проглатывают" это.
17. Borisych 495 02.11.13 17:00 Сейчас в теме
я для хитрых ограничений и проверок доступа использую подписки на события и например, РС или добавленную ТЧ в справочнике "Пользователи"
19. yuraos 958 03.11.13 09:08 Сейчас в теме
(17) Borisych,

и например, РС или добавленную ТЧ в справочнике "Пользователи"

можно пояснить ???
21. Borisych 495 05.11.13 12:15 Сейчас в теме
(19) например,
некоторым пользователям отрезаны некоторые счета хозрасчетного в БП 2.0 - для этого существует регистр сведений "недоступные для пользователя счета хозрасчетный" - с двумя измерениями - пользователь и счет;

на план счетов хозрасчетный наложен RLS - в котором пользователь может увидеть лишь те счета, записей по которым нет в регистре сведений по текущему пользователю, т.о. пользователь никаким образом - ни в оборотках, ни ещё где-либо не увидит (цель - 70 счет) обороты по 70-му счету и документы, в которых задействован 70-й счет.

В данной конкретной задачи также созданы дополнительные роли - "Бухгалтер с ограничением доступа к зарплатным документам" и "Доступ к зарплатным документам", которые решают поставленные задачи
24. artbear 1171 06.11.13 19:25 Сейчас в теме
(21) >>на план счетов хозрасчетный наложен RLS
этого совершенно недостаточно для безопасности :(
Если у пользователя есть возможность формировать карточку счета, взаимодействующего с "запрещенным" счетом (например, 44, 71, 26, 20 взаимодействуют с 70 счетом), то он в карточке легко увидит все движения и аналитику - например, для 70 счета будет написано "Объект не найден", а вот субконто и суммы будут легко видны, т.е. легко увидеть зарплату других сотрудниеков.
в итоге никакой безопасности.
26. Synoecium 666 07.11.13 08:59 Сейчас в теме
(24) artbear, есть настройка в системе, которая убирает субконто у 70 счета. По крайней мере в УПП.
29. artbear 1171 15.11.13 10:17 Сейчас в теме
(26) Synoecium, "настройка, которая убирает субконто по 70 счету"
Бухам это принесет огромную радость, 70 счет без расшифровки :(
Как правило, бухи активно работают именно с аналитикой по счетам
30. Synoecium 666 15.11.13 17:42 Сейчас в теме
(29) artbear, Сдаюсь, система прав в 1с действительно отстой)
Но может мои комментарии кому-нибудь облегчат работу, когда он будет ковыряться с правами.
20. awk 694 04.11.13 01:38 Сейчас в теме
(0) В 1С никогда не было и наверное уже никогда не будет безопасности. Все РЛС и роли это забавные тормозистры, который предназначен только для одной цели: снять денег с клиента.
28. automatizator 291 07.11.13 15:01 Сейчас в теме
Когда есть "права" на полные права.

В случае серьезного инцидента запускаем следующий механизм:

Картинно всех выводим из базы.
Восстанавливаем последнюю резервную копию. (У вас же есть резервная копия?)
Предлагаем вручную восстановить актуальность до текущего момента.


Это лучше в плане воспитания "правомочных". А то куда еще залезут в будущем...
Оставьте свое сообщение

См. также

Права пользователя исключительно на просмотр (чтение) для УТ 11.4 35

Статья Программист Нет файла v8 v8::Права УТ11 Россия Бесплатно (free) Роли и права

Простая и понятная инструкция по шагам для создания профиля группы доступа «Только чтение» для УТ 11.4. Выполняется в режиме пользователя, без использования конфигуратора и снятия базы с поддержки.

21.11.2019    2567    Aleksandr55555    4       

Подборка решений для взаимодействия со ФГИС «Меркурий» Промо

С 1 июля 2019 года все компании, участвующие в обороте товаров животного происхождения, должны перейти на электронную ветеринарную сертификацию (ЭВС) через ФГИС «Меркурий». Инфостарт предлагает подборку программ, связанных с этим изменением.

Типичные ошибки при разработке прав доступа 109

Статья Программист Нет файла v8 v8::Права Бесплатно (free) Роли и права

Рассмотрим самые распространенные ошибки в разработке прав доступа.

02.10.2019    9013    YPermitin    45       

Проверка наличия роли у пользователя 4

Статья Программист Нет файла v8 v8::Права 1cv8.cf Бесплатно (free) Роли и права

Допустим, мы добавили новую роль в конфигурацию. Потом добавили её в профиль группы доступа и назначили соответствующую группу доступа пользователю. Однако, в конфигурациях на основе БСП все известные программные проверки данной роли при включении пользователя в предопределенную группу доступа "Администраторы" не работают. В статье приведено решение данной задачи.

29.06.2019    5756    ni_cola    8       

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

Назад в прошлое! Небольшие заметки по администрированию пользователей в УПП 74

Статья Системный администратор Программист Стажер Нет файла v8 УПП1 Бесплатно (free) Роли и права

Небольшие заметки по функционалу "Администрирование пользователей" конфигурации "Управление производственным предприятием" версии 1.3. Затрагиваются такие темы как: роли, профили доступа, дополнительные права, настройки пользователей и ограничения доступа на уровне записей (RLS).

06.06.2019    8669    YPermitin    18       

Подсистема БСП «Управление доступом», основные объекты и регистры 113

Статья Программист Нет файла v8 v8::УФ v8::Права 1cv8.cf Бесплатно (free) БСП (Библиотека стандартных подсистем) Роли и права

Основные принципы работы подсистемы «Управление доступом» из состава БСП. Виды доступа, ограничение доступа на уровне записей. Описание основных объектов и регистров, используемых подсистемой.

23.05.2019    12235    ids79    8       

Программы для исполнения 488-ФЗ: Маркировка товаров Промо

1 января 2019 года вступил в силу ФЗ от 25.12.2018 № 488-ФЗ о единой информационной системе маркировки товаров с использованием контрольных (идентификационных) знаков, который позволяет проследить движение товара от производителя до конечного потребителя. Инфостарт предлагает подборку программ, связанных с применением 488-ФЗ и маркировкой товаров.

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS) 178

Статья Программист Нет файла v8 v8::Права Бесплатно (free) Практика программирования БСП (Библиотека стандартных подсистем) Роли и права

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    22002    ids79    9       

Влияние настройки роли на потребление памяти 152

Статья Системный администратор Программист Нет файла v8::Права 1cv8.cf Бесплатно (free) Роли и права

На днях разбирался с проблемой с потреблением памяти процессами конфигуратора и rphost. Как оказалось - причина в настройках ролей. Один поворот не туда, и настройки роли приводят к чрезмерному потреблению оперативки.

29.01.2019    10691    mickey.1cx    14       

22 января состоится вебинар "Использование технологии блокчейн в 1С" Промо

На вебинаре вы узнаете как использовать современную технологию блокчейн при проектировании и создании учетных систем, почему эту технологию следует рассматривать как одну из базовых. Ведущий Михаил Калимулин поделится своими знаниями основ технологии и опытом внедрения.

990 рублей

Использование утилиты ring для выяснения данных о программных лицензиях 34

Статья Системный администратор Программист Нет файла v8 Windows Бесплатно (free) Информационная безопасность

Использование утилиты ring для управления программными лицензиями без ее установки на компьютер пользователя.

22.12.2018    7255    Vovan58    20       

Доработка RLS для УНФ 33

Статья Программист Нет файла v8::Права 1cv8.cf Бесплатно (free) Информационная безопасность

Инструкция для тех, кто столкнулся с RLS на управляемых формах впервые и не знает, с чего начать.

14.05.2018    11997    FesenkoA    6       

1C:Предприятие для программистов: Запросы и отчеты. Второй поток. Онлайн-интенсив с 17 марта по 16 апреля 2020 г. Промо

Данный онлайн-курс предусматривает углубленное изучение языка запросов и возможностей системы компоновки данных, которые понадобятся при разработке отчетов, работающих на платформе “1С:Предприятие” в рамках различных прикладных решений. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей различных прикладных решений, которые используют в своей работе отчеты разного назначения.

6500 рублей

Решение проблемы автоматического утверждения расчета кадровиком документов. Разграничение прав кадровиков и расчетчиков. ЗУП 3.1 28

Статья Программист Нет файла v8 v8::СПР v8::Права ЗУП3.x БУ Зарплата Управление персоналом (HRM) Бесплатно (free) Информационная безопасность

Статья посвящена тем, кто столкнулся с проблемой автоматической установки "Расчет утвердил". Также рассматривается решение проблемы с отображением ФОТ и оклада у кадровика. Добавление роли ЧтениеДанныхДляНачисленияЗарплатыРасширенная кадровику без последствий для расчетчика.

04.04.2018    17358    leaderonex    22       

Проверка безопасности установленных паролей 6

Статья Системный администратор Нет файла v8 Бесплатно (free) Информационная безопасность

Код выводит не установленные пароли, а так же очень простые (1, 123) пароли пользователей. Список можно пополнять.

08.03.2018    7955    nomadon    12       

Перенос данных КА 1.1 / УПП 1.3 => БП 3.0 (перенос остатков, документов и справочников из "1С:Комплексная автоматизация 1.1" / УПП 1.3 в "1С:Бухгалтерия 3.0"). Обновлен до версий КА 1.1.115.х, УПП 1.3.130.х! Промо

Разработка позволяет перенести остатки по всем счетам бух.учета в программу "1С:Бухгалтерия предприятия 8", ред. 3.0 на выбранную дату начала ведения учета. Также переносятся документы за период и вся необходимая справочная информация. Правила оперативно обновляю при выходе новых релизов. Рассылка обновлений правил бесплатно в течение 12 месяцев. Есть видеодемонстрация проведения переноса данных. Конфигурации при использовании обмена остаются полностью типовыми. Перенос данных возможен в Бухгалтерию 3.0 версии ПРОФ, КОРП или базовую.

24700 руб.

Информирование об утечке базы 1С 23

Статья Системный администратор Нет файла v8 1cv8.cf Windows Бесплатно (free) Информационная безопасность

Когда работаешь в крупном холдинге, количество сотрудников, имеющих доступ к базам 1С неизменно растет. Рано или поздно появится задача по контролю утечки баз 1С. Конечно мы применим все меры по предотвращению утечки баз, но и информирование о случаях утечки тоже не повредит.

03.03.2018    11912    dima_home    79       

Отключаем предупреждения безопасности в 1С 8.3.9 и выше вручную 22

Статья Системный администратор Нет файла v8 v8::УФ v8::Права 1cv8.cf Бесплатно (free) Информационная безопасность

Как включить/выключить механизм защиты от опасных действий реализованный в новой версии платформы 1С:Предприятие 8.3.9. Одним из нововведений новой версии платформы 1С:Предприятие 8.3.9 стал механизм от опасных действий. После установки новой версии платформы 1С (начиная версии 8.3.9.2033) при попытке открыть внешнюю обработку или расширение программа выдает сообщение..

01.11.2017    31991    webresurs    10       

INFOSTART MEETUP Kazan. 13 марта 2020 г. Промо

Инфостарт продолжает путешествие по России. Следующая остановка - Казань. Тема мероприятия - управление и технологии автоматизации учета на платформе "1С: Предприятие". Ждем всех: докладчиков и участников! Стоимость участия - 5 500 рублей. Цена действительна до 30.01.2020

5 500

Управление доступом: роли, права, профили, группы доступа, функциональные опции, RLS 241

Статья Системный администратор Программист Нет файла v8::Права Бесплатно (free) Роли и права

В 1С достаточно много механизмов, отвечающих за доступ к данным. Группы доступа, профили групп доступа, роли, права доступа, функциональные опции, RLS. Иногда сложно сразу понять, зачем все это нужно, как эти элементы друг с другом связаны и как ими пользоваться.

11.10.2017    73329    ekaruk    14       

Многофакторная авторизация. Шаблон проектирования для «1С:Предприятие 8». На примере API «Приватбанка» для юр. лиц 10

Статья Программист Нет файла v8 Бесплатно (free) Информационная безопасность Обмен с банком

Многим из читателей знакомы понятия стандартов разработки и шаблонов проектирования. Для платформы «1С:Предприятие 8» на сайте its.1c.ru описаны базовые стандарты оформления кода и некоторые полезные примеры, но отсутствует информация об высокоуровневых абстракциях. Почти у каждого банка есть реализация обмена с конфигурациями «1С:Предприятие 8», но анализировать код, а тем более реализацию без слёз невозможно. Данная статья предлагает использовать некий шаблон оформления кода для многофакторной авторизации.

11.09.2017    11019    pbazeliuk    6       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

Как создать свой профиль доступа в пользовательском режиме в 1С:Бухгалтерии 3.0 13

Статья Системный администратор Программист Нет файла v8 БП3.0 Россия Бесплатно (free) Информационная безопасность

Допустим, есть следующая задача. Нужно добавить нового пользователя «Анна» в базу 1С:Бухгалтерия 3.0. При этом Анна должна только выставлять и распечатывать Счета на оплату. При этом все остальные документы и справочники только для просмотра. Т.е. добавлять новую номенклатуру и контрагентов она не может. Обязательное условие - не изменять типовую конфигурацию.

06.09.2017    13823    alfanika    3       

Копирование групп доступа между пользователями 5

Статья Программист Нет файла v8 УТ11 Бесплатно (free) Информационная безопасность

Доработки, позволяющие переносить группы доступа между пользователями. Подходит для Управление торговлей для Украины, редакция 3.1, Управление торговлей, редакция 11.1 и, я думаю, для других конфигураций, написанных на базе БСП.

03.09.2017    7830    Pervuy    0       

Базовый курс для начинающих 1С-программистов. Пятый поток. Онлайн-курс с 12 февраля по 15 апреля 2020 г. Промо

Данный онлайн-курс является начальной ступенью по изучению базовых принципов программирования в системе “1С:Предприятие” и предназначен для обучения 1С-программированию “с нуля”.

4500/9500 рублей

1001-й способ ограничить пользователей 1С 8

Статья Программист Внешняя обработка (ert,epf) v8 v8::Права Розница Бесплатно (free) Информационная безопасность

Описан еще один способ ограничить пользователя 1С, при помощи подписки на события

13.07.2017    12372    donpadlo    39       

Этюды по программированию. Разграничение прав 16

Статья Программист Нет файла v8 Бесплатно (free) Информационная безопасность

Задача: Имеется конфигурация на базе Библиотеки Стандартных Подсистем(БСП) -практически любая стандартная конфигурация 1С. Есть, к примеры заказы покупателей. Есть группы менеджеров, каждая из которых должна иметь доступ только к заказам своей группы.

29.04.2017    12905    milkers    8       

INFOSTART MEETUP Krasnodar. 14 февраля 2020 г. Промо

Краснодар станет первым в 2020 году местом, где пройдет региональная встреча IT-специалистов сообщества Инфостарт. Тема мероприятия - управление и технологии автоматизации учета на платформе "1С: Предприятие". Стоимость участия - 5000 рублей. Цена действительна до 26.12.2019.

Недостаточно прав доступа или опять забыли дать права на новые объекты 198

Статья Программист Нет файла v8 Бесплатно (free) Информационная безопасность

При постоянной доработке конфигураций в больших коллективах иногда возникает ситуация, когда программист поместил новые объекты в базу, а права на них дать забыл. При этом обновлять базу не позволяет бизнес. Что же делать? Есть небольшая хитрость.

06.04.2017    25206    Silenser    55       

Права доступа в 1С:Документооборот 2.1 42

Статья Системный администратор Программист Нет файла v8 ДО Документооборот и делопроизводство Бесплатно (free) Информационная безопасность

В программе 1С:Документооборот ред 2.1 механизм системы прав доступа сильно изменился. С одной стороны, права доступа в данной версии стали проще и быстрее, с другой стороны - права по рабочим группам объектов теперь могут противоречить политикам доступа. Разберемся в данной статье как работает механизм прав доступа в 1с документообороте 2.1.

16.09.2016    61196    vlush78    0       

Онлайн-курс "Подготовка к экзамену 1С:Эксперт и 1С:Профессионал по технологическим вопросам" с 7 по 24 апреля 2020 г. Промо

На курсе вы получите практические навыки решения задач производительности 1С, в том числе характерных для высоконагруженных информационных систем (более 1000 пользователей). Подготовка к экзамену – только одна из составляющих курса. 70% слушателей приходят за знаниями, которые позволят расти и зарабатывать, делать сложные задачи на крупных проектах.

16450 рублей

Генерация паролей 1С 8.3 (код, инструкция) 26

Статья Программист Нет файла v8 Windows Бесплатно (free) Практика программирования Информационная безопасность

Инструкция по самостоятельному написанию генерации пароля в 8.3. Может кому-нибудь пригодится, т.к. весь материал на ИС за монетку а делать-то на самом деле нечего

22.07.2016    15856    Tomy82    18       

ubuntu + 1Cv8. Как правильно задать права доступа к базе в терминальном режиме 19

Статья Системный администратор Программист Нет файла v8 Linux Бесплатно (free) Информационная безопасность

Очень часто возникает проблема с установкой прав доступа в Linux. Один пользователь заходит в базу 1С нормально, а вот второго уже не пускает. Решение проблемы очень простое.

30.03.2016    18054    viptextil    14       

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

Готовим конфигурацию "Бухгалтерия предприятия 3.0" к аудиторской проверке 4

Статья Программист Нет файла v8 БП2.0 Россия Windows Бесплатно (free) Информационная безопасность

Бывают такие ситуации, что, предоставляя данные для аудиторской проверки, мы переживаем, как бы проверяющие не узнали чего лишнего. В этой статье я расскажу, как скрыть документы и ограничить отчеты по периоду на примере конфигурации "Бухгалтерия предприятия 3.0"

21.03.2016    9211    duhh    14       

Ограничение доступа к справочнику Склады для УТ 10.3 10

Статья Системный администратор Нет файла v8 УТ10 Россия Windows Бесплатно (free) Информационная безопасность

Краткая инструкция простого метода, как ограничить видимость складов для определенных пользователей в УТ 10.3.

25.12.2015    16507    Viktor_Ermakov    8