KLADR: Ввод адреса по классификатору адресов КЛАДР (ExtDb для 8.3) управляемые формы

Публикация № 358219

Разработка - Печать - Классификаторы

Кладр 8.3

8
За основу была взята публикация http://infostart.ru/public/189714/
Всё новое - это хорошо забытое старое! Представляю оригинальную версию обработки для ввода адреса из КЛАДР в конфигурациях 8.3 (управляемые формы) без использования типового регистра сведений «Адресный классификатор». Как многим известно, в замечательной программе «1С: Бухгалтерия 7.7» ввод адресов производится из внешних DBF-файлов, свободно скачиваемых с сайта ФНС или диска ИТС в каталог ExtDb рабочей базы. С помощью данной обработки вы сможете легко подключить и обновлять внешний КЛАДР для неограниченного количества своих баз меньше чем за одну минуту.

За основу была взята публикация //infostart.ru/public/189714/ , т. к. автор в свое время писал

9. Chastiser 25.03.2014 08:51

(8) Спасибо. На управляемых формах делать пока нет надобности. Тут показан только сам подход, а оформление каждый сам доработает под себя при желании.
 
Решил сделать на управляемых формах.
Из небольших доработок:
1) весь подбор осуществляется в одной форме;
2) плюс автоматический фильтр по первым символам при подборе во всех строках классификатора;
3) по умолчанию при открытии регион Тульская область, город Тула.


8

Скачать файлы

Наименование Файл Версия Размер
Кладр
.epf 16,50Kb
29.05.15
35
.epf 1 16,50Kb 35 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. CeHbKA 253 11.06.15 15:10 Сейчас в теме
Не работает обработка - ругается на отсутствующие функции "НомерПоВиду" и "НомерДомаВИнтервале"
2. гыук320 17 16.06.15 11:16 Сейчас в теме
(1) CeHbKA, Спасибо за комментарий. Обработка относительно старая и забыл что кусок вынес в общий модуль (а перед публикацией проверял как раз на базе где он есть):


// Функция возвращает представление адреса собранного из полей значений Поле1..Поле9
Функция ПолучитьПредставлениеАдреса(Запись) Экспорт
	ТекПредставление = "";
	Если СокрЛП(Запись.Поле1) <> "" Тогда
		ТекПредставление = ТекПредставление + ", " + СокрЛП(Запись.Поле1);
	КонецЕсли;
	Если СокрЛП(Запись.Поле2) <> "" Тогда
		ТекПредставление = ТекПредставление + ", " + СокрЛП(Запись.Поле2);
	КонецЕсли;
	Если СокрЛП(Запись.Поле3) <> "" Тогда
		ТекПредставление = ТекПредставление + ", " + СокрЛП(Запись.Поле3);
	КонецЕсли;
	Если СокрЛП(Запись.Поле4) <> "" Тогда
		ТекПредставление = ТекПредставление + ", " + СокрЛП(Запись.Поле4);
	КонецЕсли;
	Если СокрЛП(Запись.Поле5) <> "" Тогда
		ТекПредставление = ТекПредставление + ", " + СокрЛП(Запись.Поле5);
	КонецЕсли;
	Если СокрЛП(Запись.Поле6) <> "" Тогда
		ТекПредставление = ТекПредставление + ", " + СокрЛП(Запись.Поле6);
	КонецЕсли;
	Если СокрЛП(Запись.Поле7) <> "" Тогда
		ТекПредставление = ТекПредставление + ", д. " + СокрЛП(Запись.Поле7);
	КонецЕсли;
	Если СокрЛП(Запись.Поле8) <> "" Тогда
		ТекПредставление = ТекПредставление + ", кор. " + СокрЛП(Запись.Поле8);
	КонецЕсли;
	Если СокрЛП(Запись.Поле9) <> "" Тогда
		ТекПредставление = ТекПредставление + ", кв. " + СокрЛП(Запись.Поле9);
	КонецЕсли;
	Если СтрДлина(ТекПредставление) > 2 Тогда
		ТекПредставление = Сред(ТекПредставление, 3);
	КонецЕсли;
	Возврат ТекПредставление;
КонецФункции

// Функция возвращает строковое представление адреса (в формате через запятую), включая незаполненные поля
Функция ПолучитьПолныйАдрес(Запись) Экспорт
	//Результат = "," + 
	//СокрЛП(Запись.Поле1) + ", " +
	//СокрЛП(Запись.Поле2) + ", " +
	//СокрЛП(Запись.Поле3) + ", " +
	//СокрЛП(Запись.Поле4) + ", " +
	//СокрЛП(Запись.Поле5) + ", " +
	//СокрЛП(Запись.Поле6) + ", " +
	//СокрЛП(Запись.Поле7) + ", " +
	//СокрЛП(Запись.Поле8) + ", " +
	//СокрЛП(Запись.Поле9);
	//Если ПустаяСтрока(СтрЗаменить(Результат,",","")) Тогда Результат="" КонецЕсли;
	//Возврат Результат;
КонецФункции

Функция ВидПоНомеру(Ном) Экспорт
	//Возврат ?(Ном=0, "Регион", ?(Ном=1, "Район", ?(Ном=2, "Город", ?(Ном=3, "НасПункт", ?(Ном=4, "Улица", "Дом")))));
КонецФункции

Функция НомерПоВиду(Вид) Экспорт
	Возврат ?(Вид="Регион", 0, ?(Вид="Район", 1, ?(Вид="Город", 2, ?(Вид="НасПункт", 3, ?(Вид="Улица", 4, 5)))));
КонецФункции

// Служебная функция, предназначенная для получения описания типов строки, заданной длины.
// 
// Параметры:
//  ДлинаСтроки - число, длина строки.
//
// Возвращаемое значение:
//  Объект "ОписаниеТипов" для строки указанной длины.
//
Функция ПолучитьОписаниеТиповСтроки(ДлинаСтроки) Экспорт
	//Массив = Новый Массив; 
	//Массив.Добавить(Тип("Строка"));
	//КвалификаторСтроки = Новый КвалификаторыСтроки(ДлинаСтроки, ДопустимаяДлина.Переменная);
	//Возврат Новый ОписаниеТипов(Массив, , КвалификаторСтроки);
КонецФункции


// Функция определяет входимость числа в заданный диапазон
//  При этом диапазон задается как это описано в комментарии к функции ЧислоВИнтервале
//
// Параметры: 
//    Номер              - (число, строка) номер дома с корпусом
//    Интервал           - (строка), интервал чисел (домов)
//    ТочноеСоответствие - (булево) номер дома должен точно соответствовать номеру в интервале
//                         или допускается наличие дробей и произвольных букв после номера дома
//
// Возвращаемое значение:
//    Истина - если заданное число входит в диапазон,
//    Ложь   - если не входит
//
Функция ВходитВИнтервал(Знач Номер, Интервал, ТочноеСоответствие) 
	
	
КонецФункции

// Функция определяет входимость:
//  1. Номера дома (представленного в виде строки)
//     где Номер дома, это строка вида:
//     <СтрокаДом> пример: 58А, 32/1, 50А/8
//
//  2. Номера дома и номера корпуса (строения), в виде строки:
//     <СтрокаДом>к<СтрокаКорпус>,   пример: 32к1   это дом 32 корпус 1, 
//     <СтрокаДом>/<СтрокаКорпус>,   пример: 32/1   это дом 32 корпус 1, 
//     <СтрокаДом>стр<СтрокаКорпус>, пример: 32стр1 это дом 32 корпус 1, 
//
//  3. Числа (номера дома) в заданный интервал чисел
//     При этом интервал задается строкой вида:
//     <Диапазон>[,<Диапазон>]
//     где Диапазон, это строка вида:
//     [Ч/Н]<Число>[-<Число>]
//     Префикс Ч или Н диапазона обозначает четность и нечетность входящих в него чисел
//     Пример: в интервал Ч12-14,Н1-5,20-29 входят числа 1,3,5,12,14 и все с 20 по 29
//
// Параметры: 
//    Номер              - (число, строка) номер дома с корпусом
//    Интервал           - (строка), интервал чисел (домов)
//    ТочноеСоответствие - (булево) номер дома должен точно соответствовать номеру в интервале
//                         или допускается наличие дробей и произвольных букв после номера дома
//
//  Истина - если заданное число входит в диапазон,
//  Ложь   - если не входит
//
Функция НомерДомаВИнтервале(Номер, Знач Интервал, ТочноеСоответствие = Ложь) Экспорт
	
	Пока НЕ ПустаяСтрока(Интервал) Цикл
		
		Позиция = Найти(Интервал, ",");
		Если Позиция = 0 Тогда
			Возврат ВходитВИнтервал(Номер, Интервал, ТочноеСоответствие);
		Иначе
			Если ВходитВИнтервал(Номер, СокрЛП(Лев(Интервал, Позиция - 1)), ТочноеСоответствие) Тогда
				Возврат Истина;
			Иначе
				Интервал = Сред(Интервал, Позиция + 1);
			КонецЕсли;
		КонецЕсли;
		
	КонецЦикла;
	
	Возврат Ложь;
	
КонецФункции


Показать
3. alext88 4 29.12.15 13:55 Сейчас в теме
почему-то индекс не определяется
4. voronin_a_2000 17 25.01.18 21:51 Сейчас в теме
Функция ВходитВИнтервал пустая. Обработка не работает. Не качайте
Оставьте свое сообщение

См. также

Добавление адресов в адресный классификатор. УПП 1.3 0

Инструменты и обработки Бухгалтер Пользователь Внешняя обработка (ert,epf) v8 УПП1 Абонемент ($m) Классификаторы

Если вам приходится вручную заносить адреса в регистр адресный классификатор, то эта обработка немного облегчит вашу работу.

1 стартмани

25.09.2019    554    1    nebuchadnezzzar    0       

Классификатор ОКПД2 для 1С 8 (управляемые формы) 0

Отчеты и формы Программист Пользователь Архив с данными v8 v8::УФ 1cv8.cf Абонемент ($m) Классификаторы

Готовый код для встраивания в любые конфигурации на платформе 1с 8.3 (управляемые формы).

2 стартмани

30.07.2019    780    pshunailov    0       

Замена объема в объектах справочника "Классификатор алкогольной продукции ЕГАИС" 0

Инструменты и обработки Бухгалтер Пользователь Внешняя обработка (ert,epf) v8 Розница Учет ТМЦ Абонемент ($m) Обработка справочников Классификаторы

Обработка позволяет перебрать справочник "Классификатор алкогольной продукции" и заменить в нем одну ёмкость на другую.

1 стартмани

12.04.2019    1323    user635667    0       

Изменение наименования в справочнике Номенклатура и заполнение реквизитов согласно Классификатору алкогольной продукции ЕГАИС 0

Инструменты и обработки Программист Бухгалтер Пользователь Внешняя обработка (ert,epf) v8 Розница Россия БУ Розничная торговля Учет ТМЦ Акцизы Абонемент ($m) Обработка справочников Классификаторы

Обработка для Розницы 2.2 изменяет название алкогольной продукции в справочнике Номенклатура и заполняет реквизиты элемента справочника, согласно наименованию номенклатуры в Классификаторе алкогольной продукции ЕГАИС.

2 стартмани

20.02.2019    2056    1    srub    0       

Автоматизация обновления адресного классификатора 2

Инструменты и обработки Программист Архив с данными v8 1cv8.cf Россия Windows Абонемент ($m) Классификаторы

Пример, как автоматизировать обновление адресного классификатора ФИАС.

1 стартмани

18.01.2019    1985    3    Meteorage    2       

Конструктор кодов бюджетной классификации (КБК) 1

Инструменты и обработки Программист Конфигурация (md, cf) v8 1cv8.cf Россия Госбюджет Абонемент ($m) Классификаторы

Понадобилось как-то добавить классификатор КБК в УТ-подобную конфигурацию. Делюсь с товарищами по несчастью, чтобы облегчить жизнь)

1 стартмани

07.11.2018    3043    2    andy_zhav    0       

Отчет "Реестр закупок до 100 тыс. рублей" (Реестр платежей до 100 тыс.) + Загрузка ОКПД 2 в дополнительный реквизит для Бухгалтерии 3.0 (без снятия конфигурации с поддержки) 0

Инструменты и обработки Бухгалтер Архив с данными v8 v8::БУ БП3.0 Государственные, бюджетные структуры БУ Абонемент ($m) Обработка справочников Классификаторы Бухгалтерские

Отчет "Реестр закупок до 100 тыс."  Отчет отбирает банковские выписки по комментарию - (так захотел клиент)  и отображает их по указанной форме. Добавляемые поля ОКПД2, Инициатор закупки. Загрузка ОКПД2 - Общероссийский классификатор продукции по видам экономической деятельности ОК 034-2014 (КПЕС 2008).

1 стартмани

16.02.2018    7270    3    Maddy18    2       

Коды ОКПД2 для загрузки в БГУ ред.1.0 1

Инструменты и обработки Бухгалтер Архив с данными v8 БГУ Россия БУ Госбюджет Производство готовой продукции (работ, услуг) Абонемент ($m) Обработка справочников Классификаторы

Текстовый файл, предназначенный для загрузки кодов ОКПД2 в БГУ ред. 1.0. ОКПД 2 — Общероссийский классификатор продукции по видам экономической деятельности

1 стартмани

01.02.2018    7074    14    Эсти    0       

Получение адреса по коду КЛАДР 0

Инструменты и обработки Программист Бухгалтер Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Россия Абонемент ($m) Универсальные обработки Классификаторы

Обработка получения адреса в виде структуры адресных элементов по коду КЛАДР. В типовых конфигурациях не нашел решения, как из кода КЛАДР получить адрес, в связи с чем написал свою обработку.

1 стартмани

23.12.2017    4898    6    ive    0       

Методика заполнения кодов ТНВЭД в Номенклатуре в конфигурации Бухгалтерия 2.0 0

Инструменты и обработки Программист Бухгалтер Внешняя обработка (ert,epf) v8 v8::БУ БП2.0 Оптовая торговля, дистрибуция, логистика Россия БУ Внешнеэкономическая деятельность (ВЭД) Оптовая торговля Абонемент ($m) Обработка справочников Классификаторы

В организации, торгующей продукцией, ввозимой в Россию и экспортируемую в страны таможенного союза, столкнулся с вопросом заполнения кода ТНВЭД в номенклатуре.  Острая необходимость возникла в связи с изменениями в печатных формах СФ и УПД в редакции Постановления Правительства РФ от 19.08.2017 № 981. В публикации речь о том, как этот вопрос решался для конфигурации Бухгалтерия 2.0 с технической и методологической сторон.

1 стартмани

19.12.2017    10604    6    abryazgin    0       

Загрузка ОКВЭД, ОКОПФ, ОКФС в справочник 2

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 1cv8.cf БУ Внешнеэкономическая деятельность (ВЭД) Учет ОС и НМА Абонемент ($m) Обработка справочников Классификаторы

Обработка загружает в справочник выбранный классификатор. Работает на любых конфигурациях с УФ на платформе 8.3.

1 стартмани

05.12.2017    6915    8    birk    0       

Дополнительные единицы измерения кодов ТНВЭД (Статистика: Форма учета перемещения товаров) в форматах xlsx, txt, csv 2

Отчеты и формы Программист Бухгалтер Архив с данными v8 1cv8.cf Россия БУ Внешнеэкономическая деятельность (ВЭД) Абонемент ($m) Статистические Классификаторы

Список дополнительных единиц измерения (ДЕИ) для кодов ТНВЭД, используемых для отправки статистических данных в ФТС (Федеральная Таможенная Служба).

10 стартмани

29.11.2017    7426    maxvcb    0       

Загрузка банков в конфигурацию УНФ для Беларуси 5

Инструменты и обработки Программист Бухгалтер Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Беларусь Банковские операции Абонемент ($m) Обработка справочников Классификаторы

Загрузка справочника банков для конфигурации Управление компанией для Беларуси (ранее УНФ). Классификатор обновлен для использования счетов в формате IBAN и SWIFT кодов банков. Тестировалось на версии УНФ для Беларуси 1.6.9.2

1 стартмани

14.11.2017    9064    2    Kim1C    2       

Классификатор грузов ЕТСНГ 0

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 БП3.0 Россия БУ Абонемент ($m) Обработка справочников Классификаторы

По необходимости пришлось сделать такую обработку. В поисках классификатора ЕТСНГ пришел к выводу, что легче получить с сайта и обновлять существующие элементы справочника, чем все время подгружать изменения.

1 стартмани

08.09.2017    8311    5    andrybar    0       

Файлы классификаторов ОКПД2 в формате .txt, для загрузки в справочник Коды ОКПД 0

Отчеты и формы Программист Архив с данными v8 1cv8.cf Россия БУ Производство готовой продукции (работ, услуг) Абонемент ($m) Классификаторы

Файлы формата txt, конвертированные из файлов Word, скачанных с сайта ФСГС, для загрузки в справочник "Коды ОКПД"

1 стартмани

09.06.2017    8145    20    user766128    4       

Загрузка классификатора банков Беларуси (с сайта - национального банка Беларуси) 2

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8::БУ v8::УФ БП3.0 Беларусь Банковские операции Абонемент ($m) Классификаторы

Обработка, позволяющая загружать новую информацию напрямую с сайта www.nbrb.by - Национального Банка Беларуси.

1 стартмани

04.03.2017    11976    35    dijee    10       

Коды ОКПД2 для загрузки в БП 2.0 (в формате csv) 1

Инструменты и обработки Бухгалтер Архив с данными v8 БП2.0 Россия Абонемент ($m) Классификаторы

Коды ОКПД2 в формате txt (csv), готовые для загрузки в БП 2.0. Данные по состоянию на 25.01.2017.

2 стартмани

03.03.2017    12962    25    korefano    1       

Автоматическая загрузка КЛАДР в типовые конфигурации 8.х 4

Инструменты и обработки Программист Бухгалтер Внешняя обработка (ert,epf) v8 БП2.0 ЗУП2.5 УПП1 БП1.6 ЗУП3.x Россия Windows Абонемент ($m) Обработка справочников Классификаторы WEB

Данная обработка предназначена для загрузки КЛАДР (Классификатор адресов Российской Федерации) в одно касание прямо из сети.

2 стартмани

28.02.2017    8373    16    Euroset1    5       

Классификатор видов экономической деятельности (ОКЭД) 2

Отчеты и формы Бухгалтер Конфигурация (md, cf) v8 1cv8.cf Беларусь БУ НУ Windows Внешнеэкономическая деятельность (ВЭД) Абонемент ($m) Обработка справочников Классификаторы

У вас отсутствует в конфигурации справочник "ОКЭД"? А быть может нужно только его заполнить данными? Тогда эта подсистема для вас!

1 стартмани

20.12.2016    14687    2    Xershi    2       

КЛАДР РБ 2013 года 1

Отчеты и формы Бухгалтер Архив с данными v8 1cv8.cf Беларусь Абонемент ($m) Классификаторы

Представлен файлами с расширением .dbf.

2 стартмани

02.09.2016    8077    3    nicolya    3       

КладРБ или классификатор адресов Республики Беларусь 13

Отчеты и формы no Внешняя обработка (ert,epf) v8 1cv8.cf Беларусь Windows Абонемент ($m) Классификаторы

КЛАДРа для Республики Беларусь не существует. Но легким движением руки это можно исправить! Вся правда о белорусском КЛАДР, читайте далее...

4 стартмани

04.11.2015    39507    141    Xershi    29       

Загрузка КЛАДР Крым, Севастополь и др. 8

Отчеты и формы no Архив с данными v8 1cv8.cf Россия Windows Абонемент ($m) Классификаторы

При загрузке КЛАДР нет возможности выбрать Крым и Севастополь, хотя в КЛАДРе они есть.

1 стартмани

07.04.2015    19545    69    ~ADm!t_@vd~    10       

Заполнить адрес контрагента по классификатору 7

Инструменты и обработки no Внешняя обработка (ert,epf) v8 УТ10 ERP2 Windows Абонемент ($m) Обработка справочников Классификаторы

Нужно как-то было мне загрузить контрагентов с адресами из Excel... Естественно, адреса хотелось бы получить не просто в свободной форме, а по классификатору. Тут я натолкнулся на вот эту ссылочку http://infostart.ru/public/293335/, автору огромное спасибо.

1 стартмани

19.12.2014    16416    59    kaging    3       

Загрузка Классификатора банков из Бухгалтерии 2.0 (возможно в других конфигурациях) без прав на скачивание и запуск *.EXE-файлов 12

Инструменты и обработки Системный администратор Бухгалтер Внешняя обработка (ert,epf) v8 БП2.0 Россия Банковские операции Абонемент ($m) Классификаторы Обмен с банком

В нашей сети пользователям категорически запрещено скачивание exe-файлов из интернета и запуск их на компьютерах. Отсюда возникла проблема скачивания файла cbrates.rbc.ru/bnk/bnk.exe и разархивирования его в %TEMP%\tempBik.

1 стартмани

18.12.2013    28510    43    Puk2    7       

KLADR: Ввод адреса по классификатору адресов КЛАДР (ExtDb для 8.2) 25

Инструменты и обработки Программист Конфигурация (md, cf) v8 1cv8.cf Россия Абонемент ($m) Классификаторы Универсальные функции

Всё новое - это хорошо забытое старое! Представляю оригинальную версию обработки для ввода адреса из КЛАДР в конфигурациях 8.2 (только толстый клиент) без использования типового регистра сведений «Адресный классификатор». Как многим известно, в замечательной программе «1С: Бухгалтерия 7.7» ввод адресов производится из внешних DBF-файлов, свободно скачиваемых с сайта ФНС или диска ИТС в каталог ExtDb рабочей базы. С помощью данной обработки вы сможете легко подключить и обновлять внешний КЛАДР для неограниченного количества своих баз меньше чем за одну минуту.

3 стартмани

06.06.2013    37330    117    Chastiser    11       

ОКП.xml по Приказу № 273 для БГУ 15

Отчеты и формы Бухгалтер Архив с данными v8 БГУ Россия Windows Абонемент ($m) Классификаторы

Справочник ОКП для 1С: БГУ 8, согласно приказу Минэкономразвития РФ от 07.06.2011 N 273 "Об утверждении номенклатуры товаров, работ, услуг для нужд заказчиков".

1 стартмани

17.02.2013    25588    165    1108    6       

Ошибка загрузки бюджетных классификаторов (БГУ 8.2) 35

Отчеты и формы Программист Нет файла v8 БГУ Государственные, бюджетные структуры Windows Абонемент ($m) Классификаторы

Часто возникает ошибка при обновлении бюджетной классификации в БГУ. Есть вариант исправить.

1 стартмани

31.08.2012    21097    107    Exiled    4       

Загрузка Банков с РБК 3

Отчеты и формы no Внешняя обработка (ert,epf) v8 УТ10 Россия Абонемент ($m) Классификаторы

Загрузка банков с РБК. С удивлением обнаружил, что отсутствует в УТ 11. Обработка сделана по правилам с возможностью добавления во внешние обработки.

1 стартмани

04.06.2012    23981    60    sherekhan    4       

Проверка телефонного номера по реестру нумерации 4

Отчеты и формы no Конфигурация (md, cf) v8 Россия Производство готовой продукции (работ, услуг) Абонемент ($m) Классификаторы

Конфигурация позволяет проверить заданный телефонный номер на соответствие "реестру Российской системы и плану нумерации". В случае соответствия выдается информация, в каком регионе и за каким оператором связи закреплен данный номер, а также номерную емкость того диапазона, которому принадлежит заданный телефонный номер. Данные "реестра Российской системы и плана нумерации" загружаются с сайта Федерального агентства связи

1 стартмани

17.05.2012    15856    30    alexstey    3       

Классификаторы ОКПД ОКФС ОКОПФ для 1С 19

Инструменты и обработки no Конфигурация (md, cf) v8 1cv8.cf Россия Абонемент ($m) Обработка справочников Классификаторы

Обработки для заполнения справочников классификаторов ОКПД, ОКФС, ОКОПФ в 1С

1 стартмани

09.02.2012    35445    204    stsasha87    11       

Украинский классификатор внешней экономической деятельности (Классификатор УКТВЭД) 22

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 1cv8.cf Украина Внешнеэкономическая деятельность (ВЭД) Абонемент ($m) Классификаторы

Обработка загрузки Классификатора УКТВЭД. Макет (.mxl) Классификатора УКТВЭД для загрузки в справочник 1С.

1 стартмани

27.12.2011    15867    58    vladen    22       

Загрузка ОКСМ (Общероссийского классификатора стран мира) из Экселя в 1С 5

Инструменты и обработки no Внешняя обработка (ert,epf) v8 КА1 БП2.0 УТ10 УПП1 Абонемент ($m) Обработка справочников Классификаторы Загрузка и выгрузка в Excel

Возникла надобность загрузить все страны мира в 5 разных баз 1С полностью. Стандартный механизм даем возможность загружать поштучно каждую страну + стандартный классификатор немного устарел. Пришлось быстро написать обработку для автоматической загрузки классификатора ОКСМ (Общероссийского классификатора стран мира) в базу 1С.

1 стартмани

07.11.2011    20966    66    Evgeniy    1       

Ручная загрузка классификатора банков 8

Инструменты и обработки no Внешняя обработка (ert,epf) v8 БП2.0 Банковские операции Абонемент ($m) Обработка справочников Классификаторы

Небольшая переделка стандартной обработки, позволяет вручную загрузить классификатор банков на компьютерах, где нет интернета и нет диска ИТС.

1 стартмани

28.09.2011    18554    82    Tango600    4       

Хранилище соответствий написаний украинских и русских имен 4

Отчеты и формы Программист Внешняя обработка (ert,epf) v8 1cv8.cf Россия Абонемент ($m) Классификаторы

Обработка предназначена для хранения соответствий имен, отчеств и фамилий для украинского и русского языков. Табличные соответствия хранятся в xml-файлах баз данных, поэтому обработка работает в любой конфигурации используя собственную базу данных имен.

02.07.2011    11602    159    djvu    4       

ОКП (Общероссийский классификатор продукции) для "Бухгалтерии Государственного Учреждения" 47

Отчеты и формы Бизнес-аналитик Бухгалтер Архив с данными v8 БГУ Государственные, бюджетные структуры Россия Госбюджет Абонемент ($m) Классификаторы

Досадное недоразумение - в составе поставляемых классификаторов есть ОКОФ и (чисто условно необходимый) ЕНАОФ, но нет очень важного классификатора, на который завязано многое, относящееся к государственным и муниципальным закупкам

1 стартмани

24.06.2011    26181    160    GlebHappy    25       

Заполнение адресного классификатора г. Киев 6

Отчеты и формы no Внешняя обработка (ert,epf) v8 УТ10 УПП1 Украина Абонемент ($m) Классификаторы

Заполнение адресного классификатора г. Киев

1 стартмани

11.06.2010    15588    41    mikukrnet    1       

Генерация/проверка ОГРН (Основной государственный регистрационный номер) 5

Отчеты и формы no Внешняя обработка (ert,epf) v8 1cv8.cf Россия Абонемент ($m) Классификаторы

Обработка позволяет сгенерировать или проверить уже существующий ОГРН (Основной государственный регистрационный номер).

1 стартмани

26.05.2010    17860    70    СергейКа    1       

Расширенный справочник стран (заполненная база) 10

Отчеты и формы no Конфигурация (md, cf) v8 1cv8.cf Украина Абонемент ($m) Классификаторы

Расширенный классификатор стран (заполненный)

1 стартмани

20.03.2010    16524    94    AnryMc    9       

Справочник дорожных знаков с подробным описанием 14

Отчеты и формы no Конфигурация (md, cf) v8 Россия Абонемент ($m) Классификаторы

Справочник дорожных знаков с подробным описанием

1 стартмани

18.09.2009    15035    126    relbler    10