Шифрование и расшифровка строковых полей справочников методом Виженера (с улучшениями)

Публикация № 518576

Разработка - Защита и шифрование

Шифрование метод Виженера

Обработка по шифрованию и расшифровке строковых полей справочников модифицированным методом Виженера - реализация без внешних компонент, без com-объектов, чистый 1С.

Хочу поделиться примером реализации обработки по шифрованию/расшифровке произвольных текстовых полей справочников. Требования перед разработкой я поставил следующие:

  1. Должен быть реализован функционал шифрования и расшифровки по паролю;
  2. Зашифрованные данные должны храниться в полях исходных данных, т.е. длина зашифрованного текста должна быть равной длине исходного текста, дополнительных таблиц быть не должно;
  3. Список полей для шифрования/расшифровки должен быть настраиваемым и не зависеть от конфигурации;
  4. Шифрование должно выполняться средствами платформы 1С без внешних компонент, com-объектов и т.д., чтобы исключить зависимость от ОС;

Решений на Инфостарте по шифрованию/расшифровки строк огромное множество (Защита и шифрование) - практически на любой вкус. Приведу наиболее интересные (на мой субъективный взгляд):

  1. Подсистема шифрования данных + пример реализации: решение Keystore для хранения паролей;
  2. Симметричное шифрование в 1С;
  3. Шифрование текста, хеш сумма;
  4. Хеширование данных с ключом по алгоритму SHA-1 штатными средствами 1С;
  5.  Шифратор и дешифратор текста и файлов для 1С

Однако, найти публикацию, отвечающую всем моим требованиям, так и не удалось. Из-за наличия требования №2 (о не превышении длиной зашифрованного текста длины исходного текста), в качестве метода шифрования был выбран шифр Виженера.
Да, по современным стандартам данный шифр является ненадежным и поддается взлому. Поэтому, чтобы повысить время на дешифровку текста, в базовый алгоритм были внесены следующие улучшения:

  1. Ключ для шифрования формируется на основании пароля, длина ключа шифрования равна длине шифруемого текста;
  2. Код каждого символа ключа шифрования равен коду соответсвующего символа пароля, смещенного на псевдо случайную величину А;
  3. Псевдо случайная величина А зависит от максимального кода среди символов пароля и длины кодируемой строки;
  4. Код каждого символа зашифрованной строки равен сумме кода соответствующего символа исходной строки, кода соответствующего символа ключа шифрования и псевдо-случайной величины В;
  5. Псевдо случайная величина В зависит от максимального кода среди символов ключа шифрования и длины кодируемой строки;

 Для генерации псевдо случайных величин использовался встроенный объект платформы "ГенераторСлучайныхЧисел". Ниже приведны основные функции обработки:

  1. Функция ПолучитьМаксимальныйКодСимволаСтроки - получает максимальный код символа в переданной строке : 
    Функция ПолучитьМаксимальныйКодСимволаСтроки(СтрокаАнализа)
    	
    	ДлинаСтрокиАнализа = СтрДлина(СтрокаАнализа);
    	
    	МаксимальныйКодСимвола = 0;
    	
    	Для Счетчик = 1 По ДлинаСтрокиАнализа Цикл
    				
    		КодТекущегоСимвола = КодСимвола(СтрокаАнализа, Счетчик);
    		
    		Если КодТекущегоСимвола > МаксимальныйКодСимвола Тогда
    			
    			МаксимальныйКодСимвола = КодТекущегоСимвола;
    			
    		КонецЕсли;
    		
    	КонецЦикла;
    	
    	Возврат МаксимальныйКодСимвола;
    	
    КонецФункции

  2. Функция ПолучитьКлючШифрования - получает по паролю ключ шифрования с учетом псевдо случайного смещения:
    Функция ПолучитьКлючШифрования(лПароль, ДлинаКодируемойСтроки)
    	
    	лПароль_Длина 	= СтрДлина(лПароль);
    	КлючШифрования	= "";
    	
    	ЧислоДляИнциализацииГенератораСлучаныхЧисел = ПолучитьМаксимальныйКодСимволаСтроки(лПароль_Длина);
    	
    	ЧислоДляИнциализацииГенератораСлучаныхЧисел = ЧислоДляИнциализацииГенератораСлучаныхЧисел + ДлинаКодируемойСтроки;
    	
    	ГенераторСлучаныхЧисел = Новый ГенераторСлучайныхЧисел(ЧислоДляИнциализацииГенератораСлучаныхЧисел);
    	
    	СчетчикПоПаролю = Неопределено;
    	
    	Для Счетчик = 1 По ДлинаКодируемойСтроки Цикл
    		
    		Если (СчетчикПоПаролю = Неопределено) ИЛИ (СчетчикПоПаролю > лПароль_Длина) Тогда
    			
    			СчетчикПоПаролю = 1;
    				
    		КонецЕсли;
    		
    		СлучайноеСмещение = ГенераторСлучаныхЧисел.СлучайноеЧисло(1, ЧислоДляИнциализацииГенератораСлучаныхЧисел);
    				
    		СимволПароля = Сред(лПароль, СчетчикПоПаролю, 1);
    		
    		КлючШифрования = КлючШифрования + Символ(КодСимвола(СимволПароля) + СлучайноеСмещение);
    		
    		СчетчикПоПаролю = СчетчикПоПаролю + 1;
    		
    	КонецЦикла;
    	
    	Возврат КлючШифрования;
    	
    КонецФункции

  3. Функция ЗашифроватьСтроку - шифрует строку шифром Виженера по ключу шифрования с учетом псевдо случайного смещения:
    Функция ЗашифроватьСтроку(КодируемаяСтрока, КлючШифрования)
    	
    	ДлинаКодируемойСтроки = СтрДлина(КодируемаяСтрока);
    	
    	ЧислоДляИнциализацииГенератораСлучаныхЧисел = ПолучитьМаксимальныйКодСимволаСтроки(КлючШифрования);
    	
    	ЧислоДляИнциализацииГенератораСлучаныхЧисел = ЧислоДляИнциализацииГенератораСлучаныхЧисел + ДлинаКодируемойСтроки;
    	
    	ГенераторСлучаныхЧисел = Новый ГенераторСлучайныхЧисел(ЧислоДляИнциализацииГенератораСлучаныхЧисел);
    	
    	ЗакодированнаяСтрока = "";
    	
    	Для Счетчик = 1 ПО ДлинаКодируемойСтроки Цикл
    		
    		КодСимволаИсходнойСтроки 	= КодСимвола(КодируемаяСтрока, Счетчик);
    		КодСимволаКлючаШифрования 	= КодСимвола(КлючШифрования, Счетчик);		
    		СлучайнаяСоставляющая 		= ГенераторСлучаныхЧисел.СлучайноеЧисло(1, ЧислоДляИнциализацииГенератораСлучаныхЧисел);
    		
    		КодЗакодированныгоСимвола = КодСимволаИсходнойСтроки + КодСимволаКлючаШифрования + СлучайнаяСоставляющая;
    		
    		ЗакодированнаяСтрока = ЗакодированнаяСтрока + Символ(КодЗакодированныгоСимвола);
    		
    	КонецЦикла;
    	
    	Возврат ЗакодированнаяСтрока;
    	
    КонецФункции

  4. Функция РасшифроватьСтроку - расшифровывает строку по ключу шифрования с учетом псевдо случайного смещения:
    Функция РасшифроватьСтроку(КодируемаяСтрока, КлючШифрования)
    	
    	ДлинаКодируемойСтроки = СтрДлина(КодируемаяСтрока);
    	
    	ЧислоДляИнциализацииГенератораСлучаныхЧисел = ПолучитьМаксимальныйКодСимволаСтроки(КлючШифрования);
    	
    	ЧислоДляИнциализацииГенератораСлучаныхЧисел = ЧислоДляИнциализацииГенератораСлучаныхЧисел + ДлинаКодируемойСтроки;
    	
    	ГенераторСлучаныхЧисел = Новый ГенераторСлучайныхЧисел(ЧислоДляИнциализацииГенератораСлучаныхЧисел);
    	
    	ЗакодированнаяСтрока = "";
    	
    	Для Счетчик = 1 ПО ДлинаКодируемойСтроки Цикл
    		
    		КодСимволаКлючаШифрования 	= КодСимвола(КлючШифрования, Счетчик);			
    		КодЗакодированныгоСимвола 	= КодСимвола(КодируемаяСтрока, Счетчик);
    		СлучайнаяСоставляющая 		= ГенераторСлучаныхЧисел.СлучайноеЧисло(1, ЧислоДляИнциализацииГенератораСлучаныхЧисел);
    		
    		КодСимволаИсходнойСтроки = КодЗакодированныгоСимвола - КодСимволаКлючаШифрования - СлучайнаяСоставляющая;
    		
    		ЗакодированнаяСтрока = ЗакодированнаяСтрока + Символ(КодСимволаИсходнойСтроки);
    		
    	КонецЦикла;
    	
    	Возврат ЗакодированнаяСтрока;
    	
    КонецФункции

  5. Функция ЗашифроватьРасшифроватьПолеОбъекта - получает ключ шифрования по паролю и шифрует или расшифровывает строку в зависимости от входных параметров:
    Процедура ЗашифроватьРасшифроватьПолеОбъекта(ЗначениеРеквизита, Пароль, ЗаписатьЭлемент, ЭтоШифрование)
    	
    	Если НЕ ПустаяСтрока(ЗначениеРеквизита) Тогда
    		
    		КлючШифрования = ПолучитьКлючШифрования(Пароль, СтрДлина(ЗначениеРеквизита));
    		
    		Если ЭтоШифрование Тогда
    			
    			ЗначениеРеквизита = ЗашифроватьСтроку(ЗначениеРеквизита, КлючШифрования);
    			
    		Иначе
    			
    			ЗначениеРеквизита = РасшифроватьСтроку(ЗначениеРеквизита, КлючШифрования);
    			
    		КонецЕсли;
    			
    		Если НЕ ЗаписатьЭлемент Тогда
    			
    			ЗаписатьЭлемент = ИСТИНА;
    			
    		КонецЕсли;
    		
    	КонецЕсли;
    	
    КонецПроцедуры

Фактическая реализация алгоритма в виде обработки в приложенном файле. Интерфейс обработки интуитивно понятен. Для выполнения шифрования (или расшифровки) необходимо выполнить несколько простых шагов: 

  1. Выбрать поля данных в базе для обработки (при нажатии на гиперссылку с надписью "Обработать:" открывается отдельная форма с деревом справочников конфигурации со всеми текстовыми реквизитами и табличными частями с текстовыми реквизитами;
  2. Ввести пароль;
  3. Ввести подтверждение пароля;
  4. Нажать кнопку "Зашифровать" или "Расшифровать" в зависимости от требуемого действия. 

В качестве примера работы алгоритма приложены скриншоты со справочником "Страны" до шифрования и после шифрования.  На этом все, спасибо за внимание, надеюсь, кому-нибудь пригодится.

Конструктивная критика приветствуется! 

Скачать файлы

Наименование Файл Версия Размер
ШифрованиеСтроковыхПолейСправочников.epf
.epf 18,61Kb
03.01.17
30
.epf 1.02 18,61Kb 30 Скачать
ШифрованиеСтроковыхПолейСправочников.epf
.epf 18,58Kb
03.01.17
8
.epf 1.01 18,58Kb 8 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. Поручик 4361 27.04.16 07:57 Сейчас в теме
Интересно. Где бы это приспособить?
2. NikitaXa 54 27.04.16 08:23 Сейчас в теме
(1) Поручик, например, временное скрытие конфиденциальной информации в базе.
9. spectre1978 50 05.06.16 16:30 Сейчас в теме
(1) Ну наиболее типичное на мой взгляд применение - это если в объектах конфы хранятся имена-пароли (скажем от неких сторонних веб-сервисов, с которыми работает программа) и есть желание это дело немного прикрыть от посторонних глаз.
3. oleg_km 27.04.16 09:54 Сейчас в теме
У меня в базе хранятся зашифрованные пароли от всякий банк-клиентов так, чтобы их не мог прочитать ни администратор, ни программист. Но я использую для всякий шифрований .NET
4. altu71 27.04.16 10:24 Сейчас в теме
А не подскажите, сколько времени занимает шифрование/расшифровка этим методом на значительном объеме данных? Т.е. запись 10 000 элементов справочника без шифрования столько то, а этих же данных, но с шифрованием - столько то. Т.е. хочется узнать накладные расходы времени на шифрование.
5. NikitaXa 54 27.04.16 21:38 Сейчас в теме
(4) altu71, накладные расходы на шифрование будут напрямую зависеть от оборудования. Я делал замеры (5 циклов шифрования/расшифровки) на справочнике объемом около 6.000. Общее время записи элементов справочника плюс/минус равно (точность до секунды) общему времени записи элементов этих же элементов с шифрованием двух полей (номер телефона и электронная почта). Т..е .время шифрования незначительно по сравнению с временем записи элемента справочника в БД. Если скорость шифрования справочника неудовлетворительна из-за длительной записи элементов справочника, то всегда можно распараллелить этот процесс через фоновые задания.
6. bubus 26.05.16 02:30 Сейчас в теме
И какова стойкость такого метода интересно? Брутфорс пальцами конечно не вариант, а если из 1С обработки пробутфорсить, сколько времени займет интересно на строку из 10 символов (зашифрованный пароль)?
7. NikitaXa 54 26.05.16 23:07 Сейчас в теме
(6) bubus, вот здесь есть описание продолжительности перебора пароля в общем случае. Т.е. для 10 символов пароля получается 1162 года. Однако существуют различные методы расшифровки шифра Виженера, которые позволяют ускорить время расшифровки.
8. bubus 27.05.16 08:31 Сейчас в теме
(7) я уже глянул, да есть. И очень эффективный - частотный криптоанализ. https://habrahabr.ru/post/221485/ Жаль там ссылка на программу мертвая. Но, программа та работает с "обычным" Виженером, а у вас я так понял изменения некоторые с ключом, плюс не "алфавитный квадрат" а символьный. Но, было бы очень интересно посмотреть за сколько бы та программа справилась, если бы справилась вообще. Но, в любом случае ваша разработка мне кажется очень и очень полезной. Для мобильных приложений к примеру, где у нас нет возможности юзать .NET Framework для шифрования.
10. spectre1978 50 05.06.16 16:34 Сейчас в теме
(6) bubus, если нужна стойкость от реального взлома - Вижинер вряд ли подойдет. Это один из самых известных и простых методов шифрования.
Т.е. "защита от дурака". Для серьезных применений нужно использовать CryptoAPI и алгоритмы из него.
11. soulsteps 73 21.06.16 16:32 Сейчас в теме
Автор, сделай сортировку в списке выбора объектов. А так обработка супер. Как раз понадобилось шифрануть данные.
12. NikitaXa 54 22.06.16 11:30 Сейчас в теме
(11) soulsteps, приложена новая версия обработки с сортировкой дерева справочников по синониму.
soulsteps; +1 Ответить
13. dobrynin.i.s 93 03.01.17 19:13 Сейчас в теме
Уважаемый, попробовал на ут 11

{ВнешняяОбработка.ШифрованиеСтроковыхПолейСправочников.Форма.Форма.Форма(780)}: Ошибка при вызове метода контекста (Выполнить)
РезультатЗапроса = Запрос.Выполнить();
по причине:
{(16, 30)}: Неверные параметры в операции сравнения. Нельзя сравнивать поля
неограниченной длины и поля несовместимых типов.
ИЛИ Таблица.ТекстоваяСтрока <<?>><> "")

убрал условие на непустую строку - обработка пишет зашифровано все, но результата не видно в справочнике
14. dobrynin.i.s 93 03.01.17 19:37 Сейчас в теме
(13) ф-я ЗашифроватьСтроку выдает пустой результат в любом случае цифры, кириллица. латиница
15. NikitaXa 54 03.01.17 22:40 Сейчас в теме
(14) Действительно, имела место ошибка в шифровании строковых реквизитов неограниченной длины. Исправленная версия обработки уже приложена к публикации. Для исправления ошибки в модуле формы необходимо заменить строку №734 замените с:
"| ИЛИ Таблица." + ИмяПоля + " <> """"";"
на:
"| ИЛИ ПОДСТРОКА(Таблица." + ИмяПоля + ", 1, 255) <> """"";".
dobrynin.i.s; +1 Ответить
17. ogidni 161 01.07.19 10:34 Сейчас в теме
КодЗакодированныгоСимвола = КодСимволаИсходнойСтроки + КодСимволаКлючаШифрования + СлучайнаяСоставляющая;

Я что то не понял у вас в сумме шифра случайное число. Получается текст зашифровать можно, а вот обратно нет. или только путем перебора случайной строки?
18. hide2000 03.01.20 17:15 Сейчас в теме
(17) Тоже обратил внимание на это. Но есть один нюанс, который все объясняет.
ГенераторСлучайныхЧисел
Описание:
Генератор случайных чисел инициализируется начальным числом из параметра.
Последовательность случайных чисел для одного и того же начального числа будет одинакова.

А начальное число всегда одно и тоже для определенного пароля.
Оставьте свое сообщение

См. также

История версий объектов для УФ

Отчеты и формы Программист Пользователь Архив с данными v8 v8::УФ 1cv8.cf Россия Windows Абонемент ($m) Журнал регистрации Обработка документов Обработка справочников

Универсальная независимая система хранения и анализа истории изменений справочников и документов. Предназначена для любых конфигураций 1С V83 ((8.3.9.1818) и выше) в режиме управляемого приложения.

1 стартмани

17.10.2019    6207    23    dmitrydemenew    19       

Онлайн-курс "Подготовка к экзамену 1С:Эксперт и 1С:Профессионал по технологическим вопросам" с 7 по 24 апреля 2020 г. Промо

На курсе вы получите практические навыки решения задач производительности 1С, в том числе характерных для высоконагруженных информационных систем (более 1000 пользователей). Подготовка к экзамену – только одна из составляющих курса. 70% слушателей приходят за знаниями, которые позволят расти и зарабатывать, делать сложные задачи на крупных проектах.

16450 рублей

Запутывание кода 1С

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Защита и шифрование

Обработка запутывания (обфускации) исходного кода 1С с помощью регулярных выражений.

2 стартмани

02.09.2019    5422    24    leoxz    66       

Защищаем конфигурацию. Один ключ СЛК для всех клиентов

Инструменты и обработки Программист Архив с данными v8 Абонемент ($m) Защита и шифрование

Пользователь защищенной конфигурации вводит регистрационный номер и код доступа. Установка сервера СЛК у пользователя не требуется. Управляем лицензиями удаленно.

1 стартмани

30.08.2019    5613    6    mvxyz    62       

Базовый курс по обмену данными в системе 1С:Предприятие. Онлайн-интенсив с 12 по 28 мая 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, обеспечивающих обмен данными между различными прикладными 1С-решениями и взаимодействие с другими информационными системами. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”.

5500 рублей

Создание ключей реестра документов

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 ERP2 Абонемент ($m) Обработка справочников

Отображение журналов документов в новых версиях 1C:ERP идет с использованием ключей реестра. В случае, например, переносов остатков, ключи могут не создасться автоматом, что приведет в дальнейшем к ошибкам при записи документов. Эта обработка создает ключи реестра для объектов, у которых ключей нет.

1 стартмани

30.06.2019    6743    62    sapervodichka    4       

Цифровая подпись Cades-BES для XML средствами 1С с помощью КриптоПро

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Россия Windows Абонемент ($m) Защита и шифрование

Обработка иллюстрирует возможность подписания XML SOAP-конверта по стандарту Cades-BES средствами 1С с помощью внешней компоненты КриптоПРО "CAdESCOM" с учетом ГОСТ 2001 и ГОСТ 2012. Стандарт используется в различных механизмах государственных сайтов России, в том числе в СМЭВ и ГИС ЖКХ. Код не привязан к прикладному решению может быть встроен куда угодно, но только на платформе Windows.

1 стартмани

13.05.2019    5870    12    PythonJ    25       

Голосование за доклады на INFOSTART MEETUP Kazan - до 25 февраля. Промо

Выбирайте и голосуйте за самые интересные доклады! Лучшие из лучших попадут в окончательную программу казанского митапа. Оставить свой голос можно до 25 февраля 2020 года.

1C:Предприятие для программистов: Расчетные задачи (зарплата). Онлайн-интенсив с 01 по 17 июня 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, которые предназначены для автоматизации периодических расчетов, а именно - для расчета зарплаты. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей прикладного решения “1С:Зарплата и управление персоналом” и прочих прикладных решений, в которых реализован функционал расчета зарплаты.

4900 рублей

Ручная выгрузка и загрузка данных через универсальный обмен данными с настройками (расширение, платформа 8.3+)

Инструменты и обработки Программист Архив с данными v8 Розница УНФ ERP2 БП3.0 УТ11 КА2 ЗУП3.x Абонемент ($m) Обработка документов Обработка справочников Обмен через XML Перенос данных из 1C8 в 1C8

Данное расширение (не требует изменения конфигураций) служит как надстройка для конфигураций, у которых обмен между базами происходит через универсальный формат (EnterpriseData), с использованием стандартных правил конвертации, которые уже есть в конфигурации. Интерфейс адаптирован для простых пользователей, сделан общий отбор по Организации для всех документов, имеется пару настроек для передачи в параметры конвертации, которые расположены в общем модуле конфигураций, а так же есть возможность выбора запуска - в фоне или в текущем сеансе. Теперь не нужно настраивать обмен между базами, для того чтоб просто перенести нужные документы. Подходит точно для УТ 11.4, БП 3.0.67, КА 2.4.5, Розница 2.2.9 (Обновление 1.2 от 02.03.2019)

2 стартмани

19.01.2019    12018    107    hakerxp    9       

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

Встраиваемая подсистема "Универсальные шаблоны объектов"

Инструменты и обработки Программист Бухгалтер Конфигурация (md, cf) v8 v8::СПР v8::УФ ЗУП3.x Абонемент ($m) Обработка документов Обработка справочников

Очень часто бывает так, что пользователь каждый месяц делает какие-либо "одинаковые" операции, например, заводит одни и те же документы, каждый раз меняя в них только значения нескольких реквизитов. Также во многих системах набирают популярность так называемые многофункциональные документы, т.е. документы, отвечающие за несколько разных участков автоматизации и в зависимости от вида операции, заполняющихся по разному. Для автоматизации подобных процессов была реализована данная подсистема.

1 стартмани

17.05.2018    12905    30    Skin123    13       

Автоматическое заполнение графиков в ЗУП 3.1

Инструменты и обработки Бухгалтер Архив с данными v8 v8::СПР ЗУП3.x Россия БУ Зарплата Учет рабочего времени Абонемент ($m) Обработка справочников

Данная разработка будет актуальна для организаций с большим количеством графиков (несколько десятков/сотен).

1 стартмани

05.05.2018    13475    19    notserioussam    2       

INFOSTART MEETUP Kazan. 13 марта 2020 г. Промо

Инфостарт продолжает путешествие по России. Следующая остановка - Казань. Тема мероприятия - управление и технологии автоматизации учета на платформе "1С: Предприятие". Ждем всех: докладчиков и участников! Стоимость участия - 5 500 рублей. Цена действительна до 30.01.2020

5 500

Расширение для 1С: Розница - форма справочника номенклатуры с ценами, остатками, штрихкодами

Отчеты и формы Пользователь Расширение (cfe) v8 Розница УУ Розничная торговля Абонемент ($m) Обработка справочников

Форма справочника номенклатуры с расширенными возможностями для 1С Розница версии 2.2.6.ХХХ и выше, платформа не ниже 8.3.10.

1 стартмани

17.03.2018    10606    50    independ    19       

​​​​​​​CorelDRAW Graphics Suite 2019 Промо

CorelDRAW – пакет профессиональных инструментов для редактирования фотографий, разработки дизайна, создания макетов страниц и векторных иллюстраций

2 в 1: Проверить действительность паспорта / Получить ИНН по паспорту

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 v8::УФ ERP2 БП3.0 ЗУП3.x Россия БУ Управление персоналом (HRM) Абонемент ($m) Обработка справочников WEB

Представляю вашему вниманию внешнюю обработку заполнения элемента справочника "Физические лица". Обработка выполнена с использованием API (для работы необходим доступ в интернет), содержит полностью открытый код и 2 команды: Проверка документа, удостоверяющего личность, в списке недействительных паспортов и Заполнение ИНН по паспортным данным.

1 стартмани

27.02.2018    15689    137    VladimirElohov    33       

[РАСШИРЕНИЕ] Заполнение данных контрагента по ИНН в 1С: Бухгалтерия и 1С: УНФ

Инструменты и обработки Бухгалтер Расширение (cfe) v8 УНФ БП3.0 Абонемент ($m) Обработка справочников

Бесплатное заполнение реквизитов контрагентов в 1С: Бухгалтерия, 1С: УНФ на базе сервиса dadata.ru. Добавляет кнопку заполнения по ИНН в карточку нового контрагента, не требует подписки на ИТС.

1 стартмани

09.01.2018    28376    207    Anton64    80       

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

Автоматическое заполнение реквизитов контрагентов по ИНН для ERP 2.4, ERP 2.2, УТ 11.4, УТ 11.3, УТ 11.2, КА 2.4, КА 2.2 и БП 3.0 (расширение конфигурации)

Инструменты и обработки Бухгалтер Пользователь Архив с данными v8 v8::БУ v8::ОУ v8::УФ УПП1 ERP2 БП3.0 УТ11 КА2 Россия Абонемент ($m) Обработка справочников Внешние источники данных WEB Расширения

Универсальное расширение конфигурации для автоматической загрузки реквизитов контрагентов (партнеров) из ОГРН для 1С:ERP Управление предприятием 2 (1С:ERP Управление предприятием 2, редакция 2.4), 1С:ERP Управление предприятием 2 (1С:ERP Управление предприятием 2, редакция 2.2), 1С:Управление торговлей 8 (Управление торговлей, редакция 11.4), 1С:Управление торговлей 8 (Управление торговлей, редакция 11.3), 1С:Управление торговлей 8 (Управление торговлей, редакция 11.2), 1С:Комплексная автоматизация 8 (1С:Комплексная автоматизация, редакция 2.4), 1С:Комплексная автоматизация 8 (1С:Комплексная автоматизация, редакция 2.2) и 1С:Бухгалтерия 8 (Бухгалтерия предприятия, редакция 3.0)

3 стартмани

08.11.2017    24287    201    AlexeyT1978    163       

Обфускация кода 1С

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Защита и шифрование

Обфускация кода 1С как вариант защиты кода.

10 стартмани

09.10.2017    28194    72    VsHome    5       

Сдача регламентированной отчетности из программ 1С Промо

Сдача регламентированной отчетности из программ "1С" во все контролирующие органы без выгрузок и загрузок в другие программы. Для групп компаний действуют специальные предложения.

от 1500 руб.

1C:Предприятие для программистов: Запросы и отчеты. Второй поток. Онлайн-интенсив с 17 марта по 16 апреля 2020 г. Промо

Данный онлайн-курс предусматривает углубленное изучение языка запросов и возможностей системы компоновки данных, которые понадобятся при разработке отчетов, работающих на платформе “1С:Предприятие” в рамках различных прикладных решений. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей различных прикладных решений, которые используют в своей работе отчеты разного назначения.

6500 рублей

Загрузка номенклатуры по штрихкоду: Управление Торговлей 11.3; Розница 2.2; Розница для Казахстана 2.2

Инструменты и обработки Системный администратор Программист Бухгалтер Внешняя обработка (ert,epf) v8 v8::ОУ v8::УФ Розница УТ11 Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Россия УУ Оптовая торговля Розничная торговля Ценообразование, анализ цен Абонемент ($m) Обработка справочников Ценообразование, прайсы

Розница 2.2, Управление Торговлей 11.3. Создание номенклатуры из интернета с помощью сканера штрихкодов либо терминала сбора данных. Варианты создания, автовыбор наилучшей позиции, источники, цены, загрузка картинки - всё это очень гибко и просто настраивается. Текущие открытые источники: barcode-list.ru(на текущий момент не работает); goodsmatrix.ru; ean13.info(может не работать капча); barcodes.olegon.ru. Автор программы не несёт ответственность за информацию, предоставляемую перечисленными выше открытыми источниками, так же не отвечает за их работоспособность. Данные источники принадлежат не автору программы. Данная программа нужна лишь для автоматизированного поиска информации на них.

10 стартмани

30.03.2017    46523    51    myALKleon    39       

Программы для исполнения 488-ФЗ: Маркировка товаров Промо

1 января 2019 года вступил в силу ФЗ от 25.12.2018 № 488-ФЗ о единой информационной системе маркировки товаров с использованием контрольных (идентификационных) знаков, который позволяет проследить движение товара от производителя до конечного потребителя. Инфостарт предлагает подборку программ, связанных с применением 488-ФЗ и маркировкой товаров.

Согласование (подсистема). Для любого справочника и документа в 1С. Встраивается в любые конфигурации

Инструменты и обработки Пользователь Руководитель проекта Архив с данными v8 1cv8.cf БП3.0 КА2 УУ Документооборот и делопроизводство Абонемент ($m) Управление бизнес-процессами (BPM) Обработка документов Обработка справочников

Подсистема для согласования в 1С. Для настройки нового согласования не требуется программировать, все делается в режиме исполнения. Открытый код. Бизнес-процессы. Документооборот. Проект выложен на GitHub.

1 стартмани

25.08.2016    42614    240    BlizD    194       

Управление ИТ-проектами. Модуль 2: продвинутый онлайн-курс по классическим методам управления проектами. Вебинары проходят с 12 марта по 11 июня 2020 года. Промо

Продвинутый онлайн-курс по классическому управлению ИТ-проектами позволит слушателям освоить инструменты из PMBoK® и 1С:Технологии корпоративного внедрения и научиться их применять для проектов любого масштаба. Курс включает в себя 12 вебинаров и 12 видеолекции, разбор кейсов и рекомендации экспертов по проектам слушателей. Ведущая курса - Мария Темчина.

от 13000 рублей

Удаление неиспользуемых элементов справочника (простые и управляемые формы)

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Обработка справочников Чистка базы

Обработка предназначена для удаления неиспользуемых элементов выбранного Вами справочника. Обработка конфигурационно-независима. UPD. Расширены возможности обработки

3 стартмани

02.08.2016    11861    79    roma_semenov79    6       

Защита разработок от копирования (Обычная и Управляемая форма)

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Windows Абонемент ($m) Защита и шифрование

Вы разработчик, и разработали чудесный алгоритм, но не хотите ни с кем с ним делиться - используйте данную разработку, и тогда предполагаемый злоумышленник, глядя на такой код, просто плюнет и начнет писать свой.

1 стартмани

28.03.2016    35170    325    karpik666    123