gifts2017

Соединение в запросе, сравнение (В ИЕРАРХИИ)

Опубликовал Вячеслав Уразов (YODDHA) в раздел Программирование - Практика программирования

Иногда требуется, в запросе, в соединении, найти какую то общую иерархию... например, есть два списка элементов номенклатуры, эти два списка надо объеденить по общему родителю, если он есть, причем этот неизвестно как высоко стоит этот родитель.

Как вариант можно перебрать родителей через ИЛИ, например так


Номенклатура.Родитель = Номенклатура1.Ссылка
    ИЛИ Номенклатура.Родитель.Родитель = Номенклатура1.Ссылка
    ИЛИ Номенклатура.Родитель.Родитель.Родитель = Номенклатура1.Ссылка
    ИЛИ Номенклатура.Родитель.Родитель.Родитель.Родитель = Номенклатура1.Ссылка


Только здесь глубина родителей конечна, если же непонятно какую глубину имеет справочник, то можно это решить так
выгрузить родителей вообще в таблицу значений в две колонки,
в одной родитель, а во второй все возможные его родители (по количеству родителей количество строк в таблице значений
полученную таблицу использовать для соедениения

Это мое первое сочинение для Инфостарта

В запросе, в соединении нельзя указать например:  ЛЕВОЕ СОЕДИНЕНИЕ ....... Ссылка В ИЕРАРХИИ(ТЗ.Ссылка)

Внизу приведены процедуры, которые позволяют все же сравниться с иерархией

идея в том что бы подготовить такую таблицу значений, где была бы информация



Первая колонка      Вторая колонка

Родитель                 Родитель.Родитель

Родитель                 Родитель.Родитель.Родитель

и так далее для каждой группы в первой колонке, всег вышестоящие группы во второй

и использовать это для этой задачи

Где можно будет указать .... СОединение Номенклатура.Родитель = ТЗ.Родитель и далее обрабатывается

условие с Вышестоящими родителями

итак процедуры

/// это основная процедура где и нужно произвести соединение по иерархии

Процедура КнопкаВыполнитьНажатие(Кнопка)

 
М = Новый МенеджерВременныхТаблиц;

 
Запрос = Новый Запрос;
 
Запрос.УстановитьПараметр("Номенклатура",Номенклатура);

 
ПолучитьНаборРодителей(М);
 
Запрос.МенеджерВременныхТаблиц = М;

 
// это конечно можно сразу в условии ГДЕ в ИЕРАРХИИ решить
 // это просто пример
 
Запрос.Текст =

 
"ВЫБРАТЬ
 | ВремТаб.ПервыйРодитель,
 | ВремТаб.РодительГдеТоНадНоменклатурой
 |ПОМЕСТИТЬ ТЗ
 |ИЗ
 | ВремТаб КАК ВремТаб
 |;
 |
 |////////////////////////////////////////////////////////////////////////////////
 |ВЫБРАТЬ
 | Номенклатура.Ссылка КАК Номенклатура,
 | ТЗ.ПервыйРодитель,
 | ТЗ.РодительГдеТоНадНоменклатурой
// ну и ради чего все затевалось, сравнение с группами в иерархии
 
|ИЗ
 | ТЗ КАК ТЗ
 |  ЛЕВОЕ СОЕДИНЕНИЕ Справочник.Номенклатура КАК Номенклатура
 |  ПО ТЗ.ПервыйРодитель = Номенклатура.Родитель
 |ГДЕ
 | ТЗ.РодительГдеТоНадНоменклатурой = &Номенклатура"
 
;

 
РЕзультат = Запрос.Выполнить().Выгрузить();
 
ЭлементыФормы.ТЗ_1.Значение = Результат.Скопировать();

КонецПроцедуры


// Эти две процедуры создают ТЗ с группами

// первая процедура выбирает все группы

// вторая заполняет ТЗ вышестоящими родителями для родителя первой колонки

Процедура ПолучитьНаборРодителей(МенВремТаблиц)


 
НовТЗСоВсемиРодителями = Новый ТаблицаЗначений;
 
ТипНоменклатура = Новый ОписаниеТипов("СправочникСсылка.Номенклатура");
 
НовТЗСоВсемиРодителями.Колонки.Добавить("ПервыйРодитель",ТипНоменклатура);
 
НовТЗСоВсемиРодителями.Колонки.Добавить("РодительГдеТоНадНоменклатурой",ТипНоменклатура);

 
Запрос = Новый Запрос;
// Запрос.УстановитьПараметр("Номенклатура",Номенклатура);
 
Запрос.Текст =
 
"ВЫБРАТЬ
 | Номенклатура.Ссылка КАК ПервыйРодитель
 |ИЗ
 | Справочник.Номенклатура КАК Номенклатура
 |ГДЕ
 | Номенклатура.ЭтоГруппа
// | И Номенклатура.Ссылка = &Номенклатура
 
|
 |СГРУППИРОВАТЬ ПО
 | Номенклатура.Ссылка"
 
;
 
Результат = Запрос.Выполнить().Выгрузить();
 Для каждого
стр Из Результат Цикл
  Если
стр.ПервыйРодитель.Родитель.Пустая() Тогда
  
стрТЗ = НовТЗСоВсемиРодителями.Добавить();
  
стрТЗ.ПервыйРодитель     = стр.ПервыйРодитель;
  
стрТЗ.РодительГдеТоНадНоменклатурой = Справочники.Номенклатура.ПустаяСсылка();
  Иначе
  
ПолучитьВсехРодителей(НовТЗСоВсемиРодителями,стр.ПервыйРодитель,стр.ПервыйРодитель.Родитель);
  КонецЕсли;
 КонецЦикла;

 
НовТЗСоВсемиРодителями.Сортировать("ПервыйРодитель");

 
////////////////////////////////////////////////////////////////////////
 ///// для наглядоности, выгружаем в Таблицу значений на форме //////////
 ////////////////////////////////////////////////////////////////////////
 
ЭлементыФормы.ТЗ_.Значение = НовТЗСоВсемиРодителями.Скопировать();
 
ЭлементыФормы.ТЗ_.ОбновитьСтроки();

 
Запрос = Новый Запрос;
 
Запрос.МенеджерВременныхТаблиц = МенВремТаблиц;
 
Запрос.УстановитьПараметр("ВоВремТабл",НовТЗСоВсемиРодителями);
 
Запрос.Текст =
 
"ВЫБРАТЬ
 | ВоВремТабл.ПервыйРодитель,
 | ВоВремТабл.РодительГдеТоНадНоменклатурой
 |ПОМЕСТИТЬ ВремТаб
 |ИЗ
 | &ВоВремТабл КАК ВоВремТабл"
 
;
 
Запрос.Выполнить();

КонецПроцедуры

Процедура
ПолучитьВсехРодителей(ТЗ,Родитель,РодительНадРодителем)

 Если
РодительНадРодителем.Пустая() Тогда
  Возврат;
 КонецЕсли;

 
стрТЗ = ТЗ.Добавить();
 
стрТЗ.ПервыйРодитель     = Родитель;
 
стрТЗ.РодительГдеТоНадНоменклатурой = РодительНадРодителем;

 
ПолучитьВсехРодителей(ТЗ,Родитель,РодительНадРодителем.Родитель);

КонецПроцедуры

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Пример группировки
.epf 8,85Kb
14.07.14
31
.epf 8,85Kb 31 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Roman Biblbox (mr zafod) 18.12.11 14:47
? А вроде в СКД такое соединение делается на ура с помощью разных наборов данных
2. Вячеслав Уразов (YODDHA) 19.12.11 00:16
бесспорно))) решается, но иногда надо влезть в существующий запрос, например типовой, и строить скд, для общего модуля, или еще по каким причинам может быть неудобно.
3. Модератор раздела Артур Аюханов (artbear) 23.12.11 16:37
Что-то как-то наворочено и запутано все :(
Да еще и неоптимально :(
стр.ПервыйРодитель.Родитель - объектный/тормозной подход
еще РодительНадРодителем.Родитель и т.п.
Временная таблица ВремТаб нафига нужна? Она создается, из нее создается еще одна временная таблица, с которой уже идет основная работа. неоптимально.
ЗЫ код путаный совсем, тяжело разгребать.
4. Вячеслав Уразов (YODDHA) 24.12.11 23:43
тут две задачи даже показаны,
одна из них понятно, это использование менеджера таблиц и использовании в запросе таблицы значения, тут все понятно и про нее расписывать ничего не стал
и вторая как узнать общего родителя через соединение в запросе

каждая процедурка, решает очень узкую задачу

КнопкаВыполнитьНажатие(Кнопка) основная процедура, в которой и лежит запрос в котором нужно получить соединение

ПолучитьНаборРодителей(М) процедура которая получает список родителей, организуя выборку родителей вообще
и подбор всех родителей через
рекурсивную процедуру ПолучитьВсехРодителей(ТЗ,Родитель,РодительНадРодителем)

что беру всего родителя, ну может и тяжело, только зачем в примере путать людей оптимизацией, чем нагляднее тем лучше

да еще, у меня приложена там обработка, которая и демонстрирует работу этой задачи
ну и я не убрал отсюда из кода строк которые управляют таблицей на форме

//ЭлементыФормы.ТЗ_1.Значение = Результат.Скопировать();

//ЭлементыФормы.ТЗ_.Значение = НовТЗСоВсемиРодителями.Скопировать();
//ЭлементыФормы.ТЗ_.ОбновитьСтроки();

если есть пожелания конкретного характера))) в частности как сделать код нагляднее, с удовольствием выслушаю
спасибо за критику
5. Модератор раздела Артур Аюханов (artbear) 26.12.11 16:47
(4) В (3) я тебе указал конкретные недостатки твоего кода.
что еще? для столь универсального кода нужна оптимизация/оптимальность.
Данные ХХХ.Родитель неужели трудно из запроса достать?
зачем промежуточная ненужная таблица вообще нужна?
6. Вячеслав Уразов (YODDHA) 26.12.11 17:17
понятно))) если вы не увидели зачем она нужна, то и статья то в общем вам должна быть не интересна
7. Модератор раздела Артур Аюханов (artbear) 27.12.11 07:46
(6) Ты пойми, что одна из двух твоих временных таблиц вообще не нужна :(
Если уж выкладываешь универсальный код, либо сразу напиши, что он далеко не оптимален, либо сделай пооптимальнее.
8. Вячеслав Уразов (YODDHA) 27.12.11 13:03
9. 1 (shomo) 05.01.12 12:23
Спасибо. Натолкнуло на решение собственной проблемы.
10. Вячеслав Уразов (YODDHA) 05.01.12 18:58
12. Владимир Клименко (KliMich) 01.03.12 22:24
13. Максим Костиков (mkostya) 01.03.12 22:49
14. Лилия Корнеева (ulili) 04.05.12 12:59
15. s1sting (s1sting) 19.06.12 17:10
16. Вячеслав Уразов (YODDHA) 19.06.12 17:30
17. Сергей Назаренко (Hobbit_Jedi) 12.03.15 12:05
(1) А можно пример того, как это легко на СКД сделать?
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа