gifts2017

Создание подчиненных документов "Заказ на производство" на основании основного заказа на производство, УПП 8.2, ред. 1.3

Опубликовал ISS (iss) в раздел Обработки - Обработка документов

Создание документов "Заказ на производство" на основании основного "Заказа на производство"

Автоматическое создание документов "Заказы на производство" на основании главного документа "Заказ на производство".

Обработка создана для того, чтобы пользователи не забыли создать все необходимые документы "Заказ на производство", чтобы произошло полное разузлование выходного изделия, которое упоминается в главном документе.

В форме обработки выбирается главный документ. При нажатии на кнопку «Заполнить» создаются подчиненные документы (см. скриншот «Запуск обработки»).

Обработку можно оформить для запуска из журнала "Заказы на производство" и/или формы списка документа "Заказ на производство" с соответствующими доработками в этих журналах. В данном случае нужно выбрать строку журнала с нужным (основным) документом и нажать на кнопку «Оформить заказы на основании» (см. скриншот «Запуск из журнала»).

Доработки конфигурации.

  1. Создан реквизит документа "Заказ на производство" – «ДеревоЗаказов», тип - Строка (200). Этот реквизит для наглядности нужно поместить в журнал "Заказы на производство" и форму списка самого документа. По нему можно легко увидеть подчинение документов сразу в журнале, не открывая структуру подчиненности.
    Принцип заполнения реквизита «ДеревоЗаказов» следующий:
    НомерОсновногоДокумента_НомерДокументаУровня2_ НомерДокументаУровня3 и т.д.
    Номера документов, заполняющие «ДеревоЗаказов» берутся без префиксов и без начальных нулей.
  2. В форме документа "Заказ на производство" в процедуру формы ПриЗаписи нужно добавить код следующего содержания:

 

	 Процедура ПриЗаписи(Отказ)
    //....Ваша обработка......
    //....Ваша обработка...
    // В ДеревоЗаказов вставляем № документа, если это 1-й док-т дерева,
    //т.е. ОсновнойЗаказНаПроизводство - не заполнено.
    Если НЕ ЗначениеЗаполнено(Номер) Тогда
        УстановитьНовыйНомер(ОсновнойЗаказНаПроизводство.Организация.Префикс);         
    КонецЕсли;    
    Если НЕ ЗначениеЗаполнено(ДеревоЗаказов) Тогда
        цц = "0123456789";
        ном = "";
        длинаНомера = СтрДлина(Номер);
        ии = длинаНомера;
        Пока ии > 0 Цикл
            Если Найти(цц,Сред(Номер,ии,1)) > 0 Тогда
                ном = Сред(Номер,ии,1) + ном;
            Иначе
                Прервать;
            КонецЕсли;    
            ии = ии - 1;
        КонецЦикла;    
        ном = Строка(Формат(Число(ном),"ЧГ=0"));
           
        Если НЕ ЗначениеЗаполнено(ОсновнойЗаказНаПроизводство) Тогда
            //Вытаскиваем №
            ДеревоЗаказов = ном;
        Иначе
            Если ЗначениеЗаполнено(ОсновнойЗаказНаПроизводство.ДеревоЗаказов) Тогда    
                ДеревоЗаказов = СокрЛП(ОсновнойЗаказНаПроизводство.ДеревоЗаказов) + "_" + ном;
            КонецЕсли;    
        КонецЕсли;    
    КонецЕсли;
КонецПроцедуры


При желании, этот новый реквизит «ДеревоЗаказов», можно вывести на форму. У меня - видимость и доступность этого реквизита только для пользователя с полными правами (см. скриншот Основной документ).

 

Желаю успехов!

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
ЗаполнениеЗаказовНаПроизводство
.epf 9,33Kb
17.08.14
47
.epf 9,33Kb 47 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

0. ISS (iss) 22.12.11 10:14
Создание документов "Заказ на производство" на основании основного "Заказа на производство"


Перейти к публикации

1. Константин Соболевский (Константин С.) 22.12.11 10:14
Зачем?

Что даст это. По какому признаку происходить создание подчиненых ЗаказовПроизводства, что внутри.

Дополни описание.
2. Виктор (vkt) 22.12.11 17:02
При формировании заказов идет сообщение об ошибке и формирование завершается.
Можно ли корректно обработать эту ошибку? Чтобы процесс формирования заказов не прерывался? Пусть документ не проводится, но формируется. Или хотя бы более конкретно было указание в какой спецификации отсутствует количество по строке?
Прикрепленные файлы:
3. ISS (iss) 23.12.11 08:40
Спасибо за сообщение! Посмотрю на досуге, сейчас просто некогда, прошу прощения.
4. Виктор (vkt) 29.12.11 20:29
Попробовал обновленную версию. При выполнении потребовались полные права доступа. Это большой минус, т.к. пользователям не разрешено работать с полными правами.
Прикрепленные файлы:
5. Виктор (vkt) 29.12.11 20:32
Еще один минус - внесение изменений в типовую конфигурацию.
Как вариант, Дерево заказов можно выводить в реквизит документа Комментарий.
Или создать дополнительное Свойство.
6. Виктор (vkt) 16.01.12 17:08
Обновленная версия так и не заработала. Формирует заказ первого уровня и прекращает работу.
Однозначно - минус.
А жаль. Идея заложена хорошая.
7. Владимир Бабайцев (discant) 13.06.12 14:57
Товарищи, речь идет о коде, который нужно добавлять в модуль формы документа?
Но процедуры "ПриЗаписи" нет в форме документа "ЗаказНапроизводство"
Как быть в такой ситуации?
8. Luzan Andrei (luzanas) 15.07.13 09:23
Я получил результат, спасибо!
(6) Не разузловался, потому что (2) Вы попросили не проводить длокумент заказа :)) Нужно вернуть проведение созданного документа
(7) Создайте её
Автор, премного благодарен!
9. АНДРЕЙ ЧЕБОТАРЬ (andr86) 10.09.15 15:13
Добрый день! Скажите а доработка конфигурации потребуются или все уже готово?
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа