gifts2017

Коллекция полезных кнопок и процедур для отчетов и обработок v3.00

Опубликовал Ю М (mtv:)) в раздел Программирование - Работа с интерфейсом

Собрал в одном месте полезные кнопки и процедуры, которые по мере необходимости можно использовать в своих разработках.

Коллекция полезных кнопок и процедур для отчетов и обработок

  Данный внешний отчет представляет собой коллекцию полезных кнопок и процедур, которые Вы можете использовать в своих разработках. Для этого надо лишь скопировать нужные кнопки и соответствующие им процедуры в разрабатываемую форму.

  Для каждой кнопки можно назначить сочетание клавиш, которое позволяет быстро выполнить выбранное действие (так называемые "Горячие клавиши").


  Эта кнопка прилично экономит время при разработке и отладке внешних отчетов и обработок. Позволяет одним нажатием закрыть текущую форму и тут же открыть её заново (со всеми внесенными изменениями). Идею почерпнул в публикации http://infostart.ru/public/96548/. Спасибо ShantinTD.


  Это подменю "Вывод копии..." содержит три кнопки:
  1. Кнопка "в Excel (.xls)" открывает сформированный отчет (табличный документ) в Microsoft Office Excel или Open Office Calc, т.е. в программе, которая ассоциирована для файлов с расширением .xls.
  2. Кнопка "в Adobe Reader (.pdf)" открывает сформированный отчет (табличный документ) в Adobe Reader или в другой программе, которая ассоциирована для файлов с расширением .pdf.
  3. Кнопка "в Табличный документ" открывает сформированный отчет (табличный документ) в другом отдельном Табличном документе.


  Эта кнопка позволит отправить по электронной почте сформированный отчет (табличный документ) через Microsoft Outlook.
Вызываемая процедура сохраняет отчет в файл с расширением .xls, подготавливает письмо с вложением сохраненного отчета и открывает в Outlook сформированное письмо.


  Кнопка "Зафиксировать" является аналогом кнопки из меню "Таблица > Вид > Зафиксировать таблицу". Для быстрого доступа к этой функции данная кнопка вынесена на командную панель. Кнопка фиксирует/расфиксирует строки и колонки таблицы слева и сверху от активной ячейки.


  Кнопка "Печать с выбором принтера" для распечатки сформированного отчета. Перед распечаткой открывается диалог печати для выбора принтера, диапазона страниц и количества копий.


  Кнопка "Печать сразу" для распечатки сформированного отчета. Печать происходит без вызова диалога печати (печать с текущими настройками).


  На этой сервисной кнопке отображается время, затраченное на формирование отчета. При нажатии на кнопку показания обнуляются.


  Программно-сгенерированные кнопки, для управления уровнями группировки в отчетах. Теперь сворачивать-разворачивать группировки стало намного удобнее и быстрее, чем стандартно, через контекстное меню. Количество кнопок соответствует количеству уровней группировки сформированного отчета.
  Использованы доработанные процедуры из публикации http://infostart.ru/public/83915/.


В версии 2.02 (от 17.03.2012) добавлено:


  Группа кнопок для управления Периодом. "Выбор периода...", "Предыдущий месяц", "Текущий месяц" и "Следующий месяц".

  Первая кнопка
открывает форму для удобного и быстрого выбора периода (см. скриншот №2). В этой форме одним кликом можно выбрать любой стандартный период: Год, Полугодие, Квартал, Месяц, День. А поле календаря (внизу формы) позволяет выбрать вообще любой период. Для этого помечаем мышкой дату начала периода, а затем с нажатой клавишей Shift дату конца периода, и нажимаем кнопку "Выбрать".
Для большей универсальности, предусмотрена кнопка вызова "Стандартного диалога выбора Периода" (сверху-справа).
Использована доработанная форма из публикации http://infostart.ru/public/90540/ от Adeptus.

  Вторая кнопка сдвигает интервал Периода по месяцам назад (в сторону уменьшения).

  Третья кнопка устанавливает интервал Периода равным текущему месяцу.

  Четвертая кнопка сдвигает интервал Периода по месяцам вперед (в сторону увеличения).


  Добавлены процедуры для отображения трех индикаторов процесса (см. скриншот №3):
  
  Первый - стандартный индикатор, можно разместить в любом месте формы отчета. Он виден только во время формирования отчета.

    Два других индикатора (СКД-шный и текстовый) отображаются в строке состояния приложения.

    За основу взяты процедуры из публикации "Индикатор процесса в строке состояния ... ?...!". Спасибо, Шёпот теней, Абадонна и Душелов.


  Добавлена процедура для подсчета суммы выделенных ячеек в отчете.
 
  Реализовано два способа отображения суммы.

  Первый способ - отображение в элементе управления "Надпись". Может располагаться в любом месте на форме отчета.

  Второй способ - отображение в сворачивающемся элементе управления "Поле ввода". Располагается в самом низу формы, под полем табличного документа. Скрывается, когда ничего не выделено. Плюсом этой реализации является то, что текст суммы выделенных ячеек можно скопировать в буфер обмена.

  Алгоритм корректно считает также и суммы в нескольких несмежных выделенных областях. За основу взяты процедуры из обработки "Универсальная консоль отчетов" от  Evg-Lylyk.


В версии 2.03 (от 17.10.2012) исправлена ошибка::


Исправлена ошибка в форме "Быстрого выбора стандартного рериода":
При выборе Второго полугодия (кнопка "II"), вместо периода "с 01.07.2012 по 31.12.2012" устанавливался период "с 01.06.2012 по 31.12.2012".

Можно не скачивать эту версию, а сделать маленькое исправление в предыдущей версии:

В модуле формы БыстрыйВыборСтандартногоПериода, в процедуре ПолугодиеНажатие
в строке:
    Период.НачалоПериода = Дата(ТекГод, ?(ПорядковыйНомер = 1, 1 ,6), 1);

надо "6" исправить на "7"; т.е. должно быть так:
    Период.НачалоПериода= Дата(ТекГод, ?(ПорядковыйНомер 1, 1 ,7), 1);


В версии 3.00 (от 10.08.2014) добавлено:


 

  1. Добавлена кнопка-меню "Вывод копии...":
    - В это меню перенесена кнопка "в Excel (.xls)" и добавлены кнопки "в Adobe Reader (.pdf)" и "в Табличный документ".

  2. Доработана процедура "ПоказатьСуммуВыделенныхЯчеек":  
    - Теперь сумма подсчитывается только в видимых ячейках (скрытые ячейки игнорируются).

  3. Переписана процедура "кнОткрытьВЭксель_Нажатие".

  4. В процедуре "кнПереоткрыть_Нажатие" устранен мелкий баг, описанный в комментарии (168) от artbear.


 

    Читайте встроенную справку, в которой находятся подробные описания кнопок и процедур, а также способ перенесения нужного функционала в свои обработки. Внимание: после нажатия кнопки "Переоткрыть" встроенная справка перестает открываться.

  Для демонстрации работы кнопок реализован простой отчет, который имеет самостоятельную ценность. Отчет показывает количетво Документов каждого вида, количество элементов каждого Справочника и количество записей каждого Регистра сведений. При двойном щелчке по наименованию открывается форма списка выбранного элемента.

  Внешний вид отчета показан на первом скриншоте.

Скачать файлы

Наименование Файл Версия Размер
КоллекцияКнопокИПроцедур(3_00).erf 1993
.erf 51,00Kb
20.06.15
1993
.erf v3.00 51,00Kb Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Вячеслав Кадацкий (marsohod) 09.01.12 07:02
Жаль, что только для толстого клиента.
2. Программулькин (Программулькин) 09.01.12 13:28
есть возможность переделать для веб клиента?
3. Ю М (mtv:)) 09.01.12 13:39
(1)(2) Я никогда не работал с управляемым приложением, поэтому, к сожалению, ни чем не могу помочь.
Может найдутся спецы по управляемому приложению, и они смогут адаптировать... Мы бы сказали им огромное спасибо.
4. Роман Хусяинов (rom-x) 09.01.12 13:49
А в 7-ке можно как-нибудь реализовать открытие таблицы в exel без записи файлов?
5. Uncore1989 (Uncore) 09.01.12 13:57
классный пост, автору большой плюс!
6. valerka78 (S.V.Y) 09.01.12 14:02
Забрал, плюс :)
(4) rom-x, можно, поиск рулит.
7. Роман Хусяинов (rom-x) 09.01.12 14:26
(6) valerka78, а по конкретнее?
У кого какие соображения?
8. valerka78 (S.V.Y) 09.01.12 14:35
(7) rom-x, http://infostart.ru/public/17464/ например.
Обсуждение в данной ветке прекращаем..
9. Сергей (Che) Коцюра (CheBurator) 09.01.12 17:08
ждем, когда в 8-ке появится такая удобная фишка как перехват любой открытой печатной формы (как в 7.7)...
10. Модератор раздела Артур Аюханов (artbear) 09.01.12 18:30
(9) Уже есть такая фича :)
Как обычно, расширения 1С ищем на сайте 1С++ - можно по моему нику :)
11. Андрей Андрей (diarki) 09.01.12 21:40
Автору однозначно плюс! Понравилась кнопка "Переоткрыть" полезная вне всякого сомненя - теперь вставляю ее везде... (открыл для себя много полезной информации) побольше бы таких публикаций.
12. valerka78 (S.V.Y) 09.01.12 21:43
(11) diarki, +1, такая кнопка рулила и в 7.7 :) Насколько меньше лишних движений.
13. Олег Иванов (ogeniv) 10.01.12 06:44
14. Дмитрий Семенов (Sam13) 10.01.12 09:53
Отлично. Полезно не только для использования, но и для расширения знаний. Особое спасибо за кнопки раскрытия группировок. Без них мучился.
15. Ю М (mtv:)) 10.01.12 10:50
(5)(11)(12)(13)(14) Спасибо за положительные отзывы, очень приятно. :)
16. Олег Василевский (OlegrVasil) 10.01.12 12:56
(15) mtv:), Спасибище огромное за разработку.
17. L K (ludai) 10.01.12 13:29
Переоткрыть - хорошая идея, да))
Остальные кнопки пока не заценила, возможно, тоже полезно.
18. Олег Василевский (OlegrVasil) 10.01.12 13:34
А можно ли настроить почту не на Outlook?
19. Дмитрий Титов (dtitov) 10.01.12 19:22
20. Ю М (mtv:)) 10.01.12 21:07
(18) OlegrVasil, в данной разработке процедура для кнопки "Отправить" настроена на отправку почты через Outlook. Можно настроить и на подругому, но придется переписать процедуру.
Поиск тебе в помощь. Ссылок на Инфостарте много. К примеру вот ссылка -> Отправка почты из 1С.
21. Сергей Федоров (Bober777) 10.01.12 22:45
А можно ли сделать пример для программного формирования файла с группировками в ёкселе.
22. Гость 10.01.12 22:51
Прикольно , парадовала кнопка открытия в экселе и переоткрыть
23. Иван Иванов (VankaV) 11.01.12 09:55
Простенько и со вкусом.
Хорошо бы еще и для управляемого приложения ...
24. Ю М (mtv:)) 11.01.12 10:34
(21) Bober777, я, к сожалению, не знаю, что такое "ёксель"... :)
25. Сергей Средних (morpheus2) 11.01.12 11:13
Большое спасибо! Лично мне очень пригодится.
26. Сергей Федоров (Bober777) 11.01.12 12:04
(21) это XLS - я его просто так зову...
27. Сергей Федоров (Bober777) 11.01.12 12:39
(24) У меня есть вопрос может ты мне поможешь?
Хочу программно сформировать XLS документ с группировками (плюсиками)
28. Ю М (mtv:)) 11.01.12 14:01
(27) Bober777, Слету на твой вопрос ответить не смогу. А копать в этом направлении - просто нет пока времени. Извини.
Я бы твою задачу по быстрому решил так: Сформировал нужный отчет (с группировками) в 1С. Затем программно сохранил бы его на диске (с расширением .xls), а потом открыл бы его, если надо в Екселе.
Такая технология устроит?
29. Сергей Федоров (Bober777) 11.01.12 14:48
(28) к сожалению нет, но что поделать значит самому придется копать)
30. Alexandr Zaslavskiy (Imm) 12.01.12 04:07
Автору респект. Очень пригодилолсь
31. Alexandr Zaslavskiy (Imm) 12.01.12 04:17
32. Макс Такойто (Maks888) 12.01.12 09:14
33. Максим Костиков (mkostya) 12.01.12 11:40
Есть такая ошибка возможно не только у меня. Нарушается порядок страниц. Например я печатаю 3 страницы 3 раза. Он печатает 3 раза первую, 3 раза вторую и три раза третью. Как с этим можно бороться?
34. Ю М (mtv:)) 12.01.12 12:07
(33) mkostya, А если в диалоге печати поставить галку "Разобрать по копиям", то помогает?
35. Антон Степанов (Stepa86) 12.01.12 13:27
Для упр. режима часть кнопок доступна и так в командах: http://screencast.com/t/1li9LmsU0A

Кнопку переоткрыть я вот так набросал:

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	
	Если Не ЗначениеЗаполнено( Параметры.ПутьКФайлу ) Тогда
		
		Параметры.ПутьКФайлу = ПутьКОтчету();
		
	КонецЕсли;
	
КонецПроцедуры

Функция ПутьКОтчету()
	
	Возврат РеквизитФормыВЗначение( "Отчет" ).ИспользуемоеИмяФайла;
	
КонецФункции



Функция ПолучитьИмяОтчета( адрес )
	
	Возврат ВнешниеОтчеты.Подключить(адрес);
	
КонецФункции

&НаКлиенте
Процедура Переоткрыть(Команда)
	
	адрес = "";
	
	Если ПоместитьФайл(адрес, Параметры.ПутьКФайлу, , Ложь ) Тогда
		
		Если Открыта() Тогда
			
			Закрыть();
			
		КонецЕсли;
		
		ОткрытьФорму("ВнешнийОтчет."+ ПолучитьИмяОтчета( адрес ) +".Форма", Новый Структура( "ПутьКФайлу", Параметры.ПутьКФайлу ));
		
	КонецЕсли;
	
КонецПроцедуры
...Показать Скрыть


где параметр ПутьКФайлу - ключевой. Чем заменить параметр не придумал, чтоб можно было без модификации формы обойтись.

Открыть в екселе почти так же выглядит:

&НаКлиенте
Процедура ОткрытьВЕкселе(Команда)
	
	#Если Не ВебКлиент Тогда
		
		ИмяФайла = ПолучитьИмяВременногоФайла( "xlsx" ) ;
		Результат.Записать( ИмяФайла, ТипФайлаТабличногоДокумента.XLSX );
		ЗапуститьПриложение( ИмяФайла );
		
	#КонецЕсли
	
КонецПроцедуры
...Показать Скрыть


для веб-клиента лень было получение временного файла писать

кнопку замера можно переписать используя подсистему "Замер производительности" из БСП, точность там до тысячных секунды

кнопки группировки не получится такими прям сделать, а их обработчик почти такой же

для отправки на почту в БСП есть подсистема "РаботаСПочтовымиСообщениями" куда можно так же приложить файлик
u_n_k_n_o_w_n; item; JohnyDeath; mtv:); +4 Ответить 1
37. Александр Иванов (fap82) 13.01.12 10:09
Очень полезно - спасибо.
39. Дмитрий Переверзев (webdimon) 14.01.12 00:36
Еще бы прикрепить к этому делу библиотеку картинок, та что от 1С.
40. Ю М (mtv:)) 14.01.12 09:04
(39) webdimon, извини, не понял твоё пожелание: "...прикрепить к этому делу библиотеку картинок, та что от 1С".
Можно по-подробнее?
41. Igor Emelyanenkov (IEmelya) 15.01.12 21:33
42. Михаил Н (Mig_Alm) 16.01.12 13:47
Судя по описанию обработка нужная. Как накоплю денег - сразу качну. Плюсик тебе!
43. Maxim (Trofimov_M) 16.01.12 17:10
Переоткрыть - реально необходимая вещь, жаль раньше о ней не знал.
Спасибо, оч пригожилось
44. Олег Василевский (OlegrVasil) 18.01.12 11:17
Жалко, что у меня не получается к разным отчётам и докам прикрепить. А так...Интересная статистика)
45. Ю М (mtv:)) 18.01.12 11:23
(44) OlegrVasil, извини, не понял, что не получается прикрепить к отчетам и докам? Поясни, если не трудно... :)
46. jojo nll (nll.jojo) 19.01.12 14:16
47. jojo nll (nll.jojo) 19.01.12 14:17
спасибо... очень удобно все
48. Cергей Филиппов (cpm-classica@mail.ru) 23.01.12 11:45
49. Ю М (mtv:)) 23.01.12 11:49
(48) cpm-classica@mail.ru, если будут новые идеи, то обязательно дополню публикацию.
51. Елена (elena_77) 23.01.12 18:30
Интересные вещи. Пригодидись. Интересная кнопка переоткрыть. Спасибо. Тебе плюсик.
52. Сергей Зобнин (Zoba) 24.01.12 00:05
Спасибо. Оч полезная вещь.
53. Кирилл Крутиков (Редкий Гад) 24.01.12 09:52
54. Александр Кузяшин (white125) 25.01.12 02:07
55. Александр Кузяшин (white125) 25.01.12 02:07
пополняться коллекция будет?
56. Иван Дерябин (ivan_83) 25.01.12 09:01
Спасибо. Кнопочки "Переоткрыть" для отладки внешних обработок очень не хватало))
57. Алексей Матросов (alexism) 26.01.12 10:50
Переоткрыть - реально необходимая вещь, жаль раньше о ней не знал.
Спасибо, очень и очень пригодилась. Буду тестировать на своих обработках.
В общем - автору - большой респект и увеличение коллекции )
58. Александр Гарькин (agarkin) 26.01.12 17:53
59. Программулькин (Программулькин) 27.01.12 10:31
есть ещё идеи для управляемого приложения?
60. Ю М (mtv:)) 27.01.12 10:39
(59) пока нету... Как только будут, так сразу же опубликую.
61. Программулькин (Программулькин) 27.01.12 10:53
Жаль, очень хочется для управляемого приложения, хотя бы "переоткрыть".
В принципе коллекция нужная. Молодец.
62. Ю М (mtv:)) 27.01.12 11:06
(61) Так кнопка "Переоткрыть" для управляемого приложения есть в http://infostart.ru/public/96548/. Посмотри там...
Программулькин; +1 Ответить
63. Программулькин (Программулькин) 27.01.12 11:46
спасибо, но всё-равно жду от тебя твои кнопки конвертированные для управляемого приложения.
65. Ирек Бикмухаметов (xbic) 28.01.12 07:54
66. Алексей Гришков (asg1975) 30.01.12 09:56
Присоединяюсь к вышенаписанным респектам. Забираем в копилку полезностей!
67. Марина (hmv59) 30.01.12 10:20
И для меня весьма актуально!
68. Dima Dr. (Scukosan) 30.01.12 11:13
в последнее время часто стал писать различные отчетики, так что заберу)
из пожеланий кнопку предварительного просмотра отчета бы)
69. Ю М (mtv:)) 30.01.12 11:49
(68) Scukosan, кнопку "Предварительного просмотра" добавить скорее всего не получится, т.к. стандартных средств 1С недостаточно.
Эта кнопка вообще-то и так присутствует в Стандартной панели. Хотя надо подумать...
70. Роман Узьмов (RomanUzmov) 31.01.12 08:53
Отличная коллекция! Автору (+)
71. Vladislav Chaplygin (tchvlad) 31.01.12 11:44
Очень интересное решение, позновательно, спасибо
72. Alina Krasnova (alice500) 31.01.12 18:06
73. Ionmuerto 01.02.12 12:33
Для веб клиента не подойдет? Туда бы еще обработку табличных частей и обработку загрузки выгрузки в из Эксель.
74. Ю М (mtv:)) 01.02.12 18:26
(73) Ionmuerto, Я никогда не работал с управляемым приложением, поэтому, к сожалению, ни чем не могу помочь.
Посмотри в (35) от Stepa86, он покопал в этом направлении, может быть почерпнешь для себя что-нибудь полезное.
75. olga pt (pt_olga) 01.02.12 21:20
автору спасибо и за идею, и за её реализацию!
76. Александр Крынецкий (echo77) 02.02.12 06:45
Не хватает кнопок:
- "Открыть публикацию на infostart.ru" (с картинкой логотипа инфостарт)
- "Плюсануть за публикацию" (картинку тоже с инфостарт)
77. Ю М (mtv:)) 02.02.12 07:22
(76) echo77, Подчеркиваю, что это "Коллекция полезных кнопок и процедур".
А в чем полезность предложенных тобой кнопок - не пойму. :) Без обид...
Хотя, добавить их можно без проблем.
79. Александр Крынецкий (echo77) 02.02.12 18:17
Добавьте пожалуйста.
Еще мне кажется, будет полезной функция, возвращающая сумму выделенных ячеек табличного документа.
Я бухгалтерам добавил эту функкциональность в свои отчеты - они были очень довольны.

Процедура РезультатПриАктивизацииОбласти(Элемент)

    НадписьСумма = "Сумма: " + ВычислитьСуммуВыделенныхЯчеекТабличногоДокумента(ЭлементыФормы.Результат)

КонецПроцедуры

Функция ВычислитьСуммуВыделенныхЯчеекТабличногоДокумента(ПолеТабличногоДокумента) Экспорт

    Сумма = 0;
    Для Каждого Область Из ПолеТабличногоДокумента.ВыделенныеОбласти Цикл
        Если ТипЗнч(Область) = Тип("ОбластьЯчеекТабличногоДокумента") Тогда
            Для ИндексСтрока = Область.Верх По Область.Низ Цикл
                Для ИндексКолонка = Область.Лево По Область.Право Цикл
                    Попытка
                        Сумма = Сумма + Число(СтрЗаменить(ПолеТабличногоДокумента.Область("R" + Формат(ИндексСтрока, "ЧГ=0") + "C" + Формат(ИндексКолонка, "ЧГ=0")) .Текст, " ", ""));
                    Исключение
                    КонецПопытки;
                КонецЦикла;
            КонецЦикла;
        КонецЕсли;
    КонецЦикла;

    Возврат Сумма;

КонецФункции
...Показать Скрыть
80. Ю М (mtv:)) 02.02.12 19:01
(79) echo77, согласен, функция полезная. Надо будет добавить.
81. Николай Зуев (zuevnp) 04.02.12 13:31
82. Александр Гарькин (agarkin) 05.02.12 12:30
83. Sergey Anisimov (Sean1s) 05.02.12 18:56
84. Сергей Серебренников (SSO) 06.02.12 12:23
Очень хорошее решение. Полезно и наглядно. Спасибо.
85. Алексей Фурманов (Aleksey-29) 06.02.12 15:41
Вот как только денежек накоплю сразу скачаю, а пока только читаю комментарии ... :(
86. Александр Топольский (AlexanderKai) 07.02.12 16:51
Да, иногда такие кнопки нужны в хозяйстве. Попозже скачаю.
87. Maksim (Massimo) 08.02.12 12:25
Автору однозначно плюс! Понравилась кнопка "Переоткрыть" полезная вне всякого сомненя - теперь вставляю ее везде... (открыл для себя много полезной информации) побольше бы таких публикаций.
88. Rino (Rino) 08.02.12 12:25
Автору респект. То, что искал
89. Yalo (yalo) 08.02.12 13:30
спасибо, пригодилось для собственной обработки
90. StronG-X (Dethmond) 08.02.12 14:04
Очень нужная вещь, большое спасибо)))
92. Евгений L (laeg) 08.02.12 20:14
Автору +++! Кнопка Переоткрыть самая полезная оказалась, - теперь вставляю ее везде...
93. v_id (v_id) 28.02.12 16:23
Спасибо, список полезностей пригодился. Автосумма кандидат на включение.
94. Ю М (mtv:)) 18.03.12 10:03
Опубликовал новую версию 2.02

Изменения:
+ Добавлена группа кнопок для управления Периодом;
+ Добавлены процедуры для отображения трех индикаторов процесса;
+ Добавлена процедура для подсчета суммы выделенных ячеек в отчете:

Подробности на странице публикации.
95. Александр Кривошеев (magvay_k) 20.03.12 13:46
Спасибо большое, пригодилось!
96. Андрей (Ejnar) 21.03.12 23:22
Спасибо! полезная информация и вся по делу, очень понравилось, подчеркнул для себя много нового - надеюсь еще будут пополнения.
Для разработчики было бы полезным добавить автосумму в отчеты.
97. Dmitriy (daho) 22.03.12 07:00
Спасибо!!! Да не помешало б и для для тонкого клиента доделать.!
98. Ю М (mtv:)) 22.03.12 07:18
(96) Ejnar, спасибо за отзыв, очень приятно.
Только не понял, что ты подразумеваешь под "автосуммой". Объясни по-подробнее, пожалуйста.

Процедура для подсчета суммы выделенных ячеек в отчете - это не оно?
99. Андрей (Ejnar) 22.03.12 15:33
(98) mtv:), Извиняюсь, о печатался в последнем предложении - именно о процедуре Процедура для подсчета суммы выделенных ячеек в отчете - шла речь. Просто хотелось бы что бы эту идею подчеркнули для себя разработчики конфигураций и в будущем включили ее в стандартные отчеты.
100. Ольга Зверькова (Lyuba-Lyuba) 03.04.12 14:22
Классно, классно! Ждем для тонкого!
101. Игорь Смирнов (MrVesna) 03.04.12 23:47
Пригодится не только для будущих отчетов и форм, но и для расширения знаний и кругозора.
102. Альтаир (Altair777) 04.04.12 11:21
Скачал, попробовал. Почти понравилось :)

Есть замечание по поводу кнопок управления группировками. Тулить процедуру их генерации в каждый отчет не есть хорошо. Перепишите процедуру для общего модуля, как это сделал я. Только для этого ей нужно передавать 2 параметра - форму и поле табличного документа.

Кстати, я ее еще доделал на случай нескольких табличных документов на форме - для каждой формируется своя ссылка на действие СвернутьДоУровня. Вот только к сожалению, не удалось эту процедуру перенести в общий модуль потому что действие кнопки требует процедуру обработки нажатия только в модуле формы.
103. Ю М (mtv:)) 05.04.12 05:40
(102) Altair777,
Прочитал ваш комментарий, почти согласен :)

Ваше предложение переписать процедуру для общего модуля подойдет не для всех. Знаю много контор, где категорически против внесения любых изменений в конфигурацию. А те, кто правит свою конфигурацию, думаю сами смогут чуть поправить процедуру для переноса ее в общий модуль. Кстати у меня в рабочей базе так и сделано - в общем модуле. И несколько табличных документов на форме тоже обрабатываются.

В публикации основная идея и простая рабочая отлаженная процедура, для простого и быстрого переноса в новые отчеты. А кто захочет, думаю, допилит сам. Там ничего сложного нет. Да и вы в своем комментарии дали остальным хорошую подсказку, как можно усовершенствовать процедуру, спасибо.
SirYozha; Altair777; +2 Ответить 1
104. Альтаир (Altair777) 05.04.12 10:23
(103) mtv:),
для простого и быстрого переноса в новые отчеты

Для простого и быстрого переноса мне пришлось тоже править отчет :)
Дело в том, что кнопки из командной панели копипастятся только в командную панель. А если надо на форму? Только руками.
Вот я и сделал еще одну форму, где кнопки на форме.

P.S. сорри за тавтологию. Но это еще фигня по сравнению с перлами от 1С.

Кроме того, в 1С:Предприятии 8 для манипулирования типами используются не их строковые наименования, а специальный тип "Тип". Значение типа Тип может быть получено функцией Тип(), получающей в качестве параметра имя типа.
Чтобы проверить тип значения переменной нужно определить ее тип функцией ТипЗнч() и использовать функцию Тип() для получения типа по имени.
altu71; mtv:); +2 Ответить
105. Филипп (Филипп) 10.04.12 14:45
Очень полезная вещь! Большое спасибо!
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа