Коллекция полезных кнопок и процедур для отчетов и обработок v3.00

Опубликовал mtv:) в раздел Программирование - Работа с интерфейсом

Собрал в одном месте полезные кнопки и процедуры, которые по мере необходимости можно использовать в своих разработках.

Коллекция полезных кнопок и процедур для отчетов и обработок

  Данный внешний отчет представляет собой коллекцию полезных кнопок и процедур, которые Вы можете использовать в своих разработках. Для этого надо лишь скопировать нужные кнопки и соответствующие им процедуры в разрабатываемую форму.

  Для каждой кнопки можно назначить сочетание клавиш, которое позволяет быстро выполнить выбранное действие (так называемые "Горячие клавиши").


  Эта кнопка прилично экономит время при разработке и отладке внешних отчетов и обработок. Позволяет одним нажатием закрыть текущую форму и тут же открыть её заново (со всеми внесенными изменениями). Идею почерпнул в публикации http://infostart.ru/public/96548/. Спасибо ShantinTD.


  Это подменю "Вывод копии..." содержит три кнопки:
  1. Кнопка "в Excel (.xls)" открывает сформированный отчет (табличный документ) в Microsoft Office Excel или Open Office Calc, т.е. в программе, которая ассоциирована для файлов с расширением .xls.
  2. Кнопка "в Adobe Reader (.pdf)" открывает сформированный отчет (табличный документ) в Adobe Reader или в другой программе, которая ассоциирована для файлов с расширением .pdf.
  3. Кнопка "в Табличный документ" открывает сформированный отчет (табличный документ) в другом отдельном Табличном документе.


  Эта кнопка позволит отправить по электронной почте сформированный отчет (табличный документ) через Microsoft Outlook.
Вызываемая процедура сохраняет отчет в файл с расширением .xls, подготавливает письмо с вложением сохраненного отчета и открывает в Outlook сформированное письмо.


  Кнопка "Зафиксировать" является аналогом кнопки из меню "Таблица > Вид > Зафиксировать таблицу". Для быстрого доступа к этой функции данная кнопка вынесена на командную панель. Кнопка фиксирует/расфиксирует строки и колонки таблицы слева и сверху от активной ячейки.


  Кнопка "Печать с выбором принтера" для распечатки сформированного отчета. Перед распечаткой открывается диалог печати для выбора принтера, диапазона страниц и количества копий.


  Кнопка "Печать сразу" для распечатки сформированного отчета. Печать происходит без вызова диалога печати (печать с текущими настройками).


  На этой сервисной кнопке отображается время, затраченное на формирование отчета. При нажатии на кнопку показания обнуляются.


  Программно-сгенерированные кнопки, для управления уровнями группировки в отчетах. Теперь сворачивать-разворачивать группировки стало намного удобнее и быстрее, чем стандартно, через контекстное меню. Количество кнопок соответствует количеству уровней группировки сформированного отчета.
  Использованы доработанные процедуры из публикации http://infostart.ru/public/83915/.


В версии 2.02 (от 17.03.2012) добавлено:


  Группа кнопок для управления Периодом. "Выбор периода...", "Предыдущий месяц", "Текущий месяц" и "Следующий месяц".

  Первая кнопка
открывает форму для удобного и быстрого выбора периода (см. скриншот №2). В этой форме одним кликом можно выбрать любой стандартный период: Год, Полугодие, Квартал, Месяц, День. А поле календаря (внизу формы) позволяет выбрать вообще любой период. Для этого помечаем мышкой дату начала периода, а затем с нажатой клавишей Shift дату конца периода, и нажимаем кнопку "Выбрать".
Для большей универсальности, предусмотрена кнопка вызова "Стандартного диалога выбора Периода" (сверху-справа).
Использована доработанная форма из публикации http://infostart.ru/public/90540/ от Adeptus.

  Вторая кнопка сдвигает интервал Периода по месяцам назад (в сторону уменьшения).

  Третья кнопка устанавливает интервал Периода равным текущему месяцу.

  Четвертая кнопка сдвигает интервал Периода по месяцам вперед (в сторону увеличения).


  Добавлены процедуры для отображения трех индикаторов процесса (см. скриншот №3):
  
  Первый - стандартный индикатор, можно разместить в любом месте формы отчета. Он виден только во время формирования отчета.

    Два других индикатора (СКД-шный и текстовый) отображаются в строке состояния приложения.

    За основу взяты процедуры из публикации "Индикатор процесса в строке состояния ... ?...!". Спасибо, Шёпот теней, Абадонна и Душелов.


  Добавлена процедура для подсчета суммы выделенных ячеек в отчете.
 
  Реализовано два способа отображения суммы.

  Первый способ - отображение в элементе управления "Надпись". Может располагаться в любом месте на форме отчета.

  Второй способ - отображение в сворачивающемся элементе управления "Поле ввода". Располагается в самом низу формы, под полем табличного документа. Скрывается, когда ничего не выделено. Плюсом этой реализации является то, что текст суммы выделенных ячеек можно скопировать в буфер обмена.

  Алгоритм корректно считает также и суммы в нескольких несмежных выделенных областях. За основу взяты процедуры из обработки "Универсальная консоль отчетов" от  Evg-Lylyk.


В версии 2.03 (от 17.10.2012) исправлена ошибка::


Исправлена ошибка в форме "Быстрого выбора стандартного рериода":
При выборе Второго полугодия (кнопка "II"), вместо периода "с 01.07.2012 по 31.12.2012" устанавливался период "с 01.06.2012 по 31.12.2012".

Можно не скачивать эту версию, а сделать маленькое исправление в предыдущей версии:

В модуле формы БыстрыйВыборСтандартногоПериода, в процедуре ПолугодиеНажатие
в строке:
    Период.НачалоПериода = Дата(ТекГод, ?(ПорядковыйНомер = 1, 1 ,6), 1);

надо "6" исправить на "7"; т.е. должно быть так:
    Период.НачалоПериода= Дата(ТекГод, ?(ПорядковыйНомер 1, 1 ,7), 1);


В версии 3.00 (от 10.08.2014) добавлено:


 

  1. Добавлена кнопка-меню "Вывод копии...":
    - В это меню перенесена кнопка "в Excel (.xls)" и добавлены кнопки "в Adobe Reader (.pdf)" и "в Табличный документ".

  2. Доработана процедура "ПоказатьСуммуВыделенныхЯчеек":  
    - Теперь сумма подсчитывается только в видимых ячейках (скрытые ячейки игнорируются).

  3. Переписана процедура "кнОткрытьВЭксель_Нажатие".

  4. В процедуре "кнПереоткрыть_Нажатие" устранен мелкий баг, описанный в комментарии (168) от artbear.


 

    Читайте встроенную справку, в которой находятся подробные описания кнопок и процедур, а также способ перенесения нужного функционала в свои обработки. Внимание: после нажатия кнопки "Переоткрыть" встроенная справка перестает открываться.

  Для демонстрации работы кнопок реализован простой отчет, который имеет самостоятельную ценность. Отчет показывает количетво Документов каждого вида, количество элементов каждого Справочника и количество записей каждого Регистра сведений. При двойном щелчке по наименованию открывается форма списка выбранного элемента.

  Внешний вид отчета показан на первом скриншоте.

Файлы

Наименование Файл Версия Размер Кол. Скачив.
КоллекцияКнопокИПроцедур(3_00).erf
.erf 51,00Kb
20.06.15
1961
.erf v3.00 51,00Kb 1961 Скачать

См. также

Лучшие комментарии

35. Stepa86 (файл скачал) 12.01.2012 13:27
Для упр. режима часть кнопок доступна и так в командах: http://screencast.com/t/1li9LmsU0A

Кнопку переоткрыть я вот так набросал:

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	
	Если Не ЗначениеЗаполнено( Параметры.ПутьКФайлу ) Тогда
		
		Параметры.ПутьКФайлу = ПутьКОтчету();
		
	КонецЕсли;
	
КонецПроцедуры

Функция ПутьКОтчету()
	
	Возврат РеквизитФормыВЗначение( "Отчет" ).ИспользуемоеИмяФайла;
	
КонецФункции



Функция ПолучитьИмяОтчета( адрес )
	
	Возврат ВнешниеОтчеты.Подключить(адрес);
	
КонецФункции

&НаКлиенте
Процедура Переоткрыть(Команда)
	
	адрес = "";
	
	Если ПоместитьФайл(адрес, Параметры.ПутьКФайлу, , Ложь ) Тогда
		
		Если Открыта() Тогда
			
			Закрыть();
			
		КонецЕсли;
		
		ОткрытьФорму("ВнешнийОтчет."+ ПолучитьИмяОтчета( адрес ) +".Форма", Новый Структура( "ПутьКФайлу", Параметры.ПутьКФайлу ));
		
	КонецЕсли;
	
КонецПроцедуры
...Показать Скрыть


где параметр ПутьКФайлу - ключевой. Чем заменить параметр не придумал, чтоб можно было без модификации формы обойтись.

Открыть в екселе почти так же выглядит:

&НаКлиенте
Процедура ОткрытьВЕкселе(Команда)
	
	#Если Не ВебКлиент Тогда
		
		ИмяФайла = ПолучитьИмяВременногоФайла( "xlsx" ) ;
		Результат.Записать( ИмяФайла, ТипФайлаТабличногоДокумента.XLSX );
		ЗапуститьПриложение( ИмяФайла );
		
	#КонецЕсли
	
КонецПроцедуры
...Показать Скрыть


для веб-клиента лень было получение временного файла писать

кнопку замера можно переписать используя подсистему "Замер производительности" из БСП, точность там до тысячных секунды

кнопки группировки не получится такими прям сделать, а их обработчик почти такой же

для отправки на почту в БСП есть подсистема "РаботаСПочтовымиСообщениями" куда можно так же приложить файлик
Ответили: (74)
# Ответить
161. Nuuq (файл скачал) 14.02.2013 11:41
Кнопка "Предварительный просмотр"
Скрытый текст
Ответили: (162)
+ 3 [ Al-X; mtv:); artbear; ]
# Ответить
103. mtv:) 05.04.2012 05:40
(102) Altair777,
Прочитал ваш комментарий, почти согласен :)

Ваше предложение переписать процедуру для общего модуля подойдет не для всех. Знаю много контор, где категорически против внесения любых изменений в конфигурацию. А те, кто правит свою конфигурацию, думаю сами смогут чуть поправить процедуру для переноса ее в общий модуль. Кстати у меня в рабочей базе так и сделано - в общем модуле. И несколько табличных документов на форме тоже обрабатываются.

В публикации основная идея и простая рабочая отлаженная процедура, для простого и быстрого переноса в новые отчеты. А кто захочет, думаю, допилит сам. Там ничего сложного нет. Да и вы в своем комментарии дали остальным хорошую подсказку, как можно усовершенствовать процедуру, спасибо.
Ответили: (104)
+ 2 [ SirYozha; Altair777; ]
# Ответить
104. Altair777 (файл скачал) 05.04.2012 10:23
(103) mtv:),
для простого и быстрого переноса в новые отчеты

Для простого и быстрого переноса мне пришлось тоже править отчет :)
Дело в том, что кнопки из командной панели копипастятся только в командную панель. А если надо на форму? Только руками.
Вот я и сделал еще одну форму, где кнопки на форме.

P.S. сорри за тавтологию. Но это еще фигня по сравнению с перлами от 1С.

Кроме того, в 1С:Предприятии 8 для манипулирования типами используются не их строковые наименования, а специальный тип "Тип". Значение типа Тип может быть получено функцией Тип(), получающей в качестве параметра имя типа.
Чтобы проверить тип значения переменной нужно определить ее тип функцией ТипЗнч() и использовать функцию Тип() для получения типа по имени.
+ 2 [ altu71; mtv:); ]
# Ответить
87. Massimo 08.02.2012 12:25
Автору однозначно плюс! Понравилась кнопка "Переоткрыть" полезная вне всякого сомненя - теперь вставляю ее везде... (открыл для себя много полезной информации) побольше бы таких публикаций.
+ 1 [ mtv:); ]
# Ответить

Комментарии

1. marsohod (файл скачал) 09.01.2012 07:02
Жаль, что только для толстого клиента.
Ответили: (3)
+ 1 [ w-divin; ]
# Ответить
2. Программулькин (файл скачал) 09.01.2012 13:28
есть возможность переделать для веб клиента?
Ответили: (3)
# Ответить
3. mtv:) 09.01.2012 13:39
(1)(2) Я никогда не работал с управляемым приложением, поэтому, к сожалению, ни чем не могу помочь.
Может найдутся спецы по управляемому приложению, и они смогут адаптировать... Мы бы сказали им огромное спасибо.
# Ответить
4. rom-x (файл скачал) 09.01.2012 13:49
А в 7-ке можно как-нибудь реализовать открытие таблицы в exel без записи файлов?
Ответили: (6) (32)
# Ответить
5. Uncore1989 (файл скачал) 09.01.2012 13:57
классный пост, автору большой плюс!
Ответили: (15)
# Ответить
6. valerka78 (файл скачал) 09.01.2012 14:02
Забрал, плюс :)
(4) rom-x, можно, поиск рулит.
Ответили: (7)
# Ответить
7. rom-x (файл скачал) 09.01.2012 14:26
(6) valerka78, а по конкретнее?
У кого какие соображения?
Ответили: (8)
# Ответить
8. valerka78 (файл скачал) 09.01.2012 14:35
(7) rom-x, http://infostart.ru/public/17464/ например.
Обсуждение в данной ветке прекращаем..
− 1 [ Altair777; ]
# Ответить
9. CheBurator 09.01.2012 17:08
ждем, когда в 8-ке появится такая удобная фишка как перехват любой открытой печатной формы (как в 7.7)...
Ответили: (10)
# Ответить
10. artbear (файл скачал) 09.01.2012 18:30
(9) Уже есть такая фича :)
Как обычно, расширения 1С ищем на сайте 1С++ - можно по моему нику :)
# Ответить
11. diarki 09.01.2012 21:40
Автору однозначно плюс! Понравилась кнопка "Переоткрыть" полезная вне всякого сомненя - теперь вставляю ее везде... (открыл для себя много полезной информации) побольше бы таких публикаций.
Ответили: (12) (15) (164)
+ 1 [ S.V.Y; ]
# Ответить
12. valerka78 (файл скачал) 09.01.2012 21:43
(11) diarki, +1, такая кнопка рулила и в 7.7 :) Насколько меньше лишних движений.
Ответили: (15)
# Ответить
13. ogeniv 10.01.2012 06:44
Супер, спасибо!
Ответили: (15)
# Ответить
14. Sam13 (файл скачал) 10.01.2012 09:53
Отлично. Полезно не только для использования, но и для расширения знаний. Особое спасибо за кнопки раскрытия группировок. Без них мучился.
Ответили: (15)
# Ответить
15. mtv:) 10.01.2012 10:50
(5)(11)(12)(13)(14) Спасибо за положительные отзывы, очень приятно. :)
Ответили: (16)
# Ответить
16. OlegrVasil (файл скачал) 10.01.2012 12:56
(15) mtv:), Спасибище огромное за разработку.
# Ответить
17. ludai 10.01.2012 13:29
Переоткрыть - хорошая идея, да))
Остальные кнопки пока не заценила, возможно, тоже полезно.
# Ответить
18. OlegrVasil (файл скачал) 10.01.2012 13:34
А можно ли настроить почту не на Outlook?
Ответили: (20)
# Ответить
19. dtitov 10.01.2012 19:22
Спасибо!!! Пригодиться
# Ответить
20. mtv:) 10.01.2012 21:07
(18) OlegrVasil, в данной разработке процедура для кнопки "Отправить" настроена на отправку почты через Outlook. Можно настроить и на подругому, но придется переписать процедуру.
Поиск тебе в помощь. Ссылок на Инфостарте много. К примеру вот ссылка -> Отправка почты из 1С.
# Ответить
21. Bober777 (файл скачал) 10.01.2012 22:45
А можно ли сделать пример для программного формирования файла с группировками в ёкселе.
Ответили: (24) (26)
# Ответить
22. Гость 10.01.2012 22:51
Прикольно , парадовала кнопка открытия в экселе и переоткрыть
# Ответить
23. VankaV 11.01.2012 09:55
Простенько и со вкусом.
Хорошо бы еще и для управляемого приложения ...
# Ответить
24. mtv:) 11.01.2012 10:34
(21) Bober777, я, к сожалению, не знаю, что такое "ёксель"... :)
Ответили: (27)
# Ответить
25. morpheus2 11.01.2012 11:13
Большое спасибо! Лично мне очень пригодится.
# Ответить
26. Bober777 (файл скачал) 11.01.2012 12:04
(21) это XLS - я его просто так зову...
# Ответить
27. Bober777 (файл скачал) 11.01.2012 12:39
(24) У меня есть вопрос может ты мне поможешь?
Хочу программно сформировать XLS документ с группировками (плюсиками)
Ответили: (28)
# Ответить
28. mtv:) 11.01.2012 14:01
(27) Bober777, Слету на твой вопрос ответить не смогу. А копать в этом направлении - просто нет пока времени. Извини.
Я бы твою задачу по быстрому решил так: Сформировал нужный отчет (с группировками) в 1С. Затем программно сохранил бы его на диске (с расширением .xls), а потом открыл бы его, если надо в Екселе.
Такая технология устроит?
Ответили: (29)
# Ответить
29. Bober777 (файл скачал) 11.01.2012 14:48
(28) к сожалению нет, но что поделать значит самому придется копать)
# Ответить
30. Imm 12.01.2012 04:07
Автору респект. Очень пригодилолсь
# Ответить
31. Imm 12.01.2012 04:17
Пригодится. +1 автору
# Ответить
32. Maks888 12.01.2012 09:14
(4) rom-x, можно =)
# Ответить
33. mkostya (файл скачал) 12.01.2012 11:40
Есть такая ошибка возможно не только у меня. Нарушается порядок страниц. Например я печатаю 3 страницы 3 раза. Он печатает 3 раза первую, 3 раза вторую и три раза третью. Как с этим можно бороться?
Ответили: (34)
# Ответить
34. mtv:) 12.01.2012 12:07
(33) mkostya, А если в диалоге печати поставить галку "Разобрать по копиям", то помогает?
# Ответить
35. Stepa86 (файл скачал) 12.01.2012 13:27
Для упр. режима часть кнопок доступна и так в командах: http://screencast.com/t/1li9LmsU0A

Кнопку переоткрыть я вот так набросал:

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	
	Если Не ЗначениеЗаполнено( Параметры.ПутьКФайлу ) Тогда
		
		Параметры.ПутьКФайлу = ПутьКОтчету();
		
	КонецЕсли;
	
КонецПроцедуры

Функция ПутьКОтчету()
	
	Возврат РеквизитФормыВЗначение( "Отчет" ).ИспользуемоеИмяФайла;
	
КонецФункции



Функция ПолучитьИмяОтчета( адрес )
	
	Возврат ВнешниеОтчеты.Подключить(адрес);
	
КонецФункции

&НаКлиенте
Процедура Переоткрыть(Команда)
	
	адрес = "";
	
	Если ПоместитьФайл(адрес, Параметры.ПутьКФайлу, , Ложь ) Тогда
		
		Если Открыта() Тогда
			
			Закрыть();
			
		КонецЕсли;
		
		ОткрытьФорму("ВнешнийОтчет."+ ПолучитьИмяОтчета( адрес ) +".Форма", Новый Структура( "ПутьКФайлу", Параметры.ПутьКФайлу ));
		
	КонецЕсли;
	
КонецПроцедуры
...Показать Скрыть


где параметр ПутьКФайлу - ключевой. Чем заменить параметр не придумал, чтоб можно было без модификации формы обойтись.

Открыть в екселе почти так же выглядит:

&НаКлиенте
Процедура ОткрытьВЕкселе(Команда)
	
	#Если Не ВебКлиент Тогда
		
		ИмяФайла = ПолучитьИмяВременногоФайла( "xlsx" ) ;
		Результат.Записать( ИмяФайла, ТипФайлаТабличногоДокумента.XLSX );
		ЗапуститьПриложение( ИмяФайла );
		
	#КонецЕсли
	
КонецПроцедуры
...Показать Скрыть


для веб-клиента лень было получение временного файла писать

кнопку замера можно переписать используя подсистему "Замер производительности" из БСП, точность там до тысячных секунды

кнопки группировки не получится такими прям сделать, а их обработчик почти такой же

для отправки на почту в БСП есть подсистема "РаботаСПочтовымиСообщениями" куда можно так же приложить файлик
Ответили: (74)
# Ответить
37. fap82 13.01.2012 10:09
Очень полезно - спасибо.
# Ответить
39. webdimon 14.01.2012 00:36
Еще бы прикрепить к этому делу библиотеку картинок, та что от 1С.
Ответили: (40)
# Ответить
40. mtv:) 14.01.2012 09:04
(39) webdimon, извини, не понял твоё пожелание: "...прикрепить к этому делу библиотеку картинок, та что от 1С".
Можно по-подробнее?
# Ответить
41. IEmelya 15.01.2012 21:33
Спасибо!
Очень кстати.
# Ответить
42. Mig_Alm (файл скачал) 16.01.2012 13:47
Судя по описанию обработка нужная. Как накоплю денег - сразу качну. Плюсик тебе!
# Ответить
43. Trofimov_M (файл скачал) 16.01.2012 17:10
Переоткрыть - реально необходимая вещь, жаль раньше о ней не знал.
Спасибо, оч пригожилось
# Ответить
44. OlegrVasil (файл скачал) 18.01.2012 11:17
Жалко, что у меня не получается к разным отчётам и докам прикрепить. А так...Интересная статистика)
Ответили: (45)
# Ответить
45. mtv:) 18.01.2012 11:23
(44) OlegrVasil, извини, не понял, что не получается прикрепить к отчетам и докам? Поясни, если не трудно... :)
# Ответить
46. nll.jojo 19.01.2012 14:16
удобно оч
# Ответить
47. nll.jojo 19.01.2012 14:17
спасибо... очень удобно все
# Ответить
48. cpm-classica@mail.ru 23.01.2012 11:45
а будут пополняться?
Ответили: (49)
# Ответить
49. mtv:) 23.01.2012 11:49
(48) cpm-classica@mail.ru, если будут новые идеи, то обязательно дополню публикацию.
# Ответить
51. elena_77 23.01.2012 18:30
Интересные вещи. Пригодидись. Интересная кнопка переоткрыть. Спасибо. Тебе плюсик.
# Ответить
52. Zoba (файл скачал) 24.01.2012 00:05
Спасибо. Оч полезная вещь.
# Ответить
53. Редкий Гад 24.01.2012 09:52
очень полезно
# Ответить
54. white125 25.01.2012 02:07
Автор молодец!
# Ответить
55. white125 25.01.2012 02:07
пополняться коллекция будет?
# Ответить
56. ivan_83 (файл скачал) 25.01.2012 09:01
Спасибо. Кнопочки "Переоткрыть" для отладки внешних обработок очень не хватало))
# Ответить
57. alexism 26.01.2012 10:50
Переоткрыть - реально необходимая вещь, жаль раньше о ней не знал.
Спасибо, очень и очень пригодилась. Буду тестировать на своих обработках.
В общем - автору - большой респект и увеличение коллекции )
# Ответить
58. agarkin 26.01.2012 17:53
норм!
# Ответить
59. Программулькин (файл скачал) 27.01.2012 10:31
есть ещё идеи для управляемого приложения?
Ответили: (60)
# Ответить
60. mtv:) 27.01.2012 10:39
(59) пока нету... Как только будут, так сразу же опубликую.
# Ответить
61. Программулькин (файл скачал) 27.01.2012 10:53
Жаль, очень хочется для управляемого приложения, хотя бы "переоткрыть".
В принципе коллекция нужная. Молодец.
Ответили: (62)
# Ответить
62. mtv:) 27.01.2012 11:06
(61) Так кнопка "Переоткрыть" для управляемого приложения есть в http://infostart.ru/public/96548/. Посмотри там...
# Ответить
63. Программулькин (файл скачал) 27.01.2012 11:46
спасибо, но всё-равно жду от тебя твои кнопки конвертированные для управляемого приложения.
# Ответить
65. xbic (файл скачал) 28.01.2012 07:54
Спасибо, очень надо
# Ответить
66. asg1975 (файл скачал) 30.01.2012 09:56
Присоединяюсь к вышенаписанным респектам. Забираем в копилку полезностей!
# Ответить
67. hmv59 30.01.2012 10:20
И для меня весьма актуально!
# Ответить
68. Scukosan 30.01.2012 11:13
в последнее время часто стал писать различные отчетики, так что заберу)
из пожеланий кнопку предварительного просмотра отчета бы)
Ответили: (69)
# Ответить
69. mtv:) 30.01.2012 11:49
(68) Scukosan, кнопку "Предварительного просмотра" добавить скорее всего не получится, т.к. стандартных средств 1С недостаточно.
Эта кнопка вообще-то и так присутствует в Стандартной панели. Хотя надо подумать...
# Ответить
70. RomanUzmov 31.01.2012 08:53
Отличная коллекция! Автору (+)
# Ответить
71. tchvlad 31.01.2012 11:44
Очень интересное решение, позновательно, спасибо
# Ответить
72. alice500 31.01.2012 18:06
спасибо
# Ответить
73. Ionmuerto 01.02.2012 12:33
Для веб клиента не подойдет? Туда бы еще обработку табличных частей и обработку загрузки выгрузки в из Эксель.
Ответили: (74)
# Ответить
74. mtv:) 01.02.2012 18:26
(73) Ionmuerto, Я никогда не работал с управляемым приложением, поэтому, к сожалению, ни чем не могу помочь.
Посмотри в (35) от Stepa86, он покопал в этом направлении, может быть почерпнешь для себя что-нибудь полезное.
# Ответить
75. pt_olga (файл скачал) 01.02.2012 21:20
автору спасибо и за идею, и за её реализацию!
# Ответить
76. echo77 (файл скачал) 02.02.2012 06:45
Не хватает кнопок:
- "Открыть публикацию на infostart.ru" (с картинкой логотипа инфостарт)
- "Плюсануть за публикацию" (картинку тоже с инфостарт)
Ответили: (77)
# Ответить
77. mtv:) 02.02.2012 07:22
(76) echo77, Подчеркиваю, что это "Коллекция полезных кнопок и процедур".
А в чем полезность предложенных тобой кнопок - не пойму. :) Без обид...
Хотя, добавить их можно без проблем.
# Ответить
79. echo77 (файл скачал) 02.02.2012 18:17
Добавьте пожалуйста.
Еще мне кажется, будет полезной функция, возвращающая сумму выделенных ячеек табличного документа.
Я бухгалтерам добавил эту функкциональность в свои отчеты - они были очень довольны.

Процедура РезультатПриАктивизацииОбласти(Элемент)

    НадписьСумма = "Сумма: " + ВычислитьСуммуВыделенныхЯчеекТабличногоДокумента(ЭлементыФормы.Результат)

КонецПроцедуры

Функция ВычислитьСуммуВыделенныхЯчеекТабличногоДокумента(ПолеТабличногоДокумента) Экспорт

    Сумма = 0;
    Для Каждого Область Из ПолеТабличногоДокумента.ВыделенныеОбласти Цикл
        Если ТипЗнч(Область) = Тип("ОбластьЯчеекТабличногоДокумента") Тогда
            Для ИндексСтрока = Область.Верх По Область.Низ Цикл
                Для ИндексКолонка = Область.Лево По Область.Право Цикл
                    Попытка
                        Сумма = Сумма + Число(СтрЗаменить(ПолеТабличногоДокумента.Область("R" + Формат(ИндексСтрока, "ЧГ=0") + "C" + Формат(ИндексКолонка, "ЧГ=0")) .Текст, " ", ""));
                    Исключение
                    КонецПопытки;
                КонецЦикла;
            КонецЦикла;
        КонецЕсли;
    КонецЦикла;

    Возврат Сумма;

КонецФункции
...Показать Скрыть
Ответили: (80)
+ 1 [ v_id; ]
# Ответить
80. mtv:) 02.02.2012 19:01
(79) echo77, согласен, функция полезная. Надо будет добавить.
# Ответить
81. zuevnp 04.02.2012 13:31
куууул :)
# Ответить
82. agarkin 05.02.2012 12:30
норм
# Ответить
83. Sean1s 05.02.2012 18:56
Автору "+". Полезно.
# Ответить
84. SSO 06.02.2012 12:23
Очень хорошее решение. Полезно и наглядно. Спасибо.
# Ответить
85. Aleksey-29 06.02.2012 15:41
Вот как только денежек накоплю сразу скачаю, а пока только читаю комментарии ... :(
# Ответить
86. AlexanderKai 07.02.2012 16:51
Да, иногда такие кнопки нужны в хозяйстве. Попозже скачаю.
# Ответить
87. Massimo 08.02.2012 12:25
Автору однозначно плюс! Понравилась кнопка "Переоткрыть" полезная вне всякого сомненя - теперь вставляю ее везде... (открыл для себя много полезной информации) побольше бы таких публикаций.
+ 1 [ mtv:); ]
# Ответить
88. Rino 08.02.2012 12:25
Автору респект. То, что искал
# Ответить
89. yalo 08.02.2012 13:30
спасибо, пригодилось для собственной обработки
# Ответить
90. StronG-X 08.02.2012 14:04
Очень нужная вещь, большое спасибо)))
# Ответить
92. laeg 08.02.2012 20:14
Автору +++! Кнопка Переоткрыть самая полезная оказалась, - теперь вставляю ее везде...
# Ответить
93. v_id (файл скачал) 28.02.2012 16:23
Спасибо, список полезностей пригодился. Автосумма кандидат на включение.
# Ответить
94. mtv:) 18.03.2012 10:03
Опубликовал новую версию 2.02

Изменения:
+ Добавлена группа кнопок для управления Периодом;
+ Добавлены процедуры для отображения трех индикаторов процесса;
+ Добавлена процедура для подсчета суммы выделенных ячеек в отчете:

Подробности на странице публикации.
+ 1 [ v_id; ]
# Ответить
95. magvay_k (файл скачал) 20.03.2012 13:46
Спасибо большое, пригодилось!
# Ответить
96. Ejnar (файл скачал) 21.03.2012 23:22
Спасибо! полезная информация и вся по делу, очень понравилось, подчеркнул для себя много нового - надеюсь еще будут пополнения.
Для разработчики было бы полезным добавить автосумму в отчеты.
Ответили: (98)
# Ответить
97. daho 22.03.2012 07:00
Спасибо!!! Да не помешало б и для для тонкого клиента доделать.!
# Ответить
98. mtv:) 22.03.2012 07:18
(96) Ejnar, спасибо за отзыв, очень приятно.
Только не понял, что ты подразумеваешь под "автосуммой". Объясни по-подробнее, пожалуйста.

Процедура для подсчета суммы выделенных ячеек в отчете - это не оно?
Ответили: (99)
# Ответить
99. Ejnar (файл скачал) 22.03.2012 15:33
(98) mtv:), Извиняюсь, о печатался в последнем предложении - именно о процедуре Процедура для подсчета суммы выделенных ячеек в отчете - шла речь. Просто хотелось бы что бы эту идею подчеркнули для себя разработчики конфигураций и в будущем включили ее в стандартные отчеты.
+ 1 [ mtv:); ]
# Ответить
100. Lyuba-Lyuba 03.04.2012 14:22
Классно, классно! Ждем для тонкого!
# Ответить
101. MrVesna (файл скачал) 03.04.2012 23:47
Пригодится не только для будущих отчетов и форм, но и для расширения знаний и кругозора.
# Ответить
102. Altair777 (файл скачал) 04.04.2012 11:21
Скачал, попробовал. Почти понравилось :)

Есть замечание по поводу кнопок управления группировками. Тулить процедуру их генерации в каждый отчет не есть хорошо. Перепишите процедуру для общего модуля, как это сделал я. Только для этого ей нужно передавать 2 параметра - форму и поле табличного документа.

Кстати, я ее еще доделал на случай нескольких табличных документов на форме - для каждой формируется своя ссылка на действие СвернутьДоУровня. Вот только к сожалению, не удалось эту процедуру перенести в общий модуль потому что действие кнопки требует процедуру обработки нажатия только в модуле формы.
Ответили: (103)
+ 1 [ mtv:); ]
# Ответить
103. mtv:) 05.04.2012 05:40
(102) Altair777,
Прочитал ваш комментарий, почти согласен :)

Ваше предложение переписать процедуру для общего модуля подойдет не для всех. Знаю много контор, где категорически против внесения любых изменений в конфигурацию. А те, кто правит свою конфигурацию, думаю сами смогут чуть поправить процедуру для переноса ее в общий модуль. Кстати у меня в рабочей базе так и сделано - в общем модуле. И несколько табличных документов на форме тоже обрабатываются.

В публикации основная идея и простая рабочая отлаженная процедура, для простого и быстрого переноса в новые отчеты. А кто захочет, думаю, допилит сам. Там ничего сложного нет. Да и вы в своем комментарии дали остальным хорошую подсказку, как можно усовершенствовать процедуру, спасибо.
Ответили: (104)
+ 2 [ SirYozha; Altair777; ]
# Ответить
104. Altair777 (файл скачал) 05.04.2012 10:23
(103) mtv:),
для простого и быстрого переноса в новые отчеты

Для простого и быстрого переноса мне пришлось тоже править отчет :)
Дело в том, что кнопки из командной панели копипастятся только в командную панель. А если надо на форму? Только руками.
Вот я и сделал еще одну форму, где кнопки на форме.

P.S. сорри за тавтологию. Но это еще фигня по сравнению с перлами от 1С.

Кроме того, в 1С:Предприятии 8 для манипулирования типами используются не их строковые наименования, а специальный тип "Тип". Значение типа Тип может быть получено функцией Тип(), получающей в качестве параметра имя типа.
Чтобы проверить тип значения переменной нужно определить ее тип функцией ТипЗнч() и использовать функцию Тип() для получения типа по имени.
+ 2 [ altu71; mtv:); ]
# Ответить
105. Филипп (файл скачал) 10.04.2012 14:45
Очень полезная вещь! Большое спасибо!
# Ответить
106. AlexZOne (файл скачал) 05.05.2012 12:36
Спасибо за проделанную работу :) Однозначно пригодится и сэкономит время.
# Ответить
107. GreenFox 10.05.2012 12:48
Спасибо за проделанную работу и за идеи - особенно за переоткрыть ))) - помоему даная фича тут многим понравилась.
+ 1 [ LaNaite; ]
# Ответить
108. electronik 16.05.2012 11:02
Спасибо есть над чем подумать и поработать. Автору респект и уважение. Будем пробовать и тестировать. Так держать заслуженое 5++++ за труд
# Ответить
109. LaNaite (файл скачал) 18.05.2012 12:42
Gracias!)
# Ответить
110. kievanton 30.05.2012 12:04
Красота! Спасибо!
# Ответить
111. _LEV_ (файл скачал) 30.05.2012 14:19
Спасибо. Попробуем поюзать полезняшки..
# Ответить
112. olegtymko (файл скачал) 02.06.2012 17:04
Не плохо))) спасибо автору за сборку, очень пригодиться)
# Ответить
113. mjane (файл скачал) 05.06.2012 16:34
прикольная штука!!
# Ответить
114. link_l (файл скачал) 06.06.2012 08:56
К кнопке "Переоткрыть" можно добавить возможность сохранения значений реквизитов в xml перед закрытием формы и при открытии загружать =) может уже предлагали выше, все комменты не читал =) себе сделал такую фичу используя публикацию http://infostart.ru/public/99526/
Ответили: (117)
# Ответить
115. ilonnaa (файл скачал) 06.06.2012 12:48
Очень полезная вещь! Большое спасибо!
А есть уже переделанная для управляемого приложения?
Ответили: (116)
# Ответить
116. mtv:) 06.06.2012 13:27
(115) ilonnaa,
Для управляемого приложения у меня нет, к сожалению, т.к. я не работаю с ним (не было необходимости).
# Ответить
117. mtv:) 06.06.2012 13:28
(114) link_l,
Спасибо, интересное предложение - надо подумать... :)
Ответили: (118)
# Ответить
118. link_l (файл скачал) 06.06.2012 13:49
(117) mtv:), у меня бывают случаи когда кучу всяких настроек сделаешь выберешь нужные данные запускаешь и бац какая то ошибка в коде =) приходится все закрывать, снова открывать и снова кучу данных вводить %)

я просто взял процедуры http://infostart.ru/public/99526/ и воткнул их перед закрытием формы и после открытия. xml файл сохраняю в "КаталогВременныхФайлов();" с именем обработки и после загрузки удаляю. И строчку из переоткрытия изменил:
ВнешниеОбработки.Создать(ЭтотОбъект.ИспользуемоеИмяФайла).ПолучитьФорму(МетаФорма.Имя).Открыть();

разделил на две:
Об = ВнешниеОбработки.Создать(ЭтотОбъект.ИспользуемоеИмяФайла);
Об.ПолучитьФорму(МетаФорма.Имя).Открыть();

единственный момент при сохранении в xml выдает ошибку если есть тип значения "Список значений". с xml вообще недавно столкнулся, в чем причина пока не понял...
# Ответить
119. ilonnaa (файл скачал) 06.06.2012 14:57
надо в свободное время попробовать сделать все тожесамое только для управляемого)
# Ответить
121. kalach2002 (файл скачал) 07.06.2012 00:07
Благодарю,
ценные полезности.
Воспользовался : xls, mail & sum - то что надо!
# Ответить
122. Bezeus 08.06.2012 13:48
Я вот думаю, а может все поскидывают подобные полезности автору, а он их включит в свой сборник, если посчитает полезностью? Пороюсь среди своих решений. Если найду что-то более-менее полезное, то отправлю. Создадим "групповую библиотеку ничтяков"?
Ответили: (124)
# Ответить
123. LaNaite (файл скачал) 08.06.2012 13:52
После активного пользования, хочу передать Вам большое человеческое спасибо!))
Ответили: (125)
# Ответить
124. mtv:) 08.06.2012 19:10
(122) Bezeus,
А что, по-моему идея хорошая. Можно попробовать. Может что-нибудь дельное и получится. :)
Только время свободное для этого получилось бы выкроить...
# Ответить
125. mtv:) 08.06.2012 19:11
(123) LaNaite, и все прокоментировавшие эту публикацию
Благодарю за отзывы. Очень приятно.
# Ответить
126. eigen20 11.06.2012 13:41
Спасибо вам большое. Вещь супер!!! Значительно экономит время при отладке.
# Ответить
127. Misanets (файл скачал) 12.06.2012 14:54
Если бы, была бы возможность поставил плюс еще раз, обязательно поставил. Публикацию можно назвать "Все гениальное просто" :)
# Ответить
128. DenisSF 12.06.2012 19:00
Для полного счастья бухгалтера, там не хватает кнопок "Расчитать как надо мне", "Расчитать как надо налоговой", "Расчитать правильно"... для декларации по прибыли например
Ответили: (129) (131)
# Ответить
129. mtv:) 12.06.2012 21:57
(128) DenisSF,
Хорошая идея :). Как только появится свободное время, так сразу же добавлю эти кнопки... ;)
# Ответить
130. ilonnaa (файл скачал) 13.06.2012 09:58
Борльшое спасибо! Очень полезно сэкономит кучу времени! Очобенно порадовала кнопка переоткрыть!
Планируется обновление, расширение функционала?
Ответили: (132)
# Ответить
131. ilonnaa (файл скачал) 13.06.2012 10:00
(128) DenisSF, ха-ха-ха!!!! А ещё такую кнопочку которая бы делала всю работу, часто просто просят) особенно там где много аналитики)
# Ответить
132. mtv:) 13.06.2012 11:38
(130) ilonnaa,
У меня пока нет новых идей для обновления и расширения функционала. Как только появятся - так сразу же добавлю.
Ответили: (133)
# Ответить
133. ilonnaa (файл скачал) 13.06.2012 12:24
(132) mtv:), ясно) будем ждать) Надеюсь идеи всетаки будут)
# Ответить
134. treedo 15.06.2012 22:14
Да, полезная вещичка... Я себе на подобе делал, хотел выложить, но не успел)))
# Ответить
135. Dnki 17.06.2012 23:35
Ай да жук! Это я по-доброму. Собрал в одной кучке чужие разработки и сорвал такой "+"!
Особенно мне люба "Выбор периода". Но я продублирую свой пост на страничке автора Adeptus
А как бы ее положение привязывать к элементу вызова? Как ВыбратьИзМеню(). Понимаете меня? форма открывается посреди экрана, не рядом с кнопкой.
Ответили: (136)
# Ответить
136. mtv:) 18.06.2012 06:13
(135) Dnki,
Ну, на счет: "Собрал в одной кучке чужие разработки..." вы явно погорячились.
В представленной коллекции, из 12-ти пунктов только 3 пункта выполнены на основе чужих разработок. И то, они прилично "допилены" и адаптированы мною.
# Ответить
137. commo 22.06.2012 13:23
спасибо за подборку. думаю пригодится.
# Ответить
138. zigomodo 29.06.2012 19:56
Самое нужное здесь-это переоткрыть)
# Ответить
139. arktika1 07.07.2012 17:55
Здравствуйте
Скажите я могу просто скачать эту разработку и получить описанные функцтоналы?
или их надо еще самостоятельно дописывать?
Ответили: (141)
# Ответить
140. mybracho (файл скачал) 07.07.2012 22:45
Больше всего понравились кнопки группировок. Для этого и качаем. Юзабилити. Спасибо
# Ответить
141. mtv:) 07.07.2012 23:41
(139) arktika1,
Представленная разработка - это сборник полезного функционала, который можно использовать в ваших разработках. Просто копируете в свою разработку нужные кнопки и соответствующие им процедуры. Подробности по каждой кнопке приведены во встроенной в обработку справке.
# Ответить
142. arktika1 08.07.2012 13:03
Спасибо за ответ
Хороший функционал
# Ответить
143. Release 13.07.2012 13:28
Замечательная подборка - "+" и спасибо.
# Ответить
144. arktika1 14.07.2012 19:02
Я все понял спасибо за Ваш комментарий
буду пользоваться.
# Ответить
145. SmokeAce 12.08.2012 20:51
Очень полезная сборка, спасибо! Повышение юзабилити всегда гуд)
+ 1 [ mtv:); ]
# Ответить
146. dwarkin (файл скачал) 15.08.2012 10:31
Очень хорошая сборка, особенно понравилась "Выбор периода..", респект от бухгалтеров :)
И раз пошла такая пьянка по идеям, кнопку "Отправить..." можно сделать раскрывающейся с отправкой по стандартным mail-агентам (изменение заголовка/картинки) и с настройкой, через ИнтернетПочта и ИнтернетПочтовыйПрофиль
+ 1 [ mtv:); ]
# Ответить
147. RainyAugust22 (файл скачал) 16.08.2012 08:24
спасибо! применим в новых отчетах:)
# Ответить
148. bulas (файл скачал) 21.08.2012 11:01
Полезная коллекция для работы.
# Ответить
149. Den_D (файл скачал) 29.08.2012 13:50
Большое спасибо за работу. Разработка интересна во всех отношениях. С огромным удовольствием буду ее использовать в собственной работе.
+ 1 [ mtv:); ]
# Ответить
150. Rad90210 19.09.2012 16:14
Да... период это что-то невообразимое...
Такое бы в типовые ...
# Ответить
151. sstar90 (файл скачал) 18.10.2012 10:40
Спасибо, нужная вещь
# Ответить
152. 1v7 (файл скачал) 21.10.2012 21:06
плюсую! достойная подборка.
# Ответить
153. webester (файл скачал) 23.10.2012 05:45
Взял, замечательный набор, мысль про кнопку с переоткрытием даже не приходила в голову
# Ответить
154. mzelensky (файл скачал) 02.11.2012 11:06
Прикольная штука +
# Ответить
155. shrek2 (файл скачал) 05.11.2012 11:39
Полезная вещь. Скачал бы, кабы SM хватало.
# Ответить
157. SergeyGladyshev 28.11.2012 11:45
Очень полезная коллекция, автору респект!
# Ответить
158. TrinitronOTV (файл скачал) 02.01.2013 11:08
спасибо большое за данный труд, пригодиться в освоении и работе на платформе 8.2
# Ответить
159. Xolli 28.01.2013 22:02
Автору респект. То, что искала
# Ответить
160. internetname 08.02.2013 14:38
Тонкий клиент не помешал бы.
# Ответить
161. Nuuq (файл скачал) 14.02.2013 11:41
Кнопка "Предварительный просмотр"
Скрытый текст
Ответили: (162)
+ 3 [ Al-X; mtv:); artbear; ]
# Ответить
162. mtv:) 16.02.2013 08:09
(161) Nuuq,
Спасибо за процедуру для Кнопки "Предварительный просмотр". Интересное решение.
Будет время - протестирую и включу в "Коллекцию", если ты не против... :)
# Ответить
163. Al-X (файл скачал) 13.06.2013 09:22
Спасибо. Пригодиться совсем скоро.
# Ответить
164. Vladal (файл скачал) 28.06.2013 19:03
(11) diarki, кнопка Переоткрыть существует в типовых дааааавным давно.
# Ответить
165. vladir (файл скачал) 09.07.2013 09:50
Отличная коллекция. Знаю о публикации уже давно, а скачать, все руки не доходили... Думаю, что пригодится. Спасибо!
# Ответить
167. chmv (файл скачал) 10.07.2013 13:42
Полезная вещь
# Ответить
168. artbear (файл скачал) 11.07.2013 12:09
(0) В процедуре Переоткрыть есть мелкий баг:
В доке 1С не написано, что метод ПолучитьФорму(МетаФорма) может возвращать неопределено в режиме обычного приложения, если есть не только обычная, но и управляемая форма
Поэтому нужно слегка поправить условие
ТекФорма = ПолучитьФорму(МетаФорма);
Если ТекФорма <> Неопределено И ТекФорма.Открыта() Тогда // добавил "ТекФорма <> Неопределено И"
Ответили: (169) (181)
+ 1 [ mtv:); ]
# Ответить
169. mtv:) 11.07.2013 12:21
(168) artbear, благодарю за сообщение об обнаруженном баге. Ситуация довольно редкая, но вполне может встретиться на практике.
Внесу ваше исправление в алгоритм процедуры.
# Ответить
170. dyak84 (файл скачал) 15.08.2013 18:09
спасибо за труд. Очень интересное собоание как раз того чего не хватает для работы, а туту все собрано и в одном месте. Економия времени и труда.Однозначно полезная штука. Жаль только денег нет как появятся обязательно скачаю.
# Ответить
171. azubar (файл скачал) 10.10.2013 18:46
простите за офтоп, но тут на инфостарте был еще одна обработка-шаблон, там были кнопки проверки обновлений версии обработки, ссылка на страницу обработке на инфостарте и т.п., не подскажите как ее найти? уже по всякому искал.
Ответили: (172)
# Ответить
172. mtv:) 10.10.2013 20:35
(171) azubar, наверное ты имел ввиду "Шаблон обработки (1.0 / 29.05.12 / CaSH)" или "Шаблон управляемой обработки"
Ответили: (173)
+ 1 [ azubar; ]
# Ответить
173. azubar (файл скачал) 11.10.2013 10:19
(172) mtv:), да, это оно, спасибо!
# Ответить
174. Evgen.Ponomarenko 11.10.2013 12:20
Классная библиотека!

Прикрепленные файлы:

Намек3.jpg
# Ответить
175. laduk 22.11.2013 10:31
Шикарная вещица, а то для простеньких обработок лень время тратить, а потом смотришь на не отвечающий процесс и думаешь завис или там просто много данных...
# Ответить
177. denis_aka_wolf (файл скачал) 03.04.2014 19:41
Автор молодец, спасибо
# Ответить
178. chmv (файл скачал) 01.07.2014 09:40
Спасибо Пару кнопок использую
# Ответить
179. KliMich 26.07.2014 06:01
Спасибо! Тут понадобились некоторые кнопки...
# Ответить
180. SemenovaMarinaV 31.07.2014 10:34
Некоторые успешно использую. Спасибо.
# Ответить
181. mtv:) 10.08.2014 19:48
Выложил новую версию v3.00(10.08.2014):
1. Добавлена кнопка-меню "Вывод копии...":
- В это меню перенесена кнопка "в Excel (.xls)" и добавлены кнопки "в Adobe Reader (.pdf)" и "в Табличный документ".
2. Доработана процедура "ПоказатьСуммуВыделенныхЯчеек":
- Теперь сумма подсчитывается только в видимых ячейках (скрытые ячейки игнорируются).
3. Переписана процедура "кнОткрытьВЭксель_Нажатие".
4. В процедуре "кнПереоткрыть_Нажатие" устранен мелкий баг, описанный в комментарии (168) от artbear.
+ 1 [ teflon; ]
# Ответить
182. sergei198821 (файл скачал) 21.08.2014 12:25
Очень хороший макет. Спасибо автору
# Ответить
184. LordPhoenix 24.10.2014 09:14
Полезная штука), делали на работе что то подобное)
# Ответить
185. SemenovaMarinaV 24.10.2014 17:22
Хотелось бы для упавляемого приложения
# Ответить
187. SemenovaMarinaV 08.12.2014 10:31
А для управляемого приложения планируется?
Ответили: (188)
# Ответить
188. mtv:) 09.12.2014 10:51
(187) SemenovaMarinaV, Для управляемого приложения пока не планируется... :(
# Ответить
189. DAnry (файл скачал) 10.12.2014 17:32
Класная вещь, рекомендую. Автору спасибо.
# Ответить
190. gigagr 10.12.2014 19:23
Однозначно полезная подборка кнопок - респект.
# Ответить
192. VladC# 03.07.2015 06:45
Что за "Переоткрыть", может "Обновить"?
# Ответить
193. denis_aka_wolf (файл скачал) 28.08.2015 13:50
Начал пользоваться.
Больше всего радует замер времени выполнения и переоткрытие.
# Ответить
194. SmokeAce 01.09.2015 22:46
Спасибо, однозначно плюс! По аналогии добавил бы еще кнопки горизонтальных группировок, наряду с вертикальными, как в Excell ))
Ответили: (195)
# Ответить
195. mtv:) 02.09.2015 06:55
(194) SmokeAce,
про кнопки горизонтальных группировок можно почитать в публикации http://infostart.ru/public/84642/
# Ответить
196. batyrkin (файл скачал) 09.03.2016 11:58
На платформе 8.3.7.1790 как ни бился, не смог сделать переоткрытие внешнего отчета в толстом клиенте с НЕ файловой базой.
Может у кого есть работающий код? Хочется посмотреть до чего же я не додумался...
# Ответить
Внимание! За постинг в данном форуме $m не начисляются.
Внимание! Для написания сообщения необходимо авторизоваться
Текст сообщения*
Прикрепить файл