gifts2017

Включение в ЗУП возможности выбирать тарифный разряд из справочника "Тарифные разряды" для вида расчета "Оплата по производственным нарядам"

Опубликовал Сергей (Seregalink) в раздел Программирование - Практика программирования

Включение в ЗУП возможности выбирать тарифный разряд из справочника "Тарифные разряды" для вида расчета "Оплата по производственным нарядам"

На многих предприятиях использующих сдельные наряды, для вида расчета "Оплата по производственным на рядам", требуется выбирать тарифный разряд из справочника "Тарифный разряд", в типовом ЗУП для чего-то эту возможность отключили.

Для включения ее нужно, изменения для ЗУП 2.5.44.1 :

1) Включить флажок "Требуется ввод тарифного разряда", для это нужно добавить изменения в самом виде расчета

ПланВидовРасчета -> ОсновныеНачисленияОрганизаций -> Форма -> ФормаВидаРасчета ->

Форма -> Модуль -> Процедура ОпределитьДоступностьРеквизитов(),

изменения в архиве и помечены //Изменения+.... //Изменения-;

 
   

2) В общих модулях -> РаботаСДиалогамиЗК -> Функция СведенияОВидеРасчета, добавить некоторые изменения, после чего автоматом включается эта возможность в документах "ПриемНаРаботуВОрганизацию","КадровоеПеремещениеОрганизаций", "ВводСведенийОПлановыхНачисленияхРаботниковОрганизаций", "Сдельный наряд" и т.д.,

изменения в архиве и помечены //Изменения+.... //Изменения- .

 

Скачать файлы

Наименование Файл Версия Размер
Изменения в модулях 45
.zip 5,19Kb
15.01.12
45
.zip 5,19Kb Скачать

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Igоr Sаulеviсh (gutentag) 15.01.12 22:52
Имхо лучше внести изменения как внешняя обработка или внеш.печ.форма
2. Сергей (Seregalink) 16.01.12 21:14
Что как внешняя обработка или внешняя печатная форма? Это же не только включение галочки, а изменения для работы в режиме выбора тарифного разряда из справочника постоянно в тех местах, где это необходимо, как в типовом варианте, без всяких дополнительных внешних обработок и печатных форм.
3. aa aa (festiv1) 18.01.12 16:43
Добрый день! Не могли бы вы выслать данную обработку на altress@yandex.ru,а то скачать не получается. У нас как раз поднимался такой вопрос. Заранее большое спасибо!
4. aa aa (festiv1) 18.01.12 18:01
Скажите, а если у нас уже введены тарифные ставки(они у нас такие же по величине как и разряды), данные изменения сохранят ставки, или придется вручную вводить их
5. Сергей (Seregalink) 18.01.12 20:35
(4) festiv1, придется перебить или сделать обработку, которая сделает соответствие, например, с копии базы, где тарифные разряды еще просто числа со справочником "Тарифные разряды" в рабочей базе и проставит элементы справочника в вид расчета "Оплата по производственным нарядам". Но, например, у одного из клиентов разные тарифные разряды имеют одинаковые значения, это уже будет не однозначное соответствие.
6. aa aa (festiv1) 19.01.12 10:03
(5) Seregalink, У Вас случайно нет такой обработки? а то 300 человек перебить руками как то не очень хочется...
7. Сергей (Seregalink) 19.01.12 22:34
(6) festiv1, нет не нужно было этого делать, обычно клиенты сразу говорили, что им нужны тарифные разряды.
8. Анна Чикирева (StellaDeMare) 20.01.12 10:35
Вообще как я понимаю это частая практика, когда сдельщикам устанавливаются еще и тарифные разряды. Мы тоже много шаманили с тарифными ставками у сделки. Интересно почему в типовой функционал это не включают?
9. aa aa (festiv1) 20.01.12 13:00
А кто-нибудь пробовал писать в 1с? может если написать и не одному человеку то они включать данных функционал...
10. Сергей (Seregalink) 20.01.12 23:10
Я в ноябре 2011 года писал на форуме 1С по этому поводу, ответили что такие пожелания уже зарегистрированы. Пока в новых релизах изменений не внесено.
11. aa aa (festiv1) 25.01.12 15:43
(10) Seregalink, Скажите а как теперь сделать так чтобы при вводе документа "Кадровое перемещение" выбрать тарифный разряд было нельзя до тех пор как не поставишь в действии "ИЗМЕНИТЬ". У нас кадровики вечно об этом забывают, выбирают разряд, а действие оставляют "не изменять", а потом говорят что ничего не работает
12. Сергей (Seregalink) 25.01.12 23:37
Например в кадровом перемещении надо добавить следующие строки помечены //изменеия+ ... //изменения-

Процедура ОсновныеНачисленияПриПолученииДанных(Элемент, ОформленияСтрок)
	
	РаботаСДиалогамиЗК.ИсправлениеКадровыхДокументовПриПолученииДанных(ОформленияСтрок, мСотрудникиИсправление);
	
	РаботаСДиалогамиЗК.ЗаполнитьСведенияОВидахРасчетаОформляемыхСтрок(мСведенияОВидахРасчетаОснНачислений, ОформленияСтрок);
	
	Для Каждого ОформлениеСтроки Из ОформленияСтрок Цикл
		
		ДанныеСтроки = ОформлениеСтроки.ДанныеСтроки;
		
		РаботаСДиалогамиЗК.ПриВыводеСтрокиПлановыхНачислений(Элемент, ОформлениеСтроки, ДанныеСтроки, мСведенияОВидахРасчетаОснНачислений);
		
		ВидРасчета = ДанныеСтроки.ВидРасчета;
		
		СведенияОВидеРасчета = мСведенияОВидахРасчетаОснНачислений[ВидРасчета];
		КоличествоПоказателей = СведенияОВидеРасчета["КоличествоПоказателей"];
		
		Если ДанныеСтроки.Действие = Перечисления.ВидыДействияСНачислением.Начать ИЛИ
			ДанныеСтроки.Действие = Перечисления.ВидыДействияСНачислением.Изменить Тогда
			
			Для СчПоказателей = 1 По 6 Цикл
				Если СчПоказателей = 1 Или СчПоказателей <= КоличествоПоказателей Тогда
					ОформлениеСтроки.Ячейки["Показатель"+СчПоказателей].ТолькоПросмотр = НЕ СведенияОВидеРасчета["Показатель" + СчПоказателей + "Видимость"];
				КонецЕсли;
			КонецЦикла;
		Иначе
			Для СчПоказателей = 1 По 6 Цикл
				Если СчПоказателей = 1 Или СчПоказателей <= КоличествоПоказателей Тогда
					ОформлениеСтроки.Ячейки["Показатель"+СчПоказателей].ТолькоПросмотр = Истина;
					//Изменения+
					ОформлениеСтроки.Ячейки["ТарифныйРазряд"+СчПоказателей].ТолькоПросмотр = Истина;
					//Изменения-
				КонецЕсли;
			КонецЦикла;	
		КонецЕсли; 	
		
	КонецЦикла;
	
КонецПроцедуры
...Показать Скрыть
13. Ольга Доги (olgadogi) 26.01.12 14:28
Большое спасибо, все получилось, теперь хоть не надо по производственным нарядам вручную вводить сумму. И в сдельном наряде берет тариф нормально, жалко что там выбор в расценке по сумме, а не по тарифу и объему работ с итоговым расчетом.
15. aa aa (festiv1) 04.04.12 15:16
Seregalink, добрый день! После обновления ЗУП на версию 2.5.47.1 В общих модулях -> РаботаСДиалогамиЗК -> убрали функцию "СведенияОВидеРасчета" и пропали тафифрные разряды у сдельщиков. НЕ подскажите где поправить чтобы снова можно было бы использовать тарифные разряды для оплаты по сдельным нарядам?
16. Сергей (Seregalink) 05.04.12 08:50
Теперь это находится в В общих модулях -> ЗаполнениеДокументовЗК -> функция "СведенияОВидеРасчета".
17. aa aa (festiv1) 05.04.12 09:26
Спасибо за оперативный ответ! Вчера пол вечера проковырялся, нашел сам, хотел с утра отписаться чтобы вы не искали.. не успел :)
18. Дмитрий_71 (Дмитрий_71) 23.09.12 22:04
(2) Seregalink, Добрый день! Помогите пожалуйста разобраться с тарифными разрядами.. Вот я создаю новый вид Расчета с произвольной формулой, в которой участвует показатель "ТарифнаяСтавкаЧасовая", ставлю "ТребуетсяВводТарифногоРазряда" в истина, но всё равно в документе "Прием" из справочника "Тарифные разряды" не выбирается, а в сотруднике выбирается.. Если ставлю в виде расчета способ расчета "регламентированный" "по часовой тарифной ставке, тогда выбирается.. Посмотрел в коде в функции "СведенияОВидеРасчета" в "ВыборкаПоказателей.ТребуетсяВводТарифногоРазряда" стоит ложь..
19. Дмитрий_71 (Дмитрий_71) 24.09.12 14:09
(16) Seregalink, Всё спасибо разобрался!)
20. Piotr (Tolpinski) 13.11.12 11:40
Спасибо, а то уже измучился.
Только вот тарифным разрядам я владельца назначил как Должность, переписывать ничего не пришлось.