gifts2017

БП 2.0 - УПП 1.3 Правила переноса справочников, документов и остатков

Опубликовал Серега Путин (Confucius) в раздел Обмен - Обмен через XML

Правила обмена и конвертации из Бухгалтерии 2.0 в УПП 1.3

Данные правила являются  доработкой вот этих: http://infostart.ru/public/99708/

Доработано: выгружаются остатки по ОС и по счетам. (поправил запросы и соответствие реквизитов)

Проверял на типовых Бухгалтерия 2.0.32.4 и УПП 1.3.21.1.

!Если у кого-то нетиповые и что-то не работает, то под них не буду ничего доделывать!

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Правила Выгрузки БУХ-УПП
.xml 5,22Mb
07.02.12
589
.xml 5,22Mb 589 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Евгений L (laeg) 08.02.12 20:08
Вот это да, уже больше года от 1с ждем этих правил, а тут такой труд. Сфенькю вери мач.
Будем тестить, правда на КА.
2. Александр Noname (Meson) 08.02.12 20:10
Если действительно работают, то это очень хорошо, возьму на заметку.
3. Aleks Федоров (faleks) 28.02.12 10:32
Справочники перенеслись, а вот остатки нет, выкидывает ошибки:

Ошибка в обработчике события ПередОбработкойПравилаВыгрузки
ПВД = ВводНачальныхОстатковОС
Обработчик = ПередОбработкойВыгрузкиДанных
ОписаниеОшибки = Преобразование значения к типу Число не может быть выполнено
ПозицияМодуля = (484)
КодСообщения = 31

Ошибка при выгрузке данных: {Обработка.УниверсальныйОбменДаннымиXML.МодульОбъекта(1636)}: Ошибка в обработчике события ПередОбработкойПравилаВыгрузки
ПВД = ВводНачальныхОстатковОС
Обработчик = ПередОбработкойВыгрузкиДанных
ОписаниеОшибки = Преобразование значения к типу Число не может быть выполнено
ПозицияМодуля = (484)
КодСообщения = 31
4. Серега Путин (Confucius) 28.02.12 10:49
Ну ты молодец и я должен понять что случилось? ))
Опиши какая конфа, типовая или нет..если не типовая то надо копать самому.А так раскопай на чем спотыкается точнее на каком реквизите. Тогда и помощь будет.
5. Aleks Федоров (faleks) 29.02.12 05:36
(4) Confucius,
типовая БП 2.0.32.4 при выгрузке остатков выдает указанную ошибку
6. Серега Путин (Confucius) 29.02.12 05:53
Вот код перед выгрузкойданных
Если Параметры.КонфигурацияПолучатель = 1 Тогда
Сообщить("Выгружаются данные для конфигурации ""Комплексная автоматизация, редакция 1.1"".
|");
ИначеЕсли Параметры.КонфигурацияПолучатель = 2 Тогда
Сообщить("Выгружаются данные для конфигурации ""Управление производственным предприятием, редакция 1.3"".
|");
Иначе
Предупреждение("Указано неверное значение параметра ""Конфигурация-получатель""!");
Отказ = Истина;
КонецЕсли;

Если ДатаНачала = Дата("00010101000000") Тогда
Предупреждение("Не указана дата ввода остатков (Дата начала) !");
Отказ = Истина;
КонецЕсли;

// Принудительно отключим оптимизированный формат файла обмена
ВыполнитьОбменДаннымиВОптимизированномФормате = Ложь;

Если НЕ Отказ Тогда

Параметры.ДатаВводаОстатков = НачалоДня(ДатаНачала)-1;
Параметры.ДатаНачала= ДатаНачала;
Параметры.Граница = Новый Граница(Параметры.ДатаВводаОстатков, ВидГраницы.Включая);

Параметры.ПоВсемОрганизациям= НЕ ЗначениеЗаполнено(Параметры.Организация);
Параметры.Счет000 = ПланыСчетов.Хозрасчетный.Вспомогательный;

Параметры.Сотрудники = Новый ТаблицаЗначений;
Параметры.Сотрудники.Колонки.Добавить("ФизЛицо",Новый ОписаниеТипов("СправочникСсылка.ФизическиеЛица"));

Параметры.СотрудникиОрганизации = Новый ТаблицаЗначений;
Параметры.СотрудникиОрганизации.Колонки.Добавить("ФизЛицо",Новый ОписаниеТипов("СправочникСсылка.ФизическиеЛица"));
Параметры.СотрудникиОрганизации.Колонки.Добавить("Организация",Новый ОписаниеТипов("СправочникСсылка.Организации"));

Параметры.мУСН = Новый Соответствие;
Выборка = Справочники.Организации.Выбрать();
Пока Выборка.Следующий() Цикл
Организация = Выборка.Ссылка;
УчетнаяПолитика = ОбщегоНазначения.ПолучитьПараметрыУчетнойПолитики(Параметры.ДатаВводаОстатков, Ложь, Организация,Ложь);
Если НЕ УчетнаяПолитика.Свойство("УСН") Тогда
Параметры.мУСН.Вставить(Организация, Ложь);
Иначе
Параметры.мУСН.Вставить(Организация, УчетнаяПолитика.УСН);
КонецЕсли;
КонецЦикла;

Если НЕ ЗначениеЗаполнено(Параметры.ЧислоСтрокНаДокумент) Тогда
Параметры.ЧислоСтрокНаДокумент = 512;
КонецЕсли;

КонецЕсли;

Из твоей ошибки связанной с преобразованием в число вижу только то что ты при выгрузке на закладке параметры обработки выгрузка\загрузка в XML не указал в какую конфигурацию ты выгружаешь надо в поле источник поставить цифру 2 если в УПП и 1 если в комплексную. и возьми последнюю версию обработки V8Exchan82 (Универсальная Загрузка Выгрузка Данных В формате XML) (находиться в папке Temlts в установленной Convertation) либо поищи на ИТС либо на просторах инета.
7. Evgeniy (Evgeniy) 29.02.12 17:49
То что доктор прописал, сенкью за правила обмена, облегчил мне работу.
Как раз нужно было ОСы переносить из БУ в УПП
8. Серега Путин (Confucius) 01.03.12 05:51
9. Evgeniy (Evgeniy) 01.03.12 11:11
При переносе остатков ОС из БУХ 2.0 в УПП 1.3 (документ Ввод начальных остатоков ОС) не переносятся следующие поля:
- строка № 1, инв. номер ОС <000000113> : (НУ) Не заполнена текущая стоимость основного средства (НУ или ПР)
- строка № 1, инв. номер ОС <000000113> : (НУ) не заполнено значение реквизита "Счет учета (НУ)"!
- строка № 1, инв. номер ОС <000000113> : (НУ) не заполнено значение реквизита "Метод начисления амортизации (НУ)"!
- строка № 1, инв. номер ОС <000000113> : (НУ) не заполнено значение реквизита "Способ отражения расходов по амортизации (НУ)"!
- строка № 1, инв. номер ОС <000000113> : (НУ) не заполнено значение реквизита "Счет амортизации (НУ)"!
10. Серега Путин (Confucius) 01.03.12 14:39
Посмотри в Бухне у этого ОС есть ли стоимость по НУ..короче тут все ошибки по Нал.учету..копать надо в бухне.
Типовая бухня?
11. Evgeniy (Evgeniy) 01.03.12 16:59
(10) бухгалтерия типовая, последний релиз
УПП правда 1.3.19, но не думаю что из-за этого расхождения

ещё обнаружилосся косяк с документом принятия к учету ОС, он почему-то подставляет не тот документ что в бухгалтерии числиться.

Это всё в документе "Ввод начальных ОС"
12. Evgeniy (Evgeniy) 15.03.12 17:49
(0) Автор, а есть ли обратные правила обмена.
Из УПП 1.3 в Бухгалтерию 2.0?
13. Равиль (vip76) 15.03.12 18:55
Из УПП 1.3 в Бухгалтерию 2.0?

Присоединяюсь к вопросу.
16. Серега Путин (Confucius) 19.03.12 11:57
(13) vip76,
У меня нету. Задачи не стояла такая.
Kolov.Sergey предлагает (за денюшку тока)))
17. Evgeniy (Evgeniy) 20.03.12 11:13
Жаль, но да ладно.
Придется написать самому тогда правила обмена между УПП и БУ
18. Омнитек Омнитек (omnitech69) 26.03.12 12:34
Некорректно переносятся документы "Списание с расчетного счета" и "Поступление на расчетный счет".
В документ не подставляются банковские счета, суммы, вид операции...
19. Олег Молочников (milkers) 31.03.12 00:50
20. Konstantin Konstantin (KonstB) 04.04.12 12:40
Как с переносом остатков по НУ?
21. Серега Путин (Confucius) 04.04.12 14:41
Сделана более новая версия с учетом недочетов в моей обработке (я так полагаю) так что кури её http://infostart.ru/public/123342/
22. Катя Пономарева (Katik) 04.04.12 14:53
Блин, а я только этот скачала:( Прошло 10 минут и новый качать.
23. Николай Терновик (tnikolas) 25.07.12 06:29
Блин чувак спасибо тебе большое!!! Хоть у меня и КА 1.1, но все же за аналог правило хорошее. Спасибо тебе, как говорить респект и уважуха ))))
25. Дмитрий Лапкин (demetr2011) 04.09.12 14:57
26. Серега Путин (Confucius) 05.09.12 06:12
Чем тебе бесплатные не угодили http://infostart.ru/public/123342/ допиленные и проверенные. остатки все по счетам переносятся.
27. Дмитрий Лапкин (demetr2011) 06.09.12 10:37
(26) перенос остатков не является проблемой даже с типовыми
28. Серега Путин (Confucius) 06.09.12 12:25
Тогда в чем отличие твоих от бесплатных?
29. Илья Коробов (aids-ice) 15.01.13 22:02
Подойдет ли данная разработка для переноса в КА 1.1.29
30. Сергей C (a31) 06.04.13 16:02
(13)(12) Evgeniy, vip76, Здравствуйте, вы писали про правила обмена из УПП 1.3 в БП 2.0, если вы написали или добыли такие правила, поделитесь, пожалуйста, на A31@bk.ru . Заранее благодарен.
31. Александр Лобачёв (SANILLA) 23.04.13 22:16
(25) demetr2011, а документ ввод остатков формируется?
32. Александр Лобачёв (SANILLA) 23.04.13 22:17
(26) Confucius, по бесплатным правилам такой же вопрос: "а документ ввод остатков формируется?"
33. Дмитрий Лапкин (demetr2011) 23.04.13 23:26
(31) ввод остатков конечно формируется. вероятно и в бесплатной.
ЗЫ: Это, можно сказать, лозунг любого продукта 1С :)

добавил версию под 3.0
(30)(29)есть обратная версия, но для 2.0
34. Александр Лобачёв (SANILLA) 23.04.13 23:41
(33) demetr2011, благодарю, завтра буду тестировать, потом отпишусь.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа