gifts2017

Печать документов для возврата товара (7.7 ТиС)

Опубликовал Алексей Куликов (avers007) в раздел Печать - Печатные формы документов

Для тех, кто работает в ТиС в рознице. Обработка для печати заявления на возврат товара от розничного покупателя.

В принципе, может запускаться из любого документа посредством команды "Открыть форму".  Для этого в процедуре "ПриЗаписи()" добавляются строки

 

Перем Пароль;
 Перем
МожноЗаписатьДокумент;

 
//Ввод данных документа покупателя и распечатка заявления на возврат товара
 
Если  ВидОперации = Перечисление.ВидыОперацийЧекККМ.ЧекНаВозврат Тогда
     Если
Вопрос(" Вы действительно хотите произвести возврат
              | денег за товар (услуги)?"
, "Да+Нет") = "Нет" Тогда
  
СтатусВозврата(0);
  ИначеЕсли (
ВвестиЧисло(Пароль,"Введите код возврата",5,0,0)= 1) И (Пароль = Константа.КодВозврата) Тогда
   
СписокПараметров Форма.Параметр;
   
СписокПараметров = СоздатьОбъект("СписокЗначений");
   
СписокПараметров.ДобавитьЗначение(глВзятьКонтекст(Контекст), "Контекст");
   
СписокПараметров.ДобавитьЗначение(МожноЗаписатьДокумент, "МожноЗаписатьДокумент");

   
ОткрытьФормуМодально("Отчет", СписокПараметров, КаталогИБ()+"ExtForms\ВводУдостДляВозвратаТовара.ert");
   
МожноЗаписатьДокумент = СписокПараметров.Получить("МожноЗаписатьДокумент");
  Иначе
  
СтатусВозврата(0);
  КонецЕсли;
 КонецЕсли;

 Если
МожноЗаписатьДокумент = 0 Тогда
 
СтатусВозврата(0);
 КонецЕсли;

У меня обработка запускается из документа "ЧекККМ". Можно добавить константу "Пароль". Тогда открываться будет после ввода пароля возврата. Если пароль не нужен, строку с паролем "залочить".
Вводятся данные покупателя, распечатывается "заявление на возврат", заявление сохраняется в корневом каталоге базы в папке "Заявы на возврат" в формате .xls. Не закрывается, пока не введены все данные покупателя и не распечатано заявление.

Скачать файлы

Наименование Файл Версия Размер
ВводУдостДляВозвратаТовара2.ert 19
.ert 40,50Kb
13.02.12
19
.ert 40,50Kb Скачать

См. также

Подписаться Добавить вознаграждение
В этой теме еще нет сообщений.