gifts2017

Обнуление сальдо по зарплате в ЗУП

Опубликовал Vladimir Strelez (extralook) в раздел Обработки - Закрытие периода

Обработка обнуления сальдо по заработной плате сотрудников на начало месяца

Обработка обнуляет сальдо по заработной плате сотрудников на начало месяца, корректируя регистры накопления ВзаиморасчетыСРаботникамиОрганизаций, ЗарплатаЗаМесяцОрганизаций, НДФЛКЗачету. Написана для конфигурации ЗУП платформы 8.2 релиз 2.5.45.3. Возможна доработка для других релизов.

Порядок работы:
1. Необходимо выбрать месяц, на начало которого необходимо обнулить сальдо
2. Выбрать организацию
3. В поле Корректировка, нажав на кнопку Выбрать (три точки), создать новый документ (нужно нажать на зеленый плюс) и выбрать его двойным щелчком.
(Важно) При повторном использовании обработки для корректировки того же периода нужно использовать документ, созданный ранее.


Бонус. Есть возможность автоматического пересчета НДФЛ во всех проведенных документах выбранного периода "Начисление заработной платы работникам организаций", нажав на кнопку меню "Действия", выбрав пункт "Пересчитать НДФЛ в документах начисление ЗП"

(Тоже важно) Перед любыми действия с обработкой рекомендуется сделать копию базы и сформировать отчетность для сравнения результата.

Скачать файлы

Наименование Файл Версия Размер
ОбнулениеCальдо 359
.epf 9,58Kb
22.02.12
359
.epf 9,58Kb Скачать

См. также

Подписаться Добавить вознаграждение
Комментарии
0. Vladimir Strelez (extralook) 27.02.12 16:04
Обработка обнуления сальдо по заработной плате сотрудников на начало месяца

Перейти к публикации

0. Vladimir Strelez (extralook) 27.02.12 16:04
Обработка обнуления сальдо по заработной плате сотрудников на начало месяца

Перейти к публикации

1. Модератор раздела Артур Аюханов (artbear) 27.02.12 16:04
Про бонус совсем непонятно :( что за автоматический пересчет НДФЛ?
2. Vladimir Strelez (extralook) 28.02.12 08:30
Автоматический пересчет данных на вкладке НДФЛ во всех проведенных документах "Начисление ЗП" за период, выбранный в обработке.
3. Олег Коваленко (OleGazz) 29.02.12 07:17
спасибо большое, надо опробовать конечно же!
4. Petr (sevipa) 29.02.12 22:45
Поможет ли он беде расчетчика которая кажный месяц корректирует док ЗП к выплате по причине неверно перенесенных из зик 77 и не отрегулированных вводом остатков данных по части сотрудников?
7. Надежда Черноусова (Надежда_) 09.03.12 12:10
А для ЗБУ подойдёт эта обработка?
8. Vladimir Strelez (extralook) 11.03.12 08:53
(7) Надежда_, не могу ответить, но можно попробовать, предварительно сделав копию базы
9. Иванов Иван (svk2007) 12.03.12 14:42
Для ЗБУ эта обработка не походит. Жаль...
10. Иван Петров (Oskol_st) 13.03.12 23:16
11. Иван Петров (Oskol_st) 13.03.12 23:18
12. infostar81 14.03.12 16:56
13. Денис Кузнецов (kuza_87) 20.11.13 12:47
Спасибо, дружище! Очень помог
14. Вячеслав (ivnik) 22.11.13 00:12
Спасибо, замечательная вещь! Сработала прекрасно, только я не понял, где были сделаны записи корректировки?
15. Аня Босая (Leanna) 10.01.14 19:13
Большое спасибо, очень полезная обработка
16. Anthon Sahrahninn (Anthon) 05.02.14 19:07
спасибо, сэкономили мне время на написание обработки для ЗиКБУ, а всего лишь надо поправить одну функцию.
так что можете модифицировать обработку, чтобы она автоматом определяла наличие измерений в регистрах (я добавил СтатьяФинансирования и КОСГУ), и она будет более универсальна. желательно добавить автоматическое создание документа, если он не выбран.


Функция ПолучитьОстатки(ИмяРегистра)
Если ИмяРегистра = "ВзаиморасчетыСРаботникамиОрганизаций" Тогда
Запрос =
Новый Запрос("ВЫБРАТЬ
| ВзаиморасчетыСРаботникамиОрганизацийОстатки.Физлицо,
| ВзаиморасчетыСРаботникамиОрганизацийОстатки.СтатьяФинансирования,
| ВзаиморасчетыСРаботникамиОрганизацийОстатки.КОСГУ,
| СУММА(ВзаиморасчетыСРаботникамиОрганизацийОстатки.СуммаВзаиморасчетовОстаток) КАК Сумма
|ИЗ
| РегистрНакопления.ВзаиморасчетыСРаботникамиОрганизаций.Остатки(&Период, ) КАК ВзаиморасчетыСРаботникамиОрганизацийОстатки
|ГДЕ
| ВзаиморасчетыСРаботникамиОрганизацийОстатки.Организация = &Организация
|
|СГРУППИРОВАТЬ ПО
| ВзаиморасчетыСРаботникамиОрганизацийОстатки.Физлицо,
| ВзаиморасчетыСРаботникамиОрганизацийОстатки.КОСГУ,
| ВзаиморасчетыСРаботникамиОрганизацийОстатки.СтатьяФинансирования
|
|ИМЕЮЩИЕ
| СУММА(ВзаиморасчетыСРаботникамиОрганизацийОстатки.СуммаВзаиморасчетовОстаток) <> 0");

ИначеЕсли ИмяРегистра = "ЗарплатаЗаМесяцОрганизаций" Тогда
Запрос =
Новый Запрос("ВЫБРАТЬ
| ЗарплатаЗаМесяцОрганизацийОстатки.Физлицо,
| ЗарплатаЗаМесяцОрганизацийОстатки.СтатьяФинансирования,
| ЗарплатаЗаМесяцОрганизацийОстатки.КОСГУ,
| СУММА(ЗарплатаЗаМесяцОрганизацийОстатки.СуммаВзаиморасчетовОстаток) КАК Сумма
|ИЗ
| РегистрНакопления.ЗарплатаЗаМесяцОрганизаций.Остатки(&Период, ) КАК ЗарплатаЗаМесяцОрганизацийОстатки
|ГДЕ
| ЗарплатаЗаМесяцОрганизацийОстатки.Организация = &Организация
|
|СГРУППИРОВАТЬ ПО
| ЗарплатаЗаМесяцОрганизацийОстатки.Физлицо,
| ЗарплатаЗаМесяцОрганизацийОстатки.СтатьяФинансирования,
| ЗарплатаЗаМесяцОрганизацийОстатки.КОСГУ,
| ЗарплатаЗаМесяцОрганизацийОстатки.ПериодВзаиморасчетов
|
|ИМЕЮЩИЕ
| СУММА(ЗарплатаЗаМесяцОрганизацийОстатки.СуммаВзаиморасчетовОстаток) <> 0");

ИначеЕсли ИмяРегистра = "НДФЛКЗачету" Тогда
Запрос =
Новый Запрос("ВЫБРАТЬ
| НДФЛКЗачетуОстатки.ФизЛицо,
| НДФЛКЗачетуОстатки.СтатьяФинансирования,
| НДФЛКЗачетуОстатки.КОСГУ,
| НДФЛКЗачетуОстатки.СтавкаНалогообложенияРезидента,
| СУММА(НДФЛКЗачетуОстатки.СуммаНДФЛКЗачетуОстаток) КАК Сумма
|ИЗ
| РегистрНакопления.НДФЛКЗачету.Остатки(&Период, ) КАК НДФЛКЗачетуОстатки
|ГДЕ
| НДФЛКЗачетуОстатки.Организация = &Организация
|
|СГРУППИРОВАТЬ ПО
| НДФЛКЗачетуОстатки.ФизЛицо,
| НДФЛКЗачетуОстатки.СтатьяФинансирования,
| НДФЛКЗачетуОстатки.КОСГУ,
| НДФЛКЗачетуОстатки.СтавкаНалогообложенияРезидента
|ИМЕЮЩИЕ
| СУММА(НДФЛКЗачетуОстатки.СуммаНДФЛКЗачетуОстаток) <> 0");
Иначе
Возврат Неопределено;
КонецЕсли;

Запрос.УстановитьПараметр("Период", НачалоМесяца(Период));
Запрос.УстановитьПараметр("Организация", Организация);
Возврат Запрос.Выполнить().Выбрать();
КонецФункции


и бонус

Процедура ПриОткрытии()
Если Период = '00010101' Тогда
Период = РабочаяДата;
МесяцСтрока = РаботаСДиалогами.ДатаКакМесяцПредставление(Период);
Выборка = Справочники.Организации.Выбрать();
Пока Выборка.Следующий() Цикл
Если Организация.Пустая() Тогда
Организация = Выборка.Ссылка;
Иначе
Организация = "";
Прервать;
КонецЕсли;
КонецЦикла;
КонецЕсли;
КонецПроцедуры
17. Марго Марго (Margaritaya) 02.12.14 08:56