gifts2017

Библиотека продвинутых функций Фиксина для повторного использования кода.

Опубликовал Осипов Сергей (fixin) в раздел Программирование - Практика программирования

В библиотеке собраны функции разных авторов, большинство из них написал Осипов Сергей (Гений 1С).
Использование библиотеки абсолютно свободное.

Цель создания библиотеки – сбор в одном месте полезных функций, их систематизация для повторного использования.

В библиотеке собраны функции разных авторов, большинство из них написал Осипов Сергей (Гений 1С).

Начало библиотеки было положено 22 сентября 2006 года.

Использование библиотеки абсолютно свободное.

В настоящее время библиотека реализована в виде набора общих модулей и некоторых других прикладных объектов 1С, оформленных в подсистему «Библиотека функций».

Принципы реализации

Все модули имеют префикс «бф».

Глобальные модули имеют префикс «бфГлоб».

Ведется история изменений и доработок библиотеки, хранится в модуле «бфИсторияБиблиотеки».

Шаблон модуля объявлен в модуле «бфШаблон».

В библиотеке не используются процедуры, всегда используются функции.

Для названия функций используется название действия, которое выполняет эта функция, или значения, получаемого функцией.

Все локальные переменные, используемые функциями, объявляются.

Описание функций

Каждая функция имеет описание. Описание записывается в первой секции комментариев внутри функции.

В комментариях указываются:

·        Автор – автор разработки

·        Назначение – назначение разработки

·        Описание – описание разработки

·        Параметры – описание входящих и исходящих параметров

·        Результат – описание результата функций

Состав

DOM

Объектная модель документа в браузере.

Даты и время

Работа с датой и временем.

Диалоги

Работа с диалогами. Предупреждения, сообщения.

Запросы

Функции, упрощающие работу с запросами.

ИНН

Функции для работы с ИНН.

Коллекции

Функции для работы с коллекциями значений.

Кэш

Функции для серверного и клиентского кэширования значений.

Лингво

Функции для работы в языковых приложениях.

ИНН

Функции для работы с ИНН.

Макеты

Функции для работы с табличными макетами 1С (MXL).

Математика

Математические функции. Геометрия. Случайные числа.

Обмены

Функции для работы с планами обмена и обмена данными.

Объекты

Функции для работы с прикладными объектами 1С.

Отчеты

Функции для работы с отчетами. Получение некоторых отчетов по коллекциям, автоматические построители отчетов по коллекциям.

Построитель

Функции для работы с построителем

Сериализация

Функции для сериализации (превращения в строку) значений.

Система

Функции для работы с операционной системой.

СКД

Функции для работы с системой компоновки данных (СКД).

Строки

Функции для работы со строками.

Типы

Функции для работы с типами 1С.

Файлы

Функции для работы с файлами.

Формы

Функции для работы с формами.

Хранилище

Функции для работы с хранилищем. Обмен между файлами и хранилищем.

Язык

Некоторые усовершенствования языка программирования 1С.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Конфигурация библиотеки функций
.cf 117,38Kb
21.03.12
656
.cf 117,38Kb 656 Скачать

См. также

PowerTools от 1 000
Подписаться Добавить вознаграждение

Комментарии

0. Осипов Сергей (fixin) 18.03.12 20:13
В библиотеке собраны функции разных авторов, большинство из них написал Осипов Сергей (Гений 1С).
Использование библиотеки абсолютно свободное.



Перейти к публикации

1. sergej anonymous (ksv74) 18.03.12 20:13
ИНН в описании функций дважды
echo77; fixin; +2 Ответить 2
2. Осипов Сергей (fixin) 18.03.12 21:43
(1) ага, поправлю, спасибо.
3. alex_japanese_student (Alex_Japanese_Student) 18.03.12 22:34
спасибо, давно пользуюсь
а вы библиотеку функций давно не обновляли, или она постоянно растет??
4. г. Казань Рустем Гумеров (Rustig) 18.03.12 22:37
однажды я что-то уже использовал из вашей коллекции функций, пригодилось...
а вскоре скопировал вашу коллекцию в свою разработку http://infostart.ru/public/89310/
спасибо :)
jONES1979; fixin; +2 Ответить
5. anry mc (AnryMc) 18.03.12 22:47
(0) Моё "знакомство" с Инфостартои началось с Ваших функций http://infostart.ru/public/57975/
Заработал -3 балла.
6. Осипов Сергей (fixin) 18.03.12 22:52
(5) это завистники. Функции хорошие.
(3) давно не обновлял, но планирую. Теперь вроде наладил таск-флоу (управление задачами). так что все будет ок.
7. alex_japanese_student (Alex_Japanese_Student) 18.03.12 22:57
(6) fixin,
обновляйте, давно пора!!
ждем!
спасибо заранее!
8. Сергей Ожерельев (Поручик) 18.03.12 23:13
(6) Не обращай внимания. Я тоже кое-что использовал. Только с БСПятиной не пересекайся, а то заклюют.
9. Осипов Сергей (fixin) 18.03.12 23:22
(8) прикол моей библиотеки в том, что 80% функций оттестированы. понятно, что многие функции можно и с нуля написать, но их еще тестировать надо. А тут - сел и поехал.
(7) ага, буду обновлять. Будут хорошие функции - давайте, включу.
10. Сергей (sstar90) 19.03.12 12:30
fixin, проверь бфФайлы.ПутьБезСлеша(), по описанию "Функция корректирует путь - удаляет из него краевые пробелы и если в КОНЦЕ есть символа слеша, удаляет его", а ты проверяешь первую позицию.
Файл качал по ссылке http://fix-in.narod.ru/articles/down_funclib/article.htm
jONES1979; fixin; +2 Ответить 1
11. Осипов Сергей (fixin) 19.03.12 13:36
(10) да, однако версия библиотеки старовата. Сегодня обновлю.
Вот код из нее:
Функция ПутьБезСлеша(ИсходныйПуть, Слеш="/") Экспорт
//Назначение: Функция корректирует путь - удаляет из него краевые пробелы и если в конце есть символа слеша, удаляет его
//ДатаСоздания: 20070727
//Автор: Fixin
//Пример: 
//	c: -> c:
//	c:\ -> c:
//$Возврат: Строка
//Тестирована: Да
	
	Рез=СокрЛП(ИсходныйПуть);
	Если Прав(Рез,1)=Слеш Тогда
		Возврат Лев(Рез,СтрДлина(Рез)-1);
	Иначе
		Возврат Рез;
	КонецЕсли;
КонецФункции
...Показать Скрыть
12. Сергей Лунев (luns) 19.03.12 13:39
в чем смысл?:


Функция Соо(Сообщение) Экспорт
	Сообщить(Сообщение);
КонецФункции

Функция ПоказатьМакет(ТД) Экспорт
//Назначение: Для оперативного отображения макета
//ДатаСоздания: 20070510
//Автор: Fixin
//Тестирована:
	ТД.Показать();
КонецФункции
...Показать Скрыть


"тестирована" во втором умиляет))
13. Осипов Сергей (fixin) 19.03.12 13:46
(12) сам догадаешься, или с тебя снять лавры гуру? посмотри на название модуля, где используются эти функции, может после этого наступит просветление, гыгыгы.

может быть тебе станет легче догадаться, если ты осознаешь, что Показать и Сообщить - это процедуры, а не функции.
14. Сергей Лунев (luns) 19.03.12 13:57
(13) и что?
если бы твои функци хотя бы возвращали успешность выполненого действия, то с натяжкой можно было бы признать что есть в них толк.
а. так...

дарю тебе еще несколько:

Функция ПрибавитьЧисло(Число,СкокаПрибавить)
  Возврат Число + СкокаПрибавить;
КонецФункции

Функция УбавитьЧисло(Число,СкокаУбавить)
  Возврат Число - СкокаУбавить;
КонецФункции
...Показать Скрыть


ну и т.п. тока оттестить надо обязательно.
su_mai; amiralnar; kabanoff; +3 Ответить 2
16. Осипов Сергей (fixin) 19.03.12 14:21
(14) ты слился, сдался? Я даю тебе еще один шанс реабилитироваться, потом будешь локти кусать, предупреждаю. Смысл есть, думай, какой!!!!
17. Dmitry Semenov (dima1c) 19.03.12 14:22
Функция Соо(Сообщение) Экспорт
   Сообщить(Сообщение);
КонецФункции
...Показать Скрыть


Lol :D)
18. Ay Bv (Flashill) 19.03.12 14:22
Не работала на 8.2.14 (конфигурация не хотела загружаться из файла).
Решил путем открытия конфигурации через файл - открыть. При открытии конфа сконвертировалась.
При повторной загрузке конфигурации из файла все заработало.
19. Сергей Рудаков (fishca) 19.03.12 14:26
(14)

Результат = ?(1 = 1, Соо(), 100); - это работает
Результат = ?(1 = 1, Сообщить(), 100); - Это НЕТ ;)
zhilchenko; jONES1979; Rustig; fixin; +4 1 Ответить 1
20. Осипов Сергей (fixin) 19.03.12 14:26
(17) еще один, который не читал мою статью "Хитрости отладки", бугога...
(18) и это правильно.. конфа то в формате 81, но легко конвертируется в 82. Обратное невозможно, потому в 81.
(19) Браво, браво, молодое дарование. Товарищ Лунс теперь будет рвать свои седые волосы - надо же так опростоволоситься! Бугога.
21. Сергей Рудаков (fishca) 19.03.12 14:29
22. Сергей Лунев (luns) 19.03.12 14:34
(16) просвети.
(20) в той статье нет упоминания о Сооб().
23. Сергей Лунев (luns) 19.03.12 14:35
(20) с чего бы?
можешь реальный пример привести необходимости?
24. Осипов Сергей (fixin) 19.03.12 14:38
(22)(23) я про статью на мисте: http://www.kb.mista.ru/article.php?id=105
там есть раздел Трассировка. Надеюсь, ты проникнешься моим гением после прочтения этой статьи и наконец-то вкуришь, зачем нужна функция Соо.
Vladal; bol; +2 Ответить 2
25. Сергей Лунев (luns) 19.03.12 15:14
(24) за все семь лет работы над гораздо более сложными вещами чем любой из твоих примеров, ни разу не чувствовал недостатков механизма отладки.
так что не думаю что проникнусь.

что касаемо статьи на мисте...

увидев это:

Отладка на сервере

Чтобы съэкономить вам нервы, сообщаю, что отлаживать код, который выполняется на сервере (в трехзвенке), невозможно. Поэтому если у вас программа в файловом варианте останавливается на точке останова, а в серверном - нет, не пугайтесь, так и задумано. Ведь код выполняется на сервере приложений и не может поэтому отлаживаться на клиенте.


дальше читать не стал. ибо чему меня научит человек не знающий про -debug
Yakud3a; Hany; awa; kabanoff; alexk-is; +5 Ответить 2
26. Сергей Лунев (luns) 19.03.12 15:16
(19) криво и не читабельно.
правильнее так:

ТекстСообщения = ?(1 = 1, "что то", 100);
ОбщегоНазначения.Сообщение(ТекстСообщения);
27. Сергей Рудаков (fishca) 19.03.12 15:24
(26) - этот пример я тебе привел в качестве обоснования зачем процедура была преобразована в функцию, а не в качестве образца для подражания.
Функцию можно использовать в любых выражениях, процедуры нет.
w-divin; bol; +2 Ответить
28. Осипов Сергей (fixin) 19.03.12 15:52
(25) слив засчитан. если тебе не нужны какие-то фишечки отладки, то это не значит, что они не нужны другим. Это раз. А перевод стрелок на другую тему про дебуг - это вообще манипуляция. Может я тогда и не знал про дебуг, но про трассировку я уже тогда знал, а ты до сих пор не знаешь. ;-)
29. Сергей Лунев (luns) 19.03.12 16:15
(28) какие манипуляции?

если ты чего то не знал и изобрел в очередной раз велосипед, то не надо тыкать другим в это.
твои "хитрости отладки" тебе и нужны для того, чтобы обойти не знание возможностей платформы.

ты ведь сам свою статью как пример необходимости приводишь. за язык тебя не тянули.
хочешь еще пример?

твое:


Функция СкопироватьМассив(М) Экспорт
//Назначение: Копирует массив. Почему-то в 1С можно скопировать список, таблицу значений, дерево значений, но не структуру
//ДатаСоздания: 20070620
//Автор: Fixin
//Тестирована: Нет
	Рез=Новый Массив();
	Для Каждого Эл ИЗ М Цикл
		Рез.Добавить(Эл);
	КонецЦикла;
	Возврат Рез;
КонецФункции

//заменяется на

Список = Новый СписокЗначений;
Список.ЗагрузитьЗначения(Массив);
МассивКопия = Список.ВыгрузитьЗначения();
...Показать Скрыть


при этом скорость выше раза в два
bol; fixin; +2 Ответить 1
30. Осипов Сергей (fixin) 19.03.12 16:49
(29) лунс, но ты с темы трассировки таки активно соскальзываешь, оттого и манипуляции. Неважно, на что ты хочешь переключить мое внимание, но я-то помню, что ты не смог придумать, для чего нужны эти функции.

>> твои "хитрости отладки" тебе и нужны для того, чтобы обойти не знание возможностей платформы.
Лунс, внимательно слушаю, как платформа позволяет организовать трассировку. Ну что за детский слив. Ну не догадался, признайся и живи дальше.

насчет массивов, согласен, хорошее замечание, учту в библиотеке. Нельзя быть на 100% идеальным.
31. Сергей Лунев (luns) 19.03.12 17:10
(30) о чем ты говоришь то? придумал не нужную потребность (трассировка), без примеров реальной необходимости применения.
обвинил платформу что она это не умеет (да не умеет) и требуешь от меня это признать.
я тебе выше русским по белому сказал. стандартных возможностей отладки вполне достаточно, если умеешь понимать код и разбираться.

в этом ты весь: борец с ветрянными мельницами.


Нельзя быть на 100% идеальным.


)))) дели на 10
32. Сергей Лунев (luns) 19.03.12 17:49
в статье на мисте последний абзац )))))))))))

Иногда сложно найти, в какую процедуру заходит программа по нажатию кнопки.
33. Осипов Сергей (fixin) 19.03.12 18:20
(31) ну да, дружище лунс, конечно же, такой классический механизм, как трассировка не нужен. Классики программирования были неправы, а Лунсу достаточно имеющихся механизмов.
Рассказываю, когда мне пригодилась трассировка.
У меня в РИБ не загружался файл обмена. НЕ хваталао прав на какой-то обмен.
Вычислить по списку зарегистрированных объектов не получилось.
Поставил трассировку на событие ПриПолученииДанныхИзГлавного.
Соответственно быстро выщемил тот объект, который не загружался.
Может быть можно было и по другому как-то сложно решить проблему, но с трассировкой решилось просто.

(32) твой смех обозначает, что ты не сталкивался с серьезной работой в поле. В типовых довольно часта ситуация, когда обработчики на кнопки назначаются программно, а если ты вскроешь форму чека ккм, то там вообще можно потерятся в событиях.
34. Алексей (alexqc) 19.03.12 18:23
(31) отладчик 1С заточен под интерактивную работу. Фишка в том, что иногда надо отследить изменения некоего значения, но таких изменений м.б. куча (например, в цикле) - делать это пошагово замахаешься. обычно в подобных случаях вставляют Сообщить(), но это изменение кода, что вызывает необходимость перезапуска.

Так вот, чтобы обходиться без изменения кода, делается один раз обертка над Сообщить(), а потом вызывается в нужном месте путем установки бряки с условием вида глСообщить("НужнаяПеременная="+НужнаяПеременная) =123. Пользуюсь таким приемом еще с 7ки. Дополнительный плюс- не нужно по окончании отладки отыскивать и убирать отладочные сообщения.

Кстати, не знаю как у Фиксина в библиотеке (не качал и не смотрел), но у меня например для нужд отладки в арсенале (также еще с 7ки) есть ф-ции глПрисвоить() и глПоказать() - первая для изменения значений прямо в отладчике, вторая - вывод и показ содержимого значения в таб. документ. Так что если там нет - вот идеи (хотя думаю что есть, все лежит на поверхности).
35. Осипов Сергей (fixin) 19.03.12 19:39
(34) не распинайся, товарищ Лунс выше этого, отлаживает в уме и трассировку считает некошерной.
w-divin; Kuzya_brаtsk; +2 Ответить 1
36. Дмитрий Денисов (Uncore) 20.03.12 08:26
предложу функцию получения числа прописью в формате "10 лет" вместо "десять лет" стандартными средствами "ЧислоПрописью", в предложенной подборке не нашел:
//Описание: 
//	Возвращает количественное представление переданного числа прописью на основе форматной строки.
//Параметры:
//  <Число> (обязательный)
//  	Тип: Число.
//		Число, которое требуется вернуть прописью.
//  <ФормСтрока> (обязательный)
//  	Тип: Строка.
//		Содержит перечисленные через запятую: единственное число именительный падеж, единственное число родительный падеж, множественное число родительный падеж.
//  <ВыводЧисла> (необязательный)
//  	Тип: Булево.
//		Признак вывода переданного числа.
//Например:
// 	ПрописьЧисла = ПрописьЧисла(10, "день,дня,дней"); 
//  	вернет "10 дней"
// 	ПрописьЧисла = ПрописьЧисла(3, "год,года,лет", Ложь);
//   	вернет "года"
Функция ПрописьЧисла(Число, ФормСтрока, ВыводЧисла = Истина)
	
	Строка = ЧислоПрописью(Число, , ",,,,,,,,0");
	ФорматнаяСтрока = ЧислоПрописью(Число, , ФормСтрока + ",,,,,,0");	
	
	Возврат СтрЗаменить(ФорматнаяСтрока, Строка, ?(ВыводЧисла, "" + Число + " ", ""));
	
КонецФункции
...Показать Скрыть
37. denis leonov (curys) 20.03.12 08:37
Прикольная штука, обязательно скачаю) спасибо автору
38. Дмитрий Изосин (Izosin) 20.03.12 14:51
С удовольствием поставил плюс, только прочитав комментарии. luns может быть по своему и прав, но его позиция по отношению к идеи которая в определенных условиях и в умелых руках может сильно помочь и сократить время отладки в десятки раз мне непонятна.

(24)Спасибо за статью на Mista, с удовольствием прочел. Буду качать библиотеку и смотреть что можно из нее использовать у себя.
39. Сергей Лунев (luns) 20.03.12 15:06
(38) позиция проста.
сама идея библиотеки функций хороша, но реализация слабая.
функции должны возвращать значения (как минимум результат выполнения усешен\нет).
должна быть логичная увязка разных функций между собой.
не должно быть примитивных. тех что в коде пишуться на лету, почти без раздумий.
или они должны расширять возможности типовых процедур, функций.

со временем функции должны совершенствоваться. если например появляется новая возможность в платформе, то функция должна адаптироваться (с проверкой платформы)

например у него есть функция

бфМат.Функция СлучайноеЧисло(Мин,Макс)


расчитанная под 8.0. вот в ней в начале надо проверять платформу и в случае 8.1 использовать штатный механизм платформы.

все те функции, что есть в типовых, должны вызываться в первую очередь. при невозможности (отсутствии), должен отрабатывать уже свой алгоритм.

пробежав по функциям вижу, что библиотека написана несколько лет назад и с тех пор не обновлялась.

в общем незачет.

хотя идея неплоха.
40. Осипов Сергей (fixin) 20.03.12 16:21
(39) лучшее - враг хорошего. А писать постоянно один и те же мелкие функции тоже влом. Напиши лучше.
41. Дмитрий Изосин (Izosin) 20.03.12 18:01
(39) Самый большой плюс этой публикации в комментариях. Прочитав их, точней прочитав статью по ссылку мне удалось взглянуть на отладку совсем с другой стороны. однозначный плюс этой статьи в том что ваш спор заставил меня прочитать ту статью, и за это я премного благодарен вам обоим. А с самой библиотекой нужно еще разбираться, беглый взгляд на её содержание привел меня к мысле, что ставить ее себе в таком виде я не буду, перегружать конфигурацию таким обилием общих модулей, половина из которых либо пусты, либо содержат по 2-4 функции, считаю форменным издевательством над теми кто будет работать с этой конфигурацией после меня. Так что публикация оставляет двойственные чувства. С одной стороны хотелось бы побольше публикация помогающих по новой взглянуть на наболевшие проблемы, а с другой стороны структурирована эта библиотека из рук вон плохо. Думаю для большинства полезней было бы если бы большая часть идей была оформлена в виде статью с примерами использования. Своего рода расширенная версия статьи http://www.kb.mista.ru/article.php?id=105, и все функции собранные в одном общем модуле.

Но это мое мнение, на работе сейчас запарка, и нет достаточно времени чтоб разбираться более глубоко. А за то что помогли взглянуть на отладчик по другому однозначный плюс, который я уже поставил.
CratosX; shatt; fixin; +3 Ответить 1
42. Осипов Сергей (fixin) 20.03.12 18:24
(41) не вижу проблемы в большом количестве модулей. ;-) Я долго думал над структурой и пришел к выводу, что лучше много модулей, чем один огромный.
43. Дмитрий Изосин (Izosin) 20.03.12 20:14
(42) Наверно проблема в том что мне лень в голове держать помимо названий функций еще и название общего модуля где он встречается. А еще тем кто работал с УПП может и привычно то что у них справочников, документов и регистров километровыми списками, а как быть тем кто привык работать с УТ? Вот забыл я как точно пишется та или иная функция, а помню что где-то она была, как ее найти в таком обилии? В свернутом виде функции занимают 2 строки на экране, плюс строка интервала между функциями, на экране смело помещаются до 20 функций, а может и больше. Наверно мне просто привычней ковыряться в 10-30тыс строк, нежели в 40 модулях по странице каждый. Но это кто к чему привык.

При беглом осмотре большая часть функций для меня остались не совсем понятны. Выносить простые и совершенно очевидные вещи во внешние модули, вроде как нелогично, но это уже кто к чему привык. Но то что к ним можно обращаться во время отладки не меняя конфигурации делает эту идею достаточно полезной.
44. Эмиль Фахреев (Kobra_RU) 21.03.12 10:35
(25) luns,
дальше читать не стал. ибо чему меня научит человек не знающий про -debug

Статья написана очень неплохо. Про отладку на сервере... Зря не стал читать дальше. В разделе Отладка клиент-серверной базы ключ -debug упоминается, и кстати в 8.0 его не было...
45. Сергей Лунев (luns) 21.03.12 10:47
(44) в том то и дело, что всему этому и статье и библиотеке в обед сто лет.
когда то может и актуально было. но сейчас уже нет.
46. Осипов Сергей (fixin) 21.03.12 11:06
(45) не надо народных песен. Что именно неактуально?
(44) во-во, товарищ Лунс не дочитал до конца, а про -debug пропел.
jONES1979; +1 Ответить
47. Андрей Гердт (AndreyNit) 21.03.12 11:52
Беспорно библиотека функций вещь нужная. До некоторых функции и приемов сам доходил, вот если бы раньше про неё узнал бы, то с экономил много времени. Ставлю большой жирный плюс.
Правда есть в этой библиотеке небольшая скрытая угроза, она расслабляет программистов, накидал модуль из готовых функций и не думаешь, а потом когда нужно реально покодить, а навыки растеряны. Просто сам на эти грабли наступал. Хотя кому как.
48. Осипов Сергей (fixin) 21.03.12 12:09
(47) интересно, доживем ли мы до времени, когда автоматизация учета будет похожа на собирание программ для андроида - скачал, посмотрел, если не понравилось, скачал другую тулзу. и никакого программирования. ;-)

(45) Чтобы не было наветов, обновил библиотеку свежеиспеченным файлом.
49. Александр Рытов (Арчибальд) 21.03.12 13:39
(35)
не распинайся, товарищ Лунс выше этого, отлаживает в уме и трассировку считает некошерной.
Ну и что? Я программирую более 50 лет (с 1970 г.) и ни разу не пользовался трассерами/дебаггерами. Отлаживал транслятор с языка параллельного потокового программирования, вообще не прикасаясь к клавиатуре - просто говорил кодерам, в каком месте ошибка. В качестве базиса этого принципиального подхода приведу известный афоризм Дейкстры:
Глубоко ошибается тот, кто думает, что изделиями программистов являются программы, которые они пишут. Программист обязан создавать заслуживающие доверия решения и представлять их в форме убедительных доводов, а текст написанной программы является лишь сопроводительным материалом, к которому эти доказательства применимы.
Естественно, создание решений происходит в уме, а "отладка" суть приведение в соответствие умозрительного решения и программного текста. Современные мышеводы напротив, пишут что-то, а потом начинают судорожно выяснять, пригодно ли это что-то для достижения нужных целей. Вот, к примеру, демонстрация такого процесса http://infostart.ru/public/121612/.
Но это так, к слову. А публикация заслуживает внимания, значит, плюса.
vkr; Valerich; +2 Ответить 3
50. Сергей Рудаков (fishca) 21.03.12 13:54
(49) хочешь сказать отладкой чужого кода ни раз не занимался? ;)
51. Александр Рытов (Арчибальд) 21.03.12 14:16
(50) Занимался. По тексту пытался понять мысль. Непонятные куски выбрасывал (снабжал заглушками). Но никогда не пытался просто запустить и посмотреть, что получится.
52. Осипов Сергей (fixin) 21.03.12 14:25
(49) Арчибальд, вы уникальный товарищ. Все же большинство кодеров юзают отладчик. А если бы в 1С была трассировка и трассировку юзали бы. Я лично все возможности отладки юзал в 1с - и замеры производительности и просмотр стека и т.п.

(51) Это ты зря не пробовал, бугога. Иногда истина на поверхности.
unknown181538; mailwood; +2 Ответить 1
53. Александр Рытов (Арчибальд) 21.03.12 14:33
(52) А я не говорю, что пользоваться отладчиком вообще нельзя. Я утверждаю только, что если сначала подумать, а потом уже начинать писать код, то отладчик может и не потребоваться - как со мной и происходило всегда.
54. Сергей Рудаков (fishca) 21.03.12 15:57
(53) мудрость приходит с годами, к сожалению, в молодости как правило бурлит кровь и рвешься в бой
55. Осипов Сергей (fixin) 21.03.12 16:59
(53) если быть буквоедом, то фразу "то отладчик может и не потребоваться - как со мной и происходило всегда" можно трактовать как "мне никогда не приходилось пользоваться отладчиком". Бугога.

(54) понты тоже.
56. Сергей Рудаков (fishca) 21.03.12 17:10
57. Осипов Сергей (fixin) 21.03.12 17:19
(56) да вся бравада Арчибальда в этой ветке мне кажется понтами. Но это, видимо, мои галюцинации. Замнем тему.
58. Anatolii Karasev (KapasMordorov) 21.03.12 18:41
Поддержу Арчибальда.
Отладчиком пользуюсь при ползании по коду типовых, в основном из-за бредовой логики вызовов общих модулей.
При разборе своего кода - редко пользуюсь, в основном проверяю выдачей сообщений.
ЗЫ.
Ну понты, конечно, присутствуют. "Всегда" и дальше по всем кочкам.
59. Алексей (alexqc) 21.03.12 19:19
(49) при всем уважении, товарищ Арчибальд, вы все-таки понтуетесь.
Ну и что? Я программирую более 50 лет (с 1970 г.)


1970+50=2020. ?????


и ни разу не пользовался трассерами/дебаггерами. Отлаживал транслятор с языка параллельного потокового программирования, вообще не прикасаясь к клавиатуре - просто говорил кодерам, в каком месте ошибка.


Иными словами - "я проверял результат работы, отлаживали кодеры". Разумеется, так с успехом можно без отладчика обойтись.


[IS-QUOTE]Программист обязан создавать заслуживающие доверия решения и представлять их в форме убедительных доводов, а текст написанной программы является лишь сопроводительным материалом, к которому эти доказательства применимы.

Естественно, создание решений происходит в уме, а "отладка" суть приведение в соответствие умозрительного решения и программного текста.[/IS-QUOTE]
Да, однако сидящее "в уме" решение - "идеально", в отличии от написанной по нему программы. "Всякая программа содержит ошибку, и всякая последняя найденная ошибка - на самом деле предпоследняя". Шутка, конечно, но доля правды как всегда там. И речь идет о отладке программы, а не отладке решения.
Ну Вы же соглашаетесь, что "отладка" - практически необходимый процесс, и при этом утверждаете что ниразу отладчиком не пользовались? Вот прям так, с первого раза все всегда и работало? "НЕ ВЕРЮ"!!!
1cmax; jONES1979; w-divin; +3 Ответить 2
60. Алексей (alexqc) 21.03.12 19:32
+(59) *Оказывается, движок не поддерживает вложенных цитат.

Я кажется понимаю, что мог иметь ввиду Арчибальд под "не пользовался отладчиком": в те времена когда машины были большими, а машинное время дорого, тратить его на отладочные прогоны было непозволительным расточительством. Поэтому отладка проходила "на бумаге" - т.е. каждый участок кода проходился "вручную", и так вылизывался до блеска, чтобы потом уже на машине ничего (или мало что) доводить оставалось. Возможно, он (Арчибальд) со своим N-летним опытом так свои программы и доводит - вручную, до первого запуска.

Но сейчас времена другие, и лишний запуск много дешевле лишнего "ручного прохода" (да и муторно это - человек думать должен, а не прогамму за компа выполнять).
61. Осипов Сергей (fixin) 21.03.12 21:18
(60) слова не мальчика, но мужа. В отличии от Господина А. не вижу ничего зазорного и постыдного в отладке. И даже обдумывать не вижу смысла. Иногда, когда известно, что есть ошибка, особенно в бредовых типовых, проще взять отладчик в руки и найти багу.
62. Dmitriy (daho) 22.03.12 06:24
Спасибо, Серега!!!! Очень хорошая вещь! Еще бы добавить нормальный движок для поиска чего нужно...
63. Александр Рытов (Арчибальд) 22.03.12 09:09
(59)
1970+50=2020.
Это иллюстрация моих слов. Я сразу набирал текст на клавиатуре вместо того, чтобы стачала в уме протестировать этот текст.
я проверял результат работы, отлаживали кодеры
Кодеры при этом тоже отладчиком не пользовались.
Ну Вы же соглашаетесь, что "отладка" - практически необходимый процесс, и при этом утверждаете что ниразу отладчиком не пользовались? Вот прям так, с первого раза все всегда и работало?
Отладка - процесс необходимый. Пользование отладчиком - нет. Я до сих пор согласен с утверждением Никлауса Вирта
Никогда программы не содержат так мало ошибок, как при отсутствии каких-либо средств отладки
KapasMordorov; fishca; +2 Ответить 2
64. Осипов Сергей (fixin) 22.03.12 11:07
(63) тут мы расходимся во мнениях. С высоты своего 18-летнего опыта программирования считаю, что не пользоваться дебуггером - мазохизм. Но я могу заблуждаться, конечно.
NazarovV; Hany; link_l; +3 Ответить
65. leraks1 leraks1 (leraks) 22.03.12 11:59
Автору спосибо позновательно
66. Алексей (alexqc) 22.03.12 12:07
(63) Арчибальд
Отладка - процесс необходимый. Пользование отладчиком - нет. Я до сих пор согласен с утверждением Никлауса Вирта
Цитата
Никогда программы не содержат так мало ошибок, как при отсутствии каких-либо средств отладки


Как бы то ни было, это всего лишь мнение, и будь оно хоть Вирта, хоть фон Неймана - это не доказательство что оно верно. К тому же, Вирт адепт "академическиго" подхода к программированию, что неприменимо в "программировании промышленном" - слишком долго. Ну и еще, а когда собственно "программы без отладчика содержат мало ошибок"? при вводе - возможно. При сдаче готового продукта - врядли.

Наконец, приведу другое высказывание Вирта
Инструмент должен оответствовать задаче. Если не соответствует - надо сделать соответствующий, а не пытаться приспособить имеющийся
(не ручаюсь за точность, но суть такая). Вы считаете, что ручка с бумагой (или умозрительные образы в мозгу) лучше соответствуют задаче отладки, чем специально сделанный инструмент?

Ну если в вашем случае действительно так, то это - исключение. Весьма и весьма редкое.
link_l; fixin; +2 Ответить 3
67. Осипов Сергей (fixin) 22.03.12 12:28
(66) браво-браво, я бы точнее не сказал.
68. Александр Рытов (Арчибальд) 22.03.12 13:32
(66) К той же цитате: "соответствующий" и "специально сделанный" - не одно и то же. Возможно, попадавшиеся мне отладчики просто не соответствовали моим задачам.
69. Осипов Сергей (fixin) 22.03.12 13:52
(68) странные какие то у вас задачи, сэр.
70. Алексей (alexqc) 22.03.12 18:38
(68) Вот вам сценарий: некий длинный алгоритм, в котором в одном месте программист ошибся (описАлся) и вместо >= написал >.
Вот выходе имеем неверный результат. Вопрос: как проще найти ошибку - вживую, проверяя значения в контрольных местах, и постепенно сужая область поиска (такую возможность обеспечит самый простой отладчик, или в отсутствии оного - трассировочные сообщения); либо проверяя весь текст "до буквы"? А с учетом того что "глаз замыливается" - вполне возможно и при просмотре такую ошибку и пропустить; и тогда проверка может быть равносильна написанию нового.

Вот вам другой сценарий - вы говорили что можете понять что делает программа, просто глядя на код.
Пока А<>Б Цикл
	Если А>Б Тогда
		А=А-Б;
	Иначе
		Б=Б-А;
	КонецЕсли;
КонецЦикла;
Сообщить(А);
...Показать Скрыть


Это один из широко известных алгоритмов, и скорее всего вы просто знаете что это. А подумайте, может ли человек, не знающий его, определить что он делает глядя на код?
71. Максим Лучко (alcoholic) 22.03.12 19:12
Спасибо Автор, очень удобна и информативна
72. Александр Рытов (Арчибальд) 23.03.12 08:07
(69) Ничего странного. Я автоматизирую учет жизни, которая неповторима.
(70)
вместо >= написал >.
И чем мне в этом случае поможет отладчик?
вы говорили что можете понять что делает программа, просто глядя на код.
Я этого не говорил, и это реально не так. И в общем-то, мне неинтересно (разве что, из простого любопытства © О. Бендер), что она делает. Область моей компетенции - знать, что программа должна делать, и заставить ее делать именно это.
И о приведенном коде. Я не знаю, что это за алгоритм. Я бы сказал, что это вообще не алгоритм, поскольку отсутствует необходимое для алгоритма свойство конечности. Скажем, когда А = 1, Б = 0. Это даже не букварь, это азбука программирования - обеспечить, чтобы циклы заканчивались.
73. Осипов Сергей (fixin) 23.03.12 08:18
(72) Арчибальд на своей волне. Что он хочет сказать, я уже не вкуриваю... Ну, может другие поймут, бугога....
74. Дмитрий Денисов (Uncore) 23.03.12 08:21
Пока А<>Б Цикл
   Если А>Б Тогда
      А=А-Б;
   Иначе
      Б=Б-А;
   КонецЕсли;
КонецЦикла;
Сообщить(А);
...Показать Скрыть

Алгоритма не знаю, но потестив его на реальных числах А и Б, думаю, что это алгоритм поиска наибольшего общего делителя двух целых чисел. Просто прочитав код, это, конечно, понять сложно...
75. Александр Рытов (Арчибальд) 23.03.12 09:00
(73) fixin, тебе "бугога" блокирует существенную часть мозга. Когда научишься без него обходиться, будет легче.
Приведу пример. Предположим, произошел сбой в http://infostart.ru/public/84868/. Эта ситуация никогда не повторится. Я никогда не узнаю, что конкретно произошло. А мне нужно, чтобы в будущем в подобной жизненной ситуации сбоя не случилось. Я включаю мозги и строю версии - при каком раскладе может "выползти" такой сбой, какие дополнительные обстоятельства надо учесть.
Отладчик же - это инструмент, помогающий программисту обнаружить собственную глупость/невнимательность/некомпетентность. А про себя я и так все знаю.
76. Дандронтий Крузенштерн (dandrontiy) 23.03.12 11:11
// Разбирает строку на две части: до подстроки разделителя и после
//
// Параметры:
// Стр - разбираемая строка
// Разделитель - подстрока-разделитель
// Режим - 0 - разделитель в возвращаемые подстроки не включается
// 1 - разделитель включается в левую подстроку
// 2 - разделитель включается в правую подстроку
//
// Возвращаемое значение:
// Правая часть строки - до символа-разделителя
//
Функция ОтделитьРазделителем(Стр, Знач Разделитель, Режим=0)
ПраваяЧасть = "";
ПозРазделителя = Найти(Стр, Разделитель);
ДлинаРазделителя = СтрДлина(Разделитель);
Если ПозРазделителя > 0 Тогда
ПраваяЧасть = Сред(Стр, ПозРазделителя + ?(Режим = 2, 0, ДлинаРазделителя));
Стр = СокрЛП(Лев(Стр, ПозРазделителя - ?(Режим = 1, -ДлинаРазделителя + 1, 1)));
КонецЕсли;
Возврат(ПраваяЧасть);
КонецФункции // ОтделитьРазделителем()
77. Осипов Сергей (fixin) 23.03.12 11:18
(75) ты путаешь ситуации. Да, есть разбирательство по результатам проблемы, а есть тестирование до внедрения. А ты все в кучу валишь. Я рад что ты научился работать без отладчика, но ты - исключение, которое не рекомендуется превращать в правило. Имхо бессмысленные затраты сил там, где проще отладчиком.
(76) возьму как кандидата, хотя там есть похожие функции типа СтрокаМежду...
78. Александр Рытов (Арчибальд) 23.03.12 11:51
(77) Я отнюдь не призываю всех не пользоваться отладчиками. Собственно, я встрял в разговор исключительно из-за 35 коммента. И смысл моих высказываний в том, что отладчики - это некоторые гаджеты, без которых вполне можно обходиться. К примеру, я не пользуюсь айфоном. Не потому, что мне западло, а потому, что у меня нет в этом необходимости/потребности. Но я же никого не призываю выбросить свой айфон. И свой не выбрасываю - вдруг потребуется когда-нибудь.
79. Осипов Сергей (fixin) 23.03.12 12:17
(78) мне лично вы напоминаете людей, которые не пользуются в наше время сотовыми. Возможно они и находят в этом прелесть, но мне лично непонятна их мотивация. 99% разработчиков 1с пользуются отладчиками, поэтому ваши пассажи о ваших личных заморочках оставьте для ветки ЛАЙФ. Предлагаю больше не возвращаться к этой теме, все же это тематическая ветка.
80. Алексей (alexqc) 23.03.12 12:27
(74) Uncore, да, это действительно так. Это алгоритм Евклида (в его простейшем варианте) нахождения наибольшего общего делителя. Потестив на реальных числах и выдвинув гипотезу, это даже можно доказать. А вот глядя на код - это врядли определишь.

(72) Блин, узнаю подход теоретиков-математиков. Как чуть что немного не так - объявлять неверным и отправлять в топку ВСЕ. Ну не пришло мне в голову в формате форума писать контроль входных данных - каюсь и посыпаю голову пеплом. Впредь буду с вами внимательнее.

вместо >= написал >.

И чем мне в этом случае поможет отладчик?
Я там же и написал. На тестовом примере отследить выполнение кода, ставя бряки по контрольным точкам и отслеживая там значения. Так постепенно (видя где есть ошибка а где нет) сужаем область вплоть до ошибочного куска. Вот что значит человек отладчиком не пользовался.

вы говорили что можете понять что делает программа, просто глядя на код.
Я этого не говорил, и это реально не так.

Значит я просто не понял фразы
хочешь сказать отладкой чужого кода ни раз не занимался? ;)
51. Арчибальд
(50) Занимался. По тексту пытался понять мысль. Непонятные куски выбрасывал (снабжал заглушками). Но никогда не пытался просто запустить и посмотреть, что получится.

"По тексту пытался понять мысль" - я воспринял как "глядя на код понять что он делает". видать ошибся. посыпаю голову пеплом вторично.

Но вопрос, можно ли понять что делает приведенный в (70) код (даже с указанием области определения: натуральные числа, без 0 ) не запуская его, по прежнему остается открытым.
81. Александр Рытов (Арчибальд) 23.03.12 12:27
82. NoMAx (NoMax) 23.03.12 15:41
Еще одна функция транслитерации

http://forum.infostart.ru/forum24/topic27629/

Код фунции
Функция Transliterate(srtRusWord)

strRUS = "АБВГДЕЁЖЗИЙКЛМНОПРСТУФХЦЧШЩЪЫЬЭЮЯ";
strENG = "A///B///V///G///D///E///YO//ZH//Z///I///Y///K///L///M///N//­/O///P///R///S///T///U///F///KH//TS//CH//SH//SHCH'///Y//////­/E///YU//JA//";

strResult = "";

Для i = 1 по СтрДлина(srtRusWord) Цикл

s = Сред(srtRusWord, i,1);
s=ВРег(s);

k = Найти(strRUS, s);

Если k = 0 тогда

strResult = strResult + s;

Иначе
strResult = strResult + СтрЗаменить(Сред(strENG, (k - 1) * 4 + 1, 4), "/", "");

КонецЕсли

КонецЦикла ;

Возврат strResult;
КонецФункции
83. zhenia74 (zhenia74) 23.03.12 17:59
а где можно ознакомится с трудами этого гениями?
84. Саўка Збянтэжаны (Збянтэжаны Саўка) 27.03.12 13:39
(66) alexqc,
ну если Вас на цитаты потянуло,
то можно и я 5 копеек от Б.Кернигана и Р.Пайка "Практика программирования" вставлю
из Главы 5 "Отладка":

"...
Отладчик можно активизировать непосредственно тогда, когда становится
очевидным наличие проблемы. Некоторые отладчики берут власть в свои руки в тот
момент, когда при выполнении программы происходит что-то неожиданное. Обычно
бывает нетрудно выяснить, в каком месте прервалось выполнение программы,
проследить последовательность активных в тот момент функций {стековый фрейм)
и отобразить значения локальных и глобальных переменных. Этой информации
может оказаться вполне достаточно для обнаружения ошибки. Если же это не так, то
с помощью точек останова и пошагового выполнения можно выполнить аварийную
программу в отладочном режиме и найти место первого проявления проблемы.
В подходящей среде и в руках квалифицированного программиста хороший
отладчик может сделать отладку быстрой и эффективной, а то и вовсе тривиальной.
Если существуют такие мощные инструменты отладки, зачем кому-нибудь
понадобится обходиться без них? Чего ради, спросит читатель, мы написали целую главу,
посвященную отладке?
Для этого имеется ряд причин. Некоторые из них вполне объективны, а другие
основаны на нашем личном опыте. Некоторые языки, не относящиеся к числу
наиболее распространенных, не имеют отладчиков или предоставляют только
зачаточные возможности отладки. Отладчики привязаны к операционной системе,
поэтому при переходе из одной среды в другую можно не найти знакомого
отладчика. Некоторые программы плохо поддаются отладке с помощью отладчика;
среди таковых — многопоточные приложения, параллельные процессы,
операционные системы, распределенные сетевые системы. Все эти классы программ часто
приходится отлаживать на более низком уровне, и в этом случае вы остаетесь
наедине с программой без всякой помощи, кроме разве что дополнительных
операторов вывода, вооруженные только своим опытом и навыками анализа кода.

На наш собственный вкус, отладчики лучше использовать только для получения
стекового фрейма и значений одной-двух переменных. Одна из причин нашей
нелюбви к отладчикам состоит в том, что бывает очень легко заблудиться в
подробностях сложных структур данных и управляющих конструкций. Пошаговое
выполнение программы, по нашему мнению, менее продуктивно, чем тщательное ее
обдумывание и добавление операторов вывода или дополнительных проверок в
критических местах кода. Перебор всех операторов по очереди отнимает больше
времени, чем просмотр результатов хорошо продуманного отладочного вывода.
Можно гораздо быстрее решить, куда вставить дополнительную проверку или
контрольный вывод, чем "дошагать" до критического фрагмента кода, даже зная, где
он находится. Что еще более важно, контрольные операторы остаются в тексте
программы, а сеансы отладки неизбежно заканчиваются.
"Слепое зондирование" с помощью отладчика далеко не всегда бывает
продуктивным. Гораздо полезнее выяснить с помощью отладчика, в каком состоянии
находилась программа в момент аварийного завершения, а затем подумать, как это
состояние могло наступить. Пользоваться отладчиками нелегко, и их поведение
часто ставит в тупик. Начинающим программистам они вообще скорее помеха, чем
подспорье. Если вы задали отладчику неправильный вопрос, он, вероятнее всего,
что-то ответит, но эта информация может завести вас в дебри.

И все же отладчики могут принести огромную пользу, поэтому такой инструмент
следует держать наготове в своем арсенале. Часто в случае возникновения ошибки
именно он первым приходит на помощь. Но если у вас нет отладчика или вы
застряли на особенно сложной проблеме, прибегните к методам и подходам,
изложенным далее в этой главе, и убедитесь, что в любом случае отладку можно
выполнить быстро и эффективно.
...
"

Простите за такую длинную цитату, но это чтобы полнее донести мысль авторов,
Профессионалов, по сравнению с которыми мы тут почти все дети, я то уж точно сосунок.
85. Осипов Сергей (fixin) 27.03.12 14:49
(84) когда писалась эта статья, не было еще точек останова по условию и команды "продолжить выполнение до строки".
Иначе как объяснить, что автор говорит, что шагать по одному оператору дольше, чем добавить контрольное условие?
добавление контрольного условия - это тоже элемент отладки, так что не зачот.
86. Данид Дзерджински (dinfo32) 28.03.12 14:53
Функция СкопироватьМассив(М) Экспорт
//Назначение: Копирует массив. Почему-то в 1С можно скопировать список, таблицу значений, дерево значений, но не структуру
//ДатаСоздания: 20070620
//Автор: Fixin
//Тестирована: Нет
   Рез=Новый Массив();
   Для Каждого Эл ИЗ М Цикл
      Рез.Добавить(Эл);
   КонецЦикла;
   Возврат Рез;
КонецФункции

//заменяется на

Список = Новый СписокЗначений;
Список.ЗагрузитьЗначения(Массив);
МассивКопия = Список.ВыгрузитьЗначения();
...Показать Скрыть

не совсем поятно
87. Алекс Ю (AlexO) 28.03.12 15:44
(86) dinfo32,
а что вам не понятно? что Сергей попутал коллекции?
Копирует массив. Почему-то в 1С можно скопировать список, ...., но не структуру

а в коде - запись в массив из М (список значений?) заменен на заполнение массива из списка значений.
88. Осипов Сергей (fixin) 28.03.12 15:58
(87) согласен, через список быстрее работает, надо будет поправить. ;-)
89. Алекс Ю (AlexO) 29.03.12 14:31
(78) Арчибальд,
не знаю, как вы не пользуетесь отладчиком, но подавляющее большинство пользуется отладчиком не для написания нового кода, а для поиска ошибок в старом, которые возникают из-за неверных/не предусмотренных данных в 99% случаев ошибок. И неверные данные вы кроме как отладчиков не поймаете - это не правка кода, это отлов ошибок/ошибочных данных.
91. Александр Рытов (Арчибальд) 30.03.12 09:17
(89) AlexO, автор топика попросил прекратить это обсуждение, и я с ним согласился.
92. Осипов Сергей (fixin) 30.03.12 11:04
(91) вынесите в тему отдельную в Лайфе, потрещим.
93. denis leonov (curys) 05.04.12 12:21
Спасибо отличная весчь=)
94. Вадим Телегин (vadimt_82) 08.04.12 12:52
С какой версией платформы совместима конфигурация? Платформа 8.2.14.537. Конфигурация не загружается.
95. Осипов Сергей (fixin) 08.04.12 14:59
(94) конфигурации для 1с81 должны без проблем открываться в конфигураторе 82. Конфа написана на 81.
96. Dima Dr. (Scukosan) 09.04.12 14:58
в качестве ознакомления тема все таки интересна
принимать чью то сторону считаю глупым(каждому виднее со своей колокольни)
но обмен наработками однозначно приветствую )

сам активно пользуюсь отладчиком(частично в силу своей безграмотности) :)
но и разбор чужого кода проще с отладчиком
97. Дандронтий Крузенштерн (dandrontiy) 10.04.12 11:17
Функции для получения значений при подключении по ОЛЕ.

Добавляем в общий модуль, у модуля ставим галочки сервер и можно привилегированный.
потом обращаемся к функциям через точку от соединения.


Функция ВернутьУникальныйИдентификаторОбъекта(Объект) Экспорт
	Если Объект = Неопределено Тогда
		Возврат "<Неопределено>";
	КонецЕсли;
	
	ТипОбъекта = ТипЗнч(Объект);
	Если Перечисления.ТипВсеСсылки().СодержитТип(ТипОбъекта) Тогда
		ОбъектМетаданных = Объект.Метаданные();
		МенеджерПеречисления = Перечисления[ОбъектМетаданных.Имя];
		Если Объект <> МенеджерПеречисления.ПустаяСсылка() Тогда
			ИндексЗначения = МенеджерПеречисления.Индекс(Объект);
		Иначе
			Возврат "<ПустаяСсылка>";
		КонецЕсли;
		Возврат ОбъектМетаданных.ЗначенияПеречисления.Получить(ИндексЗначения).Имя;
	КонецЕсли;
	
	Возврат Строка(Объект.УникальныйИдентификатор());
КонецФункции

Функция ВернутьТипОбъекта(Объект) Экспорт
	Возврат СокрЛП(ТипЗнч(Объект));
КонецФункции

Функция ВернутьТипСубконто(Объект) Экспорт
		Имя = Объект.Метаданные().Имя;			
		Если Метаданные.Перечисления.Содержит(Объект.Метаданные()) Тогда
			Тип = "Перечисление";
		ИначеЕсли Метаданные.Справочники.Содержит(Объект.Метаданные()) Тогда
			Тип = "Справочники";
		ИначеЕсли Метаданные.Документы.Содержит(Объект.Метаданные()) Тогда
			Тип = "Документы";
		КонецЕсли;
		ТипЗнч = ""+Тип+"."+Имя;
		Возврат ТипЗнч;
КонецФункции

Функция ВернутьДатуДокумента(Объект) Экспорт
	Если Объект = Неопределено Тогда
		Возврат Неопределено
	ИначеЕсли Метаданные.Документы.Содержит(Объект.Метаданные()) Тогда
		ОбъектМетаданных = Объект.Метаданные();
		МенеджерДокументы = Документы[ОбъектМетаданных.Имя];
		
		Если Объект <> МенеджерДокументы.ПустаяСсылка() Тогда
			Возврат Объект.Дата;
		Иначе
			Возврат Неопределено;
		КонецЕсли;
	Иначе
		Возврат Неопределено;
	КонецЕсли;
КонецФункции

Функция ВернутьНомерДокумента(Объект) Экспорт
	Если Объект = Неопределено Тогда
		Возврат Неопределено
	ИначеЕсли Метаданные.Документы.Содержит(Объект.Метаданные()) Тогда
		ОбъектМетаданных = Объект.Метаданные();
		МенеджерДокументы = Документы[ОбъектМетаданных.Имя];
		
		Если Объект <> МенеджерДокументы.ПустаяСсылка() Тогда
			Возврат Объект.Номер;
		Иначе
			Возврат Неопределено;
		КонецЕсли;
	Иначе
		Возврат Неопределено;
	КонецЕсли;
КонецФункции

Функция ВернутьКодСправочника(Объект) Экспорт
	Если Объект = Неопределено Тогда
		Возврат Неопределено
	ИначеЕсли Метаданные.Справочники.Содержит(Объект.Метаданные()) Тогда
		ОбъектМетаданных = Объект.Метаданные();
		МенеджерСправочники = Справочники[ОбъектМетаданных.Имя];
		
		Если Объект <> МенеджерСправочники.ПустаяСсылка() Тогда
			Возврат Объект.Код;
		Иначе
			Возврат Неопределено;
		КонецЕсли;
	Иначе
		Возврат Неопределено;
	КонецЕсли;
КонецФункции

Функция ВернутьНаименованиеСправочника(Объект) Экспорт
	Если Объект = Неопределено Тогда
		Возврат Неопределено
	ИначеЕсли Метаданные.Справочники.Содержит(Объект.Метаданные()) Тогда
		ОбъектМетаданных = Объект.Метаданные();
		МенеджерСправочники = Справочники[ОбъектМетаданных.Имя];
		
		Если Объект <> МенеджерСправочники.ПустаяСсылка() Тогда
			Возврат Объект.Наименование;
		Иначе
			Возврат Неопределено;
		КонецЕсли;
	Иначе
		Возврат Неопределено;
	КонецЕсли;
КонецФункции
	
Функция ВернутьПолныйКодСправочника(Объект) Экспорт
	Если Объект = Неопределено Тогда
		Возврат Неопределено
	ИначеЕсли Метаданные.Справочники.Содержит(Объект.Метаданные()) Тогда
		ОбъектМетаданных = Объект.Метаданные();
		МенеджерСправочники = Справочники[ОбъектМетаданных.Имя];
		
		Если Объект <> МенеджерСправочники.ПустаяСсылка() Тогда
			Возврат Объект.ПолныйКод();
		Иначе
			Возврат Неопределено;
		КонецЕсли;
	Иначе
		Возврат Неопределено;
	КонецЕсли;
КонецФункции

Функция ВернутьКодПеречисления(Объект) Экспорт
	Если Объект = Неопределено Тогда
		Возврат Неопределено
	ИначеЕсли Метаданные.Перечисления.Содержит(Объект.Метаданные()) Тогда
		ОбъектМетаданных = Объект.Метаданные();
		МенеджерПеречисления = Перечисления[ОбъектМетаданных.Имя];
		
		Если Объект <> МенеджерПеречисления.ПустаяСсылка() Тогда
			ИндексЗначения = МенеджерПеречисления.Индекс(Объект);
			Возврат ОбъектМетаданных.ЗначенияПеречисления.Получить(ИндексЗначения).Имя;
		Иначе
			Возврат Неопределено;
		КонецЕсли;
	Иначе
		Возврат Неопределено;
	КонецЕсли;
КонецФункции

Функция ВернутьРеквизитСправочника(Объект,ИмяРеквизита) Экспорт
	Если Объект = Неопределено Тогда
		Возврат Неопределено
	ИначеЕсли Метаданные.Справочники.Содержит(Объект.Метаданные()) Тогда
		ОбъектМетаданных = Объект.Метаданные();
		МенеджерСправочники = Справочники[ОбъектМетаданных.Имя];
		
		Если Объект <> МенеджерСправочники.ПустаяСсылка() Тогда
			Попытка
				Реквизит = Объект[ИмяРеквизита];
			Исключение
				Реквизит =  Неопределено;
			КонецПопытки;
			Возврат Реквизит;
		Иначе
			Возврат Неопределено;
		КонецЕсли;
	Иначе
		Возврат Неопределено;
	КонецЕсли;
	
КонецФункции

Функция ВернутьКодСчета (Объект) Экспорт
	Возврат Объект.Код;
КонецФункции
...Показать Скрыть
98. Осипов Сергей (fixin) 10.04.12 11:33
(97) а какой смысл в этих функциях? если и так можно получить это всё? Хотя хз.
99. Дандронтий Крузенштерн (dandrontiy) 10.04.12 14:16
(98) fixin,
Когда получаешь данные запросом через ком соединение, то при обращении к ресурсам, которые являются документами, справочниками, перечислениями - получим значение COMobject, и получить от него через точку наименование, код, ну или реквизит - не получится. попробуй сам. поэтому для получения этих параметров и надо сделать функции на стороне той базы, куда по OLE подключаемся, туда передаем полученный COM объект и там уже получаем то что надо и возвращаем.
Для получения цифры, строки и даты - такое не надо.

Кстати еще странный глюк - когда получаем цифру по внешнему соединению, бывает такая ситуация:
имеем в базе реквизит например 10.2, ну десять знаков в целой части, два после запятой. и допустим там записано значение 99.00, так вот ИНОГДА, и непонятно когда и от чего можно получить не 99.00, а 98.9999999999
Вообще непонятно от чего такое происходит. Может кто сталкивался и знает от чего такое шаманство происходит ?
100. Осипов Сергей (fixin) 10.04.12 14:36
(99) почему не получится? Получится. ;-) В отладчике можно посмотреть, там эти поля по латински называются.
Хотя кошернее действительно сделать функции-обертки, согласен.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа