gifts2017

SpRecord из 1С

Опубликовал Виталий Гуляев (vital1c) в раздел Обмен - Обмен с другими системами

Пример использования системы SpRecord в 1С

Возникла необходимость совершать звонки из 1С через систему SpRecord.

SpRecord имеет возможность подключения через COM-интерфейс, что задокументировано в SDK с примерами на С++ и Delphi.

Методом проб и ошибок, нашел имя класса для использования в 1С.

Набросал простую обработку для проверки возможности совершения звонков.

 

перем SPRecordChannel;

Процедура ConnectНажатие(Элемент)
   SPRecordChannel = Новый COMОбъект("spsdksvr.SpRecordChannelClient",ИмяСервера);
   SPRecordChannel.Connect(ИмяКанала, 2, "", "");
КонецПроцедуры

Процедура ПриОткрытии()
   ИмяКанала = "T4003426 - 3";
КонецПроцедуры

Процедура HandTakeНажатие(Элемент)
   SPRecordChannel.HandsetTake();
КонецПроцедуры

Процедура HandPutНажатие(Элемент)
   перем ПутьКФайлу;
   ПутьКФайлу ="";  // что бы переменная стала строкой, иначе функция не вернет значение правильно
   SPRecordChannel.HandsetPut();
   SPRecordChannel.GetFileName (ПутьКФайлу);
   Сообщить ("Путь к файлу с разговором на сервере: " + ПутьКФайлу);
КонецПроцедуры

Процедура DialНажатие(Элемент)
   SPRecordChannel.DialNumber(НомерТелефона, 2);
КонецПроцедуры 

Пример лишь поднимает линию и набирает в неё указанный номер. Воспроизведение звука в линию и с линии в наушники - это следующий этап. Либо можно поднять трубку и выйти на нужную внешнюю линию, к которой в данный момент подключен SpRecord.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
ЗвонкиSPRecord.epf
.epf 7,09Kb
23.03.12
15
.epf 7,09Kb 15 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Михаил ja-maik-a (ja-maik-a) 03.05.12 16:08
А получилось ли настроить обработку сообщений от системы записи?
2. Виталий Гуляев (vital1c) 20.08.12 09:02
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа