Анализ подписок на события

Опубликовал Владислав Данилин (Legavaz) в раздел Программирование - Практика программирования

Отчет анализирует и выводит подписки на события.
Работает на компоновке данных. Управляемая форма!
Универсальный для 8.2

Отчет анализирует и выводит подписки на события в любой конфигурации 8.2.

Скачать файлы

Наименование Файл Версия Размер
Внешний отчет 82(упр.)
.erf 9,87Kb
05.04.12
118
.erf 9,87Kb 118 Скачать
Внешний отчет 81(обычная)
.erf 9,90Kb
05.04.12
41
.erf 9,90Kb 41 Скачать

См. также

Комментарии
1. Сергей Ожерельев (Поручик) 3517 03.04.12 18:57 Сейчас в теме
(0) Годно. Увидел общую картину с подписками.
Если хотите, дам совсем универсальный вариант. Этот же отчёт, только добавлена дополнительная обычная форма.
2. Владислав Данилин (Legavaz) 650 04.04.12 09:00 Сейчас в теме
3. Дмитрий Звягинцев (Cerberdm) 19 04.04.12 09:38 Сейчас в теме
(2) Legavaz, можете, то что Поручик доработал сюда выложить? Заранее благодарен.
4. Александр Орефков (orefkov) 1450 04.04.12 15:35 Сейчас в теме
(0)
Взял на себя смелость портировать Вашу разработку под Снегопат, правда на обычных формах.
Зато теперь можно запускать прямо в Конфигураторе.
Посмотреть можно здесь
(Для просмотра скриншота там надо залогиниться анонимусом)
pumbaE; tormozit; artbear; +3 Ответить 3
5. Валерий Емельянов (ValeraEm) 131 04.04.12 16:30 Сейчас в теме
хорошая идея ... наглядная картина подписок
6. Владислав Данилин (Legavaz) 650 04.04.12 16:39 Сейчас в теме
(4) очень рад, что инструмент может помочь.
7. Модератор раздела Артур Аюханов (artbear) 04.04.12 17:02 Сейчас в теме
(4) Да, в Конфигураторе выглядит здорово и очень удобно.
8. sound sound (sound) 520 05.04.12 12:11 Сейчас в теме
9. denis leonov (curys) 05.04.12 12:41 Сейчас в теме
большое спасибо автору, отличная весчь=)
10. Сергей Ожерельев (Поручик) 3517 05.04.12 12:45 Сейчас в теме
(4) (6) Для совсем уж большей универсальности дополните анализ подписок для задач, пвх, планов видов расчета. Иначе картина получается неполная.

	Для каждого ТекЭлемента из Метаданные.ПланыВидовХарактеристик Цикл
		НС	=	ТаблицаОбъектов.Добавить();
		НС.Представление	=	ТекЭлемента.синоним;
		НС.Тип				=	Тип("ПланВидовХарактеристикОбъект."+ТекЭлемента.Имя);		
		НС.Метаданные		=	"План видов характеристик";
	КонецЦикла;
	
	Для каждого ТекЭлемента из Метаданные.ПланыВидовРасчета Цикл
		НС	=	ТаблицаОбъектов.Добавить();
		НС.Представление	=	ТекЭлемента.синоним;
		НС.Тип				=	Тип("ПланВидовРасчетаОбъект."+ТекЭлемента.Имя);		
		НС.Метаданные		=	"План видов расчета";
	КонецЦикла;
	
	Для каждого ТекЭлемента из Метаданные.Задачи Цикл
		НС	=	ТаблицаОбъектов.Добавить();
		НС.Представление	=	ТекЭлемента.синоним;
		НС.Тип				=	Тип("ЗадачаОбъект."+ТекЭлемента.Имя);		
		НС.Метаданные		=	"Задача";
	КонецЦикла;
...Показать Скрыть
11. Сергей Ожерельев (Поручик) 3517 05.04.12 13:06 Сейчас в теме
(6) и выбор метаданных из списка.
Могу дать готовое.
Прикрепленные файлы:
12. Александр Орефков (orefkov) 1450 05.04.12 13:24 Сейчас в теме
(10)
В снегопате полностью универсально, обрабатывает все виды объектов.
Там просто есть возможность имея тип, сразу получить объект метаданных, который породил этот тип.
13. Владислав Данилин (Legavaz) 650 05.04.12 14:12 Сейчас в теме
(10) обновил код. спасибо за замечание.
14. Сергей Ожерельев (Поручик) 3517 05.04.12 14:23 Сейчас в теме
(13) Лучше вариант для обычного приложения совместить с управляемым, как у меня.
15. Игорь Исхаков (Ish_2) 961 05.04.12 16:06 Сейчас в теме
(14) Вы тут все программисты.. А сам я не очень.
Вышли мне твою версию ( чтоб и для обычного приложения) ishakk@mail.ru
16. Игорь Исхаков (Ish_2) 961 05.04.12 16:15 Сейчас в теме
(4) Зашел я к тебе анонимусом. И ничего не понял. Куда тыкать , чтоб скриншот посмотреть.
Ты бы по-простому выложил сюда да и всё.
17. Сергей Рудаков (fishca) 1045 05.04.12 16:22 Сейчас в теме
(16) вот
Прикрепленные файлы:
18. Игорь Исхаков (Ish_2) 961 05.04.12 17:36 Сейчас в теме
19. Dimon (klel) 05.04.12 23:15 Сейчас в теме
Прикольная штука аж глаз радуется :)
20. Сергей Ожерельев (Поручик) 3517 06.04.12 09:11 Сейчас в теме
(15) Не могу, автор будет против.
21. Владислав Данилин (Legavaz) 650 06.04.12 13:01 Сейчас в теме
(20) я не против, если есть варианты более удобные или лучше, критика только приветствуется.
в файлах имеется: для 8.1- обычные формы и 8.2 управляемые.
22. Игорь Исхаков (Ish_2) 961 06.04.12 13:22 Сейчас в теме
(20) Ну-у-у...
Впрочем, имеешь право.
23. Игорь Исхаков (Ish_2) 961 06.04.12 13:23 Сейчас в теме