gifts2017

Кассовая книга по подразделениям (нескольким кассам)

Опубликовал Евген Каравашкин (Lokiy) в раздел Отчеты - Бухгалтерские

Кассовая книга, формирующаяся отдельно по подразделениям, если на счете 50.01 включен учет по подразделениям.

Иногда организация ведет учет по нескольким кассам и необходимо видеть остатки и формировать кассовую книгу по каждой кассе.

В типовой бухгалтерии этого сделать невозможно, но Можно обойтись минимальными изменениями конфигурации и видеть раздельный учет на счете 50.01 и кассам.

 

Для этого необходимо:

  1. На счете 50.01 включить учет по Подразделениям.
  2. В Документах ПриходныйКассовыйОрдер, РасходныйКассовыйОрдер, ОтчетОРозничныхПродажах создать реквизит ПодразделениеОрганизации и вывести его на форму документов (этого будет достаточно, в модулях документа  ничего прописывать не потребуется, достаточно просто наличия данного реквизита в документах - чтобы он стал проставляться в проводках).
  3. Скачать прилагающийся внешний отчет - Кассовая книга по подразделениям.

Типовая кассовая книга также будет работать - но будет показывать сводно по всем подразделениям.

Скачать файлы

Наименование Файл Версия Размер
КассоваяКнигаПоПодразделениям.erf 368
.erf 29,54Kb
11.04.12
368
.erf 29,54Kb Скачать

См. также

Вознаграждение за ответ
Сумма: 0 $m
Добавили:
Ирина Хузина (irlyahov) (1.00 $m), Lisa1C (Lisa1C) (0.05 $m)
Подписаться Добавить вознаграждение

Комментарии

1. Валя Гужбина (GVALA) 27.04.12 10:22
Спасибо за обработку, полезная штука, только вот подскажите как включить на счете 50.01 учет по Подразделениям, у меня что то не получилось, а мне как раз надо именно эта функция , т.к. у меня 3 подразделения кассы, и мне и необходимо видеть остатки и формировать кассовую книгу по каждой кассе и в целом по предприятию. Заранее спасибо!!!
2. Евген Каравашкин (Lokiy) 27.04.12 11:13
В конфигураторе - Планы счетов- Хозрасчетный, правой кнопкой - предопределенные данные, находите 50.01 дважды щелкаете - включаете галочку Учет по подразделениям.
Чтобы подразделения можно было указывать в ПКО,РКО- надо добавлять реквизит как указано в описании к обработке.
3. Валя Гужбина (GVALA) 27.04.12 16:46
Спасибо, сейчас попробую.
4. paren norm (gghf) 29.06.12 13:08
у меня почему то проставляется в проводках подразделение....
5. paren norm (gghf) 29.06.12 13:13
и в документах нет реквизита СчетКасса, который указан в запросе
6. paren norm (gghf) 29.06.12 13:19
не встают проводки , а именно субконто не заполняется хотя на форме заполнено
7. Андрей К (andikad) 29.06.12 16:08
Реквизит подразделение нужно прописать в конфигураторе у документа ПКО,РКО и вынести на форму .Обработка рабочая - спасибо.
8. paren norm (gghf) 03.07.12 08:02
извините может я чтото не понимаю но в проводки не встают подразделения...
добавил реквизит в док, добавил на форму заполнил, нажал провести и ничего..
9. Евген Каравашкин (Lokiy) 05.07.12 09:59
для работы подразделения организации
во-первых в ПКО,РКО реквизит должен сторого называться: ПодразделениеОрганизации
во-вторых должна быть ТиповаяБухгалтерия редакции 2,
в-третьих на счете 50.01 нужно не добавлять субконто подразделение, а включить учет по подразделениям на счете, в редакции 2.0 Поразделение не является субконтом счета - это признак счета - в конфигураторе в предопределенных счетах - галочка включается - учет по подразделениям.
10. Андрей Стручалин (dikd) 31.07.12 15:40
А как быть с нумерацией? Ведь ПКО и РКО должны нумероваться друг за другом, в итоге надо еще дописывать префиксацию ПКО, РКО в разрезе подразделений, так ведь?
11. Евген Каравашкин (Lokiy) 01.08.12 09:13
Нумероваться ПКО и РКО должны друг за другом в организации, а не в подразделениях.
если будет проверяться кассовая книга, то организации ведь, а не отдельного подразделения (или операционной кассы).
12. Анна Семенова (Simona90) 28.08.12 15:39
И все же нумерация должна быть разделена по подразделениям.
13. olga izr (olgaizr) 25.09.12 14:07
Все сделала, как написано. Обработка работает. спасибо, но теперь РКО не создается новый ---{ОбщийМодуль.УправлениеДенежнымиСредствами.Модуль(441)}: Поле объекта не обнаружено (ПодразделениеОрганизации)
Если ОбщегоНазначения.ЕстьРеквизитДокумента("СчетОрганизации", МетаданныеДокумента)
14. Евгений (gevicer) 09.11.12 11:35
(13) olgaizr,

В общем модуле УправлениеДенежнымиСредствами в процедуре "ЗаполнитьРеквизитыРасчетногоДокумента"

Вставьте кусочке с пометкой //GEV)) расположив его

чуть выше того места где происходит ошибка..


// Заполняет реквизиты расчетного документа значениями по умолчанию
//
Процедура ЗаполнитьРеквизитыРасчетногоДокумента(ДокументОбъект, ТекПользователь
, ВалютаРегламентированногоУчета = Неопределено, ПараметрОбъектКопирования = Неопределено) Экспорт

..... далее текст......

//GEV

Если ЕстьНезаполненныйРеквизитДокумента("ПодразделениеОрганизации", ДокументОбъект, МетаданныеДокумента) Тогда

Если ДокументОбъект.Метаданные().Имя="РасходныйКассовыйОрдер" Тогда

ДокументОбъект.ПодразделениеОрганизации = Справочники.ПодразделенияОрганизаций.НайтиПоКоду("000000001");

КонецЕсли;
КонецЕсли;
//GEV


Если ЕстьНезаполненныйРеквизитДокумента("ПодразделениеОрганизации", ДокументОбъект, МетаданныеДокумента) Тогда

Если ОбщегоНазначения.ЕстьРеквизитДокумента("СчетОрганизации", МетаданныеДокумента)
И ТипЗнч(ДокументОбъект.СчетОрганизации) = Тип("СправочникСсылка.БанковскиеСчета")
И ЗначениеЗаполнено(ДокументОбъект.СчетОрганизации.ПодразделениеОрганизации)
Тогда
ДокументОбъект.ПодразделениеОрганизации = ДокументОбъект.СчетОрганизации.ПодразделениеОрганизации;
Иначе
ОсновноеПодразделение = УправлениеПользователями.ПолучитьЗначениеПоУмолчанию(глЗначениеПеременной("глТекущийПользователь"), "ОсновноеПодразделениеОрганизации");
Если ЗначениеЗаполнено(ОсновноеПодразделение)
И ОсновноеПодразделение.Владелец = ДокументОбъект.Организация
Тогда
ДокументОбъект.ПодразделениеОрганизации = ОсновноеПодразделение;
КонецЕсли;
КонецЕсли;

КонецЕсли;
15. Polina Puchkova (krovohlebka) 16.12.12 23:11
Счету 50.01 выставлен учет по подразделениям в конфигураторе. Работаю с документом Приходный кассовый ордер. В бухгалтерии 3.0 уже есть реквизит ПодразделениеОрганизации. Как быть в этом случае?
При чем этот реквизит не отражается при отображении формы, ни при создании нового документа, ни при перемене каких-либо значений реквизитов. По точкам останова доступность показывает Истина.
При выходе из Процедуры ПриСозданииНаСервере(Отказ, СтандартнаяОбработка) значение ЭтаФорма.Элементы.ПодразделениеОрганизации.Доступность = Истина

кто-нибудь с таким сталкивался? подскажите в какую сторону копать. опыт работы с управляемыми формами никакой, разбираюсь по ходу
16. Макс Зеленский (mzelensky) 15.01.13 09:52
17. Елена Елена (сон) 24.01.13 12:23
Вопрос автору: Выполнили указанные Вами настройки. В первый день работы кассовые книги по обоим подразделениям сформировались правильно.
Во все последующие дни начальный и конечный ОСТАТОК в кассе по обоим подразделениям НЕ правильный, а обороты правильные.
Итоги пересчитали-обновили. Что может быть не так?
БП 8.2, платф 16.362
18. ilnet (ilnet) 20.03.13 07:53
Спасиб! Все работает! а исправления в модуль УправлениеДенежнымиСредствами вынеси пожалуйста в описание обработки из комментария.
19. ECartman 29.03.13 14:46
Раз уж пошли рекомендации по доработке данного отчета внесу свои 5 копеек

1)Чтобы не ковырять как из поста 14 можно в справочнике БанковскиеСчета добавить реквизит ПодразделениеОрганизации (можно даже в форму не добавлять)

2) Для корректности отчета, чтобы он формировался не только по отдельно взятому подразделению, но и сводно по всем подразделениям, необходимо:
а) в модуле формы в процедуре "ДействияФормыСформировать(Кнопка)" закомментировать (удалить) строки

Если не ЗначениеЗаполнено(ПодразделениеОрганизации) тогда
Предупреждение("Для данного отчета необходимо заплолнить реквизит Подраздление");
возврат;
КонецЕсли;


б) в модуле отчета в процедуре "СформироватьОтчет()" изменить условия в текстах запросов. Везде, где встречаются
"И Подразделение = &Подразделение" заменить на "И Подразделение В ИЕРАРХИИ (&Подразделение)". Тогда, если выбрана ветка подразделений (либо подразделение не выбрано вообще), отчет будет формироваться по всем подразделениям входящих в выбранную ветку (либо по всем, если подразделение не указано).

А так, вообще, штука полезная - бухгалтер доволен. Хотя не пойму, почему в типовой этого не сделали 1с-ники.
korpas; Lisa1C; Теософ; maXon777; +4 Ответить 1
20. Ламия 23.10.13 10:23
тоже недоумеваю, почему сия возможность не реализована в типовой конфигурации
21. Lisa1C (Lisa1C) 10.01.14 11:03
Ещё сюда добавила бы, то, что нужно учитывать номера листов кассовой книги. По каждому подразделению номер листа кассовой книги будет свой. Данный отчет хорош, но формирует движения по существующему регистру НомераЛистовКассовойКниги - а в нем нет реквизита ПодразделениеОрганизации. Потому можно добавить ещё один регистр сведений НомераЛистовКассовойКниги_Свой и переписать приведенный выше отчетик так, чтобы двигал он ваш регистр, а типовой не трогал. Причем надо обратить внимание, на пересчет листов кассовой книги с начала года, чтобы пересчет касался только подразделения, а не организации в целом.
22. Павел Мокосеев (pvl_mksv) 14.01.14 23:48
(19) ECartman, (20) Ламия,
Бухгалтерия предприятия КОРП, ИМХО
23. Никита Вожак (Вожак) 04.02.14 17:00
для КА 1.44 не подходит да?(
24. Ирина Хузина (irlyahov) 13.02.14 12:03
Хороший отчет. Очень помог нам. Покупать бухгалтерию КОРП дорого для нас на данный момент. Мы добавили на счете 50.01 субконто по подразделениям, немного подправила под себя и все ОК.
Прикрепленные файлы:
25. Татьяна (Душечка) 01.03.14 21:06
26. Павел Мокосеев (pvl_mksv) 23.04.14 17:55
Автору - респект и спасибо! Воспользовался, доработал то, что не понял сходу ))) Так-то все - айс, но при формировании кассовой книги есть проблема с нумерацией документов, так как из коробки нумерация в разрезе подразделений в БП 2.0. не предусмотрена(и вообще, предусмотрена ли хоть в одной типовой). Кто и как решал проблему?
27. Павел Мокосеев (pvl_mksv) 23.04.14 19:23
(21) Lisa1C,
в отдельном РС для номеров в разрезе подразделений, по аналогии с типовым
28. Олег (Sol) 25.04.14 11:59
(26)
так как из коробки нумерация в разрезе подразделений в БП 2.0. не предусмотрена(и вообще, предусмотрена ли хоть в одной типовой). Кто и как решал проблему?


даже в этой ветке уже раз 10 написали, что всё уже реализовано в БП КОРП.
29. Павел Мокосеев (pvl_mksv) 28.04.14 17:24
(28)извините, не уточнил, у клиента Общепит, который базируется на 2.0, Общепита КОРП к сожалению нет, а если и есть, то его продать тяжко будет.
Решено добавлением реквизита ПодразделениеОрганизации в кассовые документы, а так же введением Префикса, хранимого в реквизите справочника Подразделения, в номера. Вопрос в (1)сформулировал не совсем корректно. Проблема была с перенумерацие уже введенных ПКО и РКО. Воспользовался наработкой уважаемого ilmar521, чутка допилил.
30. Alex SM (Alex85SPB) 08.09.14 16:04
Здравствуйте!!!
Подскажите, пожалуйста, как вывести реквизит ПодразделениеОрганизации на форму документов. Пользуюсь версией 1С 8.2 Предприятие.
31. Павел Мокосеев (pvl_mksv) 22.09.14 23:33
(30) Alex85SPB,
В конфигураторе открыть форму документа, воспользоваться инструментом "Размещение данных" на панели инструментов(листок бумаги с зеленым крестом), там будет дерево всех реквизитов объекта, дальше разберетесь
32. Макс Бон (ozaka) 14.05.15 09:13
Здравствуйте. Я скачал обработку но при открытии вылетает ошибка :
{ОбщийМодуль.РаботаСОбщимиПеременнымиПовтИсп.Модуль(84)}: Поле объекта не обнаружено (ОСНОВНАЯОРГАНИЗАЦИЯ)
Возврат Константы[ИмяПараметраВР].Получить();
Подскажите пожалуйста в чем может быть причина? За раннее очень благодарен.

УПП 1.3
33. Павел Мокосеев (pvl_mksv) 14.06.15 23:09
(32) ozaka,
Ну, скорее всего, в УПП нет такой константы и надо в соотвествующую функцию передавать параметр с другим именем, там где лежат эти сведения.
34. ABVera (ABVera) 02.12.15 15:46
Ошибка выполнения отчета
по причине:
Не установлена схема компоновки данных
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа