gifts2017

Индивидуальная установка даты запрета редактирования документов в торговле 1С 7.7

Опубликовал Владимир Петров (agent007_1) в раздел Администрирование - Защита, права, пароли

Установка даты запрета редактирования документов индивидуально для каждого пользователя,а также предоставление в индивидуальном порядке разрешения изменения конкретных документов в определенные периоды или в конкретные дни.Срок действия установок устанавливается вами. Вы можете спокойно настроить и уехать в отпуск.

Обработка используется для установки даты запрета редактирования документов.
В списке рабочих дней отмечают только рабочие дни.
Выбираем количество разрешаемых дней для редактирования от текущей даты.
Выбираем режим обработки только для 1) рабочих дней или 2) для всех дней в недели, во втором случае в списке можно не отмечать рабочие дни.
Рассмотрим на примерах : выставили два дня разрешаемых, при наступлении Понедельника в первом случае программа пропустит нерабочие дни и отсчитает два рабочих дня, и позволит редактировать документы начиная с четверга прошлой недели.
Во втором случае программа отсчитает два дня назад и преложит изменять документы начиная с субботы прошлой недели.
При наступлении Вторника, в первом случае программа позволит редактировать с пятницы, во стором случае с воскресения и т.д.

При установке флажка "зафиксировать дату запрета включительно до указанной даты" программа устанавливает дату запрета до тех пор, пока не наступит следующая дата после указанной.

При установке флажка "Использовать плановую настройку" открывается доступ к кнопке "Планирование", при открытии которой появляется иная настройка.
Необходимо выбрать дату установки, при наступлении которой дата запрета редактирования изменяется на дату указанной в дате запрета (коричневый цвет) для тех пользователей, которые отмечены в списке Пользователей. Данная установка будет работать до даты, выбранной в Сроке действия.
Внимание. Плановая настройка стоит на первом месте,затем индивидуальная настройка и наконец общая для всех.
Кнопка "Удалить" позволяет удалить историю настройки на дату установки.
Кнопка "Очистить" позволяет удалить всю историю плановой настройки за все дни.
Кнопка "Печать" позволяет просмотреть и напечатать историю плановой настройки.салатовым цветом выделена действующая настройка.
Внимание.История автоматически очищяется от использованный записей.
При изменении даты установки при условии что не отмечены пользователи ,восстанвливаются данные,если ои были записаны на выбранную дату установки.
При установке флажка "Использовать индивидульную настройку" открывается доступ к кнопке Индивидуально,где в списке справочника пользователей можно для каждого
настроить свою установку даты запрета редактирования документов.
В колонке Участие с помощью кнопки "Выбор" включаете или выключаете режим индивидуальной настройки.По умолчанию пустое значение поля означает включение режима.
В колонке "Кол-во дней" указываете числом количество разрешаемых дней от текущей даты. По Умолчанию ноль дней
Внимание. отсчет изменяется от текущей даты,а не от даты установленной в дате запрета редактирования.
В колонке ""Дата запрета" указывается конкретная дата для пользователя".
Внимание,если будет заполнена колонки и колво дней и дата запрета,то программа выбирает значение "Дату запрета"..Поэтому если вы решили использовать
отсчет в колво дней Необходимо очистить поле с помощью кнопки "Выбор"..
Снятие флажка "Использовать индивидуальную настройку" отменяет индивидульные действия установки.Но при этом оставляет нетроннутым настройки каждого.
Будьте внимательны,если вы хотите чтобы хоть один использовал индивидуальные настройки,необходимо установить флажок "Использовать индивидуальную настройку" ,а в колонке
участие выключить всех кроме выбранных.
При установке флажка "Не предлагать настройку в следующий раз" не позволяет обработки появляться при изменении даты запрета редактирования.
При установке флажка "Выключить программу автонастройки" означает выключении всей программы настройки
В таком случае ,дату запрета редактирования меняет администратор..

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Установочный
.ZIP 161,89Kb
17.01.13
42
.ZIP 161,89Kb 42 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Иваныч Иванов (Иваныч) 18.01.13 22:00
Я себе делал как запрет редактирования документов на ТА-1день. И снять границу запрета редактирования может только пользователь с правами Администратора. А так за идею, правда пока не смотрел обработку, заочно ++
2. Александр Венгер (venger) 19.01.13 01:03
(0) А как реализовано? ВК и перехват или правка функции для доков в глобальнике?
3. Владимир Петров (agent007_1) 19.01.13 07:08
Функция глМожноЗаписатьДокумент(Конт) Экспорт
ЕстьРазрешение = 1;
if СокрЛП(Конт.Автор)<>глПользователь then
Конт.Автор = глПользователь;
endif;
Если Конт.ДатаДок<глДатаЗапретаРедактирования Тогда
ЕстьРазрешение = 0;
КонецЕсли;
Если ЕстьРазрешение = 0 Тогда
Если (Константа.ПлановаяНастройка = Да) и (глПользователь.ПланЗапрет = 1 ) Тогда
ИФ = глКаталогФорм+"zapret.ert";
Если ФС.СуществуетФайл(ИФ)=1 Тогда
Парам = СоздатьОбъект("СписокЗначений");
Парам.ДобавитьЗначение(Конт.ДатаДок,"ДатаДок");
Парам.ДобавитьЗначение(Конт.Вид(),"Вид");
ОткрытьФормуМодально("Отчет",Парам,ИФ);
Если ТипЗначенияСтр(Парам)="Число" Тогда
ЕстьРазрешение = Парам;
КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецЕсли;
Если ЕстьРазрешение = 0 Тогда
Предупреждение("Нельзя записывать документы с датой, более ранней чем дата запрета редактирования документов!", 60);
Возврат 0;
КонецЕсли;
Возврат 1;
КонецФункции // глМожноЗаписатьДокумент()
4. Виталий П (VSKIF) 09.06.13 15:39
MODULU.ERT(156)}: Поле агрегатного объекта не обнаружено (ЗапускПоследовательности)
5. Виталий П (VSKIF) 09.06.13 16:11
AUDI.ERT(1046)}: Поле агрегатного объекта не обнаружено (КПП)
6. Владимир (V_I_PRO) 10.06.13 04:52
(1) Иваныч, Я запрещал всем. Дату изменял обработкой.
7. Владимир Петров (agent007_1) 10.06.13 06:34
P(6) V_I_PRO, Значит что то пропустили.Напишите мне mylive@mail.ru
(4) VSKIF, Необходимо было прочитать условия регистрации модулей,они у вас не зарегистрированы.Если есть возможность,я могу зайти к вам через удаленный доступ на ПК и помочь. Зайдите на мой сайт.Там есть иструкции
8. Юля Иванова (ЮлияМ) 04.07.13 10:59
Интересная идея. У нас на предприятие меняется дата запрета редактирования и никак не можем понять каким образом. Стоят у всех ограничения на запрет редактирования и только может менять главный бухгалтер.
9. Семерка Семерка (raietchie) 29.03.15 12:41
добрый день
Я в первые на этот сайт
Подскажите как можно скачать данную обработку ?
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа